Page tree
Skip to end of metadata
Go to start of metadata

Where To Find This Example

Select Help > Open Examples... from the menus and type either the example name listed above or one of the keywords below.

Or in Version 13 or higher you can open the project directly from this page using this button.

Design Notes

Nonlinear FET Characterization

This project has many test benches and graphs setup to help characterize a nonlinear FET model. Please follow the steps in the project. When you first open the project, you will be prompted to enable scripts. Please enable as this will allow bias information to display on the display schematics. Please do not edit the names of schematics or graphs in this project as some functionality may no longer work if you do so. This project is intended to characterize a FETs performance, not compare simulated to measured data or fit model parameters to measured data, there are separate projects for those purposes.

Step 1. Choose your Device Under Test (DUT)

Open the "DUT" schematic and add your FET model to this schematic.

Notice the source of the device is grounded. You can add any parasitics to ground to see how that will affect your device performance. All test benches reference this schematic, so all results will be affected by whatever is in this schematic.

If you are using a PDK, you will need to add the PDK to this project to get the PDK library of parts. From the menus, select "Project > Process Library > Add/Remove Library". From the dialog that comes up, click the "Add" button and then search to the *.ini file for the PDK you are using. Then click "OK". After you do this, the "Library" node of the element browser should have the parts available for your chosen PDK.

Step 2. IV Curves

Open the "IV" schematic and the "IV Curves Graph", found in the "IV" User Folder

Adjust the SWEEP and STEP parameters to get a good set of IV curves.

A line is drawn on the graph that you can edit the end points if you want to set your ideal load line. Double click on the line and you can edit the end points. This can help you determine the DC operating point of your device.

Step 3. Linear Analysis

Right click on the "Linear" User Folder and select "Enable All".

Set your Bias

- Choose your gate and drain bias, set in the "Global Definitions" variables vg and vd.

- By default, the linear measurements will be at this bias.

- In the "linear_frequency_sweep" schematic, there is a disabled sweep block. You can enable the two items in this block and disable the items in the other block to setup for a bias sweep. You will need to set the "values" parameter to be the sweep values. All the graphs in this folder will automatically update for this additional sweeping.

- When you simulate, make sure your bias is correct by viewing the schematic annotations for voltage and current to make sure these are what you wanted from your IV curve analysis. If you are using a sweep the annotation will display the voltage and currents for the first value for the sweep.

Set your Frequency Range

- Right click on the "Linear_Frequency_Sweep" schematic, select "Options" and set the frequencies on the "Frequencies" Tab.

- You most likely want to sweep beyond the Ft of the device, see the Ft graphs for how to determine this value.

- The Global frequency will be a single point used for the nonlinear characterization of the device.

Displays

- The "Display_Network_Analyzer" schematic is setup to view the s-parameters similar to a VNA.

- The "Display_All_Linear" schematic is setup to view all the graphs for the linear analysis.

Step 4. Single Point Nonlinear Analysis

Right click on the "Nonlinear/Single" User Folder and select "Enable All".

Set your Bias

- Was set in step 3, nothing to do here.

- When you simulate, make sure your bias is correct by viewing the schematic annotations for voltage and current to make sure these are what you wanted from your IV curve analysis.

Set your Frequency

- Double click on the "Project Options" node and set a single frequency on the "Frequencies" Tab.

Set your Input Power Level

- Choose your input power level, set in the "Global Definitions" variable pwr.

Set your Harmonics

- Click on the "Options > Default Circuit Options" menu and the "Aplac Sim" tab. Change the harmonic settings if you need to. If you are unsure, just leave alone as they should be okay for most cases.

Perform Load Pull

- Choose your input power for the load pull analysis.

- In the "Nonlinear_Tuners" schematic, for the two tuners, set the "Fo" parameter to be the same as the project frequency. This sets the frequency of the tuner impedance.

- First, guess at input impedance. Look at the "Load Pull Input" plot and move marker to the proper frequency (easiest to use search for marker) on the s11 conjugate measurement. The marker shows the magnitude and angle of the reflection coefficient for S11. So enter the input tuner "Mag1" parameter to be the magnitude from the marker and "Ang1" parameter to be the angle as the marker.

- Second, do load pull analysis. Look at the "Load Pull Output" plot and move marker to the proper frequency (easiest to use search for marker) on the s22 conjugate measurement. The marker shows the magnitude and angle of the reflection coefficient for S22. The approximate output match is this impedance just to make sure the load pull is close to this (a sanity check). Next, select "Scripts > Global Scripts > Load Pull" from the menus. All of the default settings are correct for this example. Once load pull is done, set the magnitude and angle for the output tuner to the values on the marker on the maximum value.

Data from Single Frequency and Power

- Current Waveforms - shows the current waveforms at the input and output after the tuners.

- Voltage Waveforms - shows the voltage waveforms at the input and output after the tuners.

- Dynamic Load Line - shows the load line superimposed on the IV curves.

- Output Power Spectrum - shows the spectrum of power at the output port.

Displays

- The "Display_Load_Pull" schematic is setup to view the graphs and schematic for load pull analysis

- The "Display_Single_Power" schematic is setup to view all the graphs for the single power nonlinear analysis.

Step 5. One Tone Swept Power Analysis.

Right click on the "Nonlinear/One Tone" User Folder and select "Enable All".

The "Nonlinear_One_Tone_Sweep" schematic uses the "Nonlinear_Tuners" schematic. This way there is only one set of tuners in the project where impedances can be set.

Set your Input Power Level

- Choose your input power level sweep values in the "Nonlinear_One_Tone_Sweep" schematic

Displays

- The "Display_One_Tone" schematic is setup to view the graphs for one tone swept power analysis.

Step 6. Two Tone Swept Power Analysis.

Right click on the "Nonlinear/Two Tone" User Folder and select "Enable All".

The "Nonlinear_One_Tone_Sweep" schematic uses the "Nonlinear_Tuners" schematic. This way there is only one set of tuners in the project where impedances can be set.

Set your Input Power Level

- Choose your input power level sweep values in the "Nonlinear_Two_Tone_Sweep" schematic.

- You may choose to change your tone spacing if you like. If unsure, just leave the value at 100 MHz, unless your fundamental frequency is around that range (you want the spacing to be much smaller than the spacing between the first and second harmonic of the fundamental).

Displays

- The "Display_One_Tone" schematic is setup to view the graphs for one tone swept power analysis.

Final Notes:

This project uses an example process design kit. If you are using your own device model and do not want this PDK in the project you can remove it. From the menus, select "Project > Process Library > Add/Remove Library". From the dialog that comes up, select the library you dont want and click the "Remove" button.

Schematic - IV

Schematic - Display_Network_Analyzer

Schematic - Display_Load_Pull

Schematic - Display_All_Linear