Page tree
Skip to end of metadata
Go to start of metadata

 

Problem

After exporting a DXF file from AWR, and importing in to other applications (like AutoCAD), an error message appears that reads something like: adfasdf "Improper table entry name ..... on line ....", or  "Invalid or incomplete DXF input -- drawing discarded" or possibly nothing shows up at all.

Solution

For DXF files, the layer names have strict syntax on the allowable characters in the file names. The following are allowed characters. a-z A-Z 0-9 $_- If you use other characters like (*&, etc. you will have this problem. AWR does not check the layer name the user entered when exporting DXF, so the user will need to watch for this. There are three ways to remove this error.

  1. Don't have any drawing layers with these illegal characters.

  2. If you want these characters in your drawing layers, in the export mapping tables for the DXF type, you can specify the name of the layer used in the DXF file. Use a string here that has legal characters.

  3. You can set an option in the Layout Options so that AWR does not export illegal characters. This option is from the menus under Options->Layout Options..->Export/LPF tab->Remove illegal chars in layer names

If you use the Export Library command to save a DXF library from the layout manager (Layout tab at bottom of left panel), then there is no "top level" drawing in the DXF file, and each cell is an AutoCAD "block". Blocks do not open automatically when you open the file. In AutoCAD, the BLOCK command followed by ? will list the blocks in the file, or you can use the Insert > Block command and then select the desired block in order to place it on a drawing.