Page tree
Skip to end of metadata
Go to start of metadata

Problem

I have the HSPICE license feature in my License file and an HSPICE netlist that I want to use in the AWRDE. How can I import this netlist into the AWR environment, where do my options go, and how can I handle hierarchy in the imported netlist?

Version and Product

AWR 2006 (Version 6.5) and later

MWO and AO

Solution

The attached .ZIP file contains the following files, which should all be extracted to the same directory:

  • SPICE Example.emp - main project, ready to run in its current form

  • SPICE Example.vin - .VIN file for this project

  • Top.sp - netlist that will be imported directly into the AWR environment. This file contains a subcircuit reference to Sub.sp.

  • Sub.sp - netlist that is called from Top.sp. It is never imported into the AWR environment. It is just called from Top.sp.

  • awr_inc.inc - top level include file that can contain needed control statements, parameters, and other .includes

A netlist that is imported into AWR should contain only a single .SUBCKT/.ENDS block. All required hierarchy should be handled with .include statements.

A top level .inc file should be created and it is referenced by going to Options >Default Circuit Options. Click the HSPICE tab, click the More button, and select the User Text tab. In the upper box, enter the .include statement for the top level .inc file. (In this example, the statement is .include awr_inc.inc ) .

All other control statements should be placed in the top level .inc file, such as other .include statements (in this example, we .include the Sub.sp subcircuit), .param statements (in this example, we set up a parameter for the subcircuit's resistor value), and any other control statements that are needed. Note that it is always preferable to set control options through the GUI. These GUI options are located at Options > Default Circuit Options > HSPICE. Select More then User Text tab.

So, the top level .inc is specified in the options and we can now import the top level netlist. This is done by going to the Project tab, right-clicking on Circuit Schematics, and selecting Import Netlist... . In the Files of Type box, select HSPICE Netlist Files (native) and navigate to the desired netlist file ( .sp format). Once imported, the netlist will be available for placement into a schematic as a regular subcircuit. The AWRDE should recognize the number of terminals/ports and offer a schematic symbol with the appropriate number. (You can always substitute your own symbol for the generic one that AWRDE will offer.)

Once the netlist is placed on the schematic, we simply add a source, a load, and a measurement probe. For comparison, a second schematic is included in the example that shows the equivalent circuit in a harmonic balance simulation. With an increase in the number of harmonics used in HB (default is 5, the example uses 16), the results are identical.

Downloads

SPICE_Example.zip