Page tree
Skip to end of metadata
Go to start of metadata

The PCB EM Setup wizard is an MWO add-on designed to help set up EM simulation from imported PCB layout.  The two main functions of the wizard are Smart Selection which allows users to quickly and easily define the desired signal nets on their PCB and Smart EM Set Up which provides a single button click to convert the selected signal nets from layout to a simplified EM document with EM ports at the desired component pin locations.  Documentation can be found below the Download and Install section.

Download and Install

Current Version = 14.04.02

  1. Check your current wizard version to see if a new version of the wizard is available.

  2. If a new version is available, uninstall your current PCB EM Setup Wizard.
  3. Download the Wizard using the button above.

  4. Find the AWR Projects folder by choosing Help > Show Files/Directories and double-clicking on Projects



  5. Copy the zip file to the AWR Projects directory and unzip it
  6. Browse the Wizards folder in the unzipped PCB_EM_Setup folder, right click on both DLLs and choose Properties.
    1. Check to see if there is a "Security" section on the bottom of the "General" tab and if there is check the "Unblock" checkbox



    2. If the above General tab does not contain the Unblock selection, please run the following PowerShell command
      1. Unblock-file -path "FULL PATH TO PCB EM SETUP.dll"
      2. Reference to the https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.utility/unblock-file?view=powershell-6
  7. Register the PCB EM Setup Wizard with Microwave Office by choosing File > New with Library > Browse and then browsing to the INI file in the PCB EM Setup folder in your AWR Projects directory.
    1. The PDK can be added to new projects by choosing File > New with Library and choosing PCB EM Setup from the list.
    2. The PDK can be added to existing projects by choosing Project > Process Library > Add/Remove Library > Add button and choosing PCB EM Setup from the list
  8. Run the PCB EM Setup wizard by double-clicking PCB EM Setup in the Wizards node

Note that if you encounter an error stating "Error running wizard. Unexpected C++ Exception," it may be that the step to unblock both DLL files was not properly completed.

Usage Overview

Information Section

Power/Ground Nets Button - Displays the following information about the imported PCB design in the Status window:

  • Names of all the power and ground nets 
  • Total number of nets
  • Total number of components 

Selected Shape Info - Displays the following information about the selected shapes in the Status window:

  • Recommended Shape Simplification settings
  • Component pin layers
  • Path layers
  • All layers
  • Net Names
  • Component pin names

Copy to Clipboard - Copies Status window text to the clipboard.

Selection Section

General Options

Do not select power/ground nets - If checked then power and ground nets will not be selected when using any of the selection commands.  This is useful because selecting power or ground nets often involve selecting shapes as large as the entire board and power and ground nets are often something users wish to avoid.

Select pins only - If checked then only component pins will be selected when using selection commands.  This is useful in EM documents since the point of selection is often to add ports to component pins.

Auto zoom after selection - If checked then Zoom to the selected shapes when using selection commands.

Components select use Max pin count - When using the Components selection button do not select components that have a pin count greater than the Smart Select Options > Max pin count

Smart Select Options

Select all component pins - If checked all component pins for every component on the net will be selected when using Smart Select (note, however, that the other shapes on the power and ground nets will not be selected). 

Max pin count - The component pin limit used by Smart Select to decide which components to connect through.  Smart select won't connect through components with more pins than the limit.

Commands

Nets - Select all the shapes on the same net(s) as the currently selected shape(s).

Components - Select all the component pin(s) for each component in the currently selected shape(s).

Smart Select - Starting with the currently selected component pin(s) select all shapes on the net(s) that are not power and ground nets.  Continue selecting through components with a pin count less than the Max pin count defined in the options.  Used to quickly select the relevant portion of the layout by starting with the desired input component pins and running Smart Select.  None of our public domain sample boards have series SMD components but note in the screenshot shown below the Smart Select command avoided selecting pins that connect to power or ground nets.

Deselect All - Deselect all currently selected shapes in the layout.

Undo - Undo the previous selection.

Restore - Restore the last saved selection.

Save - Save the currently selected shapes.  Note that the save persists after the wizard is closed.

EM Structure Section

Commands

Check Ports - Checks the EM ports to find invalid excitation setup, multiple EM ports on the same shape, overlapping EM ports, and vias under EM ports that connect to upper/lower

Check Vias - Provides a count of power/ground net vias and selected trace signal vias for sanity checking (e.g., if the EM cutout region includes multi layer ground planes but does not contain any power/ground net vias then something is probably setup incorrectly).

Smart Setup - Typically this command is used after the desired shapes are selected with the Smart Select command.  It takes the selected shapes, asks the user a few questions, and sets up an EM Structure with ports at the selected component pin locations.  This command does the following:

  • Guides the user through created an EM clip region
  • Asks the user about which layers to copy to the EM Structure
  • Guides the user through naming the EM Structure
  • Sets the recommended Simplification Properties
  • Copies the shapes in the EM clip region to the EM structure
  • Adds EM ports to all the component pins that were selected in the layout
    • Adds differential (+/-) ports for SMD components
    • Adds connect to upper/lower point ports for other components
  • Guides the user through cleaning up the EM Structure
  • Checks vias and ports for possible issue

Setup Ports - Provides a choice to use differential (+/-) ports for SMD Components and connect to upper/lower ports for all other components or switch back to the default port settings for all ports in the EM Structure.

Clean Up - Remove all shapes that are not power and ground net shapes and that are on nets without an EM port attached.

  • No labels