Page tree
Skip to end of metadata
Go to start of metadata

Where To Find This Example

Select Help > Open Examples... from the menus and type either the example name listed above or one of the keywords below.

Or in Version 13 or higher you can open the project directly from this page using this button. Make sure to select the Enable Guided Help before clicking this button.

Design Notes

Analog Office Configuration Project

This project will help new users to Analog Office configure the software for some settings that they will be more familiar with.  These include the schematic and layout colors, the hotkeys, schematic wires behavior, units, and layout face defaults.    This project will also discuss a method to generate a library of elements defined by the user.  

Overview

Some options in the AWRDE are environment options meaning these options apply to all AWR projects.   Other options are project options meaning these options apply to only the particular project currently open.    This project will discuss different ways of setting and using different default environment and project options.  

Environment Options and Customizations

Both environment options and customizations apply to all AWR projects.   Environment options are set by selecting Options > Environment Options from the menus.   You can see the help pages for each of these settings.  Customizations are set from Tools > Customize and these set menu items, tool bar items, and Tools > Hotkeys set hotkeys.    To help new users to the AWRDE, there is a script in this project named “Configure_AO”.  This script will set your hotkeys and your environment colors (schematic background, layout background, symbols, etc) to match Cadence default settings.   To run this script, select Scripts > Project Scripts > Configure_AO(Main) from the menusYou can run this script as many times as you like to change the settings.  

Project Options

Project options are any options that are not Environment options or customizations.   These are set from the Options menu for any item not under Environment Options …  Several options should be set to match behavior from Cadence.

1.  Options>Project Options, the Global Units tab.   Select the Use Base Units button.    This will put all of the different unit types in base units (Farads, Amps, Hertz, etc.  When entering parameter values you can use standard values for suffixes, n=1e-9, k=1e3, etc).  

2.  Options>Project Options, the Schematics/Diagrams tab.  Uncheck the Auto wire cleanup.  With this unchecked, when elements are deleted in a schematic, the wires connecting the elements will not be deleted.  

3.  Options>Layout Options, the Layout tab.   Check the Default connection to closest face.  This option will have the fly lines in layout behave more like Cadence.  

The AWRDE can be configured to always start with the same set of project options; this can be done with a project template.    You can save any project as a template.  Choose File > Save Project As and from the save as type field select Project Template (*.emt).   There are potentially two ways you would use this template. 

1.   If you are not using a PDK, you can save any project as a template and then from Options > Environment Options on the File Location tab, you can list where this template file is.  If you do this, any new project created without a PDK will use this template.

2.   Each PDK uses its own template file, this is how you get substrate and process definitions in the Global Definitions when you create a new project with a foundry.   In this case, you should open the foundry template (File > Open Project¸select Project Template  from the File of type selection and then browse to the PDK template file, usually located in a folder named Library under the foundry name), make your option edits and then save the file back out as the same named template.  

Element Palate

AWRDE has an extensive library of models.  You can customize this library of parts anyway you want.   This project has been configured to help you do that.  The mechanism is to create schematics to define element folder names and then place elements in those schematics to define what elements should be available in that folder.   There is a script in this project named “XML_Generate” that will generate a file that holds all of this information.   After you run this script, reopen a new AWRDE project and you will see a node called "AO_Elements" under the "Libraries" node of the Element Browser. 

Schematic - Differential

Schematic - Lumped_Elements

Schematic - Sources

Schematic - Net_Terminal