Page tree
Skip to end of metadata
Go to start of metadata

Where To Find This Example

Select Help > Open Examples... from the menus and type either the example name listed above or one of the keywords below.

Or in Version 13 or higher you can open the project directly from this page using this button. Make sure to select the Enable Guided Help before clicking this button.

Design Notes

This project must be saved in a folder with write permission to simulate with extraction.

Before simulating, select File > Save Project As... and save in a different folder.

iNet Parasitic Extraction Basics

The AWR Design Environment allows a powerful methodology for including net parasitics in your simulation.  Once you have implemented an intelligent net (iNet), you can simulate the circuit with its affects, even if the rest of the circuit’s layout is not.   Parasitic extractions can also be done in groups, which allows you to break up the extraction problem into smaller problems or use different physical simulators. 

This example will demonstrate the basics of including the parasitics from iNets in simulation results.  

Overview

This example is a three stage ring oscillator with a completed layout.   iNets are used to wire up the circuit for both the signal path and the power supply rails.   The Net-An parasitic extractor will be used to generate the parasitics for the iNets.  The signal path will be setup to generate a RLCK extraction while the power supply rails will be setup to only generate an R extraction.    

The schematic Ring Oscillator” is the complete design; you can view the layout to see device pcells are wired together with iNets.   The graph “Spectrum” shows the frequency domain spectral results, “Supply_Voltages” shows the time domain waveforms at the source of each of the PMOS devices, and “Waveform” shows the time domain waveforms at the output of the circuit.   There is a capacitor at the output of the design.  It is set to 0 pF to show the shift in frequency due to only the parasitics of the iNets.  

When you first simulate this project, the iNet parasitics have not been simulated.   

Extraction Basics

There are three requirements for doing parasitic extraction on iNets:

1.   A STACKUP element is required to define the physical stack up of what will be simulated such as dielectric layers (thickness, Er, etc) and conductor properties (thickness, conductivity, etc.).

2.   An EXTRACT element is required to set the properties of the physical simulator to be used. 

3.   Each iNet must be enabled for Extraction.

All three steps have been configured in this project, let’s first do some parasitic extraction and then go into the details.    To simulate this project with the iNet parasitics, just enable the two EXTRACT blocks on the schematic and simulate.  When you simulate, you will see two new EM documents get created and the simulation dialog will show that Net-An is doing simulation. 

Extraction Details

In this example, the STACKUP element is located in the “Global Definitions” section.   The STACKUP element must be located either in the “Global Definitions” or in the same schematic as the EXTRACT block.    The settings for the STACKUP element are beyond this example since this block is typically fixed per PDK and provided with the PDK being used.  

In this example, there are two EXTRACT blocks located in the schematic.  Please see the element help for the details on the parameters for this block. 

You can inspect the settings for each one of the EXTRACT blocks.   For the two different EXTRACT blocks, you will notice that only the EM_DOC and the Name parameters are different.    To see which iNets are simulated with each extract block:

1.   Have both the schematic and layout open.  

2.   Click on the Extract block.

3.   In the schematic and layout, the iNets associated with that Extract block will show highlighted. 

The final setting for all this to work is associating each iNet to the proper EXTRACT block.   To do this:

1.   Open the Element Options page for any iNet.

a.   This can be done in the schematic by double clicking on an iNet (wire) or selecting an iNet, right mouse click, and select “Edit Net Properties”.  

b.   From the layout, select the iNet, right mouse click, and select “Element Properties”. 

2.   Click on the “Model Options” tab

3.   Find the “Em Extraction Options” group.

4.   Click on the “Enable” box and enter the proper “Group name”, this “Group name” must exactly match the “Name” parameter from the EXTRACT block.   

Viewing EM Extraction Document

In the previous steps, the EM documents were automatically created after the EXTRACT blocks were enabled and the project was simulated.    You can create the EM documents before you simulate.  You would do this to visually inspect what will be simulated or also to change options for the physical simulator.   

In this example, if there are any EM Documents in the project browser, please delete them at this step.

You can view the EM extraction document before simulation by right mouse clicking on the schematic name in the project browser that has the EXTRACT blocks and selecting “Add Extraction”.   If this action does not create an EM document, then there is a setup problem.  

Setting Parasitic Extractor Options

The simulator options are available on the EXTRACT block, in this case there is a tab for Net-An Options. 

In this example, we only want to extract resistance for the power supply rails.  To set this:

1.   Double click on the EXTRACT.V3 block and select “Options”

2.   Click on the “NET-AN Options” tab.

3.   Select “R” from the “Simulation Mode” group. 

4.   Click “OK”

The next time you simulate, the “DC” extraction group will only extract the resistance of these nets.  

Viewing Extraction Netlists

You can easily view the netlists that the parasitic extractors generate.   One reason to view this netlist is to verify that the change made in the previous step actually changed what is extracted.

After a parasitic extraction is completed, the “Status Window” will show all simulations completed.  You can find the group for the parasitic extraction and there will be a link to the extracted netlist simulated.   If you click on that link, a new window will open showing the results from that extraction.

Try simulating the “Extract_DC” EM document with R as the “Simulation Mode” and then RLCK and view the extracted netlist to verify the different simulation mode setting had an effect on the results.  

You can also view the parasitic extraction network superimposed on top of the 3D view of the EM document used for simulation.   To see this:

1.   Right mouse click on the EM document in the project browser, and select “Add Annotation”.

2.   From the “Meas type” selection, choose “ERC”.  

3.   From the “Measurement” selection, choose “Extract_CKT 3D”. 

4.   Set any setting you want from the options that display. 

5.   View the 3D view of the EM document to view the parasitic network.

Disabling EXTRACT Blocks

After a parasitic extraction has completed, you can easily compare the simulation results with and without the parasitic effects.   When you disable an EXTRACT block, the parasitics of the iNets associated with that block are not simulated.   You can then enable the block and the parasitics are then used in simulation but the extraction simulation doesn’t have to happen since the extraction results are saved. 

Try a few things.

1.   Get the simulation complete with both extraction groups.

2.   Open the “Supply_Voltages” graph.

3.   Disable the EXTRACT block with the name “DC” and resimulate

4.   Notice that the supply voltage is flat.

5.   Enable the same block and watch that only Hspice simulation is performed since the Net-an results are stored in the project. 

6.   Select the “Spectrum” graph and select “Graph > Freeze Traces”, this will save the spectrum results on the graph

7.   Disable the EXTRACT block with the name “Signal” and resimulate

8.   Notice the frequency shift in the oscillator by comparing the frozen graph data and the simulated data.  

  

iNets and Area Pins

Typically an iNet will connect to a layout cell that has an area pin that defines the “area” where the iNet must overlap to have a legal connection.    Sometimes users want to include any area pins connected to iNets in the extraction.   You can control whether or not area pins are used in extraction.  

To change this setting:

1.   Double click on the EXTRACT block and go the Parameters tab.

2.   Click the Show Secondary button

3.   Find the option for Extract_Pin_Shapes  and change the value to yes or no. 

Add Many iNets to One Group

In larger designs, you might want to add many iNets to one extraction group.  There are several ways you can do this.     You can have many iNets selected in layout and when you go to the iNets properties, you can set all the selected iNets to an extraction group.   You can also restrict the layout selection to only be iNets and then select all and assign to a group.  If you right mouse click in a layout, there is a “Restrict Selection” option.  From the dialog that comes up, you select all of the options except “iNets”.   Then you can select all and only iNets will be selected.  

 

Schematic - Ring_Oscillator

Schematic Layout - Ring_Oscillator

Graph - Waveform

Graph - Spectrum