Page tree
Skip to end of metadata
Go to start of metadata

Where To Find This Example

Select Help > Open Examples... from the menus and type either the example name listed above or one of the keywords below.

Or in Version 13 or higher you can open the project directly from this page using this button. Make sure to select the Enable Guided Help before clicking this button.

Design Notes

Stripline Coupler

This project demonstrates the design of a stripline coupler which uses EMSight simulation and EM-based models.  It also demonstrates the simulation and yield analysis of the entire circuit using EM Extraction to the Axiem simulator.

Overview

The schematic "Tandem_Coupler" uses stripline electrical models to create a quadrature hybrid coupler using offset broadside coupled lines. 

The broadside coupled lines are modeled by the SBCPL element, which uses an internal quasi-static EM simulation that accounts for line thickness and losses. The cross-over in the middle of the coupled line sections is simulated using EMSight.

Note the SMITER and STAPER elements use the "W@1" notation in their width parameters to derive their widths from adjacent elements.

In the "Output Equations", the magnitude and phase error of the output ports are calculated. Also, the resistive loss and total loss of the balun are calculated and subsequently plotted in the graph "Resistive Loss dB"

The 3-D view of the "Tandem_Coupler" layout gives a clear view of the multi-layer layout. The heights and thickness of each layer are defined in the Layer Setup dialog (Options> Drawing Layers) under the 3D Properties tab.

EMSight Simulation Details

In the EM structure "Cross_Over" the port extensions are 3 x the lower substrate height, and the cross over section is 2 x this distance away from the top and bottom walls. This is important, as the walls in EMSight are modeled as a perfect electric conductor (ground.)

One advantage EMSight has over many 'open-boundary' EM simulators is that coupled ports are de-embedded correctly, so that the coupling over the port lengths is not included in the final result. This is critical to this problem, because the electrical parameters of the coupler are strongly dependant on the total coupling length.

You can verify that port coupling is de-embedded correctly by looking at the graph "Maximum S Parameter Error Between EMSight Structures", which uses the SModel measurement to plot the maximum error (of the 16 s-parameters) between the two EM structures "Cross_Over" and "Cross_Over with Longer Ports". The error is less than -60 dB over the frequency band. This error would be many orders of magnitude greater if the port coupling were not de-embedded.

Extraction to Axiem

The schematic “Tandem_Coupler” is also setup for EM Extraction to Axiem.  All of the circuit elements have been enabled for Extraction by Right Clicking the on elements, selecting Properties > Model Options, and checking “Enable” for EM Extraction.  The Stackup element defines the physical properties of the EM Extraction, and the Extract element controls simulator options.  Currently, the Extract Block is disabled, and simulation of “Tandem_Coupler” is based on the circuit elements present in the schematic.  To compare results between circuit models and Axiem simulation, first freeze the simulation results from the circuit model.  Select the desired Graph window, and from the top menu select Graphs > Freeze Traces.  Then enable the Extract Block, and re-simulate.  Graphs will be updated with Axiem simulation results for “Tandem_Coupler”. 

Yield Analysis

This project is also setup to run yield analysis with Axiem Extraction.  In the schematic “Tandem_Coupler”, statistical variation has been assigned to variables representing substrate height (h1, h2, and h3), and layer alignment (Xvar, and Yvar).  The variables h1, h2, and h3 are used to define the substrate layers’ height on the Dielectric Layers tab of the Stackup Element.  The variables Xvar and Yvar are used with the Layer Offset modifier in the layout view of “Tandem_Coupler” to represent alignment between the two stripline layers.  When yield analysis (Simulate > Yield Analysis) is run with the extract block enabled, both substrate height and layer alignment are randomly varied, and an Axiem simulation is run for each trial of the yield analysis.  More details on using Shape/Layer modifiers can be found by selecting the Layer Offset modifier and clicking the Help button on its Properties dialog window.

Results of all the trials are plotted on all the graphs.  In addition, graphs “Coupling Performance Histogram” and “Pareto Chart of Coupling” plot specific measurements related to yield.  More details about the yield measurements can be found by double clicking on the measurement and selecting the Meas Help button on the Modify Measurement dialog window.  Please also refer to the “Yield Analysis” section in the Help documentation for a more comprehensive explanation of this topic.