Page tree
Skip to end of metadata
Go to start of metadata

Problem

Older versions of AWRDE starts up with an "Unable to load the required module: Generic_EMS2_ip.dll." error.

Version and Product

AWRDE 2011 (Version 11.0) and earlier.

MWO and AO

Solution

This error happen in in AWRDE V11 or earlier when 3rd party EM Solvers, such as  HFSS, CST, or Sonnet, are installed in AWRDE V12 or later.  The work around is to delete the Windows registry entries for the 3rd Party Solvers.

  1. Open the Windows Registry Editor.  Click the Start button and type regedit.
  2. In the Registry Editor window, select Edit > Find.  Enter Generic_EMS2_ip.dll, check Keys, and click Find Next
  3. The \Sofware\AWR\Microwave Office\EmSimulators section of the registry should display with 3rd Party DLLs:
     
  4. Delete all 3rd party Generic_EMS2_ip.dll entries by selecting them and using the Delete key.
  5. Close the Registry Editor.  Older versions of AWRDE should start up without errors.  Newer versions of AWRDE are also unaffected by the deletion of these registry entries.