Page tree
Skip to end of metadata
Go to start of metadata


Search Only Tip of the Day Content Below

Search Tips

Additionally, view the pages view along the left side of the window to see an alphabetical listing of each tip of they day.

Today's Tip of the Day


Extraction Video Tutorial

This video shows the extraction flow and how to go from a schematic to an EM structure using extraction in MWOffice. This is a video tutorial and therefore has an associated project with step by step instructions to work through the steps shown in the video.

Click this link to watch the video. You must have Flash Player to watch this video. If you do not have Flash Player, it can be downloaded here.

Extraction Basics Video Guideline

This document explains the steps for the Extraction Basics video which describes the effect of coupling in the microstrip double stub network. This guideline is divided into three sections for running extraction:

  • Building the schematic and layout
  • Setting up for extraction
  • Performing extraction

The instructions will include detailed step-by-step instructions to follow, or buttons that can be pressed that will complete the steps automatically in the AWRDE. At the end of each section, the "Checkpoint" button will open a project with the preceding steps successfully completed. 

Building the Schematic and Layout

To build the schematic and set up proper layout:

  1. Open the double_stub_start.emp project by clicking the button above.
  2. Double-click the "stub" schematic in project Browser to open the schematic. Create the following circuit (This step assumes you know the basics of creating schematics, if not please refer to the AWR Getting Started Guide



IN ORDER FOR THE EXTRACTION RESULTS TO BE CORRECT, THE LAYOUT MUST BE CORRECT. A good way to think about this is, your extracted layout will look just like your schematic layout.  Select the schematic window to ensure it is active, then click the Layout button on the toolbar(or go to View > View layout) to view the layout.

 

Checkpoint 1

View completed schematic...

View non-snapped layout...

 

NOTE: Depending on how you set up your schematic, your layout would look different but the important part is to make sure your layout is correct.

To snap the layout together, press Ctrl+A (or go to Edit > Select All) to select all the elements in the layout. Then click the Snap Together button on the toolbar (or go to Edit > Snap Together).

 

Checkpoint 2

View snapped together layout...

Setting Up for Extraction

The following steps describe how to set up the schematic for extraction:

  1. First step to perform extraction is placing the extraction control block element in the schematic. Go back to the "stub" schematic view by double-clicking the "stub" schematic int he Project Browser. Press Ctrl+L (or go to Draw > More Elements...) to bring up the Add Circuit Element window. Start typing Extract in the designated area and once the extraction control block is filtered out, click OK.
  2. After the element is placed, the settings for the block need to be modified. You can zoom in to get a better look at this element by right-clicking on the schematic and select View Area and draw a box around extraction block element. Below is what it should look like after modification. For each setting to be modified, you can simply double-click on it to get into the editing mode. 



  3. Double-click the extraction block in the schematic, select the AXIEM  tab and check Enable AFS



  4. Double-click Global Definitions in the Project Browser and find the STACKUP element. Select this element and press Ctrl+C to copy. Open the "stub" schematic by double-clicking on it in the Project Browser and press Ctrl+V to paste the STACKUP element in the schematic. NOTE: in this example, the STACKUP element has been properly set up for you (if you created the schematic using the above buttons, the STACKUP element was already included in the "stub" schematic). The set up for this element has not been covered in this document. For more information on how the STACKUP is set up, please refer to AWRDE User Guide.
  5. In the "stub" schematic, select one of the MLINs and hold down the Shift key and select the other elements shown in the following picture. Make sure you don't select the two ports, extract block, MSUB or the STACKUP element. After the required elements are selected, right-click on one of the selected elements and select Properties...



  6. Select Model Options tab and Enable EM Extraction. NOTE: Group name in the EM Extraction Options matches the EXTRACT element's name in the schematic.



  7. You can verify which of the elements have been set up for extraction by clicking on the EXTRACT element in the schematic. This will highlight all the elements that are set up for extraction.

 

Checkpoint 3

Performing Extraction

To run extraction on the project:

  1. Run the simulation and notice that an EM Structure is created. 



  2. Tile windows vertically to see the new results. Select Window > Tile Vertical (or press V on your keyboard) to tile the windows vertically.
  3. To see the effect of extraction on performance, run the simulation. 
  4. To compare the simulation results without extraction, activate the graph window by clicking on it and go to Graph > Freeze Traces in the Graphs menu. 
  5. Right-click on the extraction block in the "stub" schematic again and select Toggle Enable  and run the simulation. If an extraction block is enabled, EM results are used for the elements selected for extraction. If the same extract block is disabled, then the original models are used for simulation. Each time a simulation is run, if the elements used for extraction do not change, a new EM simulation will not occur. This means you can toggle the extract block to quickly see answers with and without extraction. 



  6. Now you can see how much the performance of the network changes when you include all of the coupling.

 

NOTE: In this example, all the settings were configured to make this simulation efficient. In reality, we always recommend you to first view the extracted EM document before simulating. To do this, delete the current EM document from the project, then right-click on the extract block in the schematic and select Add Extraction... . This will generate an EM document without simulating. After this, you can view the mesh, structure, and etc. to verify that your setup is correct.

Final Checkpoint

View Extracted Results

View Non-Extracted Results

 




  • No labels