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Chapter 1. Introduction
The following AWR Design Environment Getting Started Guides are available:

• TheMicrowave Office Getting Started Guide provides step-by-step examples that show you how to use Microwave
Office software to create circuit designs.

• The AWR Analyst Getting Started Guide provides step-by-step examples that show you how to use Analyst software
to create and simulate 3D EM structures from the Microwave Office program.

• Microwave OfficeMMICGetting Started Guide provides step-by-step examples that show youMonolithicMicrowave
Integrated Circuit (MMIC) features and designs.

• AWR Visual System Simulator Getting Started Guide provides step-by-step examples that show you how to use VSS
software to create system simulations and to incorporate Microwave Office software circuit designs.

To set up the AWR Design Environment software for PCB style design, choose Tools > Create New Process to display
the Create New Process dialog box, then click the Help button for details on using this tool.

Introducing the AWR Design Environment Platform
This platform comprises two powerful tools that can be used together to create an integrated system or RF design
environment: VSS and Microwave Office software. These powerful tools are fully integrated in the AWR Design
Environment platform and allow you to incorporate circuit designs into system designs without leaving the design
environment.

VSS software enables you to design and analyze end-to-end communication systems. You can design systems composed
of modulated signals, encoding schemes, channel blocks and system level performance measurements. You can perform
simulations using the VSS software predefined transmitters and receivers, or you can build customized transmitters and
receivers from basic blocks. Based on your analysis needs, you can display BER curves, ACPR measurements,
constellations, and power spectrums, to name a few. VSS software provides a real-time tuner that allows you to tune the
designs and then see your changes immediately in the data display.

Microwave Office software enables you to design circuits composed of schematics and electromagnetic (EM) structures
from an extensive electrical model database, and then generate layout representations of these designs. You can perform
simulations using any of the Cadence AWR simulation engines, such as a linear simulator; the Cadence APLAC® HB
simulator for nonlinear frequency-domain simulation and analysis; the AXIEM 3D-planar EM simulator; the Analyst
3D-FEM simulator; or transient circuit simulators (the APLAC transient simulator or an optional Spectre simulator), and
display the output in a wide variety of graphical forms based on your analysis needs. You can then tune or optimize the
designs and your changes are automatically and immediately reflected in the layout. Statistical analysis allows you to
analyze responses based on statistically varying design components.

The tool set spans the entire IC design flow, from system-level to circuit-level design and verification, including design
entry and schematic capture, time- and frequency-domain simulation and analysis, physical layout with automated
device-level place and route and integrated design rule checker (DRC), and a comprehensive set of waveform display
and analysis capabilities supporting complex RF measurements.

OBJECT ORIENTED TECHNOLOGY

At the core of the AWRDesign Environment platform capability is advanced object-oriented technology. This technology
results in software that is compact, fast, reliable, and easily enhanced with new technology as it becomes available.
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About This Guide
Through working examples, this Getting Started Guide is designed to familiarize you with Microwave Office, VSS, and
Analyst software; and MMIC capabilities.

Prerequisites

You should be familiar withMicrosoft®Windows® and have a working knowledge of basic circuit and/or system design
and analysis.

This document is available as a download from the Cadence AWR Knowledge Base.

If you are viewing this guide as online Help and intend to work through the examples, you can download and print out
the PDF version for ease of use.

Contents of this Guide

Chapter 2 provides an overview of the AWR Design Environment platform including the basic menus, windows,
components and commands.

In theMicrowave Office Getting Started Guide the subsequent chapters take you through hands-on examples that show
you how to use Microwave Office software to create circuit designs including layout and AXIEM 3D planar EM layout
and simulation.

In the Analyst Getting Started Guide the subsequent chapters take you through hands-on examples that show use of the
Analyst 3D Electromagnetic simulator for 3D EM simulation within Microwave Office software. Use of 3D parametric
layout cells and a 3D Layout Editor is included.

In theMicrowave Office MMIC Getting Started Guide the subsequent chapters take you through hands-on examples that
allow you to work with Monolithic Microwave Integrated Circuit (MMIC) features and designs.

In the AWR Visual System Simulator Getting Started Guide the subsequent chapters take you through hands-on examples
that show you how to use VSS software to create system simulations and to incorporate Microwave Office software
circuit designs.

Conventions Used in This Guide

This guide uses the following typographical conventions:

ConventionItem
Shown in a bold alternate font. Nested menu selections are
shown with a ">" to indicate that you select the first menu
item and then select the submenu item:

Anything that you select (or click on) in the AWR Design
Environment program, such as menus, nested submenus,
menu options, dialog box options, buttons, and tab names

Choose File > New Project.
Shown in a bold within quotation marks:Text that you enter using the keyboard

Enter "my_project" in Project Name.
Shown in a bold alternate font with initial capitals. Key
combinations using a "+" indicate that you press and hold
the first key while pressing the second key:

Keys or key combinations that you press

1–2 AWR Design Environment
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ConventionItem
Press Alt+F1.
Shown in italics:File names and directory paths

See the DEFAULTS.LPF file.

Getting Additional Information
There are multiple resources available for additional information and technical support for Cadence products.

Cadence AWR Knowledge Base

The Cadence AWR Knowledge Base includes these and other resources:

• Application Notes - Technical papers on various topics written by Cadence or our partners.

• Examples - Pages explaining project examples in the installed software or available for download.

• Licensing - A step-by-step guide to resolving most licensing problems.

• Questions - Frequently Asked Questions (FAQs) and answers for common customer issues.

• Scripts - Scripted utilities to help solve specific problems.

• Documentation - Downloadable copies of the latest released documentation.

• Videos - Short technical videos on how to accomplish specific tasks.

Documentation

Documentation for the AWR Design Environment platform includes:

• What's New in AWR Design Environment v22.1? presents the new or enhanced features, elements, system blocks, and
measurements for the current release. This document is available in the Help by clicking the Windows Start button
and choosing AWRDE 22.1 > AWR Design Environment Help and then expanding the Cadence AWR Design Environment
node on the Contents tab, or by choosing Help > What's New while in the program.

• The AWR Design Environment Installation Guide describes how to install the AWR Design Environment platform
and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips.
This document is downloadable from the Cadence AWR Knowledge Base.

• The AWRDesign Environment User Guide provides an overview of the AWRDesign Environment platform including
chapters on the user interface; using schematics/system diagrams, data files, netlists, graphs, measurements, and output
files; using variables and equations in projects, and more. In addition, an appendix providing guidelines for starting a
new design is included.

• The AWR Design Environment Simulation and Analysis Guide discusses simulation basics such as swept parameter
analysis, tuning/optimizing/yield, and simulation filters; and provides simulation details for DC, linear, AC, harmonic
balance, transient, and EM simulation/extraction theory and methods.

• The AWRDesign Environment Dialog Box Reference provides a reference of many program dialog boxes with dialog
box graphics, overviews, option details, and information on how to access each dialog box.

• The AWRAPI Scripting Guide explains the basic concepts of AWRDesign Environment scripting and includes coding
examples. It also provides information on the most useful objects, properties, and methods for creating scripts in the
AWR Script Development Environment (AWR SDE). In addition, this guide contains the AWR Design Environment
Component API list.
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• The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use
of the AWR Design Environment platform. This document is available within the program by choosing Help > Quick
Reference. This is an excellent document to print and keep handy at your desk.

• Context sensitive Help is available for most operations or phases of design creation. To view an associated Help topic,
press the F1 key during design creation.

Documentation for Microwave Office software includes:

• The AWRMicrowave Office Layout Guide, which contains information on creating and viewing layouts for schematics
and EM structures, including use of the Layout Manager, Layout Process File, artwork cell creation/editing/properties,
Design Rule Checking, and other topics.

• The AWRMicrowave Office Element Catalog, which provides complete reference information on all of the electrical
elements that you use to build schematics.

• The AWR Microwave Office Measurement Catalog, which provides complete reference information on the
"measurements" (for example, computed data such as gain, noise, power, or voltage) that you can choose as output
for your simulations.

Documentation for VSS software includes:

• The AWR Visual System Simulator System Block Catalog, which provides complete reference information on all of
the system blocks that you use to build systems.

• The AWR Visual System Simulator Measurement Catalog, which provides complete reference information on the
measurements you can choose as output for your simulations.

• The AWR Visual System Simulator Modeling Guide, which contains information on simulation basics, RF modeling
capabilities, and noise modeling.

Documentation for the 3D Editor and Cadence Analyst™-MP multi-physics simulator (stand-alone product for
multi-physics types of EM problems) includes:

• TheWhat's New in Analyst-MP v22.1 (Analyst_Whats_New.pdf), which presents the new or enhanced features for
both the 3D Layout Editor and Analyst-MP simulator software.

• The Analyst-MP Getting Started Guide (Analyst_Getting_Started.pdf), which provides step-by-step examples that
show you how to use Analyst-MP simulator software.

• The Analyst User Guide (Analyst_User_Guide.pdf), which provides an overview of the 3D Editor and Analyst-MP
simulator software; including chapters on the user interface, structures, simulations, post-processing, variables, data
files, and scripting.

Online Help

All AWR Design Environment documentation is available as on-line Help.

To access online Help, choose Help from the menu bar or press F1 anywhere in the program. Context sensitive help is
available for elements and system blocks in the Elements Browser and within schematics or system diagrams, and for
measurements from the Add/Modify Measurement dialog box.

Online Support

The Cadence Learning and Support System is available from the Cadence Support website. You can navigate to this site
from the AWR Design Environment platform by choosing Help > Get Technical Support.
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Chapter 2. AWR Design Environment Platform
The basic design flow in the Cadence® AWR Design Environment® platform is shown in the following flow chart.

Create Project
File > New Project or File > New with Library

Set Units, Environment Options
Options > Project Options

Create Schematics/Diagrams
Project > Add Schem./Sys. Diagram

View > View Schematic

(Microwave Office) Create Layout
View > View Layout

Set Frequency, Simulation Options
(Microwave Office) Options > Def. Circuit Options

(VSS) Options > Def. System Options

Create Graphs/Measurements
Project > Add Graph

Project > Add Measurement

Simulate Circuit
(Microwave Office) Simulate > Analyze

(VSS) Simulate > Run Sys. Sim.

Tuning(Microwave Office) Optimizing

Set Optimization Goals Manually Vary Parameters

Automatically:

Simulate > Optimize Simulate > Tune

Project > Add Opt Goal Simulate > Tune Tool

*Updates Schem./Sys. Diagrams
*(Microwave Office) Updates Layout
*Simulates
*Updates Results/Graphs

Automatically:
*Updates Schem./Sys. Diagrams
*(Microwave Office) Updates Layout
*Simulates
*Updates Results/Graphs

This chapter describes the windows, menus and basic operations for performing the following tasks in the AWR Design
Environment platform:

• Creating projects to organize and save your designs

• Creating system diagrams, circuit schematics, and EM structures

• Placing circuit elements into schematics

• Placing system blocks into system diagrams
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• Incorporating subcircuits into system diagrams and schematics

• Creating layouts

• Creating and displaying output graphs

• Running simulations for schematics and system diagrams

• Tuning simulations

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Starting AWR Software Programs
To start the AWR Design Environment platform:

1. Click the Windows Start button.

2. Choose All Programs > AWRDE 22.1 > AWR Design Environment 22.1.

The following main window displays.
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Title bar

Menu bar

Toolbar

Project Browser

System diagrams
Circuit schematics

Tabs
Status Window

Status bar

Workspace

If the AWR Design Environment platform was not configured during installation to display in your Start menu, start the
application by double-clicking the This PC icon on your desktop, opening the drive and folder where you installed the
program, and double-clicking on MWOffice.exe, the AWR Design Environment platform application.

AWR Design Environment Platform Components
The AWR Design Environment platform contains the windows, components, menu selections and tools you need to
create linear and nonlinear schematics, set up EM structures, generate circuit layouts, create system diagrams, perform
simulations, and display graphs. Most of the basic procedures apply to Cadence Microwave Office® software, Cadence
Visual System Simulator™ and (VSS) communications and radar systems design software. The major components of
the AWR Design Environment platform are:
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DescriptionComponent
The title bar displays the name of the open project and any Process Design Kit (PDK) used with
the project.

Title bar

The menu bar comprises the set of menus located along the top of the window for performing
a variety of Microwave Office and VSS tasks.

Menu bar

The toolbar is the row of buttons located just below the menu bar that provides shortcuts to
frequently used commands such as creating new schematics, performing simulations, or tuning

Toolbar

parameter values or variables. The buttons available depend on the functions in use and the
active window within the design environment (as well as any customization of toolbar button
groups). Position the cursor over a button to view the button name/function.
The workspace is the area in which you design schematics and diagrams, draw EM structures,
view and edit layouts, and view graphs. You can use the scrollbars to move around the workspace.
You can also use the zoom in and zoom out options from the View menu.

Workspace

Located by default in the left column of the window, this is the complete collection of data and
components that define the currently active project. Items are organized into a tree-like structure

Project Browser
(Project tab)

of nodes and include schematics, system diagrams and EM structures, simulation frequency
settings, output graphs, user folders and more. The Project Browser is active when the AWR
Design Environment platform first opens, or when you click the Project tab. Right-click a node
in the Project Browser to access menus of relevant commands.
The Elements Browser contains a comprehensive inventory of circuit elements for building your
schematics, and system blocks for building system diagrams for simulations. The Elements

Elements Browser
(Elements tab)

Browser displays by default in the left column in place of the Project Browser when you click
the Elements tab.
The Layout Manager contains options for viewing and drawing layout representations, creating
new layout cells, and working with artwork cell libraries. The Layout Manager displays by
default in the left column in place of the Project Browser when you click the Layout tab.

Layout Manager
(Layout tab)

The Status Window displays error, warning, and informational messages about the current
operation or simulation. The Status Window displays by default at the bottom of the workspace
when you click the Status Window tab.

Status Window (Status
Window tab)

The bar along the very bottom of the design environment window that displays information
dependent on what is highlighted. For example, when an element in a schematic is selected, the

Status bar

element name and ID displays. When a polygon is selected, layer and size information displays,
and when a trace on a graph is selected, the value of a swept parameter displays.

You can invoke many of the functions and commands from the menus and on the toolbar, and in some cases by
right-clicking a node in the Project Browser. This guide may not describe all of the ways to invoke a specific task.

Basic Operations
This section highlights the windows, menu choices, and commands available for creating simulation designs and projects
in the AWR Design Environment platform. Detailed use information is provided in the chapters that follow.

Working with Projects

The first step in building and simulating a design is to create a project. You use a project to organize and manage your
designs and everything associated with them in a tree-like structure.
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Project Contents

Because Microwave Office software and VSS software are fully integrated in the AWR Design Environment platform,
you can start a project based on a system design using VSS software, or on a circuit design using Microwave Office
software. The project may ultimately combine all elements. You can view all of the components and elements in the
project in the Project Browser. Modifications are automatically reflected in the relevant elements.

A project can include any set of designs and one or more linear schematics, nonlinear schematics, EM structures, or
system level blocks. A project can include anything associated with the designs, such as global parameter values, imported
files, layout views, and output graphs.

Creating, Opening, and Saving Projects

When you first start the AWR Design Environment platform, a default empty project titled "Untitled Project" is loaded.
Only one project can be active at a time. The name of the active project displays in the main window title bar.

After you create (name) a project, you can create your designs. You can perform simulations to analyze the designs and
see the results on a variety of graphical forms. Then, you can tune or optimize parameter values and variables as needed
to achieve the desired response. You can generate layout representations of the designs, and output the layout to a DXF,
GDSII, or Gerber file. See Appendix B, New Design Considerations in AWR Design Environment User Guide in the
AWRDesign Environment User Guide for advanced guidelines on starting a new design. You can also transfer technology
and design informationwith Virtuoso andDE-HDL/Allegro platforms through a CadenceUnified Library. See Appendix E,
AWR Design Environment Interoperability with Virtuoso and Allegro in AWR Design Environment User Guide in the
AWR Design Environment User Guide for details.

To create a project choose File > New Project. Name the new project and the directory you want to write it to by choosing
File > Save Project As. The project name displays in the title bar.

To open an existing project, choose File > Open Project. To save the current project, choose File > Save Project. When you
save a project, everything associated with it is automatically saved. Cadence AWR® projects are saved as *.emp files.

Opening Example Projects

Cadence provides a number of project examples (*.emp files) in the installation directory to demonstrate key concepts,
program functions and features, and show use of specific elements.

To search for and open example projects referenced in this guide:

1. Choose File > Open Example.

The Open Example Project dialog box displays with columns for the project name and keywords associated with each
example project.

2. Filter the list using "getting_started" as a keyword by Ctrl-clicking the Keywords column header and typing
"getting_started" in the text box at the bottom of the dialog box.

As shown in the following figure, the example list is filtered to display only those projects that have the "getting_started"
keyword associated with them.
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NOTE: You can filter examples by keyword or by file name. An inverted triangle in the column header indicates the
column on which your search is filtered. Press the Ctrl key while clicking a column header to change which column is
used to filter.

Importing Test Benches

Cadence provides several test bench examples that can serve as design guides for various applications such as mixers,
amplifiers, and oscillators. These test benches are set up for import into your working project.

To import a test bench into your project:

1. Choose File > Import Project.

2. Browse toC:\Program Files\AWR\AWRDE\22.1\Examples\ orC:\Program Files (x86)\AWR\AWRDE\22.1\Examples\
and import the desired test bench. The test bench project file names are prefaced with "TESTBENCH" as shown in
the following figure.
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Working with Schematics and Netlists in Microwave Office

A schematic is a graphical representation of a circuit, while a netlist is a text-based description.

To create a schematic, right-click Circuit Schematics in the Project Browser, choose New Schematic, and then specify a
schematic name.

To create a netlist, right-click Netlists in the Project Browser, choose New Netlist, and then specify a netlist name and
type.

After you name the schematic or netlist, a window for it opens in the workspace and the Project Browser displays the
new item as a subnode under Circuit Schematics or Netlists. In addition, the menu bar and toolbar display new command
choices and buttons particular to building and simulating schematics or netlists.
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A Schematic window or
Netlist window opens in
the workspace

Right-click and choose
New Schematic

or

Right-click and choose
New Netlist

Adding Data to Netlists

When you create a netlist, an empty netlist window opens into which you type a text-based description of a schematic.
Netlist data is arranged in blocks in a particular order, where each block defines a different attribute of an element such
as units, equations, or element connections. For more information about creating netlists, see “Creating a Netlist” in AWR
Design Environment User Guide.

Working with System Diagrams in VSS

To create a system diagram, right-click System Diagrams in the Project Browser and choose New System Diagram, and
then specify a system diagram name.
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Right-click and choose
New System Diagram

A System Diagram window
opens in the workspace

After you name the system diagram, a window for it opens in the workspace and the Project Browser displays the new
item as a subnode under System Diagrams. In addition, the menu bar and toolbar display new command choices and
buttons particular to building and simulating systems.

Connecting Element and System Block Nodes

You can connect elements or system blocks directly by positioning them so their nodes touch. Small green boxes display
to indicate the connection. You can also connect elements with wires.

• To connect element or system block nodes with a wire, position the cursor over a node. The cursor displays as a wire
coil symbol. Click at this position to mark the beginning of the wire and drag the mouse to a location where a bend is
needed. Click again to mark the bend point. You can make multiple bends.

• Right-click to undo the last wire segment added.
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• To start a wire from another wire, select the wire, right-click and choose Add wire, then click to mark the beginning
of the wire.

• To terminate a wire, click on another element node or on top of another wire.

• To cancel a wire, press the Esc key.

• When placing or positioning an element, alignment guidelines automatically display when the element nodes align
with another element. To automatically add a wire between the nodes, press the Shift key when placing the element.

Using the Elements Browser

The Elements Browser gives you access to a comprehensive database of hierarchical groups of circuit elements for
schematics and system blocks for system diagrams. The Libraries folder in the Elements Browser provides a wide range
of electrical models and S-parameter files from manufacturers.

Circuit elements include models, sources, ports, probes, measurement devices, data libraries, and model libraries that
can be placed in a circuit schematic for linear and non-linear simulations.

System blocks include channels, math tools, meters, subcircuits, and other models for system simulations.

• To view elements or system blocks, click the Elements tab. The Elements Browser replaces the Project Browser
window.

• To expand and collapse the model categories, click the + or - symbol to the left of the category name to view or hide
its subcategories. When you click on a category/subcategory, the available models display in the lower window pane.
If there are more models than the window can show, a vertical scroll bar displays to allow you to scroll down to see
all of the models.

• To place a model into a schematic or system diagram, simply click and drag it into the window, release the mouse
button, right-click to rotate it if needed, position it, and click to place it.

• To edit model parameters, double-click the element graphic in the schematic or system diagram window. An Element
Options dialog box displays for you to specify new parameter values. You can also edit individual parameter values
by double-clicking the value in the schematic or system diagram and entering a new value in the text box that displays.
Press the Tab key to move to the next parameter when editing.
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Expand, then click
desired subcategory

Elements tab diplays the
Elements Browser

Drag the desired
model into schematic
or system diagram
window

Buttons for adding
ground and ports

NOTE: Choose Draw > More Elements to display the Add Circuit Element or Add System Block dialog box to search for
elements. Press the Ctrl key while clicking a column header to change which column is used to filter.

Adding Subcircuits to Schematics

Subcircuits allow you to construct hierarchical circuits by including a subcircuit block in a schematic (insert a schematic
inside of another schematic). The circuit block can be a schematic, a netlist, an EM structure, or a data file.

• To add a subcircuit to a schematic, click Subcircuits in the Elements Browser. The available subcircuits display in the
lower window pane. These include all of the schematics, netlists, and EM structures associated with the project, as
well as any imported data files defined for the project.

• To use a data file as a subcircuit, you must first create or add it to the project. To create a new data file, choose Project
> Add Data File > New Data File. To import an existing data file, choose Project > Add Data File > Import Data File. Any
new or imported data files automatically display in the list of available subcircuits in the Elements Browser.

• To place the desired subcircuit, simply click it and drag it into the schematic window, release the mouse button, position
it, and click to place it.

Getting Started Guide 2–11

Basic Operations



• To edit subcircuit parameters, select the subcircuit in the schematic window, right-click, and choose Edit Subcircuit.
Either a schematic, netlist, EM structure, or data file opens in the workspace. You can edit it in the same way that you
would edit the individual circuit block types.

Adding Subcircuits to System Diagrams

Subcircuits allow you to construct hierarchical systems and to import results of circuit simulation directly into the system
block diagram.

• To create a subcircuit to a system diagram, choose Project > Add System Diagram > New System Diagram or Import
System Diagram and then click Subcircuits under System Blocks in the Element Browser. The available subcircuits
display in the lower window pane.

• To place the desired subcircuit, simply click and drag it into the system diagram window, release the mouse button,
position it, and click to place it.

• To edit subcircuit parameters, select the subcircuit in the system diagramwindow, right-click, and choose Edit Subcircuit.

• To add a system diagram as a subcircuit to another system diagram, you must first add ports to the system that is
designated as a subcircuit.

Adding Ports to Schematics and System Diagrams

To add ports to a schematic or system diagram, expand the Ports category in the Elements Browser. Under Circuit Elements
or System Blocks, click Ports or one of its subgroups, for example, Harmonic Balance. The available models display in
the lower window pane.

Drag the port into the schematic or system diagram window, right-click to rotate it if needed, position it, and click to
place it.

For a shortcut when placing ports and ground, click the Ground or Port buttons on the toolbar, position the ground or
port, and click to place it.

To edit port parameters, double-click the port in the schematic or system diagram window to display an Element Options
dialog box.

NOTE: You can change the port type after placing it by double-clicking the port and selecting a Port type on the Port
tab of the dialog box.

Creating EM Structures

EM structures are arbitrary multi-layered electrical structures such as spiral inductors with air bridges.

To create an EM structure, right-click the EM Structures node in the Project Browser, and choose New EM Structure.

After you specify an EM structure name and select a simulator, an EM structure window opens in the workspace and
the Project Browser displays the new EM structure under EM Structures. In addition, the menu and toolbar display new
choices particular to drawing and simulating EM structures.
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New EM Structure

An EM structure window
opens in the workspace

NOTE: The EM structure examples presented in this guide use Cadence AXIEM® 3D planar EM analysis.

Adding EM Structure Drawings

Before you draw an EM structure, you must define an enclosure. The enclosure specifies things such as boundary
conditions and dielectric materials for each layer of the structure.

To define an enclosure, double-click Enclosure under your new EM structure in the Project Browser to display a dialog
box in which you can specify the required information.

After you define the enclosure, you can draw components such as rectangular conductors, vias, and edge ports in the
Layout Manager.

You can view EM structures in 2D (double-click the EM structure node in the Project Browser) and 3D (right-click the
EM structure node in the Project Browser and choose View 3D EM Layout), and you can view currents and electrical fields
using the Animate buttons on the EM 3D Layout toolbar.
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Creating a Layout with Microwave Office

A layout is a view of the physical representation of a circuit, in which each component of the schematic is represented
by a layout cell. In the object-oriented AWR Design Environment platform software, layouts are tightly integrated with
the schematics and EM structures that they represent, and are simply another view of the same circuits. Any modifications
to a schematic or EM structure are automatically and instantly reflected in their corresponding layouts.

To create a layout representation of a schematic, click the schematic window to make it active, then choose View > Layout.
A layout window tab opens with an automatically-generated layout view of the schematic.
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With a schematic window active, you can also click the View Layout button on the toolbar to view the layout of a schematic.

The resulting layout contains layout cells representing electrical components floating in the layout window. Choose Edit
> Select All then choose Edit > Snap Objects > Snap Together to snap the faces of the layout cells together. The following
figure shows the layout view from the previous figure after a snap together operation.

When you choose View > View Layout, corresponding schematic components with default layout cells are automatically
generated for common electrical components such as microstrip, coplanar waveguide, and stripline elements. After the
layout is generated, the schematic window displays in blue the components that do not map to default layout cells, and
displays in magenta the components that do have default layout cells. You must use the Layout Manager to create or
import layout cells for components without them. For more information see “Using the Layout Manager”.

You can draw in the schematic layout window using the Draw tools to build substrate outlines, draw DC pads for biasing,
or to add other details to the layout. In this mode, the layout is not part of a schematic element and therefore does not
move as part of the snapping process.

Modifying Layout Attributes and Drawing Properties

To modify layout attributes and drawing properties, and to create new layout cells for elements without default cells,
click the Layout tab to open the Layout Manager.
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Using the Layout Manager

The Layer Setup node in the Layout Manager defines layout attributes such as drawing properties (for example, line color
or layer pattern), 3D properties such as thickness, and layer mappings. To modify layer attributes, double-click the node
(named "default.lpf" in the previous figure) below the Layer Setup node. You can also import a layer process file (LPF)
to define these attributes by right-clicking Layer Setup and choosing Import Process Definition.

The Cell Libraries node in the Layout Manager allows you to create artwork cells for elements that do not have default
layout cells. The powerful Cell Editor includes such features as Boolean operations for subtracting and uniting shapes,
coordinate entry, array copy, arbitrary rotation, grouping, and alignment tools. You can also import artwork cell libraries
such as GDSII or DXF into the AWRDesign Environment platform by right-clicking the Cell Libraries node and choosing
Import Cell Library.

After creating or importing cell libraries, you can browse through the libraries and select the desired layout cells to
include in your layout. Click the + and - symbols to expand and contract the cell libraries, and click the desired library.
The available layout cells display in the lower window pane.
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After you define a cell library, you can assign cells to schematic elements. You can also use a cell directly in a schematic
layout by clicking and dragging the cell into an open schematic layout window, releasing the mouse button, positioning
it, and clicking to place it.

To export a schematic layout to GDSII, DXF, or Gerber formats, click the layout window to make it active, and choose
Layout > Export Layout. To export a layout cell from the cell libraries, select the cell node in the LayoutManager, right-click
and choose Export Layout Cell.

Creating Output Graphs and Measurements

You can view the results of your circuit and system simulations in various graphical forms. Before you perform a
simulation, you can create a graph, specifying the data or measurements (for example, gain, noise or scattering coefficients)
that you want to plot.

To create a graph, right-click Graphs in the Project Browser and choose New Graph to display a dialog box in which to
specify a graph name and graph type. An empty graph displays in the workspace and the graph name displays under
Graphs in the Project Browser. The following graph types are available:

DescriptionGraph Type
Displays the measurement on an x-y axis, usually over frequency.Rectangular
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DescriptionGraph Type
Displays real versus imaginary components of complex data on a
rectangular graph.

Rectangular - Real/Imag

Displays passive impedance or admittances in a reflection coefficient
chart of unit radius.

Smith Chart

Displays the magnitude and angle of the measurement.Polar
Displays the measurement as a histogram.Histogram
Displays the sweep dimension of the measurement as the angle and
the data dimension of the measurement as the magnitude.

Antenna Plot

Displays the measurement in columns of numbers, usually against
frequency.

Tabular

Displays the in-phase (real) versus the quadrature (imaginary)
component of a complex signal.

Constellation

Displays the measurement in a 3D graph.3D Plot

To specify the data that you want to plot, right-click the new graph name in the Project Browser and choose Add
Measurement. An Add Measurement dialog box similar to the following displays to allow you to choose from a
comprehensive list of measurements.

Setting Simulation Frequency and Performing Simulations

To set the Microwave Office simulation frequency, double-click the Project Options node in the Project Browser, or
choose Options > Project Options and then specify frequency values on the Frequencies tab in the Project Options dialog
box. By default, all the schematics use this frequency for simulation. You can overwrite this frequency with an individual
schematic frequency by right-clicking the schematic name under Circuit Schematics in the Project Browser and choosing
Options. Click the Frequencies tab, clear the Use project defaults check box and then specify frequency values.
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To set VSS system simulation frequency, double-click the SystemDiagrams node in the Project Browser or choose Options
> Default SystemOptions, and then specify frequency values on the Basic tab in the System Simulator Options dialog box.

To run a simulation on the active project, choose Simulate > Analyze. The simulation runs automatically on the entire
project, using the appropriate simulator (for example, linear simulator, harmonic balance nonlinear simulator, or 3D-planar
EM simulator) for the different documents of the project.

When the simulation is complete, you can view the measurement output on the graphs and easily tune and/or optimize
as needed.

You can perform limited simulations by right-clicking the Graphs node or its subnodes to simulate only the graphs that
are open, only a specific graph, or simulate for just one measurement on a graph.

Tuning and Optimizing Simulations

The real-time tuner lets you see the effect on the simulation as you tune. The optimizer lets you see circuit parameter
values and variables change in real-time as it works to meet the optimization goals that you specified. These features are
shown in detail in the linear simulator chapter.

You can also click the Tune Tool button on the toolbar. Select the parameters you want to tune and then click the Tune
button to tune the values. As you tune or optimize, the schematics and associated layouts are automatically updated!
When you re-run the simulation, only the modified portions of the project are recalculated.

Using Command Shortcuts

The use of keyboard command shortcuts (or hotkeys) can greatly increase efficiency within the AWRDesign Environment
platform. Default menu command shortcuts are available for many common actions such as simulation, optimization,
and navigating between the Project Browser, Elements Browser and LayoutManager. Default shortcuts display onmenus
or by choosing Tools > Hotkeys to display the Customize dialog box where you can also create custom hotkeys.
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Using Scripts and Wizards
Scripts andwizards allow you to automate and extendAWRDesign Environment platform functions through customization.
These features are implemented via the Microwave Office API, a COM automation-compliant server that can be
programmed in any non-proprietary language such as C, Visual Basic™, or Java.

Scripts are Visual Basic programs that you can write to do things such as automate schematic-building tasks within the
AWR Design Environment platform software. To access scripts, choose Tools > Scripting Editor or any of the options on
the Scripts menu.

Wizards are Dynamic Link Library (DLL) files that you can author to create add-on tools for the AWRDesign Environment
platform; for example, a filter synthesis tool or load pull tool. Wizards display under the Wizards node in the Project
Browser.

Using Online Help
Online Help provides information on the windows, menu choices, and dialog boxes in the AWR Design Environment
platform, as well as for design concepts.

To access online Help, choose Help from the main menu bar or press the F1 key anytime during design creation. The
Help topic that displays is context sensitive-- it depends on the active window and/or type of object selected. The following
are examples:

• Active window = graph, Help topic = "Working with Graphs".

• Active window = schematic (with nothing selected), Help topic = "Schematics and System Diagrams in the Project
Browser".

• Active window = schematic (with an element selected), Help topic = the Help page for that element.

• Active window = schematic (with an equation selected), Help topic = "Equation Syntax".

• Active window = schematic layout (with nothing selected), Help topic = "Layout Editing".

Context sensitive Help is also available by:

• clicking the Help button in most dialog boxes

• right-clicking a model or system block in the Elements Browser and choosing Element Help, or selecting an element
in a schematic or a system block in a system diagram and pressing F1, or clicking the Element Help button in the Element
Options dialog box.

• clicking the Meas Help button in the Add/Modify Measurement dialog box
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Chapter 3. ANA: Using the Analyst 3D Electromagnetic Simulator
The Cadence® Analyst™ 3D FEM EM analysis solver is based on the finite element method. As with any FEM field
solver, the basic steps include constructing the geometry, setting up boundary and source (excitation) conditions,
configuring the frequency and other solver options, and finally examining the mesh and simulation results. Before
performing the detailed procedures in this and subsequent chapters, it is important to acquire a general understanding of
how and when to use the Analyst software instead of the Cadence AXIEM® 3D planar EM analysis software.

AXIEM analysis is based on the method of moment (MoM). The algorithm implemented in AXIEM software limits its
application to 3D planar shapes. The term “3D planar” simply means that the shapes (geometries) are constructed in a
series of planes (parallel to the horizontal x-y plane) and extruded along the third dimension (vertical z-axis). The boundary
faces of all geometries have the normal direction either parallel or perpendicular to the z-axis. If the metal geometry you
want to model has a boundary face that is tilted against the z-axis (for example: bond wires, ball grid arrays, solder
bumps, connectors, waveguides, cavity resonators, and RF packages), then you should use Analyst software. In addition,
AXIEM analysis also assumes that the dielectric is uniform and extends to infinity along the x-y directions and piecewise
uniform along the z-direction. If you want to model a finite dielectric substrate (like a patch antenna), a finite dielectric
brick (like a dielectric resonator), a small air “void” (as beneath an inductor), or a multi-technology design (like a GaAs
chip on a PCB), then AXIEM analysis is not applicable. In addition, one of the reasons that the AXIEM solver is usually
more efficient than 3D FEM solvers is that it meshes and models only the conductors, not the dielectrics. However, if
the geometry contains many ground planes and conductor vias, the volume occupied by conductor is similar to that of
dielectric, the number of unknowns that AXIEM software needs to solve for might be similar to that of the FEM solver,
then Analyst software might be faster. Lastly, with the exception that AXIEM software offers certain port types that are
not directly supported in Analyst software (though conversion is possible), any AXIEM EM structure can be easily
converted to use the Analyst software simulator and you can compare the answers from MoM and FEM.

Another important consideration when comparing Analyst and AXIEM software is how to construct the geometry for
simulation in Analyst software. The Cadence AWRDesign Environment® platform offers many convenient and flexible
ways that have attracted increasing interest from designers:

1. 3D planar shapes can be constructed as a Cadence Microwave Office® software layout. You start with defining a
dielectric stackup, and then draw planar shapes on a series of planes (“drawing layers”). These planar shapes are
extruded along the z-direction through the definition of conductor thickness or via extension depth. The details of
constructing 3D planar layout are covered in theMicrowave Office Getting Started Guide chapters. Assuming that
you have constructed a 3D planar geometry in AXIEM (also called “AXIEM structure” or “AXIEM document”), you
can convert it into an “Analyst structure” (or “Analyst document”) in a few steps, as covered later in this chapter.

2. Geometries of a mixed technology design can be constructed by “lumping” together 3D planar shapes defined with
different underlying stackups (and more precisely, layer processing files (LPFs)) through “hierarchy”. Basically, you
place one structure (EM document) as the “subcircuit” or “child structure” of another structure (EM document). You
then align them by specifying the z-position of the bottom face of the “subcircuit”, as discussed in “ANA: Hierarchy
and 3D Parts in Analyst ”.

3. Several commonly used three-dimensional shapes can be placed into planar layout directly from within Microwave
Office. These are called 3D parameterized cells (“3D pCells”) that include bondwire, ball grid array (BGA), ribbon,
tapered via, QFN package, and others. Details for adding a bondwire p-cell are discussed in “ANA: Hierarchy and
3D Parts in Analyst ”.

4. You can use the Analyst 3D editor to draw 3D geometry. You can draw commonly seen primitive geometries (such
as spheres, cylinders, and cubes) directly, and Boolean operation of 3D shapes can be performed using the Analyst
3D Editor. See “Encapsulating the Chip and Bond Wires” for details.

5. You can place arbitrary 3D EM elements from user-customizable libraries into an Analyst structure. Sample elements
such as coaxial lines, SMA connectors and helical coil inductors are included in the AWR Design Environment
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platform installation. “ANA: Using Arbitrary 3D Structures in Analyst ” discusses the steps for including SMA in a
model. You can construct and add your own elements to the library; see the AWR Design Environment User Guide
for details. (The 3D pCells are different because they are constructed by calling codes compiled within Microwave
Office. The basic shape of a 3D pCell is fixed, while you can change values of certain dimensions (parameters).
Arbitrary 3D EM elements are constructed by executing recordable, user-modifiable scripts from Analyst 3D Editor.)

6. Three-dimensional geometries constructed in other software can be imported into an Analyst structure through
intermediate files (ACIS SAT file or STEP file). You need to define the material for individual shapes after importing.
Importing an example SAT file is discussed in “ANA: Importing SAT Files in Analyst ”.

7. The Layout > Copy to Arbitrary 3D EM Structure command provides an easy way to convert an EM structure constructed
in the Microwave Office EM Layout Editor into an arbitrary 3D structure that you can open and modify in the Analyst
3D Editor. Material, port, and boundary definitions are preserved. The 3D structure shows the effects of layer processing
and shape modifier rules. This feature is useful in various scenarios. For example, it is easier to examine in the Analyst
3D Editor whether there is any gap between the starting point of a bondwire and the contacting metal trace.

With these key points in mind, you are better prepared for the detailed steps in the following procedures. As you perform
the steps, consider why you are doing them and how you might design the user interface differently. This mindset allows
you to drive the software rather than simply following instructions. After getting your first result, you will start to ask
important questions such as how to obtain the best accuracy or fastest simulation speed. The best way to answer these
questions is to examine the examples and experiment with different port settings, boundary condition types, and solver
options. To get started, you need to know where these controlling parameters are set in the user interface.

Creating a Simulation for a Simple EM Structure
This example demonstrates how to set up a simulation for an Analyst 3D EM document. Basic setup concepts already
covered in previous chapters are not included, so you should familiarize yourself with these before starting.

This example includes the following main steps:

• Installing the Analyst 3D EM simulator

• Converting an AXIEM structure to an Analyst structure

• Properly configuring ports and the enclosure

• Viewing the initial mesh

• Running a simulation

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Opening an Existing Project

The example you create in this chapter is available in its complete form as Analyst_Basic_Finish.emp. To access this
file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project
dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the
dialog box.

To create a project:

1. Choose File > Open Example to locate and open the Analyst_Basic_Start.emp file.

2. Choose File > Save Project As. The Save As dialog box displays.
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3. Navigate to the directory in which you want to save the project, type "Analyst_GS_basic" as the project name, and
then click Save.

NOTE: Simulation results may vary slightly from the images in this guide. Finite Element Method (FEM) simulations
require a convergence based on a mesh refinement sequence. Slight changes in the mesh refinement between versions
of the solver can cause results to vary slightly. While the default convergence tolerance is sufficient for most geometries,
if you find results shift you can decrease the convergence tolerance to ensure that the results are accurate.

Converting the AXIEM Structure to Analyst

To convert the AXIEM structure to an Analyst structure:

1. Simulate the project to see the "AXIEM_Line" structure simulate. After simulation, view the data on the "S Parameters"
Smith Chart.

2. Select the "AXIEM_Line" EM structure in the Project Browser and choose Edit > Copy and Edit > Paste or press Ctrl
+ D to duplicate the structure. The new structure displays in a new window. Make sure you close this window.

3. In the Project Browser, right-click the copied EM document and choose Rename. Type "Analyst_Line" as the new
name and then click the Rename button.

4. In the Project Browser, right-click "Analyst_Line" and choose Set Simulator. In the Select a Simulator dialog box
select Analyst™ 3D EM - Async and then click OK.

Double-click the "Analyst_Line" EM structure. The Analyst structure displays as shown in the following figure.
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Like most finite element simulators, Analyst software requires well-defined boundary conditions and a 3D bounding
box. Analyst software also requires that you configure the top, bottom, and side enclosure boundary conditions for the
structure. A shape in the 2D layout defines the boundary size, then you edit the shape properties to specify the boundary
condition for each side of the boundary. Each Analyst structure has a default 2D rectangular boundary shape drawn with
the approximate open boundary conditions on each edge; you can edit the existing shape or add a new shape of any size.
This example draws a new boundary shape to replace the default boundary shape. The default height of this boundary
shape is specified in the enclosure and is defined in the stackup for this structure.

To draw a shape as the boundary:

1. With the "Analyst_Line" document window active, choose Draw > Rectangle.

2. With the cursor in the window, press the Tab key to display the Enter Coordinates dialog box, then type the values
show in the following figure and click OK.

3. Press the Tab key again and type the following values, then click OK. Note the Rel setting.

The layout displays as shown in the following figure.
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The new shape is automatically selected.

4. Choose Draw >Create 3D EMSimulation Boundary or click the Create Simulation Boundary button on the toolbar to create
a new boundary shape in the layout.

5. The layout displays as shown in the following figure.

Notice that there are two boundary shapes. Select the original boundary shape (which extends in the x-direction beyond
the end of the line) and press the Delete key.
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6. Select the remaining boundary shape, right-click and choose Shape Properties to open the Properties dialog box. Ensure
that the boundary conditions match this figure.

The layout displays as shown in the following figure.
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You can view the boundary conditions of the structure in the 3D view of the structure to verify that they are correct.

1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button
on the EM 3D Layout toolbar.

2. Click the ShowBoundary Conditions button on the EM 3DLayout toolbar. The layout displays the boundary conditions
as shown in the following figure.

3. Click the Layout tab to open the Layout Manager, then click the arrows on the right of the Visibility ByMaterial/Boundary
pane to open it.

You can turn off the visibility for specific materials. For example, when turning off the Approx Openmaterial, the 3D
layout displays without those boundary conditions visible.
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4. Click the Show Boundary Conditions button on the EM 3D Layout toolbar to turn off this display for the next several
steps.

Analyst software supports wave ports and lumped ports. Wave ports are generally preferred. You can attach wave and
lumped ports to shapes on or inside the simulation boundary.

To configure wave ports for this structure:

1. With the 2D Layout View window active, double-click a port.

2. In the Properties dialog box on the Port Attributes tab, make sure that Type is set to Wave and then click OK.
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3. Repeat these steps for the other port.

Running the Simulation

The Analyst structure is ready for simulation from 0.1 to 10 GHz in 1 GHz steps.

Before simulating, you can view the mesh in the 3D view of the structure. The first mesh you see is the initial solver's
mesh. As each additional Adaptive Mesh Refinement (AMR) step continues, the view of the mesh updates.

To view the mesh:

1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button
on the EM 3D Layout toolbar.

2. Click the Show 3D Mesh button on the EM 3D Layout toolbar. The layout displays as shown in the following figure.
This is the initial mesh of the structure with Perfect Conductor material turned off.
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Additionally, the display for the Air layer is turned off by default. You can turn it on in the LayoutManager by opening
the Visibility By Material/Boundary pane. The mesh is visible in the Air layer as shown in the following figure.

To simulate the structure:

1. Choose Simulate > Analyze or click the Analyze button on the toolbar. NOTE: Typically this simulation takes a few
minutes to run with no other programs competing for resources.
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2. The Simulation dialog box displays the status during simulation.

Click the down arrow icon on the right of the dialog box to display details about the simulation progress. The following
figure shows the output log from this simulation. You can watch each AMR sequence and see how close the simulation
is to converging. Simulation times and memory use vary by computer.
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3. As the simulation progresses, the mesh is refined. If the 3D layout is visible after viewing the mesh, you see the mesh
update after each AMR sequence. The following figure shows the mesh after the AMR sequence converges with the
Air layer visibility turned off.
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NOTE:While the simulation is running you can continue this exercise as the Analyst simulator is asynchronous, like
the AXIEM simulator.

It is useful to know how to use cut planes when viewing information such as mesh, boundary conditions, and E-fields
in the EM structure 3D view.

To use a cut plane:

1. Open the 3D layout of the structure by choosing View > View 3D EM Layout or by clicking the View EM 3D Layout button
on the EM 3D Layout toolbar.

2. Click the Use Cut Plane button on the toolbar and ensure that the Show Cut Plane button is also pressed. The following
figure shows a plane that cuts the structure where the information is drawn on one side and removed from the other
side.

3. Click and drag on the cut plane to move its position. Click and drag on the arrows at the end of the line through the
cut plane to change the orientation. Use the x, y, or z keys to move the cut plane in that orientation and make the plane
orthogonal to that plane. If this is not obvious, move the cut plane to an odd angle by moving the arrow that extends
beyond the plane, and then use these keys to observe the cut plane.

To view simulation results:

1. In the Project Browser, right-click the "AXIEM_Line:S(2,1)" measurement on the "S Parameters" graph and choose
Duplicate to display the Modify Measurement dialog box.

2. Change the Data Source Name to "Analyst_Line" and then click OK.

3. Repeat these steps for the "AXIEM_Line:(S(1,1)" measurement.

4. After the simulation is complete you might need to resimulate the project to update the graph data. Note that the
structure does not resimulate because nothing has changed.
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Double-click the "S Parameters" graph in the Project Browser. When the graph data is updated, the graph displays similar
to the following figure.
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Some structures with iterative solvers (like FEM solvers) might have two sets of S-parameters between AMR iterations
that can be close enough to one another to satisfy the convergence criteria. In actuality, the mesh may not have refined
enough to catch certain behaviors. If this occurs, you can lower the convergence criteria to force the simulator to take
more AMR iterations to try to capture this behavior, although this restarts the simulation from AMR iteration 1.

Another possibly more efficient way than lowering the convergence tolerance and simulating the entire structure again,
is to force the simulator to run one more AMR iteration to ensure that the simulation did converge. This simulation starts
where the last simulation ended and does not need to simulate the prior AMR iterations.

To run one more AMR iteration, right-click the "Analyst_Line" EM structure and choose Refine Solution. A simulation
starts on the next AMR iteration.

You can refine the solution multiple times if the results shift. This potentially saves a lot of time re-running full simulations
after lowering the convergence tolerance.

For this particular structure the results don't really change so you know the solution has converged.
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Chapter 4. ANA: Hierarchy and 3D Parts in Analyst
Hierarchy is a powerful concept when using Cadence® Analyst™ 3D FEM EM analysis software in the Cadence AWR
Design Environment® platform. By using hierarchy, you can greatly simplify a dielectric stackup setup. Each EM
document can have its own dielectric stackup. When you combine them using hierarchy (one is added as a subcircuit to
the other), you only need to specify the appropriate location in the Z direction, and the program properly simulates the
combined dielectric stackup of both structures, effectively combining the stackups. This approach offers these advantages:

• You do not have to define one complete (and sometimes complicated) dielectric stackup for your entire structure,
typically before you add any geometry.

• You can easily add more dielectric layers at later stages in the structure simulation process.

Building a Hierarchical Simulation
This chapter is a continuation of “ANA: Using the Analyst 3D Electromagnetic Simulator ”. If you have not completed
that example please do so before continuing here, as it includes concepts that may not be discussed in this example.

This chapter demonstrates how to build hierarchical simulations in the Analyst simulator as well as using predefined
parameterized cells in the geometry.

The example in this chapter includes the following main steps:

• Setting up a hierarchical design

• Adding bond wire 3D parameterized cells (pCells)

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Opening an Existing Project

The example you create in this chapter is available in its complete form as Analyst_Hierarchy_Finish.emp. To access
this file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project
dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the
dialog box. This example is a continuation of the previous Analyst chapter.

To open an existing project:

1. Choose File > Open Example to locate and open the Analyst_Basic_Finish.emp file.

2. Choose File > Save Project As. The Save As dialog box displays.

3. Navigate to the directory in which you want to save the project, type "Analyst_GS_hierarchy" as the project name,
and then click Save.

NOTE: Simulation results may vary slightly from the images in this guide. Finite Element Method (FEM) simulations
require a convergence based on a mesh refinement sequence. Slight changes in the mesh refinement between versions
of the solver can cause results to vary slightly. While the default convergence tolerance is sufficient for most geometries,
if you find results shift you can decrease the convergence tolerance to ensure that the results are accurate.

Creating an Analyst EM Structure

To create an Analyst EM structure:
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1. Right-click the EM Structures node in the Project Browser and choose New EM Structure. (Alternatively, choose Project
> Add EM Structure > New EM Structure or click the Add New EM Structure button on the toolbar).

2. In the New EM Structure dialog box, type "PCB" as the structure name, select Analyst™ 3D FEM - Async as the
simulator, select From Stackup under Initialization Options, select PCB as the Stackup, and then click Create.

NOTE:The STACKUP element named "PCB" in the Global Definitions contains all of the setup for this EM structure
so this example can focus on Analyst-specific topics.

An EM structure layout window displays.

3. In the Project Browser, double-click the Enclosure node under the "PCB" EM structure to display the Element Options
- ENCLOSURE Properties dialog box. Set theGrid_X andGrid_Y to "1" mil to set the drawing grid for the EM document
(it has no impact on the Analyst software simulation).

By default, a square boundary shape is added when the structure is created. To configure the boundary for this example:

1. Make the 2D Layout View window active (it should be the active window after creating the EM document).

2. Double-click the boundary shape to enter edit mode. Diamonds/squares display at the vertices and mid-points of each
boundary edge as shown in the following figure.
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3. While clicking and dragging the upper right corner of the square, press the Tab key. In the Enter Coordinates dialog
box, type the values shown in the following figure to make a boundary shape that is 750 x 500 mil. Note that the Rel
check box is NOT selected.

4. Right-click the 2D layout and choose View All to see the entire boundary shape.

5. Select the boundary shape, right-click and choose Shape Properties to display the Properties dialog box. Click the
Boundary Conditions tab and ensure that the settings match those in the following figure.
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The Use Side Boundary check box forces each side of the shape to use the same setting as the Side Boundary setting.
If you clear this check box, you can specify the boundary condition for each side of the boundary shape. NOTE: You
can also set boundary information in the Element Options - ENCLOSURE Properties dialog box by double-clicking
the Enclosure node under the EM document name in the Project Browser and clicking the Boundary Conditions tab.

6. Right-click the "PCB" EM structure in the Project Browser and choose Options to display the Options dialog box,
then click the Frequencies tab. Notice that the frequency range is already set with the values copied from the project
frequencies. The Mesh and Analyst tabs have options for changing mesh or Analyst solver options if needed.

You now need to add the "Analyst_Line" EM document to the "PCB" EM document. To build hierarchy for this example:

1. Click the Layout tab to open the Layout Manager, then click to open the EM Layers pane.

2. To set the initial Z location of the subcircuit, ensure that EM Layer is set to "2".

3. With the "PCB" EM structure layout window active, choose Draw > Add Subcircuit to open the Add Subcircuit Element
dialog box. Select "Analyst_Line" and then click OK.

4. You can now place the subcircuit anywhere in the layout. Press the Tab key to display the Enter Coordinates dialog
box and type the following values, then click OK. Note the Rel setting.
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Click OK to place the subcircuit in the middle of the current boundary condition area.

5. View the 3D layout of the "PCB" structure by right-clicking the structure in the Project Browser and choosing View
EM 3D Layout.
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Note that the line layout is sitting on the top of the substrate layer in the new structure.

6. You can easily control the Z location of the subcircuit. To move the line to the bottom of the substrate, select the line
in the 2D layout, right-click and choose Shape Properties to display the Cell Options dialog box.

7. On the Layout tab, in the Z Position section, change the EM layer to Bottom boundary.

The "Analyst_Line" subcircuit now displays on the bottom of the substrate as shown in the following figure.
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8. Reset the subcircuits layer back to "2". You can edit the properties or just choose Edit > Undo.

You can now draw the ground pad for the chip to sit on, and the lines feeding up to the chip.

1. With the "PCB" structure 2D Layout View window active, click the Layout tab to open the Layout Manager, then
click to open the Drawing Layers pane.

2. With the Copper layer selected, choose Draw > Rectangle. Press the Tab key to display the Enter Coordinates dialog
box and type the following values, then click OK.

Press the Tab key again and type the following values, then click OK. Note the Rel setting.

A shape displays under the line as shown in the following figure.
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3. Select the Via layer and then choose Draw > Ellipse. Click anywhere in the 2D Layout ViewWindow and press the Tab
key to display the Enter Coordinates dialog box. Enter 4 as the dx coordinate and 4 as the dy coordinate, select Rel,
and then click OK to create a 4 x 4 via. Next, drag the via under the line grounding pad as shown in the following
figure. The exact placement is not critical for this example, but the via should be some distance from the edge.

4. Select the via and type Ctrl + C and then Ctrl + V to copy and paste the via. Paste three vias under the line ground pad
as shown in the following figure.
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5. To construct the microstrip feed lines, with the Copper layer selected, choose Draw > Rectangle. Press the Tab key to
display the Enter Coordinates dialog box and type the following values, then click OK.

Press the Tab key again and type the following values, then click OK. Note the Rel setting.

A shape now leads up to the line as shown in the following figure.

6. Copy and paste this shape to the other side of the line as shown in the following figure. Ensure that the line is perfectly
aligned with the right edge of the boundary shape. This is necessary to enable using a wave port on this shape.
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7. Choose Edit > Auto Repeat and then choose Draw > Add Edge Port. Move the cursor to the left edge of the left-most
shape until the port symbol displays, as shown in the following figure, then click to place the port. Move the cursor
to the right edge of the right-most shape until the port symbol displays, then click to place the port. Press Esc to exit
Auto Repeat mode.

8. Double-click each port and in the Properties dialog box change the port Type toWave. You can also choose Edit > Port
Properties to edit both ports at once. See the Analyst User Guide for information about the differences in port types.

The 2D and 3D layout of the structure should display as shown in the following figures.
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Adding a 3D Parameterized Cell (Bond Wires)

The next step is to add bond wires between the chip and the PCB. To do so, you can use a bond wire model from the 3D
EM Elements libraries.

To add the bond wires:

1. Click the "PCB" EM structure 2D layout window to make it active.

2. In the Elements Browser, under 3D EM Elements, expand the Libraries category and then click the AWR web site >
Interconnects subgroup. Select the Bondwire model and place it in the "PCB" EM structure as shown in the following
figure.
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As with the subcircuit, the bond wire is placed at the Z location specified by the current EM layer. You can change
the shape properties of the item to move up and down in the Z direction.

The following figure shows the 3D view of the bond wire on the chip.

3. To configure the loop characteristics of the wire, select the wire in the 2D layout, right-click and choose Element
Properties to display the Element Options - BWIRES dialog box. Verify that your settings match those in the following
figure.
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The heights set for the bond wire parameters are relative from the layer set for the 3D pCell. In a previous step you
set the wire on EM layer 2, so the heights are set as heights above layer 2 in the "PCB" stackup.

4. To place an identical wire on the other side of the structure, in the 2D layout, select the bond wire and choose Edit >
Copy and then Edit > Paste. Ctrl + right-click twice to flip the wire about the y-axis so that the high end is on the line.

5. Move the cursor over the other end of the line and click to place the line as shown in the following figure. It helps to
have both the 2D and 3D layouts visible to ensure that you have the correct end of the pasted bond wire on the chip.

The 3D view now shows the wires on both sides of the chip.

Getting Started Guide 4–13

Building a Hierarchical Simulation



6. To ensure that all elements are connected properly and there are no gaps in between, you can view the colored mesh.
To do so, with the "PCB" EM structure 3D view active, click the ShowMesh Connectivity button on the EM 3D Layout
toolbar. The shapes with the same color are electrically connected.

The following figure shows the 3D view after the color meshing is turned on. Note that everything is connected
properly.
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Chapter 5. ANA: Using Arbitrary 3D Structures in Analyst
There are many ways to use 3D geometries in the Cadence® Analyst™ 3D FEM EM analysis software. As shown in
the previous chapter, you can use built-in parameterized cells like a bond wire. You can also use components that are
vendor-defined and hosted on the web via XML. It is also possible to create your own static or parameterized 3D
components in the Cadence AWR Design Environment® platform 3D Editor. With the number of options available for
creation/use, a 3D geometry structure set up becomes very easy.

Creating and Importing 3D Structures
This chapter is a continuation of “ANA: Hierarchy and 3D Parts in Analyst ”. If you have not completed that example
please do so before continuing here, as it includes concepts that may not be discussed in this example.

In this example you attach an SMA connector to the board and also cover the bond wires and chip area with a dielectric
material. The SMA connector is a predefined structure designed in the AWR Design Environment platform 3D Editor.
As part of this example you create a structure in the 3D Editor for the dielectric encapsulant.

This example includes the following main steps:

• Connecting the SMA connector to the board

• Using dielectric bricks to encapsulate the bond wire

• Running the full structure simulation

• Viewing results and E-fields

• Simplifying the structure to simulate just the SMA connector

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the program. Choose Help > Quick Reference to access this document.

Opening an Existing Project

The example you create in this chapter is available in its complete form as Analyst_Arbitrary_Finish.emp. To access this
file from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project
dialog box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the
dialog box. This example is a continuation of the previous Analyst chapter.

To open an existing project:

1. Choose File > Open Example to locate and open the Analyst_Hierarchy_Finish.emp file.

2. Choose File > Save Project As. The Save As dialog box displays.

3. Navigate to the directory in which you want to save the project, type "Analyst_GS_arbitrary" as the project name,
and then click Save.

NOTE: Simulation results may vary slightly from the images in this guide. Finite Element Method (FEM) simulations
require a convergence based on a mesh refinement sequence. Slight changes in the mesh refinement between versions
of the solver can cause results to vary slightly. While the default convergence tolerance is sufficient for most geometries,
if you find results shift you can decrease the convergence tolerance to ensure the results are accurate.
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Adding the SMA Connector

You now add the SMA connectors to the "PCB" EM structure. Another level of hierarchy is used so you can simulate
the chip and board itself, and then simulate the same structure with the SMA connectors to see the impact the connectors
have on the overall circuit performance. To add the SMA connectors to the board:

1. Right-click the EM Structures node in the Project Browser and choose New EM Structure. (Alternatively, choose Project
> Add EM Structure > New EM Structure or click the Add New EM Structure button on the toolbar) to display the New
EM Structure dialog box.

2. Type "SMA" as the structure name, select Analyst™ 3D EM - Async as the simulator, select From Stackup as the
Initialization Options, select AIR as the Stackup, and then click Create.

3. With the 2D Layout View window active, double-click the boundary shape to enter edit mode. Diamonds/squares
display at the vertices and mid-points of each boundary edge.

4. Click and drag the upper right corner of the square and press the Tab key. In the Enter Coordinates dialog box, clear
the Rel check box, and enter the values to make a boundary shape that is 750 x 500 mil, then click OK.

5. Right-click the 2D layout and choose View All to see the entire boundary shape.

6. Select the boundary shape, right-click and choose Shape Properties to display the Properties dialog box. Click the
Boundary Conditions tab and ensure that the settings match those in the following figure.
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7. You now add the "PCB" EM document to the "SMA" EM document.

With the "SMA" EM structure layout window active, choose Draw > Add Subcircuit to open the Add Subcircuit Element
dialog box. Select "PCB" and then click OK.

8. Place the subcircuit inside the boundary. You can press the Ctrl key while doing so to align the subcircuit with the
boundary.

Getting Started Guide 5–3

Creating and Importing 3D Structures



9. Select the "PCB" subcircuit, right-click, and choose Shape Properties to display the Cell Options dialog box. Under
Z Position, change the EM layer to 3-Air.
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10. Choose View > View 3D EM Layout to see a 3D view of the "SMA" EM structure as follows.

11. With the 2D view of the "SMA" EM structure active, in the Elements Browser under 3D EM Elements, expand the
Libraries category and then click the AWR web site > Connectors > SMA subgroup. Select the SMACONFIG model and
place it in the "SMA" EM structure.

12. Press the Tab key while dragging SMACONFIG into the "SMA" EM structure, enter the following values in the Enter
Coordinates dialog box, then click OK.

The following figure shows the 2D view of the "SMA" EM structure.
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13. Select the SMACONFIG model, then right-click and choose Element Properties to display the Element Options:
SUBCKT - Properties dialog box. Verify that your settings for ContactType, GndTabUpVoff, and GndTabLowVoff
match those in the following figure and then click OK. All the other values remain at defaults.

14. Right-click the 2D SMACONFIG layout again and choose Shape Properties to display the Cell Options dialog box.
Under Z Position, make sure the EM layer is set to 2-Air.
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15. Copy the SMACONFIG element and paste it on the other side of the EM structure. After rotating the structure press
Tab, clear the Rel check box and enter "802" for X and "250" for Y.

16. Choose Draw > Add Edge Port and hover the cursor near the edge of the center conductor of the left SMA until the port
outline displays. Click to place the port. Repeat this step for the right port. When you are done the 2D view should
look like the following figure:

17. The following figure shows the 3D view of the "SMA" EM structure.
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18. To ensure that everything is connected properly, in the 3D view of the "SMA" EM structure, click the Show Mesh
Connectivity button on the toolbar. The following figure shows the 3D view after the mesh connectivity is turned on.

NOTE:Conducting boundary conditions propagate through hierarchy, so the ground plane from the PCB EM structure
is present in the SMA EM structure as seen with the mesh connectivity.

Adding Solder Pads

Before simulating, a more realistic design of this structure would include the solder pads for the SMA connection. You
can add four copper shapes and vias at the same level of hierarchy as the SMA connectors. The final project includes
these solder pads as shown in the following figure.

To add the solder pads and vias:

1. Open the 2D Layout View of the "SMA" EM structure and click the Layout tab to open the Layout Manager.
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2. Select the Copper drawing layer and start to draw a rectangle by pressing CTRL + B or by choosing Draw > Rectangle.

3. Press the Tab key to display the Enter Coordinates dialog box, then enter the values shown in the following figure
and click OK.

4. Press the Tab key again and enter the size of the rectangle. Note the Rel setting.

5. Select the Via drawing layer and choose Draw > Circle, then press the Tab key to display the Enter Coordinates dialog
box. Enter "30" for x and "82" for y and then click OK.

Press the Tab key again and enter "15" for R.

Copy the via and paste two more vias 60 mils apart. When pasting you can press the Tab key to enter coordinates and
space the vias evenly. When you are done the layout should display as shown in the following figure.

6. Copy the solder pad and all three vias and paste them in the appropriate positions under the SMA flanges. When you
are done the 2D layout should display as shown in the following figure.
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Simulating the Entire Structure

Now that the solder pads and vias are added, it is time to simulate the structure.

To visualize the E-fields for this structure after the simulation is complete you need to set certain options. To set up the
structure to save E-field information:

1. Right-click the "SMA" EM structure in the Project Browser and choose Options to display the Options - SMA dialog
box, then click the Analyst tab.

2. Change the Field Output Frequency to AMR Frequencies Only, then click OK.
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3. Click the Show Currents/Fields button on the EM 3D Layout toolbar to display the fields on a cut plane. As each AMR
sequence finishes, the E-field display updates.

4. With the SMA EM structure 3D view window active, click the Show 3D Mesh button on the toolbar to view the mesh
of the structure and watch it update at each AMR step. (NOTE: To ensure that your project matches this example,
your toolbar should display as shown in the following figure, specifically the activation of the Show Cut Plane and
Use Cut Plane buttons.

The following figure shows the initial mesh with the cut plane off to the side.

5. Choose Simulate > Analyze or click the Analyze button on the toolbar to start the simulation. NOTE: Typically, this
simulation takes about 10 minutes to run with no other programs competing for resources. While the simulation runs
you can configure a graph to display results from the new simulation.

To create a graph:

1. Right-click the Graphs node in the Project Browser and choose New Graph.

2. Name the graph "SMA", select Smith Chart as the graph type, and click Create.

3. Right-click the new graph and choose Add NewMeasurement to add "S11" to the graph. Verify that your settings match
those in the following figure.
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4. When the simulation is complete, the graph data displays as shown in the following figure.
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You can see the finished solution E-field display in the 3D layout. With the 3D Layout View active, press the y key to
move the cut plane to the y plane. The annotations display similar to the following figure.
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To see the fields in the structure behind the metal, click and hold on the cut plane and it displays the fields hidden behind
the metal.

You can view the mesh and E-field data for each AMR sequence during simulation or after the simulation is complete.
To view each AMR sequence result:

1. With the "SMA" EM structure 3D layout window active, expand the Data Sets node in the Project Browser and then
expand the SMA subnode. The current data set for this EM structure displays with a green icon and you can also expand
it. The data sets below it are for each AMR sequence run in the simulation.
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2. Shift-click a sub data set to show the mesh and E-fields for that AMR sequence. Note that the E-field does not display
for the port-only AMR sequences. These display a small "P" on the data set icon and are the lowest in the list.

Configuring for Transition Simulation Only

In the previous example, you simulate the SMA, PCB, and the chip as an entire structure. You may, however, want to
simulate only a subset of the geometry drawn. In this example, you look at the response of the SMA to see how it affects
when adding it to the network. You can do so by moving the boundary shape and configuring ports; you do not need to
alter the original geometry.

For Analyst software simulation, only shapes inside the boundary are simulated. so you can simulate only parts of your
geometry without needing to edit much on the full geometry of your structure. In the following step you only simulate
one of the SMAs using the current geometry setup.

The first step is to duplicate the structure already created. To duplicate this structure:

1. Right-click the "SMA" EM structure and choose Duplicate. A new EM structure named "SMA 1" displays in the
Project Browser.

2. Right-click "SMA 1" and choose Rename EM Structure. In the Rename EM Structure dialog box, name the structure
"SMA_Simplified", then click Rename.

3. With the "SMA_Simplified" window active, double-click the boundary shape to enter edit mode (diamonds/squares
display on each vertex and edge mid-point).

4. Click and hold the mid-point of the right boundary shape and drag it towards port 1 as shown in the following figure.
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5. As you get closer to port 1, press the Tab key and enter the following values. Make sure the Rel box is selected.

6. Select the Copper drawing layer and choose Draw > Rectangle. Press the Tab key to display the Enter Coordinates
dialog box and type the following values, then click OK.

7. Press the Tab key again and type the following values, then click OK. Note the Rel setting.

8. Delete port 2 on the right side. Choose Draw > Add Edge Port to add a port to the right edge of the rectangle created
in the previous step. After you add the port, double-click it and change the Type from Lumped Down to Wave.
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9. Even though the boundary shape is not touching the SMA on the right, that SMA is simulated with the current setup.
You can prevent this by right-clicking that SMA and choosing Shape Properties, then selecting the Clipped by simulation
boundary check box in the Cell Options dialog box.

10. Observe the connectivity mesh before simulating.
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11. Run the simulation.NOTE:: Typically, this simulation takes several minutes to run with no other programs competing
for resources.

While the simulation runs, add the S11 measurement to the "SMA" graph to see the response of this circuit when the
simulation completes. The "SMA" graph should display similar to the following figure.
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Encapsulating the Chip and Bond Wires

The next step is to encapsulate the chip and bond wires with a dielectric material. In previous steps you imported an
arbitrary 3D EM structure, the SMA connectors. Now you are going to create an arbitrary 3D EM structure and use it in
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this design. The encapsulant is parameterized such that after creation you can specify the parameters on the subcircuit
of the EM document rather than modifying the geometry in the AWR Design Environment platform 3D Editor.

The encapsulant is an extremely simple parameterized 3D EM structure but it is possible to create fully parameterized
EM structures with complex geometries such as the SMA connector used in this example. To see different examples of
parameterized EM structures, browse the 3D EM Elements in the Elements Browser.

To create the encapsulant:

1. Right-click the EM Structures node and choose New Arbitrary 3D EM Structure to display the New 3D EM Structure
dialog box.

2. Type "Encapsulant" as the structure name, select Analyst™ 3D EM - Async as the simulator, select From Stackup under
Initialization Options, select AIR as the Stackup, and then click Create.

3. Right-click the "Encapsulant" EM structure and choose Open in 3D Editor. The AWR Design Environment platform
3D Editor opens.

4. On the Home ribbon in the Settings group, click Units to display the Working Units dialog box.

5. Change the Length units to mil and click OK.
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6. On the Structure ribbon, in the Entity Creation group, click Draw Entity and choose Box.

7. Press the Space bar to display the Edit Properties dialog box. Set Material to <New>.

8. In the Edit Properties dialog box for the new material, specify the Label as "BCB", and set the Relative Permittivity (Er)
to "2.65", then click OK.
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9. In the Edit Properties dialog box for the new box, specify the Label as "Encapsulant", set Corner to "0, 0, 0", and then
for Extent, type "length, width, height", then click OK.

The BCB material is included in the list of materials that you can use on other shapes.

10. Set the values of the variables in the Variables window (click the Variables tab at the bottom left of the main window
by default, or on the Window ribbon in the Controls group, click Control Visibility and choose Variables to display the
Variables window). Set length to "70 mil", width to "64 mil", and height to "20 mil", then click the Apply button to
accept the changes. Note that you must type "mil" in the expression. This flexibility allows you to enter values in
units besides the current drawing unit.

When complete, the Variables window should match the following figure.

5–20 AWR Design Environment

Creating and Importing 3D Structures



11. Press the Fit button on the toolbar. Alternatively, press F, the default hotkey for the Fit command.

The dielectric brick should display as shown in the following figure:

12. To make the dielectric a more realistic shape, you need to fillet the box to soften the corners. To soften the shape, on
the Structure ribbon in the Entity Modification group, click Modify Solids and choose Fillet Edges.

The box becomes transparent, except for the edges, to allow you to select which edges you want to soften.

13. Click an edge to add it to the group of edges to alter. When selected, the edge displays in red.

14. Select the following edges and then press Enter to display the Edit Properties dialog box.
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15. Specify the Label as "EdgeFillet" and the Radius as "radius", then click OK.

16. In the Variables window, set the Expression of the new radius variable to "20 mil" and click Apply.

17. The final step in creating a parameterized arbitrary 3D EM structure is to set the variables to export from the AWR
Design Environment platform 3D Editor into the AWR Design Environment software. In the Variables window, click
the Export check box for each of the four variables that define this structure.

18. When defining a parameterized EM structure you should constrain the variables that define the structure. Enable
constraints for each variable and set the values to match those in the following figure.
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When complete, the final structure should display as shown in the following figure.

19. Click the Save button on the toolbar and then exit the AWR Design Environment platform 3D Editor. Upon closing
the 3D editor, the changes to the "Encapsulant" EM structure are sent to the AWR Design Environment software.

20. Open the 2D Layout View of the PCB EM structure and add the encapsulant by choosing Draw > Add Subcircuit and
selecting Encapsulant. Press the Tab key to enter the coordinates as shown in the following figure.

21. Right-click the encapsulant in the 2D layout and choose Shape Properties.

22. In the Cell Options dialog box under Z Position, set the EM layer to "2". The encapsulant covers the chip and the bond
wires.
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23. Select the Clipped by simulation boundary check box and then click OK.

24. To see what is in the encapsulant, in the Layout Manager Visibility By Material/Boundary pane, set the Opaque value
for the BCB material to "0.5".

25. Change the height of the encapsulant. From the 2D layout of the PCB EM structure, right-click the encapsulant and
choose Element Properties to display the Element Options dialog box. Change the height to "5" and the radius to "5",
then click OK. The bond wires extrude from the dielectric with these settings.

26. Change both the height and radius to "10" so the bond wires do not extrude from the dielectric.
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Chapter 6. ANA: Importing SAT Files in Analyst
In addition to the geometry creationmechanisms covered in previous Cadence®Analyst™ 3D FEMEManalysis chapters,
there is another mechanism, importing Standard ACIS Text (SAT) files, that you can take advantage of to create a
structure. SAT files are a commonly used file format to transfer 3D geometries between tools. Product vendors often
provide SAT files of their products for convenience.

Using a Custom Housing to Enclose the PCB
This chapter is a continuation of “ANA: Using Arbitrary 3D Structures in Analyst ”. If you have not completed that
example please do so before continuing here, as it includes concepts that may not be discussed in this example.

In this example you replace the SMA connectors that are attached to the PCBwith a custom housing. The custom housing
is a three-dimensional geometry that is pre-defined in a SAT file. SAT files define the geometry of a structure but have
no concept of the materials that comprise the structure. Materials and ports must be assigned to the structure to make it
ready for simulation.

This example includes the following main steps:

• Importing the SAT housing

• Assigning materials to the structure

• Running the full structure simulation

NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the Cadence AWR Design Environment® platform. Choose Help > Quick Reference to access this document.

Opening an Existing Project

The example you create in this chapter is available in its complete form as Analyst_SAT_Finish.emp. To access this file
from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog
box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog
box. This example is a continuation of the previous Analyst chapter.

To open an existing project:

1. Choose File > Open Example to locate and open the Analyst_Arbitrary_Finish.emp file.

2. Choose File > Save Project As. The Save As dialog box displays.

3. Navigate to the directory in which you want to save the project, type "Analyst_GS_SAT" as the project name, and
then click Save.

NOTE: Simulation results may vary slightly from the images in this guide. Finite Element Method (FEM) simulations
require a convergence based on a mesh refinement sequence. Slight changes in the mesh refinement between versions
of the solver can cause results to vary slightly. While the default convergence tolerance is sufficient for most geometries,
if you find results shift you can decrease the convergence tolerance to ensure the results are accurate.

Importing the Housing

You can only import or modify SAT files in the AWR Design Environment platform 3D Editor. To import the SAT
housing:
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1. Right-click the EM Structures node in the Project Browser and choose New Arbitrary 3D EM Structure (alternatively,
choose Project > Add Arbitrary 3D EM Structure > New Arbitrary 3D EM Structure) to display the New 3D EM Structure
dialog box.

2. Type SAT_Housing as the structure name, select Analyst™ 3D EM - Async as the simulator, select From Stackup as the
Initialization Options, select AIR as the Stackup, and then click Create.

3. Right-click the “SAT_Housing” EM Structure and choose Open in 3D Editor.

Next you define the materials that comprise the housing. Copper is a default material in the list and is used for the
metal of the housing. The dielectric of the coaxial inputs is Teflon.

4. In the AWR Design Environment platform 3D Editor, right-click the Materials node in the Browser and choose New
Material. Type "Teflon" as the Label, "2.1" as the Relative Permittivity, and "0.0004 as the Electric Loss Tangent. Verify
that your settings match those in the following figure.
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5. On the Structure ribbon in the Entity Creation group, click Import Entities and choose Import Entities (SAT, IGES, STEP,
etc).

6. In the File Open dialog box, browse to the Analyst_SAT_Finish_Housing.sat file in the \Examples directory. If you
installed in the default location this path is similar to C:\Program Files (x86)\AWR\AWRDE\22.1\examples\.

If you used a different installation path, you can locate the \Examples directory by choosing Help > ShowFiles/Directories
in the program and then double-clicking the Examples folder.

The imported housing displays as follows:
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Assigning Materials to the Structure

You now assign materials to the housing structure. In the previous step you imported the geometry of the housing into
the 3D editor. When imported, the material for each section of the geometry is by default set to “Air”. In this example
you set the coax dielectric to “Teflon”, and both the housing and center conductors to “Copper”. You also add the ports.

1. In the Geometry node of the Browser, select Imported_1. The left dielectric of the coax is highlighted.

2. Change the Material from Air to Teflon.
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The 3D view displays as follows.

3. Repeat these steps for the right dielectric by selecting Imported_2 and changing the Material to Teflon.

4. Select Imported_3. The right center conductor of the coax is highlighted.

5. Change the Material from Air to Copper.
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6. Repeat this step for the left conductor and the housing by selecting Imported_4 and Imported_5 and changing theMaterial
to Copper.

7. Click the Geometry node to display the full structure, and then click the Fit button on the toolbar or press the F key.

The materials for the housing are now set and the 3D view should display as shown in the following figure.

8. To add the ports to the structure, view the structure from the left side. You can rotate the structure by clicking the
middle mouse button and moving the cursor (alternatively, click the Rotate button on the toolbar or press the R key).

You can also change the camera view by clicking the Next Camera View button on the toolbar and choosing Left from
the drop-down menu.
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9. In the Geometry node of the Browser, select Imported_4 to highlight the left conductor.

10. On the Structure ribbon in the Attributes group, click Apply New and choose Port.

11. Click the face of the conductor to apply the port to it, then press Enter. The Port Properties dialog box displays. The
default settings for the port are sufficient so just click OK.

The 3D view of the structure from the left should display as shown in the following figure.
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12. Repeat these steps for the right side to add the second port. When complete, the housing should display as shown in
the following figure.
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13. Click Save and close the AWR Design Environment platform 3D Editor to transfer the Geometry to the program.

Simulating the Structure

The next step places the PCB structure in the housing and set up the structure for simulation. You add the housing and
the PCB as subcircuits in another top level EM structure. The hierarchical design style that is used in the Analyst Getting
Started Guide examples is a powerful way to compare variations of structures that have portions of the structure that do
not vary. In this example you previously simulated the PCB structure with edge launch SMA connectors and now you
can compare the results with the PCB structure in a custom housing. While this example is simple, it is meant to illustrate
the concept of a hierarchical 3D EM design style.

1. In the Project Browser, right-click the EM Structures node and choose New EM Structure to display the New EM
Structure dialog box.

2. Type "Housing" as the EM Structure name, select Analyst™ 3D EM - Async as the simulator, select AIR as the Stackup,
and then click Create.

3. In the 2D layout of the “Housing” EM structure, double-click the Enclosure. The edit diamonds display.

4. Click the top right edit diamond and begin to drag it. Press the Tab key to display the Enter Coordinates dialog. Clear
the Rel check box and enter "750" for x and "500" for y then click OK.

Getting Started Guide 6–9

Using a Custom Housing to Enclose the PCB



5. Choose Draw > Add Subcircuit and select PCB.

6. Press the Ctrl key to help align the PCBwith the enclosure boundary. Right-click the subcircuit of the PCB and choose
Shape Properties. Make sure that the PCB Z Position has an EM layer of 3, then click OK.

7. Repeat the previous step, but choose the "SAT_Housing" instead of the PCB and set the EM layer to Bottom Boundary
instead of 3.

8. In the 2D layout view of “Housing”, choose Draw > Add Edge Port to add a port to the left end of the SAT_Housing
coax. Repeat this for the right end as well.

The 3D view should display as shown in the following figure.

9. With the 3D layout view active, add a cut plane by clicking the Use Cut Plane button on the toolbar and then mesh the
structure by clicking the Show 3D Mesh button on the toolbar (alternatively, right-click the EM structure and choose
Mesh).

10. Click the ShowMesh Connectivity button on the toolbar. The 3D view should display as shown in the following figure.
The colors, representing electrical connectivity, may vary from the figure.
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11. Right-click the Graphs node and choose New Graph. In the New Graph dialog box, type Housing as the graph name,
select Smith Chart as the graph type, and then click Create.

12. Right-click the new graph and choose Add New Measurement to display the Add/Modify Measurement dialog box.

13. Add "S11" to the graph. Verify that your settings match those in the following figure.

14. Right-click the "Housing" EM structure and choose Simulate. When the simulation is complete, the "Housing" graph
should display as shown in the following figure.
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