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Migration Issues
The following are issues you need to address when migrating from a Cadence®AWR®Analyst™ 3D FEMEM analysis
v14 release to an Analyst v15 software release. Not all topics apply to every user. If you are not familiar with a topic or
program feature included here, it probably does not apply to your use of the software. You should read about all of the
issues before developing your migration strategy. You can contact <Technical Support for AWR Products>
with any questions.

Analyst v15-Specific Migration Issues

Operating System

NOTE: Cadence® AWR® Analyst™-MP multi-physics simulator v15 software no longer supports Windows 7 and
Windows Server 2008 R2 operating systems.

Command Line Arguments

Using a "-" character for analyst.exe command line arguments is no longer supported. Please use a "/" character as
indicated in Analyst software documentation (for example, analyst.exe /python=...).

Remote Linux Simulation Changes (Analyst-MP Only)

Licensing

v15 requires you to check out the LSF_001 license feature in order to run remote Linux simulations. If this feature is not
checked out, all such simulations fail immediately. The user is responsible for configuring Analyst software to check
out this feature. See “Configuring Licensing Information” for details.

Prior Analyst Software Versions

If you wish to continue using prior versions of Analyst software on Linux, AWR® recommends not removing any settings
that these versions rely on. See the Analyst software documentation for these prior versions for those requirements. Note
that any such requirements (for example, environment variables or Torque/LSF settings) do not interfere with v15.

New Requirements in Version 15

1. Redhat 7.x (or derivative such as CentOS) or compatible.

2. LSF 10.1 or Torque 4.2.6 or compatible.

3. OpenMPI 2.1.3 or compatible, built withMPI_THREAD_MULTIPLE support. Analyst software looks for this support
and fails if not found.

4. Non-interactive SSH sessions cannot echo anything to standard out. Analyst software checks for this and fails if not
found.

5. TheANALYST_PATH,ANALYST_SIM_FOLDER, andANALYST_MPI_PATH_VXXLinux environment variables
are still supported, but AWR recommends using AWR_PATH, AWR_SIM_FOLDER, and AWR_MPI_PATH_VXX
respectively going forward.

See “Remote Linux Simulations” for details.
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Parameter Change

Maximum Number of Processes is changed to Maximum Number of Processes Per Node and has a different meaning now.
This value is auto-corrected when you open pre-v15 projects.

Accelerator Calculations Change (Analyst-MP Only)

These changes are specific to the linear accelerator calculations inOM2p/OM3p simulations. In prior versions of Analyst-MP
software, all OM2p/OM3p simulations performed calculations for linear accelerators. In v15 you can choose whether or
not to perform them.

Parameter Change

Accelerator calculations are performed by setting Compute Accelerator Results to True in the simulator setup dialog box,
under the Solver tab. This also exposes the Accelerator Result Settings: Shunt Impedance Path Start Point, Shunt Impedance
Path End Point, Kick Factor Path Start Point, Kick Factor Path End Point, Particle Beta, and Clip Paths at Structure Boundaries.
All of these settings exist and are visible in previous versions of Analyst-MP software. In new projects, Compute Accelerator
Results is False by default. When you open pre-v15 projects however, Compute Accelerator Results is automatically set
to True.

In addition, the shunt impedance path and kick factor path are no longer used for mode orientation. Instead all OM2p/OM3p
simulations use a dedicated mode orientation path, defined with theMode Orientation/Start Point and Mode Orientation/End
Point. When you open pre-v15 projects these new parameters are auto-populated with the values in the Shunt Impedance
Path Start Point and Shunt Impedance Path End Point.

Results Change

The following results are only output in the Mode Summary table if Compute Accelerator Results is set to True: R = Shunt
Impedance, R/Q, Kick Factor, Eacc = Average Accelerating Gradient, Ep/Eacc, Es/Eacc, Hs/Eacc, T = Real Part Transit Time
Factor, S = Imag Part Transit Time Factor, G = Geometric Factor, and Integration Path Length.

Version-Independent Migration Issues
The items in this section address moving files and settings from one software version to another. Some of these files and
settings are automatically migrated from a previous version of the software to the current version.

NOTE: Ensure that your Windows® Explorer program is set to show hidden and system files.

Files Automatically Migrated

All files from the All Users App Data Directory and the User App Data Directory are copied to their correct locations
when you start the new version of Analyst software for the first time. Also included are the user preferences file, hotkey
file, layout of the design environment, job queues, and other settings. See “Showing Files and Folders ” for details. Note
that for migration to occur, these directories must be in their default locations.

Files NOT Automatically Migrated

The Analyst software license file is not migrated, however the location of the license file is migrated in the user preferences
file.
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Transferring Preference Files to Different User or Machine

There may be situations where you want to transfer preferences from one user to another or from one machine to another.
To do so, use the following steps.

To transfer user preferences to a different user or machine:

1. Locate the folder on the source machine: C:\Users\<source username>\AppData\Roaming\AWR\Analyst\<version
number e.g. 14.0>.

2. Copy the UserPython folder, and the DockPanelLayout.xml, Preferences.xml, RecentFiles.txt, ToolBarLayout.xml,
andWindows.xml files from this folder.

3. Locate the folder on the destinationmachine:C:\Users\<destination username>\AppData\Roaming\AWR\Analyst\15.0.
Create the folder if it does not exist.

4. Paste the copied items into the destination folder.

To transfer all-user preferences to a different machine:

1. Locate the folder on the source machine: C:\ProgramData\AWR\Analyst\<version number e.g. 14.0>.

2. Copy Preferences.xml from the version folder.

3. Locate the folder on the destination machine: C:\ProgramData\AWR\Analyst\15.0. Create the folder if it does not
exist.

4. Paste the copied file into the destination folder.

When you start Analyst software on the destination machine or under the new user, the transferred preferences and other
settings are used.

Other Concerns

Project Compatibility

Analyst software project files (*.apz) are backward-compatible, so projects created in Analyst software v14 open in
Analyst software v15. You can also backsave - for example you can save a project from within v15 to v14 or older.

Multiple Versions

You can have any number of Analyst software versions on your machine. Each version has its own Start menu entry,
with no registry conflicts between them. If you double-click on an Analyst software project file (*.apz), it opens in the
most recently installed compatible version of Analyst software.

Resetting the Temporary Directory

You can reset the Temporary Directory via the File Management / Temporary File Folder environment variable when there
is no model open. See “Setting Environment Properties” for details. The change takes effect for future models after
saving the change.
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Analyst 15 Features
The AWR® Analyst™ v15 software includes the following new features, enhancements, and user interface changes.

Environment

Data Files

Unused Files

Unused files are now placed into an Unused folder in the Navigator for easier identification.

Delete All and Convert All Linked Files to Imported Files

The Navigator Files and Files > Unused context menus now allow you to delete all contained files and to convert all linked
files to imported files. See “Navigator Representation” for details.

Search

Searching is now supported in the Navigator, Browser, and certain attribute and simulation property grids. See “Search”
for details.

You can also control the types of items that are searched.
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Home Ribbon Changes

The Home ribbon includes the following changes:

• The combo box previously used to set the active simulation type is replaced by the New Simulation split button. Use
the left side of the split button to create a new simulation of the active type. Use the right side of the split button to
create a simulation of a different type; this action also sets the active simulation type.

• The button to set the default simulation type is replaced by the Set ... as Default menu item in the New Simulation split
button.

Structure

Ribbon Changes

The Structure ribbon includes the following changes:

• The active coordinate system is now specified via radio buttons in the Structure Browser instead of on the ribbon
menu.

• The buttons to create coordinate systems and set the working plane orientation and offset have shifted right.

• The Working Plane Visibility button is moved from the ribbon to the Structure view toolbar.

Solid Organization Browser Buttons

There are two new buttons on the Browser toolbar to provide quick access to controlling solid organization. These options
remain in the Browser Geometry node context menu as well. See “Organizing Solids and Elements in the Browser” for
details.

2–2 AWR Analyst

Structure



Custom Cameras

You can now create Custom camera presets for use within and across projects. See “Custom Cameras” for details.

Solid References

A solid reference produces another instance of a solid, maintaining the referenced solid's geometric definition. As a
result, changing any of the creation parameters of the referenced solid impacts all references. Each reference contains
several independent parameters, however, including

• Coordinate System

• Material

• Include in Simulation

• Visible

• Mesh Control Only

These parameters allow you to uniquely position each reference (either via a coordinate system or by applying a
transformation), assign a different material for each reference, and other operations. See “References” for details and an
example.
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Attribute Application

When applying an attribute to entities, some of which already contain attributes, the resulting dialog box now offers an
additional option to apply the new attribute to only entities without other attributes. This can greatly simplify the application
of attributes in complex situations.

Minor Improvements

Performance

Actions performed on large numbers of solids (such as changing materials, excluding, and including) are now much
faster.

Pick Corresponding

The Structure view context menu contains commands to pick items that correspond to what is already picked.

• Pick > Corresponding Solids - Picks solids associated with currently picked edges, faces, and bodies.

• Pick > Corresponding Bodies - Picks bodies associated with currently picked edges, faces, and solids.

• Pick > Corresponding Faces - Picks faces associated with currently picked edges, bodies, and solids.

• Pick > Corresponding Edges - Picks edges associated with currently picked faces, bodies, and solids.

Solid Query

Solid queries now report the number of bodies in the solid(s). See “Solid Query” for details.

Interactive Polyline/Spline Point Addition

Points can be added to wire and sketch polylines or splines and interactively placed with the mouse. See “Adding Points
Interactively” and “Add Points To Sketch Polyline or Spline” for details.

Simulation (Analyst-MP Only)

Ribbon Changes

A simulation value set is now selected using a combo box in the Simulation Browser instead of in the ribbon.

Capacity Improvements - Distributed Solver

The new linear solver introduced in v14 (dubbed HMLU) is extended to use multiple nodes on a Linux cluster, enabling
solution of substantially larger problems than can be performed on a single computer. As applied to the driven frequency
(RF3p) simulator, this allows the matrix solution at a single frequency (as part of a fast or discrete sweep) access to the
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total combined memory these nodes offer. For example, problems in excess of 100M unknowns have been solved to
date on nodes each with less than half a terabyte of memory. See “Linear Solver” for details.

Remote Linux Simulation Improvements

A number of improvements are made in this version. See “Remote Linux Simulation Changes (Analyst-MP Only)” for
migration issues and “Remote Linux Simulations” for additional general information.

Clear Results Keeping Initial Mesh

You can now delete all results but the initial mesh from a simulation. A subsequent Simulate action then starts the AMR
(adaptive mesh refinement) from that initial mesh, eliminating the time associated with recreating the initial mesh.

Meshing

Performance and Robustness

Meshing is both faster and more robust, particularly on very complex geometries containing many small entities.

Curvature Geometry Representation Absolute Size

You can now optionally define the mesher curvature geometry representation size in absolute units. Previously you could
only specify a value relative to the element size. This change also controls the definition of the minimum element size
that the curved geometry representation can cause. See “Curved Geometry Representation Controls” for details.

Reusing Meshes Between Simulations

You can now copy a mesh from one simulation to another simulation. The new mesh is then used in a subsequent Solve
or Simulate. Note that the most recent (and thus the largest) mesh is the one copied. See “Reusing Meshes” for details.
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Child Simulations (Pre-release Feature)

Child simulations allow you to encapsulate simulations within simulations. This feature provides the ability to run a
single simulation that in turn runs child simulations first, and then the parent simulation, allowing you to connect fields
from the child simulations into the parent simulation.

Practical examples of this include a parent MICHELLE simulation that contains one or more child simulations for an
RF cavity, control grid, control magnet, or other. Key to this is the ability to specify which solids to include in a simulation.

See “Coupled and Child Simulations” for details.

Optimizations and Sweeps

Additional Output Tables

Optimizations and sweeps now produce an additional dataset named Optimization Results. This dataset contains two tables
named "All Results" and "Best Results". These tables mirror the tables displayed in the Optimization Results dialog box,
but are now exposed here so you can include this data in charts, export it, and other operations.
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Driven Frequency (RF3p)

Lumped RLC Elements

A lumped RLC circuit element is implemented as an enforced frequency-dependent impedance between two points,
where the RLC components can be in either a parallel or a series configuration. The lumped RLC element is implemented
for both discrete and GAWE frequency sweeps (RF3p). See “Lumped RLC Elements” for details.
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Wave Port Conductor Loss Improvements

In previous Analyst versions, the imperfectly conducting metal on a wave port was replaced with perfectly conducting
metal. This was an efficiency and is appropriate in most situations. However, in cases where the losses are significant,
this approximation can lead to lower accuracy solutions, particularly if a reference-plane shift is applied at the port. In
v15, losses on the port are added in the same way as in the 3D problem, with the exception that modeling is not allowed
inside metal on a port. Metal is converted to impedance boundary conditions applied to the metal surface, and the
calculation of the impedance value includes skin-depth effects (limited by metal thickness). The primary impact of this
change is higher accuracy results for high-loss cases where a reference-plane shift is used at the port.

Stored Energy by Material versus Frequency Table

Driven frequency simulations now produce a stored energy by material table that you can select using the Qualifier 3
selection in a measurement. This table only includes the frequencies at which the field output is requested.

Reduced Memory Use for Field Output

Driven frequency simulations now use significantly less memory when requesting near or far field output, especially
when requested at many frequencies.

Performance

Various aspects of the solver are faster, most noticeably for large point count simulations. Additionally, fast frequency
(GAWE) sweeps make better use of parallel resources.

Eigenmode (OM2p and OM3p)

To simply the interface to the eigenmode simulators, their inputs and outputs are changed:

• A Compute Accelerator Results parameter is added. If true, additional parameters for shunt impedance path, kick factor
path, and particle beta are exposed. This parameter also controls if theMode Summary output table contains accelerator
application-specific quantities. Note that Analyst adjusts this parameter accordingly when you open pre-v15 projects.

• TwoModeOrientation parameters are added. These parameters control the integration paths used to resolve ambiguities
in the mode solution. At least one of these paths should pass through a part of your geometry with nonzero fields. The
direction of the path should roughly correspond to the expected direction of the fields. Every eigensolver result has a
sign ambiguity, and results for periodic problems also have a phase ambiguity. The path is used to choose the sign
and phase consistently between AMR steps. If the path does not encounter nonzero fields, the eigensolver automatically
chooses the field sign and phase. The result may differ between AMR steps, leading to difficulties with convergence.
Prior to v15, the Shunt Impedance Path parameters served this purpose. Note that Analyst adjusts these parameters
accordingly when you open pre-v15 projects.

• Shunt impedance path, kick factor path, and particle beta parameters are now located under the Accelerator Result
Settings category.

See “Accelerator Calculations” for details.
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2D Magnetostatics (MS2p)

A new 2D XY and RZ magnetostatics solver is introduced. See “2D/3D Magnetostatics (MS2p/MS3p)” for details.

3D Magnetostatics (MS3p)

AMR Improvements

Improvements to the adaptive mesh refinement (AMR) strategy have reduced simulation times.

Permeability Interpolation Improvements

A cubic spline interpolation is now used for permeability, improving the accuracy of the simulation and reducing the
number of necessary nonlinear iterations.

Electrostatic Particles (MICHELLE)

Coupled Simulations (Pre-release Feature)

You can now obtain imported fields for Grid-Defined Magnetic and Grid-Defined RF directly from other simulations (for
example, magnetostatic, electrostatic, or frequency domain). You no longer need to export these fields to regular grid
files. This plays an important role in another new feature named child simulations.

To use this feature, set the Input Type parameter to Simulation

and then choose the desired compatible simulation for the Input Simulation parameter.
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Note that for Grid-Defined RF instances there are additional inputs that make the field selection unambiguous.

When you run theMICHELLE simulation, immediately after a mesh is generated (initial or refined) the Analyst simulator
locates the specified field from the input simulation and performs an interpolation of that field to the MICHELLE mesh.
This is performed without going through a regular grid and is fully automated. If the input simulation does not contain
the required field, the MICHELLE simulation fails. See “Coupled and Child Simulations” for details.

New Simulation Inputs

The following are new simulation inputs. See the corresponding parameter help strings for details.

1. Solver Setup > Basic > Cycles > Cycle Averaging Factor Expressions

2. Solver Setup > Imported Fields and Particles > Volumetric Particles > Current Override

3. Solver Setup > Imported Fields and Particles > Grid-Defined Magnetic > Input Type

4. Solver Setup > Imported Fields and Particles > Grid-Defined Magnetic > Input Simulation

5. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Type

6. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Simulation > Simulation

7. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Simulation > Mode Index

8. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Simulation > Frequency Index

9. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Simulation > Port Index

10. Solver Setup > Imported Fields and Particles > Grid-Defined RF > Input Simulation > Phase Advance Index

11. Data Output and Processing > Field Data > EField Flux On Surface (SS-only)
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12. Data Output and Processing > Beam Data > Summary Table > Beam Line Direction for Optimization Metrics

13. Data Output and Processing > Beam Data > Particle Data Output > Write Current or Charge

14. Data Output and Processing > Beam Data > Particle Data Output > Charge: Column Number

15. Data Output and Processing> Beam Data> Particle Data Output > Boundary Name: Column Number

New Primary Emitter Inputs

The following are new inputs to the primary emitter attribute. See the corresponding parameter help strings for details.

1. Emission Models > Thermal Particle Distribution > Shuffle Thermal Distribution

2. Emission Models > Thermal Particle Distribution > Random seed for the shuffling of thermal bin indices

3. Emission Models > General Field-Emission v02

Grid-Defined Magnetic Field Ordering

You can reorder Grid-Defined Magnetic Field instances in the MICHELLE simulation setup tree by dragging the node
above/below another node. You can also change the order by choosing Move Up or Move Down from the node context
menu.

This is important when you have more than one enabled instance with overlapping regions in space. See “Grid-Defined
Magnetic Fields” for details.

Convergence Considerations for Steady-State Simulations Updates

The documentation on this topic is greatly improved. See “Convergence Considerations for Steady-State Simulations”
for details.

Minor Improvements

PML Improvements

The PML (Perfectly Matched Layer) attribute is modified for better performance.

AMR Improvements

AMR memory estimates are improved in driven frequency (RF3p) simulations, allowing improved use of parallel
resources.

Log Timestamps

You can now hide the timestamps on the far-left side of the simulation log entries using the new check box at the bottom
of the Simulation view. This simplifies the comparison of such logs.

Ordering

You can reorder the simulations displayed in the Navigator by dragging a simulation node above/below another simulation.
You can also change the order by choosing Move Up or Move Down from the simulation's Navigator context menu.
This applies to child simulations as well.

Real Time Plots and AMR

Adaptive mesh refinement progress is now plotted against a logarithmic y-axis to make it easier to interpret.
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Assign Simulation Job Variable Values to Value Set

You can now easily assign the variable values used in a simulation job to the active value set, making it easier to reproduce
a given simulation job's results. See “Restoring Variable Values From a Job” for details.

Post Processing (Analyst-MP Only)

Annotations

Quicker Access to Geometry and/or Annotation Visibility

A new Next Geometry Annotation Visibility button on the Browser toolbar allows you to quickly change visibility of the
geometry and annotations. See “Geometry Annotation Visibility” for details.

Cut Line Filter Trimming

The cut line filter now includes an additional parameter named Trim at Domain Boundary. If true, the output of the filter
is trimmed so that only the portion inside the corresponding mesh is maintained.

Browser Icons

Browser annotation icons now indicate if the annotation contains an enabled filters. See “Browser Icons” for details.

Plots and Measurements

Plot Ribbon Changes

The Plot ribbon includes the following changes:

• The X and Y axis limit (range) properties are now located on tabs in the Chart Properties dialog box.

• The table format precision increment and decrement buttons are replaced by a spinner control.

Smith Charts

Smith charts are now supported. See “Chart Types” for details.
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Ordering

You can reorder the plots displayed in the Navigator by dragging a plot node above/below another plot node. You can
also change the order by choosing Move Up or Move Down from the plot's Navigator context menu.

Movies over Choice Variables

Movies in the Plot view can now animate over specified values of a choice variable. You can also define the order in
which the frames are generated. See “Creation” for details.

Scripting

Min/Max Function Changes

The min and max functions now take an arbitrary number of arguments (in previous versions the limit was 2 arguments).
This allows for expressions such as min(a, b, 4.2).

Canceling

If you cancel a running script that has changed the model, you are prompted to undo or keep those changes.

Failure Behavior

If a script fails and has changed the model, you are prompted to undo or keep those changes.

Run Python Function at Start Up

The analyst.exe command line option /pythonfcns allows you to run one or more functions with specific arguments
in a Python script at launch. See “Command-line Usage and Examples” for details.
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Version 15.01 Updates
The Cadence® AWR® Analyst™ 3D FEM EM analysis version 15.01 software includes the following enhancements.

Simulation (Analyst-MP Only)

Performance Improvements

• The calculation of where to refine the mesh during AMR is faster.

• Various aspects of the HMLU linear solver are faster.

Driven Frequency (RF3p)

• Improvements to the adaptive mesh refinement algorithm to reduce the number of AMR iterations.

• Lumped port accuracy improvements.

• A new table of power loss by impedance boundary conditions is available if wall loss fields are enabled.

Eigenmode (OM2p/OM3p)

• Improvements to the adaptive mesh refinement algorithm to reduce the number of AMR iterations.

• A new table of power loss by impedance boundary conditions is available if field output is enabled.

Post Processing (Analyst-MP Only)

Annotations

• Scalar and vector field and particle annotations now support transparency - see the Opacity parameter.

Scripting
The following functions are now available

• ISolid::GetVolume

• IBody::GetDiagonal

• IBody::GetBoundingBox

• IFace::GetBoundingBox

• IEdge::GetBoundingBox
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Version 15.02 Updates
The Cadence® AWR® Analyst™ 3D FEM EM analysis version 15.02 software includes the following enhancements.

Structure

Attribute/Material Context Menu Pick Additions

The context menu for attributes and materials now offers additional pick options such as Pick > Only and Pick > Pick All
Faces.

Simulation (Analyst-MP Only)

Performance Improvements

The calculation of where to refine the mesh during AMR is faster that previous versions.

Coupled and Child Simulations Released

These features are no longer considered pre-release.

Magnetostatics (MS2p/MS3p)

Improvements to the nonlinear iteration convergence have been made.

2D Eigenmode (OM2p)

The basis set order is now automatically increased on-axis in all OM3p RZ simulations for improved accuracy.

3D Driven Frequency (RF3p)

Accuracy improvements to the hybrid (c1.5, c2.5, etc.) basis sets.

Electrostatic Particles (MICHELLE)

Improved Help

The parameter help has been improved on many inputs.

New Primary Emitter Inputs

The following are new inputs to the primary emitter attribute. See the corresponding parameter help strings for details.

1. Emission Models > Space Charge Limited Emission > Thermionic Correction Work Function

Remote Linux Simulation - New Input

Cluster > Submission Arguments Location has been introduced. This controls if the submission arguments are placed on
the command line or in the submission script (e.g. to the LSF bsub command). This currently only applies to LSF.
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Post Processing (Analyst-MP Only)

Annotation Properties Accessible from Measurement

If a measurement's Qualifer 1 is set to an annotation, you can now edit the annotation from by choosing
ANNOTATION_LABEL Properties from the measurement's context menu in the Plot browser.
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Version 15.03 Updates
The Cadence® AWR® Analyst™ 3D FEM EM analysis version 15.03 software did not include any notable changes.
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Version 15.04 Updates
The Cadence® AWR® Analyst™ 3D FEM EM analysis version 15.04 software includes the following enhancements.

Environment

Color Selector

Corrected a color mapping issue in the property grid Color dialog box.

Simulation (Analyst-MP Only)

Coupled Simulations Involving Complex Fields

Corrected an indexing issue when complex fields from one of the frequency domain simulators are involved in coupled
simulation RF Drive fields.

Wave Port Impedance using Power-Voltage Method

Corrected a conjugate error in calculating the wave port impedance using the power-voltage method.

Magnetostatics (MS2p/MS3p)

Improved nonlinear iteration convergence to correct some issues introduced in v15.00.

2D and 3D Eigenmode (OM2p/OM3p)

Fixed a failure that occurred where not all modes are found at all phase advances.

Remote Linux Simulations

Robustness Improvements

Implemented various improvements that collectively increase the robustness of this support in the event of network
interruptions.

Very Large Result Files

Fixed an issue causing very large (> 2 GB) result files causing remote Linux jobs to fail.

MICHELLE Slice Files and Remote Linux

Fixed an issue causing particle slice files to be skipped when transferring result files back from remote Linux jobs.

Post Processing (Analyst-MP Only)

Time-Domain Particle Annotation

Corrected a time-domain particle annotation-specific issue where the view would not update when moving from a time
step with particles to a time step without particles.
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Scripting

New Scripting Functions

Exposed additional arguments in the IModel::Save and IModel::Export functions to specify a product version.

Improved recording to capture new scripting functions.
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