Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Associated with this application note is a reference DXF file and a Layout Process File (LPF file) used to personalize the AWRDE.

Introduction

The AutoCAD drawing exchange format (DXF) standard is popular with EDA, CAD and CAM tools for exchanging mechanical drawing data. You can view DXF files using any ASCII text editor. AutoCAD users can reference the documentation shipped with any program that uses DXF for a description of the syntax they support.

...

DXF files can contain information relating to conductor shapes generated using tools other than AutoCAD. Often these files make use of the AutoCAD POLYLINE and ARC elements with a finite width. The current version of the AWR DE does not support POLYLINE and ARC elements with finite width. For precision artwork, there are several problems with this representation. You should request that the DXF file be regenerated using the drawing entities that are supported by the AWRDE and then imported. See "AutoCAD DrawingPrimitives and the AWRDE" for a list of supported drawing entities.

Model Layers and Drawing Layers

The graphical shapes in a DXF file display on one or more drawing layers in the AWRDE. These layers are used to organize the graphical information in a logical fashion. The layers of a DXF or GDSII file are termed model layers, and these model layers are mapped to drawing layers in the AWRDE to maintain the data organization and to make the imported information visible. In general, any process that draws shapes in the Layout window does so by sending the drawing instruction to a model layer. This model layer is then mapped to a drawing layer on which the shapes are seen. For more information on using model layers and drawing layers, see the MWO/AO User Guide. There are many reasons for using the model and drawing layer technique; however, these are beyond the scope of this document.

...

The second method is to add the appropriate model layers before importing a DXF or GDS file. This method assumes you can use another tool to determine what layers exist in the file. You can then assign the new model layers to any drawing layer. If you need a new drawing layer, you can add it and then assign the drawing layer to the new model layer. The advantage to this method is that no new drawing layers are auto-generated. The disadvantage is that you must know what layers exist in the external file and configure these same named model layers before artwork import.

Configuring Drawing Layers and Model Layers

In the Layer Setup dialog box, you can easily add and remove drawing layers and model layers, as well as change the way the layers display in a layout. To access this dialog box, choose Options > Drawing Layers

...

All of the drawing layer and model layer settings are saved in the LPF file. You can import LPF files into projects by choosing Project > Process Library > Import LPF or export files from projects by choosing Project > Process Library > Export LPF

Drawing Primitives

Drawing shapes that are exported from mechanical design tools are composed of drawing primitives. The AutoCAD documentation refers to these drawing primitives as graphical objects, which are found in the ENTITIES section of a DXF file. In this document, we use the term drawing primitives in place of ENTITIES. Drawing primitives include LINEs, POLYLINEs, SPLINEs, CIRCLEs and ARCs. To be consistent with the AutoCAD standard documentation, the names of the drawing primitives are capitalized. Note that these drawing primitives are stored in a DXF file in a variety of ways; this subject is beyond the scope of this application note.

...

A POLYLINE can also appear as a closed shape simply because the first and last points share the same coordinates. You can consider a closed shape as a polygon and an open shape as a line. If the imported shape is closed, then in the Layout window it is filled with a pattern whose characteristics are defined by the LPF. As expected, the open shape displays as a line.

 Example LPF and DXF Files

A DXF file (Housing Example.dxf) associated with this application note illustrates the main points of using DXF data. This DXF file contains the design of a circuit board and the housing for an arbitrary RF application. The housing is drawn using lines to represent the inner and outer walls. Some circles are drawn to represent fixings, and the outline of the board is designed to fit inside the housing. Two extra lines serve as guides to the centers of two coaxial connectors. For the first exercise, import the LPF file named simple.lpf, then read in the DXF file into the Artwork Cell Editor. Notice that when you import, new drawing layers and model layers are created.

...

This application note demonstrates techniques for setting up the Layout Process File (LPF file) for a design environment that shares DXF files between several design tools. Setting up the LPF to define the DXF layers (model layers) and the mapping between model and drawing layers is a precursor to the successful use of the AWR DE and a mechanical design tool.

APPENDIX: AUTOCAD DRAWING PRIMITIVES AND DATA STORAGE

POLYLINE

A POLYLINE can consist of one or more:

...

Each segment can have its own start and end width. The property width is not supported by the AWRDE. Both LINE and ARC segments support variable width.

POLYGON

A regular N sided (3 -1024) shape. AutoCAD has a simple command that is used to create these drawing primitives. The command is an automated method of creating a regular POLYLINE with the CLOSED attribute. (Not to be confused with an AWRDE or GDSII POLYGON.) An AWRDE or GDSII polygon is a closed shape defined by three of more vertices. Each segment has a non-zero length.

LWPOLYLINE

LWPOLYLINE means Light Weight POLYLINE. AutoDESK has created a data storage mechanism with reduced functionality compared to a POLYLINE, however it does not mean the POLYLINE is thinner! This entity is actually a means of storing a simpler POLYLINE structure with an improved and compact data storage mechanism. An importer needs to read the entity data set. There is no actual LWPOLYLINE drawing command. AutoCAD stores the entity depending on the elements that make it. A LWPOLYLINE does not support the SPLINE or FIT drawing primitives. The AWR DE supports the import of the LWPOLYLINE.

AutoCAD Drawing Primitives and the AWRDE

AutoCAD entities supported within the AWRDE.

AutoCAD EntityDescriptionAWRDE
ARCSegment of circleYes
CIRCLECircleYes
LINEStraight path between two pointsYes
POLYLINE (width = 0)Similar to line or ArcYes
POLYLINE (width > 0)Line or Arc with a specific width and shapeNo
Closed POLYLINE (width=0)

Closed shape, can be translated to a

polygon

Yes
LWPOLYLINELight Weight POLYLINEYes
TEXTString of ASCII charactersYes
TRACEX-vertex parallelogram, similar to solidNo
POLYGON

Regular N Sided Shape (exported from

AutoCAD as a CLOSED POLYLINE

Yes

Downloads

HTML
<button class="gh-button gh-green" title = "File=/appnotes/DXF.zip" onclick="window.location.href='https://awrcorp.com/download/kb.aspx?File=/appnotes/DXF.zip' ">Download Referenced Files</button>

...