Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 27 Current »

Summary

This application note covers some valuable layout concepts for doing printed circuit board designs using Microwave Office. It demonstrates how to use positive and negative layers to ease drawing ground flood regions. By utilizing some simple setup procedures it is possible to have all lines draw with a user-specified spacing to the ground flood automatically. This technique greatly simplifies drawing the ground flood when the initial layout for a circuit is complete. This application note also discusses various ways that Gerber files can be created in Microwave Office. One way is to merge the positive and negative layers to make one Gerber file. The other way is to keep the positive and negative layers separate if using a paint-scratch-paint processing technique.

Downloads

PCB_Layout_70.zip

Printed Circuit Board (PCB) Layout Application Note 2 - Multi-Level Layout

Board Layout Simplification Techniques

 Click here to expand...

This Application note demonstrates:

  • the capability of Microwave Office to streamline Printed Circuit Board (PCB) designs
  • how to properly set up Microwave Office to do PCB layout in an efficient manner, and the advantages of this approach
  • several options for exporting the layout, focusing on different options for creating Gerber files.

In a PCB design, all of the components (active and passive) are used as discrete parts. The circuit is then assembled on a microwave substrate with metal patterns etched or machined to make transmission lines. This document assumes that the reader has a strong understanding of Microwave Office layout concepts. For more information on layout, see the Microwave Office User's Guide "Layout" chapter and the layout principles application notes available on AWR's web site (www.mwoffice.com). Additionally, the Microwave office project used to make all the figures in this application note is available.

The examples included here use a process technology that has a two-sided microwave board with thin-film resistors on both sides of the board. Chip components are only allowed on the top of the board. This may not be a practical technology, but it helps demonstrate many of the concepts discussed here. These techniques and discussions can easily be extended too multi-layer boards.

Typically, when designers are doing a PCB design, they design the entire circuit to fit into a fixed area. The last step is to draw the top ground plane so that it covers any area not populated by other components. While there is nothing wrong with this approach, drawing the top ground can be difficult if the board is complex and especially if there are curved lines or circles in the layout. This technique becomes even more difficult if the designer needs to make changes. Now instead of just moving one component in the layout, the component and the drawn ground plane all must be moved. The technique presented here eliminates all of these problems and allows the software to draw the proper spacings from transmission lines, pads, components, etc. to the ground plane.

Board Layout Setup

 Click here to expand...

The Microwave Office layout tool simplifies the PCB layout through the use of positive and negative layers. The Microwave Office User Guide contains an excellent explanation of positive and negative layers. The basics of this concept are that for a named layer (e.g., Metal) you can have a normal layer, a positive layer, and a negative layer. The positive layer is specified by adding a "+" after the layer name (e.g., Metal+ is the positive for Metal) and the negative layer is specified by adding a "-" after the layer name (e.g., Metal-). These three layers represent one mas layer used for processing. When combined, the shapes on the negative (Metal-) layer are subtracted from the positive (Metal+) layer and the results are added to the normal layer (Metal).

When a layout is exported, Microwave Office can merge the normal, positive, and negative layers when creating the exported file. You can also specify to export each of these layers separately. Finally, you can use te built-in scripting environment to create one file that has all three layers' information using the Gerber format, allowing positive and negative layers. These formats are used with photopolotter machines that utilize a "paint-scratch-paint" processing technique. To visualize what a layer looks like when the normal, positive, and negative layers are merged, the drawing layers in Microwave Office for these layers need to be set up in a particular manner.

Figure 1 shows a microstrip line as a basic example of how these layers are used. The entire board surface is drawn with the positive layer, then the negative layer is drawn to cut a hole in the positive layer. This layer is drawn larger than the microstrip geometry. Finally, the normal layer is drawn to the exact dimensions of the microstrip line. The offset of the negative layer ffrom the normal layer creates the spacing to the ground plane.

The key to making this work is defining the necessary layers before designing the circuit. For the technology used in this example, layers are needed for:

  • top and bottom metal
  • top and bottom resistor
  • via
  • package
  • package leads
  • board outline

The following sections cover the steps to properly create the drawing layers, the layer mapping, and the line types for the chosen technology.

Drawing Layers

The first and probably most important step in setting up this type of layout is to define the draw layers. These layers must be set up in a particular way to make the layout look the same in Microwave Office as the artwork files look when exported.

Figure 2

In this technology, positive and negative layers are needed for both the top and bottom metal layer. To display the layout properly, the layers must be in the proper order, i.e., which draw layer number is first. The order should be normal layer (Top Metal), negative layer (Top Metal_), and positive layer (Top Metal+). Figure 2 shows the drawing layer setup for this project. Notice that for Top Metal and Bottom Metal the order is as described above.

To finish setting up and properly displaying the drawing layers, the normal, positive, and negative layers should have the same Pattern. Finally, the normal and the positive layers should have the same line and fill color. The negative layer can have a line color, but the fill color should be the same as the background color of the Layout Editor, in this case white. it isn't obvious in Figure 2 that the negative layer has the same pattern as the other layers because the color is white, so it isn't displaying anything with a white background. you can change the color while setting the pattern and then change to the background color when done. Also, Figure 2 shows the negative layer for Top Metal with a line color and the negative layer for Bottom Metal without a line color. Drawing an outline for this layer is optional.

Drawing layers are also set up for the top resistor, bottom resistor, package, and leads layers.

Layout Process File (LPF)

After the drawing layers are set up, the next step is to define line types that utilize these layers to their full extent. This is done by editing the Layout Process File (LPF) in a text editor. Before you can do this, you must export the file from the project by choosing Options > Process Definition > Export.

The LPF contains definitions for line types, which are used to describe how to draw the layout for microstrip, stripline, and CPW models. The line types enable these models to be drawn with multiple layers in layout. For example, using different line types, a microstrip line can be drawn on one layers, two layers, or 10 layers, whatever number of layers is desired. This concept is used to create line types that use the normal layer to draw the line, and the negative layer to draw the spacing from the line to the ground plane.

Three line types are created for a 5, 10, and 20 mil spacing to the ground plane. These line types are shown in Figure 3.

Notice that the layer specified in each line type do not match any of the drawing layers specified in the previous section. When specifying entries in the LPF, the layer names are model layers, not drawing layers. The layer mapping set up in the following section maps the model layers to the already defined drawing layers. The line types are defined this way so that the 5, 10, or 20 mil spacing can be applied to the top or bottom metal layer of the board.

For each line type, the first layer is the normal layer and the second layer is the negative layer. Notice that each negative layer has a positive offset value. In the LPF file, the offsets are always set in meters, so these offset values are the meter equivalent of 5, 10, and 20 mil spacings. This offset is used to draw the negative layer with the proper spacing to effectively make a spacing from the line to the ground plane.

The drawing for the via model can also be set up in the LPF file. When using a via in a schematic, the layout is specified in the via definition section in the LPF. The entries for the via are shown in Figure 4.

Notice that the via layer names are not the same as any of the drawing layers. Again, these are model layers and are defined this way to easily expand the via drawing to a multiple layer board. There is only one via definition type allowed, so the layer mapping can change on which drawing layers each via is displayed. The via model layers are set up as follows: via, drawn as a circle of the via dimension in the model; vtMetal (via top metal), drawn as a square 10 mils larger than the geometry in the model; vtMetal- (via top metal negative), drawn as a square 20 mils larger than the geometry in the model, effectively drawing a 10 mil space to the ground plane. The vbMetal and vbMetal- layers are the same as vtMetal and vtMetal- except they are used for the bottom connection of the via. The flag setting determines the shape of the drawing. See the Microwave Office User’s Guide for more information. Remember that after changing the LPF file, you must import it into Microwave Office to apply the changes by choosing Options > Process Definition > Import.

Layer Mapping

Now that all of the drawing layers, the line types, and the via have all been set up, the final step is to assign the layer mapping. This is where the model layers for the line types, the via, and the thin film resistor (TFR) model are assigned to display on their proper drawing layers. Two layer mappings are needed, one for the top side of the board and one for the bottom side of the board. For the model layers, the program automatically makes each draw layer a model layer and then maps back to the same named drawing layer. After these "unity mapped" model layers, all the model layers used in the line type, via definitions, and the TFR need to be added as model layers and then mapped to the proper drawing layer. The model layers for the line type and via are shown in the LPF entries in Figure 3 and Figure 4. For the TFR element, the model layers are hard coded to "NiCr" and "Metal1". After these new model layers are added they are mapped to the proper drawing layer. Figure 5 shows the mapping for these model layers for the top of the board.

Notice that the layer names used in the LPF (model layers) are associated with the drawing layers previously defined. When this layer mapping is assigned to vias, transmission lines, or resistors, they are drawn on the drawing layers
assigned for the top side of the board. Figure 6 shows the layer mapping for the bottom of the board.

Note that the layer names for the line types and the TRF are now mapped to the drawing layers for the bottom of the board. The via mapping did not change in this example because there is only one type of via possible in the current technology. If this was a multi-layer board, the top and bottom via model layers could be mapped to different drawing layers to display the via at different heights in the stack.

Board Layout Examples

 Click here to expand...

After the setup is complete, you can see some of the advantages of setting up Microwave Office in the described manner for PCB layout. With the current setup, you can add the top ground layer (drawn on the positive layer) at the beginning of the design/layout process or after the circuit is designed electrically. There is no advantage of one technique over the other, it is simply designer preference.

Face Settings

A basic example is to draw the layout for a simple microstrip line. Figure 7 shows the schematic view for a 25 mil by 100 mil section of transmission line.

Figure 8 shows the layout for this microstrip line. When a microstrip line is first drawn it uses the first line type and first layer mapping defined in the LPF file. In this example, this is the “line 5 mil space” line type and the “Top Map” layer mapping. With this line type and layer mapping, the line is drawn with “Top Metal” for the dimension of the microstrip in the model, and “Top Metal-” stretched 5 mils in each direction for the spacing to the ground plane spacing. If
a “Top Metal+” shape is drawn surrounding this line, the layout looks like Figure 9. Note that the spacing to the ground plane extends 5 mils around the entire line. This may not be desirable when this line is hooked to another element. Since the spacing to the ground is created by a multi-layer drawing of the microstrip line, the way the line is drawn at the connection points to other models can be changed by the face properties.

To change a layout object’s face properties, you must first select the object in the Layout View, right-click, choose Shape Properties, and then click the Faces tab in the Cell Options dialog box. This dialog box is shown in Figure 10.

In Figure 11, face 1 of the microstrip line has its Multi-layer Drawing setting set to Flush as shown in Figure 10. Face 1 of the microstrip line corresponds to the left end of the line. Flush specifies that all drawing layers are at the same location for the chosen face. Now the “Top Metal-” drawing does not extend 5 mils beyond the left edge of the “Top Metal” layer, rather “Top Metal-” is drawn at the same location as the “Top Metal” layer. The original setting was Inside, as used to draw Figure 9. Note that Inside specifies drawing with the original offsets in the LPF file. An Outside setting would change the sign on the offset. For these lines, Outside would make the negative layer draw smaller than the normal layer. This is clearer by trial with a layout in Microwave Office.

Line Type Settings

The next step is to change the spacing from the line to the ground plane by changing the line type used in drawing the microstrip (or stripline) models. Figure 12 shows the schematic for three microstrip lines. Note that the geometries
are the same for the three line models. Figure 13 shows the initial layout for the three lines with the positive layer (Top Metal+) drawn around them. Line types are assigned in the layout by opening the properties for the line from the
layout and changing the Line Type.

To change a layout object’s line type, you select the object in the Layout View, right-click, choose Shape Properties, and then click the Layout tab on the Cell Options dialog box. This dialog box is shown in Figure 14.

Figure 15 shows the same layout, but now the line types are changed. The far left line kept the “line 5 mil space” line type, the middle line is using the “line 10 mil space” line type, and the right line is using the “line 20 mil space” line type. Modifying the line type changed how the negative layer (Top Metal-) was drawn, creating a different spacing from the line to the ground plane.

Via Layout

In the LPF file, all the layers are set up to draw the via properly for this technology. The via model is drawn with a circle of the same geometry as the model, and then square pads are drawn surrounding the via on the top and bottom metal layers. The negative layers are included to give the via pads a 10 mil spacing to the ground plane. Figure 16 shows a very simple schematic that has two microstrip lines and a single via.

Figure 17 shows the layout of this schematic for just the top metal and via layers. Figure 18 shows the layout on the bottom metal and via layers. A positive layer is drawn around the lines and the via for the top and bottom metal (Top Metal+ and Bottom Metal+).

Note:

  • The via circle is the same diameter as is set in the model (25 mils).
  • The pads on the normal metal layers (top metal and Bottom Metal) are drawn as squares and offset from the via by 10 mils in each direction.
  • the spacing to the ground planes is 10 mils, as specified by the negative layer (Top Metal- and Bottom Metal-) offsets in the LPF definition.

Moving Lines Between Layers (Layer Mapping)

You can change a line drawn on the top of the board to the bottom of the board by simply changing the layer mapping that is assigned to that line’s layout. Recall that there is layer mapping established for the top of the board (Top Map) and the bottom of the board (Bottom Map). To demonstrate this, Figure 19 shows a slight modification of Figure 16.

The initial layout for this schematic looks identical to Figure 17 after the positive layers (Top_Metal+ and Bottom_Metal+) are drawn for both the top and bottom of the board. Remember that when layouts are initially created, they use the first line type defined in the LPF and the first layer mapping defined. To change the right microstrip line to be drawn on the bottom of the board, select the shape properties of the line in the Layout View and change the Layer Mapping to Bottom Map.

To change a layout object’s layer mapping, select the object in the Layout View, right-click, choose Shape Properties and then click the Layout tab on the Cell Options dialog box as shown in Figure 14.

Figure 20 shows just the layers for the top metal and via. Figure 21 shows just the layers for the bottom metal and via. Note that the right line is drawn on the layers for the bottom of the board. Moving line drawings to different layers
could be extended to board stack-ups with more than two layers by just adding new drawing layers and layer mapping tables to be able to draw on the specified layers on the board stack.

Adding Cutout Regions

Sometimes when doing layout using these techniques, designers use models in Microwave Office that have hard-coded drawing definitions, such as the Thin Film Resistor (TFR) model. This model is hard-coded to draw to specific model layers which were previously mapped to the correct drawing layer to draw the layout properly. However, there is not a negative layer associated with this model, which might cause problems. This is easily averted by drawing a shape on the negative layer around the resistor layout cell to open up the ground plane around it. The following example demonstrates.

Figure 22 shows a very simple schematic with a TFR element connected between two microstrip lines. The faces of the microstrip lines connected to the resistor are set to Flush and the other ends are set to Inside. The positive layer for the top metal (Top Metal+) is drawn around these elements.

Figure 23 shows the initial layout of this schematic.

Figure 24 shows the layout with the resistor layer turned off. Note that the resistor and the microstrip lines are shorted-out by the top ground layer because the TFR model is hard-coded to only draw on certain layers. There is no general way to add the negative layer to this drawing code while still using the default drawing cell for this model. The solution is to draw a rectangle around the TFR layout using the negative layer (Top Metal-) to create a cutout of the ground plane so that this resistor behaves as it should.

Figure 25 shows the layout when a rectangle was drawn around the resistor on the negative layer (Top Metal-).

Figure 26 shows the same layout with the resistor layer turned off. Now the spacing to the ground plane is set by the size of the drawn rectangle. The only drawback to this technique is that if the resistor layout moves, the negative layer does not move with it. You can use other techniques to overcome this specific problem with the TFR model such as creating a GDSII Cell Stretcher as the artwork cell for this resistor. This cell would also draw a negative layer surrounding the resistor layer. See the Microwave Office User’s Guide for more information on the GDSII Cell Stretcher.

This example shows how the negative layer is used to create a cutout in the ground plane around another component. This negative layer shape does not have to surround another component--you can draw it over the positive layer at any location to create a hole in the top ground.

Adding Cutout Regions to Artwork Cells

The previous example demonstrates how to add a cutout region to a layout cell that has its layout hard-coded in Microwave Office. Often, the artwork for a model is a user-defined artwork cell, such as for active devices. The electrical
models are s-parameter data files or nonlinear models, and the layout is a package artwork cell. When the artwork cell is used in the layout, you can draw the negative layer around the artwork cell if you do not want the ground layer below the device. There are two ways to do this:

  • Draw the negative layer around the artwork cell used in layout, the same as for the resistor above. You must do this for every device, and the ground layer does not move with the device if it is moved.
  • A better approach is to add the negative layer to the artwork cell for the device so that every time the cell is used, the negative layer is included.

The following example demonstrates.

Figure 27 shows the schematic for a simple device with some lines feeding the input and output. Curved lines are added to demonstrate the ease of creating the surrounding ground plane.

Figure 28 shows the layout for this schematic. In this example, the layout for the device was assigned to an artwork cell. All of the line types were set to provide a 10 mil spacing to ground. The lines that are touching the device’s input and output have their face properties set to Inside, which extends the negative layer further under the device. It isn’t obvious in Figure 28, but the top ground plane is sitting under the device.

You can now see the ground under the device. If you do not want this area to have the ground, you can add the negative layer for the top metal (Top Metal-) to the artwork cell where the metal should be removed below the device. This application note assumes knowledge of artwork cell editing. For more information, see the Microwave Office User’s Guide “Layout” chapter.

Now you can add the negative layer to the artwork cell. These basic layout operation steps are not covered. In this example, the package layer for the device package was copied and pasted to the original location of the device package, oversized by 10 mils, and then set to the 1_0 model layer (which displays on the Top Metal- draw layer). When you use the new artwork cell the layout looks like Figure 30, where it is not obvious that the metal is removed under the device.

Figure 31 shows the layout with the layers for the device package and leads turned off. You can now see a cutout in the ground below the device.

With this layout technique, it is simple to move the spacing to the ground along with the device artwork or the curved lines. It is time consuming to move these objects and redraw the outside ground plane.

Drawing Ground Spacings for Unassociated Drawing Objects

Often in layout, a drawing object unassociated with any electrical model in the schematic is used to represent something the designer wants in the layout but doesn’t want modeled in the circuit. When using unassociated drawing objects, you can draw them on any drawing layer and then apply the line types to the layout shapes. The following example demonstrates.

This example starts with the layout in the previous section. A small line is drawn to connect to the right transmission line. This line is not modeled, but used only to connect the microstrip line to a larger pad. (You would model this line in a working project). Figure 33 shows the initial layout with the line and pad added. Initially, you can draw these on any layer. After they are drawn, you can set their properties to use the line types defined in the LPF file by selecting the drawing object, right-clicking and choosing Properties. Figure 32 shows the dialog box for the shape properties of an unassociated drawing object.

Select the Use process layers check box to access the pre-defined line types and layer mappings. In this example, the line type is set to a 5 mil space and the layer mapping is set to Top Map to draw the line and pad on the top metal using the 5 mil space line type.

Figure 34 displays this layout with the line type applied to the two unassociated drawing objects, which you could have created by drawing on the normal layer and the negative layer separately. By using the line type, ground spacing follows the line when it moves and it is easy to change the spacing to the ground plane by simply changing the line type.

Exporting the Artwork

 Click here to expand...

After the PCB design and layout is complete you can transfer the design to the mask maker or the board manufacturer. In Microwave Office, you can export layouts into several formats including GDSII, DXF, and Gerber. For board layouts, Gerber format is typically used because it is the format photoplotters read. When doing layout in this manner, you have two options when sending Gerber files to a design house:

  • You can merge the normal, positive, and negative layers into one file. When done using Microwave Office, geometric Boolean operations are performed on the different layers to produce one merged layer resulting from the original normal, positive, and negative layer. This file no longer has the normal, positive, and negative layer information.
  • The other option is to keep the normal, positive, and negative layers separated. You can do this by having three separate data files, one for each layer. You can also merge them into one Gerber file, but all of the information for each layer ins in the single file, and special Gerber commands are used to process the information properly. These separated files are used if the board house supports a paint-scratch-paint process where the entire positive layer is written (painted), the negative layer is removed (scratched) from the positive layer, and finally the normal layer is written (painted). Both techniques are discussed in "Paint-Scratch-Paint Technique" on page 28.

The original artwork file for export is shown in Figure 35. This artwork is almost identical to Figure 34 with an additional pad in the upper left corner. Also, the device package layers are removed since only the metal patterns are exported for processing.

Merged Artwork File

To export the normal, positive, and negative layers to one Gerber (GDSII or DXF) file, the layer mapping must be properly set up by opening the Layer Setup dialog box and clicking the Export Mapping tab. You must create a new export mapping table for a Gerber file. Click New Export Mapping and select Gerber as the type. You can specify the name for this map. Finally, the only layers that should be written are the normal, positive, and negative layers. These drawing layers should have the Write Layer column checked. In this example, these are Top Metal, Top Metal+, and Top Metal- layers. Since Gerber does not understand layers, do not check this column for any other layers, or any artwork on these layers is merged into this file.

Figure 36 shows the export mapping settings for the merged Gerber file. The only other check box you must select is Union layout shapes in the Layout Options dialog box. With this check box selected, the normal, negative, and
positive layers are merged into the Gerber file. Access this dialog box by choosing Options > Layout Options and select the Layout tab. This setting is shown in Figure 37.

The layout for this example does not include any artwork on the bottom of the board. If you had to export this layer, this process is repeated, except the normal, positive, and negative layers for the bottom layer would be exported.

Figure 38 shows the Gerber file imported into a 3rd party Gerber viewer.

Notice that the normal, positive, and negative layers were properly manipulated to give the correct artwork file.

Paint-Scratch-Paint Technique

Some board houses prefer a paint-scratch-paint technique when making boards of this type. This technique involves the photoplotter painting the positive layer, scratching out the negative layer, and then painting the normal layer. Figure 39, which is the artwork for Figure 38 with the fill color turned off, illustrates the reason for using this approach.

Note how the artwork is drawn around the open area at the top left. It is not possible to draw this “donut” type shape as a polygon without making a break in the donut shape. The line that is drawn down the left side from the open area is required to drawn this shape as a polygon. Because Microwave Office currently exports Gerber as polygons, this can sometimes cause problems with photoplotters. The paint-scratch-paint technique overcomes this problem.

Exporting Three Separate Gerber Files

The first way to use paint-scratch-paint is to export three separate Gerber files. Microwave Office can accommodate this with some changes in its setup. Instead of exporting three files at once; you must export the normal, positive, and negative layer separately to their own Gerber files by checking the respective Write Layer column in the Export Mapping tab of the Layout Setup dialog box for each layer and then exporting the layers individually.

This process must be repeated three times to get all of the layers exported for the top metal patterns. Using Microwave Office’s built-in COM interface, this process is automated by a Microwave Office scripting language that uses Visual Basic. This script (“ExportGerberFiles_user_selected”) is located in the Microwave Office project accompanying this application note.

The script looks at the export mapping you select for layers that have Write Layer checked and then exports one file for each layer selected.

With the paint-scratch-paint method, the first paint layer, the positive layer (Top Metal+), is shown in Figure 40.

The scratch layer, the negative layer (Top Metal-), is shown in Figure 41.

Finally the second pain layer, the normal layer (Top Metal) is shown in Figure 42.

When these layers are combined properly using photoplotter techniques, the pattern on the board looks like Figure 35.

Creating One Gerber File with All Layer Information

The second paint-scratch-paint technique is to create one Gerber file that has all of the positive, negative, and normal layer information in one file. You can merge the files that were output separately by including the correct Gerber commands to tell which information is a paint layer and which is a scratch layer. The Microwave Office scripting language also automates this process with the “ExportGerberFiles_PSP” script in the accompanying project.

This script works by first asking which layer to export. It determines which draw layers have the required negative and positive layers defined and then asks for the layout to export. Finally, the script asks for a file name for the new Gerber file. The script exports the three files separately and then merges them into one file with the appropriate control strings to distinguish between paint and scratch information. When this single file is read into a Gerber reader, the artwork is identical to Figure 35.

Conclusion

 Click here to expand...

This application note has demonstrated some of the powerful layout capabilities available in Microwave Office for complete PCB designs. By leveraging some simple set-up techniques with a knowledge of how the Microwave Office layout tool operates, it is possible to efficiently create complex PCB layouts in a fraction of the time it would take when using normal techniques. Additionally, the power of the scripting environment is used to produce variations of a Gerber layout output file depending on the specific requirements of the process used to manufacture the board.

 

 

 

  • No labels