AWR Design Environment
Dialog Box Reference
Product Version 16.03

AWR Design Environment Dialog Box Reference
© 2022 Cadence Design Systems, Inc. All rights reserved.
Printed in the United States of America.
Cadence Design Systems, Inc. (Cadence), 2655 Seely Ave., San Jose, CA 95134, USA.
Open SystemC, Open SystemC Initiative, OSCI, SystemC, and SystemC Initiative are trademarks or registered
trademarks of Open SystemC Initiative, Inc. in the United States and other countries and are used with permission.
Trademarks: Trademarks and service marks of Cadence Design Systems, Inc. (Cadence) contained in this document
are attributed to Cadence with the appropriate symbol. For queries regarding Cadence’s trademarks, contact the
corporate legal department at the address shown above or call 800.862.4522.
All other trademarks are the property of their respective holders.
Restricted Permission:This publication is protected by copyright law and international treaties and contains trade
secrets and proprietary information owned by Cadence. Unauthorized reproduction or distribution of this publication,
or any portion of it, may result in civil and criminal penalties. Except as specified in this permission statement, this
publication may not be copied, reproduced, modified, published, uploaded, posted, transmitted, or distributed in any
way, without prior written permission from Cadence. Unless otherwise agreed to by Cadence in writing, this statement
grants Cadence customers permission to print one (1) hard copy of this publication subject to the following conditions:
1. The publication may be used only in accordance with a written agreement between Cadence and its customer.
2. The publication may not be modified in any way.
3. Any authorized copy of the publication or portion thereof must include all original copyright, trademark, and other
proprietary notices and this permission statement.
4. The information contained in this document cannot be used in the development of like products or software,
whether for internal or external use, and shall not be used for the benefit of any other party, whether or not for
consideration.
Disclaimer: Information in this publication is subject to change without notice and does not represent a commitment
on the part of Cadence. Except as may be explicitly set forth in such agreement, Cadence does not make, and
expressly disclaims, any representations or warranties as to the completeness, accuracy or usefulness of the
information contained in this document. Cadence does not warrant that use of such information will not infringe any
third party rights, nor does Cadence assume any liability for damages or costs of any kind that may result from use
of such information.
Restricted Rights: Use, duplication, or disclosure by the Government is subject to restrictions as set forth in
FAR52.227-14 and DFAR252.227-7013 et seq. or its successor.

Table of Contents
Preface ............................................................................................................................................. 1–1
About This Book ........................................................................................................................ 1–2
Getting Online Help .................................................................................................................... 1–4
Legal Notices ..................................................................................................................................... 2–1
Legal Notices ............................................................................................................................. 2–2
Environment Options ........................................................................................................................... 3–1
Environment Options Dialog Box: Project Tab ................................................................................. 3–2
Environment Options Dialog Box: Mouse Tab ................................................................................. 3–4
Environment Options Dialog Box: Colors Tab ................................................................................. 3–6
Environment Options Dialog Box: Schematics/Diagrams Tab ............................................................. 3–7
Environment Options Dialog Box: Schematic Annotation Tab ............................................................ 3–8
Environment Options Dialog Box: Layout Tab ................................................................................. 3–9
Environment Options Dialog Box: File Locations Tab ..................................................................... 3–11
Font Dialog Box ...................................................................................................................... 3–12
Projects ............................................................................................................................................. 4–1
Project Options Dialog Box: Frequencies Tab .................................................................................. 4–2
Project Options Dialog Box: Schematics/Diagrams Tab ..................................................................... 4–3
Project Options Dialog Box: Global Units Tab ................................................................................. 4–4
Project Options Dialog Box: Interpolation/Passivity Tab .................................................................... 4–6
Project Options Dialog Box: MWO Server Scheduler Tab .................................................................. 4–8
Design Environment Options Dialog Box ...................................................................................... 4–10
Data File Options Dialog Box: Raw Data Format Tab ....................................................................... 4–11
Data File Options Dialog Box: MDIF Files Tab .............................................................................. 4–13
Options - Data File Dialog Box: Interpolation/Passivity Tab ............................................................. 4–14
Manage Symbols Dialog Box ..................................................................................................... 4–15
Import Symbols Dialog Box ....................................................................................................... 4–16
Export Symbols Dialog Box ....................................................................................................... 4–17
Simulation Filters Dialog Boxes .................................................................................................. 4–18
Switch List Dialog Boxes ........................................................................................................... 4–20
Edit Subcircuit Dialog Box ......................................................................................................... 4–23
Add/Edit Schematic/System Diagram/EM Structure Annotation Dialog Box ........................................ 4–24
Known Migration Issues Dialog Box ............................................................................................ 4–25
Import Project Dialog Box ......................................................................................................... 4–26
Open Example Project Dialog Box .............................................................................................. 4–27
Measurement Editor .................................................................................................................. 4–29
Job Scheduler Admin Dialog Box: General Settings Tab .................................................................. 4–31
Verify Host Failed Dialog Box ..................................................................................................... 4–36
Send Diagnostic Files Dialog Box ................................................................................................ 4–37
Version Control Dialog Box ........................................................................................................ 4–38
Schematics ........................................................................................................................................ 5–1
Element Options Dialog Box: Parameters Tab .................................................................................. 5–2
Element Options Dialog Box: User Attributes Tab ............................................................................. 5–4
Element Options Dialog Box: Symbol Tab ....................................................................................... 5–5
Element Options Dialog Box: Layout Tab ........................................................................................ 5–6
Element Options Dialog Box: Model Options Tab ............................................................................. 5–7
Element Options Dialog Box: (Distributed Line) Model Options Tab .................................................... 5–8
Element Options Dialog Box: (Subcircuit) Model Options Tab ............................................................ 5–9
Element Options Dialog Box: Port Tab .......................................................................................... 5–11
Element Options Dialog Box: Ground Tab ..................................................................................... 5–13

Dialog Box Referenceiii

Contents
Element Options Dialog Box: Net Properties Tab ............................................................................ 5–14
Element Options-(Schematic) EXTRACT Properties Dialog Box: SPICE Model Generation Tab ............. 5–15
Element Options-(Schematic) STACKUP Properties Dialog Box: Material Defs. Tab ............................. 5–17
Element Options-(Schematic) STACKUP Properties Dialog Box: Dielectric Layers Tab ......................... 5–21
Element Options-(Schematic) STACKUP Properties Dialog Box: Materials Tab .................................... 5–23
Element Options-(Schematic) STACKUP Properties Dialog Box: EM Layer Mapping Tab ...................... 5–24
Element Options-(Schematic) STACKUP Properties Dialog Box: Line Type Tab ................................... 5–26
Element Options-(Schematic) STACKUP Properties Dialog Box: Parameters Tab ................................. 5–28
Element Options-(Schematic) STACKUP Properties Dialog Box: User Attributes Tab ............................ 5–30
Element Options-(Schematic) STACKUP Properties Dialog Box: Symbol Tab ...................................... 5–31
Element Options-(Schematic) STACKUP Properties Dialog Box: Rules Tab ......................................... 5–32
New Netlist Dialog Box ............................................................................................................. 5–33
Add Subcircuit Element Dialog Box ............................................................................................. 5–34
Circuit Options Dialog Box: Layout Tab ........................................................................................ 5–35
Circuit Options Dialog Box: Paths Tab .......................................................................................... 5–36
Circuit Options Dialog Box: iNet Tab ............................................................................................ 5–37
Circuit Options Dialog Box: Spectre Tab ....................................................................................... 5–38
Circuit Options Dialog Box: Job Scheduler Tab .............................................................................. 5–39
Circuit Options Dialog Box: Nets/Voiding Tab ................................................................................ 5–40
Options Dialog Box: Frequencies Tab ........................................................................................... 5–41
Options Dialog Box: Schematic Tab ............................................................................................. 5–42
Options Dialog Box: Symbol Tab ................................................................................................ 5–43
Options Dialog Box: iNet Tab ...................................................................................................... 5–44
Options Dialog Box: Locking Tab ............................................................................................... 5–45
Options Dialog Box: Spectre Tab ................................................................................................. 5–46
Options Dialog Box: Job Scheduler Tab ......................................................................................... 5–47
Options Dialog Box: Nets/Voiding Tab .......................................................................................... 5–48
Rename Netlist Dialog Box ......................................................................................................... 5–49
Rename Data File Dialog Box ..................................................................................................... 5–50
Save Simulation Results Dialog Box ............................................................................................. 5–51
Swap Element Dialog Box .......................................................................................................... 5–52
Restrict Selection (Schematics) Dialog Box .................................................................................... 5–53
Transmission Line Calculator Dialog Box ...................................................................................... 5–54
Element Selection Tool Dialog Box .............................................................................................. 5–55
Export Cadence Unified Library Dialog Box .................................................................................. 5–56
EM Structures .................................................................................................................................... 6–1
New EM Structure Dialog Box ...................................................................................................... 6–2
Project Level Defaults - EM Options Dialog Boxes ........................................................................... 6–4
EM Options Dialog Box: Layout Tab .............................................................................................. 6–5
EM Options Dialog Box: Current View Tab ..................................................................................... 6–6
EM Options Dialog Box: Job Scheduler Tab .................................................................................... 6–7
EM Options Dialog Box: EMSight Tab ........................................................................................... 6–9
EM Options Dialog Box: NET-AN Options Tab .............................................................................. 6–12
EM Options Dialog Box: ACE Tab ............................................................................................... 6–13
Document Level Defaults - Options Dialog Boxes .......................................................................... 6–16
Select a Simulator Dialog Box ..................................................................................................... 6–17
Options Dialog Box: General Tab ................................................................................................. 6–18
Options Dialog Box: Frequencies Tab ........................................................................................... 6–19
Options Dialog Box: Layout Tab .................................................................................................. 6–21
Options Dialog Box: Current View Tab ......................................................................................... 6–22
Options Dialog Box: Interpolation/Passivity Tab ............................................................................. 6–23

iv AWR Design Environment

Contents
Options Dialog Box: Job Scheduler Tab ......................................................................................... 6–24
Options Dialog Box: Custom Tabs ................................................................................................ 6–25
Options Dialog Box: NET-AN Options Tab .................................................................................... 6–26
Options Dialog Box: EMSight Tab ............................................................................................... 6–27
Options Dialog Box: ACE Tab ..................................................................................................... 6–28
Solver Information Dialog Box: Summary Tab ................................................................................ 6–29
Solver Information Dialog Box: Simulation Log Tab ........................................................................ 6–31
Properties Dialog Box: Layout Tab ............................................................................................... 6–32
Properties Dialog Box: Boundary Conditions Tab ........................................................................... 6–33
Port Attributes Dialog Box .......................................................................................................... 6–34
EM Ports Properties Dialog Box .................................................................................................. 6–36
Element Options-(EM) ENCLOSURE Properties: Enclosure Tab ....................................................... 6–38
Element Options-(EM) ENCLOSURE Properties Dialog Box: Material Defs. Tab ................................. 6–39
Element Options-(EM) ENCLOSURE Properties Dialog Box: Dielectric Layers Tab ............................. 6–43
Element Options-(EM) ENCLOSURE Properties Dialog Box: Materials Tab ........................................ 6–45
Element Options-(EM) ENCLOSURE Properties Dialog Box: EM Layer Mapping Tab .......................... 6–47
Element Options-(EM) ENCLOSURE Properties Dialog Box: Line Type Tab ....................................... 6–49
Element Options-(EM) STACKUP Properties Dialog Box: Parameters Tab .......................................... 6–51
Element Options-(EM) STACKUP Properties Dialog Box: Display Tab .............................................. 6–53
Element Options-(EM) STACKUP Properties Dialog Box: Rules Tab ................................................. 6–54
Restrict Selection (EM) Dialog Box .............................................................................................. 6–55
Preview Geometry Dialog Box .................................................................................................... 6–56
Show Geometry Dialog Box ........................................................................................................ 6–57
System Simulators .............................................................................................................................. 7–1
System Simulator Options Dialog Box: RF Frequencies Tab ............................................................... 7–2
Options Dialog Box: RF Frequencies Tab ........................................................................................ 7–3
Options Dialog Box: System Diagram Tab ....................................................................................... 7–4
System Node Settings Dialog Box .................................................................................................. 7–5
Restrict Selection (System Diagrams) Dialog Box ............................................................................. 7–6
Signal Heritage Dialog Box .......................................................................................................... 7–7
Sweep Setup Dialog Box .............................................................................................................. 7–8
Graphs and Output Files ....................................................................................................................... 8–1
New Graph Dialog Box ................................................................................................................ 8–2
Add/Modify Measurement Dialog Box ........................................................................................... 8–4
Add/Modify Output File Dialog Box .............................................................................................. 8–6
Select a Graph for the Measurement Dialog Box ............................................................................... 8–8
Tabular Graph Options Dialog Box ................................................................................................ 8–9
Graph Options Dialog Box: Axes Tab ........................................................................................... 8–10
Graph Options Dialog Box: Traces Tab ......................................................................................... 8–12
Graph Options Dialog Box: Format Tab ......................................................................................... 8–14
Graph Options Dialog Box: Labels Tab ......................................................................................... 8–16
Graph Default Options Dialog Box: Labels Tab ............................................................................... 8–17
Graph Options Dialog Box: Fonts Tab ........................................................................................... 8–18
Graph Options Dialog Box: Measurements Tab ............................................................................... 8–19
Graph Options Dialog Box: Markers Tab ....................................................................................... 8–21
Add/Edit Auto-Search Marker Dialog Box ..................................................................................... 8–23
Graph Options Dialog Box: Numeric Tab ....................................................................................... 8–24
Graph Options Dialog Box: Yield Data Tab .................................................................................... 8–26
Antenna/Polar Plot Options Dialog Box: Grid Tab ........................................................................... 8–27
Smith Chart Options Dialog Box: Grid Tab .................................................................................... 8–28
Graph Options Dialog Box: Units Tab ........................................................................................... 8–29

Dialog Box Referencev

Contents
3D Plot Options Dialog Box: Axes Tab ......................................................................................... 8–30
3D Plot Options Dialog Box: Surface Tab ...................................................................................... 8–31
3D Plot Options Dialog Box: Lighting Tab ..................................................................................... 8–33
Tuning, Optimizing, and Yield Analysis .................................................................................................. 9–1
Optimizer Dialog Box .................................................................................................................. 9–2
Variables Window ....................................................................................................................... 9–4
Yield Analysis Dialog Box ........................................................................................................... 9–6
New/Modify Optimization Goal Dialog Box .................................................................................... 9–8
New/Modify Yield Goal Dialog Box ............................................................................................... 9–9
Tuner Dialog Box ...................................................................................................................... 9–10
Layout ............................................................................................................................................ 10–1
Options - Drawing Layer 2D Properties Dialog Box ........................................................................ 10–2
Options - Model Layer Mappings Dialog Box ................................................................................ 10–4
Options - Drawing Layer 3D Dialog Box ...................................................................................... 10–5
Options - EM Layer Mappings Dialog Box .................................................................................... 10–7
Options - File Export Mapping GDSII Dialog Box .......................................................................... 10–8
Options - Units Dialog Box ........................................................................................................ 10–9
Options - Grids Dialog Box ...................................................................................................... 10–10
Options - Default Values Dialog Box .......................................................................................... 10–11
Options - Drill Hole Layers Dialog Box ...................................................................................... 10–12
Options - Voiding Options Dialog Box ........................................................................................ 10–13
Options - Voiding Constraint Sets Dialog Box .............................................................................. 10–14
Layout Options Dialog Box: Layout Tab ..................................................................................... 10–15
Layout Options Dialog Box: Export/LPF Tab ............................................................................... 10–17
Layout Options Dialog Box: iNet Tab ......................................................................................... 10–19
Layout Options Dialog Box: Paths Tab ....................................................................................... 10–21
Layout Options Dialog Box: Boolean Tab .................................................................................... 10–23
Layout Options Dialog Box: Dimension Lines Tab ........................................................................ 10–24
Layout Options Dialog Box: Ruler Tab ....................................................................................... 10–25
Layout Options Dialog Box: Layout Font Tab .............................................................................. 10–26
Layout Options Dialog Box: Gds Cell Stretcher Tab ...................................................................... 10–27
Layout Options Dialog Box: Placement Tab ................................................................................. 10–29
Properties Dialog Box: Layout Tab ............................................................................................ 10–30
Properties Dialog Box: Arc Tab ................................................................................................. 10–31
Properties Dialog Box: Path Tab ................................................................................................ 10–32
Properties Dialog Box: Circle Tab .............................................................................................. 10–33
Properties Dialog Box: Ellipse Tab ............................................................................................. 10–34
Properties Dialog Box: Rectangle Tab ......................................................................................... 10–35
Properties Dialog Box: Cell Port Tab .......................................................................................... 10–36
Properties Dialog Box: Cell Pin Tab ........................................................................................... 10–37
Properties Dialog Box: Route Tab .............................................................................................. 10–38
Properties Dialog Box: Segments Tab ......................................................................................... 10–40
Properties Dialog Box: Vias Tab ................................................................................................ 10–41
Properties Dialog Box: iNet Tab ................................................................................................ 10–42
Properties Dialog Box: Information Tab ...................................................................................... 10–43
Properties Dialog Box: Dimension Line Tab ................................................................................ 10–44
Properties Dialog Box: Ruler Tab ............................................................................................... 10–45
Properties Dialog Box: Font Tab ................................................................................................ 10–46
Properties Dialog Box: Gds Cell Stretcher Tab ............................................................................. 10–47
Properties Dialog Box: Drill Hole Tab ........................................................................................ 10–49
Properties Dialog Box: Net Properties Tab ................................................................................... 10–50

vi AWR Design Environment

Contents
Cell Library Properties Dialog Box ............................................................................................ 10–51
Rename Cell Dialog Box .......................................................................................................... 10–53
Import DXF File Dialog Box .................................................................................................... 10–54
Cell Options Dialog Box: Layout Tab ......................................................................................... 10–55
Cell Options Dialog Box: Faces Tab ........................................................................................... 10–57
Cell Options Dialog Box: Parameters Tab .................................................................................... 10–59
Create Pin Dialog Box: Cell Pin Tab ........................................................................................... 10–60
Restrict Selection (Layouts) Dialog Box ...................................................................................... 10–61
Restrict Selection (Artwork Cell) Dialog Box ............................................................................... 10–62
Layout Editor Mode Settings Dialog Box .................................................................................... 10–63
Layout Mode Properties Dialog Box ........................................................................................... 10–67
Connectivity Highlight Rules Dialog Box .................................................................................... 10–68
Error Marker Options Dialog Box .............................................................................................. 10–69
Make New GDS Cell Dialog Box .............................................................................................. 10–70
Copy Cell Dialog Box ............................................................................................................. 10–71
Merge Cell Libraries Dialog Box ............................................................................................... 10–72
Modify Selected Vertices Dialog Box ......................................................................................... 10–73
Modify Corners Dialog Box ...................................................................................................... 10–74
Modifier Properties Dialog Box: Shape Modifiers tab .................................................................... 10–75
Modifier Properties Dialog Box: Layer Modifiers tab .................................................................... 10–77
Properties Dialog Box: Edge Modifier ........................................................................................ 10–79
Properties Dialog Box: Point Stretch Modifier .............................................................................. 10–82
Properties Dialog Box: Width Modifier ....................................................................................... 10–83
Properties Dialog Box: Radius Modifier ...................................................................................... 10–85
Properties Dialog Box: Ellipse Size Modifier ............................................................................... 10–86
Properties Dialog Box: Array Modifier ....................................................................................... 10–87
Properties Dialog Box: Spacing Modifier .................................................................................... 10–88
Properties Dialog Box: Polar Spacing Modifier ............................................................................ 10–90
Properties Dialog Box: Stretch Area Modifier .............................................................................. 10–93
Properties Dialog Box: Control Point Modifier ............................................................................. 10–95
Properties Dialog Box: Layer Offset Modifier .............................................................................. 10–96
Properties Dialog Box: Layer Resize Modifier .............................................................................. 10–97
Properties Dialog Box: Layer Boolean Modifier ........................................................................... 10–98
Properties Dialog Box: Layer Corner Modifier ........................................................................... 10–103
Properties Dialog Box: Shape Preprocessor (SPP) Modifier ........................................................... 10–109
Debug Cell Instance Dialog Box ............................................................................................... 10–111
Associate Cell Dialog Box ...................................................................................................... 10–112
Align Shapes to Array Dialog Box ........................................................................................... 10–113
Via Fill Dialog Box ............................................................................................................... 10–114
Via Fence Dialog Box ............................................................................................................ 10–117
Simplification Properties Dialog Box ........................................................................................ 10–121
Net and Constraint View Window ............................................................................................ 10–125
Variables and Equations ...................................................................................................................... 11–1
Edit Equation Dialog Box ........................................................................................................... 11–2
Add/Modify Measurement Equation Dialog Box ............................................................................. 11–4
Wizards ........................................................................................................................................... 12–1
RFB Spreadsheet Wizard Block Properties Dialog Box: Block Tab .................................................... 12–2
RFB Spreadsheet Wizard Block Properties Dialog Box: Parameters Tab ............................................. 12–3
RFB Spreadsheet Wizard Branch Properties Dialog Box ................................................................... 12–4
RFB Spreadsheet Wizard Connect Branch Dialog Box ..................................................................... 12–5
RFB Spreadsheet Wizard Format Properties Dialog Box: Numbers Tab ............................................... 12–6

Dialog Box Referencevii

Contents
RFB Spreadsheet Wizard Format Properties Dialog Box: Font and Selection Font Tabs .......................... 12–7
RFB Spreadsheet Wizard Format Properties Dialog Box: Alignment and Selection Alignment Tabs .......... 12–8
RFB Spreadsheet Wizard Header/Footer Dialog Box ........................................................................ 12–9
RFB Spreadsheet Wizard Measurement Properties Dialog Box: Measurement Definition Tab ................. 12–10
RFB Spreadsheet Wizard Measurement Properties Dialog Box: Graph Tab ......................................... 12–11
RFB Spreadsheet Wizard Mixer LO Dialog Box ............................................................................ 12–12
RF Budget Wizards Options Properties Dialog Box: General Tab ...................................................... 12–13
RFB Spreadsheet Wizard Parameter Definition Dialog Box ............................................................. 12–14
RFB Spreadsheet Wizard Rename Branch Dialog Box .................................................................... 12–15
RFB Spreadsheet Wizard Resolve Conflict Dialog Box ................................................................... 12–16
RFB Spreadsheet Wizard Select Branch Dialog Box ....................................................................... 12–17
Create New Process Dialog Box ................................................................................................. 12–18
Layer Generation Defaults Dialog Box ........................................................................................ 12–23
PCB Import Wizard Dialog Box: Options Tab ............................................................................... 12–25
PCB Import Wizard Dialog Box: Layers Tab ................................................................................ 12–26
PCB Import Wizard Dialog Box: Nets Tab ................................................................................... 12–27
PCB Import Wizard Dialog Box: Stackup Tab ............................................................................... 12–28
Stability Analysis Wizard Simulation Settings Dialog Box .............................................................. 12–29
Cadence Unified Library Import Wizard Dialog Box: Options Tab .................................................... 12–31
Cadence Unified Library Import Wizard Dialog Box: Layers Tab ..................................................... 12–32
Cadence Unified Library Import Wizard Dialog Box: LineTypes Tab ................................................. 12–33
Cadence Unified Library Import Wizard Dialog Box: Stackup Tab .................................................... 12–34
Licensing ......................................................................................................................................... 13–1
AWR License Configuration Dialog Box ....................................................................................... 13–2
Select License Features Dialog Box .............................................................................................. 13–4
License Configuration Dialog Box ................................................................................................ 13–5

viii AWR Design Environment

Preface
The Cadence® AWR Design Environment® platform incorporating Cadence Microwave Office® software and Cadence
Visual System Simulator™ (VSS) communications and radar systems design software, is a powerful fully-integrated
design and analysis tool for RF, microwave, millimeterwave, analog, and RFIC design that allows you to incorporate
circuit designs into system designs without leaving the AWR Design Environment software.
Microwave Office software allows you to create complex circuit designs composed of linear, nonlinear, and EM structures,
and generate layout representations of these designs. They allow you to perform fast and accurate analysis of your designs
using linear, nonlinear harmonic balance, electromagnetic (EM), Cadence APLAC® HB, and SPECTRE simulation
engines, and feature real-time tuning and optimizing capabilities.
VSS software is the system level design component of the AWR Design Environment suite. With this software you can
analyze a complete communications system, from data encoding through transmission, reception, and data decoding.
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About This Book

About This Book
This book is a comprehensive reference of all of the dialog boxes within the AWR Design Environment suite. Each
section includes the dialog boxes specific to a certain function or step in the design process.

Additional Documentation
The AWR Design Environment platform includes the following additional documentation:
• What's New in AWR Design Environment v15? presents the new features, user interface, elements, system blocks, and
measurements for this release.
• The AWR Design Environment Installation Guide describes how to install the AWR Design Environment platform
and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips.
This document is downloadable from the Cadence AWR Knowledge Base.
• The AWR Design Environment Getting Started Guide familiarizes you with the AWR Design Environment platform
through Microwave Office software, VSS software, Cadence Analyst™ 3D FEM EM analysis software, and Monolithic
Microwave Integrated Circuit (MMIC) examples.
Microwave Office example projects show how to design and analyze simple linear, nonlinear, and EM circuits, and
how to create layouts. VSS examples show how to design systems and perform simulations using predefined or
customized transmitters and receivers. Analyst examples show how to create and simulate 3D EM structures from
Microwave Office, and MMIC examples show MMIC features and designs.
You can perform simulations using a number of simulators, and then display the output in a wide variety of graphical
forms based on your analysis needs. You can also tune or optimize the designs, and your changes are automatically
and immediately reflected in the layout.
• The AWR Design Environment User Guide provides an overview of the AWR Design Environment platform including
chapters on the user interface; using schematics/system diagrams, data files, netlists, graphs, measurements, and output
files; using variables and equations in projects, and more. In addition, an appendix providing guidelines for starting a
new design is included.
• The AWR Design Environment Simulation and Analysis Guide discusses simulation basics such as swept parameter
analysis, tuning/optimizing/yield, and simulation filters; and provides simulation details for DC, linear, AC, harmonic
balance, transient, and EM simulation/extraction theory and methods.
• The AWR Microwave Office Layout Guide contains information on creating and viewing layouts for schematics and
EM structures, including use of the Layout Manager, Layout Process File, artwork cell creation/editing/properties,
Design Rule Checking, and other topics.
• The AWR Microwave Office Element Catalog provides complete reference information on the electrical element
model database that you use to build schematics.
• The AWR Visual System Simulator System Block Catalog provides complete reference information on all of the
system blocks that you use to build systems.
• The AWR Microwave Office Measurement Catalog provides complete reference information on the "measurements"
(computed data such as gain, noise, power, or voltage) that you can choose as output for your simulations.
• The AWR Visual System Simulator Measurement Catalog provides complete reference information on the measurements
you can choose as output for your simulations.
• The AWR Visual System Simulator Modeling Guide contains information on simulation basics, RF modeling
capabilities, and noise modeling.
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• The AWR API Scripting Guide explains the basic concepts of AWR Design Environment platform scripting and
provides coding examples. It also provides information on the most useful objects, properties, and methods for creating
scripts in the AWR Script Development Environment (AWR SDE). In addition, this guide contains the AWR Design
Environment Component API list.
• The AWR Design Environment Quick Reference document lists keyboard shortcuts, mouse operations, and tips and
tricks to optimize your use of the AWR Design Environment platform. This document is available within the program
by choosing Help > Quick Reference.

Typographical Conventions
This guide uses the following typographical conventions.
Item

Convention

Anything that you select (or click on) in the AWR Design Shown in a bold alternate font. Nested menu selections are
Environment program, such as menus, nested submenus, shown with a ">" to indicate that you select the first menu
menu options, dialog box options, buttons, and tab names item and then select the submenu item:
Choose File > New Project.
Text that you enter using the keyboard

Shown in a bold within quotation marks:
Enter "my_project" in Project Name.

Keys or key combinations that you press

Shown in a bold alternate font with initial capitals. Key
combinations using a "+" indicate that you press and hold
the first key while pressing the second key:
Press Alt+F1.

File names and directory paths

Shown in italics:
See the DEFAULTS.LPF file.

Contents of a file, fields within a file, command names,
Shown in a mono-spaced font:
command switches/arguments, or output from a command
Define this parameter in the $DEFAULT_VALUES field.
at the command prompt

Dialog Box Reference1–3

Getting Online Help

Getting Online Help
The AWR Design Environment platform online Help provides information on the windows, menus, and dialog boxes
that compose the design environment, as well as on the concepts involved.
To access online Help, choose Help from the menu bar, or press F1. The Help menu includes the following options:
Menu Choice

Description

Contents and Index

Open the online Help file to view AWR Design Environment platform Help
topics organized by book/subject, or to search the Help contents by index or
character string.

Help on Selected Item

Access Help on the currently selected item.

Getting Started

View the "Getting Started Guide" that includes introductory material for all
products.

What's New

View the "What's New" document for information about new or enhanced
features, elements, and measurements in the latest release.

Quick Reference

View the AWR Design Environment Quick Reference document to learn keyboard
shortcuts, mouse operations, and tips and tricks to optimize your use of the AWR
Design Environment platform.

Home Page

Open the Cadence AWR web page in your internet browser to the AWR®
software products web page.

AWR e-Learning

Open the e-Learning portal login page in your internet browser to access AWR
software training videos.

Knowledge Base

Open the AWR Knowledge Base in your internet browser to access to a variety
of AWR software documentation and other resources.

Get Technical Support

Access the Cadence Learning and Support portal to search for answers to software
or licensing issues or file a Support case.

Check for Update

Check for AWR software updates using an Autoupdate utility.

Show Files/Directories

Display/open a list of the files and directories the program uses.

Open Example

Display the Open Example Project dialog box to locate a specific project in the
/Examples subdirectory by filtering by keywords or project name.

Show License Agreement

Display the AWR Design Environment platform End User License Agreement.

About

Display AWR software copyright, release, license, and registration information.

In addition, the following context-sensitive Help is available:
• Context-sensitive Help buttons in each dialog box. For example, to view Help for a specific measurement, select the
measurement in the Add/Modify Measurement dialog box, and click the Meas. Help button.
• Context-sensitive Help for each element or system block in the Element Browser, accessed by right-clicking an element
and choosing Element Help. You can also access element Help by choosing Help > Element Help after creating a schematic
or system diagram, or by clicking Element Help in the Element Options dialog box.
• Context-sensitive Help for using the AWR Script Development Environment, accessed by selecting a keyword (for
example; object, object model, or Visual Basic syntax), and pressing F1.
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Legal Notices
© 2022 Cadence Design Systems, Inc. All rights reserved.
Printed in the United States of America.
Cadence Design Systems, Inc. (Cadence), 2655 Seely Ave., San Jose, CA 95134, USA.
Open SystemC, Open SystemC Initiative, OSCI, SystemC, and SystemC Initiative are trademarks or registered trademarks
of Open SystemC Initiative, Inc. in the United States and other countries and are used with permission.

Trademarks
Trademarks and service marks of Cadence Design Systems, Inc. (Cadence) contained in this document are attributed to
Cadence with the appropriate symbol. For queries regarding Cadence’s trademarks, contact the corporate legal department
at the address shown above or call 800.862.4522.
All other trademarks are the property of their respective holders.
Restricted Permission:This publication is protected by copyright law and international treaties and contains trade secrets
and proprietary information owned by Cadence. Unauthorized reproduction or distribution of this publication, or any
portion of it, may result in civil and criminal penalties. Except as specified in this permission statement, this publication
may not be copied, reproduced, modified, published, uploaded, posted, transmitted, or distributed in any way, without
prior written permission from Cadence. Unless otherwise agreed to by Cadence in writing, this statement grants Cadence
customers permission to print one (1) hard copy of this publication subject to the following conditions:
1. The publication may be used only in accordance with a written agreement between Cadence and its customer.
2. The publication may not be modified in any way.
3. Any authorized copy of the publication or portion thereof must include all original copyright, trademark, and other
proprietary notices and this permission statement.
4. The information contained in this document cannot be used in the development of like products or software, whether
for internal or external use, and shall not be used for the benefit of any other party, whether or not for consideration.
Disclaimer: Information in this publication is subject to change without notice and does not represent a commitment on
the part of Cadence. Except as may be explicitly set forth in such agreement, Cadence does not make, and expressly
disclaims, any representations or warranties as to the completeness, accuracy or usefulness of the information contained
in this document. Cadence does not warrant that use of such information will not infringe any third party rights, nor does
Cadence assume any liability for damages or costs of any kind that may result from use of such information.
Restricted Rights: Use, duplication, or disclosure by the Government is subject to restrictions as set forth in FAR52.227-14
and DFAR252.227-7013 et seq. or its successor.

Copyright Notices
Portions of this application are:
• ©1991-1997 Compuware Corporation.
• ©2004 Sax Software Corporation.
• Copyright University of California, Berkeley ©1985,86,87,88,89,90 by Kenneth S. Kundert and the University of
California.
• CM2 library: Contains CM2 MeshTools by Computing Objects, SARL - http://www.computing-objects.com.
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• ©1998 Silicon Graphics, Inc. All Rights Reserved. - http://oss.sgi.com/projects/FreeB/.
• For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:
Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ian
Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum,
Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov,
Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Christian Spieler, Antoine Verheijen, Paul von Behren,
Rich Wales, Mike White
This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or its
contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use
of or inability to use this software.
Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter
it and redistribute it freely, subject to the following restrictions:
1. Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this list of
conditions.
2. Redistributions in binary form must reproduce the above copyright notice, definition, disclaimer, and this list of
conditions in documentation and/or other materials provided with the distribution.
3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with new graphical
interfaces, and dynamic, shared, or static library versions--must be plainly marked as such and must not be
misrepresented as being the original source. Such altered versions also must not be misrepresented as being Info-ZIP
releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation
thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the
explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the
Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s).
4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "WiZ," "Pocket UnZip," "Pocket Zip," and
"MacZip" for its own source and binary releases.
• ©1991-2, RSA Data Security, Inc. Created 1991. All rights reserved. RSA Data Security, Inc. MD5 Message-Digest
Algorithm.
• 7-Zip Copyright ©1999-2016 Igor Pavlov
You can use 7-Zip on any computer, including a computer in a commercial organization. You don't need to register
or pay for 7-Zip.
• GNU LGPL and GPLv3+ libraries
Copyright © 2007 Free Software Foundation, Inc.
This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; version 2.1 or later versions of the License.
This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details.
You can receive a copy of the GNU Lesser General Public License from http://www.gnu.org/
• OpenAccess License V 4.0 Oct. 1, 2004
As distributors of this package, National Instruments acknowledges itself as the originator of any contributions.
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• Visualization Toolkit (VTK)
©1993-2008 Ken Martin, Will Schroeder, Bill Lorensen All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
• Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
• Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
• Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names of any contributors may be used to
endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• Clipper library: Copyright © 2010-2014 Angus Johnson
Bitmask Operators library: © Copyright 2015 Just Software Solutions Ltd
Boost Software License - Version 1.0 - August 17th, 2003
Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and
accompanying documentation covered by this license (the "Software") to use, reproduce, display, distribute, execute,
and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the
Software is furnished to do so, all subject to the following:
The copyright notices in the Software and this entire statement, including the above license grant, this restriction and
the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works
of the Software, unless such copies or derivative works are solely in the form of machine-executable object code
generated by a source language processor.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT
HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER
LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
• Copyright ©2010, Dale Roberts. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
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1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the author nor the names of its contributors may be used to endorse or promote products derived
from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• KLU included, ©2004-2013, University of Florida by Timothy A. Davis and Ekanathan Palamadai. KLU is also
available under other licenses; contact authors for details. http://www.suitesparse.com
• BTF included, ©2004-2013, University of Florida by Timothy A. Davis and Ekanathan Palamadai. BTF is also available
under other licenses; contact authors for details. http://www.suitesparse.com
• AMD ©1996-2015, Timothy A. Davis, Patrick R. Amestoy, and Iain S.Duff. All Rights Reserved. Used in the Cadence®
AWR Design Environment® software under the LGPL v2.1 license.
• COLAMD included, ©1998-2016, Timothy A. Davis. http://www.suitesparse.com
• CXSPARSE included, ©2006, Timothy A. Davis. http://www.suitesparse.com
• ©2009, 2010 by the mingw-w64 project
This license has been certified as open source. It has also been designated as GPL compatible by the Free Software
Foundation (FSF).
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
1. Redistributions in source code must retain the accompanying copyright notice, this list of conditions, and the
following disclaimer.
2. Redistributions in binary form must reproduce the accompanying copyright notice, this list of conditions, and the
following disclaimer in the documentation and/or other materials provided with the distribution.
3. Names of the copyright holders must not be used to endorse or promote products derived from this software without
prior written permission from the copyright holders.
4. The right to distribute this software or to use it for any purpose does not give you the right to use Servicemarks
(sm) or Trademarks (™) of the copyright holders. Use of them is covered by separate agreement with the copyright
holders.
5. If any files are modified, you must cause the modified files to carry prominent notices stating that you changed the
files and the date of any change.
Disclaimer: THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS "AS IS'' AND ANY EXPRESSED
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
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MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• getopt, getopt_long, and getop_long_only
©2002 Todd C. Miller;
THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD
TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS.
IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR
CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
Sponsored in part by the Defense Advanced Research Projects Agency (DARPA) and Air Force Research Laboratory,
Air Force Materiel Command, USAF, under agreement number F39502-99-1-0512.
• ©2000 The NetBSD Foundation, Inc. All rights reserved.
This code is derived from software contributed to The NetBSD Foundation by Dieter Baron and Thomas Klausner.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS ``AS IS''
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• GNU GPLv2+
© 1998, 1999, 2000, 2001, 2002 Red Hat, Inc.
• © 1982, 1983, 1986, 1992, 1993 The Regents of the University of California.
All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
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2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products
derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.
• gdtoa
The author of this software is David M. Gay.
©1997, 1998, 1999, 2000, 2001 by Lucent Technologies All Rights Reserved.
Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee
is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice
and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent
or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific,
written prior permission.
LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS
ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH
THE USE OR PERFORMANCE OF THIS SOFTWARE.
The author of this software is David M. Gay.
©2005 by David M. Gay, All Rights Reserved.
Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee
is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice
and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of the
author or any of his current or former employers not be used in advertising or publicity pertaining to distribution of
the software without specific, written prior permission.
THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR
OR ANY OF HIS CURRENT OR FORMER EMPLOYERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR
CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
The author of this software is David M. Gay.
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©2005 by David M. Gay, All Rights Reserved.
Based on material in the rest of /netlib/fp/gdota.tar.gz, which is ©1998, 2000 by Lucent Technologies.
Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee
is hereby granted, provided that the above copyright notice appear in all copies and that both that the copyright notice
and this permission notice and warranty disclaimer appear in supporting documentation, and that the name of Lucent
or any of its entities not be used in advertising or publicity pertaining to distribution of the software without specific,
written prior permission.
LUCENT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL LUCENT OR ANY OF ITS
ENTITIES BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH
THE USE OR PERFORMANCE OF THIS SOFTWARE.
• Parts of the math library
©1993 by Sun Microsystems, Inc. All rights reserved. Developed at SunSoft, a Sun Microsystems, Inc. business.
• Cephes math lib
©1984-1998 Stephen L. Moshier
• libmangle and gendef
©2009 mingw-w64 project, Contributing authors: Kai Tietz, Jonathan Yong.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this
permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
• PSEH
©2004-2008 KJK::Hyperion
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
Software.
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THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
• Zone Public License (ZPL) Version 2.1
©2009, 2010 by the mingw-w64 project
Disclaimer: THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS "AS IS'' AND ANY EXPRESSED
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
• ©2010 Lockless Inc. All rights reserved.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AN ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• muparser library: The class is licensed under the MIT License: Copyright © 2016 Ingo Berg
JSON library: The class is licensed under the MIT License: Copyright © 2013-2019 Niels Lohmann
date library: The class is licensed under the MIT License: Copyright © 2017 Howard Hinnant
CSV Parser library: The class is licensed under the MIT License: © 2017-2019 Vincent La
whereami library: The class is licensed under the MIT License: © Gregory Pakosz
RapidXML software: The class is licensed under the MIT License: © 2006, 2007 Marcin Kalicinski
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
Software.
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THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
• LAPACK library:
Copyright © 1992-2010 The University of Tennessee and The University of Tennessee Research Foundation. All
rights reserved.
Copyright © 2000-2010 The University of California Berkeley. All rights reserved.
Copyright © 2006-2010 The University of Colorado Denver. All rights reserved.
$COPYRIGHT$
Additional copyrights may follow
$HEADER$
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
• Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
• Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer listed in this license in the documentation and/or other materials provided with the distribution.
• Neither the name of the copyright holders nor the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written permission.
The copyright holders provide no reassurances that the source code provided does not infringe any patent, copyright,
or any other intellectual property rights of third parties. The copyright holders disclaim any liability to any recipient
for claims brought against recipient by any third party for infringement of that parties intellectual property rights.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• libssh2 library:
Copyright © 2004-2007 Sara Golemon <sarag@libssh2.org>
Copyright © 2005,2006 Mikhail Gusarov <dottedmag@dottedmag.net>
Copyright © 2006-2007 The Written Word, Inc. Copyright © 2007 Eli Fant <elifantu@mail.ru>
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Copyright © 2009-2019 Daniel Stenberg
Copyright © 2008, 2009 Simon Josefsson
All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
Neither the name of the copyright holder nor the names of any other contributors may be used to endorse or promote
products derived from this software without specific prior written permission.
* * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND * CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, * INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE * ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR * CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, * BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR * SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS * INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING *
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE * USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY * OF SUCH DAMAGE.
• Mesa 3D library
Copyright © 1999-2007 Brian Paul All Rights Reserved.
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
• Open MPI library
3-Clause BSD License/New BSD License/Modified BSD License
Copyright © 2004-2010 The Trustees of Indiana University and Indiana University Research and Technology
Corporation. All rights reserved.
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THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
• Qhull, Copyright © 1993-2019
http://www.qhull.org/COPYING.txt
• Scintilla and SciTE: Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
All Rights Reserved
Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee
is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and
this permission notice appear in supporting documentation.
NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL HODGSON
BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH
THE USE OR PERFORMANCE OF THIS SOFTWARE.
• Xerxes library: Apache
http://www.apache.org/licenses/LICENSE-2.0
• pybind11 library
Copyright © 2016 Wenzel Jakob <wenzel.jakob@epfl.ch>, All rights reserved.
Redistribution and use in source and binary forms, with or without--> modification, are permitted provided that the
following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following
disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote
products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
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TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
Please also refer to the file CONTRIBUTING.md, which clarifies licensing of external contributions to this project
including patches, pull requests, etc.
• Qhull, Copyright © 1993-2019 by C.B. Barber, Arlington, MA and The National Science and Technology Research
Center for Computation and Visualization of Geometric Structures (The Geometry Center) University of Minnesota,
email: qhull@qhull.org
This software includes Qhull from C.B. Barber and The Geometry Center. Qhull is copyrighted as noted above. Qhull
is free software and may be obtained via http from www.qhull.org. It may be freely copied, modified, and redistributed
under the following conditions:
1. All copyright notices must remain intact in all files.
2. A copy of this text file must be distributed along with any copies of Qhull that you redistribute; this includes copies
that you have modified, or copies of programs or other software products that include Qhull.
3. If you modify Qhull, you must include a notice giving the name of the person performing the modification, the date
of modification, and the reason for such modification.
4. When distributing modified versions of Qhull, or other software products that include Qhull, you must provide
notice that the original source code may be obtained as noted above.
5. There is no warranty or other guarantee of fitness for Qhull, it is provided solely "as is". Bug reports or fixes may
be sent to qhull_bug@qhull.org; the authors may or may not act on them as they desire.
• Curl, Copyright © 1996 - 2022, Daniel Stenberg, daniel@haxx.se, and many contributors
All rights reserved.
Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted,
provided that the above copyright notice and this permission notice appear in all copies.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to
promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.
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Environment Options Dialog Box: Project Tab

The Environment Options dialog box Project tab allows you to modify options related to how items display in the Project
Browser, project saving, and which features are activated. To access this tab, choose Options > Environment Options. This
dialog box contains the following options:
Field

Description

Reset Defaults

Returns all options to their default settings.

Project Browser

Select options to specify how items are displayed in the Project Browser:
Only Show Top Level Schematic Nodes: Does not display sub-circuits under schematics in the
Circuit Schematics node.
Show Options as Sub-nodes: Displays sub-nodes for easy access to option dialog boxes. Normally
these dialog boxes are opened by right-clicking a main node and choosing Option. For example,
Default Ckt Options displays under Circuit Schematics if this option is selected, otherwise you
right-click Circuit Schematics, and choose Options to display the dialog box.
Collapse on Open: Displays only the top level nodes the next time the project is opened, regardless
of the state of the Project Browser from previous saves.
Environment Nodes in Project Tree: Displays the Environment Options node for easy access to the
Environment Options dialog box.

Save Options

Specify options related to saving projects:
Autosave: Automatically save your project at the interval specified in Minutes.
Minutes: Specify the number of minutes after which you want a project automatically saved.
Save Revisions: Retain previously saved versions of this project. Saved Revisions have ".bk<#>"
appended to their names. The most recent revision is ".emp.bk1" and the oldest is ".emp.bkN"
where N is the maximum number of revisions specified.
Previous Versions: Specify the number of previous versions of the current project you want to
keep.
Save Before Simulating: Automatically save a project before simulation.
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Field

Description

Miscellaneous

Show Splash Screen at Startup: Display the Cadence® AWR Design Environment® splash screen

when the program starts.
Run Scripting at Startup: Start the scripting environment in the background when the program
starts. Otherwise, the scripting environment starts on demand.
Disabled Goals Draw on Graph: Select to display disabled optimization or yield goals in dimmed
colors on their respective graphs. Select this option if you want to take pictures or copy graphs
to other applications where you don't want to lose your goals, but don't want the goals interfering
with the graph's appearance.
Disabled Measurements in Legends: Select to display disabled measurements in dimmed colors
on the graph legend.
Equation Edit Auto-complete: Auto-complete equations and variables. See “Equation
Auto-Complete” for details.
Max # of Param Markers: Specify the maximum number of parameter markers to display on a
graph. Valid values are zero through 1000.
Graphics Acceleration

Enable 2D layout view:

Provides faster 2D layout rendering with GPU. When not selected, the
CPU is used for rendering.
Enable 3D layout view: Provides faster 3D layout rendering with GPU. When not selected, the
CPU is used for rendering.
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The Environment Options dialog box Mouse tab allows you to customize use of the mouse wheel for specific operations.
To access this tab, choose Options > Environment Options. This dialog box contains the following options:
Field

Description
a

Zoom

Select an option to specify which (if any) key the mouse wheel zoom operation uses:
None: Zoom in or out by scrolling the mouse wheel alone.
Shift: Zoom in or out by pressing the Shift key while scrolling the mouse wheel.
Ctrl: Zoom in or out by pressing the Ctrl key while scrolling the mouse wheel.
Shift-Ctrl: Zoom in or out by pressing the Shift + Ctrl keys while scrolling the mouse wheel.
Shift-Alt: Zoom in or out by pressing the Shift + Alt keys while scrolling the mouse wheel.

Vertical Scrolla

Select an option to specify which (if any) key the mouse wheel vertical scroll operation uses:
None: Scroll vertically by scrolling the mouse wheel alone.
Shift: Scroll vertically by pressing the Shift key while scrolling the mouse wheel.
Ctrl: Scroll vertically by pressing the Ctrl key while scrolling the mouse wheel.
Shift-Ctrl: Scroll vertically by pressing the Shift + Ctrl keys while scrolling the mouse wheel.
Shift-Alt: Scroll vertically by pressing the Shift + Alt keys while scrolling the mouse wheel.

Horizontal Scrolla

Select an option to specify which (if any) key the mouse wheel horizontal scroll operation uses:
None: Scroll horizontally by scrolling the mouse wheel alone.
Shift: Scroll horizontally by pressing the Shift key while scrolling the mouse wheel.
Ctrl: Scroll horizontally by pressing the Ctrl key while scrolling the mouse wheel.
Shift-Ctrl: Scroll horizontally by pressing the Shift + Ctrl keys while scrolling the mouse wheel.
Shift-Alt: Scroll horizontally by pressing the Shift + Alt keys while scrolling the mouse wheel.
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Field

Description
a

Rotate in 3D view

Select an option to specify which (if any) key the mouse wheel 3D view rotation operation uses:
None: Rotate in 3D view by scrolling the mouse wheel alone.
Shift: Rotate in 3D view by pressing the Shift key while scrolling the mouse wheel.
Ctrl: Rotate in 3D view by pressing the Ctrl key while scrolling the mouse wheel.
Shift-Ctrl: Rotate in 3D view by pressing the Shift + Ctrl keys while scrolling the mouse wheel.
Shift-Alt: Rotate in 3D view by pressing the Shift + Alt keys while scrolling the mouse wheel.

Tilt in 3D viewa

Select an option to specify which (if any) key the mouse wheel 3D view tilt operation uses:
None: Tilt in 3D view by scrolling the mouse wheel alone.
Shift: Tilt in 3D view by pressing the Shift key while scrolling the mouse wheel.
Ctrl: Tilt in 3D view by pressing the Ctrl key while scrolling the mouse wheel.
Shift-Ctrl: Tilt in 3D view by pressing the Shift + Ctrl keys while scrolling the mouse wheel.
Shift-Alt: Tilt in 3D view by pressing the Shift + Alt keys while scrolling the mouse wheel.

Enable tilt wheel
horizontal scrolling
(mouse dependent)

Enables horizontal scrolling while the mouse wheel is tilted.

Enable click + drag
panning (2D view
only)

Enables panning by pressing and holding down the mouse wheel as you move the mouse. To
exit panning mode, release the mouse wheel. You can also perform this operation using the
middle mouse button.

Entry mode

Select an entry/drawing mode for window definition using the mouse:
Click and drag: Use the standard entry mode for "drawing" a window by clicking and dragging
the mouse to define a window.
Two click: Use a two-click entry mode for "drawing" a window by clicking once to start the
window and clicking a second time to end/define the window. The following commands support
this mode: Draw Rectangle, Draw Path, Draw Circle, Draw Polygon, Draw Polyline, Draw Arc,
Draw 3D Clip Area, Draw Layout Ruler, Draw Symmetry Line, Draw Dimension Line, Draw
Route (no change from other click and drag mode), View Area, View Pan, Add Rectangle
Cutout, Add Circle Cutout, Add Ellipse Cutout, Add Polygon Cutout, Stretch Area (two-click
for vertex selection only, not stretching), Slice Shape, and Notch Shape.

a

If the same key is specified for multiple operations, command precedence is: 1) Zoom 2) Vertical Scroll 3) Horizontal Scroll. 4) Rotate in 3D view
5) Tilt in 3D view

Dialog Box Reference3–5

Environment Options Dialog Box: Colors Tab

Environment Options Dialog Box: Colors Tab

The Environment Options dialog box Colors tab allows you to specify options related to default colors used in schematics
and layouts. To access this tab, choose Options > Environment Options. This dialog box contains the following options:
Field

Description

Reset Defaults

Returns all options to their default settings.

Schematic/Diagram
Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for the named element.

Layout Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for layout background and grid.

Misc Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for output equations or plain text (such as text entered by choosing Draw > Text).

Global Definition
Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for Global Definitions window background and grid.

Schematic Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for the schematic background, grid, elements, source elements, meter elements, and elements
and nodes with layout.

System Diagram
Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for the system diagram background, grid, source block, and system block.

Output Equation
Colors

Click the corresponding button to display a Color dialog box for specifying the default color
used for Output Equations window background and grid.
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Environment Options Dialog Box: Schematics/Diagrams Tab

The Environment Options dialog box Schematics/Diagrams tab allows you to specify the default fonts and symbol
characteristics used in schematics. To access this tab, choose Options > Environment Options. This dialog box contains
the following options:
Field

Description

Reset Defaults

Returns all options to their default settings.

Fonts

Specify the element and/or equation text font type (name), style (for example, bold or italic)
and size. Click on the field to open a new dialog box. See “Font Dialog Box ” for more
information.
Select Bold Element Names to bold the element name text.
Select Bold Parameter Names to bold the element parameter text.

Symbols

Specify symbol options:
Don't Draw Nodes: Does not display the nodes on a schematic.
Draw All Black: Displays symbols in black instead of default colors.
Symbol Line Thickness: Enter a symbol line thickness value from 0 - 10, with 10 being the
thickest.
Enable alignment guides: Allows use of the first selected shape as the reference shape around
which others are relatively moved.

Unit normalization

Select the Schematic dependent parameters use base units check box to allow dependent
parameterized subcircuits to work independently of project units. The environment option for
this setting is used to set the default for new projects. There is a project level option (choose
Options > Project Options and click the Schematic tab) that controls this setting for the current
project. This is especially useful when exporting schematics for use in an XML library. When
this check box is cleared, parameters do not maintain their original units (they can change when
a schematic is imported into a project with different base units.)
Select the System diagram dependent parameters use base units check box to allow dependent
parameterized system diagrams to work independently of project units.
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Environment Options Dialog Box: Schematic Annotation Tab

The Environment Options dialog box Schematic Annotation tab allows you set the fonts, colors, and display options for
measurements that display directly on a schematic. To access this tab, choose Options > Environment Options. This dialog
box contains the following options:
Field

Description

Reset Defaults

Resets all options in the dialog box to their default settings.

Fonts

Click on the Node Text or Element Text buttons to display a Font dialog box for setting node and
element text characteristics. See “Font Dialog Box ” for more information.

Colors

Click on the Text or Background buttons to display a Color dialog box for setting the text and
background colors of the measurement read-out boxes.

Options

Show connecting line to node: Displays a dashed line connecting the annotation display with the

associated node.
Draw annotation in frames: Displays the annotation inside of a frame.
Show background filled: Displays the specified background color inside an annotation
Draw current arrows: Displays an arrow showing the direction of the current flow.

3–8 AWR Design Environment

frame.

Environment Options Dialog Box: Layout Tab

Environment Options Dialog Box: Layout Tab

The Environment Options dialog box Layout tab allows you to define default layout options. To access this tab, choose
Options > Environment Options. This dialog box contains the following options:
Field

Description

Reset Defaults

Returns all options to their default settings.

Default Snap Options Snap Together: Note that project level settings exist for your current project. For more information,
(these options take
see “Cell Options Dialog Box: Faces Tab ”. - Auto Snap on Parameter Changes: Automatically
effect after restarting performs a snap together operation after a parameter that affects layout is changed. Manual Snap
for All Objects: Snaps together all objects in a layout only when you choose Edit > Snap All
the AWR Design
Environment program, Hierarchy. Manual Snap Selected Objects Only: Snaps together selected objects in a layout only
on new projects only) when you choose Edit > Snap Together.
Default face justification: Allows center, variable, top, or bottom alignment of layout cell faces.
The default is for all faces to connect center-to-center. The "variable" justification setting allows
elements to connect anywhere along the face (rather than the center, top, bottom, or specified
offset from center). If any part of this face overlaps the adjacent face, the elements are considered
connected. This setting applies to new elements that you place in a project that is opened after
changing this setting. You can also change this justification per element. For more information,
see “Cell Options Dialog Box: Faces Tab ”.
Don't Rotate Shapes when Snapping: Prevents objects from rotating during a snap together
operation.
Enable Pin Area by Default: When cleared, any area pins are disabled, so connections must be at
the default face of the area pin rather than just overlapping the area pin. You can also change
this option per element. For more information, see “Cell Options Dialog Box: Faces Tab ”.
Snap to adjacent: Enables snapping operations. You can also set this option per face on each
element.
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Field

Description

Layout Project

Show top level library cells only: Displays only the top level of cells under the Cell Libraries node

in the Layout Manager.
Show EM Document's LPF:

Displays an LPF under the Layer Setup node for each EM structure.
These LPFs begin with a "+" symbol. You should not select this option unless Cadence Support
recommends it.
Layout Mode Options

Layout mode: Select the set layout editing option configuration.
Mode properties: Click this button to display the “Layout Editor
for the selected Layout mode.
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Environment Options Dialog Box: File Locations Tab

The Environment Options dialog box File Locations tab allows you to specify various directory paths for storing items
such as projects and log files. To access this tab, choose Options > Environment Options. This dialog box contains the
following options:
Field

Description

Default Project
Template

Project template to load on program start or when creating a new project. See “Saving Projects
As Project Templates” for more information on project templates.

Library Directory

Path for the Library folder under the AWR installation folder. Browse to this directory to see
files located there.

Default Design
Directory

The default path for opening and saving new AWR Design Environment projects.

Logfile Directory

Directory for storing log files. Please do not change this setting.

Design Kit Directory

The default path when choosing File > New With Library > Browse or any similar browsing for a
design kit.

Data Set Directory

The re-direct path for data set files. If no directory is specified, data sets are saved in the
DATA_SETS folder in the project directory.
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Font Dialog Box

The Font dialog box allows you to define text font properties for various types of text. These dialog box settings are self
explanatory.
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Project Options Dialog Box: Frequencies Tab

The Project Options dialog box Frequencies tab allows you to specify the default frequency sweep or point at which
simulations are performed for this project. To access this tab, choose Options > Project Options or double-click Project
Options in the Project Browser. This dialog box contains the following options:
Field

Description

Current Range

Lists the currently-specified frequency points.

Modify Range

Allows you to specify the default frequency sweep or point at which simulations are performed
for this project. The entry mode is controlled by the Sweep Type setting.
For Linear mode, specify values for Start, Stop, and Step between frequency points.
For Logarithmic mode, specify values for Start, Stop, and #points/dec to specify an even number
of points between each decade change in frequencies.

Single point

To specify a frequency point, select the Single Point check box, and enter a value for Start.

Add

Select this option to add a frequency point or range of points, then click Apply or OK.

Delete

Select this option to delete a frequency point or range of points, then click Apply or OK.

Replace

Select this option to replace the current range with a new point or range of frequencies, then
click Apply or OK.

Sweep Type

Select Linear or Logarithmic.

Data Entry Units

Specify the units of the frequency range.
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Project Options Dialog Box: Schematics/Diagrams Tab

The Project Options dialog box Schematics/Diagrams tab allows you to specify options about how elements are displayed.
To access this tab, choose Options > Project Options or double-click Project Options in the Project Browser. This dialog
box contains the following options:
Field

Description

Parameter Display
Options

Customize the display of the element parameters.
Hide Parameters does not display parameters.
Hide If Empty hides parameters not assigned a value.
Hide If Secondary hides parameters marked as secondary (typically parameters that are not edited)
in the element definition.
Hide Units hides the units on the parameter values.
Hide Labels hides the parameter names.
Boldface Parameters displays parameter in bold.
Multi-column displays parameters in more than one column on a schematic.

Auto Wire Cleanup

Clear the Auto wire cleanup check box to leave all wires (connections) intact when you delete
an element. The default (selected) is to delete the attached wires when you delete an element.

Unit Normalization

Select the appropriate option to specify whether or not element or system block parameters that
are dependent on a variable or equation use base units. You can use this option to make dependent
parameters independent of project units.

Element/Block Options Specify the display of the element/block names on the screen. Hide names hides the name;
Boldface names emboldens the name.
Parameters/equations

Display digits:

Specify the number of significant digits to display for element parameters and

equations.
Zero threshold:

Specify a zero threshold level. Any number below this level displays as zero.
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Project Options Dialog Box: Global Units Tab

The Project Options dialog box Global Units tab allows you to specify the units to use in the schematics contained within
a project. To access this tab, choose Options > Project Options or double-click Project Options in the Project Browser. The
options in this dialog box differ depending on whether you are running the Cadence® AWR Design Environment®
software with or without the Layout feature license.
When running the AWR Design Environment software with the Layout feature license (units are configured per-LPF),
the dialog box contains the following options:
Field

Description

Units to modify

Choose the desired LPF for editing

Edit Units

Opens the LPF Options dialog box for setting LPF units.
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When running the AWR Design Environment software without the Layout feature license, the dialog box contains the
following options:
Field

Description

Use Base Units

Sets all units to base units; for example, meters, amps, Farads, and Henrys (no modifier used
to describe the value).

Frequency, Angle,
Temperature, Time,
Voltage, Resistance,
Conductance,
Inductance,
Capacitance, Current

Click the arrows to the right of these options to specify the units to use in all schematics contained
within this project.

Power

Click the arrows to the right of Linear and Log to specify the power units to be used in all
schematics contained within this project.

Length

Specify the length units to use in all schematics, EM structures, and layouts contained within
this project. Select the Metric Units check box to toggle between metric and English units for
Length Type.
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Project Options Dialog Box: Interpolation/Passivity Tab

The Project Options dialog box Interpolation/Passivity tab allows you to specify interpolation options for the simulations
performed in this project. To access this tab, choose Options > Project Options or double-click Project Options in the
Project Browser. This dialog box contains the following options:
Field

Description

Interpolation Options Choose one of the following interpolation methods:
Linear: Uses a linear function to interpolate between points.
Rational Function: Use rational functions to interpolate between points (for example, smoothing).
Missing data points are estimated by fitting a pole-zero model to the points used for the
interpolation. The pole-zero model of the data can accurately represent the transfer function of
measurements taken on physical devices (such as the S-parameters of a passive component).
Spline Curve: Uses a spline curve to interpolate between points.
Rational Function

Window Size:

Determines the maximum number of frequency points used to compute the
interpolated data. If the window size is larger than the number of frequency points in the data
file, the window size is automatically set to the number of frequency points in the data file. Set
this option to specify the maximum number of frequency points to use to compute the interpolated
data. The following figure demonstrates the operation of the window. Each tick on the line
represents a frequency point in the data file. The bold tick marks represent the points that would
be used to interpolate the indicated point if a window size of 4 is selected. The window slides
along the axis as the interpolation point changes. A larger window size includes more points in
the interpolation, but the simulation is slower.
Interpolation Window = 4

Interpolation Point

Spline Curve Options
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Spline Order:

Specify the spline order.

Project Options Dialog Box: Interpolation/Passivity Tab
Field

Description

Coordinate System

Cartesian: Interpolates complex numbers by interpolating their real and imaginary parts.
Polar: Interpolates complex numbers by interpolating their magnitude and unwrapped phase.

MDIF and Load Pull
Files

Align gammas over power:

EM Documents and
Data Files

Consider Passive for Noise Simulation:

Interpolates the load pull A and B values to keep the gammas fixes
over swept power. The default is off.
Block name: Specifies the data block within the MDIF document to use when there is more than
one data block available. If there is only one data block, or for load pull documents where the
data blocks are known (for example, HEADER and ABWAVES blocks are present), leave this
blank unless you want to read values from the HEADER block using one of the functions for
reading generalized MDIF. In this case you need to create a copy of the MDIF document and
set this value to HEADER. Load pull deembeding structure: Specifies the two port network
(circuit schematic, data file, or EM structure) used to deembed the output pin of load pull data
(move the reference plane of the output measurements from the device pin to the other side of
the specified network).
Noise is calculated different for network parameters
(S-parameters, etc.) if the network is passive or active. This can occur if there is calibration
error in measurement or numerical error in EM simulation causing a passive structure to be
slightly active. This option forces the structures noise to be calculated using the passive method.
This option can be set globally or per data file or EM document.
Enable parameter interpolation: Allows parameter interpolation for any numeric VAR values
(unless your VAR type is a string).

NOTE: Interpolation must be used carefully. Always visually check the results of the interpolation to make sure it did
not break down at any point. For example, if the data is noisy, the interpolation may not provide the desired results. If it
appears that the interpolation has failed to provide reliable results, try increasing or decreasing the window size in this
dialog box.
Interpolation/Passivity tab

settings do not apply to the interpolation of the parameter values for MDIF N-Port file format
and EM data sets resulting from SWPVAR simulations. Interpolation of parameter values uses the Linear method and
Cartesian coordinate system.
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Project Options Dialog Box: MWO Server Scheduler Tab

The Project Options dialog box MWO Server Scheduler tab allows you to specify job processing options for this project.
To access this tab, choose Options > Project Options or double-click Project Options in the Project Browser. See “Remote
and Parallel Simulation ” and “Job Scheduler” for more information. This dialog box contains the following options
(some options display only when a remote node is set up in the Job Scheduler Admin dialog box):
Field

Description

Job Process Priority

The Operating System priority to assign to the job process once it is running. A "Default" setting
is the "Normal" setting.

Remote Execution

If a remote server is available, this selects whether the job is run on the local computer or the
remote server.

Preferred Remote
Queue

For remote job execution, this is the first remote job server listed in the Job Scheduler Admin
tool.

Remote Performance
Preference

Controls job assignments to remote computers (in combination with the LocalComputePreference
option set via the Job Scheduler Admin dialog box on the remote computer). The default is
Normal, so jobs are never rejected by remote computers. If set to High, a job is only assigned to
a remote computer with LocalComputePreference set as High, and rejected by computers with
this option set to Normal. If no remote computers satisfy the Remote Performance Preference of
the job, the scheduler node rejects the job.

Remote Memory
Preference

Controls job assignments to remote computers (in combination with the LocalMemoryCapacity
option set via the Job Scheduler Admin dialog box on the remote computer). The default is
Normal, so jobs are never rejected by remote computers. If set to High, a job is only assigned to
a remote computer with LocalMemoryCapacity set as High, and rejected by computers with this
option set to Normal. If no remote computers satisfy the Remote Memory Preference of the job,
the scheduler node rejects the job.

Max Nodes for
Multiple Jobs

The maximum number of compute nodes in the remote server used in the simulation.

Max Parallel Jobs Per The maximum number of jobs that can run in parallel on the same compute node.
Node
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Field

Description

Percent Improvement Controls local updates during distributed optimization. Local updates are used to refresh any
for Async Update
measurements that are involved in the optimization. Since the local updates involve a simulation
within the AWR client process, you may want to limit how often these update simulations are
executed. The value of this option is the percentage improvement in the optimization cost
function that triggers simulation updates within the AWR client process. To minimize the
updates, you can set this value to a larger number (up to 1000%).
Enable Diagnostic
Logging

Generate log files for diagnosing MWO server jobs in the specified Logs directory.

Save project after
MWO server job

Automatically saves the project if any of the remote MWO server jobs complete successfully.
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The Design Environment Options dialog box allows you to control the visual appearance and display of the AWR Design
Environment program, its tabbed workspace, and docked windows. To access this dialog box, choose Tools > Options.
This dialog box contains the following options:
Field

Description

Theme

Choose one of the following for the visual appearance of the AWR Design Environment
workspace: Classic, Contemporary, or Modern, with specific color options or a system default
color option.

Tabbed Workspace

Select this check box to add a workspace tab for each window that you open. For example, tabs
may display for your schematic, layout, graph, and output equations windows. Tabs allow you
to quickly locate and activate a specific window, and you can drag tabs to reorder them. Clear
this check box to maintain a non-tabbed (windowed only) workspace.
Multirow tabs: Select this check box to wrap tabs to a second row when their number exceeds
the length of the workspace area. Clear this check box to scroll horizontally to view tabs that
display outside of the workspace area.
Location: Choose the border on which you want to display workspace tabs (Top, Left, Bottom,
or Right).

Docked Windows

Select Hide tabs as group to hide the Project, Element, and Layout tabs as a group when you click
the "push pin" (Auto Hide toggle) icon on any of these tabs. Clear this check box to individually
hide a tab when you click the "pushpin" icon on that tab.
Select Close tabs as group to close the Project, Elements, and Layout tabs as a group when you
click the "x" (Close) icon on any of these tabs. Clear this check box to individually close a tab
when you click the "x" icon on that tab. To reopen a closed window, choose View and the
appropriate window option.

Preview

Click the Preview button to view your current selections in the open AWR Design Environment
program window.
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Data File Options Dialog Box: Raw Data Format Tab

The Data File Options dialog box Raw Data Format tab allows you to specify the format used to read data from imported
raw data files. The raw data format reads data as rows and columns of data in a text file. To access this tab, right-click
the Data Files node in the Project Browser and choose Options. This dialog box contains the following options:
Field

Description

Data Type

Specify the type of data in raw data files. You can select S-, Y-, or Z-parameters.

Reference Impedance, If the data file is an S-parameter file, then the reference impedance for the S-parameters also
Normalization
needs to be specified. The default value of 50 ohms is the most common value for S-parameter
Impedance
data. If the data file is a Y-parameter or Z-parameter file, then the normalization impedance
needs to be specified. The default value is 50 ohms. For non-normalized Y- or Z-parameters,
use a value of one for the normalization impedance.
Matrix Size

Specify allows you to specify the number of ports for the N-port file or One Matrix per Line allows

the program to determine the number of ports by assuming that all the entries in the N-port
matrix are written on a single row. If all the matrix entries are written on a single row, then the
first entry in the row must be the frequency point for the N-port matrix. If you specify the size
of the matrix, then the first item in the first row is the frequency point for the first N-port matrix.
The entries for the first N-port matrix then follow the frequency point starting from the second
column in the first row. Following the first N-port matrix will be the frequency point for the
second N-port matrix, followed by the second N-port matrix entries (and so on). By specifying
the size of the matrix, the entire matrix does not have to be written to a single line. Also, the
number of columns in each row does not have to be the same, and the frequency value for each
matrix does not always have to be in the first column.
Format

Allows you to specify the format of the N-port matrix entries. Complex numbers are read in as
two real numbers in adjacent columns in the same row. Real-valued data can be read as a single
number. The following data types can be used:
Real/Imag: x+j*y written as x y
Mag/Angle (polar): x*exp(j*theta) written as x theta
Real: x written as x
dB: 20*log(x) written as 20*log(x)
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Field

Description

Data Order

Specifies the relationship between the order of the data in the file and the position of each entry
of the N-port matrix. The data read from the raw data file is always read by row. The data can
be inserted into the N-port matrix by row (the same as the data file) or by column. The two
options follow:
Row Major: An N-port file read using row major format will read the data into the N-port matrix
by row. For example a 2-port S-parameter file would be read into the project in the following
order: S11, S12, S21, S22.
Column Major: An N-port file read using column major format will read the data into the N-port
matrix by column. For example a 2-port S-parameter file would be read into the project in the
following order: S11, S21, S12, S22.

File Units

Specifies the units that are assumed in the data file (not the units that are used by the project).
For example, if Frequency is specified as kHz, then the frequency point 10 would be converted
to 10,000 Hz when it is read into the project. The Angle units are only used if the data format
uses angles (i.e. magnitude angle). Click on the arrows to the right of the option to select the
correct unit.
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Data File Options Dialog Box: MDIF Files Tab

The Data File Options dialog box MDIF Files tab allows you to specify sorting options for imported/linked MDIF files
within this project. To access this tab, right-click on the Data Files node in the Project Browser and choose Options. This
dialog box contains the following options:
Field

Description

MDIF Variable Sort
Order

When importing version 6.0 projects, the sorting order defaults to Alphabetical to maintain the
sort order used in 6.0, and thus the simulation results. To use alphanumeric sorting in a project
created in version 6.0, open the project, set MDIF Variable Sort Order to Alphanumeric, and
save the project as a version 6.5 or higher project. Same as file, the default option, causes the
sorting order to be the same as the (often arbitrary) ordering of values in the MDIF file.
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Options - Data File Dialog Box: Interpolation/Passivity Tab

The Options - Data File dialog box Interpolation/Passivity tab allows you to specify interpolation options for the associated
data file. To access this tab, right-click a data file under the Data Files node in the Project Browser and choose Options.
This dialog box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for interpolation/passivity properties. If this check box is cleared, specify
the interpolation/passivity properties for this data file only. For option descriptions, see “Project
Options Dialog Box: Interpolation/Passivity Tab ”.
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Manage Symbols Dialog Box

The Manage Symbols dialog box allows you to view a list of the custom symbols available in the current project, and to
edit (redesign) or rename a symbol. To access this dialog box, choose Project > Circuit Symbols > Manage Symbols. This
dialog box contains the following options:
Field

Description

Symbols

Lists the symbols available in the current project.

Number of nodes

Identifies the number of nodes in the selected (highlighted) symbol.

New

Opens the New Circuit Symbol dialog box to allow you to name a new symbol. The new symbol
name displays in the list of symbols.

Edit

Opens the Symbol Editor to allow you to make changes to the selected symbol.

Rename

Opens the Rename Circuit Symbol dialog box to allow you to rename the selected symbol.

Close

Closes the Manage Symbols dialog box.

Delete

Removes the selected symbol from the project. A dialog box confirms this operation.
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Import Symbols Dialog Box

The Import Symbols dialog box allows you to view a list of the symbols available in a symbol file (.syf), and to import
some or all of the symbols into the current project. To access this dialog box, choose Project > Circuit Symbols > Import
Symbols and then choose a symbol file to import. This dialog box contains the following options:
Field

Description

Check the symbols to Allows you to select the check box for the symbols in the current symbol file (.syf) you want
import
to import.
Number of nodes

Identifies the number of nodes in the selected (highlighted) symbol.

Check All / Uncheck
All

Selects or clears the check boxes for all symbols in the symbol list.

Import

Imports the selected symbols and makes them available within the current project.
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Export Symbols Dialog Box

The Export Symbols dialog box allows you to view a list of the symbols in the current project, and to export some or all
of the symbols to a symbol file (.syf). To access this dialog box, choose Project > Circuit Symbols > Export Symbols. This
dialog box contains the following options:
Field

Description

Check the symbols to Allows you to select the check box for the symbols in the current symbol file (.syf) you want
export
to export.
Number of nodes

Identifies the number of nodes in the selected (highlighted) symbol.

Check All / Uncheck
All

Selects or clears the check boxes for all symbols in the symbol list.

Export

Exports the selected symbols to the specified symbol file (.syf) to make them available to other
projects.
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Simulation Filters Dialog Boxes
Simulation filters allow you to set up different simulation profiles. These filters are typically used in large designs where
enabling/disabling measurements would be a difficult means to control simulations that are run on your design. There
are several dialog boxes associated with simulation filters, as shown in the following figures.
To access the New Simulation Filter dialog box, right-click the Simulation Filters node in the Project Browser and choose
Add Simulation Filter.

To access the Edit Simulation Filter dialog box, double-click a simulation filter name under the Simulation Filters node
in the Project Browser.

To access the Simulation Filters dialog box, right-click the Simulation Filters node in the Project Browser and choose
Manage Simulation Filters or choose Simulate > Manage Simulation Filters.
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The Simulation Filters dialog box contains the following options:
Field

Description

Filters

Name of the filter you are configuring. Click the New, Rename, Delete, and Copy buttons to
manage filter names. When adding a new filter, this is the name you specify for it. When editing
a filter, this filter name displays in the dialog box title bar.

Documents

Filter by document name. This list includes all documents (for example, schematics and EM
structures) you can use for simulation in the project. This list changes depending on what exists
in the project.

Simulators

Filter by simulator vendor. This list includes all the licensed simulators available. This list
changes based on your license configuration.

Simulation Types

Filter by type of simulation. This list includes all the licensed simulation types available. This
list changes based on your license configuration.

Switch Lists

Filter by simulator configuration. This list includes all simulation configurations for the project
and it changes accordingly. Click Manage to display the Switch Lists dialog box for configuring
Switch Lists. See “Switch List Dialog Boxes ” for more information.

NOTES: All check box fields have a right-click context menu with Check All, Check None, and Toggle Check options.
After you set up simulation filters they affect what is simulated, so make sure you intend to use filters when enabling
them here.
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Switch List Dialog Boxes
Switch Views allows you to configure Switch Lists for your designs. There are several dialog boxes associated with
Switch Lists, as shown in the following figures.
To access the New Switch List dialog box, right-click the Switch Lists node in the Project Browser and choose Add Switch
List.

To access the Edit Switch List dialog box, double-click a Switch List name under the Switch Lists node in the Project
Browser.
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To access the Switch Lists dialog box, right-click the Switch Lists node in the Project Browser and choose Manage Switch
Lists or choose Simulate > Manage Switch Lists.

The Switch Lists dialog box contains the following options:
Field

Description

Switch Lists

The name you select when adding measurements. Click the New, Rename, or Delete buttons to
manage the configuration names. When adding a new Switch List, this is the name you specify
for it. When editing a Switch List, this name displays in the dialog box title bar. When managing
Switch Lists, this name displays in the Switch Lists column.

Design Views

Displays the different lists set up for each configuration. Click New, Edit, or Delete to manage
the lists per configuration. The New and Edit buttons display the Edit Switch List dialog box
with the following options.
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Field

Description

Select top level design Lists all available documents. Choose a top level schematic to see any Switch Views available
for the Switch List
from this level and below in Available. Select All Sources to see all configured switch views in
the project.
New View

Adds a Switch View name and makes it available to add to the View List.

View List

Shows the settings for the current Switch List.

Add / Remove / Move Add or remove the selected view to/from the current View List, or move the selected View List
Up / Move Down
item up or down in the View List order.
Instance to apply list
(leave empty for
default)

Allows you to apply the filter list to only specified instances instead of the entire design hierarchy.
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Edit Subcircuit Dialog Box

The Edit Subcircuit dialog box allows you to select a switch view to push into when more than one switch view is
available. To access this dialog box, select the SUBCKT you want to push into, right-click and choose Edit Subcircuit,
then select the desired view.
For more information on Switch Views, see “Switch View Concepts ”.
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Add/Edit Schematic/System Diagram/EM Structure Annotation Dialog Box

The Add/Edit Schematic/System Diagram/EM Structure Annotation dialog box allows you to display simulation results
directly on the specific document instead of on a graph. To access this dialog box, right-click on a schematic, system
diagram, or EM structure node in the Project Browser and choose Add Annotation. Click the Search button next to
Measurement to display the Select Measurement dialog box and search for an Annotation measurement by name,
description, or category (Measurement Type). The options in this dialog box differ based on the annotation you choose.
Click the Meas Help button for more information about each annotation.
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Known Migration Issues Dialog Box

The Known Migration Issues dialog box displays to alert you that the current project was saved using a model compatibility
version that is older than the current version. This occurs when you open a project that contains models for which a newer
version exists. To change the model compatibility version, choose Options > Default Circuit Options to display the Circuit
Options dialog box, then on the AWR Sim tab change the Model compatibility version, which is a secondary option, to the
desired version. You can also change this option at the schematic level. An option to hide this dialog box when opening
projects is included in the dialog box.
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Import Project Dialog Box

The Import Project dialog box allows you to easily import most project items into another project. To access this dialog
box, choose File > Import Project. This dialog box contains the following options:
Field

Description

Check the project items Select the individual project items you want to import. This list varies by project.
you wish to import
Add auto numbered
suffix

Renames selected, conflicted items by adding a number as a suffix. You must click the Conflicted
button to rename the items.

Add prefix

Renames items by adding the prefix you specify in the text box. The prefix can only be A-Z,
a-z, 0-9, the "_" or " " (blank) characters. You can add the prefix to just the selected, conflicted
items by clicking the Conflicted button, or add the prefix to all selected items in the project tree
by clicking the All button.

Add suffix

Renames items by adding the suffix you specify in the text box. The suffix can only be A-Z,
a-z, 0-9, or the "_" or " " (blank) characters. You can add the suffix to just the selected, conflicted
items by clicking the Conflicted button, or add the suffix to all selected items in the project tree
by clicking the All button.

For more information on importing projects, see “Importing a Project ”.
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Open Example Project Dialog Box

The Open Example Project dialog box allows you to locate specific example projects in the AWR Design Environment
program or Cadence AWR Knowledge Base. Short tutorial videos are also listed. If an example is included in the AWR
Design Environment installation it opens directly. If the example is in the Cadence AWR Knowledge Base, a web page
for the example displays with a link for downloading the example. To access this dialog box, choose File > Open Example
or Help > Open Example. This dialog box contains the following options:
This dialog box has the following features:
• Type in the text field at the bottom of the dialog box to filter the examples based on the keywords typed.
• Click on a column header to sort by that column's contents.
•

Ctrl-click to change which column is used to filter. The selected column is identified by a highlighted, inverted triangle

icon to the right of the column name.
• The title bar lists the number of examples that match your filter. For example "[11 of 479]".
For more information on dialog box use and filtering examples, see “Opening Example Projects”.

Filtering Examples
The Open Example Project dialog box filtering capability is quite powerful. The following are tips for entering filters:
• Type part of a keyword and watch the matches filter as you type.
• Type part or all of a keyword, use a space and then type another word to filter both words. For example, if you type
"mwo mixer" all the mixer examples for the Cadence Microwave Office® program are listed.
• Use the "video" keyword to see all available videos.
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• Use the "new" keyword to see all examples that are new or have new functionality added. Typing "new mwo" lists all
new Microwave Office examples, and "new vss" lists all new Cadence Visual System Simulator™ (VSS) software
examples.
• Use the "mwo", "vss", or "ao" keywords to filter by product.
• Use the "install" keyword to see all examples in the program installation.
• Use the "web" keyword to see all examples in the Cadence AWR Knowledge Base.
• Use the "design_guide" keyword to see all examples set up as design guides or measurement templates.
• Use the "model_tester" keyword to see all examples set up to help you characterize specific types of models.
• Each example has additional keywords added. These keywords include simulator types (such as Cadence AXIEM®
EM simulator or Cadence APLAC® HB simulator), design types (such as amplifier or mixer), the unique measurements
used in the example, and the unique models used in the example. For example, to locate examples that use a BIASTEE
model, type "BIASTEE" to list all the examples.
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Measurement Editor

The Measurement Editor displays the active project measurements and their options and allows you to quickly edit
measurements or collections of measurements. This Editor allows you to manage the measurements in your project by
changing the sort order of the variables, filtering on specific criteria, editing multiple measurements, and pre-populating
the filter selection by choosing to open the Editor from a particular source. To open the Measurement Editor, right-click
a source document such as a schematic, EM structure, or system diagram, or a host document such as a graph, optimization
goal, or annotation, and choose Edit Measurements. You can also right-click a graph in the Project Browser and choose
Edit Measurements or choose Graph > Edit Measurements.
NOTE: Unlike the Modify Measurement dialog box, the Measurement Editor does not restrict access to specific settings
for each measurement. For example, the Vtime (Time Domain Voltage) measurement has real values, but the Measurement
Editor allows you to select the dB box or set the Cplx Modifier. Use caution when editing multiple measurements to ensure
that the modified settings are applicable to all measurements.
For more information about the Measurement Editor, see “Using the Measurement Editor”. The Measurement Editor
contains the following options:
Field

Description

Host Doc

Lists where the measurement is located, for example, what graph the measurement is on. You
cannot edit the Host Doc in the Measurement Editor - it is there to support filtering.

Host Type

Lists the type of document the Host Doc is. The valid types are Graph, OptGoal (Optimization
Goal), YldGoal (Yield Goal), Anno (Annotation), (OutFile) Output File, or OutEqn (Output
Equation). You cannot edit the Host Type in the measurement Editor - it is there to support
filtering.

Enabled

Indicates whether or not the measurement is enabled.

Document

The source documents that the measurement is on. You can change the source document from
a list of sources. Source documents can be circuit schematics, EM structures, system diagrams,
data files, or output equation documents.

Measurement

The measurement made on the source document. In this text entry field, you can type the name
of the measurement you want to make. Case is auto-corrected. If the string you enter is not a
valid measurement, it is not accepted and remains at its original value.

Simulator

The simulator used in the measurement. There are two letter shortcuts for each non-default
simulator. To use the default simulator, leave this cell blank.

Config

The representation of the circuit you want to use (the Switch View).

dB

Indicates whether or not the measurement is plotted in dB.
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Field

Description

Complex Modifier

The modifier applied to the simulation data. You can select a modifier from the list of modifiers:
None, Real, Imag, Mag, Ang, Angu, or Conj.

Parameters

The measurement parameters, a comma separated list of values that are meaningful to that
measurement that reside in the parentheses of the measurement string.

Sweep Parameters

The measurement sweep parameters. Controls how the sweeps, frequency or otherwise, display
on the graph. A comma separated list of values that reside in the brackets of the measurement
string.

Frequency Sweep

The frequency list that the measurement is plotting.

Out Eq Doc

The Output Equations document.

Tag

A descriptive tag for the measurement. Tags can be used for grouping measurements in the
Measurement Editor.
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Job Scheduler Admin Dialog Box: General Settings Tab

The Job Scheduler Admin dialog box General Settings tab displays the remote hosts and Job Server properties used to
add and configure both user and remote computers for remote computing. The options that display depend on whether
the AWR Design Environment program is running with a standard installation, or running as a service on a remote
computer. To access the Job Scheduler, choose Tools > Job Scheduler Admin. For more information about the Job Scheduler
and remote simulations, see “Job Scheduler”.

Standard Installation
For a standard installation, this dialog box contains the following options:
Field

Description

Editing

For standard installations the uneditable default is Current User Settings.

Remote Hosts

Displays the remote host entry name, host, IPC transport, verification status, version, and queue
type.

Create a new host

Click this button to add new remote computers to the Remote Hosts table. For Windows-based
hosts, you should only add scheduler nodes. For Linux-based hosts, you can add the same submit
host multiple times with different submit options.
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Field

Description

Duplicate the selected Click this button to create a new entry as a copy of an existing one. This button facilities creating
host entry
similar entries where only a few options are changed.
Delete the selected
host(s)

Click this button to remove the selected remote host.

Edit host entry details Click this button to display advanced details for the selected host; generally not used.
Up/Down arrows

Click these arrows to change the order of remote computers in the host table. The table order
is also the search order of the remote hosts for operations such as Verify.

Verify Hosts

Click this button to confirm network connection to the remote computer.

Transports

Click this button to display the Edit Transports dialog box with editable transport information.

Get Logs

Click this button to retrieve Job Scheduler logs from the selected remote host. The remote logs
are copied to the Appdatauser\logs directory to a folder with the naming convention
ExtractedLogs[remote host name]_<date and time>.

NOTE: Do not add a compute node to a user computer remote host table. The Queue Type for a standard installation
remote host entry should always be "Scheduler" and not "Compute".

Service Installation
The Job Scheduler Admin dialog box contains two sections. Editing should be set to All User (Service) Settings for remote
computers. The upper Remote Hosts section is only used for scheduler nodes. You do not need to edit this section on
compute nodes. On a scheduler node, you use this section to add compute nodes to the list of available computers for
remote simulation. See “Standard Installation” for details on how to add hosts. The Job Server Settings section only
displays on computers running the AWR_JobScheduler service. These settings are used to configure the local computer
from which this dialog box is opened, not the remote computers in the Remote Hosts table. To change settings on the
remote computers listed in the Remote Hosts table, open the Job Scheduler Admin dialog box on those computers.
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For a service installation, this dialog box contains the following Job Server Settings:
Field

Description

Show incoming
connection settings

Allows advanced users to change the IPC configuration for incoming connections to a job server,
such as the port number used for sockets if the default is already in use on the machine. This
option also allows you to add incoming IPC connections (for example, if one client cannot use
the default port number you can retain the default port by setting up another incoming socket
connection with a different port number.) You can also disable one of the default incoming
connections (for example, if you don't trust named pipes and want to shut them off.)

EnableIPCLoggingServer When enabled, with an [IPC] LoggingEnabled=1 entry in the user.ini file for the user
and mwoffice.ini file for remote machines, IPC logs display in appdatauser\logs for the user
and appdatacommon\logs for remote machines. The IPC logs are overwritten when the user
restarts the AWR Design Environment program or the AWR Job Scheduler service is restarted
on the remote machines.
EnforceProcessorExclusive Do not edit this option. The default is False.
JobArchiveInterval

Specifies the time interval between job archive operations, such as job archiving and removing
jobs that have exceeded the archive age. The default is 1 hour.

JobMaxArchivedAge Specifies the maximum time to retain archived jobs. When an archived (stored on disk) job
exceeds this age, the archive is deleted, and the job is permanently removed. Make sure to set
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Field

Description
this to a sufficiently large value so that users that are unable to reconnect to the Job Scheduler
for extended periods still have access to their completed jobs. The default is 30 days.

JobMaxCompletedAge Specifies the maximum age of a completed job before it is either archived (for non-reported
jobs) or retired. Archived jobs are removed from the Job Scheduler’s job list, but the details of
the job are stored on disk. Retired jobs are just removed from the job list. Jobs that have not
reported their results to the submitting client are archived after they exceed the
JobMaxCompletedAge. The default is 24 hours.
License file

Do not edit this option. The default is an empty field.

LocalComputePreference Ranks CPU performance of the various remote computers. A remote job with a high Remote
Performance Preference setting can only run on remote computers with this option set as high;
it is rejected by remote computers with a normal setting. A remote job with a normal Remote
Performance Preference setting can run on both high and normal remote computers. The default
value is high.
LocalMemoryCapacity Ranks memory capacity of the various remote computers. This setting is similar to
LocalComputePreference with respect to memory. The default value is high.
LocalPriority

(Scheduler node only, not compute nodes.) Determines the order of job assignments to remote
computers. If set to LocalFirst, the scheduler node first tries to assign the remote job to itself. If
the scheduler node is already busy with a job, it tries to assign the job to an available compute
node.
If set to RemoteFirst, the scheduler node first tries to assign jobs to compute nodes. If all compute
nodes are busy, it assign jobs to itself.
If set to Automatic, no computers have assignment priority. Jobs are assigned based on computer
availability and Compute Performance/Memory settings. The default value is Automatic.

MaxLogFileAge

The maximum amount of time to retain old job scheduler log files. Files older than this value
are deleted. The default is 14 days.

MaxProcessors

Do not edit this option. The default is Logical.

MaxRunningJobs

Specifies the maximum number of parallel jobs to simulate simultaneously. The default is 1.

NoLocalJobs

(Scheduler node only, not compute nodes.) Determines whether the computer can run local jobs.
If set to True, the computer does not run any local simulations. For a scheduler node, a True
value means that the scheduler node only functions as a queue manager, and assigns all jobs to
compute nodes. If set to False, the computer can run local simulations. For a scheduler node, a
False value means that the scheduler also functions as a compute node, and runs simulations.
The default is False.

NoQueue

Do not edit this option. The default is False.

NoRemoteJobs

Do not edit this option. The default is False.

QueueTypeOverride

Sets whether the computer is a scheduler or compute node. For scheduler nodes, set to Scheduler.
For compute nodes, set to Compute.

ReservedSystemMemory Used in job memory management to specify the amount of memory reserved to the system and
restricted from use by jobs. Running jobs share the remaining memory (system memory minus
reserved memory). The default is the larger of 2GB or 20% of system memory.
TaskRootDataPath

Do not edit this option. The default is an empty field.

TokenizedCommandPaths Do not edit this option. The default is False.
Verbose

Enables verbose logging for the Job Scheduler. If there are problems with the remote computer,
set this option to True to assist with troubleshooting. The default is False.
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Field

Description

Defaults

Resets all Job Server Settings values to program defaults.

Reset

Resets Job Server Settings values to the values set when this dialog box opened.

Revert to Saved

Resets Job Server Settings values to the values currently saved in the configuration file.

Save

Saves the Job Server Settings values to the configuration file.
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Verify Host Failed Dialog Box

This dialog box opens when a local computer cannot connect to a remote computer. The term "local computer" refers to
the computer initiating the verification check, and "remote computer" refers to the remote host to which the local computer
is trying to connect. There are two verification scenarios: a local user computer trying to connect to a remote scheduler
node, and a local scheduler node trying to connect to a remote compute node.
Possible causes for failed verification include:
• The network is not set up with a domain controller. If not, see “Troubleshooting Remote Computing”.
• No network connection. Ping the remote machine to check the connection. Try using the IP address instead of the host
name.
• The AWR_JobScheduler service is not running on the remote machine. Make sure the service is running.
• The version of the AWR_JobScheduler service on the remote machine is older than the local Job Scheduler. A v16
local computer cannot connect to a v15 remote computer.
See “Firewall Ports” for details on which ports must be open for remote computing.
See “Log Files” for details on how to find the Job Scheduler logs, and how to contact Cadence Support for assistance.
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Send Diagnostic Files Dialog Box

The Send Diagnostic Files dialog box controls which files are sent back to Cadence in the event of a software crash.
Sending in a crash report helps us identify issues and improves the performance of the software. The options are:
•

Send the dump files and the error.txt file only:

With this default option, no intellectual property is sent. Only software
call stacks are sent, which aid in debugging the crash.

•

Send the dump files, error.txt, the project file, and the settings files:

•

I don't want this problem fixed, don't send anything:

The project (.emp) that caused the crash and AWR
Design Environment configuration files are also sent along with the software call stacks. Selecting this option provides
Cadence with more information for debugging the issue. Software call stacks sometimes do not provide enough
information for fixing the crash, so the project may be required for debugging purposes.
No files are sent to Cadence.
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Version Control Dialog Box

The Version Control dialog box controls which documents are under version control and allows you to manage conflicts
and changes. To access this dialog box, choose File > Version Control. For more information on setting up and using a
version control repository, see “Using Version Control”. This dialog box contains the following options:
Field

Description

Project Items

Displays a list of unversioned documents/data files available in the AWR Project.

Available Files

Displays a list of versioned documents/data files available in connected repositories but not
linked to a Project Item.

Versioned Items

Displays a list of versioned documents/data files available in the repositories linked to a Project
Item in AWR.

Sources

Displays a list of connected source repositories.

Source, File, File Type, Provides document/data file details per column heading..
...
Connect

Connection to new version control source repository not currently listed under Sources.

Update

Updates the local document/data files with the latest files from the version control database or
central repository.

Remote Status

Checks the version control database or central repository for modifications.

Add to Project

Adds a document/data file to the version control database or central repository.

Remove

Removes a document/data file from the version control database or central repository.

Rename

Renames a document/data file in the version control database or central repository.

Get Lock

Locks the document/data file for use (in edit mode) only by the current user. While locked, other
users can view the document in read-only format.

Commit

Unlocks (releases) an edited document/data file and commits it to the version control database
or central repository.

Revert

Undo local changes to an edited document/data file.

Difference

Shows text- or graphics-based differences in project documents/data files.

History

Lists the version (revision) history for the document/data file.

Explore

Opens Windows File Explorer to your working copy.
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Field

Description

Cancel

Cancels execution of selected version control command.
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Element Options Dialog Box: Parameters Tab

The Element Options dialog box Parameters tab allows you to modify element parameter values, enable parameter values
for tuning and optimization, and specify other options about the element and its parameters. To access this tab, double-click
an element or port in a schematic window, or click an element in the schematic window, then right-click, and choose
Properties. This dialog box contains the following options:
Field

Description

Name

Parameter name.

Value

The value of the parameter. Depending on the type of parameter, the value can be a numeric
value, a string, a variable, or a vector. Certain parameters also allow an empty value.

Unit

The unit of the parameter (for example, nH, pF, or mil)

Tune

If selected, the parameter is tunable.

Optimize

If selected, the parameter is used during optimization.

Constrain

If selected, limits the parameter to the range defined by the Lower and Upper settings during
tuning and optimization.

Lower

If Constrain is selected, this defines the lower limit for the parameter during tuning and
optimization.

Upper

If Constrain is selected, this defines the upper limit for the parameter during tuning and
optimization.

Step Size

Step size for tuning and discrete optimization.
a

Use Statistics

If selected, varies the parameter during yield analysis.
a

Yield Optimize

If selected, uses the parameter during yield optimization analysis. The Use Statistics field must
also be selected for yield optimization.

Tolerancea

Specifies the amount to vary the parameter. Tolerance can be specified as an absolute value, or
as a percent by adding the percent character as a suffix (for example, "10%")
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Field

Description
ab

Distribution

Uniform: An equal distribution of the variable tolerance.
Normal: A Gaussian distribution of the variable tolerance.
Log Normal: Distribution of the variables whose logarithm is normally distributed.
Discrete: Distribution of variables that can take only discrete values.
Normal-Tol: A Gaussian distribution with values near the center removed.
Normal Clipped: A Gaussian distribution with values near the edge removed.

Tolerance2a

Only used for distributions that require a second statistical parameter.

Hide

If selected, the parameter is hidden when displaying the element.

Hide Label

If selected, the parameter name is hidden but the parameter value displays.

Description

A description of the parameter.

Enable

Enables/disables the element in the active schematic. The default is selected (enabled).

Freeze

If selected, freezes the placement of the element in the active schematic.

Hide Name

If selected, hides the element name in the active schematic.

Bold Name

If selected, displays the element name in bold typeface.

Part Number

An optional part number for this component (either defined by the manufacturer or
internally-defined).

a

Displays when the Yield button in the toolbar is toggled On.
See “Setting Statistical Properties” for more information about statistical distributions.

b

See “Using Property Grids” for details on using property grids.

Dialog Box Reference5–3

Element Options Dialog Box: User Attributes Tab

Element Options Dialog Box: User Attributes Tab

The Element Options dialog box User Attributes tab allows you to assign user-defined properties such as cost, power,
weight, and current. To access this tab, double-click an element or port in a schematic, system diagram, or EM document
window, or select the element in the window, right-click, and choose Properties. This dialog box contains the following
options:
Field

Description

Name

Property name.

R

A check mark indicates that the property is read-only; an empty field indicates that the property
is editable.

Visible (schematics
only)

Specify whether the property displays in the document. If set to None, the user attribute only
displays as the result of the UATTR annotation. Other choices are to display Value, Name, or
Both .

Value

Property value
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Element Options Dialog Box: Symbol Tab

The Element Options dialog box Symbol tab allows you to specify a symbol other than the default symbol for this element.
To access this tab, double-click an element or port in a schematic window, or click an element in the schematic window,
right-click, and choose Properties. This dialog box contains the following options:
Field

Description

Symbol

Name of the currently selected symbol.

Number of nodes

The number of nodes associated with the currently selected symbol.

Use custom color

Select this option and then click the Symbol Color button to display the Color dialog box for
custom symbol color selection. To use the default symbol color, clear this option.

(drop-down box)

Select the desired symbol file (*.syf). The list box lists all symbols that are compatible with the
electrical element.

Preview

View a preview of this symbol.
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Element Options Dialog Box: Layout Tab

The Element Options dialog box Layout tab allows you to specify a different layout cell than the default for this element.
To access this tab, double-click an element or port in a schematic window, or click an element in the schematic window,
right-click, and choose Properties. This dialog box contains the following options:
Field

Description

Cell name

Displays the name of the currently selected layout cell.

Library name

This selection helps find possible layout cells. When this selection is blank, the available cells
are parameterized layout cells loaded into the Cadence® AWR Design Environment® program.
Any artwork cell libraries (GDSII or DXF) in the project are listed here. Select the artwork cell
library for a list of available layout cells for the element.

Ignore library name

If selected, the name of the library that contains the layout cell is ignored. If multiple libraries
contain a layout cell with the same name, the first cell that is encountered with that name is
used.

Multiplicity param

If selected, indicates the name of the element parameter that determines the number of instances
of the layout cell to draw.

Number of nodes

Enter the number of nodes you want the displayed layout cells to have. Layout cells do not need
to have the same number of nodes as the electrical element.

List of compatible cells The list box lists all layout cells that contain the specified Number of nodes.
area
Preview area
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View a preview of this layout cell.
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Element Options Dialog Box: Model Options Tab
The options displayed in this dialog box differ based on the type of model selected. This dialog box is for non-subcircuits
and non-distributed elements. See “Element Options Dialog Box: (Distributed Line) Model Options Tab” for options
for distributed line models and “Element Options Dialog Box: (Subcircuit) Model Options Tab” for options for subcircuits.

The Element Options dialog box Model Options tab allows you to specify model type and SPICE model extraction options.
To access this tab, double-click an element or port in a schematic window, or click an element in the schematic window,
right-click, and choose Properties. This dialog box contains the following options:
Field

Description

SPICE Model
Extraction

Use schematic defaults:

Uses the default SPICE netlist syntax for the chosen SPICE simulator.

EM Extraction Options Select the Enable check box to enable EM extraction of the element. You must also set the Group
name. For more information, see “EM: Creating EM Structures with Extraction”.
Multi-rate Harmonic
Balance

(Cadence APLAC® HB simulator only) Choose the block ID of the multi-rate harmonic balance
block.

Vector Instance
Properties

Allows you to create the specified number of vector instances. For example [0:3] creates four
instances. See “Vector Instances” for details.
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Element Options Dialog Box: (Distributed Line) Model Options Tab

The Element Options dialog box (Distributed Line) Model Options tab allows you to specify model type and SPICE model
extraction options. To access this tab, double-click an element or port in a schematic window, or click an element in the
Schematic window, right-click, and choose Properties. This dialog box contains the following options:
Field

Description

SPICE Model
Extraction

Use schematic defaults: Uses the default SPICE Model Extraction and Model Compatibility options
as set on the Circuit Options dialog box AWR Sim tab. Otherwise, select a specific option.

EM Extraction Options Select the Enable check box to enable EM extraction of the element. You must also set the Group
name. For more information, see “EM: Creating EM Structures with Extraction”
Multi-rate Harmonic
Balance

(APLAC only) Choose the block ID of the multi-rate harmonic balance block.

Vector Instance
Properties

Allows you to create the specified number of vector instances. For example [0:3] creates four
instances. See “Vector Instances” for details.
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Element Options Dialog Box: (Subcircuit) Model Options Tab

The Element Options dialog box (Subcircuit) Model Options tab allows you to specify transient simulation options for a
model represented by its frequency-dependent N-port parameters (Touchstone file or EM Structure). To access this tab,
double-click a subcircuit in a schematic window, right-click, and choose Properties.
There are two methods of representing such models for transient simulations: Rational Approximation with equivalent
circuit generation, and Numerical Convolution. You can use Rational Approximation only for a model that represents a
passive device (a device that does not generate power, such as interconnect). The code checks for passivity using a strict
passivity criterion. Experimental errors and errors in EM simulations can result in small passivity violations that can be
corrected using the Make passive options. The PASSIVE measurement in the Linear > Gain category can display the
amount of passivity violation.
Rational approximation can be obtained by fitting to either short-circuit admittance (Y), or scattering parameters (S).
Fitting to S-parameters is preferable when simulating N-ports that describe interconnect, and when there is no DC (f=0)
data available. After constructing the approximation and enforcing its passivity, an equivalent circuit consisting of Voltage
Controlled Current Sources with s-dependence in the form of rational function (represented in pole-residue, or Foster
form) is generated. This approach yields fast and accurate transient simulations. The CPU time is proportional to the
length of the transient waveform to be simulated. Under most conditions, the rational approximation approach yields
superior accuracy.
Numerical convolution can be used for both passive and active N-ports. However, it is important to have the data on a
uniform dense grid of frequency points to achieve satisfactory accuracy. When performing a long transient simulation
(for example, when simulating an eye diagram), numerical convolution yields a slower simulation, as the CPU time
scales superlinearly with the length of transient simulation.
This dialog box contains the following options:
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Element Options Dialog Box: (Subcircuit) Model Options
Tab
Field

Description

Fitting to Y parameters

Use Convolution if not passive: Checks if the N-port is passive. If it is not, it switches to numerical

convolution after issuing a warning message. If it is passive, it constructs the rational
approximation of the Y matrix and enforces the passivity of the generated approximation within
the frequency range of the available data.
Make passive: Constructs the rational approximation of the Y matrix, and enforces the passivity
of the generated approximation within the frequency range of the available data.
Fitting to S parameters

Use Convolution if not passive: Checks if the N-port is passive. If it is not, it switches to numerical

convolution after issuing a warning message. If it is passive, it constructs the rational
approximation of the S matrix and enforces the passivity of the generated approximation within
the frequency range of the available data.
Make passive in band: Constructs the rational approximation of the S matrix, and enforces the
passivity of the generated approximation within the frequency range of the available data.
Make passive everywhere: Constructs the rational approximation of the S matrix, and enforces
its passivity over the entire frequency axis. This is slower than the previous option, and is
recommended if there is a convergence problem.
Convolution (needs
denser grid)

Extract Delay, Use fMax:

Use numerical convolution, assuming that the frequency response is
identically zero above fMax, the maximum available frequency in the model (e.g. Touchstone
file). Delay extraction is performed.
Extract Delay, Use 2*fMax: Use numerical convolution, assuming that the frequency response is
identically zero above 2* fMax, where fMax is the maximum available frequency in the model
(e.g. Touchstone file). Delay extraction is performed.
Don't Extract Delay, Use fMax: Use numerical convolution, assuming that the frequency response
is identically zero above fMax, the maximum available frequency in the model (e.g. Touchstone
file). No delay extraction is performed.
Don't Extract Delay, Use 2*fMax: Use numerical convolution, assuming that the frequency response
is identically zero above 2* fMax, where fMax is maximum available frequency in the model
(e.g. Touchstone file).

EM Extraction Options Select the Enable check box to enable EM extraction of the element. You must also set the Group
name. For more information, see “EM: Creating EM Structures with Extraction”
Multi-rate Harmonic
Balance

(APLAC only) Choose the block ID of the multi-rate harmonic balance block.

Vector Instance
Properties

Allows you to create the specified number of vector instances. For example [0:3] creates four
instances. See “Vector Instances” for details.
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Element Options Dialog Box: Port Tab

The Element Options dialog box Port tab allows you to modify port attributes. To access this tab, double-click an element
or port in a schematic window, or click an element in the schematic window, right-click, and choose Properties. This
dialog box contains the following options.
Field

Description

Port Type

Source: Active port.
Termination: Passive port.
Network terminated: If Termination

is the port type, you can specify the port termination value
to be dependent upon a network (such as another schematic). You must specify the name of the
network via the NET parameter. This option is disabled if the port type is Source.
Specify source gamma: If Termination is the port type, you can specify the magnitude and angle
of the port termination. This option is disabled if the port type is Source.
Swept power: If Source is the port type, you can choose to use the swept power version of the
port.
Tone Type

If Source is the port type, you can select the number of tones produced by the port. This option
is disabled if the port type is Termination.

Dialog Box Reference5–11

Element Options Dialog Box: Port Tab
Field

Description

Source Excitation

Excite fundamental frequency:

Specifies that the source is a sinusoid (or sinusoids) at frequency
(or frequencies) corresponding to the number of tones selected in Tone Type.
Signal source: Specifies a pulse train, sawtooth signal, triangular or square wave (as selected at
the bottom of the option) whose fundamental frequency is equal to the tone-1 frequency.
Signal source (file-based):Specifies a file-based input. The file to use is selected at the bottom of
the option.
Modulated signal (file-based): Specifies a file-based modulated signal. The file to use is selected
at the bottom of the option. The Source Excitation options are enabled or disabled based upon
your selection in Tone Type.
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Element Options Dialog Box: Ground Tab

The Element Options dialog box Ground tab allows you to specify a subcircuit grounding type. To access this tab,
double-click a subcircuit element in a schematic window, or select a subcircuit element in the schematic window,
right-click, and choose Properties. This dialog box contains the following options:
Field

Description

Grounding Type

Select the ground type for any port count data file or subcircuit.
Normal is the original part count of the subcircuit.
Explicit ground node exposes a ground node and subcircuit with the number of ports of the
subcircuit plus 1.
Balanced ports exposes a reference node for each of the original ports, creating a subcircuit with
twice the number of original ports.

See “Subcircuit Grounding” for details on using this setting.
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Element Options Dialog Box: Net Properties Tab

The Element Options dialog box Net Properties tab allows you to edit electrical net (iNet) names directly from a schematic.
To access this tab, double-click an electrical net or element node in a schematic window, or select a net/node in the
schematic window, right-click, and choose Edit Net Properties. This dialog box contains the following option:
Field

Description

Net Name

Allows you to modify the logical User Net name from a schematic, even when there is no wire
and only two nodes directly connected.

See “Electrical Net (iNet) Elements” for more information about iNet elements.
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Element Options-(Schematic) EXTRACT Properties Dialog Box: SPICE Model
Generation Tab

The Element Options-(Schematic) EXTRACT Properties dialog box SPICE Model Generation tab allows you to control
how simulation results from extraction are sent to transient simulators. To access this tab, on a schematic, double-click
an EXTRACT element, or right-click on the element and choose Properties. This dialog box contains the following
options:
Field

Description

SPICE Model
Generation

Level 0 - Simplest Models: All transmission lines and other distributed models are shorted.
Level 1 - 1st order (lumped): Transmission lines are modeled as an RC Pi lumped circuit. Note

that this is not a very accurate model of transmission lines.
Level 2 - 2nd order (lump/dist.): Transmission lines are modeled as an RLC Pi lumped circuit (one
"lump" per transmission line). This can be an adequate model for transmission lines whose
length is less than 0.1 of the wavelength of the highest frequency of interest.
Level 3 - Distributed: Accurate models are used for most distributed devices. Transmission lines
discontinuities such as steps and T-junctions are still modeled using simple lumped
approximations, however. Also, simple lumped approximations are used for capacitor models
from Dielectric Labs.
Level 4 - Most accurate available: In addition to level 3 models, rational approximation models
are used for capacitors from Dielectric Labs and for some transmission line discontinuities.
Fitting to Y Parameters

Use Convolution if not passive: Checks if the N-port is passive. If it is not, it switches to numerical

convolution after issuing a warning message. If it is passive, it constructs the rational
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Field

Description
approximation of the Y matrix and enforces the passivity of the generated approximation within
the frequency range of the available data.
Make passive: Constructs the rational approximation of the Y matrix, and enforces the passivity
of the generated approximation within the frequency range of the available data.

Fitting to S Parameters

Use Convolution if not passive: Checks if the N-port is passive. If it is not, it switches to numerical

convolution after issuing a warning message. If it is passive, it constructs the rational
approximation of the S matrix and enforces the passivity of the generated approximation within
the frequency range of the available data.
Make passive in band: Constructs the rational approximation of the S matrix, and enforces the
passivity of the generated approximation within the frequency range of the available data.
Make passive everywhere: Constructs the rational approximation of the S matrix, and enforces
its passivity over the entire frequency axis. This is slower than the previous option, and is
recommended if there is a convergence problem.
Convolution (needs
denser grid)

Extract Delay, Use fMax:

Use numerical convolution, assuming that the frequency response is
identically zero above fMax, the maximum available frequency in the model (e.g. Touchstone
file). Delay extraction is performed.
Extract Delay, Use 2*fMax: Use numerical convolution, assuming that the frequency response is
identically zero above 2* fMax, where fMax is the maximum available frequency in the model
(e.g. Touchstone file). Delay extraction is performed.
Don't Extract Delay, Use fMax: Use numerical convolution, assuming that the frequency response
is identically zero above fMax, the maximum available frequency in the model (e.g. Touchstone
file). No delay extraction is performed.
Don't Extract Delay, Use 2*fMax: Use numerical convolution, assuming that the frequency response
is identically zero above 2* fMax, where fMax is maximum available frequency in the model
(e.g. Touchstone file).
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Element Options-(Schematic) STACKUP Properties Dialog Box: Material Defs.
Tab

The Element Options-(Schematic) STACKUP Properties dialog box Material Defs. tab allows you to add new materials
to structures, specify their properties, and edit and delete these layers. To access this tab, on a schematic, double-click a
STACKUP element, or right-click on the element and choose Properties. This dialog box contains the following options:
Field

Description

Dielectric Definitions Define the dielectric.
Add: Displays the Add Dielectric dialog box.
Remove: Deletes the currently selected dielectric.
Advanced: Displays a dialog box for setting specific dielectric and magnetic properties.
You can type new values in the Name,Er,and TanD columns, and set a new color by clicking in
the Color column and selecting a color from the drop-down list.

Dialog Box Reference5–17

Element Options-(Schematic) STACKUP Properties Dialog
Box: Material Defs. Tab
Field

Description

Conductor Definitions Define a conductor's properties by its conductivity.
Add: Displays the Add Conductor dialog box.
Remove: Deletes the currently selected dielectric.
Advanced: Displays a dialog box for setting specific dielectric and magnetic properties.
You can type new values in the Name and Sigma columns and set a new color by clicking in the
Color column and selecting a color from the drop-down list.
Impedance Definitions Define a conductor's properties by its impedance.
Add: Displays the Add Conductor dialog box.
Remove: Deletes the currently selected dielectric.
You can type new values in the Name,ResSq,ResF, and React columns and set a new color by
clicking in the Color column and selecting a color from the drop-down list.
NOTES: Both the Conductor and Impedance Definitions define the electrical properties of a conductor. For Conductor
Definitions, you specify the conductivity and then the thickness is set on the Materials tab. For Impedance Definitions,
the thickness is already accounted for in the values entered (ohms/sqr). There are two methods you can use, as sometimes
you know your material conductivity (gold, copper, etc) and sometimes you will know your material's impedance (thin
film resistors, etc).
The following names are reserved and cannot be used: Air, Perfect Conductor, Approx Open, and Inf WG. You cannot
add items with these names.

Add Dielectric
When you click the Add button, the Add Dielectric dialog box displays.

Type the values for Name, Er, and TanD, or choose a value from the Preset menu. Any time you add a new dielectric, it
is listed in the Preset menu.

Advanced Settings
When you click the Advanced button, the following dialog box displays.
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Element Options-(Schematic) STACKUP Properties Dialog
Box: Material Defs. Tab

Select the Anisotropic check box to expose the x and y contributions for each value. Type the values for each directional
property. The active EM simulator needs to support anisotropic materials for these settings to be effective.

Add Conductor
When you click the Add button, the Add Conductor dialog box displays.

Type the values for Name and Conductivity, or choose a value from the Preset menu. Any time you add a new dielectric,
it is listed in the Preset menu.

Add Impedance
When you click the Add button, the Add Impedance dialog box displays.
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Element Options-(Schematic) STACKUP Properties Dialog
Box: Material Defs. Tab

Type the values for Name, Low frequency resistance, High frequency loss coef., and Excess surface reactance.
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Element Options-(Schematic) STACKUP Properties Dialog Box: Dielectric
Layers Tab

The Element Options-(Schematic) STACKUP Properties dialog box Dielectric Layers tab allows you to add dielectric
layers to structures, specify their properties, and edit and delete these layers. To access this tab, on a schematic, double-click
a STACKUP element, or right-click on the element and choose Properties. This dialog box contains the following options:
Field

Description

Layer

Indicates the dielectric layer number. Specifies layers from top down, layer 1 is on top. Note,
the selected layer selected is highlighted in the cross-section view along the left.

Thickness

Specifies the thickness of the dielectric layer.

Material Definition

Select a material that was defined on the Material Defs tab.

Draw Scale

Specifies a factor used to visually scale a layer thickness in the 3-D view. This scale factor
allows very thin or very thick layers to be exaggerated to improve the visualization of structures
with layers that have very large differences in their relative thickness.

Insert button

Inserts a new layer with identical properties to the currently selected dielectric. The cross section
display will add an additional dielectric layer also.
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Field

Description

Delete button

Deletes the currently selected dielectric. The cross section display will remove this dielectric
layer also.

Up/Down buttons

Change the location of the currently selected dielectric. The cross section display will update
after each move.

Top Boundary and
Bottom Boundary

Perfect Conductor: This option models the boundary as a lossless perfect electric conductor.
Approx Open: Using this option is equivalent to assigning the boundary to a material that has

Substrate Name

Displays the name of the specified substrate.

a
DC resistivity of 377 ohms, which is the impedance of free-space. When simulating an open
boundary, the top cover should be far enough away from the circuit that any near-fields radiated
from the circuit do not interact significantly with the boundary. The use of a 377 ohm boundary
is an approximation for free space that should provide sufficient accuracy for most problems.
This option would be used when analyzing an antenna type structure using the EM simulator.
Inf WG: The infinite waveguide option models the top (or bottom) layer as an infinitely long
waveguide using the same dielectric as the top (or bottom) layer. An infinite waveguide boundary
could be used to model a microstrip to rectangular waveguide transition.
Other: Any Conductor or Impedance Definition defined on the Material Defs tab is also available
to model the boundary with the specified electrical characteristics.

NOTE: If you move the mouse over the cross-section display pane on the left, a Tool Tip displays that layer's dielectric
properties. When you select a dielectric layer, that layer highlights in the display pane.
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The Element Options-(Schematic) STACKUP Properties dialog box Materials tab allows you to add new materials to a
structure, specify their properties, and edit and delete these layers. To access this tab, on a schematic, double-click a
STACKUP element, or right-click on the element and choose Properties. This dialog box contains the following options:
Field

Description

Insert button

Inserts a material with identical properties to the currently selected material.

Delete button

Deletes the currently selected material. If this material is being used in EM mapping, a dialog
displays to confirm the deletion.

Name

Enter the material name. This name is used in the EM Layer Mapping and Line Type tabs.

Thickness

Enter the thickness of the material. For Conductor Definitions, the thickness completes the
conductor's physical properties. For Impedance Definitions, the thickness setting is not used.

Material Def.

Select a material defined from the Conductance and Impedance settings from the Material Defs
tab.

Etch Angle

For future implementation.

Roughness

Enter the surface roughness of the material.

Solve Inside

Select to specify solving inside the conductors.
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Element Options-(Schematic) STACKUP Properties Dialog Box: EM Layer
Mapping Tab

The Element Options-(Schematic) STACKUP Properties dialog box EM Layer Mapping tab allows you to specify how
shapes in EM Layout will be simulated. If a drawing layer does not have a mapping entry, it will not be used in simulation.
To access this tab, on a schematic, double-click a STACKUP element, or right-click on the element and choose Properties.
This dialog box contains the following options:
Field

Description

Drawing Layer

Layer as displayed in the Layout View.

EM Layer

Select the EM structure dielectric layer number (only layers in current dielectric layers configured
can be selected). If set to None, this layer is not mapped and any shapes on the layer are not
simulated. If you move the mouse over the cross-section display pane on the left, a Tool Tip
shows where this layer is located in the stackup. Vias are the "Via Extent" number of layers from
the entered layer down.

Via

Distinguishes if the layer describes vias or planar conductor objects.

Material

Maps drawing layers to materials defined on the Materials tab used for simulation. If empty it
defaults to Perfect Conductor.
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Field

Description

Via Extent

Number of layers the via extends. The default is 1.

Active EM Mapping

EM Layer mapping to display from the LPF selected.

LPF Name

Selects which LPF to display mapping table.

New Map

Adds new EM Layer Mapping to the selected LPF.

Delete Map

Deletes selected Active EM Mapping table. This is active only if there is more than one EM
Mapping.

NOTES: When you select a row, the mapping of shapes on that drawing layer displays in the cross-sectional pane on
the left. This view is useful to visualize the affects of your mapping settings. Vias will always draw completely through
a layer and will draw through as many layers as the Via Extent setting. Conductors will draw with varying thicknesses in
each dielectric based on how thick the conductor is and how thick the dielectric is.
The EM Layer Mapping display is a view of the same EM layer mapping displayed in the Drawing Layers Options dialog
box. If you edit the mapping here, the Drawing Layers EM mapping is also edited. Please use caution when editing these
fields as this change is used for any STACKUP using this same mapping table. If you are unsure and need to edit this
table, Cadence recommends making a new table first.
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Element Options-(Schematic) STACKUP Properties Dialog Box: Line Type
Tab

The Element Options-(Schematic) STACKUP Properties dialog box Line Type tab allows you to define lines and their
properties. To access this tab, on a schematic, double-click a STACKUP element, or right-click on the element and
choose Properties. This dialog box contains the following options:
Field

Description

Line Type

Name of the Line Type used in the process.

Material Name

Maps Line Type to materials defined on the Materials tab used for simulation. If empty it defaults
to Perfect Conductor.

EM Layer

Select the EM structure dielectric layer number (only layers in current dielectric layers configured
can be selected). If set to None, this layer is not mapped, and any shapes on the layer are not
simulated. If you move the mouse over the cross-section display pane on the left, a Tool Tip
shows where this layer is located in the stackup.

Upper Gnd*

Specifies the dielectric layer number for ground above the line.

Upper Gnd Material* Specifies the material for the upper ground. If empty, it defaults to Perfect Conductor.
Lower Gnd*

Specifies the dielectric layer number for ground below the line.
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Field

Description

Lower Gnd Material* Specifies the material for the lower ground. If empty it defaults to Perfect Conductor.
Initialize

Imports line types from an LPF in your project. A second dialog box opens to prompt you to
select the proper LPF. This is the recommended way of populating this list.

Insert

Adds a new line to the mapping table. Not recommended for use.

Delete

Deletes the current line from the mapping table. Not recommended for use.

*only available if Specify grounds is selected.
NOTES: If you do not specify the grounds, they are set at the top and bottom of the enclosure. On the Dielectrics tab,
you can specify the material type for the enclosure.
If you select Specify grounds but do not change the default values, the option is not saved when you close the dialog box.
When you select a row, the mapping of shapes on that drawing layer displays in the cross-sectional pane at the left to
help you visualize the affects of your mapping settings.
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Element Options-(Schematic) STACKUP Properties Dialog Box: Parameters
Tab

The Element Options-(Schematic) STACKUP Properties dialog box Parameters tab allows you to define parameters for
an EM structure. To access this tab, on a schematic, double-click a STACKUP element, or right-click on the element
and choose Properties. This dialog box contains the following options:
Field

Description

Name

Parameter name.

Value

The value of the parameter. Depending on the type of parameter, the value can be a numeric
value, a string, a variable, or a vector. Certain parameters also allow an empty value.

Unit

The unit of the parameter (for example, nH, pF, mil).

Tune

If selected, the parameter is tunable.

Optimize

If selected, the parameter is used during optimization.

Constrain

If selected, limits the parameter to the range defined by the Lower and Upper settings during
tuning and optimization.

Lower

If Constrain is selected, this defines the lower limit for the parameter during tuning and
optimization.

Upper

If Constrain is selected, this defines the upper limit for the parameter during tuning and
optimization.

Step Size

Step size for tuning and discrete optimization.
a

Use Statistics

If selected, varies the parameter during yield analysis.
a

Yield Optimize

If selected, uses the parameter during yield optimization analysis. The Use Statistics field must
also be selected for yield optimization.

Tolerancea

Specifies the amount to vary the parameter. Tolerance can be specified as an absolute value, or
as a percent by adding the percent character as a suffix (for example, "10%")
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Field

Description
ab

Distribution

Uniform: An equal distribution of the variable tolerance.
Normal: A Gaussian distribution of the variable tolerance.
Log Normal: Distribution of the variables whose logarithm is normally distributed.
Discrete: Distribution of variables that can take only discrete values.
Normal-Tol: A Gaussian distribution with values near the center removed.
Normal Clipped: A Gaussian distribution with values near the edge removed.

Tolerance2a

Only used for distributions that require a second statistical parameter.

Hide

If selected, the parameter is hidden when displaying the element.

Hide Label

If selected, the parameter name is hidden but the parameter value displays.

Description

A description of the parameter.

Enable

Enables/disables the element in the active schematic. The default is selected (enabled).

Freeze

If selected, freezes the placement of the element in the active schematic.

Hide Name

If selected, hides the element name in the active schematic.

Bold Name

If selected, displays the element name in bold typeface.

Part Number

An optional part number for this component (either defined by the manufacturer or
internally-defined).
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Element Options-(Schematic) STACKUP Properties Dialog Box: User Attributes
Tab

The Element Options-(Schematic) STACKUP Properties dialog box User Attributes tab allows you to assign user-defined
properties such as cost, power, weight, and current. To access this tab, on a schematic, double-click a STACKUP element
or right-click on the element and choose Properties. This dialog box contains the following options:
Field

Description

Name

Property name

Value

Property value
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Element Options-(Schematic) STACKUP Properties Dialog Box: Symbol Tab

The Element Options-(Schematic) STACKUP Properties dialog box Symbol tab allows you to allows you to modify the
symbol associated with a specified model. To access this tab, on a schematic, double-click a STACKUP element, or
right-click on the element and choose Properties. This dialog box contains the following options:
Field

Description

Symbol name

Name of the currently selected symbol.

Number of nodes

The number of nodes associated with the currently selected symbol.

(Compatible symbols) Select the desired symbol file (*.syf). The list box lists all symbols that are compatible with the
electrical element.
(Description)

The name of the schematic which contains the element for which you are changing the symbol.
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Element Options-(Schematic) STACKUP Properties Dialog Box: Rules Tab

The Element Options-(Schematic) STACKUP Properties dialog box Rules tab displays a text entry field to define rules
for simplifying geometry for EM simulation. See “Geometry Simplification” for details on this feature. To access this
tab, on a schematic, double-click a STACKUP element, or right-click the STACKUP element and choose Properties.
This dialog box contains the following options:
Field

Description

Enable rules

Turns rules on or off

Import

Import an existing .rules file

Verify

Verify that the rules syntax is correct
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New Netlist Dialog Box

The New Netlist dialog box allows you to add a new netlist to a schematic. To access this dialog box, choose Project >
Add Netlist > New Netlist or right-click Netlists in the Project Browser and choose New Netlist. This dialog box contains
the following options:
Field

Description

Enter a name for the
new netlist

Enter a descriptive name for the new netlist. This name is displayed under the Netlists node in
the Project Browser.

Select the desired type Select the desired netlist file format.
Create as a linked file Allows you to access a netlist without copying it into the current project. When you link to a
netlist, that file must always be available for the project to read.
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Add Subcircuit Element Dialog Box

The Add Subcircuit Element dialog box allows you to add a subcircuit element to a schematic or system diagram, and
specify its grounding type. To access this dialog box, choose Draw > Add Subcircuit with a schematic or system diagram
window active. This dialog box contains the following options:
Field

Description

Name/Ports/Type

Choose a subcircuit from the list of available data sources. Type can be schematic, system
diagram, data file, subcircuit, netlist, or other.

Grounding Type

Select the ground type for any port count data file or subcircuit.
Normal is the original part count of the subcircuit.
Explicit ground node exposes a ground node and subcircuit with the number of ports of the
subcircuit plus 1.
Balanced ports exposes a reference node for each of the original ports, creating a subcircuit with
twice the number of original ports.

See “Subcircuit Grounding” for details on using this settings.
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Circuit Options Dialog Box: Layout Tab

The Circuit Options dialog box Layout tab allows you to modify options related to layout grid and cell snap, and to specify
polygon points. To access this tab, choose Options > Default Circuit Options, or double-click Circuit Schematics in the
Project Browser, or right-click Circuit Schematics in the Project Browser and choose Options. For option descriptions,
see “Layout Options Dialog Box: Layout Tab ”.
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Circuit Options Dialog Box: Paths Tab

The Circuit Options dialog box Paths tab allows you to specify path drawing options. To access this tab, choose Options
> Default Circuit Options, or double-click Circuit Schematics in the Project Browser, or right-click Circuit Schematics in
the Project Browser and choose Options. For option descriptions, see “Layout Options Dialog Box: Paths Tab ”.
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Circuit Options Dialog Box: iNet Tab

The Circuit Options dialog box iNet tab allows you to specify iNet options for vias and bends. To access this tab, choose
Options > Default Circuit Options, or double-click Circuit Schematics in the Project Browser, or right-click Circuit Schematics
in the Project Browser and choose Options. For option descriptions, see “Layout Options Dialog Box: iNet Tab ”.
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Circuit Options Dialog Box: Spectre Tab

The Circuit Options dialog box Spectre tab allows you to manually add text into generated Spectre netlists. To access
this tab, choose Options > Default Circuit Options, or double-click Circuit Schematics in the Project Browser, or right-click
Circuit Schematics in the Project Browser and choose Options. For more information about transient simulation, see
“Transient Analysis”. This dialog box contains the following options:
Field

Description

Reset Defaults

Resets all options in the dialog box to their default settings.

Text for beginning of
netlist file

Enter text to add to the beginning of the netlist.

Text for end of netlist Enter text to add to the end of the netlist.
file
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Circuit Options Dialog Box: Job Scheduler Tab

The Circuit Options dialog box Job Scheduler tab allows you to specify job processing options for schematics. These
options are used on all schematics unless you override them for an individual instance of a schematic (see “Options
Dialog Box: Job Scheduler Tab”). To access this tab, choose Options > Default Circuit Options, or double-click Circuit
Schematics in the Project Browser, or right-click Circuit Schematics in the Project Browser and choose Options. This
dialog box contains the following options:
Field

Description

Max Threads

Maximum number of threads per job. A value of 0 indicates that a simulation is allowed to use
all available threads.

Simulate as AWRDE
Server Job

All measurement-based simulations for this document are done in a separate AWR Design
Environment process. When selected, simulations are portable and can be run remotely or in
parallel.
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Circuit Options Dialog Box: Nets/Voiding Tab

The Circuit Options dialog box Nets/Voiding tab allows you to specify dynamic voiding options. Dynamic voiding options
are configured in the layout process file. The schematic options provide flexibility in selecting these options on a per
schematic basis. To access this tab, choose Options > Default Circuit Options, or double-click Circuit Schematics in the
Project Browser, or right-click Circuit Schematics in the Project Browser and choose Options. This dialog box contains
the following options:
Field

Description

Connectivity mode

Controls the running of automated net connectivity extraction.
Disabled: Disables automated net connectivity extraction.
Extract before voiding: Specifies that net connectivity extraction is always executed as a pre-step
to voiding. If voiding is enabled, the behavior is the same as Auto extract. If voiding is not
enabled, the behavior is the same as Disabled.
Auto extract: Specifies that net connectivity extraction is executed after any edits to the layout
that can change the connectivity (independent of voiding).

Shapes sticky to nets

Controls if shapes added to nets remain in the net if the shape is pulled out of the net, but isn't
connected to any other net.

Smoothing mode

Specifies use of the dynamic shape corner rounding and small feature removal as defined in the
LPF.

Show top level
dynamic only

When selected, only dynamic shapes in the top level document display; shapes lower in the
hierarchy are hidden.

Put voided shapes on
base layer

When selected, puts result voided shapes on the base layer.

Use fast voiding

When selected, enables the fast voiding algorithm.

Use parallel voiding

When selected, enables the parallel voiding algorithm.
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Options Dialog Box: Frequencies Tab

The Options dialog box Frequencies tab allows you to specify the frequency sweep or point at which simulations are
performed for this schematic. To access this tab, right-click a schematic under Circuit Schematics or a netlist under Netlists
in the Project Browser, and choose Options. This dialog box contains the following options:
Field

Description

Use Project Defaults

Use the frequencies defined for the entire project. If this check box is cleared, specify the
frequencies for this schematic only. For option descriptions, see “Project Options Dialog Box:
Frequencies Tab ”.
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Options Dialog Box: Schematic Tab

The Options dialog box Schematic tab allows you to modify options related to parameter unit normalization. To access
this tab, right-click a schematic under Circuit Schematics or an EM document under EM Structures in the Project Browser,
and choose Options. This dialog box contains the following options:
Field

Description

Process Library

Name: Process library (PDK) that the schematic is associated with. This parameter is read-only.
Version: Version of the PDK that the schematic is associated with. The version can be modified

if multiple PDK versions are loaded.
LPF: Specify the associated LPF file. If the schematic is associated with a PDK, the LPF is preset
to the LPF specified by the PDK, and it is auto-updated if the Version is modified.
Stackup for 3D view and Z-Position: Specify a Stackup in order to change the Z position of the
schematic (in 3D view) by selecting an EM layer. This option applies only when the schematic
is used in hierarchy. See “Cell Options Dialog Box: Layout Tab ” for more information.
Use project defaults

Use the project defaults for schematic or EM document options. If this check box is cleared,
specify the schematic options for this schematic or EM structure only.

Unit Normalization

Dependent parameters use base units:

Specify whether or not dependent parameters use base

units.
Scale exported parameters with units to user unit values: For parameterized subcircuits with passed
parameters that have a Unit Type set in the Edit Equation dialog box, specify that values passed

from a parent document to a child document are automatically scaled back to user-specified
(project) units so that variable parameters in the child document can be written using project
units.
Annotations

Specify the number of digits to show for annotations displayed directly on a schematic or EM
document.
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Options Dialog Box: Symbol Tab

The Options dialog box Symbol tab allows you to modify the symbol associated with a specified model. To access this
tab, right-click a schematic under Circuit Schematics, a system diagram under System Diagrams, or an EM structure under
EM Structures in the Project Browser, and choose Options. This dialog box contains the following options:
Field

Description

Symbol name

Name of the currently selected symbol.

Number of nodes

The number of nodes desired for the symbol.

Compatible symbols

Select the desired symbol. The list box shows the names of all symbols that have the specified
number of nodes.

Description

The description displayed for the subcircuit in the Element Browser.
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Options Dialog Box: iNet Tab

The Options dialog box iNet tab allows you to specify iNet options for vias and bends. To access this tab, right-click a
schematic under Circuit Schematics in the Project Browser, and choose Options. This dialog box contains the following
options:
Field

Description

Use Project Defaults

Use the project defaults for iNet options. If this check box is cleared, specify the iNet options
for this schematic only. For option descriptions, see “Circuit Options Dialog Box: iNet Tab”.
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Options Dialog Box: Locking Tab

The Options dialog box Locking tab allows you to modify options related to configuration control. To access this tab,
right-click a schematic under Circuit Schematics, a system diagram under System Diagrams, or an EM structure under EM
Structures in the Project Browser, and choose Options. This dialog box contains the following options:
Field

Description

Locking Options

Specify whether this document is locked, or whether editing or viewing is allowed. When a
document is locked for editing, you can only open and view the document; edits are not allowed.
When a document is locked for viewing, you cannot open and view the document. When a
document is locked, you cannot edit the content of that design window, but you can change
other properties such as frequencies and symbols.

Password

Enter a password to change options.

Dialog Box Reference5–45

Options Dialog Box: Spectre Tab

Options Dialog Box: Spectre Tab

The Options dialog box Spectre tab allows you to manually add text into generated Spectre netlists. To access this tab,
right-click a netlist under Circuit Schematics in the Project Browser, and choose Options. This dialog box contains the
following options:
Field

Description

Use Project Defaults

Use the project defaults for netlist options. If this check box is cleared, specify the netlist syntax
options for this schematic only. For option descriptions, see “Circuit Options Dialog Box:
Spectre Tab”.
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Options Dialog Box: Job Scheduler Tab

The Options dialog box Job Scheduler tab allows you to specify job processing options for individual schematics. To
access this tab, right-click a schematic under Circuit Schematics in the Project Browser, and choose Options. This dialog
box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for AWR Job Scheduler options. If this check box is cleared, specify
the job processing options for this schematic only. For option descriptions, see “Circuit Options
Dialog Box: Job Scheduler Tab”.
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Options Dialog Box: Nets/Voiding Tab

The Options dialog box Nets/Voiding tab allows you to specify dynamic voiding options. Dynamic voiding options are
configured in the layout process file. The schematic options provide flexibility in selecting these options on a per schematic
basis. To access this tab, right-click a schematic under Circuit Schematics in the Project Browser, and choose Options.
This dialog box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for dynamic voiding options. If this check box is cleared, specify the
dynamic voiding options for this schematic only. For option descriptions, see “Circuit Options
Dialog Box: Nets/Voiding Tab”.
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Rename Netlist Dialog Box

The Rename Netlist dialog box allows you to rename a netlist and update the name within the project. To access this
dialog box, right-click a netlist under Netlists in the Project Browser and choose Rename Netlist. This dialog box contains
the following options:
Field

Description

Enter a new name

Type a name for the new netlist.

Synchronize

Update with the name change any place this source is used (for example, subcircuits,
measurements, or equations).
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Rename Data File Dialog Box

The Rename Data File dialog box allows you to rename a data source file, and to update the name within the project. To
access this dialog box, right-click a data file under Data Files in the Project Browser and choose Rename Data File. This
dialog box contains the following options:
Field

Description

New Name

Type a name for the new data source file.

Synchronize
References

Update with the name change any place this source is used (for example, subcircuits,
measurements, or equations).
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Save Simulation Results Dialog Box

The Save Simulation Results dialog box allows you to specify which simulation results to save for lengthy nonlinear
simulations. To access this dialog box, choose Simulate > Results > Save. This dialog box contains the following options:
Field

Description

Save only results used Saves results for existing measurements only; adding a similar or even the same measurement
for existing
at a different port means a resimulation will be necessary.
measurements
Save dynamically
Saves dynamically computed results such as operating point information.
computed information
Save charges,
capacitance,
conductances

When Q, C, and G for nonlinear sources is selected in the Compute and save results from area of
the Advanced HB Options dialog box, saves that information.

Simulator Results to
Save

After a simulation, displays the simulator results that you can save.
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Swap Element Dialog Box

The Swap Element dialog box allows you to swap an element on a circuit for another specified element. An advanced
use of the swap command is also described in the following options. To access this dialog box, in a schematic window,
right-click on an element and choose Swap Element. This dialog box contains the following options:
Field

Description

Choose replacement

Choose the element with which you want to replace the selected element.

The Swap Element command has an extended capability that allows swapping multiple elements, swapping with an
element that has a different number of nodes from the original, and swapping with elements from the libraries node. It
also provides the option to preserve or replace the swapped element's electrical parameters. To swap one or more elements,
select the element(s) in the schematic, then in the Element Browser, right-click on the element with which you want to
replace the selected element(s). Choose Replace Selected Element > Preserve Parameters or Replace Selected Element >
Replace Parameters to replace the selected element with the specified element and preserve or replace its parameters.
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Restrict Selection (Schematics) Dialog Box

The Restrict Selection (Schematics) dialog box allows you to prevent the selection of specified item types such as
equations, text, and wires. To access this dialog box, in a schematic window, right-click in a blank space and choose
Restrict Selection. This dialog box contains the following options:
Field

Description

Graphic primitives

Shapes drawn on the schematic using Draw > Arc, Draw > Ellipse, Draw > Polygon, Draw > Polyline,
or Draw > Rectangle.

Equations

Equations added to the schematic using Draw > Add Equation.

Text

Text added to the schematic using Draw > Text.

Element parameter text Grouped text containing element parameter information such as an element's type, ID, and
parameter values.
Elements

Components added to the schematic by dragging them from the Element Browser. Does not
include parameter text.

Wires

Schematic interconnections between elements.

Annotations

Displays of voltages, currents, etc. on the schematic created by right-clicking the appropriate
node under Circuit Schematics in the Project Browser and choosing Add Annotation.

Movable probes

M_PROBE elements added to the schematic by dragging them from the Element Browser.
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Transmission Line Calculator Dialog Box

The Transmission Line Calculator dialog box allows you, for some transmission line and coupled transmission line
elements, to synthesize physical parameters based on electrical specifications. To access this dialog box, right-click a
transmission line element in a schematic and choose Synthesize. This dialog box contains the following options:
Field

Description

Physical property grid Initially populated with the schematic's center frequency (calculated as the N/2 frequency in
the list), the model's physical parameters, and referenced substrate parameters. If any of the
physical parameters are equations, the evaluated value displays. Select Synthesize check boxes
for the transmission line physical parameters to synthesize based on the Electrical property grid
Target values.
Electrical property grid Displays the targeted electrical values after synthesis.
Left arrow

Click to run the synthesis program.

Right arrow

Click to run the analysis program. Generally unnecessary as an analysis is performed with the
final physical values.

Ele Help

Displays the Help for the selected element.

Sub Help

Displays the Help for the associated substrate.

For more information, see the Help for the supported transmission line/coupled transmission line elements: MLIN,
MCLIN, SLIN, SCLIN, S1LIN, CPW1LINE, RWG_TEmn, COAX, and COAXC.
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Element Selection Tool Dialog Box

The Element Selection Tool dialog box allows you to select all items on the active schematic that match specified criteria.
To access this dialog box, with a schematic window active, choose Edit > Select Tool. This dialog box is mode-less, so
you can view it while continuing to work in the design environment. This dialog box contains the following options:
Field

Description

Name

Element name, for example "MLIN" or "PORT".
This option supports regular expression syntax. See the following table for more information.

Parameter

Element's parameter name and value, for example "W=75". You can type in both types to further
restrict the search.
This option supports regular expression syntax. See the following table for more information.

Action

Add adds matching elements to the current selection group.
Remove removes matching elements from the current selection group.
Replace makes the matching elements the only elements in the current
Click Select to perform the selection group operation.

selection group.

Select

Click Select to perform the selection group operation.

Edit

Click Edit to open the Element Options dialog box for the items currently selected.

Numerous tutorials and reference guides for regular expression syntax exist on-line. The form and functionality of these
regular expressions is modeled after the regular expression facility in the Perl 5 programming language. The following
table shows some syntax examples.
Syntax

Comment

.

Match any single character.

*

Match zero or more of the preceding character.

+

Match one or more of the preceding character.

?

Match zero or one of the preceding character.

\d

Match any digit (0-9).

[ch]at

Match cat and hat.

W[1-3]

Match W1, W2, and W3.

MBEND|MLIN

Match MBEND or MLIN.

^M

Match names that start with M.

^W\d+

Match names that start with W followed by one or more digits.

\$$

Match names that end in $.

ID=TL\d

Match names that contain ID=TL followed by a digit.
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Export Cadence Unified Library Dialog Box

The Export Cadence Unified Library dialog box allows you to export schematic and layout data (as .iff and .oa files,
respectively) from Cadence Microwave Office® software for use in Cadence Allegro® PCB design software, Cadence
Virtuoso® software, and Cadence SiP software. For details about the interoperability between the AWR Design
Environment platform and both Allegro and Virtuoso software, see Appendix E, AWR Design Environment Interoperability
with Virtuoso and Allegro . To access this dialog box, right-click a schematic in the Project Browser and choose Cadence
Unified Library Export. This dialog box contains the following options:
Field

Description

Use project defaults

Use the project defaults for export options.

Library

Specify options for exporting the design library. Select an option to view a short description of
it in the display area at the bottom of the dialog box. When exporting from a project that uses
a Unified Library PDK, Tech Option should be set to Attach to Existing Tech, and Attach to
Technology should specify the technology library name in the Unified Library. This setting
defaults to the Technology Library specified during import of the Cadence Unified Library in the
“Cadence Unified Library Import Wizard Dialog Box: Options Tab”.

Layout

Specify options for exporting the design layout. Select an option to view a short description of
it in the display area at the bottom of the dialog box.

Schematic

Specify options for exporting the design schematic. Select an option to view a short description
of it in the display area at the bottom of the dialog box.
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Export Cadence Unified Library Dialog Box
Field

Description

Presets

Specify preconfigured options for exporting to a set environment or for a specific use. For
example, choose IC - Virtuoso to set standard options to create a tech file with IC fabric, or choose
Board - Allegro to set options that are required for an AWR/DE-HDL/Allegro link.
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New EM Structure Dialog Box
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New EM Structure Dialog Box

The New EM Structure dialog box allows you to create a new EM structure, specify the structure name, and choose the
electromagnetic simulator to associate with the EM structure. To access this dialog box, select the EM Structures node
in the Project Browser, right-click and choose New EM Structure. This dialog box contains the following options:
Field

Description

Enter a name for the
EM structure

Enter a descriptive name for the new EM structure. This name is displayed under the EM
Structures node in the Project Browser.

Select a simulator

The list of available simulators is determined dynamically by searching the Windows registry
for simulators that support the EM Socket interface. Select a simulator for a short description
of the simulator in Description.

Initialization Options Specify where to get "default" for EM structures.
From Stackup: This is the preferred method because the STACKUP block is easier to configure
and you can specify any of the blocks as the default for the structure. With this method you do
not need to enter the Stackup properties for EM structures individually; you specify the structure
property in the STACKUP block instead. When an EM structure is created it gets all the
information such as dielectric materials, dielectric properties, number of dielectric layers,
conductor materials, and material properties from the STACKUP. See “Element
Options-(Schematic) STACKUP Properties Dialog Box: Material Defs. Tab” for more
information. When this option is selected the Global Doc drop-down allows you to choose a
global definition, and the Stackup drop-down allows you to choose a STACKUP to use. If
created with this setting blank, the default setting is used.
From LPF: Allows you to select any LPF loaded in your project and an EM layer mapping table
specified in that LPF. See “EM Layer Mappings” for more information. When you select this
option the LPF drop-down allows you to choose an LPF, and the EM Mapping drop-down allows
you to choose which EM Mapping table from the selected LFP to use.
Default: Provides an easy means of initializing a new EM structure from a primary LPF. This
option is no different than initializing by selecting From LPF and choosing the primary LPF.
When you select this option the Active EM mapping is used.
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Project Level Defaults - EM Options Dialog Boxes
The following EM Options dialog boxes allow you to configure the default options to apply to all EM structures. Unless
you override these options at the document level (see “Document Level Defaults - Options Dialog Boxes ”), these options
are used for all EM structures.
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EM Options Dialog Box: Layout Tab

The EM Options dialog box Layout tab allows you to configure the default layout options for the Cadence® Microwave
Office® EM structure Editor. These drawing options are used unless you override them for an individual instance of an
EM structure (see “Options Dialog Box: Layout Tab”). The layout options allow you to configure visual aspects of 3D
views. To access this tab right-click EM Structures in the Project Browser and choose Options. This dialog box contains
the following options:
Field

Description

Model as linetype

Clear this check box if a p-cell or other shape in EM layout uses a line type.

Line Thickness

The line thickness of various components of the view.

Show enclosure outline In a 3D view, draws the outlines of the enclosure and substrate layers.
Show conductor fill

In a 3D view, displays the selected conductor fill pattern.

Red-blue stereo 3D

In a 3D view, displays the structure in 3D if you have special glasses.

Show conductor
wireframe

In a 3D view, draws the conductor wireframe.
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EM Options Dialog Box: Current View Tab

The EM Options dialog box Current View tab allows you to configure the 3D animation frames per cycle. This option is
used unless you override it for an individual instance of an EM structure (see “Options Dialog Box: Current View Tab”).
To access this tab right-click EM Structures in the Project Browser and choose Options. This dialog box contains the
following option:
Field

Description

3D Animation

Frames/cycle
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is the number of bitmap images used in the animation of one frequency cycle.

EM Options Dialog Box: Job Scheduler Tab

EM Options Dialog Box: Job Scheduler Tab

The EM Options dialog box Job Scheduler tab allows you to specify job processing options for EM structures. These
options are used on all EM structures unless you override them for an individual instance of an EM structure (see “Options
Dialog Box: Job Scheduler Tab”). To access this tab right-click EM Structures in the Project Browser and choose Options.
This dialog box contains the following options (Cluster options display only with a license to use the Cadence Analyst™
3D FEM EM simulator on Linux):
Field

Description

Max Threads

Controls the maximum number of execution threads for Cadence AXIEM® 3D planar EM
simulations, or maximum number of processes for Cadence Analyst software simulations. A
value of 0 specifies use of all available processors, up to a maximum of 8. To use more than 8
threads/processes, you must set the exact number of threads/processes to use. A negative value
specifies use of the maximum on the machine minus this number. A positive value specifies to
use that maximum number. Using positive numbers may not provide optimal use of the simulator.
For example, if you set the value to 1 and you have 4 processors, the simulation runs
approximately 4x slower than if it were set to 0. Additionally, if used on a different computer
with more cores than the computer setup, this value could limit the simulation speed.

Job Process Priority

Controls the Operating System priority of the running job process. A Default setting is preferable.

Remote Execution

Controls where a job simulates if there are remote servers available. The job simulates either
on the local machine if set to Local Only or on remote machines if set to Remote Only.
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Field

Description

Preferred Remote
Queue

For remote jobs, specify the preferred remote server to run the job on. The Default setting
corresponds to the first enabled server listed in the Remote Hosts table in the Job Scheduler
Admin dialog box. See “Job Scheduler Admin Dialog Box: General Settings Tab ”. Only enabled
servers are listed in the selection drop-down.

Remote Performance
Preference

Controls job assignments to remote computers (in combination with the LocalComputePreference
option set via the Job Scheduler Admin dialog box on the remote computer). The default is
Normal, so jobs are never rejected by remote computers. If set to High, a job is only assigned to
a remote computer with LocalComputePreference set as High, and rejected by computers with
this option set to Normal. If no remote computers satisfy the Remote Performance Preference of
the job, the scheduler node rejects the job.

Remote Memory
Preference

Controls job assignments to remote computers (in combination with the LocalMemoryCapacity
option set via the Job Scheduler Admin dialog box on the remote computer). The default is
Normal, so jobs are never rejected by remote computers. If set to High, a job is only assigned to
a remote computer with LocalMemoryCapacity set as High, and rejected by computers with this
option set to Normal. If no remote computers satisfy the Remote Memory Preference of the job,
the scheduler node rejects the job.

Max Nodes for
Multiple Jobs

Controls the maximum number of compute nodes swept, optimization, and yield jobs. A value
of 0 specifies to use all available compute nodes.

Max Parallel Jobs Per Controls the maximum number jobs that can simulate in parallel on a compute node. The actual
Node (Windows)
number of parallel jobs that simulate on a compute node may be further limited by the
MaxRunningJobs option set in the Job Scheduler Admin dialog box on the remote compute node.
Hosts Per Job (Linux) (Analyst simulations only) The maximum number of compute nodes per job.
Max Parallel Jobs
(Linux)

Controls the maximum number of jobs that can be simultaneously submitted to a Linux queue.

Submission Options
Override

Specify submission options that override those specified for the remote host entry in the Job
Scheduler Admin dialog box. See “Job Parameters and LSF/Torque Submission”. These options
are passed directly to your Linux resource manager as trailing lines in the submission script.
You can use them to specify memory reservations or wall time limits, for example.
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EM Options Dialog Box: EMSight Tab

The EM Options dialog box EMSight tab allows you to configure the default options for EM structures in which EMSight
is the simulator. These options are used on all EM structures with EMSight selected as the solver unless you override
them for an individual instance of an EM structure (see “Options Dialog Box: EMSight Tab”).The EMSight tab allows
you to specify options specifically related to how EMSight solves the electromagnetic problem. To access this tab
right-click EM Structures in the Project Browser and choose Options. This dialog box contains the following options:
Field

Description

De-embed Ports/Feed Automatically removes the port discontinuities and de-embeds the results to the reference planes
Lines
indicated by the reference plane arrows attached to the ports. For more information, see
“De-embedding”.
Compute Loaded
Currents

Allows the EM simulator to use the port termination properties to solve for the currents in the
structure under terminated (loaded) conditions. The solution for the loaded current is used for
animation purposes only. The time required to compute the loaded currents is relatively short,
so this option is usually left enabled. If this check box is cleared, the current animation shows
a standing wave solution of the currents.

Use Fast De-embed (1 The de-embedding procedure requires the analysis of two separate "de-embedding standards"
port/side)
to perform the de-embedding. Normally this requires a completely separate analysis with a
different sized enclosure (which requires the computation of a new set of moment tables). The
fast de-embedding algorithm determines the required "de-embedding standards" using the
moment tables from the main structure, which eliminates the need to compute a new set of
moment tables for the de-embedding process. The drawback of the fast de-embed algorithm is
that it is currently only implemented for the de-embedding of sides that have a single port. When
there are multiple ports on a side, the standard de-embedding routine is automatically used
instead of the fast de-embed routine. The other drawback with the fast de-embedding algorithm
is that it fails when the length of the enclosure is close to a multiple of a half wavelength. The
solver issues a warning when it detects this problem. For more information, see “De-embedding”.
Select a Matrix Solver Several options are available for the matrix solver that is used to solve the moment matrix. The
choice of the solver should only have an effect on the memory requirements and the solution
time, with the exception of Single Precision which may also effect accuracy. The moment matrix
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Field

Description
is a symmetric matrix (half the matrix is a mirror image of the other half). The EM simulator
can store the moment matrix as a full matrix (storing all entries) or as a symmetric matrix (where
only half of the entries are stored). The storage method is determined by the following Select a
Matrix Solver options.
Default Direct: Allows the EM simulator to choose which solver is best for the problem being
solved. This option chooses between the Direct Full (Out-of-Core) solver and the Direct Full
solver based on the size of the problem, the available physical memory, and the matrix type
(real or complex). This option does not choose the precision.
Direct Full: Stores the entire moment matrix, while the Direct Symmetric solver stores only one
half of the matrix, as it is symmetric. The advantage of using the Direct Full solver is that the
algorithm used can be stored in the available RAM. However, if the problem size causes the
matrix to use virtual memory, the speed is drastically reduced. You should always use the Direct
Full solver if the problem can be solved using the available RAM.
Direct Symmetric: Normally it is best to use the symmetric storage since it requires half the
memory of the full storage.
Direct Full (Out-of-Core): Like the other direct solvers, this solver inverts the moment matrix by
a factorization algorithm. The difference in this algorithm is that this solver is able to store the
matrix on the disk drive and factor the matrix in blocks as they are swapped to and from memory.
This effectively removes the limitations of the maximum problem size due to the amount of
RAM on your computer. This solver should be the preferred solver for very large problems that
cannot be solved using the Direct Full solver.
Iterative Solvers: Four iterative solvers are offered to solve EM problems. The only difference
between these iterative solvers is the amount of time spent creating the preconditioner. The
iterative solvers work best for loosely meshed EM structures.

Iterative Solver
Tolerance

The iterative solvers use this option to determine when the solver has converged to the correct
solution. A higher tolerance increases the confidence of convergence to the correct solution, at
the expense of longer simulation times.

Single Precision (less The matrix to solve is set up with single precision numbers instead of double precision numbers.
memory)
The memory requirement is cut in half, but accuracy may be lost (typically at lower frequencies.
Enable AFS

Specifies whether or not to use Advanced Frequency Sweep (AFS) to speed up EM simulations.
This option is off (cleared) by default. Generally, AFS can speed up the EM simulation if at
least 20 frequency points are needed. If this option is selected, the number of frequency points
within its range can be as large as desired without incurring a significant CPU time penalty. For
more information about AFS see “Advanced Frequency Sweep (AFS) ”.

Error Type

Error Type is used with Error Tol in the convergence criterion for AFS. Possible settings are
Absolute and Relative. Absolute provides the fastest convergence, and Relative yields the greatest
accuracy. Absolute is recommended as it is accurate enough in most cases.

Error Tol (dB)

Error tolerance used along with Error Type to determine if the AFS algorithm has converged.
The default setting is -40 dB. The recommended range is from -60 to -30 dB. Remember to
keep it negative.

# Grid Pts

Number of grid points used by the AFS algorithm to determine convergence. The deviation
between two candidate rational approximations is checked on the grid with the specified number
of frequency points. The recommended settings are 200 to 500. There is no benefit in reducing
this number below 200.

Max # Sim Pts

Maximum number of EM simulations AFS can perform before it is required to stop, display the
best available approximation and report achieved accuracy. The default setting of 200 virtually
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Field

Description
removes the limit. The typical number of simulations AFS has to perform ranges from 8 to 30
depending on the frequency range and the number of resonances in the frequency dependence.

Specify AFS Band

If selected, AFS approximation is constructed only for the frequency range from Start to Stop.
All other frequencies are simulated directly, after AFS is finished.

Start

If Specify AFS Band is selected, this is the start frequency of the range for which to construct the
AFS approximation.

Stop

If Specify AFS Band is selected, this is the stop frequency of the range for which to construct the
AFS approximation.
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The EM Options dialog box NET-AN Options tab allows you to configure the default options for EM structures in which
OEA NET-AN Extractor (Multi-Net 3D Field Solver Extraction) is the simulator. These options are used on all EM
structures with OEA NET-AN Extractor selected as the solver unless you override them for an individual instance of an
EM structure (see “Options Dialog Box: NET-AN Options Tab”). To access this tab right-click EM Structures in the
Project Browser and choose Options. This dialog box contains the following options:
Field

Description

Simulation Mode

Specify what type of components to include in the SPICE model returned:
Shorts: In this mode of operation, the connectivity between ports is determined purely from
graphical data passed. This option is useful when using EM Extraction to determine if the
connectivity is the same as that represented in the schematic.
C: The returned SPICE model contains only capacitors.
R: The returned SPICE model contains only resistors.
RC: The returned SPICE model contains only resistors and capacitors.
RCL: The returned SPICE model contains only resistors, capacitors, and inductors.
RCLK: The returned SPICE model contains only resistors, capacitors, inductors, and inductive
coupling.
RL: The returned SPICE model contains only resistors and inductors.
RLK: The returned SPICE model contains only resistors, inductors, and inductive coupling.

RC Time Constant (pS) Controls the maximum RC time constant value in pico seconds which the NET-AN solver uses
to break up large RC PI sections.
Minimum K (0.0 0.99)

The minimum value of the inductance coupling ratio (K value) that is added to the SPICE output
file. The default value if blank is 0.1. This value can range from 0.0 to 0.99.

Expansion Distance
(um)

The clip distance around target nets (in the netlist) that are included in the simulation.

Minimum Conductor
Separation (um)

The minimum separation to ensure correct fracturing of non-orthogonal geometries for the solver
without causing shorts between nets.
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The EM Options dialog box ACE tab allows you to configure the default options for EM structures in which ACE
Automated Circuit Extractor is the simulator. To access this tab right-click EM Structures in the Project Browser and
choose Options. These options are used on all EM structures with ACE Automated Circuit Extractor selected as the solver
unless you override them for an individual instance of an EM structure (see “Options Dialog Box: ACE Tab”). To access
this tab right-click EM Structures in the Project Browser and choose Options. This dialog box contains the following
options:
Field

Description

Extract Discontinuities Extracts discontinuities models for junctions such as bends, tees, crosses, steps, and open ends.
Extract Crossovers

Extracts a capacitor model between two consecutive metal layers that completely cross over
each other perpendicularly.

Calculation Method

Select a calculation method for crossover.

Remove Short Lines

Removes those transmission lines whose length-to-width ratio is smaller than the Minimum L/W
ratio.

Minimum L/W Ratio

Controls the threshold at which the lines are eliminated. This ratio is also used to control the
minimum length of lines that can be modeled with coupled lines. Currently, the minimum length
of line that can couple with another line is set to 2* Minimum L/W ratio.

Extract Coupled Lines Extracts coupled line models for the parallel sections of the lines.
Max Coupled Lines

Maximum number of segments that can be coupled together in a coupled line. The maximum
number of coupled lines allowed is 100. Increasing this number provides more complete analysis
of the coupling, but at the expense of increased simulation time. When many lines are running
parallel together, setting this number to a number less than the number of parallel lines can cause
them to be split into multiple N-coupled lines, which may not be desirable.

Max Coupled Distance Maximum distance allowed between two lines to be considered as coupled lines. This distance
is the absolute distance measured from the center of the lines, and includes z-offsets if lines are
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Field

Description
on different layers. This number is usually set for each type of technology, as the default is often
not appropriate.

Max S/L Ratio

Maximum spacing-to-length ratio used to determine if two lines are coupled. Spacing is the
absolute distance measured from the center of the lines, and includes z-offsets if lines are on
different layers. This value can be adjusted to give the desired modeling detail.

Model Preference

This option controls the type of transmission line model the circuit extractor uses. The closed
form models are models like MLIN and SLIN, while the numerical models are models like
GMCLIN and GFMCLIN. When using closed form models such as MLIN (or SLIN) with a
stackup that is not appropriate for an MSUB (or SSUB), an approximate mapping of the stackup
to an MSUB (or SSUB) is performed. There are several choices for modeling transmission lines.
Simple series resistance: Transmission lines are modeled as simple series resistors. The value
of the resistors is computed from the dc resistance of each transmission line segment. No shunt
capacitance is taken into account. This mode of operation can be useful for debugging.
Always closed form: The transmission lines should be modeled using closed form models.
Currently only microstrip and stripline closed form models using the MSUB and SSUB substrate
definitions respectively, are supported. If coupling is to be considered, Max coupled lines should
be set to 2 with this option, as there is only a closed form model available for two lines. In
general though, this option is not recommended when coupling is to be taken into account.
Prefer closed form: This option is similar to Always closed form, except it is only a preference
(numerical models can be used when a closed form line model does not fit the problem). This
option is preferred to Always closed form when coupling is to be taken into account.
Prefer numerical models: The reverse of Prefer closed form. With this option, numerical models
are preferred over closed form models, but closed form models can still be selected if they are
more appropriate.
Always numerical models: Specifies that the numerical models are always used.

Solver Preference

Controls which numerical models are used for the transmission lines. If a closed form model is
used, then this option is not applicable.
Quasi-static MOM: Uses the GMCLIN model which is based on a boundary element based
quasi-static Method of Moments. This option is suitable for PCB, module and GaAs type
applications. The GMCLIN model does not handle very conductive substrates well, so it is not
recommended for Si IC simulation.
Quasi-static FEM for Si: Uses the GFMCLIN model which is based on a cross sectional finite
element based solver. This option is intended for Si application as this model is very general
and handles very conductive substrates well. Also, this option assumes that the ground return
path is in the same plane as the conductors (as is typically found in a Silicon IC).
Quasi-static FEM for GaAs, PCB: This option also uses the GFMCLIN model which is based on
a cross sectional finite element based solver. The difference between this option and Quasi-static
FEM for Si is in how the ground return is specified. With this option, the ground plane is assumed
to be a plane under the conductors (typical microstrip or stripline type configurations).

Curve Model

Select the desired curve model.

Coupled Line Model

Select the desired coupled line model.

Model Accuracy

For quasi-static models, enter 1 - 10 to specify model accuracy.

Match Tolerance

Controls how inexact the geometry can be while still being recognized as a circuit component
used by the circuit extractor. A higher tolerance requires a closer match (NOTE: not fully
implemented in this release).

Substrate Simplify

Choose the level of substrate simplification for general GMSUB substrate. Using a higher level
of simplification allows layers to be combined in an approximate sense. Increasing the level of
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Field

Description
simplification allows layers to be combined that have a greater difference in material parameters.
For example, a thin layer of dielectric can be combined into a thicker dielectric layer with
different material properties. If the thin layer has an er=4 and the thick layer has an er=8, then
these layers may not be combined at a low level of simplification, but increasing the level of
simplification might cause them to combine. Layers separated by a signal line are never combined.
Dielectric layers with the exact same material properties are always combined independent of
this option as long as there is not a signal line between the layers. The non-general substrates
such as MSUB and SSUB are not affected by this parameter, as these substrates must always
simplify to a particular configuration if they are used.

Use X Models

This option indicates that X-models should be used in preference to other available models.

ErNom Values

Provides ErNom values for the X-models that might be different from the Er values defined in
the stackup. This option allows the analysis of variations in Er without having X-models
computed at each Er variation. The ErNom value that is used for the X-model is the closest one
to any of the four entered in this dialog box. If no ErNom value is within at least 30% of the
desired value, stackup Er is used for ErNom.

Via Model

Specifies a user-supplied via model.

Via Map File

Specifies the configuration file that lists where via model nports can be located. This file MUST
be located in the NPorts subdirectory under the executable directory.

Show Simplified
Stackup

Specifies if the Status Window displays the potential substrates to use for the electrical models
based on the stackup. This is off by default.

Dialog Box Reference6–15

Document Level Defaults - Options Dialog Boxes

Document Level Defaults - Options Dialog Boxes
The following Options dialog boxes allow you to access and edit options specific to individual EM structures and their
associated simulators. The options in these dialog boxes apply only to the associated EM structure, and override the
options set at the project level (see “Project Level Defaults - EM Options Dialog Boxes”). To access information specific
to an individual EM structure, right-click the EM structure node under EM Structures in the Project Browser and choose
Options.

6–16 AWR Design Environment

Select a Simulator Dialog Box

Select a Simulator Dialog Box

The Select a Simulator dialog box allows you to change the electromagnetic simulator associated with an individual EM
structure. The list of available simulators is determined dynamically by searching the Windows registry for simulators
that support the EM Socket interface. To access this dialog box, right-click an EM Structure under EM Structures in the
Project Browser and choose Set Simulator.
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The Options dialog box General tab allows you to view the selected simulator, change the default editor, and determine
what results are saved in the Microwave Office project file. To access this tab, right-click an EM structure under EM
Structures in the Project Browser and choose Options. The options selected on this tab apply to all simulators. This dialog
box contains the following options.
Field

Description

Simulator

Displays the electromagnetic simulator chosen to solve this individual EM structure. You cannot
change the selected simulator from this dialog box. To change the simulator, see “Select a
Simulator Dialog Box”.

Editor

Select the default editor for this EM structure. Two editors are possible, but not all
electromagnetic simulators may support both selections. The first possible editor selection is
the AWR Layout Editor, which all electromagnetic simulators support. If the selected third-party
solver supports an editor of its own, a second selection called "Native editor" displays. If you
select the AWR Layout Editor it controls the geometry, and the Native editor (if supported) is
only used to perform a best effort view of the structure. Likewise, if you select the Native editor
it controls the geometry, and the image seen in the AWR Layout Editor is a best effort view of
the data.

Save Results in
Document

Specify which results are saved in the Microwave Office project if valid simulation results are
present at the time you save the project. Note that the port parameters of the EM structure are
always saved within the document if they are valid at the time of the Save operation. Additional
results you can save include Currents, Fields, and Antenna results. Note that if the selected
simulator does not support one or more of these options, the associated check box is disabled.
There are trade-offs involved when determining which results to save in the Microwave Office
project. If additional results are saved in the document, the size of the resulting project file can
grow substantially. However, if these results are not present, they are not available for display
or post-processing. If measurements requiring these results are desired, the results need to be
recovered by resimulation.
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Options Dialog Box: Frequencies Tab

The Options dialog box Frequencies tab allows you to specify the simulation frequencies for this EM structure. This
frequency set is often referred to as the "document frequencies". If simulation results are required at frequency points
not included in the document frequency, for example if an EM structure is included as a subcircuit in a schematic, the
simulation results are supplied via an interpolation or extrapolation of the document frequencies. To access this tab,
right-click an EM structure under EM Structures in the Project Browser and choose Options. This dialog box contains the
following options
Field

Description

Use Project Defaults

Use the frequencies defined for the entire project. If this check box is cleared, specify the
frequencies for this EM structure only.

Current Range

Lists the currently-specified frequency points.

Modify Range

Allows you to specify the frequency sweep or point at which simulations are performed for this
project. To specify a frequency sweep, enter values for Start, Stop, and Step between frequency
points. To specify a frequency point, select the Single Point check box and enter a value for Start.

Single Point

Specifies a frequency point.

Add

Adds a frequency point or range of points. Click Apply afterwards.

Delete

Deletes a frequency point or range of points. Click Apply afterwards.

Replace

Replaces the current range with a new point or range of frequencies. Click Apply afterwards.

Sweep Type

Select Linear or Logarithmic.

Data Entry Units

Allows you to specify the units of the frequency range.

Meshing Frequency

Select the Use Maximum Frequency check box or enter a lesser meshing frequency in the unit of
measure specified in Data Entry Units. If you enter a meshing frequency it must be greater than
the highest simulation frequency. Not all simulators use this option in determining the mesh. If
you use another third-party simulator, you should check the vendor documentation to see if this
option is used in determining the mesh. Changing this option does not affect the way EMSight
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Field

Description
meshes the conductors. AXIEM EM simulation uses this setting, although it must be higher
than the highest simulation frequency.
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The Options dialog box Layout tab allows you to specify visual aspects of 3D views for this individual EM structure.
The options set in this dialog box override the options set at the project level (see “EM Options Dialog Box: Layout
Tab”). To access this tab, right-click an EM structure under EM Structures in the Project Browser and choose Options.
This dialog box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for layout options. If this check box is cleared, specify the layout options
for this EM structure only. For option descriptions, see “EM Options Dialog Box: Layout Tab”.

Show free space
material (individual
EM structures only)
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Options Dialog Box: Current View Tab

The Options dialog box Current View tab allows you to configure the 3D animation frames per cycle. The options set in
this dialog box override the options set at the project level (see “EM Options Dialog Box: Current View Tab”). This tab
displays at the document level only if the selected simulator is capable of displaying currents and/or fields within
Microwave Office program. To access this tab, right-click an EM structure under EM Structures in the Project Browser
and choose Options. This dialog box contains the following option:
Field

Description

Use Project Defaults

Use the project defaults for current view. If this check box is cleared, specify the current view
for this EM structure only. For option descriptions, see “EM Options Dialog Box: Current View
Tab”.
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Options Dialog Box: Interpolation/Passivity Tab

The Options dialog box Interpolation/Passivity tab allows you to specify the interpolation options for the simulations
performed in this individual EM structure. To access this tab, right-click an EM structure under EM Structures in the
Project Browser and choose Options. This dialog box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for interpolation/passivity properties. If this check box is cleared, specify
the interpolation/passivity properties for this EM structure only. For option descriptions, see
“Project Options Dialog Box: Interpolation/Passivity Tab ”.

NOTE: Interpolation must be used carefully. The results of the interpolation should always be checked visually to make
sure the interpolation did not break down at any point. For example, if the data is noisy, the interpolation may not provide
the desired results. If it appears that the interpolation has failed to provide reliable results, try increasing or decreasing
the window size in this dialog box.
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Options Dialog Box: Job Scheduler Tab

The Options dialog box Job Scheduler tab allows you to specify job processing options for individual EM structures. To
access this tab, right-click an EM structure under EM Structures in the Project Browser and choose Options. This dialog
box contains the following options:
Field

Description

Use Project Defaults

Use the project defaults for job processing options. If this check box is cleared, specify the job
processing options for this EM structure only. For option descriptions, see “EM Options Dialog
Box: Job Scheduler Tab”.
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Options Dialog Box: Custom Tabs
When viewing the EM Options or Options dialog boxes, the tabs that display are customized for the features available
from the selected EM simulator. An additional tab customized by the simulator also displays. Typically the name of the
tab is the name of the selected simulator. For example, if the EMSight simulator is selected, an EMSight tab is included
in the dialog box. For documentation of the customized tab that displays, see the corresponding vendor documentation.
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Options Dialog Box: NET-AN Options Tab

The Options dialog box NET-AN Options tab allows you to specify settings for the OEA NET-AN EM Simulator (Multi-Net
3D Field Solver Extraction). To access this tab, right-click an EM structure under EM Structures in the Project Browser
and choose Options. Note that this tab displays only when you have selected "OEA NET-AN" as the EM simulator for
an EM structure. For option descriptions, see “EM Options Dialog Box: NET-AN Options Tab”.
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Options Dialog Box: EMSight Tab

The Options dialog box EMSight tab allows you to specify options related to the EM solver employed for the structure.
Note that this tab displays only when you select EMSight Simulator as the EM simulator for an EM structure. To access
this tab, right-click an EM structure under EM Structures in the Project Browser and choose Options. For option descriptions,
see “EM Options Dialog Box: EMSight Tab”.
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Options Dialog Box: ACE Tab

The Options dialog box ACE tab allows you to specify options related to the ACE simulator employed for the structure.
Note that this tab displays only when you select ACE Automated Circuit Extractor as the EM simulator for an EM structure.
To access this tab, right-click an EM structure under EM Structures in the Project Browser and choose Options. For option
descriptions, see “EM Options Dialog Box: ACE Tab”.
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Solver Information Dialog Box: Summary Tab

The Solver Information dialog box Summary tab displays customized information for EMSight simulations. Tabs that
are customized for and controlled by the selected EM simulator may display in its place. The tab that displays provides
information about memory usage and resource requirements for the EM simulation. This dialog box may have more than
one tab. See the vendor documentation for the selected simulator for more information. To access this dialog box,
double-click the Information node under the EM structure in the Project Browser. This dialog box contains the following
options:
Field

Description

Max # of Unknowns

Displays the maximum number of unknowns that EMSight must solve for in the simulation
process. Note that this may be from the actual simulation of the embedded structure or it could
be the number of unknowns in a de-embedding structure.

Memory

Virtual:

Displays the virtual memory available and required for the current problem. On a
Windows 32-bit operating system, each application is allocated 2GB of virtual memory.
Regardless of the amount of memory available on the system, each process must solve its
problem within this amount of addressable memory. The application itself, all loaded DLLs,
and the data for the project all reduce the amount of virtual memory available to solve the
problem.
Physical: Displays the amount of physical memory available on your machine. If the available
memory on your machine is smaller than that which is required to solve the problem, consider
changing the matrix solver option to the Direct Full (Out-of-Core) matrix to reduce the memory
requirement.
Max Block Size: Displays the largest available and required contiguous block of memory within
the virtual memory space. The matrix solvers used by EMSight require that all memory allocated
for a matrix must be allocated in a contiguous block of memory. To solve a particular problem,
the required max block size must be smaller than the available max block size. Also, if the
simulation is performed without swapping to disk, the required max block size should be smaller
than the physical memory on the machine.
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Field

Description
Disk Space:

Displays the disk space required for the solver to solve the problem, and the disk
space available (free) on the machine. The Direct Full (Out-of-Core) matrix allows you to solve
very large problems by storing the matrix on disk, so you can work on portions of it at a time.
Text Log

The text log displayed in the EMSight Solver Information dialog box attempts to analyze the
EM structure and give detailed comments about the analysis of the simulation. If the size of the
simulation is larger than the limits of your machine, information on correcting the problem are
presented.

During simulation with EMSight, the Status Window displays the elapsed time and the estimated time to completion.
You can simulate one frequency to get a good idea of your total simulation time.
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Solver Information Dialog Box: Simulation Log Tab
Both EMSight and OEA's Net-AN include this tab on the Solver Information dialog box. This tab includes the text that
displayed in past simulations, allowing you to view simulation times and other information about the simulation while
it occurred. The Clear Log button allows you to clear this text it if becomes too extensive. This log is also cleared when
you force a complete resimulation.
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Properties Dialog Box: Layout Tab

The Properties dialog box Layout tab allows you to specify layout options for a selected conductor. To access this tab,
choose a shape in an EM structure drawing window, right-click and choose Shape Properties. This dialog box contains
the following options:
Field

Description

Layer Settings

EM layer: Sets the EM layer on which the object is drawn.
Material: Lists all materials that have been created.
Via: Changes the structure to a via.
Conductor: Changes the structure to a conductor.
Extent: Number of layers the via extends. The default is 1.

Use Process Layers

When selected, the shape can be assigned a Line Type to define on which layer to draw the shape.

Show Unmapped
Layers

Display/hide unmapped layers.

Drawing Layer

Sets the drawing layer on which the object is drawn.

Orientation

Flipped: Flips the layout object from the normal orientation.
Angle: Sets the angle of orientation. For normal orientation, specify

Scale

For future implementation.

Freeze

Makes the layout object unmovable and uneditable.
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Properties Dialog Box: Boundary Conditions Tab

The Properties dialog box Boundary Conditions tab allows you to specify the EM boundary type and its top, bottom, and
side conditions. To access this dialog box, in a Cadence Analyst document, select the boundary shape, right-click and
choose Shape Properties. You can also access this dialog box by double-clicking the Enclosure node under any Analyst
document in the Project Browser, and on the Element Options - ENCLOSURE Properties dialog box clicking the Boundary
Conditions tab. This dialog box contains the following options:
Field

Description

Side, Top, and Bottom Set the appropriate boundary conditions for each part of the boundary shape. See “Choosing
Boundary
Boundary Conditions” for a description of the settings.
Use Side Boundary

When selected, each side of the boundary shape uses the Side Boundarysetting. If this option is
cleared, you can specify the boundary condition for each side separately. See “Specifying
Simulation Boundaries” for details on identifying the appropriate side.
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Port Attributes Dialog Box

The Port Attributes dialog box allows you to specify port attributes. To access this dialog box, double-click a port in an
EM structure window. The dialog box options that display are dependent on your simulator and port type choices. This
dialog box contains the following options:
Field

Description

Port Number

Specifies the port number. Port numbers must start with 1 and be sequential.

Type

Specify the port configuration. For AXIEM port configuration see “Auto Ports”. For Analyst
Wave port and lumped port configurations see “Analyst Ports” for more information.

GND Strap (AXIEM
only)

The default (selected), adds a ground strap for Auto ports. When this check box is cleared, the
port behaves the same as a differential port with the minus port placed on the ground plane. See
“Local Ground Plane” for details.

Excitation

Select Excitation Port to specify an Excitation port and enter relative power and phase values
for excitation data. Excitation is only used to calculate the image currents, which generate
antenna patterns, images, and e-field and current measurements. This setting does not affect
the S-parameter data.a

De-embedding Options

Reference Plane Distance

Impedance

Enter real and imaginary impedance values to specify (termination) Impedance. EM impedances
are only used to calculate the image currents, which generate antenna patterns, images, and
e-field and current measurements. The impedance port does not affect the S-parameter data.a

is the distance of the de-embedding reference plane for edge ports.
This is the distance from the end of the port, so the number is always positive. This distance is
applied only when De-embed is selected. De-embed (AXIEM only): If the vertical strip is
connected to the enclosure ground plane, its effects can be removed with de-embedding; however,
if it connects to a user ground plane (another conductor), its effects are not removed with
de-embedding.
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Port Attributes Dialog Box
Field

Description

Port Group (AXIEM
only)

Name:

Pin ID

Name identifier for pin. You can specify a pin identifier which displays in the EM subcircuit
symbol in a circuit schematic. The Pin ID is not, however, transported when the structure is
used in EM hierarchy. The Pin ID is included in Touchstone files exported using the NPORTF
output file measurement.

The calibration group name. You can type in a new name or select an existing group
name.
Type: The type of calibration group used for the grouped ports, either Mutual or Series. See
“Mutual Group De-embedding” or “Series Ports” for more information on mutual group
de-embedding, and series ports, respectively.

a

To see the effects of non-50 ohm terminations for S-parameters of EM structures, place your EM structure as a subcircuit in a schematic, add ports
to each node of the subcircuit, and then change the impedance of the ports.
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EM Ports Properties Dialog Box

The EM Ports Properties dialog box allows you to specify attributes for multiple ports in EM documents. To access this
dialog box, select a port in an EM structure window and choose Edit > Port Properties. This dialog box contains the
following options:
Field

Description

Port Number

The port numbers. Port numbers must start with 1 and be sequential.

Pin ID

Name identifier for pin. You can specify a pin identifier which displays in the EM subcircuit
symbol in a circuit schematic. The Pin ID is not, however, transported when the structure is
used in EM hierarchy. The Pin ID is included in Touchstone files exported using the NPORTF
output file measurement.

Ref. distance

The distance of the de-embedding reference plane for edge ports. This is the distance from the
end of the port, so the number is always positive.

Port Type (AXIEM
only)

Connects the port to a ground plane either above or below the edge with a vertical strip of
conductor. Connect to lower or Connect to upper automatically inserts a vertical strip of conductor
that extends from the port edge to the first conductor or ground plane that is encountered. A
delta gap port is added between the bottom of the strip that extends to the nearest conductor (or
ground) and the shape to which it connects. The effect of the strip introduces more of a
discontinuity than the default port with None selected, so you should select the De-embed check
box when using this option. If you are using differential ports, you can only set this option to
None. Point ports should also be set to None, with the GND Strap check box cleared.

GND Strap (AXIEM
only)

The default (selected), adds a ground strap for Auto ports. When this check box is cleared, the
port behaves the same as a differential port with the minus port placed on the ground plane. See
“Local Ground Plane” for details.

Group

The Calibration group name. You can type in a new name or select an existing group name.

Group Type

The type of calibration group used for the grouped ports, either Mutual or Series.
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EM Ports Properties Dialog Box
Field

Description

De-embed (AXIEM
only)

If the vertical strip is connected to the enclosure ground plane, its effects can be removed with
de-embedding; however, if it connects to a user ground plane (another conductor), its effects
are not removed with de-embedding.

Excitation

Select this option to specify an Excitation port and enter relative power and phase values for
excitation data. Excitation is only used to calculate the image currents, which generate antenna
patterns, images, and e-field and current measurements. This does not affect the S-parameter
data.

Power

The relative power value for excitation data.

Phase

The phase value for excitation data.

Real

Real value of the termination impedance when used as an excitation port (simulation data is
always returned normalized to 50 ohms).

Imag

Imaginary value of the termination impedance when used as an excitation port (simulation data
is always returned normalized to 50 ohms).

Viewing buttons

These buttons help you quickly navigate to a port or group of ports.
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Element Options-(EM) ENCLOSURE Properties: Enclosure Tab

The Element Options-(EM) ENCLOSURE Properties dialog box Enclosure tab allows you to specify the dimensions of
the enclosure for this substrate. To access this tab, double-click Enclosure under an EM structure node under EM Structures
in the Project Browser. This dialog box contains the following options:
Field

Description

X_Dim and Y_Dim
(some simulators).

The box dimensions if the EM simulator needs this information. If not, these fields do not
display. (AXIEM does not need this information, EMSight does).

Grid_X and Grid_Y

The cell size. This value cannot be smaller than the layout database resolution setting.

Freeze

Makes the element object unmovable and uneditable.

NOTES: If you specify X_Dim or Y_Dim parameters that are not integer multiples of the corresponding grid setting,
the X_Dim or Y_Dim is automatically adjusted.
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Element Options-(EM) ENCLOSURE Properties Dialog Box: Material Defs. Tab

The Element Options-(EM) ENCLOSURE Properties dialog box Material Defs. tab allows you to add new materials to
an EM structure, specify their properties, and edit and delete these layers. To access this tab, double-click Enclosure
under an EM structure node under EM Structures in the Project Browser. This dialog box contains the following options:
Field

Description

Dielectric Definitions Define the dielectric.
Add: Displays the Add Dielectric dialog box.
Remove: Deletes the currently selected dielectric.
Advanced: Displays a dialog box for setting specific dielectric and magnetic properties.
You can type new values in the Name, Er, and TanD columns and set a new color by clicking in
the Color column and selecting a color from the drop-down list.
Conductor Definitions Define a conductor's properties by its conductivity.
Add: Displays the Add Conductor dialog box.
Remove: Deletes the currently selected dielectric.
Advanced: Displays a dialog box for setting specific dielectric and magnetic properties.
You can type new values in the Name and Sigma columns and set a new color by clicking in the
Color column and selecting a color from the drop-down list.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Material Defs. Tab
Field

Description

Impedance Definitions Define a conductor's properties by its impedance.
Add: Displays the Add Conductor dialog box.
Remove: Deletes the currently selected dielectric.
You can type new values in the Name, ResSq, ResF, and React columns and set a new color by
clicking in the Color column and selecting a color from the drop-down list.
Defaults

Set the default fill color or pattern for boundaries.

NOTES: Both the Conductor and Impedance Definitions define the electrical properties of a conductor. For Conductor
Definitions, you specify the conductivity and then the thickness is set on the Materials tab. For Impedance Definitions,
the thickness is already accounted for in the values entered (ohms/sqr). There are two methods you can use, as sometimes
you know your material conductivity (for example, gold or copper) and sometimes you know your material's impedance
(for example, thin film resistors).
You cannot use the following reserved names: Air, Perfect Conductor, Approx Open, and Inf WG.

Add Dielectric
When you click the Add button, the Add Dielectric dialog box displays.

Type the values for Name, Er, and TanD, or choose a value from the Preset menu. Any time you add a new dielectric, it
is listed in the Preset menu.

Advanced Settings
When you click the Advanced button, the following dialog box displays.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Material Defs. Tab

Select the Anisotropic check box to expose the x and y contributions for each value. Type the values for each directional
property. The active EM simulator needs to support anisotropic materials for these settings to be effective. AXIEM
supports only uni-axially anisotropic materials, with the stackup direction as the axis, so property values for the x and y
directions must be the same for the AXIEM structure.

Add Conductor
When you click the Add button, the Add Conductor dialog box displays.

Type the values for Name and Conductivity, or choose a value from the Preset menu. Any time you add a new dielectric,
it is listed in the Preset menu.

Add Impedance
When you click the Add button, the Add Impedance dialog box displays.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Material Defs. Tab

Type the values for Name, Color, Low frequency resistance, High frequency loss coef., and Excess surface reactance. For
more information about how these values affect impedance, see “Impedance Definitions”.
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Element Options-(EM) ENCLOSURE Properties Dialog Box: Dielectric Layers
Tab

The Element Options-(EM) ENCLOSURE Properties dialog box Dielectric Layers tab allows you to add dielectric layers
to an EM structure, specify their properties, and edit and delete these layers. To access this tab, double-click Enclosure
under an EM structure node under EM Structures in the Project Browser. This dialog box contains the following options:
Field

Description

Insert button

Inserts a new layer with identical properties to the currently selected dielectric. The cross-section
display adds an additional dielectric layer also.

Delete button

Deletes the currently selected dielectric. If the dielectric is referenced in any mapping you are
prompted to confirm the Delete operation. The cross-section display removes this dielectric
layer also.

Up/Down buttons

Change the location of the currently selected dielectric. The cross-section display updates after
each move.

Layer

The dielectric layer number. Specifies layers from top down; layer 1 is on top. Note that the
selected layer is highlighted in the cross-section view along the left. This column is display
only.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Dielectric Layers Tab
Field

Description

Thickness

Enter the thickness of the dielectric layer.

Material Def.

Select a material defined on the Material Defs. tab.

Draw Scale

Enter a factor used to visually scale a layer thickness in the 3D view. This scale factor exaggerates
very thin or very thick layers to improve the visualization of structures with layers that have
very large differences in their relative thickness.

Top Boundary and
Bottom Boundary

Perfect Conductor: Models the boundary as a lossless perfect electric conductor.
Approx Open: Selecting this option is equivalent to assigning the boundary to a material that has

a DC resistivity of 377 ohms, which is the impedance of free-space. When simulating an open
boundary, the top cover should be far enough away from the circuit that any near-fields radiated
from the circuit do not interact significantly with the boundary. The use of a 377 ohm boundary
is an approximation for free space that should provide sufficient accuracy for most problems.
You should use this option when analyzing an antenna type structure using the EM simulator.
Inf WG: Models the top (or bottom) layer as an infinitely long waveguide using the same dielectric
as the top (or bottom) layer. You can use an infinite waveguide boundary to model a microstrip
to rectangular waveguide transition.
Other: Any Conductor or Impedance Definition defined on the Material Defs. tab are available
to model the boundary with the specified electrical characteristics.
NOTE: If you move the mouse over the cross-section display pane on the left, a tool tip displays that layer's dielectric
properties. When you select a dielectric layer, that layer highlights in the display pane.
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Element Options-(EM) ENCLOSURE Properties Dialog Box: Materials Tab

The Element Options-(EM) ENCLOSURE Properties dialog box Materials tab allows you to add new materials to an EM
structure, specify their properties, and edit and delete these layers. To access this tab, double-click Enclosure under an
EM structure node under EM Structures in the Project Browser. This dialog box contains the following options:
Field

Description

Insert button

Inserts a material with identical properties to the currently selected material.

Delete button

Deletes the currently selected material. If this material is currently used in EM mapping you
are prompted to confirm the Delete operation.

Name

Enter the material name. This name is used in the EM Layer Mapping and Line Type tabs.

Thickness

Enter the thickness of the material. A positive value means the shape is extruded up, while a
negative value means it is extruded down, as shown in the following figure. For Conductor
Definitions, the thickness completes the conductor's physical properties. For Impedance
Definitions, the thickness setting is not used.

Material Def.

Select a material from the drop-down list. For AXIEM and EMSight structures, the list includes
Perfect Conductor and all the Conductor and Impedance Definitions included on the Material
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Materials Tab
Field

Description
Defs. tab. For Analyst
Material Defs. tab.

structures, the list also include Air and Dielectric Definitions on the

Etch Angle

For future implementation.

Roughness

Enter the RMS surface roughness, in length units, of the material. Value must be less than or
equal to half the material thickness.

Solve Inside

Select to specify solving inside the conductors.

The following figure compares materials defined with positive and negative thickness values. Both materials are defined
on the same EM layer 2, as indicated by the red line. A positive thickness means that the shape is extruding up from the
EM layer, while a negative value means it is extruding down from the layer interface. Note the difference in the stackup
dielectric property spanning the thickness of these shapes. For positive thickness material, the corresponding shape is
immersed in dielectric layer 1. For negative thickness, the shape is in layer 2.
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Element Options-(EM) ENCLOSURE Properties Dialog Box: EM Layer Mapping
Tab

The Element Options-(EM) ENCLOSURE Properties dialog box EM Layer Mapping tab allows you to specify options
about how the EM structure layers and vias map to the Layout View. It also defines which EM structure layer to paste
to when copying from a layer in the Layout View (the mapping is bidirectional between EM structure layers and Layout
drawing layers). The display of this dialog box tab is EM simulator dependent. To access this tab, double-click Enclosure
under an EM structure node under EM Structures in the Project Browser. This dialog box contains the following options:
Field

Description

Drawing Layer

The layer as displayed in the Layout View.

EM Layer

Select the EM structure dielectric layer number (you can only select layers in the current dielectric
layers configured). If set to None, this layer is not mapped and any shapes on the layer are not
simulated. If you move the mouse over the cross-section display pane on the left, a tool tip
shows where this layer is located in the stackup. Vias are the "Via Extent" number of layers from
the entered layer down.

Via

Distinguishes if the layer describes a via or planar conductor.

Material

Maps drawing layers to materials defined on the Materials tab used for simulation. If empty, it
defaults to Perfect Conductor.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
EM Layer Mapping Tab
Field

Description

Via Extent

The number of layers the via extends. The default is 1.

Active EM Mapping

The EM layer mapping to display from the selected LPF. Do not change this number in this
mode.

LPF Name

Not used in this mode.

New Map

Adds new EM Layer Mapping to the selected LPF. You should not use this in this mode because
each EM structure should only have one mapping table.

Delete Map

Deletes the selected Active EM Mapping table. This is active only if there is more than one EM
Mapping.

NOTE: When you select a row, the mapping of shapes on that drawing layer displays in the cross-sectional pane on the
left. This view is useful to visualize the effects of your mapping settings. Vias always draw completely through a layer,
and draw through as many layers as specified in Via Extent. Conductors draw with varying thicknesses in each dielectric
based on how thick the conductor is and how thick the dielectric is.
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Element Options-(EM) ENCLOSURE Properties Dialog Box: Line Type Tab

The Element Options-(EM) ENCLOSURE Properties dialog box Line Type tab allows you to define line type properties
in an EM structure. The display of this dialog box tab is EM simulator dependent. To access this tab, double-click
Enclosure under an EM structure node under EM Structures in the Project Browser. This dialog box contains the following
options:
Field

Description

Line Type

Name of the Line Type used in the process.

Material Name

Maps Line Type to materials defined on the Materials tab used for simulation. If empty it defaults
to Perfect Conductor.

EM Layer

Select the EM structure dielectric layer number (you can only select layers in the current dielectric
layers configured). If set to None, this layer is not mapped and any shapes on the layer are not
simulated. If you move the mouse over the cross-section display pane on the left, a tool tip
shows where this layer is located in the stackup.

Upper Gnd*

Specifies the dielectric layer number for ground above the line.

Upper Gnd Material* Specifies the material for the upper ground. If empty, it defaults to Perfect Conductor.
Lower Gnd*

Specifies the dielectric layer number for ground below the line.
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Element Options-(EM) ENCLOSURE Properties Dialog Box:
Line Type Tab
Field

Description

Lower Gnd Material* Specifies the material for the lower ground. If empty it defaults to Perfect Conductor.
Initialize

Imports line types from an LPF in your project. A second dialog box opens to prompt you to
select the proper LPF. This is the recommended way to populate this list.

Insert

Adds a new line to the mapping table. Not recommended for use.

Delete

Deletes the current line from the mapping table. Not recommended for use.

* only available if the Specify grounds check box is selected.
NOTES: If you don't specify the grounds, they are set at the top and bottom of the enclosure. On the Dielectrics tab, you
can specify the material type for the enclosure.
If you select Specify grounds but do not change the default values, the option is not saved when you close the dialog box.
When you select a row, the mapping of shapes on that drawing layer displays in the cross-sectional pane at the left to
help you visualize the effects of your mapping settings.
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Element Options-(EM) STACKUP Properties Dialog Box: Parameters Tab

The Element Options-(EM) STACKUP Properties dialog box Parameters tab allows you to view the parameters for an
EM structure. To access this tab, double-click Enclosure under an EM structure node under EM Structures in the Project
Browser, or right-click a STACKUP element to view its properties in the Element Options:STACKUP dialog box.
NOTE:These parameters display the values set on other STACKUP Properties tabs and are intended as view-only. This
dialog box contains the following options:
Field

Description

Name

Parameter name.

Value

The value of the parameter. Depending on the type of parameter, the value can be a numeric
value, a string, a variable, or a vector. Certain parameters also allow an empty value.

Unit

The unit of the parameter (for example, nH, pF, mil).

Tune

If selected, you can tune the parameter.

Opt

If selected, the parameter is used during optimization.

Limit

Limits the parameter to the range defined by the Lower and Upper settings during tuning and
optimization.

Lower

If Limit is selected, this defines the lower limit for the parameter during tuning and optimization.
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Element Options-(EM) STACKUP Properties Dialog Box:
Parameters Tab
Field

Description

Upper

If Limit is selected, this defines the upper limit for the parameter during tuning and optimization.

Description

A description of the parameter.

6–52 AWR Design Environment

Element Options-(EM) STACKUP Properties Dialog Box:
Display Tab

Element Options-(EM) STACKUP Properties Dialog Box: Display Tab

The Element Options-(EM) STACKUP Properties dialog box Display tab allows you to modify options related to how
parameters display in an EM document. To access this tab, double-click Enclosure under an EM structure node under
EM Structures in the Project Browser. This dialog box contains the following options:
Field

Description

Name

Parameter name

Hide, Hide Empty,
Select the appropriate check box to modify the parameter display.
Hide 2nd, Hide Units,
Hide Label, Boldface
Description

(Display only) Text that describes the parameter.

Show Secondary/Hide If the Show Secondary button is active, clicking it displays all secondary parameters of the model.
Secondary
If secondary parameters are shown in the list, click the Hide Secondary button to hide them.
Hide name

Select this check box to hide all parameter names on the EM document.

Bold Name

Select this check box to display all parameters in bold typeface.
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Element Options-(EM) STACKUP Properties Dialog Box: Rules Tab

The Element Options-(EM) STACKUP Properties dialog box Rules tab displays the text entry field to define rules for
simplifying geometry for EM simulation. See “Geometry Simplification” for details on this feature. To access this tab,
double-click Enclosure under an EM structure node under EM Structures in the Project Browser.

6–54 AWR Design Environment

Restrict Selection (EM) Dialog Box

Restrict Selection (EM) Dialog Box

The Restrict Selection (EM) dialog box allows you to prevent the selection of specified item types such as text, iNets,
and EM ports. To access this dialog box, in an EM structure window, right-click in a blank space and choose Restrict
Selection. This dialog box contains the following options:
Field

Description

Polygons

Polygons added to the EM document using Draw > Polygon.

Paths

Paths added to the EM document using Draw > Path.

Circles

Circles added to the EM document using Draw > Circle.

Graphic primitives

Shapes drawn on the EM structure using Draw > Arc, Draw > Ellipse, Draw > Polygon, Draw >
Polyline, or Draw > Rectangle.

Equations

Equations added to the EM document using Draw > Add Equation.

Text

Text added to the EM document using Draw > Text.

Modifier parameter text
Pcells
Artwork cells
Subcircuit layout cells
iNets

Intelligent interconnects between layout objects.

EM ports

Edge, Internal, or Via ports on an EM document.

Layout modifier
Frozen object

Objects to which the Freeze command is applied to prevent their accidental movement.

Obj clipped by view

An object clipped by the Layout View.

Obj bounds exceed
view

Layout objects with bounding rectangles falling outside the current Layout View.
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Preview Geometry Dialog Box

The Preview Geometry dialog box allows you to preview selected sweep points in the EM structure layout view. To
access this dialog box, in the Project Browser, right-click an EM document and choose Preview Geometry. This dialog
box contains the following options:
Field

Description

Select sweep point for Select the sweep point you want to preview in the EM structure layout window.
preview
Show on selection in
list

Automatically displays a sweep point in the EM structure layout window when you select it
from the list.

View to fit

Displays the selected sweep point sized to fit within the EM structure layout window in its
entirety.

Show Selected

Displays the selected sweep point in the EM structure layout window (used when Show on
selection in list is not selected).

Show Next

Displays the sweep point that follows the selected sweep point in the list.
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Show Geometry Dialog Box

The Show Geometry dialog box allows you to preview selected sweep points in EM structure data sets. To access this
dialog box, in the Project Browser under Data Sets, right-click an EM document data set and choose View Geometry. This
dialog box contains the following options:
Field

Description

Select sweep point for Select the sweep point you want to preview in the EM structure layout window.
preview
Preview document
name

Specify a name for the preview document that shows the selected sweep point. This document
displays under the EM Structures node in the Project Browser.

Delete the preview
document on close

Delete the preview document specified in Preview document name when you Close the dialog
box. If not selected, the document is saved.

Show on selection in
list

Automatically displays a sweep point in the EM structure layout window when you select it
from the list.

Show Selected

Displays the selected sweep point in the EM structure layout window (used when Show on
selection in list is not selected).

Show Next

Displays the sweep point that follows the selected sweep point in the list.
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Show Geometry Dialog Box
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System Simulator Options Dialog Box: RF Frequencies Tab

The System Simulator Options dialog box RF Frequencies tab allows you to specify frequency offsets used in frequency
analysis simulations such as for the RF budget analysis measurements. The frequency offsets are specified relative to
the signal center frequency to easily accommodate frequency shifts due to mixers. To access this tab, choose Options >
Default System Options, or right-click System Diagrams in the Project Browser and choose Options. This dialog box
contains the following options.
Field

Description

Frequencies

Lists the currently-specified frequency offset points. Both positive and negative offsets are
allowed.

Modify Range

Allows you to specify the frequency sweep or point at which simulations are performed for this
project. To specify a frequency sweep, enter values for Start, Stop, and Step between frequency
points. To specify a frequency point, select the Single Point check box and enter a value for Start.

Single Point

Specifies a frequency point.

Add

Adds a frequency point or range of points. Click Apply afterwards.

Delete

Deletes a frequency point or range of points. Click Apply afterwards.

Replace

Replaces the current range with a new point or range of frequencies. Click Apply afterwards.

Sweep Type

Select Linear or Logarithmic.

Data Entry Units

Specify the units of the frequency range.
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Options Dialog Box: RF Frequencies Tab

The Options dialog box RF Frequencies tab allows you to specify frequency offsets used in frequency analysis simulations
such as for the RF budget analysis measurements. The frequency offsets are specified relative to the signal center frequency
to easily accommodate frequency shifts due to mixers. To access this tab, right-click a system diagram under System
Diagrams in the Project Browser, and choose Options. This dialog box contains the following options.
Field

Description

Use project defaults

Use the project defaults for frequency analysis options. If this check box is cleared, specify the
frequency analysis options for this system diagram only. For option descriptions, see “System
Simulator Options Dialog Box: RF Frequencies Tab”.
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Options Dialog Box: System Diagram Tab

The Options dialog box System Diagram tab allows you to set the base units schematic option on a system diagram level.
To access this tab, right-click a system diagram under System Diagrams in the Project Browser, and choose Options. This
dialog box contains the following options.
Field

Description

Use project defaults

Use the project defaults for system diagram options. If this check box is cleared, specify the
unit normalization option for this system diagram only.

Unit Normalization
(schematics only)

Dependent parameters use base units:

7–4 AWR Design Environment

Specify whether to allow dependent parameterized
subcircuits to work independently of project units. When this check box is cleared, parameters
do not maintain their original units (they can change when a schematic is imported into a project
with different base units.)

System Node Settings Dialog Box

System Node Settings Dialog Box

The System Node Settings dialog box displays information about a system block's input or output node. It also allows
you to set the node data type for nodes that support multiple data types. To access this dialog box, in a system diagram
with a model displayed, move the cursor over a node until a circle displays, then double-click. This dialog box contains
the following options:
Field

Description

Port Description

Display only.

Node Data Type

Indicates and optionally selects the data type output or input by the node. The options may only
be selected if the node supports multiple data types, otherwise they are disabled. The following
options are available:
Unset: The data type will be determined automatically from the connected nodes.
Real data: The data represents real floating-point values.
Complex: The data represents complex floating-point values.
Digital: The data represents bits or digital symbols, and are non-negative whole numbers.
Fixed Point: The data represents fixed-point signals. System nodes cannot be manually set to
this data type; this is done automatically by the modules that support fixed-point operation.
Nodes on the model symbols are color-coded as follows:
-Yellow for real data nodes
- Red for complex nodes
- Green for digital nodes
- Blue for fixed point nodes
- No color for nodes that can be a combination of complex, real data, and/or digital.
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Restrict Selection (System Diagrams) Dialog Box

Restrict Selection (System Diagrams) Dialog Box

The Restrict Selection (System Diagrams) dialog box allows you to prevent the selection of specified item types such
as graphic primitives, text, and iNets. To access this dialog box, in a system diagram window, right-click in a blank space
and choose Restrict Selection. This dialog box contains the following options:
Field

Description

Graphic primitives

Shapes drawn on the system diagram using Draw > Arc, Draw > Ellipse, Draw > Polygon, Draw >
Polyline, or Draw > Rectangle.

Equations

Equations added to the system diagram using Draw > Add Equation.

Text

Text added to the system diagram using Draw > Text.

Element parameter text Grouped text containing parameter information such as a block's type, ID, and parameter values.
Elements

Components added to the system diagram by dragging them from the Element Browser. Does
not include parameter text.

Wires

Schematic interconnections between blocks.

Annotations

Displays of voltages, currents, etc. on the system diagram created by right-clicking the appropriate
node under System Diagrams in the Project Browser and choosing Add Annotation.
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Signal Heritage Dialog Box

Signal Heritage Dialog Box

The Signal Heritage dialog box allows you to analyze the spectrum components of an RF Inspector simulation. You can
view detailed information about individual spectrum components. You can also determine what blocks contributed to
generating the components. For more information, see Section 2.3.2. To access this dialog box, in a graph with RF
Inspector measurements, double-click a trace. This dialog box contains the following options:
Field

Description

Content to inspect

Lists the different spectral components available for inspection in the window. Selecting a
different component updates the Details and Heritage window appropriately.

Display Floor

Allows you to set a minimum threshold for the contributors displayed in the Heritage window.
This is quite useful when the signal passes through several nonlinearities, as quite often there
are a large number of contributors with very small values compared to the overall signal, and
these contributors can be ignored.

Details

Provides detailed information on the item selected in the Heritage window. The upper portion
of the section displays component details such as power, voltage and current information for
the contribution.
The lower portion identifies, when the information is available, the equation responsible for the
contribution.

Heritage

The lower section of the RF Inspector dialog box is used to browse the heritage of the selected
spectral component. You can trace the various contributors back to their sources.
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Sweep Setup Dialog Box

Sweep Setup Dialog Box

The Sweep Setup dialog box allows you to create a sweep with a Variable Sweep Control (SWPVAR). For more
information, see “Creating a Sweep with Variable Sweep Control (SWPVAR)”. To access this dialog box, right-click a
shape modifier on a layout or a parameter on an element and choose Setup Sweep. This dialog box contains the following
options:
Field

Description

Variable Name

The name of the variable.

Sweep Type

Select Linear, Logarithmic, or List.

Range Spec

For Linear sweep types, select Start/Stop and specify the desired Start and Stop values, or select
Center/Span and specify the desired Center and Span values.

Step Spec

For Linear sweep types, select Step Size or Points and specify the desired values, or for Log
sweep types select Pts/Dec or Pts/Oct and specify the desired number of points.

Start

For Linear or Log sweep types enter the starting frequency for the sweep.

Stop

For Linear or Log sweep types enter the stopping frequency for the sweep.

Step Size

For Linear sweep types, enter the value for the step size between frequency points.

# Points

For Linear sweep types with Points as step specs, or for Log sweep types, specify the maximum
number of frequency points to sweep.

Comma separated list For List sweep types, enter a comma separated list of values to sweep.
of values
Center

For Linear sweep types with Center/Span range specs, enter a center frequency.

Span

For Linear sweep types with Center/Span range specs, enter the desired frequency span from the
center frequency.
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Graphs and Output Files
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New Graph Dialog Box

New Graph Dialog Box

The New Graph dialog box allows you to specify the type of graph you want to create. To access this dialog box, choose
Project > Add Graph, or right-click Graphs in the Project Browser and choose New Graph. This dialog box contains the
following options:
Field

Description

Enter a name for the
new graph

Enter a descriptive name for the graph. This name is displayed under the Graphs node in the
Project Browser.

Select the desired type Select the graph type you want to create:
Rectangular: Displays a measurement that has real results on an x-y axis, usually over frequency.
Smith Chart: Displays passive impedance or admittance (or both) in a reflection coefficient chart
of unit radius.
Polar: Displays the magnitude and angle of a measurement that has complex results.
Histogram: Displays the measurement as a histogram.
Antenna Plot: Displays the sweep dimension of a measurement that has real results as the angle
and the data dimension of the measurement as the magnitude.
Tabular: Displays a measurement that has both real and complex results in columns of numbers,
where the first column usually represents frequency. The remaining columns display the
measurements, with a header at the top of each column identifying the particular measurement
and data format. For measurements taken from data files with different frequency points, the
first column displays the union of the two frequency ranges; measurement values that correspond
to frequency points that do not apply to that measurement display as empty spaces.
Constellation: Displays the real and imaginary parts of a complex-valued signal against each
other, usually with time as an implied parameter. The horizontal axis shows the real part of the
signal, while the vertical axis shows the imaginary part. Symmetry constraints are applied to
the scaling of the minimum and maximum x and y axis values. The minimum and maximum
values on each axis are negatives of each other, and the x and y axes have identical minimum
and maximum values. By default, the line style of constellation graphs is set to scatter so the
data displays as unconnected dots. Constellation plots are most useful when displaying
measurements such as the IQ component of a baseband signal whose modulation scheme results
in a predictable pattern of the real and imaginary parts of the signal.
3D Plot: 3D graphs plot one or more real-valued measurements as a function of two parameters.
Results are displayed as a surface, analogous to a function of the form z = f(x, y). The two swept
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New Graph Dialog Box
Field

Description
parameters are associated with the x- and y-axes of the graph using the Add/Modify Measurement
dialog box. The value of the measurement at each x-y pair becomes the z-axis value of the graph.
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Add/Modify Measurement Dialog Box

Add/Modify Measurement Dialog Box

The Add/Modify Measurement dialog box allows you to specify the measurement that you want to output as a result of
simulations. To access the Add Measurement dialog box, choose Project > Add Measurement, or right-click a graph under
the Graphs node in the Project Browser and choose Add Measurement. To display the Modify Measurement dialog box,
double-click an existing measurement. This dialog box contains the following options:
Field

Description

Measurement Type

Select the desired measurement category, such as Antenna or Nonlinear Voltage. The list of all
possible measurements for that type displays in Measurement.

Measurement

Specify the computed data, such as gain or noise, that you want to output as a result of
simulations. This data can be plotted on a graph or deposited in an output file.

Search

Click this button to display the Select Measurement dialog box and search for a measurement
by name, description, or category (Measurement Type).

Simulator

Select a simulator. The simulators available depend on the measurement type selected and your
active Cadence® AWR Design Environment® license. The simulator vendor such as Cadence
APLAC® HB simulator or Spectre is listed first, then the simulator type. Some types include:
DC Analysis: See “DC Analysis ” for details.
Linear: See “Linear Analysis” for details.
AC-HB: See “AC Analysis” for details.
HB: See “Harmonic Balance Analysis ” for details.
Trans: See “Transient Analysis” for details.

Configuration

Choose the appropriate Switch List (if set up). See “Switch View Concepts ”

8–4 AWR Design Environment

Add/Modify Measurement Dialog Box
Field

Description

Complex Modifier

Specify a format for the measurement quantity, so you can plot it on the selected graph type:
Real: Uses the real part x of x+jy
Imag(inary): Uses the imaginary part y of x+jy
Mag(nitude): Uses the magnitude A of the polar form A*exp(j*theta)
Angle: Uses the angle theta of the polar form A*exp(j*theta)
AngleU: Same as Angle with ± 180deg transitions included for a smooth angle plot.
Complex: Compute the measurement as a complex value.
Conjugate: The conjugate of the measurement as a complex value.
dB/dBm: Compute the dB magnitude of the measurement; for example, 10*log|x| for power
measurements, and 20*log|x| for all others including output equations.
NOTE:
Only modifiers that apply to the graph type are enabled. For example, Complex and Conjugate
are disabled for rectangular graphs, and the other modifiers are disabled for Smith Charts and
polar grids. All modifiers are enabled for tabular graphs, which can display both real and complex
measurements.

One of the following,
depending on the
measurement type:
Data Source Name,
Source Name, Load
Pull Data File Name,
EM Structure Name,
Two Port Name,
Equation Name, Block
Diagram, or Variables
In

Data Source Name:

Select a data source for the measurement. Select All Sources to create a
template measurement. In this case, the measurement object creates a trace on the graph for
each data source object added to the project. All Sources makes measurement objects
data-independent. Select another data source to create a single source measurement, where the
selected source is associated with the measurement.

Other options
The available options are determined by the selected Measurement Type and Measurement. These
(measurement-dependent) options allow you to specify details required to compute this measurement, such as the frequency
sweep index or harmonic index to use. The following are some common options:
Measurement Component (or similarly named option): Click the "..." button to the right of this
option to display the associated schematic and graphically select a specific element at which to
measure a value. See “Measurement Location Selection” for more information.
Harmonic Index (or similarly named option): Click the "..." button to the right of this option to
display the Frequency dialog box and select the desired frequency. The corresponding harmonic
index parameter values automatically display at the top of the dialog box and in the Harmonic
Index option.
Sweep Freq: The frequency sweep control. See “Frequency Sweep Control” for details.
To Port Index

(Measurement specific)

From Port Index

(Measurement specific)

Use Vars

Displays or hides the option to choose any available output equations for measurement variables
to use.

Apply

Click this button after specifying a measurement if you want to add multiple measurements to
a graph without having to open the Add Measurement dialog box each time. Click OK to add a
measurement and close this dialog box.

Favorite

Click this button to specify this measurement as a favorite. Favorite measurements display in
the Add Measurement context (right-click) menu for schematic, EM structure, and system diagram
views for quick selection. You must restart the program for these entries to display.
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Add/Modify Output File Dialog Box

Add/Modify Output File Dialog Box

The Add/Modify Output File dialog box allows you to specify the data format type that you want to write to a file as a
result of simulations. To access the Add Output File dialog box, choose Project > Add Output File, or right-click a graph
under the Output Files node in the Project Browser and choose Add Output File. To display the Modify Output File dialog
box, double-click an existing output file. This dialog box contains the following options:
Field

Description

Measurement Type

Select the desired measurement category, such as File or LVS. The list of all possible
measurements for that type displays in Measurement.

Measurement

Specify the computed data (such as NPORTF or AMtoAMPMF) that you want to output to a
file as a result of simulations.

Search

Click this button to display the Select Measurement dialog box and search for a measurement
by name, description, or category (Measurement Type).

Simulator

Select a simulator. The simulators available depend on the measurement type selected and your
active AWR Design Environment license. The simulator vendor such as APLAC or Spectre is
listed first, then the simulator type. Some types include:
DC Analysis: See “DC Analysis ” for details.
Linear: See “Linear Analysis” for details.
AC-HB: See “AC Analysis” for details.
HB: See “Harmonic Balance Analysis ” for details.
Trans: See “Transient Analysis” for details.

Configuration

Choose the appropriate Switch List (if set up). See “Switch View Concepts ”

Complex Modifier

Not applicable for output files.
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Add/Modify Output File Dialog Box
Field

Description

One of the following, Data Source Name: Select a data source for the measurement. The available values depend on
depending on the
the file type selected.
measurement type:
Data Source Name,
EM Structure Name, or
Measurement
Write Noise for Active Noise parameters are only written to the output file for non-passive two-port data sources. Clear
2-Port Source
this check box to omit the noise parameters.
File Name

Click the ... button to specify the file name and location.

Other options
The available options are determined by the selected Measurement Type and Measurement. These
(measurement-dependent) options allow you to specify details required to compute this measurement, such as the frequency
sweep index or harmonic index to use. The following are some common options:
Measurement Component (or similarly named option): Click the "..." button to the right of this
option to display the associated schematic and graphically select a specific element at which to
measure a value. See “Measurement Location Selection” for more information.
Harmonic Index (or similarly named option): Click the "..." button to the right of this option to
display the Frequency dialog box and select the desired frequency. The corresponding harmonic
index parameter values automatically display at the top of the dialog box and in the Harmonic
Index option.
Sweep Freq: The frequency sweep control. See “Frequency Sweep Control” for details.
Apply

Click this button after adding a measurement if you want to add multiple measurements to a
graph without needing to open the Add Measurement dialog box each time. Click OK to add a
measurement and close this dialog box.
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Select a Graph for the Measurement Dialog Box

Select a Graph for the Measurement Dialog Box

The Select a Graph for the Measurement dialog box allows you to select the graph to which you want to add a new
measurement when there are multiple graphs. To access this dialog box, choose Project > Add Measurement when there
is more than one graph under the Graphs node in the Project Browser and no graph is selected as the active window. This
dialog box contains the following options:
Field

Description

Name

Select the graph to which you want to add the new measurement.
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Tabular Graph Options Dialog Box

Tabular Graph Options Dialog Box

The Tabular Graph Options dialog box allows you to specify display options for this graph. To access this dialog box,
right-click in a tabular graph window and choose Options. This dialog box contains the following options:
Field

Description

Complex Display
Format

Specify the format of complex numbers displayed on this graph. Select one of the following
options:
Real/Imaginary: Displays the real and imaginary components of the result.
Magnitude/Angle: Displays the polar form of the complex result.
dB Magnitude/Angle: Displays the polar form with the magnitude in decibels.

Display Precision

Specify the number of significant digits displayed for each part of the complex number. For
example, if Sweep and Dataare specified as "5", then Magnitude might be displayed as 0.54321,
and Angle might be displayed as 123.45.

Font

Change the font type, size, and style of the text that identifies the columns of the graph.

Select measurement to Select the measurement you want to edit.
edit
Meas. templates

Select the appropriate option to specify how measurements created from a measurement template
should display in the legend: All in Legend: Every measurement created from the measurement
template appears as an entry in the legend. In this case, the default data name is used to identify
different entries. One in Legend: A single legend entry represents all the measurements created
from the template.

Legend Data Name

Allows you to use the default data name in the graph legend display or to type an alternate name.

Legend Meas. Name

Allows you to use the default measurement name in the graph legend display or to type an
alternate name.

Hide x-axis column

When a graph includes multiple measurements, hides the (separate) x-axis column that displays
for measurements whose x-axis data differs from that of other measurements on the graph.
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Graph Options Dialog Box: Axes Tab

Graph Options Dialog Box: Axes Tab

The Graph Options dialog box Axes tab (available for rectangular and constellation graphs and histograms) allows you
to specify the limits on each axis of a graph. To access this tab, right-click in a graph window and choose Options. This
dialog box contains the following options:
Field

Description

Choose Axis

Select the axis for which you want to set properties.

Add Axis

You can designate multiple graticules on a graph by adding additional left or right axes. To add
an axis, select Left 1 or Right 1 in the list and click Add axis. You can set individual limits and
divisions for each axis.

Remove Axis

To reduce the number of graticules displayed, you can remove any added left or right axes. To
remove an axis, select the axis in the list and click Remove axis. Any measurements on the
removed axis are shifted to the previous axis.

Auto Limits

Automatically computes the minimum and maximum values of the chosen axis.

Auto

When a y-axis is selected and Auto limits is disabled, allows you to individually specify a value
for the y-axis maximum or minimum while the other value is automatically set. Selecting both
Auto check boxes is the same as selecting Auto limits.

Min or Max

Specify the minimum and maximum values on the chosen axis. You must clear the Auto Limits
check box for these limits to take effect.

Log Scale

Plots the data for this axis on a log scale.

Allow autoscale while Allows the graph axis to adjust while tuning to keep the entire graph response in the visible
tuning
region of the graph. This option only applies when Auto limits is selected.
Auto divs.

Automatically computes the number of divisions on the chosen axis.

Show values

Shows the numerical values of axis divisions.

Show divs.

Displays this axis' grid divisions.
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Graph Options Dialog Box: Axes Tab
Field

Description

Show subdivs.

Displays the specified grid subdivisions.

Step / Subdiv. step

Specify the step size of the divisions and subdivisions used for this axis. If the Auto Divisions
check box is selected, these options are not used.

Save as Defaults

Saves all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Sets the properties of the current graph (all tabs except Traces) to the default properties for
graphs of this type.
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Graph Options Dialog Box: Traces Tab

Graph Options Dialog Box: Traces Tab

The Graph Options dialog box Traces tab (available for rectangular graphs, antenna plots, polar grids, and Smith Charts)
allows you to specify options related to the format of measurement traces on the grids of a graph. For usage examples
of options in this dialog box, see “Trace Style ”. To access this tab, right-click in a graph window and choose Options.
This dialog box contains the following options:
Field

Description

Style

Specify the trace color, symbol, line style, and weight (line thickness) for each measurement
on this graph. Traces are identified by a number, and by the name of their associated
measurement. To specify a trace style for a given measurement, click on the numbered styles
until the desired measurement displays in Measurement, and then specify the trace color, symbol,
line style, and weight by choosing from the options for each in the boxes below the measurement
name. The default graph properties (choose Options > Default Graph Options > graphtype) settings
for trace styles (1 - 10) determine the order of styles used when you add new measurements to
a graph. For example, the first measurement added to a graph uses the default style 1, the second
measurement added uses default style 2, and so on. If you delete a measurement, the next
measurement you add uses the style previously assigned to the deleted measurement. (In a graph
with five measurements, if you delete number 3 and then add another measurement, the new
measurement uses the style previously assigned to measurement 3-- it does not use style number
6, nor do existing measurements change their original style numbers.)

Symbol

Specify the format and presence of symbols for the traces in a graph. Specify an interval at
which to place symbols. Specify the size of the symbol in Size.

Measurement

Displays the measurement associated with the trace selected in the Style section.
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Graph Options Dialog Box: Traces Tab
Field

Description

Trace

Show text: For histogram data only. Turns trace value text annotations on or off.
Show direction: For Smith Charts and polar grids only. Specify whether the arrows that indicate

the direction of increasing frequency are displayed.
Stepped Color: Specifies how trace color is selected for each sweep. None is the default, with no
color applied; Stepped generates different colors for each trace from a single measurement;
Gradient generates a rainbow of colors over all the traces for the measurement; Gradient Red,
Gradient Green, and Gradient Blue generate a smaller range of spectrum of the rainbow, starting
from the named color; Shaded generates a range of shaded colors, using the normal trace color
that is specified as the base color. This option makes it easier to differentiate multiple
measurements that have multiple traces. NOTE: Load pull contours use stepped colors slightly
differently than other measurements.
Type: Choose from the following trace styles:
Auto: The trace style is chosen automatically based on both the graph type and the measurement
type. This is usually linear, except for certain special combinations of measurements and graph
types. Spectral measurements displayed on rectangular graphs default to Spectral. Measurements
displayed on constellation graphs default to Scatter.
Scatter: The selected trace displays as a sequence of unconnected dots.
Spectral: For rectangular graphs, this trace style displays a vertical line segment for each data
point. Each line segment extends from the x-axis to the measurement data point.
Histogram: For rectangular graphs, data displays as a bar chart. This option is typically used for
YSens component sensitivity measurements.
Digital: For rectangular graphs, data displays as a piecewise-constant "staircase" waveform.
Sampled: Similar to Spectral, except the vertical line at each x-axis value extends from y = 0 to
the y value of the data. This allows for line segments pointing either upward or downward,
similar to how sampled data is illustrated in digital signal processing literature.
Save as Defaults

Saves all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Sets the properties of the current graph (all tabs except Traces) to the default properties for
graphs of this type.
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Graph Options Dialog Box: Format Tab

Graph Options Dialog Box: Format Tab

The Graph Options dialog box Format tab (available for rectangular graphs, histograms, antenna plots, polar grids, and
Smith Charts) allows you to specify options related to the general appearance of the grid border and grid divisions for
this graph. To access this tab, right-click in a graph window and choose Options. This dialog box contains the following
options.
Field

Description

Line Style

Select the line style used to draw the grid divisions for this graph. For Smith Charts, you specify
the line style for the impedance and admittance grids. For antenna plots, you specify the
magnitude and angle divisions.

Divisions

Specify the color of the grid divisions and subdivisions. For Smith Charts, you specify the color
of the impedance and admittance grids. Specify the thickness of the line used to draw the grid
divisions in Weight.

Border

Specify the color of the grid border in Color. Specify the thickness of the line that draws the
grid border in Weight. Select the Shadow check box to display a 3D shadow on the border of the
graph and legend.

Visible

Select the appropriate check boxes to specify which features of the graph are visible:
Border: A border around the graph.
Legend: A legend box.
Legend Border: A border around the legend.
Tick-Marks: Small tick lines on the axis at divisions. (Not available for antenna plots.) Sweep
min/max: Minimum and maximum sweep values on polar grids or histograms.
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Graph Options Dialog Box: Format Tab
Field

Description

Trace Color Styles

Select a style for individual trace types:
Frozen: Select the style for any frozen traces.
Data Set: Select the style for data from a data set on the graph.
Yield: Select the style for the individual yield runs.
Yield Range: Select the style for any traces that aggregate the yield data (for example, range,
median, or standard deviation).

Save as Defaults

Saves all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Sets the properties of the current graph (all tabs except Traces) to the default properties for
graphs of this type.
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Graph Options Dialog Box: Labels Tab

Graph Options Dialog Box: Labels Tab

The Graph Options dialog box Labels tab (available for rectangular graphs, constellation plots, antenna plots, polar grids,
and Smith Charts) allows you to specify labels and titles for a graph, as well as the type of information included in the
graph legend. Depending on the graph type, some of these options may not display. To access this tab, right-click in a
graph window and choose Options. This dialog box contains the following options:
Field

Description

Choose Axis

Select the axis for which you want to set properties.

Graph Title

Enter a title for the graph if you want the title to differ from the graph name displayed in the
Project Browser. You must clear the Default Title check box to access this option.

Selected Axis Label

Enter a label for the selected axis if you want it to differ from the default label. You must clear
the Auto Label check box to access this option. Select the Show Units check box to display the
unit identifier (for example, GHz) after the label. This option is not available for some graphs.

Legend Entries

Specify which entries you want to display in the graph legend:
Data Name: Include the data name in the legend.
Measurement Name: Include the measurement name in the legend.
Both: Include both the data name and the measurement name in the legend.

Legend Frame

Select a legend frame resizing option:
Resize frame to fit text: Resizes the legend frame to fit the legend entries.
Resize text to fit frame: Resizes the legend entry text to fit the frame size.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Graph Default Options Dialog Box: Labels Tab

Graph Default Options Dialog Box: Labels Tab

The Graph Default Options dialog box Labels tab (available for rectangular graphs, constellation plots, histograms,
antenna plots, polar grids, and Smith Charts) allows you to specify labels and titles for this graph, as well as the type of
information included in the graph legend. To access this tab, choose Options > Default Graph Options and choose a graph
type. This dialog box contains the following options:
Field

Description

Title

Enter a title for the graph if you want the title to differ from the name of the graph displayed in
the Project Browser. You must clear the Default Title check box to access this option.

X-axis

Enter a label for the X-axis if you want it to differ from the default label. You must clear the
Auto label check box to access this option. Select the Show Units check box to display the unit
identifier (for example, GHz) after the label. These options are not available for some graphs.

Left side / Right side

Enter a label for the left and right y-axis. This option is not available for some graphs.

Legend Entries

Select an option to specify which entries you want to display in the graph legend:
Data name: Include the data name in the legend.
Measurement name: Include the measurement name in the legend.
Both: Include both the data name and the measurement name in the legend.

Legend Frame

Select a legend frame resizing option:
Resize frame to fit text: Resizes the legend frame to fit the legend entries.
Resize text to fit frame: Resizes the legend entry text to fit the frame size.
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Graph Options Dialog Box: Fonts Tab

Graph Options Dialog Box: Fonts Tab

The Graph Options dialog box Fonts tab (available for rectangular graphs, histograms, antenna plots, polar grids, Smith
Charts, and 3D plots) allows you to specify options for the fonts used to label and title a graph, as well as the type of
information included in the graph legend. To access this tab, right-click in a graph window and choose Options. This
dialog box contains the following options:
Field

Description

Title

Click this button to specify the font type, size, style, and color for the graph title.

Labels

Click this button to specify the font type, size, style, and color for the x-axis and y-axis labels
of the graph.

Axis Numbers

Click this button to specify the font type, size, style, and color for the numbers on the axis of
the graph.

Legend

Click this button to specify the font type, size, style, and color for the graph legend.

Markers

Click this button to specify the font type, size, style, and color for the graph markers.

Save as Defaults

Save the current graph options as defaults for all graphs of this type.

Reset to Defaults

Set the properties of the current graph to the default properties for graphs of this type.
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Graph Options Dialog Box: Measurements Tab

Graph Options Dialog Box: Measurements Tab

The Graph Options dialog box Measurements tab (available for rectangular and constellation graphs, histograms, antenna
plots, polar grids, and Smith Charts) allows you to specify options related to how measurement entries are formatted in
the graph legend. For usage examples of options in this dialog box, see “Measurement Axis”. To access this tab, right-click
in a graph window and choose Options. This dialog box contains the following options:
Field

Description

Select measurement to Select the measurement (from the list of measurements added to this graph) to which the options
edit
specified in this dialog box apply. Measurements that begin with "All Sources" are template
measurements. Template measurements represent one or more actual measurements (one for
each data file). When you set options for a template measurement, the settings apply to each
measurement created from the template.
AutoStack

For rectangular, histogram, and constellation graphs only. Click to add one axis for each
measurement and automatically assign each measurement to a unique axis.

Choose axis

For rectangular, histogram, and constellation graphs only. Select Left and/or Right to specify to
which axis the measurement is associated. The trace for the selected measurement is plotted
using the data value shown on that side of the grid. An (L) or (R) identifier displays after the
measurement name in the legend.

Meas. Templates

Select the appropriate option to specify how measurements created from a measurement template
should display in the legend:
All in legend: Every measurement created from the measurement template appears as an entry
in the legend. In this case, the default data name is used to identify different entries.
One in legend: A single legend entry represents all the measurements created from the template.

Legend Data Name

The name of the measurement data to display in the legend. The default value is the name of
the data file associated with this measurement. To specify a different name, clear the Use Default
check box and type a name in the text box.
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Field

Description

Legend Meas. Name

The name of the measurement to display in the legend. The default value is the measurement
type (for example, |S11|). To specify a different name, clear the Use Default check box and type
a name in the text box.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Graph Options Dialog Box: Markers Tab

The Graph Options dialog box Markers tab (available for rectangular graphs, histograms, antenna plots, polar grids, and
Smith Charts) allows you to specify how markers display on a graph. For usage examples of options in this dialog box,
see “Modifying Number of Digits in Cursor and Marker Display”. To access this tab, right-click in a graph window and
choose Options. This dialog box contains the following options:
Field

Description

Param markers enabled Display parameter markers and data set markers on the graph.
Show sweep val.

Display frequency (the x-axis information) for a given data point in the marker display window.

Transparent
background

For polar grids only. Make the marker display window transparent.

Param markers in
legend

Display parameter and data set marker information in the graph legend.

Draw connector

Display a connector between the marker on the trace and the marker display window.

Labels tied to markers Associate the movement of the markers with the movement of the marker display window.
Data markers in legend Display measurement data information in the graph legend.
Match text color to
trace

Matches the color of the text in the marker legend or marker label to the associated trace Color.

Names in labels

Displays the marker number in the label.

Ref marker all traces

Use a reference marker as the reference for all traces, not just individual traces. Only one
reference marker is allowed per graph; all others display Delta from the reference. If not selected
there is one reference per trace.

Color

Specify the color of the marker symbol, the line, and the outline of the marker display window.

Symbol

Specify which symbol to use for the marker on the graph trace.
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Field

Description

Weight

Specify the trace line thickness.

Size

Specify the size of the marker on the trace. NOTE: To specify the size of the marker in the
display window, click Markers on the Fonts tab.

Display Format

For polar grids and Smith Charts only. Specify the format of data displayed by the markers.
Choose Real/Imaginary, Magnitude/Angle, or dB Magnitude/Angle.

Z or Y display

Specify whether the impedance or admittance of the marker display is normalized or denormalized
to the reference impedance. Enter the reference impedance.

Display Type

For Smith Charts only. Specify the type of data the markers display. Choose Reflection Coefficient,
Impedance, or Admittance.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Add/Edit Auto-Search Marker Dialog Box

The Add/Edit Auto-Search Marker dialog box allows you to add or edit a special type of marker onto the selected trace.
To access this dialog box, right-click in a rectangular graph window and choose Add Auto-Search Marker or click the Add
Auto-Search Marker button on the Graphs toolbar. To edit existing auto-search markers right-click and choose Edit
Auto-Search Marker. This dialog box contains the following options:
Field

Description

Search Type

Searches the measurement trace for the selected feature:
Max: The marker searches for the maximum y value.
Min: The marker searches for the minimum y value.
Peak: The marker searches for the nearest relative maximum that is substantial enough to satisfy
the aperture size requirements.
Valley: The marker searches for the nearest relative minimum that is substantial enough to satisfy
the aperture size requirements.
Value: The marker searches for the specified y value.
X Index: The marker goes to the point with the specified x index. A value of 1 corresponds to
the leftmost point on the trace.

Aperture Size

To prevent the marker from locking onto a minimum or maximum that exists strictly due to
numerical noise in the data, you can specify the minimum size for legitimate peaks and valleys.
An aperture is used to filter out the smaller features, with the size of the aperture determined
by the Width and Height settings. Width is specified as a percentage of the number of x points
for the trace. Height is specified as a percentage of the distance between the trace's maximum
and minimum y values.
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Graph Options Dialog Box: Numeric Tab

The Graph Options dialog box Numeric tab (available for antenna plots, polar and rectangular grids, histograms,
constellation graphs, and Smith Charts) allows you to specify the numeric formatting style and precision for data markers
and cursors. For usage examples of options in this dialog box, see “Modifying Number of Digits in Cursor and Marker
Display”. To access this tab, right-click in a graph window and choose Options. This dialog box contains the following
options:
Field

Description

Marker/Cursor Sweep Specify the format and precision of sweep value data (for example, time, frequency, or voltage)
Value Format
displayed by the graph markers or cursor:
Fixed significant digits: Specify the number of significant digits displayed. The default is floating
point numbers, however very large or very small numbers display in scientific notation.
Fixed digits right of decimal: Specify the number of digits to the right of the decimal point (fixed
point notation). The number of significant digits that display depends on the size of the numbers.
Scientific notation: Specify use of scientific notation. The Precision value specifies the number
of digits to the right of the decimal point in the mantissa of the displayed data.
Select Automatic to specify that the precision is automatically determined by the range and
absolute value of data. Small changes in value caused by small (single pixel) cursor or marker
movements are resolved.
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Graph Options Dialog Box: Numeric Tab
Field

Description

Marker/Cursor Data
Value Format

Specify the format and precision of the data value displayed by the graph markers or cursor:
Fixed significant digits: Specify the number of significant digits displayed. The default is floating
point numbers, however very large or very small numbers display in scientific notation.
Fixed digits right of decimal: Specify the number of digits to the right of the decimal point (fixed
point notation). The number of significant digits that display depends on the size of the numbers.
Scientific notation: Specify use of scientific notation. The Precision value specifies the number
of digits to the right of the decimal point in the mantissa of the displayed data.
Select Automatic to specify that the precision is automatically determined by the range and
absolute value of data. Small changes in value caused by small (single pixel) cursor or marker
movements are resolved.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Graph Options Dialog Box: Yield Data Tab

The Graph Options dialog box Yield Data tab (available for rectangular graphs and histograms) allows you to specify
options related to how the traces for each trial are displayed for this graph. To access this tab, right-click in a graph
window and choose Options. This dialog box contains the following options:
Field

Description

Show traces

Display traces for this graph. Select which traces display:
All Traces: Display all trials.
Passed: Display passed trials.
Failed: Display failed trials.
Mean: Display the mean value of the traces.

Show Range

Display a whole range of values. Select the range to display:
Max/Min: Display the maximum and minimum values of the total range.
Envelope: Display the computed range of values.
Range Bars: Display bars centered around a trace.

Show Sigma (Standard Display the standard deviation of values. Select the range to display:
Deviation)
Max/Min: Display the maximum and minimum values of the standard deviation.
Envelope: Display the computed range of values.
Range Bars: Display bars centered around a trace.
Show Sigma*2

Display two standard deviations of values. Select the range to display:
Max/Min: Display the maximum and minimum values of two standard deviations.
Envelope: Display the computed range of values.
Range Bars: Display bars centered around a trace.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Antenna/Polar Plot Options Dialog Box: Grid Tab

The Antenna/Polar Plot Options dialog box Grid tab (available for antenna plots and polar grids) allows you to specify
options related to how grids are displayed for these graphs. To access this tab, right-click in a graph window and choose
Options. This dialog box contains the following options:
Field

Description

Magnitude Limit

Sets the magnitude limit to display.

Magnitude Divs.

Sets the grid for the magnitude circles.

Angle Divisions

Sets the grid for the polarization angle.

Sweep Value Limits

Limits the frequency range in which to display the graph data.

Save as Defaults

Saves all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Sets the properties of the current graph (all tabs except Traces) to the default properties for
graphs of this type.

Dialog Box Reference8–27

Smith Chart Options Dialog Box: Grid Tab

Smith Chart Options Dialog Box: Grid Tab

The Smith Chart Options dialog box Grid tab allows you to specify options related to how grids are displayed for this
graph. To access this tab, right-click in a graph window and choose Options. This dialog box contains the following
options:
Field

Description

Sweep Value Limits

Limits the frequency range in which to display the graph data.

Visible

Specify which contour lines display on the graph (Impedance or Admittance), as well as whether
the values (numerical labels) for each contour line display.

Size

Specify the size of the graph with Auto Size to determine limits automatically from the data
being plotted, or click the arrows in Size to choose one of the following options:
Normal: Size of graph is bound by a reflection coefficient of 1; this graph size is typically used
for matching and passive structures.
Compressed: Displays reflection coefficients greater than 1; this size is typically used for stability
and gain analysis.
Expanded: Displays a close-up view of the center of a normal Smith Chart.

Contour Lines

Specify the density of the contour lines of the graph with Auto contour to specify that the number
of contour lines is selected automatically, or click the arrows in Contour density to choose one
of the following options: Coarse, Normal, or Fine.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Graph Options Dialog Box: Units Tab

The Graph Options dialog box Units tab allows you to specify the .lpf file from which unit values are derived. To access
this tab, right-click in a graph window and choose Options. This dialog box contains the following options:
Field

Description

Units from

Select the .lpf file from which the unit values are derived.

Units values

(Read only) Displays the unit values specified in the selected .lpf file.
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3D Plot Options Dialog Box: Axes Tab

The 3D Plot Options dialog box Axes tab allows you to specify options related to the data limits, text, and color of the
axes of 3D graphs. To access this tab, right-click in a 3D graph window and choose Options. This dialog box contains
the following options:
Field

Description

Choose Axis

Select the axis for which you want to set properties.

Divisions

Specify whether the numeric values of axis divisions are shown using Show values. Auto divs
automatically computes the number of divisions on the chosen axis. Div count manually
determines the number of divisions on the chosen axis when Auto divs is not selected.

Limits

Select the Auto limits check box to automatically compute the minimum and maximum values
of the chosen axis. Specify Min and Max values for the chosen axis manually when Auto limits
is not selected.

Graph title

When the Default title check box is selected, the graph title is the same as the graph name in the
Project Browser. When the Default title check box is cleared, you can enter the desired graph
title.

Axis label

When the Auto label check box is selected, a default label is generated. When the Auto label
check box is cleared, you can enter the desired label. Show units includes the units of the
measurement on the chosen axis label.

Axis color

Specify the color of the chosen axis. For best graph legibility, each axis should have a unique
color.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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3D Plot Options Dialog Box: Surface Tab

3D Plot Options Dialog Box: Surface Tab

The 3D Plot Options dialog box Surface tab allows you to specify options related to the appearance of surfaces displayed
on 3D graphs. To access this tab, right-click in a 3D graph window and choose Options. This dialog box contains the
following options:
Field

Description

Measurement

Determines which measurement is modified by the following options.

Surface elements

Surface renders the graph as a surface plot.
Lines shows lines on the plot. If the Surface check box is selected, Lines adds lines to the surface.
If the Surface check box is cleared, Lines allows a wire frame chart to be created.
Points renders each data point on the chart as a dot. You can use Points in combination with
Surface and Lines to achieve a variety of visual effects.

Surface properties

To choose the surface color of the selected measurement, click Color to open the Choose Surface
Color dialog box. Set the Opacity to determine the extent to which the viewer can see through
the surface of the selected measurement. An opacity of 100 percent is a purely opaque surface,
while an opacity of 0 percent is a purely transparent surface. Opacity is useful when there is
more than one surface in the plot, for preventing one surface from obscuring another.
Fill polygons fills with the selected color the polygons that form the surface.
Smooth shading and Smooth lighting are used with the lighting feature. Clearing either of these
check boxes makes the surface more faceted in appearance when lighting is used. Selecting
them gives the surface a smooth, rounded appearance in the presence of lighting.

Line color

When the Lines check box is selected in Surface elements, determines the color of the lines on
the surface or wire frame.

Point color

When the Points check box is selected in Surface elements, determines the color of the dots on
the surface or wire frame.

Point size

When the Points check box is selected in Surface elements, determines the size of the dots in
pixels.
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3D Plot Options Dialog Box: Surface Tab
Field

Description

Line width

When the Lines check box is selected in Surface Elements, determines the thickness of the lines
in pixels.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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3D Plot Options Dialog Box: Lighting Tab

The 3D Plot Options dialog box Lighting tab allows you to improve the appearance of a 3D graph by giving the illusion
that surfaces on the plot are illuminated by a light source. This can make details of a surface, such as dips and bumps,
easy to see. Best results are achieved by varying the settings of a 3D graph whose surface has already been displayed.
Experiment with each setting individually, then click Apply to view its effects on the surface's appearance. To access this
tab, right-click in a 3D graph window and choose Options. This dialog box contains the following options:
Field

Description

Enable Lighting

Activates the simulated light source that illuminates the surfaces of a 3D graph. Various
parameters of the simulated light source, specified in the following options, can be adjusted to
highlight the desired surface features.

Lighting

Adjust the Ambient slider to control the intensity of ambient light. Ambient light is light that is
scattered so much that it is impossible to determine its direction. Adjust the Diffuse slider to
control the diffuse component of the light. The diffuse component is light that comes from one
direction, but reflects equally in all directions after it hits a surface. Adjust the Specular slider
to control the specular component of the light. The specular component is light that comes from
one direction, and reflects in a single direction after it hits a surface.

Light Coordinates

The X, Y and Z sliders control the (x, y, z) coordinate of the simulated light source. A normalized
coordinate system is used, independent of the graph's data values. The normalized x, y, and z
components each range from 0 to 100. This allows for illumination to be concentrated on the
specific area of the surface that you want to highlight.

Material

These sliders control various aspects of the reflection of light from a 3D graph's surface. Ambient
reflection has uniform intensity over a surface. Diffuse reflection is reflection that is most intense
where the light hits a surface, and less intense further away. Specular reflection depends on the
viewer's location relative to the light source, unlike diffuse and ambient reflection. Reducing
the Shininess setting gives a duller appearance to the surface, while increasing it makes the
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3D Plot Options Dialog Box: Lighting Tab
Field

Description
surface more glossy. Increasing the Emission slider value from zero makes the surface appear
to be giving off light.

Save as Defaults

Save all current graph options (all tabs) as defaults for graphs of this type.

Reset to Defaults

Set the properties of the current graph (all tabs except Traces) to the default properties for graphs
of this type.
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Tuning, Optimizing, and Yield Analysis
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Optimizer Dialog Box

The Optimizer dialog box allows you to specify the optimization method to employ, as well as other options related to
optimization. To access this dialog box, choose Simulate > Optimize. This dialog box contains the following options:
Field

Description

Optimization Methods Select the desired optimization method. Optimization methods are described in “Optimization
Methods”. The optimizer terminates after Maximum Iterations.
Swap Control (0-2)

Swap control influences how the optimizer picks parts to swap with. If the parameter is set to
0, the optimizer only tries to swap parts between two lineups that are both failing (for example,
with a cost greater than zero). If the value is 1, then approximately half the time, one of the
lineups in the swap is failing. The larger the value, the more likely the swap occurs between
any two randomly chosen lineups, and not just failing lineups. The default value of 1 is normally
sufficient.

Relative Goal Cost

Bars in this graph depict the relative contribution of each optimization goal in the project to the
overall cost. The order of the goals displayed in the Project Browser determines the order of the
goals in this graph.

Equalize Goals

Adjusts the weight of all non-zero cost goals to equalize the cost of all goals. The total cost is
held constant.

Cost History

A small plot of the cost function as a function of the iteration number. This graph automatically
"wraps" and scales as the iteration progresses. See Cost for more information.

Show all iterations

Select this check box to have the graph display every solution that is tried (in contrast to only
displaying the solution for points that are an improvement). The display of all iterations can be
useful for gaining insight into some of the optimizers (in particular, when used with the genetic
algorithm it will give some feedback to the user on the convergence of the population used by
the genetic algorithms).
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Optimizer Dialog Box
Field

Description

Stop at minimum error Under normal operation, the optimizer stops when it is unable to improve the solution by any
significant amount. Sometimes it is desirable to let the optimizer continue running even when
no improvement can be found. This is useful for running the optimization and tuning at the same
time (you should not tune the same variables that you are optimizing though) and it is also useful
if you are changing the goals by dragging them in the graph view while the optimizer is running.
In this case, if you move a goal, it resets the minimum cost and continues optimizing. This
allows the optimizers to "track" changes to the optimizer goals without needing to stop and
restart the optimizers.
Stop on simulation
errors

Stops the simulation when an error is detected, otherwise optimization continues and ignores
errors.

Cancel current iteration Cancels the current iteration when it stops due to a simulation error, otherwise optimization
on stop request
continues.
Log to file

Writes optimization and variable information to a JSON formatted log file. See “Optimization
Log” for more information.

Optimizer Iter.

Displays the number of iterations for the optimizer. Some optimization methods, for example
gradient, require multiple simulations for each iteration of the optimizer.

Cost

The value used to measure convergence. The cost is a measure of the closeness to the minimum:
as the optimizer approaches a minimum of the error function, this value approaches zero.

Start

Starts the optimization.

Stop

Stops the optimization at the end of its current iteration.

Reset

Resets all of the optimization variable values to the values set when this dialog box was opened.
When the dialog box closes, the optimization variables are assigned the values determined by
any optimization that is performed and it is not possible to reset the variable values to their
original state.

Save

Allows a "state" of the optimization to be saved in a list of states that can be reverted to while
this dialog box is open. By clicking this button, the simulator prompts for a name to use to
identify the state. The Revert button resets the optimization variables to any intermediate point.
When this dialog box is closed, the optimization variables are assigned the values currently set
by the optimizer and you cannot reset the variable values to their original state.

Revert

This button allows a "state" of the optimization to be retrieved once you click the Save button.
By reverting, you can reset the optimization variables to any intermediate point by selecting the
name of the saved state from the menu that displays. When you close this dialog box, the
optimization variables are assigned the values currently set by the optimizer and you cannot
reset the variable values to their original state.

Status

This button displays the Simulation window.

Round

This button displays the Round Optimization Variables dialog box to allow you to specify the
number of significant digits to round to, as well as options for rounding to variable step values
when defined, and updating the simulation.

Vars

Displays the Variables window with a list of all variables in the current project, or variables per
filtered criteria. See “Variable Browser” for more information.

Goals tab

Displays the Goals window with a list of all goals in the current project. See “Setting Optimization
Goals” for more information.

Variable History tab

Displays the Variables History window. See “Optimization” for more information.

Goal History tab

Displays the Goal History window. See “Setting Optimization Goals” for more information.
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Variables Window

The Variables window (Variable Browser) displays the current value of variables and element parameters for schematic
elements in the active project. To access this window, choose View > Variable Browser, or click the Variable Browser button
on the toolbar. Using the column headers, you can sort columns in ascending or descending order by clicking (toggling),
move columns by dragging and dropping them, and change column widths to fit text by moving column sides or clicking
the adjust column width button on the Variable Browser toolbar. You can view yield related columns by clicking the
Show or hide yield-related columns button on the Variable Browser toolbar. The Variable Browser also supports filtering
via regular expressions, multi-select, linking to source documents and variable tagging. For details on using the Variable
Browser, see “Variable Browser”. This window contains the following options:
Field

Description

Document

The document name in the specified schematic.

Element

The element name in the specified schematic.

ID

The ID of the specified element. This is the name of the schematic prefaced by an "@" symbol.

Parameter

The parameter of the specified element.

Value

The value of the element parameter or variable. If the value of a variable is beyond or equal to
one of the constraints (Lower or Upper), then the constraint is highlighted in red. If the value is
inside of the constraint range but is close to a constraint (within 5% of the difference between
the limits), the constraint is highlighted in yellow.

Tune

Select this check box to set up the variable for tuning.

Optimize

Select this check box to set up the variable for optimization.

Constrain

Select this check box to set up the variable for constraints.

Lower

Defines the lower limit for the parameter during tuning and optimization.

Upper

Defines the upper limit for the parameter during tuning and optimization.
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Variables Window
Field

Description

Step Size

Defines the step size for tuning and discrete optimization.

Use Statistics
(Yield-related)

Assigns the parameter random values based on the other settings during a yield analysis or a
yield optimization. If this check box is cleared, the statistical properties are ignored during a
yield analysis or a yield optimization.

Yield Optimize
(Yield-related)

Allows modification of the nominal value of the parameter during a yield optimization. If the
parameter value is also constrained, then the yield optimizer uses these constraints to ensure
that the nominal value is not changed to an unacceptable value.

Tolerance
(Yield-related)

Specifies the amount to vary the parameter. You can enter this value as a percentage by including
a percent "%" sign, otherwise the default is project units.

Distribution
(Yield-related)

Allows you to specify different statistical distributions. You can specify variation using the
Tolerance and Tolerance2 columns. Tolerance2 is only available for those distributions that need
a second statistical parameter.

Tolerance2
(Yield-related)

Only available for distributions that require a second statistical parameter.

Tag

A descriptive tag for the variable. Tags can be used for grouping variables in the Variables
window.

When you click the All tab, buttons control whether to display element parameters and equations, equations only, or
element parameters only. If element parameters are displayed, two additional buttons control whether all element
parameters or only the ID parameter display, and whether to display secondary parameters.
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Yield Analysis Dialog Box

The Yield Analysis dialog box allows you to specify the analysis method to employ. To access this dialog box, choose
Simulate > Yield Analysis. The options that display depend on the specified analysis method. (Not pictured are the three
Parallel analysis options.) This dialog box contains some or all of the following options:
Field

Description

Yield Methods

Select the desired optimization method. The available optimization methods are described in
“Yield Analysis”.

Maximum Iterations

The yield analysis terminates after this number of iterations. For some analyses this value is
grayed out. For yield optimization, this is the number of optimization iterations.

Dampening

Determines the size of the corrections that are used for each iteration of the yield optimization
algorithm.

Maximum Error

Determines the number of iterations to run before changing parameter nominal values during
yield optimization.

Scale Relative to
Sigma

For Corners Analysis, any values using a normal distribution use this number of standard
deviations away from the nominal for the analysis.

Number Processes

Displays for Asynchronous analysis methods only.

Data file name

For User Defined corner analysis, specifies the values for each variable
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Field

Description

Number of Parallel
Jobs

For Parallel analysis modes, specify the number of Cadence® AWR Design Environment®
server processes you want to run the yield analysis.

Show all trace updates Clear this check box to disable graph updates with the yield trace during each yield analysis
iteration. All of the yield traces display when the analysis is complete. The analysis is faster
without updating traces each iteration.
Stop on simulation
error

Allows yield analysis to continue past any simulation errors that might occur when changing
model parameters.

Simulate nominal when If there are simulation errors, when you turn off this option, the Status Window displays the
finished
errors to help you identify which models are problematic.
Create data set for yield Creates a yield data set to store all the data created during the yield analysis for reuse. See “Yield
analysis
Data Sets” for details on using yield data sets.
Iter.

While yield analysis is running, this number updates with the current yield iteration being run.

Yield

While yield analysis is running, this number updates with the current yield percentage, with a
+- of the estimated error.

Start

Start the yield analysis.

Continue

Continue the yield analysis.

Stop

Stop the yield analysis at the end of its current iteration.

Clear

Clear yield traces from all graphs.

Status

Open the Simulation status dialog box to view details of the currently running simulation.
Typically, you use this for longer simulations (nonlinear or EM) where you want to watch the
status of each iteration. For fast simulations, opening the Simulation status dialog box slows
down the yield analysis process.

Close

Close the Simulation Window.

See the following sections for details on each of the analysis types:
• “Yield Analysis”
• “Yield Optimization”
• “Corners Analysis”
• “User Defined Corners (Design of Experiments)”
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New/Modify Optimization Goal Dialog Box

The New/Modify Optimization Goal dialog box allows you to specify a new optimization goal. To access this dialog
box, choose Project > Add Opt Goal, or right-click an optimization goal under Optimizer Goals in the Project Browser and
choose Add Opt Goal or Edit Goal Properties, or right-click Optimizer Goals in the Project Browser and choose Add Opt
Goal. This dialog box contains the following options:
Field

Description

Measurement

Select a measurement for the goal to use from the list of current measurements.

New/Edit Measurement Create a new measurement. Brings up the Measurement Edit dialog.
Goal Type

Meas > Goal:
Meas < Goal:
Meas = Goal:

Range

The range of sweep values for the goal. For most measurements the sweep variable is frequency.
The start value must be less than the stop value. The start value can be set to the minimum
possible sweep value. The stop value can be set to the maximum possible sweep value. You
can also define the Start and Stop values by right-clicking a measurement on a rectangular graph
legend and choosing Add Optimization Goal, then clicking and dragging the cursor on the graph.

Goal

The target value for the goal's cost function.

Weight

Weight factor for the goal's cost function.

L

L factor for the goal's cost function. If L < 0, then returns max error.

Use Default L

Sets L to a default value of 2.

Sloped

Allows different goal values for the start and stop points.

Enable Goal

Allows optimization to be turned on and off for the goal.

9–8 AWR Design Environment

Constrains the measurement to be greater than the goal value.
Constrains the measurement to be less than the goal value.
Constrains the measurement to be equal to the goal value.

New/Modify Yield Goal Dialog Box

New/Modify Yield Goal Dialog Box

The New/Modify Yield Goal dialog box allows you to specify a new Yield goal. To access this dialog box, choose Project
> Add Yield Goal, or right-click a yield goal under Yield Goals in the Project Browser and choose Add Yield Goal or Edit
Goal Properties, or right-click Yield Goals and choose Add Yield Goal. This dialog box contains the following options:
Field

Description

Measurement

Select a measurement for the goal to use from the list of current measurements.

New/Edit Measurement Create a new measurement. Brings up the Measurement Edit dialog.
Goal Type

Meas > Goal:
Meas < Goal:

Constrains the measurement to be greater than the goal value.
Constrains the measurement to be less than the goal value.

Range

The range of sweep values for the goal. For most measurements the sweep variable is frequency.
The start value must be less than the stop value. The start value can be set to the minimum
possible sweep value. The stop value can be set to the maximum possible sweep value. You
can also define the Start and Stop values by right-clicking a measurement on a rectangular graph
legend and choosing Add Yield Goal, then clicking and dragging the cursor on the graph.

Goal

The target value for the goal's cost function.

Enable Goal

Allows optimization to be turned on and off for the goal.
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Tuner Dialog Box

To access this dialog box, choose Simulate > Tune. This dialog box contains the following options:
Field

Description

Document

The name of the document where the element/equation is placed. Useful for filtering/sorting.

Element

The type name of the element associated with the parameter. For variables, the name is 'EQN'.
You can click on these names to navigate to the element/equation.

ID

The ID of the element associated with the parameter. Blank for variables.

Parameter

The name of the parameter or variable.

Tune

Clear the checkmark to remove this parameter from the tuner.

Step Size

Step size while tuning. For continuous variables, the default value used rounds a number to give
on the order of magnitude of 100 tune points. The maximum value allowed is max-min. The
minimum value allowed is (max-min)/1001. For discrete variables, the default value and minimum
value is 1 and the maximum value allowed is max-min. Auto-calculated (default) values are
drawn in light blue.

Lower

Lower limit for constrained tuning. If no user-specified value exists, the value is auto-calculated
as one half the nominal value. Auto-calculated values are drawn in light blue.

Tuner

Slide the tuning bar left and right to observe the simulation change on the graph. This control
responds to these hotkeys: Left/Right arrow, Page Up, Page Down, Home, and End.

Upper

Upper limit for constrained tuning. If no user-specified upper limit exists, the value is
auto-calculated as twice the nominal value. Auto-calculated values are drawn in light blue.

Value

The nominal value of the parameter/variable.

Tag

Enter a name/label. Useful for filtering/sorting.

Analyze

Simulate the active project.

Save

Save the current state of the tuner.

Restore

Reset the tuner to initial values.

Freeze

Freeze traces.

Clear

Clear the frozen traces.

See “Tuning” for more information on using the tuner.
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Layout
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Options - Drawing Layer 2D Properties Dialog Box

The Options - Drawing Layer 2D Properties dialog box allows you to specify options about how 2D layers are drawn.
To access this tab, choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under Layer
Setup and choose Properties. See “Using Property Grids” for information on manipulating the data in this dialog box.
This dialog box contains the following options:
Field

Description

Layer

Drawing layer number.

Name

Drawing layer name. Click this field and type a new name.

System

Identifies system-level properties.

Visible

Toggle on/off layer visibility. When this option is cleared, shapes on this layer are not visible
or selectable in layout.

Cloak

Hide/show the layer name in the Drawing Layers pane. When this option is selected, the layer
name is hidden in the Drawing Layers pane.

Line

Click to choose a shape outline color and line pattern from the drop-down menu.

Fill

Click to choose a shape fill color and hatch pattern from the drop-down menu. The Cadence®
AWR Design Environment® program includes some predefined hatch patterns, or you can
define you own custom hatch pattern. See “User Defined Drawing Layer Fill Patterns” for
details.

Show Fill

Toggle on/off polygon fill.

Freeze

Toggle on/off freeze for layer. Shapes not associated with schematic items cannot be selected
if on a frozen layer.

Opaque

If selected, the layer is not transparent in the 2D view.
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Options - Drawing Layer 2D Properties Dialog Box
Field

Description

Blend

If Opaque is not selected, type a number between 0 and 1 to specify a blend of transparent and
opaque, where 0 is completely transparent and 1 is completely opaque.

Description

Click this field to type a text description.

New Layer

Add a new layer to the drawing layers directly after the currently selected layer.

Delete

Delete the selected layer from the drawing layers.

Up/Down Arrows

Move the selected layer up or down in the drawing layer list. Shapes draw in order from the
bottom of the list to the top.

Configurations

Save or remove named configurations. Type a name for the current configuration. Named
configurations allow you to save setting groups for use with layout modes to easily swap different
configurations. See “Layout Editor Mode Settings Dialog Box ” for more information on layout
modes.

Select/Clear All

Click the check mark in the Show Fill, Freeze, or Opaque column header to toggle selecting or
clearing all layers in that column.

Sync line & fill edits

For future implementation.

Preview

Preview your current selections for any open layout window.
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Options - Model Layer Mappings Dialog Box

The Options - Model Layer Mappings dialog box allows you to specify options that control the mapping between the
model layers of a cell and the drawing layers that are displayed in the 2D and 3D layout windows (this mapping can then
be saved to an .lpf file). To access this dialog box, choose Options > Drawing Layers, or in the Layout Manager, right-click
a project LPF file under Layer Setup and choose Properties. This dialog box contains the following options:
Field

Description

Model Layer

The layer names that artwork cells and parameterized layout cells use within the library (GDSII
format uses numbered layers, whereas DXF format can use named layers) and the parameterized
cells, and brought into the Cadence Microwave Office® software.

Drawing Layer

The layers used to display and export layouts in the Microwave Office program. Model layers
are viewed in the Microwave Office program by mapping them to these drawing layers. Multiple
model layers can be mapped to the same drawing layer.

New Layer

Create a new layer.

Delete

Delete the selected layer.

Up/Down Arrows

Moves the selected layer up or down in the drawing layer list. Shapes draw in order from the
bottom of the list to the top.

Preview

Preview your current selections for any open layout window.

Projects can have more than one model layer mapping. To add a new model layer mapping, right-click on any folder in
the left pane of this dialog box and choose New Model Layer Mapping.
With any of the model layer maps selected, right-click to rename and delete the selected mapping.
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Options - Drawing Layer 3D Dialog Box

Options - Drawing Layer 3D Dialog Box

The Options - Drawing Layer 3D Properties dialog box allows you to specify options about the 3D view of the layout.
To access this dialog box, choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under
Layer Setup and choose Properties.This dialog box contains the following options:
Field

Description

Name

Drawing layer name.

Opaque

If selected, the layer is not transparent in the 3D view. This must be selected if texturing is
desired.

Thickness

Defines layer thickness in project length units (for example, mils or microns).

Z-Position

Defines the position of each new layer in the Z-direction in project length units (for example,
mils or microns).

Texture File

You can apply texturing to the 3D layout object by specifying a bitmap (.bmp) file name. The
bitmap file must be located in the \textures subdirectory of the Microwave Office root directory.
Type the name of the bitmap file (without the extension) in the row that corresponds to the
desired layer. To use texturing, you must also select the Opaque column. Finally, to enable
texturing in the 3D Layout View, close the Drawing Layer Options dialog box and make the
3D layout window active, then choose View > Visual > Texturing or click the Texturing button on
the Schematic 3D Layout toolbar.

Texture Scale

If texturing is used, this value is used to scale the size of the bitmap in relation to the size of the
3D layout object. If the size of the bitmap is the same as the size of the 3D layout object, a
Texture Scale value of 1 would correspond to no scaling (1-to-1).

Blend

If Opaque is not selected, this is a number between 0 and 1 that describes a view that is a blend
of transparent and opaque. A value of 0 is completely transparent and 1 is completely opaque.
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Options - Drawing Layer 3D Dialog Box
Field

Description

New Layer

Create a new layer.

Delete

Delete the selected layer.

Configurations

Save or remove named configurations. Type in a name for the current configuration. Named
configurations allow saving setting groups. These can be used with layout modes to easily swap
different configurations, see “Layout Editor Mode Settings Dialog Box ” for more information
on layout modes.

Configurations

Save or remove named configurations.

Quick Check

Select or clear all Opaque properties.

Preview

Preview your current selections for any open 3D layout window.

Up/Down Arrows

Moves the selected layer up or down in the drawing layer list. Shapes draw in order from the
bottom of the list to the top.
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Options - EM Layer Mappings Dialog Box

The Options - EM Layer Mappings dialog box allows you to specify options about how the EM structure layers and vias
map to the Layout View. It also defines which EM structure layer to paste to when copying from a layer in the Layout
View (i.e. the mapping is bidirectional between EM structure layers and Layout drawing layers). To access this dialog
box, choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under Layer Setup and
choose Properties. This dialog box contains the following options:
Field

Description

Drawing Layer

Layer as displayed in the Layout View.

EM Layer

EM structure drawing layer number.

Via

Distinguishes if the layer describes vias or planar objects.

Material

Maps different conductor materials to drawing layers.

Via Extent

Number of layers the via extends. The default is 1.

Quick Check

Select or clear all Via properties.

Projects can have more than one EM layer mapping. To add a new EM layer mapping, right-click on any folder in the
left pane of this dialog box and choose New EM Layer Mapping.
With any of the EM layer maps selected, right-click to choose options to rename and delete the selected mapping.
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Options - File Export Mapping GDSII Dialog Box

The Options - File Export Mappings dialog box allows you to map the drawing layers to an exported file format (GDSII,
DXF, Gerber or PADS). You can define multiple mappings. To access this dialog box, choose Options > Drawing Layers,
or in the Layout Manager, right-click a project LPF file under Layer Setup and choose Properties. This dialog box contains
the following options:
Field

Description

Drawing Layer

Name of drawing layer that is mapped to the specified GDSII / DXF / Gerber layer.

Layer Number

Defines the layer to write to when exported. For GDSII, these will be integer numbers. For
DXF, these can be any name. This does not apply for Gerber file formats since the Gerber format
does not recognize the concept of layers. When exporting Gerber file types, all selected layers
are merged together.

Write Layer

Writes the layer to the exported file.

Data Type

GDSII data type. Used for GDSII export only.

Projects can have more than one file export mapping. To add a new file export mapping, right-click on a folder in the
left pane of this dialog box and choose New PADS File Export Mapping, New DXF File Export Mapping, New GERBER File
Export Mapping, or New GDSII File Export Mapping.
With any of the file export maps selected, right-click to choose options to rename and delete the selected mapping.

10–8 AWR Design Environment

Options - Units Dialog Box

Options - Units Dialog Box

The Options - Units dialog box allows you to individually specify which units are used in each LPF file associated with
a project. This allows different designs within the same project to use the units specified in the associated process
technology. To access this dialog box, choose Options > Drawing Layers, or in the Layout Manager, right-click a project
LPF file under Layer Setup and choose Properties. This dialog box contains the following options:
Field

Description

Unit Name (display
only)

Unit for which the multiplier is set.

Multiplier

Value in which the unit displays.

Base Units

Sets all unit types to their respective base units. For example, Frequency in Hz, Capacitance in
F, and Inductance in H.
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Options - Grids Dialog Box

The Options - Grids dialog box allows you to set the spacing for grids per the specified unit of measure. To access this
dialog box, choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under Layer Setup
and choose Properties. This dialog box contains the following options:
Field

Description

Grid Name (display
only)

The grid for which spacing and units are specified.

Spacing

The grid space value in the specified units.

Unit

The unit as specified in the Options - Units dialog box.
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Options - Default Values Dialog Box

The Options - Default Values dialog box allows you to . To access this dialog box, choose Options > Drawing Layers, or
in the Layout Manager, right-click a project LPF file under Layer Setup and choose Properties. This dialog box contains
the following options:
Field

Description

Default Name (display The grid for which spacing and units are specified.
only)
Value

The default value in the specified units.

Unit

The unit as specified in the Options - Units dialog box.
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Options - Drill Hole Layers Dialog Box

The Options - Drill Hole Layers dialog box allows you to specify drill holes in PCB boards. To access this dialog box,
choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under Layer Setup and choose
Properties. This dialog box contains the following options:
Field

Description

Name

Drill tool name.

Diameter

Drill diameter.

Number

Tool number.

See “Drill Hole” for details on using drill holes.
NC drill files do not specify the number format in the file. If units are in metric, the format for the file is 3.3, so the first
three numbers are before the decimal point and the last three are after the decimal point and the units are millimeters.
You can resolve up to 1 meter and down to 1 micron. If units are imperial units (mils), the format for the file is 2.4, so
the first two numbers are before the decimal point and the last four are after the decimal point and the units are inches.
You can resolve up to 100 inches and down to 0.1 mil.
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Options - Voiding Options Dialog Box

The Options - Voiding Options dialog box is used for layout shape corner rounding and small shape removal when
dynamic voiding is enabled. To access this dialog box, choose Options > Drawing Layers, or in the Layout Manager,
right-click a project LPF file under Layer Setup and choose Properties. This dialog box contains the following options:
Field

Description

Min Voiding Aperture Diameter for rounding the outside corners of dynamic shapes when dynamic voiding is enabled.
Min Voiding Spacing Minimum feature size for dynamic shape when dynamic voiding is enabled.
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Options - Voiding Constraint Sets Dialog Box

The Options - Voiding Constraint Sets dialog box is used for configuring spacing rules for dynamic voiding. To access
this dialog box, choose Options > Drawing Layers, or in the Layout Manager, right-click a project LPF file under Layer
Setup and choose Properties. This dialog box contains the following options:
Field

Description

Type

Select Spacing for rules that apply to layout shapes that have different net names, or select Same
Net Spacing for rules that apply to layout shapes that have the same net names.

CSet

Constraint set label. "DEFAULT" cannot be removed.

Layer

For internal use; this column cannot be edited.

Layer Name

Layer Name. The names of the defined line types. This column cannot be edited.

[All Types]

The spacing between layout shapes in length units associated with the LPF file. Entering a value
in this column sets all the Object Types columns to that value.

Object Types

(All remaining columns) These are the spacing rules for specific layout object types. You can
identify the object type by highlighting the component on the layout and viewing the Type=
parameter in the status bar or by right-clicking and choosing Shape Properties > Information tab
> Object Constraint Type.

New CSet

Click to add a new constraint set.

Delete CSet

Highlight the row of the CSet and click. DEFAULT constraint rules cannot be deleted.
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Layout Options Dialog Box: Layout Tab

The Layout Options dialog box Layout tab allows you to modify options related to layout grid and cell snap, and to
specify polygon points. To access this tab, choose Options > Layout Options, or double-click Layout Options in the Layout
Manager, or right-click Layout Options in the Layout Manager and choose Edit Layout Options. This dialog box contains
the following options:
Field

Description

Grid Options

Specify desired grid, grid spacing, database unit size, and rotation snap angle. See “Grid Options
” for more information.

Number of
points/circle

When converting a circle to a polygon, specify the number of polygon points used to represent
a circle. Larger numbers provide higher accuracy.

Instances draw as
boxes

Instances selected from the dialog box that opens only draw the instance outline and the instance
name instead of the full instance layout.

Layout Cell Snap
Options

Snap Together:
Auto Snap on Parameter Changes:

Automatically performs a snap together operation after a
parameter that affects layout is changed.
Manual Snap for All Objects: Snaps together all objects in a layout only when you choose Edit >
Snap All Hierarchy.
Manual Snap for Selected Objects Only: Snaps together selected objects in a layout only when
you choose Edit > Snap Together.
Auto face inset:

Specifies whether or not to inset the layout cell faces from their normal positions. For more
information, see “Layout Cell Snap Options”. Options for small insets for faces when snapping
layout together. These options are available because rotated shapes can have rounding that
causes the layout to be snapped together but still have small gaps (order of the database resolution)
in the layout.
Do not inset faces: Turns off the automatic face insetting so no artificial overlap is created for
any of the layout cells.
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Layout Options Dialog Box: Layout Tab
Field

Description
Inset non-orthog.: Options for 0.25, 0.5, 0.75 and 1 database units to inset faces for any element

that is rotated any amount besides 0-, 90-, 180- or 270-degrees.
Inset all: Options for 0.25, 0.5, 0.75 and 1 database units to inset faces for all elements.
Auto-snap parameterized subcircuits: Snaps elements in parameterized subcircuits after parameter
values are applied.
Don't rotate shapes when snapping: Prevents objects from rotating during a snap together operation.
Default connection to closest face: Snaps objects to the closest cell face during a snap together
operation.
Fixed origin for subcircuits: Sets the origin for the subcircuit to the 0,0 location of the subcircuit.
By default the origin is the first vertex of the first face of the subcircuit.
Fixed origin for layout cells: Sets the origin for layout cells to the 0,0 location of the cell. By
default the origin is the first vertex of the first face of the layout cell.
Keep origin on grid: Enforces that the origin for layout cells must be on the database resolution
grid. By default, the origin is the first vertex of the first face of the layout cell. This vertex can
be off grid even if the layout shapes are not.
Allow pCell's origin to float: For designs that are mostly non-orthogonal (for example, MMIC),
allows the origins of pCells that do not override the database unit to float. pCells are snapped
together in floating point, and curved/angled shapes can still exist without gaps. Artwork cells
and subcircuits should keep their origins on grid; this option works in conjunction with Keep
origin on grid. NOTE: The settings for Auto face inset, Fixed origin for subcircuits, Fixed origin
for layout cells, Keep origin on grid and Allow pCell's origin to float can all help the layout system
properly snap together based on your design style. See “Setting Layout Options” and specifically
the section “Preventing Layout Problems”.
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Layout Options Dialog Box: Export/LPF Tab

The Layout Options dialog box Export/LPF tab allows you to specify layout export and LPF options. To access this tab,
choose Options > Layout Options, or double-click Layout Options in the Layout Manager, or right-click Layout Options in
the Layout Manager and choose Edit Layout Options. See “Exporting the Layout ” for details on options for exporting
layouts. This dialog box contains the following options:
Field

Description

Layout Export Options

Merge layout shapes on +/- layers: Combines positive, negative, and normal layers on export. The

results of merged shapes on +/- layers are unioned, regardless of the visible Union layout shapes
setting. See “Negative Layers ” for details.
Union layout shapes: Unions all shapes on the same layer when the layout is exported.
Subcircuits as instances: Subcircuit layout instances are "flattened" but artwork cells are not
when exporting a hierarchical file type (DXF or GDSII).
Artwork instance
export options

Do not change cell names: If there are multiple cells (from different libraries) that have the same

cell name in a layout, only one of the multiple instances is written out to the GDSII file when
this option is chosen. This is a result of the restriction that the cell instance names must be unique
within the GDSII file. By not allowing the name of the cell instance to be changed, it is only
possible to write one of the cells.
Append number to duplicates: This option allows multiple cell instances with the same name to
be written into a single GDSII file. The name of cell instances that were previously written are
changed by appending a number preceded by an underscore. For example, if a CellA is written
and another CellA needs to be written to the same file, the second instance of CellA is
automatically renamed to CellA_1.
Append lib name to duplicates: This option allows multiple cell instances with the same name to
be written into a single GDSII file. This option automatically changes the name of cell instances
that were previously written out by appending the name of the library from which the cell
instance was located. For example, if a CellA from LibA is written, then another CellA from
LibB needs to be written to the same file, the first instance is renamed CellA_LibA and the
second instance is renamed CellA_LibB.
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Layout Options Dialog Box: Export/LPF Tab
Field

Description
Append lib name to all: This option appends the library name to all cell instances that are written.

For example, CellA from LibA is renamed CellA_LibA even if there are no other cell instances
named CellA.
Layout cell export
options

These options apply to any object drawn from a parameterized cell (pCell), and when a layout
is exported with hierarchy.
Export flattened: All pCells are exported flat.
Export all as instances: All pCells are exported as instances, that is, as separate GDSII or DXF
cells for each unique instance of a pCell.
Export specified as instances: Click the Select cells to export as instance button to select pCells
by name for exporting as instances.

Write layout cell
parameter map

Writes a text file (to the same location as the exported artwork) that serves as a map between
individual pCells and the instance they use in the exported file.

Select cells to export as Displays a Select Layout Cells dialog box to allow selection of specific pCells to export as
instances
instances. Note that your layout must be open to list these pCells. These settings ONLY apply
if Layout cell export options is set to Export specified as instances.
LPF Options

Use parent LPF for EM subcircuits: EM subcircuits use the parent LPF. When selected, any layer

in EM that has a valid mapping entry displays properly and any layer that does not have a valid
mapping (that is displaying on a derived layer) displays on the error layer.
Limit number of
The maximum number of points that any one polygon can have when the artwork is exported.
vertices per polygon to If the polygon exceeds this number of points, the shape is fractured such that each point has no
more than this number, while maintaining the same layout. The default value is the maximum
number allowed by a GDSII record. Some GDSII readers adhere to an older specification of
200 points, so set this value to 200 if needed.
Export cell faces

When selected, includes the face drawing objects for pCells exported as instances. Sometimes
these faces can cause DRC errors so you can clear this option to prevent drawing these faces
when exporting.

Limit cell names to 32 Limits exported cell names to 32 characters maximum.
chars
DXF Options

Remove illegal chars in layer names: Automatically fixes illegal DXF layer names (for example,

auto-generated layers contain a "+" which is removed.)
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Layout Options Dialog Box: iNet Tab

The Layout Options dialog box iNet tab allows you to specify iNet options for vias and bends. Via options only affect
iNets, while the Default Bend Style also affects routes. To access this tab, choose Options > Layout Options, or double-click
Layout Options in the Layout Manager, or right-click Layout Options in the Layout Manager and choose Edit Layout
Options. This dialog box contains the following options:
Field

Description

Automatic via sizing

Enforce minimum size via: For future implementation.
Via covers pin-route intersection: Via arrays only draw

in the area where a route overlaps a pin.
If the route is smaller than the pin, the via area is the same size as the route.
Via covers entire pin area: Via arrays draw in the area of the area pin being connected to. If the
route is smaller than the pin, the via area is the same size as the pin, making a larger connection
as the pin.
Minimal via: For future implementation.
Default Bend Style

Specify the bend style as square, mitered, or curved.
For a Miter bend style, if Miter Length Relative to Width is selected, enter a number in Amount to
specify the miter amount relative to the line width. If not selected, enter the absolute miter
amount.
For a Curve bend style, if the Curve Radius Relative to Width is selected, enter a number in Amount
to specify the curve radius relative to the width. If not selected, enter the absolute curve radius.
Curves use fixed radius (for iNets and Routes) Controls the default value for newly created iNet
route objects in the project. If this option is selected, any newly created iNet Route objects
default to having a fixed radius for curves. If this option is not selected (the default), all newly
created iNet route objects default to having a variable radius for curves.

Route Via Insertion

Specify the Default Via Mode.
Full: Adds vias at every location where the iNet overlaps itself, when segments change layers,
and at the end points of the iNet if needed. The via locations update if the net is moved, or if
any of the pins or faces the net connects to are moved. Manual: No vias are added automatically,
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Layout Options Dialog Box: iNet Tab
Field

Description
you must specify via placement. The via locations do not update automatically when the net is
moved or when pins or faces that connect to the net are moved.
Minimal and Minimal 2: Adds vias only when segments change layers, and at the end points of
the iNet if needed. Via locations update if the net is moved, or if any of the pins or faces the net
connects to are moved or changed.
Minimal 2: Provides support for constructing complex multi-layer self-overlapping iNet route
structures. See “Preparing to Route” for details.

Semi-auto via mode

Vias are initially automatically inserted at locations according to the Default Via Mode. After
routing is complete, vias transition to Manual mode and no longer update when the route is
edited.

Route Connectivity
Model

Specify the Default Model.
Centerline Model: An iNet route is considered connected to an area pin or cell face when the
centerline of the route touches the pin or face. Two routes are considered connected when their
centerlines touch.
Centerline and Adjacent: (for iNets only) An iNet route is considered connected to an area pin
or cell face when the centerline of the route touches the pin or face. Two routes are considered
connected if the centerline of one route touches any part of another route.
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Layout Options Dialog Box: Paths Tab

The Layout Options dialog box Paths tab allows you to specify path drawing options. To access this tab, choose Options
> Layout Options, or double-click Layout Options in the Layout Manager, or right-click Layout Options in the Layout
Manager and choose Edit Layout Options. This dialog box contains the following options:
Field

Description

Path Width

Sets the width of the straight line segments that construct a path.

End Type

Extended half-width extends both ends of the path by one-half the width.
Flush leaves the path ends flush with the centerline end points.
Rounded extends the path ends by a semi-circle with a radius equal to half the width.
Extended extends the end of the line as specified in Begin Ext and End Ext.
Chamfered extends the path ends by one-half the width and chamfers the corners of this extension

by one-quarter the width.
Truncated is the same as Flush but it includes all layers of a multi-layer linetype.
<various> is available if you select more than one object with different end types before opening
the dialog box. To make the end types of all selected objects the same, choose one of the other
options.
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Field

Description

Bend Type

Square has no modification to the bend.
Mitered miters the outside of the bend by the path width.
Offset miter miters the outside of the bend by the amount

specified in Miter offset. The offset is
relative to the normal miter and is limited to +/- the path width.
Curved curves the entire bend by the amount specified in Radius.
Rounded rounds the outside of the bend by half the path width, common in PCB.
Chamfered is conceptually like Curved but uses a single line segment for the curve.
Fixed Radius: Select this check box to make curved/chamfered bends square if there is not enough
room to render them. If the check box is cleared, the bends' radius is reduced as needed in order
to make them fit.
<various> is available if you select more than one object with different end types before opening
the dialog box. To make the end types of all selected objects the same, choose one of the other
options.
Layout

Select the Use Process Layer check box to display a line type for dumb shapes, then specify the
line type you want to apply to the shape.

Draw as polygons

Options for drawing a path as a polygon, usually used to address off grid problems.
Never: Always draw as a path.
Always: Always draw as a polygon.
When vertices are off-grid: Draw as a polygon only if the path draws such that the shape vertices
would be off grid.
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Layout Options Dialog Box: Boolean Tab

The Layout Options dialog box Boolean tab allows you to modify options related to Boolean operations. To access this
tab, choose Options > Layout Options, or double-click Layout Options in the Layout Manager, or right-click Layout Options
in the Layout Manager and choose Edit Layout Options. This dialog box contains the following options:
Field

Description

Cutout processing

Specify whether Boolean operations on polygons resulting in holes retain the holes in the resultant
polygons, or add cutlines to the resultant polygons:
Allow cutlines for cutouts: Add cutlines to holes in resultant polygons.
Retain holes for cutouts: Preserve holes in resultant polygons.

Resize acute corners

Specify how acute corners are resized:
Rounded: Resized acute corners are rounded.
Sharp: Acute corners are maintained on resize operations.
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The Layout Options dialog box Dimension Lines tab allows you to modify options related to dimension line properties.
To access this tab, choose Options > Layout Options, or double-click Layout Options in the Layout Manager, or right-click
Layout Options in the Layout Manager and choose Edit Layout Options. This dialog box contains the following options:
Field

Description

Default Dimension
Line Properties

Specify the font type and height, the arrow style and size, the text orientation, and tolerance and
precision options. Most of the dialog options are self-explanatory; however, three options require
more information:
Gap: Sets the spacing between the measured object and the dimension lines.
Tolerance: Allows the user to display an absolute tolerance (+/-) on all dimensions (e.g. +/- 10
um).
Precision: Sets the number of digits past the decimal point that will be displayed (trailing zeros
are omitted).
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The Layout Options dialog box Ruler tab allows you to modify options related to default ruler properties. To access this
tab, choose Options > Layout Options, or double-click Layout Options node in the Layout Manager, or right-click Layout
Options in the Layout Manager and choose Edit Layout Options. This dialog box contains the following options:
Field

Description

Lines

Ruler spacing: Sets the resolution of the ruler (e.g. a ruler spacing of 5 um results in a ruler that

displays distance in 5 um increments).
Gap: Sets the spacing between the measured object and the ruler.
Tick mark height: Sets the height of the ruler tick marks.
Labels

Show Labels: Display labels.
Height: Specify the label height.
Decimals: Sets the number of digits

beyond the decimal point that will be displayed (trailing

zeros are omitted).
Show minor tick

Display minor ticks on the ruler.
Minor tick spacing: Sets the increment between major and minor ticks.
Minor tick height: Sets the height of the minor tick marks.

Font name

Specify the font type.Show unit: Display the distance units on the ruler (e.g. um).
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Layout Options Dialog Box: Layout Font Tab

The Layout Options dialog box Layout Font tab allows you to modify options related to the default font to be used on
layouts. To access this tab, choose Options > Layout Options, or double-click Layout Options in the Layout Manager, or
right-click Layout Options in the Layout Manager and choose Edit Layout Options. This dialog box contains the following
options:
Field

Description

Default Layout Font

Specify the font typeface and height, and indicate style options such as bold and italic.
Default Layout Font: The font type must be a Windows True Type Font. Only the True Type
Fonts that are currently installed on the system are displayed in the font list.
Height: Specify a font height. The width of the font is based on the height.
Draw as polygons: If selected, all letters are drawn as polygons on the specified layer. The text
is treated as any other drawing object. If the layout is exported, the text is associated with a
particular layer. If not selected, the text is treated as a text object. If the layout is exported, the
text is not associated with a particular layer but is exported as a text object.
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The Layout Options dialog box Gds Cell Stretcher tab allows you to modify options related to default cell stretcher
properties. To access this tab, choose Options > Layout Options, or double-click Layout Options in the Layout Manager,
or right-click Layout Options in the Layout Manager and choose Edit Layout Options. This dialog box contains the following
options:
Field

Description

Default Cell Stretcher Multiplier (m/unit): Sets the scaling factor for the specified parameter. The units of the multiplier
Object Properties
are in meters per unit, where "unit" is the MKS (or base) unit of the parameter being referred
to. For example, if stretching a MMIC resistor, the unit would be in ohms, therefore a multiplier
of 10e-6 results in stretching the cell 10 um for every ohm. As another example, if stretching a
capacitor with width and length parameters, and width was the parameter upon which to base
the stretch, one would normally set the multiplier to 1 for a 1-to-1 stretch.
Parameter: The parameter of the electrical model associated with the GDSII artwork cell. The
amount of stretching is dependent upon this parameter.
Offset: This value (in meters) is added or subtracted from the stretch distance that is obtained
from the result of multiplying the Multiplier by the Parameter value. In the MMIC resistor example
above, if the multiplier was set to 10e-6 m/unit, the resistance parameter was set to 50 ohms,
and the offset was set to -10e-6, the overall stretch distance would be: 10e-6 m/ohm x 50 ohm
- 10e-6 m = 490e-6 m = 490 um
Maximum and Minimum: Sets the maximum and minimum values that the cell can be stretched.
For example, if the original cell is 100 um long, Maximum is set to 100 um and Minimum is set
to -100 um, the cell can be stretched positively to a maximum length of 200 um and negatively
to a minimum of 0 um.
Arrow height: The height of the displayed arrow.
Direction: Sets the stretching direction. Positive stretches in the positive x or y direction, Negative
stretches in the negative x or y direction, and Both stretches equally by one-half the stretch
distance in each direction.
Bound: Stretches only the vertices of the polygon within the bounds of the cell stretcher. For a
cell stretcher that is drawn to stretch an object horizontally, the bounds of the cell stretcher are
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Field

Description
defined vertically. For example, if a cell stretcher is defined with a positive direction and is
drawn from the top-middle to the bottom-middle of a box (the arrow is pointing to the right),
both the top-right and bottom-right vertices are stretched if you select this option. If, however,
the cell stretcher is only drawn from the top-middle of the box to the exact center of the box,
only the top-right vertex is stretched.)
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Layout Options Dialog Box: Placement Tab

The Layout Options dialog box Placement tab allows you to specify layout placement options. To access this tab, choose
Options > Layout Options, or double-click Layout Options in the Layout Manager, or right-click Layout Options in the
Layout Manager and choose Edit Layout Options. This dialog box contains the following options:
Field

Description

Placement

Match Schematic orientation: When auto-placing schematic driven layout cells, use the orientation

of the schematic element for the orientation of the layout cell.
See “Layout Placement Commands ” for details on the command that uses this option.
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The Properties dialog box Layout tab allows you to modify options related to layer settings and orientation. To access
this tab, create a schematic, choose View > View Layout , create a layout shape, right-click the layout shape, and choose
Shape Properties. This dialog box contains the following options:
Field

Description

Layer Settings

Draw Layers: Sets the drawing layer on which the object is drawn.
Use process layers: Enables Line Type and Layer Mapping to allow you

to specify the line type

and layer mapping to use for the object.
Orientation

Flipped: Flips the layout object from the normal orientation.
Angle: Sets the angle of orientation. For normal orientation, specify

Scale

Reserved for future use.

Freeze

Makes the layout object unmovable and uneditable.

EM Extraction Options

Enable: Click to enable the shape for extraction.
Group name:: Name of the extraction group for the
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The Properties dialog box Arc tab allows you to modify arc properties. To access this tab, create a schematic, choose
View > View Layout , right-click an arc, and choose Shape Properties. This dialog box contains the following options:
Field

Description

Start Angle

Sets the start angle of the arc.

Stop Angle

Sets the stop angle of the arc.

Radius

Sets the length of the arc radius.

Filled

Fills the arc with a pattern.
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Properties Dialog Box: Path Tab

The Properties dialog box Path tab allows you to modify options related to paths. To access this tab, create a schematic,
choose View > View Layout, right-click a path, and choose Shape Properties. This dialog box contains the following options:
Field

Description

Path Width

Sets the width of the straight line segments that construct a path.

End Type

Extended half-width extends both ends of the path by one-half the width.
Flush leaves the path ends flush with the centerline end points.
Rounded extends the path ends by a semi-circle with a radius equal to half the width.
Extended extends the end of the line as specified in Begin and End.
Chamfer extends the path ends by one-half the width and chamfers the corners of this extension

by one-quarter the width.
Truncate is the same as Flush but it includes all layers of a multi-layer linetype.
<various> is available if you select more than one object with different end types before opening
the dialog box. To make the end types of all selected objects the same, choose one of the other
options.
Bend Type

Square has no modification to the bend.
Mitered miters the outside of the bend by the path width.
Offset miter miters the outside of the bend by the amount specified in Offset. The offset is relative

to the normal miter and is limited to +/- the path width.
Curve curves the entire bend by the amount specified in Radius.
Round rounds the outside of the bend by half the path width, common in PCB.
Chamfer is conceptually like Curve but uses a single line segment for the curve.
Curves use fixed radius turns curved/chamfered bends to square if there is not enough room to
render them. If off, the bends' radius is reduced as needed in order to make them fit.
<various> is available if you select more than one object with different end types before opening
the dialog box. To make the end types of all selected objects the same, choose one of the other
options.
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The Properties dialog box Circle tab allows you to modify the radius of a circle. To access this tab, create a schematic,
choose View > View Layout, right-click a circle, and choose Shape Properties. This dialog box contains the following
options:
Field

Description

Radius

Sets the length of the circle radius.
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Properties Dialog Box: Ellipse Tab

The Properties dialog box Ellipse tab allows you to modify radius options related to ellipses. To access this tab, create a
schematic, choose View > View Layout, right-click an ellipse, and choose Shape Properties. This dialog box contains the
following options:
Field

Description

Major radius

Sets the length of the ellipse's major radius.

Minor radius

Sets the length of the ellipse's minor radius.
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Properties Dialog Box: Rectangle Tab

The Properties dialog box Rectangle tab allows you to modify the size of a rectangle. To access this tab, create a schematic,
choose View > View Layout, right-click a rectangle, and choose Shape Properties. This dialog box contains the following
options:
Field

Description

Width

Sets the width of the rectangle.

Height

Sets the height of the rectangle.

Dialog Box Reference10–35

Properties Dialog Box: Cell Port Tab

Properties Dialog Box: Cell Port Tab

The Properties dialog box Cell Port tab allows you to specify options related to a cell's port. To access this dialog box,
in a layout window, select a cell port, right-click the port, and choose Shape Properties. This dialog box contains the
following options:
Field

Description

Port Number

Specify which port number the properties are being set for.

Connection Type

For multi-layer artwork cells, the connection type specifies the type of element the cell port
represents. Any artwork cell that connects to this port will know how to connect based upon
this information. Select Unknown (default) unless you are creating a cell for a custom MMIC
library.

Pin Group

For cells that have more than one pin per electrical port (for example, a FET with three nodes
on the schematic but six in the layout): Pin groups allow you to define how pins are connected
inside the layout cell.
Weak: Pins are already connected internally, so you only need to wire to one pin in the group.
Wiring into one pin and out of another is not allowed.
Strong: Pins are already connected internally, so you only need to wire to one pin in the group.
Wiring into one pin and out of another is allowed.
None: You must connect the pins.

Artwork Line Type

When Artwork line is the Connection Type, specify the line type.
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Properties Dialog Box: Cell Pin Tab

The Properties dialog box Cell Pin tab allows you to specify options related to a cell pin. To access this tab, in a layout
window, select a cell pin, right-click the pin and choose Shape Properties. This dialog box contains the following options:
Field

Description

Port Number

Specify for which port number the properties are being set.

Pin Group

For cells that have more than one pin per electrical port (e.g. a FET with three nodes on the
schematic but six in the layout):Pin groups allow you to define how pins are connected inside
the layout cell.
Weak: Pins are already connected internally, so you only need to wire to one pin in the group.
Wiring into one pin and out of another is not allowed.
Strong: Pins are already connected internally, so you only need to wire to one pin in the group.
Wiring into one pin and out of another is allowed.
None: You must connect the pins.

Connection Type

For multi-layer artwork cells, the connection type specifies the type of element the cell pin
represents. Any artwork cell that connects to this pin will know how to connect based upon this
information. Select Unknown (default) unless you are creating a cell for a custom MMIC library.

Artwork Line Type

When Artwork line is the Connection Type, specify the line type.
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The Properties dialog box Route tab allows you to specify route properties. To access this tab, in a layout window, select
a route, right-click the route and choose Shape Properties. This dialog box contains the following options:
Field

Description

Attributes

Select Global to apply the global attribute to the route when exported to a Cadence Unified
Library. This setting is not used in the AWR Design Environment.
Specify whether the Segment ends are controlled automatically or set manually. Your selection
determines which options you edit/control on the Segments tab. Automatic allows you to control
just the beginning style for the first start segment of the route and the end style of the last
segment. All of the end style segments in between are automatically adjusted to optimum settings.
Custom allows you to adjust segments individually and set the styles for all segments in between
the first and last segments.

Bend Style

Specify the bend style as Square, Mitered, Curved, Chamfered, or Rounded.
For a Mitered bend style, if Miter Length Relative to Width is selected, in Amount, enter a number
to specify the miter relative to the line width. If this option is not selected, in Amount, enter the
absolute miter amount.
For a Curved bend style, if Curve Radius Relative to Width is selected, in Amount, enter a number
to specify the curve radius relative to the width. If this option is not selected, in Amount, enter
the absolute curve radius.
Curves use fixed radius controls the type of radius used for curved bends on an iNet route. If this
option is selected, a fixed radius is used to calculate the curves in the corners. If the adjacent
sides to the bend corner become shorter than the fixed radius value the corner is not curved. If
this option is not selected, a variable radius is used to calculate the corners. In this default mode
the radius is varied (reduced) as the adjacent sides become shorter to allow the corner to be
curved for values smaller than the specified radius amount.
Chamfered bends can either have the amount of chamfer (similar to curve radius) relative to the
route width, or be specified by an absolute size. In addition, when lengths of the incoming and
outgoing segments to a bend become too small to fit the full-size chamfer segment, the length
of the chamfer segment is automatically reduced to fit a shorter segment by default. If you do
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Field

Description
not want automatic resizing, select Curves use fixed radius and when the incoming and outgoing
segments become too short, the bend reverts to a Rounded bend.
The Rounded bend style is similar to Square, but rounds off the outer edge corners with a radius
that is half the line width.
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Properties Dialog Box: Segments Tab

The Properties dialog box Segments tab allows you to specify segment properties. To access this tab, in a layout window,
select a route, right-click the route and choose Shape Properties. This dialog box contains the following options:
Field

Description

Index

The segment order/number.

Line

Pull down menu to select line type configured for the current process.

Width

The line width.

Beg(inning) Style

Line beginning style. iNet ends can have the following shapes:
FlushEndStyle leaves the end point flush with the line edge, and includes layer pullbacks (for
multi-layer line types).
ExtendedEndStyle extends the end of the line as specified.
ChamferEndStyle extends the end into a chamfered polygonal termination.
RoundedEndStyle extends the end into a radius equal to half the width.
TruncatedEndStyle leaves the end point flush with the line edge, cutting off ends with multiple
layers aligned at the iNet end point.

Beg(inning) Ext.

The extension of the line from the beginning of the reference edge.

End Style

Line end style (see Beg(inning) Style for options).

End Ext.

The extension of the line from the end of the reference edge.
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Properties Dialog Box: Vias Tab

The Properties dialog box Vias tab allows you to specify via properties. To access this tab, in a layout window, select a
via, right-click the via and choose Shape Properties. This dialog box contains the following options:
Field

Description

Index

The segment order/number.

Line1 / Line2

Pull down menu to select line type configured for the current process.

Direction

The via direction between layers.

Extent X

The extension of metal in the x direction.

Extent Y

The extension of metal in the y direction.

Offset X

The via offset from the origin in the x direction.

Offset Y

The via offset from the origin in the y direction.

Autosize

Automatically sizes a via per rules defined in the active .lpf file.

Enabled

Vias will draw if this option is selected.
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Properties Dialog Box: iNet Tab

The Properties dialog box iNet tab allows you to specify an iNet via mode. To access this tab, in a layout window, select
an iNet, right-click the via and choose Shape Properties. This dialog box contains the following options:
Field

Description

Via Mode

Full:

Semi-auto via mode

Vias are initially automatically inserted at locations according to the Via Mode. After routing is
complete, vias transition to Manual and no longer update when the route is edited.

Route Connectivity

Use Project Default: Use the project defaults for iNet options as set on the Layout Options dialog
box iNet tab (choose Options > Layout Options).
Centerline Model: An iNet route is considered connected to an area pin or cell face when the

Adds vias at every location where the iNet overlaps itself, when segments change layers,
and at the end points of the iNet if needed. The via locations update if the net is moved, or if
any of the pins or faces the net connects to are moved.
Manual: No vias are added automatically, you must specify via placement. The via locations do
not update automatically when the net is moved or when pins or faces that connect to the net
are moved.
Minimal and Minimal 2: Adds vias only when segments change layers, and at the end points of
the iNet if needed. Via locations update if the net is moved, or if any of the pins or faces the net
connects to are moved or changed.
Minimal 2: Provides support for constructing complex multi-layer self-overlapping iNet route
structures. See “Preparing to Route” for details.

centerline of the route touches the pin or face. Two routes are considered connected when their
centerlines touch.
Centerline and Adjacent: An iNet route is considered connected to an area pin or cell face when
the centerline of the route touches the pin or face. Two routes are considered connected if the
centerline of one route touches any part of another route.

10–42 AWR Design Environment

Properties Dialog Box: Information Tab

Properties Dialog Box: Information Tab

The Properties dialog box Information tab allows you to view the properties and coordinates of the selected shape, including
width, height, or length, model and drawing layers, total area, and the location of the vertices. All information is display
only. This information also displays in the status bar at the bottom of the design environment window. To access this
tab, create a schematic, choose View > View Layout, right-click a shape, and choose Shape Properties.
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Properties Dialog Box: Dimension Line Tab

The Properties dialog box Dimension Line tab allows you to modify options related to dimension lines. To access this
tab, create a schematic, choose View > View Layout, right-click a dimension line, and choose Shape Properties. This dialog
box contains the following options:
Field

Description

Dimension Line
Properties

Specify the arrow style and size, the text orientation, and tolerance and precision options. Most
of these options are self-explanatory; however, these options deserve more description:
Gap: Sets the spacing between the measured object and the dimension lines.
Tolerance: Allows you to display an absolute tolerance (+/-) on all dimensions (e.g. +/- 10 um).
Precision: Sets the number of digits that display past the decimal point (trailing zeros are omitted).
Alternate Text: If specified, this text is displayed instead of the actual dimension value. This
option is useful for documentation purposes.
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Properties Dialog Box: Ruler Tab

The Properties dialog box Ruler tab allows you to modify options related to ruler properties. To access this tab, create a
schematic, choose View > View Layout, right-click a ruler, and choose Shape Properties. This dialog box contains the
following options:
Field

Description

Ruler Properties

Specify the ruler spacing and gap, the tick mark heights, and the precision.
Ruler spacing: Sets the resolution of the ruler (for example, a ruler spacing of 5 um will result
in a ruler that displays distance in 5 um increments).
Gap: Sets the spacing between the object and the ruler.
Tick mark height: Sets the height of the ruler tick marks.
Decimal places: Sets the number of digits past the decimal point that will be displayed (trailing
zeros are omitted).
Minor tick spacing: Sets the distance between minor ticks on the ruler.
Minor tick height: Sets the height of the incremental tick marks inside the main tick marks.
Show labels: Displays the unit of measure on the ruler.
Show minor ticks: Displays the minor tick marks.
Show unit: Displays the distance units on the ruler (e.g. um).
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Properties Dialog Box: Font Tab

The Properties dialog box Font tab allows you to modify font options. To access this tab, create a schematic, choose View
> View Layout, right-click on text, and choose Shape Properties. This dialog box contains the following options:
Field

Description

Font

Select the font type, height, and attributes (bold, italic).

Draw as polygons

If selected, the text is drawn as a polygon shape (this tapes out on a process layer). If not selected,
the text is drawn as a text object (does not tape out on a process layer).
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Properties Dialog Box: Gds Cell Stretcher Tab

The Properties dialog box Gds Cell Stretcher tab allows you to modify options related to the Gds cell stretcher. To access
this tab, click the Layout Manager tab at the lower left of the window, create a new Gds library or load an existing library,
create or open an existing layout cell, right-click the cell stretcher break line, and choose Shape Properties. For more
information about cell stretching, see “Stretching Artwork Cells”. This dialog box contains the following options:
Field

Description

Cell Stretcher Object
Properties

Specify properties such as the maximum, minimum, arrow height, and direction.
Multiplier (m/unit): Sets the scaling factor for the specified parameter. The units of the multiplier
are in meters per unit, where "unit" is the MKS (or base) unit of the parameter being referred
to. For example, if stretching a MMIC resistor, the unit is in ohms, therefore a multiplier of
10e-6 results in stretching the cell 10 um for every ohm. As another example, if stretching a
capacitor with width and length parameters and width was the parameter upon which to base
the stretch, one would normally set the multiplier to 1 for a 1-to-1 stretch.
Parameter: The parameter of the electrical model associated with the GDSII artwork cell. The
amount of stretching is dependent upon this parameter.
Offset: This value (in meters) is added or subtracted from the stretch distance that is obtained
from the result of multiplying the Multiplier by the Parameter value. In the MMIC resistor
example above, if the multiplier was set to 10e-6 m/unit, the resistance parameter was set to 50
ohms, and the offset was set to -10e-6, the overall stretch distance would be: 10e-6 m/ohm x
50 ohm - 10e-6 m = 490e-6 m = 490 um
Maximum and Minimum: Sets the maximum and minimum values that the cell can be stretched.
For example, if the original cell is 100 um long, Maximum is set to 100 um and Minimum is
set to -100 um, the cell can be stretched positively to a maximum length of 200 um and negatively
to a minimum of 0 um.
Direction: Sets the stretching direction. Positive stretches in the positive x or y direction, Negative
stretches in the negative x or y direction, and Both stretches equally by one-half the stretch
distance in each direction.
Bound: If selected, only the vertices of the polygon within the bounds cell stretcher are stretched.
For a cell stretcher that is drawn to stretch an object horizontally, the bounds of the cell stretcher
are defined vertically. For example, if a cell stretcher is defined to have a positive direction and
is drawn from the top-middle to the bottom-middle of a box (the arrow will be pointing to the
right), both the top-right and bottom-right vertices are stretched if this option is selected.
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Field

Description
However, if the cell stretcher is only drawn from the top-middle of the box to the exact center
of the box, only the top-right vertex is stretched.
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Properties Dialog Box: Drill Hole Tab

The Properties dialog box Drill Hole tab allows you to modify options related to drill tools. To access this tab, create a
schematic, choose View >View Layout, right-click a drill hole, and choose Shape Properties. This dialog box contains the
following options:
Field

Description

Select Drill Tool

Specify the drill tool desired. You must configure a drill tool before it displays in this list. See
“Options - Drill Hole Layers Dialog Box ” for more information.
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Properties Dialog Box: Net Properties Tab

The Properties dialog box Net Properties tab allows you to set options for the selected layout shape that is intended for
use as a dynamic shape when dynamic voiding is enabled. To access this tab, create a schematic, choose View > View
Layout, create a layout shape, right-click the layout shape, and choose Shape Properties. This dialog box contains the
following options:
Field

Description

Net Name

Net name associated with the dynamic shape.

Dynamic Shape

Is dynamic shape: Internal use; cannot be edited.
Dynamic shape priority: Sets the priority for overlapping dynamic shapes. A dynamic shape with

a higher priority cuts out a dynamic shape with a lower priority.
Use voiding defaults: Select this check box to use the voiding options defined in the LPF.
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Cell Library Properties Dialog Box

The Cell Library Properties dialog box allows you to specify options related to library searching and editing. To access
this dialog box, right-click a library under the Cell Libraries node in the Layout Manager and choose Cell Library Properties.
This dialog box contains the following options:
Field

Description

Library name/File
name/File date

Lists the library name and file name and date, along with cell information.

LPF name

Lists the default LPF file name and allows you to choose an alternate LPF file as the parent LPF
of the cell library.

Override database unit Select this check box to override the specified Database unit size. When not selected, the database
size for layout cells in unit size is used.
this library
Database unit size

Specify the default database unit size.

Library searching
priority

Changes the search order for hierarchical artwork cells. This can be used to resolve name conflicts
when several libraries are being used that have artwork cells with the same names. This option
only affects hierarchical artwork cells.

Lock library editing

Prevents accidental changes to artwork cells in a library. When the library is locked, any edits
on a cell in the library are not saved back into the library after you close the Artwork Cell Editor.

Exclude from export

If a layout is exported as a hierarchical GDSII file, then the artwork cells that are part of the
layout are exported as GDSII instances. If Exclude from GDSII export is selected for the library,
then the references to the instances in the library are written out, but the actual cell instance data
is not written out. This can be useful if standard GDSII libraries are used and it is important to
maintain a single copy of common cells, or it is desired to minimize file size. It can also be used
as a mechanism for replacing cell instances in a layout. If the layout is exported without instances,
then it can be read into a project that has different versions of those instances.
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Field

Description

Always read newest

Causes the Layout Manager to automatically import newer versions of cells when the date of
the referenced library file is newer than the date of the original library. If an artwork cell is
edited, then the edits may be lost if a newer version of the library becomes available. To prevent
lost edits with this option, you need to save the library after making any edits (right-click the
library and choose Export Cell Library). When this option is cleared, any changes to a referenced
library file are not updated in the layout within the project. If Replace All Cells is selected this
option has no effect because the cells are always re-read from the library.

Replace all cells (even Causes the artwork cells to be re-read from the referenced library file when the project is opened.
modified cells)
When this option is cleared (the default), then any artwork cells used in a project are stored in
the project and used for all instances in the layout.
When to save cells
with the project?

Specify how to save GDSII libraries in the project:
For libraries created in the project, Always is the default and the only setting that applies. All of
the library cells are saved in the project whether or not they are used in the project.
For libraries imported into the project, InUse is the default setting. Only the library cells that are
used in the project are saved with the project. Always specifies that all the cells are saved with
the project, potentially making the project large. Never specifies that the cells are not saved in
the project at all.
For libraries that are linked to the project, Never is the default setting. Never specifies that the
cells only exist if the library file exists, which locks the library and makes it uneditable. InUse
saves only the cells that are used in the project, whereas Always saves all the cells in the project
whether or not they are used in the project

Allow cell to be used
in path-based
extraction

Allows cells in this library to be used by a path-based extractor (such as ACE) when the cells
are used in schematic layouts that are used for extraction. This class of extraction assumes that
the input geometry can be resolved to paths (a center line with a width), although not all geometry
in artwork cells fits into this category (for example, a circle).
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Rename Cell Dialog Box

The Rename Cell dialog box allows you to rename an artwork cell and specify its synchronization options. To access
this dialog box, right-click a cell in Cell Libraries in the Layout Manager, and choose Rename Layout Cell. This dialog
box contains the following options.
Field

Description

New Cell Name

Enter the new name for the artwork cell. Only letters, numbers and underscores are allowed.

Do Not Synchronize
Instances

Do not find other instances of this cell in the project and do not change any other names.

Synchronize Instances Find all occurrences of the original cell name in the current library and change all occurrences
in This Library
to the new name.
Synchronize Instances Find all occurrences of the original cell name in all loaded libraries for the project and change
in All Loaded Libraries all occurrences to the new cell name.
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Import DXF File Dialog Box

The Import DXF File dialog box allows you to import a DXF file and select its units. To access this dialog box, right-click
Cell Libraries in the Layout Manager, choose Import DXF Library, select a library and open it, and choose Import DXF File.
This dialog box contains the following option:
Field

Description

What Is the Unit for
This DXF File?

Select the units in which the DXF file should be drawn. There is no unit information in a DXF
file so you must supply this information to the Microwave Office program. The available units
are:
femtometer(fm)
picometer(pm)
nanometer(nm)
micron(um)
millimeter(mm)
centimeter(cm)
meter(m)
mil
inch
foot

Join

Join open polylines:

If selected, the import process attempts to turn polylines into polygons if
the begin and end points are within the Join tolerance of each other.Join tolerance: The maximum
distance between polyline begin and end points to allow joining them as polygons.
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Cell Options Dialog Box: Layout Tab

The Cell Options dialog box Layout tab allows you to set properties for a given instance of a layout cell. To access this
dialog box, create a schematic, choose View > View Layout, right-click a layout cell, and choose Shape Properties. This
dialog box shows the options for a shape that is a 3D pCell. This dialog box contains the following options:
Field

Description

Line Type

Applies only to configured cells that use the LPF file to configure their model layers. There is
a line type entry for each line type definition in the LPF file.

Layer Mapping

Select the layer mapping table (from model layers to drawing layers) that is applied to the
selected layout cell instance.

Orientation

Flipped: (Non-3D pCell only) Flip the cell instance from the normal orientation.
Angle (Non-3D pCell only): Set the angle of orientation. For normal orientation,

specify 0

degrees.
Rotate about z: (3D pCell only): Set the z angle of orientation when a 3D pCell is used.
Rotate about y: (3D pCell only): Set the y angle of orientation when a 3D pCell is used.
Rotate about x: (3D pCell only): Set the x angle of orientation when a 3D pCell is used.

Z Position (3D pCell
only)

EM layer:

The recommended method for offsetting 3D pCells or subcircuits in the Z-direction
is to set the base Z position for a 3D pCell or subcircuit by specifying an EM layer from the
Stackup. If this is option is grayed, you need to specify a Stackup for 3D view on the (schematic)
Options dialog box Schematic tab for both the subcircuit and the parent schematic. See “Options
Dialog Box: Schematic Tab” for more information.
Offset: Additional control for the Z position of the 3D pCell or subcircuit. This option should
only be an offset from an EM layer specified in this section.
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Cell Options Dialog Box: Layout Tab
Field

Description

Freeze

Freezes the cell position to prevent it from being moved with the mouse or via coordinate entry.
Frozen cells, like anchored cells, do not move when you snap together the layout. Frozen cells
exhibit a weaker form of snapping than other cells, and thus different behavior than anchor cells.
With anchored cells, adjacent layout cells attempt to readjust so that they snap to the anchored
cell, while with frozen cells, the adjacent cells do not always try to snap to the frozen cell. If
you want to make another layout cell snap to a frozen cell, try selecting the frozen cell and then
snap the layout together. There can be multiple frozen cells within a layout.

Use for Anchor

"Anchors" one cell within a layout. The anchored cell remains in a fixed location, and all other
cells adjust themselves accordingly when you change circuit parameters and resize objects.
There can be multiple objects anchored per schematic. Each anchored object stays in a fixed
position when you snap together the layout. Unlike the Freeze option, you can move anchored
cells with the mouse (or with coordinate entry). Selecting both Use for anchor and Freeze check
boxes causes the cell to be used as an anchored cell. Only the anchored layout objects at the top
level of a hierarchy are used to anchor the layout cells.

Stretch to Fit

For use with the TRACE elements. For example, if this option is set for an MTRACE, then the
MTRACE automatically stretches to fit between two other cells when you snap together the
layout.

EM Extraction Options

Enable: Select to enable the cell for extraction.
Group name:: Name of the extraction group for

the cell, only used if extraction is enabled.

Clipped by simulation When selected, 3D EM cells outside of the simulation boundary are not included in the simulation.
boundary
If a 3D EM cell is on both sides of the boundary, only the shapes in the simulation boundary
are simulated.
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Cell Options Dialog Box: Faces Tab

The Cell Options dialog box Faces tab allows you to specify options related to the face properties of a cell. To access
this dialog box, create a schematic, choose View > View Layout, right-click a layout cell, and choose Shape Properties.
This dialog box contains the following options:
Field

Description

Face

Select the face number of the current element to edit.

Snap To

Choose which face of a layout cell that you want the current face to snap to. For example, a
FET has two source leads in layout but is represented by one node in a schematic. The source
FETs faces are named FET3A and FET3B. Attached to that node are two MLIN elements called
MLIN_A and MLIN_B. To connect face 2 of MLIN_A to the first source face: 1. Select MLIN_A
in the Layout View. Right-click and choose Shape Properties. 2. Click the Faces tab. 3. In Face,
select 2. 4. In Snap to, select FET3A.

Snap to Adjacent

Enables snapping operations.

Multi-Layer Drawing Specify how the multi-layer cells are drawn at the connection faces. The following displays the
left ends of the lines set as Inside, Outside, and Flush.
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Cell Options Dialog Box: Faces Tab
Field

Description

Face Justification

Specify how two adjacent cells connect together. In addition to the standard justification options,
you can select an offset (including rotation) that allows the relative positions between two
connecting cells to be defined.

Area Pins

Enable pin area:

When not selected, any area pins are disabled, so connections must be at the
default face of the area pin rather than just overlapping the area pin.
Extract pins connected to extracted objects: This setting overrides default behavior for how area
pins are included in extraction when items connected to them are extracted. See “Area Pins”
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Cell Options Dialog Box: Parameters Tab

The Cell Options dialog box Parameters tab allows you to view and modify cell parameter values. To access this dialog
box, while in a schematic window, choose View > View Layout, right-click a layout cell that has parameters associated
with it, and choose Shape Properties.
See “Using Property Grids” for details on using property grids.
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Create Pin Dialog Box: Cell Pin Tab

The Create Pin dialog box Cell Pin tab allows you to specify options related to a cell pin. To access this tab, select an
artwork cell, right-click the cell and choose Create Pin. For option descriptions, see “Properties Dialog Box: Cell Pin Tab
”.
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Restrict Selection (Layouts) Dialog Box

The Restrict Selection (Layouts) dialog box allows you to prevent the selection of specified item types such as graphic
primitives, text, and iNets. To access this dialog box, in a layout window, right-click in a blank space and choose Restrict
Selection. This dialog box can contain the following options:
Field

Description

Graphic primitives

Shapes drawn on the layout using Draw > Arc, Draw > Circle, Draw > Ellipse, Draw > Polygon, Draw
> Polyline, or Draw > Rectangle.

Text

Text drawn on the layout using Draw > Text.

Pcells

Programmable cell objects.

Artwork cells

Non-parameterized GDSII or DXF cells used as layout cells.

Subcircuit layout cells Layout objects associated with a subcircuit.
iNets

Intelligent interconnects between layout objects.

EM ports

Edge, Internal, or Via Ports on an EM document.

Frozen object

Objects to which the Freeze command is applied to prevent their movement during operations.

Obj clipped by view

An object clipped by the Layout View.

Obj bounds exceed
view

Layout objects whose bounding rectangle falls outside the current Layout View.

Dialog Box Reference10–61

Restrict Selection (Artwork Cell) Dialog Box

Restrict Selection (Artwork Cell) Dialog Box

The Restrict Selection (Artwork Cell) dialog box allows you to prevent the selection of specified item types such as
graphic primitives, cell ports, and area pins. To access this dialog box, in an artwork cell window, right-click in a blank
space and choose Restrict Selection. This dialog box can contain the following options:
Field

Description

Graphic primitives

Shapes drawn on the artwork cell using Draw > Arc, Draw > Circle, Draw > Ellipse, Draw > Polygon,
Draw > Polyline, or Draw > Rectangle.

Text

Text drawn on the artwork cell using Draw > Text.

Pcells

Programmable cell objects.

Artwork cells

Non-parameterized GDSII or DXF cells used as layout cells.

Cell ports

Layout faces added to artwork cells in the Artwork Cell Editor.

Area pins

A specified area on a cell port which allows connections.

Frozen object

Objects to which the Freeze command is applied to prevent their movement during operations.

Obj clipped by view

An object clipped by the Layout View.

Obj bounds exceed
view

Objects whose bounding rectangle falls outside the current Layout View.
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Layout Editor Mode Settings Dialog Box

The Layout Editor Mode Settings dialog box is used to define various layout editing options as convenient configurations
with different settings to enable users to switch between them rapidly and easily depending on the kind of layout work
performed (editing, routing, placement, or custom work). The configurations (tabs) in this dialog box are created using
the Layout Mode Properties dialog box. To access this dialog box, in a layout window, choose Layout > Layout Mode
Properties. This dialog box contains the following options:
Field

Description

Restrict selection

Disallows selection in the layout window of the selected classes of objects.

Draw dim

Allows dimmed color to be used to draw the selected classes of objects to make other objects
stand out.

Outline only

Allow only the outline to be drawn for the selected classes of objects, to improve drawing
performance and reduce cluttering.

Not visible

Allows selected classes of objects not to be drawn at all, to improve drawing performance and
reduce cluttering.

Minimize detail

Allows selected classes of objects to be drawn at minimum detail when they are too small to be
drawn at full detail. For example, a polygon may be draw as a line with a thick width instead
of a filled pattern. Text is drawn as a box instead of fully readable text. Minimum detail drawing
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Layout Editor Mode Settings Dialog Box
Field

Description
is only applied at certain pre-defined sizes to improve drawing performance and reduce cluttering.
This option affects zoom and view all commands.

Viewing detail

Regulates the level of viewing detail (LOD) on all objects based on their aperture size, to improve
drawing performance and reduce cluttering. This option affects zoom and view all commands.
All details: No optimization, and all objects are drawn regardless of their size.
Normal details: Some objects are not drawn due to their size (> 2 pixels).
Low detail: More objects are not drawn due to their size (> 5 pixels).
Very low details: More objects are not drawn due to their size (> 10 pixels).

Hierarchical viewing

Subcircuit boundaries: Display subcircuit boundaries.
Instances as boxes: Display subcells (pCells or subcircuits) as instance boxes (regardless of their
complexity) through the specified Level.
Instance labels: Display subcircuit names.
Draw pins: When Instances as boxes is selected, displays area pins as additions to the instance

box if they exist.
Selection options

Manual Select

requires Shift-clicking an object to select it (prevents accidental selection of

objects).
Auto Select enables simple selection of an object with one click.
Auto zoom with manual selection: In Manual Select mode, automatically

magnifies the area you
select to view (by clicking and dragging the magnifying glass cursor over the desired area.)
When not selected you must right-click, choose View Area, and then select the area you want to
magnify.
Auto select on right-click: In Auto Select mode, enables auto-selection of objects which are
right-clicked.
Layer configuration

Allows use of a predefined layer configuration with any layout editing mode. The layer
configurations are set in the Drawing Layer Options dialog box Configuration option. After
creating multiple layer configurations and links with layout editing mode, the switch between
various layer configurations is quick and easy.
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Layout Editor Mode Settings Dialog Box
Field

Description

Drawing options

Specify options that affect the display of layout attributes.
Draw abstract: Only applies to the DrawRectArray construct in a pCell to reduce the number of
rectangles drawn.
Draw all rat lines: Draw ratlines at the current level of hierarchy and all lower levels used for the
current layout.
Draw selection boxes: Draw selection indicator boxes at the corners of the selected object's
bounding box.
Draw crosshairs: Draw crosshairs during move operations.
Draw path centerlines: Draw the centerline (line connecting the vertices of the path) of any layout
objects that are paths.
Draw origin markers: Draw a visual indicator of every layout cell's origin.
Draw anchors: Draw an anchor or freeze indicator on anchored or frozen objects.
Draw route vias as X: Draw vias as an "X" of the overlapping metals where the via exists, instead
of the full detail of the vias.
Draw cell faces: Draw a perpendicular green line from the face to help determine orientation.
Show obscured outlines: Draw shape outlines for all shapes on top of the shape fill patterns. This
helps to identify shapes in layouts with many overlapping shapes. Cadence does not recommend
using this setting if using positive and negative layers, as the layout will not look very good.
Dynamic flight lines: Draw ratlines to the end of the current iNet during the routing operation.
When not selected, ratlines do not update until the iNet route operation is complete.
Show extraction ports: Display extraction ports in the schematic layout. These are used for helping
set Cadence AXIEM® EM simulator port properties when using extraction.
Make dim layers extra dim: Apply an extra dim level to dimmed layers.
Dim lower levels of hierarchy: Dim the color of any subcells (pCell, artwork cells, or subcircuit
cells).
Dynamic selection highlight: As a visual aid in selection, displays (by default) a dotted yellow
outline on the layout object that the cursor is over to help you determine what is selected if you
click at that point. The attributes of the highlight drawing are controlled by the system layer
DynamicHighlight so you can change the default. This feature is useful in dense layouts or
layouts where many objects are stacked and it is hard to determine what you are selecting when
clicking.
View text always readable: Modifies how View text is drawn so that it generally displays
left-to-right on the screen. Layout has two types of text in layout: Polygon text and View text.
Polygon text can be output so that it is used for instances like a label on a chip. View text is
written with normal fonts and can be used to write on the design, but is never output. You can
rotate or flip View text when using subcircuits, or by performing these operations directly on
the text object. The angle of the text can be 90 to -90 degrees before it is changed. If the angle
exceeds 90 degrees, it is flipped to maintain its left-to-right orientation.
Flight lines nearest pin edge: Draw ratline connections to the nearest area pin edge. When not
selected, ratlines connect to the cell face.
Selected pin/face width: Specify the width of the selected pin/face.
Paste offset as grid mult: For future implementation.
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Layout Editor Mode Settings Dialog Box
Field

Description

Routing options

Start routes on pin layer: The first and last segment of an iNet route use the same layer as the pin

being routed from, if being connected to an area pin. This overrides the routing layers specified
in the iNet Routing dialog box.
Start route same width as pin: The first and last segment of an iNet route use the same width as
the pin being routed from, if they are connected to an area pin. This option overrides the routing
widths specified in the iNet Routing dialog box.
Add vias in standalone routes: Adds a via between metal layers even in standalone iNet routes
(the iNet routes not associated with any rat lines). You can draw a standalone route by choosing
Draw > Draw Route without selecting a rat line.
Minimum spacing guides: Enables minimum spacing route guidelines while routing, as defined
by SEPARATION rules in the DRC rules file.
Reject clicks inside min spacing: Does not allow single clicks to place a route inside the minimum
spacing region around shapes. Double-clicks are still allowed to complete the routes. This option
is only available when Minimum spacing guides is selected.
Constrain to outside min spacing: Restricts the routing to outside of the minimum spacing guides.
When routing, if a segment starts approaching a shape, its progress is constrained when the
route reaches the minimum spacing guide. To temporarily override this behavior press the Alt
key to allow a route connection to a shape. This option is only available when Minimum spacing
guides is selected.
Disable self avoidance guides: Turns off the minimum spacing route guide for the same route
net, but leaves the guides in place for all other structures.
Alignment gravity: Select the gravity snap strength for alignment with guides during routing.
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Layout Mode Properties Dialog Box

The Layout Mode Properties dialog box is used to add, remove, edit, or reorder the layout mode configurations that
display as tabs in the Layout Editor Mode Settings dialog box, where various layout editing options are grouped together
as convenient configurations with different settings to enable you to switch between them rapidly and easily depending
on the kind of layout work performed (editing, routing, placement or custom work). To access this dialog box, in a layout
window, choose Layout > Layout Mode Manager. This dialog box contains the following options:
Field

Description

Layout mode sets

Lists all predefined layout modes.

Add

Displays the Layout Editor Mode Settings dialog box for creation of and definition of a layout
mode.

Delete

Deletes the selected layout mode.

Edit

Displays the Layout Editor Mode Settings dialog box for editing of the selected layout mode.

Move up / Move down Reorders the selected layout mode on the Layout Editor Mode toolbar button drop-down list,
and in the tab order of the Layout Editor Mode Settings dialog box.
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Connectivity Highlight Rules Dialog Box

The Connectivity Highlight Rules dialog box has two main uses. The first is to control which rules are run during
connectivity analysis. The second is to add to, remove, or edit the current list of connectivity rules. See “Connectivity
Checking ” for details on how to use the Connectivity Checker and “Connectivity Rules” for an explanation of connectivity
rules and syntax. To access this dialog box, in a layout window, choose Verify > Highlight Connectivity Rules. This dialog
box contains the following options:
Field

Description

Connect Rules

The LPF file name displays at the top of this section (more than one displays if the project has
multiple LPFs). The rules for each LPF are listed below it. If there are syntax errors in the rules
(for example, misspelling or wrong keywords), the rule is highlighted in red and you must fix
the rule before using it. If you use a layer name that does not exist, the rule is highlighted in
yellow and you can either fix the layer name for the rule or add or rename a drawing layer to
match the rule.
Select the check box next to a rule to use it during the connectivity analysis; select it again to
deselect it and ignore the rule. Double-click a rule to edit the rule.

On Highlight
Connectivity All

Displays this dialog box every time you run the Highlight All Connectivity command (choose
Verify > Highlight Connectivity All). The connectivity displays after you click OK.

On Highlight
Connectivity Probe

Displays this dialog box every time you run the Highlight Connectivity Probe command (choose
Verify > Highlight Connectivity Probe). The connectivity displays after you click OK.

Insert Rule

Inserts a new blank rule below the currently selected rule, ready for text entry.

Delete Rule

Deletes the currently selected rule from the list.
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Error Marker Options Dialog Box

The Error Marker Options dialog box allows you to customize how DRC or LVS errors display when navigating through
errors. See “Working with DRC Errors ” for details on working with DRC and LVS errors. These options are remembered
between AWR Design Environment software sessions. To access this dialog box, in the window listing all DRC or LVS
errors, right-click an error and choose Error Marker Options. This dialog box contains the following options:
Field

Description

Show Error Markers

All shows all errors when navigating to specific errors.
Selected only shows only the selected error when navigating

to specific errors.

Show Tooltips

Displays the rule that the highlighted error violates.

Flashing Markers

Flashes error indicators on screen to more easily identify their locations.

Thick Error Markers

Draws error indicators with thicker lines to more easily identify their locations.

Zoom to Selected Error Zooms in on the error on which you double-click while navigating errors. The amount of zoom
is determined by the Zoom Percentage: setting.
Zoom Percentage:

Controls the zoom magnification for errors when using Zoom to Selected Error. 100 percent
zooms to the bounding box of the error marker so the error marker fills the entire screen. Smaller
numbers zoom out further from the bounding box of the error marker.

Max Markers to Draw Limits the number of error markers that are drawn to keep the layout responsive.
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Make New GDS Cell Dialog Box

The Make New GDS Cell dialog box allows you to create a new GDSII cell in a specified GDSII library with items you
select in your schematic or artwork cell layout. If the library and cell already exist, you are prompted for a new name.
If the original layout is a GDSII cell, the shapes are copied to the same named layers. If the original layout is a DXF cell
or a schematic layout, shapes on the drawing layers for the schematic layout must be mapped to GDSII layers through
the model layer mapping table, and NOT through export mapping tables in the project. If there are multiple model layer
mappings in the project, the first one is used. In this map, the drawing layer is listed in the Drawing Layer column and it
checks if the Model Layer is in a GDSII format, such as 2_0. In the model layer mappings each model layer is unique,
however, you can map multiple model layers to the same drawing layer. In this case, the last valid mapping found in the
list is used. Finally, if there is no GDSII formatted match found, a new GDSII model layer is added. To access this dialog
box, select the desired items in your schematic or artwork cell layout and choose Layout > Make GDSII Cell. This dialog
box contains the following options:
Field

Description

Library Name

Select an existing library name or type a new library name.

Cell name

Type in the name of the new cell.

Flatten new cell

If selected, the new cell flattens all hierarchy. If not selected, the original hierarchy is copied.
When viewing this dialog box from a schematic layout, this option is always selected.

Copy hierarchy

If selected, the new cell contain copies of the entire hierarchy for the cell. If not selected, the
top cell is copied and any hierarchy references the original library and cells.
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Copy Cell Dialog Box

The Copy Cell dialog box allows you to create a new cell in a specified library (GDSII or DXF) with cells you select in
an artwork cell. If the library and cell already exist, you are prompted for a new name.
If copying between the same type cells (DXF to DXF or GDSII to GDSII), the shapes remain on the original layers. If
copying between different library types, shapes in the cell must be mapped to layers in the opposite type through the
model layer mapping table, and NOT through export mapping tables in the project. If there are multiple model layer
mappings in the project, the first one is used. To access this dialog box, in the Layout Manager, select the desired cell
under a library node, then right-click and choose Copy Layout Cell. This dialog box contains the following options:
Field

Description

Library Name

Select an existing library name or type a new library name.

Cell name

Type in the name of the new cell.

Flatten new cell

If selected, the new cell flattens all hierarchy. If not selected, the original hierarchy is copied.

Copy Hierarchy

If selected, the new cell contain copies of the entire hierarchy for the cell. If not selected, the
top cell is copied and any hierarchy references the original library and cells.
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Merge Cell Libraries Dialog Box

The Merge Cell Libraries dialog box allows you to merge two cell libraries into one library.
If merging between the same type cells (DXF to DXF or GDSII to GDSII), the shapes remain on the original layers. If
merging between different library types, shapes in the cell must be mapped to layers in the opposite type through the
model layer mapping table, and NOT through export mapping tables in the project. If there are multiple model layer
mappings in the project, the first one is used. To access this dialog box, in the Layout Manager Cell Libraries node, with
more than one library loaded, right-click a library node name and choose Merge Cell Libraries. This dialog box contains
the following options:
Field

Description

Choose Library to
Merge

Select an existing library to merge into the currently selected library.
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Modify Selected Vertices Dialog Box

The Modify Selected Vertices dialog box allows you to fillet or chamfer polygon vertices. To access this dialog box,
select one or more polygon shapes, right-click and choose Edit Points, then select one or more vertices, right-click and
choose Add Fillet/Chamfer. See “Filleting or Chamfering Vertices” for details.
This dialog box contains the following options:
Field

Description

Create

Fillets with Arcs creates Arc segment fillets. Fillets with Points creates a filleted arc with polygon
points, using the Layout Options dialog box Layout tab Number of points/circle setting. Chamfers

creates chamfered corners.
When vertices too
close

When one or both of the segments connecting to a selected vertex is too short to support a fillet
or chamfer of the desired radius, select Reduce Radius to use a smaller fillet/chamfer radius to
fit in the available space or Skip Vertex to leave the vertex unmodified.

Outer Radius

The fillet/chamfer radius to use for outside corners.

Outer Radius

The fillet/chamfer radius to use for inside corners.

Dialog Box Reference10–73

Modify Corners Dialog Box

Modify Corners Dialog Box

This command performs the same operation as the Layer Corner modifier, but on the selected shape instead of all shapes
on a layer. See “Properties Dialog Box: Layer Corner Modifier ” for parameter details.
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Modifier Properties Dialog Box: Shape Modifiers tab

The Modifier Properties dialog box Shape Modifiers tab allows you to change the order in which the shape modifiers are
executed as well as edit some properties. To access this dialog box, in a layout choose Layout > Modifier Properties. See
“Shape/Layer Modifiers” for details. This dialog box contains the following options:
Field

Description

Index

The order in which the modifier is executed.

ID

The modifier identifier.

Name

The modifier name.

Description

A short description of the modifier.

Enabled

Specifies if the modifier displays, and enables/disables the modifier.

Priority

Value specified by the modifier type; helps determine the initial order of modifiers.

Move Down/Move Up Changes the order of operation of the modifiers.
arrow buttons
Properties button

Displays modifier parameter properties.

Preview

Displays a preview of modifications.

When you select a specific modifier row in this open dialog box, the modifier in the layout is highlighted as shown in
the following figure.
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Modifier Properties Dialog Box: Shape Modifiers tab
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Modifier Properties Dialog Box: Layer Modifiers tab

The Modifier Properties dialog box Layer Modifiers tab allows you to control all layout or shape modifiers in the active
layout. To access this dialog box, in a layout choose Layout > Modifier Properties. See “Shape/Layer Modifiers” for details.
This dialog box contains the following options:
Field

Description

Index

The order in which the modifier is executed.

ID

The modifier identifier.

Name

The modifier name.

Description

A short description of the modifier.

Enabled

Specifies if the modifier displays, and enables/disables the modifier.

Priority

Value specified by the modifier type; helps determine the initial order of modifiers.

Move Down/Move Up Changes the order of operation of the modifiers.
arrow buttons
Properties button

Displays modifier parameter properties.

Preview

Displays a preview of modifications.

When you select a specific modifier row in this open dialog box, the modifier in the layout is highlighted as shown in
the following figure.
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Modifier Properties Dialog Box: Layer Modifiers tab
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Properties Dialog Box: Edge Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Edge Modifier” for details on adding the Edge modifier. See “Parameterizing EM
Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

L

The modifier length.

FE
a

Controls where on the modifier the fixed end is placed; options are "Left", "Right" and "Center".

*S

Size of the arrows drawing the modifier in layout.

*ST

The stretch type; options are "Lock Angles" or "Single Vertex".

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The following figures show the FE parameter options. The top shape is before the L parameter changes to a new value
and the bottom shape is after the change. In each case, notice the FE parameter setting and the small square that indicates
which end of the modifier is locked. The first figure shows the left edge locked.
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The following figure shows the right edge locked.

The following figure shows the center locked.

The following figures show the shapes with ST parameter settings. The top shape is before the L parameter changes to
a new value and the bottom shape is after the change. The first figure shows the shape with the ST parameter set to "Lock
Angles" and shows that the angles of the polygon will not change.

The following figure shows the ST parameter set to "Single Vertex" where only the specified edge changes, causing the
polygon to have different angles.
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Properties Dialog Box: Point Stretch Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Point Stretch Modifier” for details on adding the Point Stretch modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

SP

The spacing of the modifier.

*ANG

The fixed angle between the end points of the modifier.

FE

Controls where on the modifier the fixed end is placed; options are "Left", "Right" and "Center".

a

*S

Size of the arrows drawing the modifier in layout.

*ST

The stretch type; options are "Lock Angles" or "Single Vertex".

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.
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Properties Dialog Box: Width Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Width Modifier” for details on adding the Width modifier. See “Parameterizing
EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier

W

The modifier width.

*WT

The width type; options are "Path" or "Segment".

a

Size of the arrows drawing the modifier in layout.

*S
a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The behavior of the Width Type (WT) parameter depends on the type of shape on which the modifier is operating, either
a path or iNet. If you set WT to "Segment" and the modifier is on a path shape, an error displays in the Status Window
to indicate that this mode is not allowed for the object connected to. A path by definition only has one width, so it is not
possible to try to modify just one segment of the current path. If you have multiple modifiers on a path shape with the
WT parameter set to "Path", when one W parameter is changed, all of the modifiers change to have the same value.
The WT parameter allows you to change the width of the entire iNet when set to "Path", or just the segment attached to
when set to "Segment". The following figure shows a simple iNet where each segment has a path modifier.
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Changing the W parameter for any of the modifiers only edits that segment. If one of the path modifiers has WT set to
"Path", then the entire iNet has that width, as shown in the following figure where the top left modifier is changed.

After changing this parameter, the others do not update immediately. You must change the width (W) of a modifier or
choose Layout > Update Modifiers.
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Properties Dialog Box: Radius Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Radius Modifier” for details on adding the Circle modifier. See “Parameterizing
EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

R

The modifier radius.
a

*S

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter
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Properties Dialog Box: Ellipse Size Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Ellipse Size Modifier” for details on adding the Ellipse modifier. See “Parameterizing
EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

W

The modifier width.

H

The modifier height.
a

*S

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

10–86 AWR Design Environment

Properties Dialog Box: Array Modifier

Properties Dialog Box: Array Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Array Modifier” for details on adding the Array modifier. See “Parameterizing
EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

R

The number of rows of the modifier.

C

The number of columns of the modifier.

DX

The spacing in the x direction of the modifier.

DY

The spacing in the y direction of the modifier.

DY

The spacing in the y direction of the modifier.

ST

The spacing type of the modifier; the options are "Edge-to-Edge" or "Center-to-Center".

a

*S

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter
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Properties Dialog Box: Spacing Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Spacing Modifier” for details on adding the Spacing modifier. See “Parameterizing
EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

SP

The spacing of the modifier.

FE

Controls where on the modifier the fixed end is placed; options are "Left", "Right" and "Center".

a

*S

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The following figures show the FE parameter options. The top shape is before the S parameter changes to a new value
and the bottom shape is after the change. In each case, notice the FE parameter setting and the small square that indicates
which end of the modifier is locked. The first figure shows the left edge locked.
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The following figure shows the right edge locked.

The following figure shows the center locked.
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Properties Dialog Box: Polar Spacing Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Polar Spacing Modifier” for details on adding the Polar Spacing modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

SP

The spacing of the modifier.

ANG

The fixed angle between the end points of the modifier.

a

*S

Size of the arrows drawing the modifier in layout.

SRT

Controls if the second shape also rotates with the angle parameter.

ISA

Controls the initial rotation of the second shape.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The following figures show the relationship between the ANG, SRT, and ISA parameters. These are the two shapes
before the shape modifier is added.
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The following figure shows the layout after the modifier is added. In this example, the lower left shape is selected first
and there is a reference shape (notice the angle indicator at this end of the modifier). The SRT parameter is set to Fixed
and the upper right shape has the same rotation it had before adding the modifier.

The following figure shows the SRT parameter set to Rotate. Notice that the upper right shape is rotated by the same
amount as the ANG parameter.
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Properties Dialog Box: Polar Spacing Modifier

The following figure shows the SRT parameter set to Fixed and the ISA parameter set to "-45". Notice that the upper
right shape is rotated by the ISA amount.
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Properties Dialog Box: Stretch Area Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Stretch Area Modifier” for details on adding the Stretch Area modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

DX

The movement in the x direction of the modifier.

DY

The movement in the y direction of the modifier.

LT

Controls what layers are affected by this modifier; the options are "All Layers" and "Single
Layer".

LI

Controls which layer is modified if the LT parameter is set to "Single Layer". The available
options are all drawing layers in your project.

*Sa

Size of the arrows drawing the modifier in layout.

*ST

The stretch type; options are "Lock Angles" or "Single Vertex".

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The following figures show the shapes with ST parameter settings. The top shape shows the original shape with the upper
right corner modified with a stretch area modifier.
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With the ST parameter set to "Lock Angles", notice how the angles of the shape have not changed; the shape is still a
rectangle.

With the ST parameter set to "Single Vertex", notice how the angles of the shape have changed; the shape is no longer
a rectangle.
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Properties Dialog Box: Control Point Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Control Point Modifier” for details on adding the Control Point modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

ID

The modifier identifier.

DX

The movement in the x direction of the modifier.

DY

The movement in the y direction of the modifier.

a

*S

Size of the arrows drawing the modifier in layout.

*ST

The stretch type; options are "Lock Angles" or "Single Vertex".

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The control point modifier stretches control points (drag handles) similar to the way in which the stretch area modifier
stretches vertices. See “Properties Dialog Box: Stretch Area Modifier ” for details.
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Properties Dialog Box: Layer Offset Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Layer Offset Modifier” for details on adding the layer offset modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

OFFX

The movement in the x direction for the shapes on the specified shape.

OFFY

The movement in the y direction for the shapes on the specified shape.

LI

Controls which layer is modified. The available options are all drawing layers in your project.
a

*S

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter
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Properties Dialog Box: Layer Resize Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Layer Resize Modifier” for details on adding the layer resize modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

OS

The absolute amount to resize shapes on the specified shape.

LI

Controls which layer is modified. The available options are all drawing layers in your project.

MF

Controls how many layout Data Base Units (DBUs) are around the shape when considering if
two shapes are close enough to merge.

*Sa

Size of the arrows drawing the modifier in layout.

OP

Operation for the resize. “Resize” (the default) resizes the shapes. “Copy, Resize” copies the
shapes to a new layer and then resizes the copies relative to the original shapes, giving you the
original shapes plus the copied and resized shapes as output.

CLI

Specifies the copy layer index. This is the name of the layer to which the shapes are copied if
the OP mode is “Copy, Resize”.

RCS

Specifies the Resize Corner Style which describes how acute angles are controlled during resize.
For Rounded, additional points are inserted in the corner to round it. For Sharp, the corner is
resized but remains with just a single point in the corner.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter
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Properties Dialog Box: Layer Boolean Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Layer Boolean Modifier” for details on adding the layer resize modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

LIA

Controls which layer is modified, specified as layer A. The available options are all drawing
layers in your project.

LIB

Controls which layer is modified, specified as layer B. The available options are all drawing
layers in your project.

LIR

Controls on which layer the results for the Boolean operations are placed. The available options
are all drawing layers in your project.

OP

Controls the type of Boolean operation. The options are "OR", "AND", "XOR", "A_SUB_B",
"B_SUB_A", "A_TOUCHES_B", and "B_TOUCHES_A". For difference and touches operations
such as "A_SUB_B" and "A_TOUCHES_B" the values for "LIA" and "LIB" cannot be the
same layer. See the "Parameter Details" section for more information.

KEEP LIA

Controls whether the shapes on the LIA layer are deleted ("NO") or retained ("YES"). See the
"Parameter Details" section for more information.

KEEP LIB

Controls whether the shapes on the LIB layer are deleted ("NO") or retained ("YES"). See the
"Parameter Details" section for more information.

*Sa

Size of the arrows drawing the modifier in layout.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.

* indicates a secondary parameter

Parameter Details
The following figures show layouts with different OP, KEEP_LIA, and KEEP_LIB parameter options set.
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OP Option
The first figure is an unmodified layout; the succeeding layouts reflect selection of the different OP options as identified.

The OP parameter is set to "OR".

The OP parameter is set to "AND".

The OP parameter is set to "XOR".
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The OP parameter is set to "A_SUB_B".

The OP parameter is set to "B_SUB_A".

The OP parameter is set to "A_TOUCHES_B".
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The OP parameter is set to "B_TOUCHES_A".

KEEP_LIA and KEEP_LIB Options
The following layouts reflect selection of the KEEP_LIA and KEEP_LIB options as identified.
KEEP_LIA and KEEP_LIB are both set to "NO".
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KEEP_LIA is set to "YES" and KEEP_LIB is set to "NO".

KEEP_LIA is set to "NO" and KEEP_LIB is set to "YES".

KEEP_LIA and KEEP_LIB are both set to "YES".
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Properties Dialog Box: Layer Corner Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Layer Corner Modifier” for details on adding the layer corner modifier. See
“Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

LI

Layer Index for the layer on which you want to modify shape corners.

OPOC

Operation to apply to the outer corners of the modified shapes.

OPIC

Operation to apply to the inner corners of the modified shapes.

ROC

Radius value for operations applied to outer corners.

RIC

Radius value for operations applied to inner corners.

MINANG

Minimum corner angle to which the operations should apply.

MAXANG

Maximum corner angle to which the operations should apply.

RT

Radius Type.

RMINOC

Maximum corner angle to which the operations should apply.

RMINIC

Maximum corner angle to which the operations should apply.

a

*S

Size of the arrows drawing the modifier in layout.

*CPO

Corner priority order, determines if the outer or inner corners are modified first.

*PM

Pre-Merge Shapes Mode. Determines whether the shapes on the layer are merged (union or
Boolean OR operation) prior to the corner modifiers application.

*SI

Skip Intersections. When enabled, the modifier skips corners that lie on the edge of another
shape on the same layer.

a

Default modifier size is controlled by the default font height setting in the project. See the “Layout Options Dialog Box: Layout Font Tab ” for details.
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* indicates a secondary parameter

Parameter Details
The parameters on this modifier control how the corners of the shapes in the layout design are modified when the layout
is placed as an instance into other designs. The parameters provide individual control over how the modifier affects outer
corners (those ending in OC) and inner corners (those ending in IC). The following figure defines the different corner
types.

Layer Index (LI)
The layer index determines which layer in the layout is affected by the corner modifications. When the layout is placed
as an instance, the layer corner modifier affects the shapes on this layer in the placement. If more than one layer needs
to be modified within the layout, you can add multiple layer modifiers to the design and configure them so that each one
affects a different layer.
Operation for Outer Corners (OPOC)
The corner modifier supports two types of corner operations. Fillet rounds the shapes corners.

Chamber

cuts the corner at an angle half way between the two entering side angles.
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Operation for Inner Corners (OPIC)
You can also apply the two types of corner operations to inner corners of a geometric shape. The OPIC parameter specifies
what operations are applied to the inner corners. By default the value is set to None (no changes to the inner corners).
Available options are Fillet which rounds the inner corners,

and Chamfer which angles the inner corners.

By adjusting the values of the operation for inner corners or outer corners, you can apply the modification to the inner
corners only, to the outer corners only, or to both or neither inner and outer corners.
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NOTE: Different parameters define operation for outer corners and inner corners, so the operations applied to these
corners can be set independently. For example, if a process requires it, you can specify Fillet for (OPOC) Operation for
Outer Corners and Chamfer for (OPIC) Operation for Inner Corners.
Radius for Outer Corners (ROC)
The radius value controls the amount of fillet or chamfer applied to the outer corners of the shapes. The radius value is
measured from the corner point out along the incident segments to define the region to modify. The following figure
shows its application for the fillet operation on a rectangle shape.

For the chamfer operation the radius parameter defines the amount of the corner to cut from the shape. The following
figure shows the radius measurements for a shape and the results after the chamfer operation is applied.

The previous figures demonstrate an important point regarding the radius values for the chamfer and fillet operations.
Each corner has associated with it a length R on the two adjacent sides of the corner point, so for the corner operation
to apply to a corner the adjacent sides must be a length of 2 * R on both sides of the corner point. The previous figure
shows the operations applied to adjacent corners. In order for the operations to be applied correctly to two adjacent
corners the length of a side must be at least 2 * RMIN; where RMIN is the minimum radius (see the "Radius Type (RT)"
section). If the length of a side between adjacent corners is not at least 2 * RMIN, the operations overlap and cannot be
applied, since the modified regions overlap on that side. If the length of a side is not sufficient, the operation is not applied
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to that shape. This is also true for the distance between inner and outer corners. Each corner has a length of RMIN
associated with the corner, so the distance between the inner and outer corner must be the sum of their RMIN values for
the operation to be applied to either the inner or outer corners or both (see the "Corner Priority Order (CPO)" section).
Radius for Inner Corners (RIC)
The radius value for inner corners is applied in a similar manner as for outer corners. The radius value is the distance
measured from the corner point along the adjacent sides to which the corner modification operation is applied. It defines
the distance along the sides for the region to be filled with rounded material or triangle material for fillet and chamfer
operations.
NOTE: In addition to supporting different operations for inner and outer corners, the modifier supports different radius
values for inner and outer corner. If a process requires different radius values for inner and outer corners this can be
implemented by providing different radius values for the (ROC) Radius Outer Corner parameter and the (RIC) Radius
Inner Corner parameters.
Minimum and Maximum Angle (MINANG, MAXANG)
The minimum and maximum angle values set limits on the types of corners for modification. The angle value is measured
on the interior for outer corners and on the exterior for inner corners. In both cases the angle is the smaller of the two
angles formed by the two sides adjacent to the corner point.

This operation is only applied to corners that have an angle greater than the minimum angle and less than the maximum
angle. If an angle is less than the minimum (a sharp point) or greater than the maximum (a gradual direction change),
the operation is not applied to that corner on the shape.
Radius Type (RT)
The radius type can be fixed or variable. When RT is Fixed, the corner is modified only if the specified ROC or RIC
value can be met, otherwise the corner is not modified. When RT is Variable, the radius is reduced as much as necessary,
down to RIMINOC or RMINIC, in order to make the modification possible.
Minimum Variable Radius for Outer and Inner Corners (RMINOC and RMINIC)
When RT is Variable, these are the minimum outer and inner corner radius values.
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Corner Priority Order (CPO)
The corner priority order provides a way to control which type of corner, Inner or Outer, has the higher priority. In some
cases a side between an adjacent outer and inner corner may not be long enough to apply both the outer corner operation
and the inner corner operation. The CPO parameter controls which operation is applied first. If it is more important to
have outer corners modified rather than inner corners, the value Outer, Inner has the corner modifier first modify the outer
corners and then attempt to modify the inner corners. If the reverse is true and modifying inner corners is more important,
the value Inner, Outer modifies all inner corners first and then tries to modify the outer corners.
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Properties Dialog Box: Shape Preprocessor (SPP) Modifier

To access this dialog box, select the modifier, right-click and choose Shape Properties. See “Shape/Layer Modifiers” for
details on using shape modifiers and “Shape Preprocessor (SPP) Modifier” for details on adding the shape preprocessing
modifier.

Shape Preprocessor Rules
Shape preprocessor modifier rules are specified on the Properties dialog box Rules tab. The SPP modifier supports a
subset of the SPP rules available for use in EM structures. The syntax for the rules are identical, see “Rule Syntax”. The
following are the supported rules for the shape preprocessor modifier:
Rule

Description

BOOLEAN_OPS

Perform Boolean operations such as AND, OR, or SUBTRACT between layers or lists of layers.

RESIZE

Resize all of the shapes on a layer or list of layers.

LDELETE

Delete all of the shapes on a layer or list of layers.

REPLACE

Delete all shapes on one layer and put those shapes on another layer.

FILLET_SHAPES

Adds fillets to shapes on a layer.

Shape Preprocessor Details
In the AWR Design Environment program, support for shape processing is implemented through the use of shape
modifiers. Different types of modifiers are supported to perform operations such as resizing all the shapes on a specific
layer when an instance of the design is placed in another design. Other operations include offsetting the shapes of a
specific layer by a certain amount or performing Boolean operations between shapes such as ORing all the shapes in the
resulting instance placement. Placing shape modifiers in the master design provides a flexible and convenient graphical
method for specifying the operations to perform on instances when instances of that design are placed in other designs.
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To perform a number of operations on many layers in a design and perhaps place some of the results on temporary layers
during processing, you can place one layer modifier down for each layer and operation that is required. In some cases
this can mean placing a large number of modifiers into the master design. The SPP modifier provides a convenient and
flexible way to do this often using just a single shape modifier.
The SPP modifier uses a set of rules to specify the types of editing operations to perform on the shapes of each layer and
on shapes between layers. Rather than placing many shape modifiers you can place a single SPP modifier with a number
of rules to specify all the editing operations that need to be performed on the master design when an instance is placed.
This method performs the editing operations more efficiently than a large number of individual modifiers, since the
shapes are being processed through a single modifier. It can also lead to a much cleaner master design document.
The SPP modifier provides a clean and flexible way of specifying a number of shape modifications on a master design
when the layout is placed as instance blocks into other designs.
Importing Rules and Checking Rule Syntax
The Import button allows you to copy the rules from a separately created *.rules text file into the SPP modifiers Rules
tab.
The Verify button invokes a syntax checker to check the rules syntax. Any errors display in a separate dialog box.

Click OK and then click Yes to close the dialog box, make changes elsewhere in the design environment, and fix the error
later; or click No to keep the dialog box open, navigate to the Rules tab, and correct the error.
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Debug Cell Instance Dialog Box

The Debug Cell Instance dialog box allows you to watch interactions between shape modifiers in a parameterized
subcircuit document. To access this dialog box, select the subcircuit, then right-click and choose Debug Modified Cell
Instance. Click the Start button to disable all modifiers, and then click the Next button repeatedly to enable modifiers one
by one to observe layout changes in the subcircuit instance. See “Shape/Layer Modifiers” for details on using shape
modifiers, and “Parameterizing EM Structures” for details on how to use modifiers to parameterize EM documents.
Field

Description

Start

Initiate debug mode by disabling all modifiers.

Next

Move down to next modifier in list and enable it.

Prev

Disable current modifier in list and move back up to the previous modifier in list.

Props

Open the Modifier Properties dialog box for the last modifier enabled.

Enabled

Indicate whether the modifier is in operation or not.
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Associate Cell Dialog Box

The Associate Cell dialog box allows you to re-associate a layout cell with a schematic element that is available and that
has the correct number of ports. To access this dialog box, right-click a layout cell and choose Associate Layout Cell. This
dialog box contains the following options:
Field

Description

Index

Index name

Ident

Element ID

Type

Element type
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Align Shapes to Array Dialog Box

The Align Shapes to Array dialog box allows you to arrange and resize objects (including window-in-window and
drawing objects) in an array. To access this dialog box, select multiple objects and choose Draw > Align Shapes > Space
and Size as Array.
Field

Description

Arrange the objects in Array row and column size. Enter the number of rows/columns, and the corresponding number
an array
of columns/rows is calculated based on the number of objects.
Space between cells

Spacing between objects. Spacing is specified in length units for layout views or grid units in
other views.

Fill the array

Direction in which the array is filled from the object list. The anchor object is the left, topmost
element of the array. The next object in the list is either placed to the left of the anchor element
if Vertically is selected, or below the anchor element if Horizontally is selected.

Set the order in which A list of objects to arrange. The first object in the list is the anchor object. The order of the
to fill the array
objects in the list determines the order in which the array is filled. Rearrange the list by selecting
an object and dragging it up or down, or clicking the up or down arrow. All objects are resized
to the same height and width as the anchor object.
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Via Fill Dialog Box

The Via Fill dialog box allows you to fill shapes with vias from a specified cell library, and define the fill. To access this
dialog box, select a shape in the layout and choose Draw > Add Shapes > Via Fill. For more information, see “Via Fill”.
Field

Description

Process Defaults

If the process definition includes definitions for specific Via Fill presets, these options are
included in the drop-down list. You can select between preset via spacing settings defined by
the layout process file (LPF). The default value is the first entry in the Via Fill Entries in the
LPF file.

Library

A drop-down list of the cell libraries that are imported into the current project. You can switch
between different libraries when selecting the via cell to use in the fill operation. The default
value is the first library listed under Cell Libraries in the Layout Manager.

Cell

A drop-down list of the cells in the currently selected library. You can choose any of the cells
in this library to use in the via fill operation. The default value is the first cell in the selected
library.

Spacing X,Y

Distance between vias. This value is interpreted differently based on the Type value.

Type

Allows you to select how the Spacing X and Spacing Y values are interpreted when filling the
region with via cells. If Type is Center-to-Center the spacing values represent the distance between
the subsequent via center points. If Type is Edge-to-Edge the spacing values represent the distance
from the side of one via cell to the side of the next via cell in the grid pattern.

Align
Offset X,Y

Provides a method for shifting the via cell relative to the placement position. While the via fill
algorithm attempts to optimize the placements to include as many vias in the fill regions as
possible, sometimes the fill pattern may not be in the exact location desired. The offset is
measured from the original placement location, so positive values shift each cell to the right (or
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Field

Description
up) and negative values to the left (or down). The default value is 0, which indicates no offset
shift.

Clearance

The clearance spacing specifies the minimum distance between any part of a via cell and the
perimeter of the fill region. When the placement is complete, the pattern should be such that no
part of a via is placed closer than the value of the clearance spacing from any side of the fill
shape.

Stagger

Option to stagger the vias placed, horizontally or vertically by half a placement column (or row).

Group Vias

For future implementation.

Spacing Types
The following figure shows the difference in Center-to-Center and Edge-to-Edge for Spacing X and Spacing Y.

X-Offset and Y-Offset
The following figure shows the X-Offset and Y-Offset as applied to the cells of a via fill grid.
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Clearance
Clearance is the minimum distance between the region edge and any via cell side.

Stagger
The following figure shows the change to a via grid when the stagger setting is set to stagger rows.
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Via Fence Dialog Box

The Via Fence dialog box allows you to fence, or surround, shapes with vias from a specified cell library, and define the
fence. To access this dialog box, select a shape in the layout and choose Draw > Add Shapes > Via Fence.
Field

Description

Process Defaults

If the process definition includes definitions for specific Via Fence presets, these options are
included in the drop-down list. You can easily select between preset via spacing settings defined
by the layout process file (LPF). The default value is the first entry in the Via Fence Entries in
the LPF file.

Library

A drop-down list of the cell libraries that are imported into the current project. You can switch
between different libraries when selecting the via cell to use in the fence operation. The default
value is the first library listed under Cell Libraries in the Layout Manager.

Cell

A drop-down list of the cells in the currently selected library. You can choose any of the cells
in the currently selected library to use in the via fence operation. The default value is the first
cell in the selected library.

Spacing

Distance between vias. This value is interpreted differently based on the value of Type.

Type

Allows you to select how the Spacing value is interpreted when fencing the shape with via cells.
If Type is Center-to-Center the spacing values represent the distance between the subsequent via
center points. If Type is Edge-to-Edge the spacing values represent the distance from the side of
one via cell to the side of the next via cell in the fence.

Offset X,Y

Provides a method for shifting the via cell relative to the placement position. While the via fence
algorithm attempts to optimize the placements of vias, sometimes the fence may not be in the
exact location desired. The offset is measured from the original placement location, so positive
values shift each cell to the right (or up) and negative values to the left (or down). The default
value is 0, which indicates no offset shift.

Merge Perimeters

When multiple shapes are selected, select this option to specify that the fencing algorithm treats
the shapes as one shape rather than fencing the adjoining edges.
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Field

Description

Open Path Ends

Select this option to specify that vias are not placed at the end of a path.

Oversize

Select this option to space the via fence a set distance from the selected shape.

Spacing
The following figure shows Center-to-center spacing around a corner. If Edge-to-edge is the spacing Type it is the same,
except the distance is between the edge of the vias rather than the center.

Oversize
The following figure shows how a positive versus negative Oversize value changes via placement.
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Merge Perimeters and Open Path Ends
The following figure shows the results of a via fence operation with both Merge Perimeters and Open Path Ends selected.
If Merge Perimeters is not selected the vias are placed where the two lines meet. If Open Path Ends is not selected the ends
of each line are surrounded by vias.
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Simplification Properties Dialog Box

The Simplification Properties dialog box allows you to apply SPP-like rules to the layout you are copying to EM, which
decreases the complexity of the EM simulation. To access this dialog box, in Layout View, choose Layout > Copy to EM
Structure, then click Create. This dialog box contains the following options:
Field

Description

Decimate paths

Paths bends are changed to use square bends and path ends are changed to use half-width
extended ends.

Decimate circles

Simplify arcs and circles by faceting them into n-point polygons.

Decimate cutouts

Simplify arcs and circular cutouts in polygons.

Minimum points per
circle

The minimum number of points in the polygon used to represent a simplified circle.

Maximum deformation Maximum allowed deformation when turning arcs and circles into faceted polygons. The
deformation is defined as the distance from the circle to the chord (sagitta). This option is not
applied if you use a value of "0".
Maximum radius fillets The maximum radius for fillet removal. Fillets with a radius less than or equal to this value are
squared off. This option is not applied if you use a value of "0".
Minimum path width
or Clearance

The smallest path width or clearance used in design. This value is used to set initial mesh options
like minimum edge length (AXIEM only). This option is not applied if you use a value of "0".

Show Mods Only

Show only non-default properties.

The following figure shows how you can combine the decimation options to create a simplified PCB board layout for
faster EM simulation.
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Original

Simplified

Maximum radius fillet

Decimate path ends and bends

Decimate circle with
Maximum Deformation

Curves are preserved

Decimate Paths Option
squares off path bends and ends. All bends are converted to square bends and all ends are converted to
half-width extended ends.
Decimate paths
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Original shape

Decimate paths

Decimate Circles Option
Decimate circles converts circles and arcs into polygons with a specified minimum number of facets. If you specify a
Maximum deformation, the facet length may be limited by deformation, and the circle may be simplified with more facets
than the specified Minimum points per circle. If Maximum deformation is 0, no deformation limit is applied.

Original Shapes

Decimate Circles
with Minimum
points per circle = 6

Decimation of the
outer circle limited by
Maximum deformation

The deformation is defined as the height of the arc formed by the intersection of the facet of the simplified polygon and
the unmodified arc, as shown in the following figure.

Deformation
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Decimate Cutouts Option
Decimate cutouts simplifies arcs and circular cutouts in polygons similar to the way Decimate circles simplifies circles.
Maximum deformation applies to simplification of cutouts as well. If Decimate cutouts is used in conjunction with Maximum
radius fillets, fillets on polygons are first removed, and then any remaining arcs and circles are decimated.

Original Shape

Decimate cutouts with
Minium number of
points per circle = 4

Decimate cutouts
with Maximum
radius fillets

Maximum Radius Fillets Option
turns rounded rectangles, such as PCB pads, into rectangles with squared corners. This option
removes fillets with a radius less than or equal to the option value. Fillets are not removed if you enter a value of "0".
Maximum radius fillets

Original shape
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Net and Constraint View Window

The Net and Constraint View window allows you to assign net names and constraint sets to signal shapes and dynamic
shapes used in layout dynamic voiding. To access this dialog box, choose View > Net and Constraint View.
Field

Description

Type

Schematic Instance name or “Net” for dynamic shapes and iNet routes.

Name

Net name.

Net Objects

Instance, iNet, or Dynamic Shape. iNet is further qualified as:
iNet(): iNet with no layout objects
iNet(Routes): iNet route only
iNet(Shapes): Route only contains a layout shape that is associated with a net route.
iNet(Shapes, Routes): Route that contains both iNet route and layout shape that is associated

with the net route.
Spacing CSet

Spacing rules in “Options - Voiding Constraint Sets Dialog Box ” associated with the net.

Same Net CSet

Same Net Spacing rules in “Options - Voiding Constraint Sets Dialog Box ” associated with
the net.

Each schematic is assigned a unique net and constraint set of rules. In the dialog box toolbar, select the desired schematic
from the drop-down option.

Other dialog box toolbar buttons include:
•

Select and show nets:

Highlight the layout shape and schematic instances associated with the selected net.

•

Select net on row selection:

Toggle selection for highlighting the schematic instances and layout shapes.
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•

Show interconnect instances:

Display rows associated with schematic instances.

•

Show more columns:

•

Size the columns to the width of the text

•

Enable/Disable tool tips

Display the Net Objects, Spacing CSet and Same Net CSet columns.
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Edit Equation Dialog Box

Edit Equation Dialog Box

The Edit Equation dialog box allows you to modify a variable or equation. To access this dialog box, select an equation,
right-click, and choose Properties. This dialog box contains the following options:
Field

Description

Variable
Name/Parameter
Name/Expression

The name of the variable, parameter, or expression.

Variable Value/Default If Variable Type is Variable Definition, this is the mathematical expression assigned to the variable.
Value/Value
It can be either a numeric value or another variable. If Variable Type is Parameter definition, this
is the default value of the parameter. If Variable Type is Display value, this option is disabled.
Variable Type

Specifies what the variable represents:
Variable definition: The variable is defined as a normal variable that represents a numeric value
or another variable. For example: x=10
Parameter definition: The variable represents a parameter for use in creating parameterized
subcircuits.
Display value: The variable is used to display the value of a previously defined variable. The
notation in the Global Definitions, Schematic, or Output Equations window is the variable name
followed by a colon. For example, if VEC represents a vector of numbers: VEC = {0, 2, 4, 6}.
Then 2*VEC: displays: 2*VEC: {0, 4, 8, 12}. The displayed value is not consistent
if the variables involved depend on the measurement being performed or the hierarchy. If you
select this option, all other dialog box options are disabled.
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Field

Description

Parameter Definition

Description: Enter the description to display in the Element Options dialog box for instances of

the parameterized document.
Does not affect layout: Select this check box if the parameter you are defining has no effect on
layout. If all of the parameters of the parameterized subcircuit have this option selected, then
automatic snapping of the subcircuit instance in the parent circuit is disabled.
Unit Type: Select the unit type of the parameter. When this is set and you use this schematic as
a subcircuit, you can change the project units and these values scale appropriately so you get
the same simulation results. Otherwise, changing units changes your simulation results.
Data Type: Select the data type of the parameter. If you select Enumeration, specify the enumerated
values as a comma-separated list in Description, for example {red, blue, green}. For enumerated
parameters, the Default Value represents the zero-based index into the list.
Tuning/Optimization

Applicable only when Variable Type is Variable Definition and Variable Value is a numeric value.
Tune: Allows tuning of the variable.
Optimize: Allows optimization of the variable.
Constrain: Allows constraint of the variable.
Upper bound: When Constrain is selected, defines the upper limit for constrained optimization.
Lower bound: When Constrain is selected, defines the lower limit for constrained optimization.
Step Size: Used for the tuning step size and can be used by some optimizers (such as Discrete
Local Search).

Statistics

Applicable only when Variable Type is Variable Definition and Variable Value is a numeric value.
Use statistics: Uses the variable during statistical (yield) analysis.
Optimize yield: Uses the variable during yield optimization analysis.
Distribution Type: - Uniform: Specifies a uniform probability density function. - Normal: Specifies
a normal (Gaussian) probability density function. - Log-Normal: Specifies a log-based normal
(Gaussian) probability density function. - Discrete: Specifies a discrete value probability density
function - Normal minus Tol: Specifies a normal (Gaussian) probability density function with
values near the center removed. - Normal Clipped: Specifies a normal (Gaussian) probability
density function with values near the edges removed.
In percent: If selected, the variation value is specified as a percentage (for example, a value of
5 in +/- means +/- 5%).
+/-: The absolute variation value.
The Std. Dev. and N/A values change based on the yield distribution type selected. See “Setting
Statistical Properties” for details on how these parameters are used to control each distribution
type. The first is the same as the Tol parameter and the second is the same as the Tol2 parameter.

Pass Down Mode

Specifies how you can use the variable for this level and all levels of hierarchy below.
None: The variable is only used at the current level of hierarchy.
Weak: The variable is used at lower levels only if the variable is not already defined at that level.
Strong: The variable is used at lower levels of hierarchy even if defined at the lower levels.
Select Strong to ensure that your entire design is using the same value of the variable, typically
used for temperature or process variation. This option is disabled for variables in the Global
Definitions window as they always effectively have Weak inheritance.
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Add/Modify Measurement Equation Dialog Box

The Add/Modify Measurement Equation dialog box allows you to assign a variable to a particular measurement to
post-process the measurement data. To access this dialog box, choose Draw > Add Output Equation when the Output
Equations window is active or right-click an existing measurement equation in an Output Equation window and choose
Properties. This dialog box contains the following options:
Field

Description

Variable Name

The name of the equation.

Measurement Type

Select the desired measurement category, such as Antenna or Nonlinear Voltage. The list of all
possible measurements for that type displays in Measurement.

Measurement

Specify the computed data, such as gain or noise, that you wish to output as a result of
simulations. This data can be plotted on a graph or deposited in an output file.

Simulator

Select a simulator.

Configuration

Select a configuration.
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Field

Description

Complex Modifier

Specify a format for the measurement quantity so you can plot it on the selected graph type:
Real: Uses the real part x of x+jy
Imag(inary): Uses the imaginary part y of x+jy
Mag(nitude): Uses the magnitude A of the polar form A*exp(j*theta)
Angle: Uses the angle theta of the polar form A*exp(j*theta)
AngleU: Same as Angle with ± 180deg transitions included for a smooth angle plot.
Complex: Compute the measurement as a complex value.
Conjugate: The conjugate of the measurement as a complex value.
dB/dBm: Compute the dB magnitude of the measurement; for example, 10*log|x| for power
measurements, and 20*log|x| for all others including output equations.
NOTE:
Only modifiers that apply to the graph type are enabled. For example, Complex and Conjugate
are disabled for rectangular graphs, and the other modifiers are disabled for Smith Charts and
polar grids. All modifiers are enabled for tabular graphs, which can display both real and complex
measurements.

One of the following, Data Source Name: Select a data source for the measurement. Select All Sources to create a
depending on
template measurement. In this case, the measurement object creates a trace on the graph for
Measurement Type
each data source object added to the project. All Sources makes measurement objects
selected: Data Source data-independent. Select another data source to create a single source measurement, where the
Name, EM Structure
selected source is associated with the measurement. The available options are determined by
Name, Two Port Name, the selected Measurement Type and Measurement. These options allow you to specify details
Equation Name,
required to compute this measurement, such as the frequency sweep index or harmonic index
Variables In.
to use.
To Port Index

(Measurement specific)

From Port Index

(Measurement specific)

Sweep Freq

The frequency sweep control. See “Frequency Sweep Control”.
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RFB Spreadsheet Wizard Block Properties Dialog Box: Block
Tab

RFB Spreadsheet Wizard Block Properties Dialog Box: Block Tab

The Block Properties dialog box Block tab allows you to select the RF block for a column. To access this tab for an
existing block column or row:
• Double-click the block heading for the column or row
• Select the column or row, then right-click and choose Column Properties
• Select the column or row, then choose Edit > Column Properties
Choosing Insert > Add Block or Insert > Insert Block and an appropriate command also displays this dialog box, as well as
right-clicking a row or column and choosing Add Amplifier, Add Attenuator, Add Block, Add Filter, or Add Mixer.
Note that these commands are only available when you select an appropriate column. For example, the Add commands
are not available if you select the last column, as the last column is a termination and cannot have a block after it. This
dialog box contains the following options:
Field

Description

Available Categories

Lists the block categories available. The list of categories depends on the selected column. For
example, if you select the first column, only source blocks display. If you select the last column,
only termination blocks display. If you select any other column, source blocks and termination
blocks do not display.

Blocks

Lists the blocks available in the selected category.
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RFB Spreadsheet Wizard Block Properties Dialog Box:
Parameters Tab

RFB Spreadsheet Wizard Block Properties Dialog Box: Parameters Tab

The Block Properties dialog box Parameters tab allows you to configure the parameters of the RF block selected on the
Block tab. To access this tab for an existing block column or row:
• Double-click the block heading for the column or row
• Select the column or row, then right-click and choose Column Properties
• Select the column or row, then choose Edit > Column Properties
Choosing Insert > Add Block or Insert > Insert Block and an appropriate command also displays this dialog box, as well as
right-clicking a row or column and choosing Add Amplifier, Add Attenuator, Add Block, Add Filter, or Add Mixer.
Note that these commands are only available when you select an appropriate column. For example, the Add commands
are not available if you select the last column, as the last column is a termination and cannot have a block after it. This
dialog box contains the following options:
Field

Description

Parameters

You can modify parameter values by entering the desired value in the Value column for the
parameter.
Select the Display in Header column check box to display the parameter name and its value in
the header row.
Select the Show Secondary check box in the lower right of the dialog box to display and modify
secondary parameters.
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RFB Spreadsheet Wizard Branch Properties Dialog Box

The Branch Properties dialog box allows you to specify the branch name, the input information and the output information
for a new branch. To access this dialog box choose Branches > New Branch. This dialog box contains the following
options:
Field

Description

Branch name

The branch name may contain letters, numbers, spaces and punctuation characters. Branch
names must be unique; you cannot have multiple branches with the same name.

Input

Determines the first column of the branch. You can set the column to either a TONE source,
or, if available, an output port of a block with multiple output ports. If there are blocks with
multiple output ports, the output ports that can be connected to branches are listed in Output port
of multi-output RF block. The first output port of a block is not listed, as that port is always
connected to the first input port of the following block.

Output

Determines the last column of the branch. You can set the column to either a LOAD termination,
or, if available, an input port of a block with multiple input ports. If there are blocks with multiple
input ports, the input ports that can be connected to branches are listed in Input port of multi-input
RF block. The first input port of a block is not listed, as that port is always connected to the first
output port of the preceding block.
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RFB Spreadsheet Wizard Connect Branch Dialog Box

The Connect Branch dialog box allows you to select branches for blocks with multiple input or output ports. To access
this dialog box choose Branches > Connect to Branch. This dialog box contains the following options:
Field

Description

Port to connect

Select from the list the input or output port of the block to which you want to connect the selected
branch.

Branch for port

Available branches are listed. You can double-click the desired branch or select it and click OK.
If you select a branch that is already in use, the branch is disconnected from the block that was
using it and assigned to the selected input or output port of the block.

Include branches in use Blocks that are in use are labeled as in use. You can hide blocks that are in use by clearing this
check box.
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RFB Spreadsheet Wizard Format Properties Dialog Box: Numbers Tab

The Format Properties dialog box Numbers tab allows you to change the appearance of the spreadsheet cells by specifying
the text used to display numerical values. To access this dialog box choose Format > Cells or any of the Format commands
in the Format menu. The dialog box also displays when you right-click on the spreadsheet and choose Format Cells. This
dialog box contains the following options:
Field

Description

Category

Select a numerical category. For Number, Percent, and Scientific categories, you can specify the
number of Decimal places and Leading zeroes, and select Negative numbers red to display negative
numbers in red.

Format

Select from common, pre-defined numerical formats.

Format code

When Custom is selected as the Category, specify the formatting code. The custom format codes
are similar to the Microsoft Excel numerical format codes.
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RFB Spreadsheet Wizard Format Properties Dialog Box: Font and Selection
Font Tabs

The Format Properties dialog box Font and Selection Fonttabs allow you to change the appearance of the spreadsheet
cells by specifying the typeface, font size, font style, font characteristic, and colors of text in the cells. To access this
dialog box choose Format > Cells or any of the Format commands in the Format menu. The dialog box also displays when
you right-click on the spreadsheet and choose Format Cells.
The Font tab settings apply to text in cells that are not selected. The Selection Font tab settings apply to text in cells that
are selected.
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RFB Spreadsheet Wizard Format Properties Dialog Box: Alignment and
Selection Alignment Tabs

The Format Properties dialog box Alignment and Selection Alignmenttabs allow you to change the appearance of the
spreadsheet cells by configuring the alignment of the text within the cells. To access this dialog box choose Format >
Cells or any of the Format commands in the Format menu. The dialog box also displays when you right-click on the
spreadsheet and choose Format Cells.
The Alignment tab settings apply to text in cells that are not selected. The Selection Alignment tab settings apply to text
in cells that are selected. This dialog box contains the following options:
Field

Description

Text Alignment

Specify the Horizontal Alignment and Vertical Alignment to determine along which edges of the
cell the text is aligned.

Text Orientation

Specify whether the text displays horizontally or vertically, and if vertically, whether it reads
from top to bottom (Top-down) or from bottom to top (Bottom-up).

Cell margins (screen
pixels)

Specify the spacing between the text and the Top, Left, Right, and Bottom edges of the cell.
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RFB Spreadsheet Wizard Header/Footer Dialog Box

The Header/Footer dialog box allows you to add text to the top (the header) and bottom (the footer) of each page when
the spreadsheet is printed. To access this dialog box choose File > Header/Footer.
Use the appropriate edit boxes to enter text to display in the header or footer. Text entered in the Left edit box is aligned
with the left edge of the page, text entered in the Center edit box is centered on the page, and text entered in the Right
edit box is aligned with the right edge of the page.
You can right-click in the desired edit box and choose to add special items such as page numbers, the time and date the
spreadsheet is printed, or the document, spreadsheet, or path name. The special items display within brackets, such as
'[PAGES]'.
You can also change the header/footer text formatting by selecting the desired text, right-clicking in the edit box, and
choosing Character Format to display the Header/Footer Text Format Properties dialog box.
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RFB Spreadsheet Wizard Measurement Properties Dialog Box: Measurement
Definition Tab

The Measurement Properties dialog box Measurement Definition tab allows you to select an RF Budget Analysis
measurement and configure its settings. To access this dialog box for an existing measurement row:
• Double-click the measurement heading for the row
• Select the row, then right-click and choose Row Properties
• Select the row, then choose Edit > Row Properties.
Choosing Insert > Add Measurement or Insert > Insert Measurement as well as right-clicking a row and choosing Add
Measurement also displays this dialog box. This dialog box contains the following options:
Field

Description

Measurement

Select an RF Budget Analysis measurement.

Settings

Specify the desired settings for the selected measurement.

Display

Specify a format for the conversion of a complex quantity to a real quantity that can be plotted
on a rectangular graph:
Real: Uses the real part x of x+jy
Imaginary(inary): Uses the imaginary part y of x+jy
Magnitude(nitude): Uses the magnitude A of the polar form A*exp(j*theta)
Phase: Uses the phase theta of the polar form A*exp(j*theta).
dB: Select this check box to compute the measurement as a real value, and apply a dB modifier.
This option applies only to measurements for tabular graphs, since these graphs can display
both real and complex measurements. Smith Charts and polar grids can only display complex
measurements; rectangular graphs can only display real measurements.
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RFB Spreadsheet Wizard Measurement Properties Dialog Box: Graph Tab

The Measurement Properties dialog box Graph tab allows you to determine the name of the graph into which the
measurement is placed. You can allow the name to be automatically selected, or you can specify the name of the graph.
To access this dialog box for an existing measurement row:
• Double-click the measurement heading for the row
• Select the row, then right-click and choose Row Properties
• Select the row, then choose Edit > Row Properties.
Choosing Insert > Add Measurement or Insert > Insert Measurement as well as right-clicking a row and choosing Add
Measurement also displays this dialog box.
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RFB Spreadsheet Wizard Mixer LO Dialog Box

The Mixer LO dialog box allows you to configure the LO for a mixer block. To access this dialog box, add a new mixer
block to the spreadsheet.
To create a new LO branch consisting of a TONE source, specify the desired LO frequency and power in LO Frequency
or LO Power, then click OK to create a new branch with the name and ID of the mixer block, followed by 'LO'.
You can also select an existing branch by clicking the Existing Branch button to display the Select Branch dialog box.
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RF Budget Wizards Options Properties Dialog Box: General Tab

The RF Budget Wizards Options Properties dialog box General tab allows you to set the names of the RFB Spreadsheet
Wizard object, the system diagram generated when the simulation is run, the orientation of the spreadsheet, and the
impedance mismatch modeling setting. To access this dialog box choose Options > Options.
This dialog box contains the following options:
Field

Description

Wizard name

Allows you to specify/change the name of the RFB Spreadsheet Wizard object. This name
displays beneath the VSS RF Budget Spreadsheet in the Project Browser Wizards node. The name
can contain letters, numbers, spaces and underscores ('_').

System Diagram name By default, the system diagram generated when the simulation is performed is created with the
same name as the RFB Spreadsheet Wizard object. You can specify a different name by clearing
the Use Wizard name for System Diagram check box, and entering the desired name in this text
box. System Diagram names can contain letters, numbers, spaces and '_'.
Row/Column Layout

Choose whether blocks display as columns or as rows. Parameters and measurements display
in the opposing configuration - rows or columns.

RF Options

Impedance mismatch modeling

determines whether or not impedance mismatches are modeled

or the project setting is used.
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RFB Spreadsheet Wizard Parameter Definition Dialog Box

The Parameter Definition dialog box allows you to configure the parameter filter for parameter rows (or columns, if
blocks are displayed in rows). The parameter filters determine which parameter (if any) of a block displays in the row.
If the block does not have a parameter satisfying the filter, a '-' character displays. To access this dialog box for an existing
parameter row:
• Double-click the parameter heading for the row
• Select the row, then right-click and choose Row Properties
• Select the row, then choose Edit > Row Properties
Choosing Insert > Add Parameter or Insert > Insert Parameter as well as right-clicking a row and choosing Add Parameter
also displays this dialog box. This dialog box contains the following options:
Field

Description

Parameter Category

Displays the parameter from a block that fits into the selected category, if the block contains
the parameter. For example, if you select the GAIN category, the GAIN parameter of an amplifier
block displays. The LOSS parameter of an attenuator would also display (as a negative gain).

Parameter Name

Displays the parameter from a block whose name matches the entered parameter name. The
parameter name is case-sensitive.

12–14 AWR Design Environment

RFB Spreadsheet Wizard Rename Branch Dialog Box

RFB Spreadsheet Wizard Rename Branch Dialog Box

The Rename Branch dialog box allows you to change the name of a branch. To access this dialog box choose Branches
> Rename Branch.
Branch names must be unique in the spreadsheet.
For more information, see “Branches”.
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RFB Spreadsheet Wizard Resolve Conflict Dialog Box

The Resolve Conflict dialog box assists in resolving the differences detected between a system diagram and a saved
spreadsheet. This dialog box displays when significant differences are detected between a system diagram and a saved
spreadsheet when you open the spreadsheet. This typically occurs when you make changes to a system diagram that was
generated by the RF Budget Spreadsheet Wizard, and then reopen the spreadsheet.
A list of the actions you can perform to resolve the differences displays. You can select the action(s) you want performed
by selecting items individually or by clicking the Check All button to select all items. You can also clear all selected items
by clicking the Uncheck All button.
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RFB Spreadsheet Wizard Select Branch Dialog Box

RFB Spreadsheet Wizard Select Branch Dialog Box

The Select Branch dialog box allows you to select an existing branch for the LO branch of a new mixer block. To access
this dialog box, click the Existing Branch button in the Mixer LO dialog box.
You can double-click the desired branch or select the desired branch and click OK. If you select a branch that is already
in use, the branch is disconnected from the block that was using it and is assigned to the mixer block.
Blocks that are in use are labeled as in use. You can hide blocks that are in use by clearing the Include branches in use
check box.
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Create New Process Dialog Box

The Create New Process dialog box allows you to create new PCB/LTCC Process Design Kits (PDKs). See “Create New
Process Wizard” for more information. To access this dialog box, choose Tools > Create New Process. This dialog box
contains the following tabs and options:
Field

Description

Process Name

New PDK name. Displays in the generated .ini file.

Process Version

A dotted numeric version number for the PDK

Length Unit

Unit of length: mil, um, or mm

DBU Grid Size

Database unit grid size; sets the precision of layout shapes. See “Grid Options ” for more
information.

Top Cover

If set to "Yes", adds a ground cover at the top of the layer stack.

Bottom Cover

If set to "Yes", adds a ground cover at the bottom of the layer stack.

# Conductor Layers

Number of conductor layers in the stackup

Conductor Name
Format

Specifies how metal layers are named. "#" represents the layer number. The Format of Layer
Numbers setting in the Layer Generation Defaults dialog box determines the number of digits.

Via Name Format

Specifies how via layers are named. "#" represents the layer number. The Format of Layer Numbers
setting in the Layer Generation Defaults dialog box determines the number of digits.

Substrate Name Format Specifies how substrate layers are named. "#" represents the layer number. The Format of Layer
Numbers setting in the Layer Generation Defaults dialog box determines the number of digits.
Add Fill/Keep Out

If set to "Yes", adds a + and – layer for each metal layer (for example, "Copper01+" and
"Copper01-"). Line types have both the nominal metal layer and a negative layer with a positive
offset specified by Ground Spacing. When the example layout is created, ground flood shapes
are added on the + layers (though visibility on these layers is off by default.)

Ground Spacing

For PCB Process Type. Sets the spacing from conductor traces to the ground flood.
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Create New Process Dialog Box
Material Stack tab

Field

Description

Layer Name

Drawing layer name

Layer Type

Dielectric or conductor

Is Via

Select if the layer is a via (connects between adjacent substrate layers)

Er

Relative dielectric constant

Tand

Dielectric loss tangent

Sigma

Substrate bulk conductivity

Thickness

Layer thickness in specified length units.

Layer Display tab
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Create New Process Dialog Box

Field

Description

Layer Name

(Display only; specified on Material Stack tab.) Drawing layer name

Visible

Toggle on/off layer visibility. When this option is cleared, shapes on this layer are not visible
or selectable in layout.

Cloak

Hide/show the layer name.

Line

Click to choose a shape outline color and line pattern from the drop-down menu.

Fill

Click to choose a shape fill color and hatch pattern from the drop-down menu.

Show Fill

Toggle on/off polygon fill.

Freeze

Toggle on/off freeze for layer. Shapes not associated with schematic items cannot be selected
if on a frozen layer.

Layer Display 3D tab
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Create New Process Dialog Box

Field

Description

Layer Name

(Display only; specified on Material Stack tab.) Drawing layer name

Opaque

If selected, the layer is not transparent in the 3D view. This must be selected if texturing is
desired.

Thickness

Defines layer thickness in specified length units. Layer extends this length from Z-Position.

Z-Position

Defines the position of each new layer in the Z-direction in specified length units.

Texture File

You can apply texturing to the 3D layout object by specifying a bitmap (.bmp) file name. This
file must be located in the \textures subdirectory of the Cadence® Microwave Office® software
root directory. Type the name of the bitmap file (without the extension) in the row that
corresponds to the desired layer. To use texturing, you must also select Opaque.

Texture Scale

If texturing is used, this value is used to scale the size of the bitmap in relation to the size of the
3D layout object. If the size of the bitmap is the same as the size of the 3D layout object, a
Texture Scale value of 1 would correspond to no scaling (1-to-1).

Blend

If Opaque is not selected, this is a number between 0 and 1 that describes a view that is a blend
of transparent and opaque. A value of 0 is completely transparent and 1 is completely opaque.

Vias/Drills tab
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Create New Process Dialog Box

Field

Description

Via Name

Via type name

Range Start

Starting layer of range for valid connections with this via type

Range End

Ending layer of range for valid connections with this via type

Thru

Thru vias are drilled through multiple layers at once. If selected, this via type draws as a single
cut through all layers in the start/end range. If not selected, vias are allowed between any two
layers in this range.

Per Layer

Specify via hole diameter, pad size, and ground spacing per layer as a vector (top to bottom).

Hole Diam

Via hole diameter

Pad Diam

Via catch pad diameter

Gnd Space

Via catch pad to ground plane spacing

Via Model

Electrical model for via
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Layer Generation Defaults Dialog Box

Layer Generation Defaults Dialog Box

The Layer Generation Defaults dialog box provides additional options for creating layers in the Process Definition
Wizard. To access this dialog box, click the Defaults button in the Create New Process dialog box. This dialog box
contains the following options:
Field

Description

Format of Layer
Numbers

Format for layer numbers in generated names.

Layer Ordering

Ordering of layers. "Top to Bottom" places Copper1 on top of the stack, "Bottom to Top" places
Copper 1 on the bottom of the stack.

Background Color

Layout background color.

First Color

Color of the first layer. High contrast colors are assigned to subsequent layers.

First Pattern

Pattern used for the first fill.

Sub Thickness

Default substrate thickness for generated layers.

Conductor Thickness Default conductor thickness for generated layers.
Conductor Sigma

Default conductor sigma for generated layers.

Sub Er

Default substrate dielectric constant for generated layers.

Sub TanH

Default substrate dielectric loss tangent.
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Layer Generation Defaults Dialog Box
Field

Description

Top Cover

Ground cover at the top of the layer stack.

Air Gap to Top Cover Air gap to cover above the top conductor layer. Enter 0 for no air layer above.
Bottom Cover

Ground cover at the bottom of the layer stack.

Air Gap to Bottom
Cover

Air gap to cover below the bottom conductor layer. Enter 0 for no air layer below.

Hole Diameter

Via hole diameter.

Pad Diameter

Via catch pad diameter.

Model Type

Electrical model for via.

Series R, L, or C

Series R, L, or C for via model.

S Param File

Via S-parameter file name.

Create Sample Layout Create an example layout to test metal layers and via transitions.
Default Line Width

Used for the sample layout, and as the default value for any elements with a W parameter.

Default Line Length

Used for the sample layout, and as the default value for any elements with an L parameter.
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PCB Import Wizard Dialog Box: Options Tab

PCB Import Wizard Dialog Box: Options Tab

The PCB Import Wizard Options tab allows you to specify the format of the imported file as well as the path to the file.
To access this dialog box, open the Wizards node in the Project Browser and double-click PCB Import. See “PCB Import
Wizard” for more information. This dialog box contains the following options:
Field

Description

Import Format

Standards available: 3Di, Allegro IPC-2581, ODB++(file), ODB++(dir), Gerber(file) and Gerber(dir)

Filename

Path to file to import

Various options

Options vary depending on the selected Import Format. Select an option to view a short description
of it in the display area at the bottom of the dialog box.
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PCB Import Wizard Dialog Box: Layers Tab

The PCB Import Wizard dialog box Layers tab allows you to specify the layers to include or exclude from the import
process. To access this dialog box, open the Wizards node in the Project Browser and double-click PCB Import. See “PCB
Import Wizard” for more information. This dialog box contains the following options:
Field

Description

Import

Check box selection resulting in the inclusion or exclusion of the Layer during import.

Name

The name of the layer as specified in the PCB design file.

Type

The type of layer, such as CONDUCTOR or DIELECTRIC, as specified in the PCB design file.

Negative

Specifies whether the layer is defined as Positive or Negative in the design file. This selection
can be toggled and is honored during import.
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PCB Import Wizard Dialog Box: Nets Tab

PCB Import Wizard Dialog Box: Nets Tab

The PCB Import Wizard Nets tab allows you to specify the electrical nets to include or exclude from the import process.
To access this dialog box, open the Wizards node in the Project Browser and double-click PCB Import. See “PCB Import
Wizard” for more information. This dialog box contains the following options:
Field

Description

Import

Check box selection resulting in the inclusion or exclusion of the electrical net during import.

Net Name

The name of the electrical net as specified in the PCB design file.
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PCB Import Wizard Dialog Box: Stackup Tab
See “PCB Import Wizard”

The PCB Import Wizard Stackup tab displays the material properties of the stackup specified in the design file. Not all
files contain accurate stackup layer information like thickness, dielectric constant, or conductivity. If data is not found,
N-1 dielectric layers, where N is the number of conductive layers imported, are added between the conductors. Default
values are used for missing data. All data is editable, including multi-select editing support. This information is used to
create a STACKUP element in the schematic. The STACKUP will have AIR dielectric layers added above and below
the core. The thickness of these layers of AIR is equal to 1/4 of the total dielectric thickness of the core. Finally, the top
and bottom boundaries are set to approximate opens. To access this dialog box, open the Wizards node in the Project
Browser and double-click PCB Import. See “PCB Import Wizard” for more information. This dialog box contains the
following options:
Field

Description

Layer Name

The name of the layer found in the PCB design file.

Material

The name of the material defined for the layer, as specified in the PCB design file.

Various options

The material properties values for the layer defined in the design file. For instance, Thickness,
Conductivity, Dielectric Constant, and Loss Tangent as specified in the PCB design file.
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Stability Analysis Wizard Simulation Settings Dialog Box

The Stability Analysis Wizard Simulation Settings dialog box allows you to specify STAN stability analysis options for
analyzing the stability of a selected circuit. To access this dialog box, open the Wizards node in the Project Browser and
double-click Stability Analysis using STAN. See “Stability Analysis Wizard” for additional information. This dialog box
contains the following options:
Field

Description

Stability Probes

At least one STAB_PROBE is needed for STAN analysis. Click Add to add a new
STAB_PROBE. Click Delete to remove the selected probe from the list. New STAB_PROBEs
are connected to NCONN elements in the schematic. Define the probe Type (Current/Voltage,
Single/Diff) and Node+ to connect for each probe.

Settings/STAN Options

MaxOrder: Max Order for STAN indentification
PhaseTolerance: Phase Tolerance for STAN indentification

Settings/Small Signal
Test Conditions
Conditions

FStart: Small-signal frequency start
FStop: Small-signal frequency end
FSteps: Number of points in small-signal frequency sweep
SweepType: Sweep type in small-signal frequency sweep (linear/log)
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Stability Analysis Wizard Simulation Settings Dialog Box
Field

Description

Settings/Drive
Conditions

Port: Selected port is replaced with swept
PStart: Swept power magnitude start
PStop: Swept power magnitude stop
PStep: Swept power magnitude step

Settings/Large Signal
Frequencies

UseSchematicFreqs: Use original schematic frequencies
Fstart: Large-signal frequency start
Fstop: Large-signal frequency end
Fsteps: Number of points in large-signal frequency sweep

Settings/Wizard
Settings

KeepResultSchematic:

Settings/IVCAD
Settings

UseLocalServer: Use IVCAD server installed on localhost
IVCADPath: Location of IVCAD executable on localhost
IVCADServer: IVCAD server address (name or IP)
IVCADPort: IVCAD Script Server Port
OutputTerm: Output termination character for IVCAD socket
Timeout: IVCAD Script Server Timeout in seconds
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source port with the following parameters.

Keep generated schematic with STAN settings

connection

Cadence Unified Library Import Wizard Dialog Box: Options
Tab

Cadence Unified Library Import Wizard Dialog Box: Options Tab

The Cadence Unified Library Import Wizard Options tab allows you to specify the format of the imported file as well as
the path to the file and PDK creation options. To access this dialog box, open the Wizards node in the Project Browser
and double-click Cadence Unified Library Import. See “Cadence Unified Library Import Wizard” for more information.
This dialog box contains the following options:
Field

Description

Import Type

Translate one of the following for use in Microwave Office: Allegro Library, a Cadence Unified
component and technology library, or Virtuoso PDK.

cds.lib File

Specify the path to the cds.lib file that contains the library reference(s) to translate. You can
edit this file in a text editor. The path cannot contain spaces.

Technology Library

Select the technology library from the list of available libraries. This library should contain the
tech.db which has the layer, STACKUP information, and via definitions to use in the design.

Display Name

Select the display name from the list of available displays. This specifies the display selection
in the .drf file in the Technology Library and controls the colors/fills in the Microwave Office
.lpf file.

Reverse Layer Order

When selected, the lower layers in the stackup have a higher drawing priority.

Output Directory

Specify the output directory for the Microwave Office PDK. The path cannot contain spaces.

Delete Contents

When selected, the existing Output Directory contents are deleted prior to creating the PDK.

PDK Name

Specify a name for the PDK.

PDK Version

Specify a PDK version.
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Cadence Unified Library Import Wizard Dialog Box: Layers Tab

The Cadence Unified Library Import Wizard Layers tab allows you to specify the layers to include or exclude from the
import process. To access this dialog box, open the Wizards node in the Project Browser and double-click Cadence Unified
Library Import. See “Cadence Unified Library Import Wizard” for more information. This dialog box contains the following
options:
Field

Description

Import

Select or clear the check box to include or exclude the Layer during import.

Name

The layer name as specified in the design file.

Purpose

The layer type as specified in the design file.

AWR Name

The name of the layer as specified in the AWR design file.
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Cadence Unified Library Import Wizard Dialog Box:
LineTypes Tab

Cadence Unified Library Import Wizard Dialog Box: LineTypes Tab

The Cadence Unified Library Import Wizard LineTypes tab provides a list of the line types from the LPF file that the
PDK uses, in the order in which the PDK expects them to appear. To access this dialog box, open the Wizards node in
the Project Browser and double-click Cadence Unified Library Import. See “Cadence Unified Library Import Wizard” for
more information. This dialog box contains the following options:
Field

Description

Name/Layer

The name of the model layer.

Offset

The offset used for drawing the layer.

Min Width

The value used to check design rule violations.

Flags

Notification that specialized information is passed to the layout cells.
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Cadence Unified Library Import Wizard Dialog Box: Stackup Tab

The Cadence Unified Library Import Wizard Stackup tab displays the material properties of the stackup specified in the
design file. To access this dialog box, open the Wizards node in the Project Browser and double-click Cadence Unified
Library Import. See “Cadence Unified Library Import Wizard” for more information. This dialog box contains the following
options:
Field

Description

Layer Name

The name of the layer found in the design file.

Material

The name of the material defined for the layer, as specified in the design file.

Additional options

The material properties values for the layer defined in the design file. For instance, Thickness,
Conductivity, Dielectric Constant, and Loss Tangent as specified in the design file.
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Licensing
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AWR License Configuration Dialog Box

The AWR License Configuration dialog box allows you to register for a valid FLEXlm license with Cadence® AWR®
software and to troubleshoot many licensing issues. This dialog box displays when you start the Cadence AWR Design
Environment® program and a valid license file is not detected. You can also access this dialog box after the program is
installed by choosing File > License > Configuration.
This dialog box contains the following options:
Field

Description

HostID

The user code calculated from your computer hard disk. This is also the MAC address of your
computer.

Configure

Click this button to set the CDS_LIC_FILE environment variable. Enter the server name and
port or browse for the location of the awrd.lic license file. You need administrative privileges
on your computer to make this change.

Information

Click this button to open a website with information about obtaining a license file.

Troubleshoot

Click this button to access options for viewing an online license troubleshooting guide or sending
an e-mail to Cadence Support. The e-mail template contains much of the information used to
diagnose licensing issues, such as the FLEXlm environment variables and the text of the last
error encountered. You can add any additional relevant information to the message body. If you
cannot generate an e-mail message because your machine is not MAPI compliant, a file named
license_status.txt in the AWR Design Environment program installation directory contains the
same troubleshooting information, so you can forward it to Technical Support for AWR Products.

View Status

Opens the license_status.txt file in Windows Notepad for ease of location when relaying
information to Cadence Support personnel.
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AWR License Configuration Dialog Box
Field

Description

Configurations

Features: The set of license features the program tries to checkout on startup.
Configuration: Displays your licensing type: AWR or Cadence.
AWR Configuration: When configured to run with an AWR license, shows how

you have the

license configured.
Cadence Configuration:

When configured to run with a Cadence license, shows how you have
the license configured.
When you have both AWR and Cadence licenses configured, the license used is the one
last specified in the License Configuration dialog box.
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Select License Features Dialog Box

The Select License Features dialog box allows you to select the primary and optional feature licenses available to you,
and allows you to choose how you want to use the licenses. To access this dialog, choose File > License > Feature Setup.
This dialog box contains the following options:
Field

Description

Select Primary Features Select the desired feature(s) for which you have an authorized license(s).
Select Optional
Features

Select the desired optional feature(s) for which you have an authorized license(s).

Always run with the
selected features

Select this option if you regularly run the AWR Design Environment program with the same
feature set.

Prompt for features
Allows you to select a feature set each time you start the program. Useful when your feature
when the application is sets are not standard and your program use changes. Your previous selections are remembered
run
the next time you run in this mode.
Create Desktop
Shortcut

Create a desktop shortcut that runs with the selected feature set. Useful when you run more than
one configuration of the program.

NOTE: Some features you may own are not listed in this dialog box. These features are not optional; if they are in the
license file they are used. This applies to all Process Design Kit (PDK) features and other additional features.
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License Configuration Dialog Box

License Configuration Dialog Box

The License Configuration dialog box allows you to specify your desired license configuration. To access this dialog
box, from the AWR License Configuration dialog box (choose File > License > Configuration), click Configure. You must
have administrator privileges to set the environment variable. See the AWR Design Environment Installation Guide for
more information on setting this value.
This dialog box contains the following options for specifying your desired license configuration and setting the environment
variable:
Field

Description

Floating license
Set your port@host values for your floating license. Your license administrator should provide
(port@server or
these values. You can specify one or more servers, separated by semi-colons.
port@server1;port@server2...)
Locked license
(filename)

Browse to the location of your locked license file, or manually enter the path

Floating License with Browse to the location of your locked license file or manually enter the path if you have access
file (filename)
to the license file used for your floating license server. The floating server must be running.
You can use this option without knowing the port@host values.
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License Configuration Dialog Box
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