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QUICK REFERENCE for Experienced Administrators
1. FLEXlm SETUP
Cadence® AWR Design Environment® platform software conforms to standard FlexLM™ guidelines. The vendor
daemon name is cdslmd. Cadence requires version 11.15 or later of lmgrd and cdslmd.
The AWR Design Environment client software uses the CDS_LIC_FILE environment variable to find the server for
floating license configuration in AWR Design Environment V16 and later software. The client queries the server to
determine what features are available, and presents those features so you can select the desired configuration. The AWR
Design Environment client software uses the AWRD_LICENSE_FILE environment variable for both locked and floating
licenses in AWR Design Environment V15 and earlier software.

2. USER DIRECTORY CONFIGURATION
The AWR Design Environment platform software writes data to several locations. In an environment where users have
limited rights, you can configure the directories the software uses. See “Configuring Program File Locations (optional)”
for more information.

3. COMMAND LINE INSTALLATION
See “AWR Design Environment Installation Program” for options for installing the AWR Design Environment platform
software from the command line.
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Chapter 1. Introduction
1.1. AWR Software Installation and Licensing
The Cadence® AWR Design Environment® platform software employs the FLEXlm™ licensing scheme. FLEXlm can
be used in either locked or floating configurations. Locked licensing dedicates a license to a particular machine. Floating
licensing allows multiple users to share a license over a network via a client-server architecture that grants or denies
licenses based on availability. With floating licensing, the license is assigned to a machine defined as the license server,
and each client workstation running the AWR Design Environment platform software (Cadence Microwave Office®
software/Cadence Visual System Simulator™ (VSS) communications and radar systems design software) requests
licenses from the server as needed.
FLEXlm user license keys are stored in a license file. The license key can be calculated from the Ethernet address of the
computer's network card, disk volume serial number, or from the serial number of an Cadence AWR®-supplied hardware
dongle attached to the machine's parallel or USB port.
You can purchase a license with full functionality (for example, in the AWR Design Environment platform: linear
simulator, nonlinear simulator, EM simulator(s), layout tool, and VSS software), or with one or more limited features.
The license keys in the license file activate only the purchased features.

1.2. About This Guide
This guide describes how to install the AWR Design Environment platform software. It also provides complete details
for configuring and troubleshooting your site for FLEXlm licensing in both locked and floating configurations, using
either software- or hardware-based keys. Chapter 2 covers basic AWR Design Environment platform software installation,
chapter 3 details FLEXlm configuration, and chapter 4 discusses FLEXlm troubleshooting issues. Appendix A provides
information on the installation and Addin programs.
The latest version of this guide (install.pdf) is available at Install.pdf. Comments and suggestions regarding this guide
are welcome and should be e-mailed to awr.install@cadence.com.
This guide assumes that you have an intermediate level of knowledge as a PC user or administrator.

1.2.1. Typographical Conventions
This document uses the following typographical conventions.
Item

Convention

Anything that you select (or click on) Shown in a bold alternate font. Nested menu selections are shown with a ">" to
in the AWR Design Environment
indicate that you select the first menu item and then select the submenu item:
program, such as menus, nested
submenus, menu options, dialog box Choose File > New Project.
options, buttons, and tab names
Text that you enter using the keyboard Shown in a bold within quotation marks:
Enter "my_project" in Project Name.
Keys or key combinations that you
press

Shown in a bold alternate font with initial capitals. Key combinations using a
"+" indicate that you press and hold the first key while pressing the second key:
Press Alt+F1.

Installation Guide 1–1

About This Guide
Item

Convention

File names and directory paths

Shown in italics:
See the DEFAULTS.LPF file.

Contents of a file, fields within a file, Shown in a mono-spaced font:
command names, command
switches/arguments, or output from a Define this parameter in the $DEFAULT_VALUES field.
command at the command prompt
Optional arguments in a command

Shown in a mono-spaced font in square brackets:
The command line format is: dir [/w]

Variables for which you must specify Shown in a mono-spaced font in angle brackets:
values
awrde_<version_build>.exe

1–2 AWR Design Environment

Chapter 2. Installing the AWR Design Environment
This chapter describes how to install the Cadence® AWR Design Environment® platform which includes the Cadence
Microwave Office® software, Cadence Visual System Simulator™ (VSS) communications and radar systems design
software, Cadence Analyst™ 3D FEM EM analysis software; and Cadence Analyst™-MP multi-physics simulator. A
procedure for performing command line installations is also included.
The installation procedures are intended for evaluators and licensed users who wish to install the AWR Design Environment
platform software with a FLEXlm license dedicated to their particular machine. For licensing configurations, see
“Configuring FLEXlm”.

2.1. Installation Overview
You can download and install the AWR Design Environment platform software from the Cadence website or from the
Cadence Downloads page. You can access vendor libraries from within the AWR Design Environment platform program
via the Elements Browser and through the Support portal on the Cadence website.
After installing the software you need to configure your FLEXlm licensing before using the software. For FLEXlm
licensing information see “Configuring FLEXlm”.

2.1.1. Licensing and Available Features
You may have purchased a complete Microwave Office/VSS license with full functionality (for example: linear simulator,
nonlinear simulator, EM simulator, and layout tool), or you may have purchased a license for one or more features. In
either case, the complete application is installed and your license determines the specific Microwave Office and/or VSS
functions that are available to you. The default program installation directory for 64-bit operating systems is C:\Program
Files (x86)\AWR\AWRDE\[version_number].

2.2. Preparing for Installation
Before you start the installation:
1. Ensure that the computer on which you want to install the AWR Design Environment platform software meets the
minimum requirements. For recommended hardware requirements see the Cadence website: Minimum Requirements.
2. When installing an upgrade to the AWR Design Environment platform, retain your existing version until you verify
that your projects work successfully in the new version. (To uninstall the AWR Design Environment platform, choose
Programs and Features from the Windows Control Panel, select the program and follow the instructions.)
3. Ensure that you have Administrative rights on the computer. The AWR Design Environment platform and FLEXlm
licensing software both require Administrator privileges for installation and configuration.
4. (Optional) Disable your spyware and/or virus checking programs if interference is probable. Re-enable these programs
after installation.
5. The AWR Design Environment platform software does not support Unicode languages. For proper software operation,
ensure you have set your operating system set to English as the language for non-Unicode programs. If you are unsure
how to check this, see Trouble Entering Text in the Cadence AWR Knowledge Base.

2.3. Installing the Software
To install the AWR Design Environment platform:
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1. Download the software from the Cadence website or from the Cadence Downloads page, browse to the download
folder and run awrde_<version_number>.exe to display the AWR Setup Wizard screen.
2. After accepting a license agreement, you proceed with the installation and are prompted to specify the following:
Option

Description

Select the installation folder

Browse to the directory in which you want to install the AWR Design
Environment platform software. DO NOT INSTALL THE SOFTWARE
IN THE SAME DIRECTORY AS A PREVIOUS INSTALLATION.

Set the default Units value

Choose the default units to use in schematics and layouts (and affect the default
sizes for components such as transmission lines). The default is Microns. You
can alternatively set this default within the program; see the AWR Design
Environment User Guide for details.

Choose the file extensions to open
with the AWR Design Environment
platform program.

Specify the file type(s) you want to open with the AWR Design Environment
platform program by selecting the option(s) for the associated file extension.

Your installation progress is shown.
3. When installation is complete click Close to close the screen. For most users, the installation is now complete. The
following sections describe custom installation procedures that are not typically used.

2.3.1. Setting Up a Group Policy
The AWR Design Environment platform software installer is based upon Windows Installer technology, which allows
installations to be managed through a Group Policy. By setting up a Group Policy, you can automate the installation of
the software for specific users or computers within a domain. For more information on how to configure Group Policies,
see Microsoft's Support Website.

2.4. Configuring Program File Locations (optional)
By default, the AWR Design Environment platform program looks for files and folders in specific directories. You can
optionally change these default directories to accommodate roaming users.
To view the location of the directories and files that the AWR Design Environment platform program uses, choose Help
> Show Files/Directories to display the Directories dialog box.
The AWR Design Environment platform software uses three primary base locations:
• application - the AWR Design Environment platform installation directory
• appdatacommon - items common to all user accounts
• appdatauser - items specific to a single user
The installation directory is user-specified during program installation. The location of the appdatacommon and
appdatauser directories is determined by calling the Windows SHGetFolderPath API. An administrator can set the
physical location of these directories. The default locations on Windows machines are:
application:
C:\Program Files (x86)\AWR\AWRDE\[version_number]
appdatacommon:
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C:\ProgramData\AWR\Design Environment\[version_number]
appdatauser:
C:\Users\[username]\AppData\Local\AWR\Design Environment\[version_number]
A fourth virtual location, appdata, is set to either appdatacommon or appdatauser depending on a configuration setting.
All other subdirectories, with the exception of projects are under one of the three primary directories.

2.4.1. Searching mwoffice.ini
A search is performed for the mwoffice.ini file in the following locations:
1. the appdatauser version specific directory
2. the appdatacommon version generic directory
3. the application directory
4. If not found, this file is created in the appdatacommon directory.
The first location in which the file is found is the location that is used.

2.4.2. Searching user.ini
A search is performed for the user.ini file in the following locations:
1. the appdatauser version specific directory
2. the appdatacommon version generic directory
3. the application directory
4. If not found, this file is created in the appdatauser directory.
The first location in which the file is found is the location that is used.

2.4.3. Customizing File Locations
You can customize the default AWR Design Environment platform directories by creating a file named REDIRECT.INI
in the Documents folder for a single user, or in the application directory for multiple user configurations. The default
location for the Documents folder for Windows is C:\Users\[user]\Documents.
This file has a section that allows you to configure how the AWR Design Environment platform program behaves, and
a section that tells the software to change the default primary directory locations.
You can change the behavior of the AWR Design Environment platform program by specifying one or more of the
following flags under the [Design Environment] section. For example:
[Design Environment]
CommonDirectory=D:\All Users\AWRDE\Data
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2.4.4. Overriding appdatacommon and appdatauser Locations
By default, the AWR Design Environment platform program gets the locations of the appdatacommon and appdatauser
default locations from the system. As noted in “Configuring Program File Locations (optional)”, an administrator can
change the location of these directories. Doing so, however, causes a system-wide change and affects all programs. There
are circumstances when you may want to change the location for only the AWR Design Environment platform program.
You can do so by adding entries to the REDIRECT.INI file to override the appdatacommon and appdatauser directories
as follows:
[Design Environment]
CommonDirectory=D:\All Users\AWRDE\Data
UserDirectory=D:\[username]\AWRDE\Data

A convenient way to place all of your AWR Design Environment platform data under a common directory is to specify
the AppDataDirectory instead of the CommonDirectory and UserDirectory individually. When you use the
AppDataDirectory key, the AWR Design Environment platform program automatically appends to the specified path
"All Users" for the appdatacommon directory, and the user name to the appdatauser directory.
For example, specifying:
[Design Environment]
AppDataDirectory=C:\Data\AWRDE

results in:
appdatacommon:
C:\Data\AWRDE\All Users
appdatauser:
C:\Data\AWRDE\[username]
You can also redirect directories based on the machine name, the user account name, or both. This is useful in a group
setting when the AWR Design Environment platform software is run from a network location or from multiple machines.
For instance, you have two machines with the AWR Design Environment platform software installed, one in your office
and one in a meeting room. The machine in the meeting room is shared by multiple users, however, when you use it,
you want it to use the customizations and cache files from your desktop machine. You can do this by adding a username
category to the REDIRECT.INI file on the meeting room machine, and redirecting the appdatacommon and appdatauser
directories to your desktop machine as follows.
[yourusername]
CommonDirectory=\\YOURMACHINENAME\AWRDE\CommonData
UserDirectory=\\YOURMACHINENAME\AWRDE\username

NOTE: You need to log on to the meeting room machine using your own account.
When looking for path overrides, the AWR Design Environment platform program searches categories in this order:
[machine_username]
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[username]
[machine]
[Design Environment]
If both the CommonDirectory and AppDataDirectory are found in a given category, the path specified for
CommonDirectory is used. If both UserDirectory and AppDataDirectory are found in a given category, the path specified
by UserDirectory is used. The first successful override that it finds is used.

2.5. Running the Software
NOTE: Before using the software you need to configure your FLEXlm licensing. For FLEXlm licensing information,
see “Configuring FLEXlm” .
To run the AWR Design Environment platform program, from the Windows Start menu, choose AWRDE [version_number]
> AWR Design Environment [version_number].
If an error occurs while running the AWR Design Environment program, check “Solutions to FLEXlm-related Problems”
to see if it is listed. If not, contact Technical Support for AWR Products.

2.5.1. Specifying License Features
To specify with which license features you want to run, start the program and in the Select License Features dialog box
choose the primary and optional features (licenses) available to you. You can access this dialog box within the program
by choosing File > License > Feature Setup. After selecting the desired features, you can specify to always run with them
or to be prompted for feature selection upon program startup, and to create a desktop icon for your selection.

2.5.2. Specifying a Foundry Library
To load a foundry library for use with a new project, start the program and choose File > New with Library. If installed, a
list of foundry libraries displays, or you can browse to locate a foundry configuration (.ini) file. The name of the foundry
library is saved in your project file. Whenever you reopen the project, the associated foundry library is automatically
loaded.

2.5.3. Accessing User Resources
The AWR Design Environment Getting Started Guide is included with the software to help explore the suite and learn
how to perform tasks. For easy access to this guide choose Help > Getting Started. A concise, comprehensive Quick
Reference resource is also available by choosing Help > Quick Reference.
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Chapter 3. Configuring FLEXlm
This chapter describes how to configure your site for FLEXlm licensing.
FLEXlm can be configured in a locked or floating licensing environment using either software- or hardware-based keys.
For instructions on configuring your machine for locked licensing using either type of key, see “Configuring Locked
Licensing”. For instructions on configuring your site for floating licensing, see “Configuring Floating Licensing”.
If you cannot successfully configure FLEXlm, see “Troubleshooting FLEXlm” for troubleshooting information.
NOTE: FLEXlm licensing software requires Administrator privileges for installation and configuration.

3.1. Configuring Locked Licensing
FLEXlm locked licensing can use either a software-based or hardware-based key. For instructions on configuring FLEXlm
using a software-based key, see “Configuring Locked Licensing with a Software-Based Key”. For instructions on
configuring FLEXlm with a hardware-based key, see “Configuring Locked Licensing with a Hardware-Based Key”.
These instructions assume that the Cadence® AWR Design Environment® platform software is installed on your machine.
For installation instructions, see “Installing the AWR Design Environment”.

3.1.1. Configuring Locked Licensing with a Software-Based Key
The following steps configure your machine for FLEXlm locked licensing with a software-based key. In this configuration,
the AWR Design Environment platform software is installed on and licensed to your particular machine.
1. From the Windows® Start menu, choose AWRDE [version_number] > AWR Design Environment [version_number].
Alternatively, double-click This PC on your desktop, open the folder where you installed the program and double-click
MWOffice.exe to display one of the following dialog boxes.
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2. Click OK to display the AWR License Configuration dialog box.

After your initial license file configuration you can access this dialog box by choosing File > License > Configuration
while in the AWR Design Environment platform program.
3. To obtain a valid license file from Cadence, click Information and follow the instructions. NOTE: Evaluators must
complete the registration process to obtain an evaluation license. See Get Evaluation License for registration information.
4. When you receive your license, copy it to your computer and then click the Configure button on the AWR License
Configuration dialog box to display the License Configuration dialog box.

Specify your license configuration as Locked license (filename) and set the environment variable by browsing to the
location of your locked license file or manually entering the path, then click OK.
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FLEXlm locked configuration using a software-based key is complete. To verify FLEXlm operation, see “Verifying that
a License Can Be Checked Out”.

3.1.2. Configuring Locked Licensing with a Hardware-Based Key
The following procedure configures your machine for FLEXlm locked licensing with a hardware-based key calculated
from the serial number of the hardware dongle attached to your machine's USB port. Cadence supplies you with the
hardware key. In this configuration, the AWR Design Environment platform software is installed on your machine, but
the license can be transferred between machines simply by moving the hardware dongle.
Installing with a USB Hardware Key
To install with a USB hardware key:
1. Download and install the latest Sentinel HASP4 device driver from
http://sentinelcustomer.safenet-inc.com/sentineldownloads/, or run the HASPUserSetup.exe file from the FLEXlm
Utilities in the Cadence AWR Knowledge Base.
2. Cadence supplies you with a license file. When you receive your license, copy it to your computer and then in the
AWR License Configuration dialog box, click the Configuration button. In the License Configuration dialog box,
specify the desired license configuration and directory path.
FLEXlm locked configuration using a hardware-based key is complete. To verify FLEXlm operation, see “Verifying
that a License Can Be Checked Out”.

3.2. Configuring Floating Licensing
In a FLEXlm floating licensing configuration, the license file is assigned to a machine designated as the FLEXlm license
server. Each client workstation runs the Cadence Microwave Office® software or Cadence Visual System Simulator™
(VSS) communications and radar systems design software, requesting licenses from the server when needed. If you have
a floating license server running for other Cadence products, you do not need to set up a new service, but you may need
to get and add the awrd.exe license daemon to your cdslmd.exe daemon location.
Cadence tools require FlexLM version 11.15 or later. You can download the FLEXlm drivers and tools as described in
“Obtaining the License File”.

3.2.1. Configuring Floating Licensing on the License Server
Perform the following steps on the machine designated as the FLEXlm license server to configure the server.
NOTE: These steps direct you to create a C:\awr_flexlm folder for download of FLEXlm utilities. The "FLEXlm Utilities"
link in the first step provides several download locations for the utilities. If you choose to download the utilities from
the Cadence download site they are installed in a C:\Cadence\LicenseManager folder. All steps in this procedure apply
when working from this folder as well.
Obtaining the License File
Skip this section if you already received your license file.
To obtain the FLEXlm license file:
1. Create a C:\awr_flexlm directory and download the FLEXlm Utilities from the Cadence AWR Knowledge Base.
These files run, debug, and maintain the FLEXlm license manager. Cadence license files are sent as .txt files. You
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can configure the server using this file, but LMTOOLS filters for .lic files, so you need to either override the filter or
change the file extension.
2. To obtain a valid FLEXlm license file, you must provide the machine's Ethernet address (hostID) as well as the
hostname. Locate and launch the lmtools.exe program included with the FLEXlm files. The LMTools dialog box
displays.
3. Click the System Settings tab.
4. E-mail the value in Ethernet, the value in Computer/Hostname, and your name, company name, address, phone number,
and purchase order number or invoice number to Cadence at awr.licenses@cadence.com.

Editing the License File
1. After you receive the license file, Cadence highly recommends you rename the file to awrd.lic and place it in your
C:\awr_flexlm directory.
2. Open awrd.lic in a text editor and check the line starting with "SERVER". If you see "Cadence_SERVER" as shown
here, replace it with the correct machine name and save the file.
SERVER Cadence_SERVER 00abcdef1234 5280
3. In the "SERVER" line, there is a port number assigned for use with the server. By default the port number assigned
is 5280 per the previous example. You can use this port number or replace it with a different number. If there is a port
number currently used with the Cadence license server, for simplicity you should use that port number.
Installing the FLEXlm Server
These instructions cover a simple FLEXlm license server installation. More complex configurations are described in the
License Administration Guide included with the FLEXlm Utilities in the Cadence AWR Knowledge Base.
To install the FLEXlm Server:
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1. If applicable, copy to your C:\awr_flexlm directory the awrd.exe, lmflex.exe, lmgrd.exe, lmtools.exe, lmutil.exe,
cdslmd.exe, and lmutil.exe files by downloading the FLEXlm Utilities.
2. If the Cadence license file awrd.lic is in the same folder as awrd.exe and cdslmd.exe you can proceed to the next step,
otherwise you need to edit the license file with a text editor to include the absolute path to awrd.exe and cdslmd.exe.
3. Start lmtools.exe. The LMTOOLS dialog box displays.
4. Click the Service/License File tab.
5. If you previously installed and set up FLEXlm services, select Config Services and specify AWR License Manager. If
you have not previously installed FLEXlm services, proceed to the next step.
6. Click the Config Services tab and verify that your settings match the following:
Service Name:

"AWR License Manager"

Path to the lmgrd.exe file:
Path to the license file:

"C:\awr_flexlm\awrd.lic"

Path to the debug log file:
Use Services:

"C:\awr_flexlm\lmgrd.exe"

"C:\awr_flexlm\debug.log"

(selected)

Start Server at Power Up:

(selected)

7. Click Save Service to save these settings. When asked to confirm saving the settings for the license server, click Yes.
8. Click the Start/Stop/Reread tab and click the Start Server button to start the FLEXlm license server.
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Note the "Server Start Successful" message that displays in the Status bar at the bottom of the dialog box.
9. Click the Server Status tab and specify awrde as the Individual Daemon, then click Perform Status Enquiry to display
information about the server status.
NOTE: The first few times you start the license server, you should view the debug file C:\awr_flexlm\debug.log for
any messages. You may first need to stop the license service if it has a lock on the file.

10. If necessary, click the Server Diags tab and then click the Perform Diagnostics button to diagnose any problems.
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11. Choose File > Exit to close the LMTOOLS license service.
FLEXlm server configuration is complete. To verify FLEXlm server operation, see “Verifying that a License Can Be
Checked Out”.

3.2.2. Configuring Floating Licensing on Client Workstations
The AWR Design Environment platform software must be installed on the client machines. For instructions on installing
the program, see “Installing the AWR Design Environment”.
Perform the following steps on the client machines to configure FLEXlm clients:
1. In the AWR License Configuration dialog box, click the Configure button to display the License Configuration dialog
box and set the CDS_LIC_FILE environment variable.
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2. In the License Configuration dialog box, select Floating license (port@server or port@server1;port@server2...) to set
<portNumber>@<serverName>
where <portNumber> is the port number described in the license file and <serverName> is the name of the
server machine. These variables are defined on the SERVER line of the license file in the following format:
SERVER <serverName> <hostID> <portNumber>

For example:
SERVER myserver 00abcdef1234 5280
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To use the floating license file directly, select Floating license with file (filename) to specify the file name. This option
only works if the client computers can access the network location where the license file is located. In this mode, the
port number and host name are read directly from the license file instead of setting them directly. The advantage of
this method is that if you need to change port numbers, you can change the license file only, with no need to update
client machine settings.

3. If applicable, copy the lmflex.exe, lmutil.exe, and lmtools.exe files FLEXlm Utilities in the Cadence AWR Knowledge
Base to your C:\awr_flexlm directory. These utilities are used to troubleshoot the FLEXlm licensing configuration.
FLEXlm client configuration is complete. To verify FLEXlm client operation, see “Verifying that a License Can Be
Checked Out”.

3.3. Configuring Single User Licensing
The following steps configure your machine for Single User Licensing (SUL). In this configuration, the AWR Design
Environment software is installed on and licensed to your particular machine. Licenses are individually assigned by the
license administrator identified at your company.

3.3.1. Creating a Cadence Entitlement Management System Account
License administrators assign SUL licenses through the Cadence Entitlement Management System (EMS).
1. When you are identified as a SUL client, you receive an email with a link to register in EMS. The email and password
that you register with are later used to download your license file.
2. Sign into EMS to see your entitlements (product licenses). You will receive an email whenever you are assigned new
entitlements. Do not proceed with SUL setup until you are granted entitlements for the AWR Design Environment
software.

3.3.2. Downloading the SUL File
The AWR Design Environment software must be installed on your machine. For instructions on installing the program,
see “Installing the AWR Design Environment”. You must also have AWR Design Environment platform entitlements in
EMS.
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Perform the following steps on your machine to configure SUL:
1. In the AWR License Configuration dialog box, click the Configure button to display the License Configuration dialog
box.

2. In the License Configuration dialog box, select Single User License. Enter the Username and Password you used to
register in EMS, then click Download.. Only your username is remembered on the machine. The password is never
stored.
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3. A status window displays the license generation and download progress. The entire process can take several minutes.
When the download is complete, a new dialog box displays to indicate that your single user license is ready. Click
OK to close the dialog box. The downloaded license.txt file is located in the
C:\Users\<USER_NAME>\AppData\Roaming\Cadence\VBL\AWR\license folder where <USER_NAME> is your
computer login name.

4. Once you have downloaded a SUL, there is no need to enter the password and download a license again, even when
changing between license configurations, until there has been a change in your entitlements (product licenses).
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Chapter 4. Troubleshooting FLEXlm
This chapter references the information and tools available to verify the operation of and troubleshoot a FLEXlm licensing
environment. It provides a troubleshooting walk-through designed to verify FLEXlm operation and identify any errors
made during FLEXlm configuration, includes descriptions of the command line programs and Windows®-based program
(for example, FLEXlm Toolbox's LMTOOL program) that you can use during verification and troubleshooting, and
provides solutions to the FLEXlm-related errors that may occur during Cadence® AWR Design Environment® platform
operations.
If you cannot solve a FLEXlm-related problem using this information, contact Technical Support for AWR Products.
For additional information on FLEXlm and FLEXlm management tools, see the License Administration Guide available
from the FLEXlm Utilities from the Cadence AWR Knowledge Base.

4.1. FLEXlm Troubleshooting Walk-through
You can use the following procedures to verify FLEXlm configuration and operation and identify the most common
configuration errors.

4.1.1. Checking License File Location
To check client settings, follow these steps on the client workstations:
1. In the AWR Design Environment program, choose File > License > Configuration. The AWR License Configuration
dialog box displays.
2. Click Configure to display the License Configuration dialog box and set it to <portNumber>@<servername> where
<portNumber> is the TCP/IP port number.

4.1.2. Checking License Server Configuration
To check the license server configuration, follow these steps on the server machine:
1. Start lmtools.exe. The LMTOOLS dialog box displays.
2. Click the Config Services tab.
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3. If you have only one copy of FLEXlm running on the server, the Service Name should be AWR License Manager. If
you have more than one copy, make sure the correct service name is selected.
4. Verify that Path to the lmgrd.exe file points to the AWR Design Environment platform version of the lmgrd.exe file.
(Since each application using FLEXlm can ship its own version of lmgrd.exe, you must use the one shipped with the
AWR Design Environment platform software.)
5. Verify that Path to the license file points to the full path name of the correct license file.
6. Verify that Path to the debug log file specifies a file name on the license server.
7. Click the Server Status tab, and then click Perform Status Enquiry to verify that the FLEXlm Version is 11.15 or later
and that the connection to the server was successful.
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4.1.3. Restarting the License Server
To restart the license server on the server machine:
1. Start lmtools.exe. The LMTOOLS dialog box displays.
2. Click the Start/Stop/Reread tab.
3. Click Stop Server, and wait for at least 10 seconds to ensure that all processes have stopped. If the license service was
not running, this command fails. Continue regardless.
4. Click Start Server. A "Server Started" message should display.

4.1.4. Checking the Debug Log
To check the debug log file on the server machine:
1. On the Config Services tab of the LMTOOLS dialog box, click View Log, or open the Debug.log file in a text editor.
Note that it can take up to 30 seconds for text to display in this file. If you get a message that another program has
control of this file, stop the license server, then try to open the debug log file again.
2. Verify the relevant information in the file, as follows:
• Make sure that you are looking at the latest information by checking the time stamp.
• Check for:
FLEXlm (v11.15)

if you see a lower version, you are running the wrong lmgrd.exe.
• Check for:
License file(s): <mwo_license_file>
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where <mwo_license_file> is the name of the license file.
• Check for:
lmgrd tcp-port <nnnnn>

where <nnnnn> is the TCP/IP port on which FLEXlm is running. (The default port range is 27000-27009, however,
other values can be set via the SERVER line in the license file.)
• Check for:
Started awrd (internet tcp_port 0 pid xxx)

to verify that the vendor daemon has started.
• Check for:
Server started on serverName
for: feature1, feature2, ..., featureN

to verify which features are being served. This list should match the features listed in your license file.

4.1.5. Verifying that a License Can Be Checked Out
To verify that a FLEXlm license can be checked out on the server or client machines, follow these steps on the machine:
1. At a command prompt, from the C:\awr_flex directory for servers, or from the program directory for clients, run
lmflex.exe. The following table summarizes the different AWR Design Environment platform product features.
2. Enter a feature specified in your license file (for example, "MWO_225"). The command output tells you if the feature
was successfully checked out.
MWO_225 checked out...press return to exit...

3. If the feature cannot be checked out, a dialog box displays to inform you. See “Troubleshooting FLEXlm” for instructions
on finding possible causes for the problem.

4.1.6. FLEXlm Diagnostic Tools
To verify FLEXlm operation, you can either invoke the command line based lmutil.exe program or run the Windows-based
FLEXlm Toolbox program. For complete details, see the FLEXlm End Users Guide.
Command Line Program: lmutil.exe
To determine who has licenses checked out, at the command prompt, change to the C:\awr_flex directory and run
lmutil.exe as follows. The command output lists the status of the license manager, the number of licenses available, and
who has licenses checked out. For example:
C:\awr_flexlm> lmutil
lmstat -a
lmutil - Copyright (C) 1989-2009
Globetrotter Software, Inc.
Flexible License Manager status on Thu 8/25/2008
20:44
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[Detecting lmgrd processes...]
License server status: 27007@mizar
License file(s) on mizar: C:\awr_flexlm\awrd.lic:
mizar: license server UP (MASTER) v9.1
Vendor daemon status (on deneb):
awrd: UP v9.2
Feature usage info:
Users of MWO-228: (Total of 1 license
available)
"MWO-228" v8.0, vendor: awrd
floating license
slr Mizar Mizar (v8.0) (deneb/27007
103), start Thu 8/25 20:44

4.2. Solutions to FLEXlm-related Problems
This section lists some of the FLEXlm-related problems you may encounter when starting or running the AWR Design
Environment software. Additional troubleshooting information is available in the appendices of the License Administration
Guide available from the FLEXlm Utilities from the Cadence AWR Knowledge Base. For an online License
Troubleshooter, see License Troubleshooter.
Problem

Cause

Solution

A Choose Server or
File dialog box
displays.

The AWR Design Environment software cannot Click Cancel in this dialog box and follow the
connect to the license server. This could be
instructions in “Troubleshooting FLEXlm”.
because the license server is running on a
different port, running on a machine different
from the one specified, or not running at all.

A "License server does
not support this version
of this feature
FLEXLM error:
-25,147" message
displays.

Each FEATURE line in the license file contains
a version number field that determines what
versions of the software it authorizes. This field
displays after the "awrd" and before the date.
The following are the license versions that
correspond with the various AWR platform
releases:
Version: 22.1 ProductRelease: AWRDE V22.1
Version: 16.0 ProductRelease: AWRDE V16
Version: 15.0 ProductRelease: AWRDE V15
Version: 14.0 ProductRelease: AWRDE V14
Version: 13.0 ProductRelease: AWRDE V13
Version: 12.0 ProductRelease: AWRDE V12
Version: 11.0 ProductRelease: AWRDE V11
Version: 10.0 ProductRelease: AWRDE V10
Version: 9.03 ProductRelease: AWR Suite 2010
Version: 9.0 ProductRelease: AWR Suite 2009
(V9.0)
Version: 8.0 ProductRelease: AWR Suite 2008
(V8.0)
Version: 7.5 ProductRelease: AWR Suite 2007
(V7.5)
Version: 1.7 ProductRelease: AWR Suite 2006
(V7.0)

If you are on maintenance, request a new license
file for the new version of the AWR Design
Environment software from Cadence. If you are
not on maintenance, you will need to purchase
an upgrade to run the new version.
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Problem

Cause

Solution

Version: 1.6 ProductRelease: AWR Suite 2004
(V6.5)
Version: 1.5 ProductRelease: AWR Suite 2003
(V6.x)
Version: 1.4 Product Release: AWR Suite 2002
(V5.x)
Version: 1.3 Product Release: MWO 2001
(V4.02)
Version: 1.2 Product Release: MWO 2000
(V3.22)
Version: 1.1 Product Release: MWO V2.6
A "Cannot connect to FLEXlm has a default port range of
server" message
27000-27009. If the port specified in your
displays.
license file is within this range, you can specify
the CDS_LIC_FILE in the form
@<serverName>. Although this works on
most machines, it can cause problems on some.

Specify a port number that does not conflict
with any other servers in the SERVER line of
the license file. (All AWR Design Environment
platform license files now use a specific port
number to avoid this problem.) For example, if
your current SERVER line is :SERVER name
0000aaaabbbb you would change it to:
SERVER name 0000aaaabbbb 27033
where "27033" is the TCP/IP port number now
specified for your license file. You also need to
change the CDS_LIC_FILE environment
variables on all of the client workstations from
@<serverName> to
27033@<serverName> .

An "(awrd) Invalid
The license file has been improperly edited or
license key
created.
(inconsistent
encryption code for
...)" message displays
(this message can also
display in the
Debug.log file).

Open the license file in a text editor such as
Windows Notepad. If the license file is for a
floating configuration, the first line starts with
SERVER and the second line starts with
DAEMON. Verify that the lines are not merged
together and that there are no invalid control
characters in the file. FEATURE or
INCREMENT lines (are present in both floating
and locked license files. The FEATURE or
INCREMENT lines are usually line-wrapped, so
they will always start with FEATURE or
INCREMENT and end in a backslash, with the
second line starting with VENDOR_STRING.
For example:FEATURE MWO_225 awrd
1.7 13-mar-2002 1 D25C75B75E80
\VENDOR_STRING=cg123
HOSTID=00104b72d5f7 ck=191 If the
license file does not conform to these rules, it
is probably because your e-mail program cannot
interpret it correctly. Send the license file to
Cadence at awr.licenses@cadence.com
for a purchased license or at
awr.registrar@cadence.com for an
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Problem

Cause

Solution
evaluation license, and Cadence will attempt to
send it to you in a format that your e-mail
program understands.
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Appendix A. Installation Program Reference
This appendix provides information about the Cadence® AWR Design Environment® platform installation programs.
These programs are automatically invoked by the installation program, but you can also run them from the Windows®
Start > Run command or from a command prompt if, for example, you want to create script files to perform network
rollouts.

A.1. Addin Manager: ADDINMANAGER.EXE
The Addin Manager allows you to enable/disable dynamically loadable DLLs to aid in troubleshooting. You can browse
for a DLL and register it within the AWR Design Environment program without needing to use the Windows Registry
Editor (regedit.exe).
At startup, the AWR Design Environment program first searches the program installation directory for a DLL. If the
DLL isn't stored there, it locates and uses the registered version.
To open the Addin Manager choose Tools > Manage Addins. The Addin Manager displays with a list of add-in programs
in several categories: EM Simulators, General, Wizards, and all of these categories, (All). Select each option to view a brief
description of it in the Description area of the dialog box. To disable the DLL for an addin, clear the associated check
box.
You can also start the Addin Manager by launching AddinManager.exe from the AWR Design Environment program
directory.

A.2. AWR Design Environment Installation Program
A.2.1. Description
The AWR Design Environment platform software is distributed as an executable bootstrapper containing a set of executable
files for installing the AWR Design Environment software and dependencies. At run-time, the bootstrapper determines
which of these files needs to be executed to complete the installation.

A.2.2. Command Line Format
awrde_<version>.exe [arguments]

Argument

Opt./Mand.

Description

/?

optional

Displays current command usage for install, user interface
mode, logging, and component arguments

/i

optional

Command line installation

/DisplayConfig

optional

Displays the IDs and display names of the individual
bootstrapper components

/ComponentArgs
"AWRDE":"value"

optional

Passes additional arguments to the AWR Design Environment
software installer.
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Command line

Description

awrde_<version>.exe

Install the AWR Design Environment software
in graphical user interface mode.

awrde_<version>.exe /?

Display installation options.

awrde_<version>.exe /qb

Install the AWR Design Environment software
in basic silent mode to the default location.

awrde_<version>.exe /ComponentArgs
AWRDE:"TARGETDIR=C:\AWRDE /LOG /LogFile
awrdeinstall.log"

Install the AWR Design Environment software
to C:\AWRDE and write the install log to
awrdeinstall.log

awrde_<version>.exe /q /ComponentArgs
"AWRDE":"TARGETDIR=""C:\My Location\AWRDE""

Install the AWR Design Environment software
silently to a path containing spaces (C:\My
Location\AWRDE)

awrde_<version>.exe /x

Uninstall the software.

awrde_<version>.exe /ExtractCab

Extract the embedded components from the exe.
This allows access to the msi and other
components.

ComponentArgs Examples
The default lpf installed is MMIC.lpf(2). To override this file, use the DEFAULTLPF_FILE and following chosen value:
MIC_english.lpf
MMIC.lpf
MIC_metric.lpf

DEFAULTLPF_FILE="1”
DEFAULTLPF_FILE="2"
DEFAULTLPF_FILE="3"

To disable a particular extension, set the following property on the msiexec command line:
EXTENSION_CAL=""
EXTENSION_DXF=""
EXTENSION_GDS=""
EXTENSION_SF=""

For example, to install the software by disabling all of these file extensions and writing the installation log to awrinstall.log
in a C:\Temp folder, type the following:
awrde_<version>.exe /qb /LOG /Logfile C:\Temp\awrinstall.log /ComponentArgs "AWRDE":"
"EXTENSION_CAL=""" "EXTENSION_DXF=""" "EXTENSION_GDS=""" "EXTENSION_SF="""

A.3. Job Scheduler Service Installation
A.3.1. Description
This section provides information for installing the Job Scheduler service for remote computing.

A.3.2. Command Line Format
The following command line syntax installs the AWR Design Environment software with the Job Scheduler Service
argument.
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awrde_<version>.exe /ComponentArgs "AWRDE":"JOBSERVICE=YES" /LOG /LogFile awrdeinstall.log

The following example shows how to pass multiple arguments to the AWR Design Environment software installer. The
following command line syntax installs the AWR Design Environment software with the Job Scheduler service to the
specified directory C:\AWRDE\MyChosenLocation.
awrde_<version>.exe /ComponentArgs "AWRDE":"JOBSERVICE=YES
TARGETDIR=C:\AWRDE\MyChosenLocation" /LOG /LogFile awrdeinstall.log

After running the installer, you must configure the service to use the Cadence license daemon. The first step is to specify
the license file location upon starting the AWR Design Environment software, or by running LicLocSetup.exe from the
AWR Design Environment platform installation directory. The second step is to edit the mwoffice.ini file so that the Job
Scheduler service uses the CDS_LIC_FILE environment variable instead of the AWRD_LICENSE_FILE environment
variable. You need to complete the following steps on all scheduler and compute nodes:
1. Stop the Job Scheduler service.
2. Open the mwoffice.ini file with a text editor. The default location is: C:\ProgramData\AWR\Design
Environment\17.0\mwoffice.ini.
3. Search for the "[License]" section. If it does not exist, add it.
4. Add "Vendor = 2" as follows:
[License]
Vendor=2

5. Restart the Job Scheduler service.
See the AWR Design Environment Simulation and Analysis Guide for details on managing the service.
After installation, open the Windows Task Manager and click the Services tab to verify that the AWR_JobScheduler
service is listed with its Status as "Running". For further details and service options, click the Services button at the
bottom of the window to display the Services window. After the Job Scheduler is registered as a service, it launches
whenever Windows starts and serves jobs on that computer until the computer shuts down or you stop the service. See
the Simulation and Analysis Guide for information on stopping and removing the Job Scheduler Service.
NOTE: Running the AWR Design Environment software installer again switches the version of the Job Scheduler service
to that of the most recent installation. When installing multiple versions of the AWR Design Environment software on
a remote computer, you should install from the lowest to the highest version number to ensure that the highest version
of the Job Scheduler service is installed. See the Simulation and Analysis Guide for information on manually changing
the service version.
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