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x AWR Design Environment

Chapter 1. Preface
The Cadence® AWR Design Environment® platform incorporating Cadence Microwave Office® software and Cadence
Visual System Simulator™ (VSS) communications and radar systems design software, is a powerful fully-integrated
design and analysis tool for RF, microwave, millimeterwave, analog, and RFIC design that allows you to incorporate
circuit designs into system designs without leaving the AWR Design Environment platform.
Microwave Office software allows you to create complex circuit designs composed of linear, nonlinear, and EM structures,
and generate layout representations of these designs. They allow you to perform fast and accurate analysis of your designs
using linear, nonlinear harmonic balance, electromagnetic (EM), Cadence APLAC® HB simulator, and Spectre simulation
engine, and feature real-time tuning and optimizing capabilities.
VSS software is the system level design component of the AWR Design Environment platform. With this software you
can analyze a complete communications system, from data encoding through transmission, reception, and data decoding.

1.1. About This Book
The Microwave Office Layout Guide describes how to create layout representations of your designs in Microwave Office
software.
Chapter 2 provides an overview of the layout process. Chapters 3 through 5 describe layout editing, configuration,
verification, and export.

1.1.1. Additional Documentation
The AWR Design Environment platform includes the following additional documentation:
• What's New in AWR Design Environment v16? presents the new features, user interface, elements, system blocks, and
measurements for this release.
• The AWR Design Environment Installation Guide describes how to install the AWR Design Environment platform
and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips.
This document is downloadable from the Cadence AWR Knowledge Base.
• The AWR Design Environment Getting Started Guide familiarizes you with the AWR Design Environment platform
through Microwave Office software, VSS software, Cadence Analyst™ 3D FEM EM analysis software, and Monolithic
Microwave Integrated Circuit (MMIC) examples.
Microwave Office example projects show how to design and analyze simple linear, nonlinear, and EM circuits, and
how to create layouts. VSS examples show how to design systems and perform simulations using predefined or
customized transmitters and receivers. Analyst examples show how to create and simulate 3D EM structures from
Microwave Office, and MMIC examples show MMIC features and designs.
You can perform simulations using a number of simulators, and then display the output in a wide variety of graphical
forms based on your analysis needs. You can also tune or optimize the designs, and your changes are automatically
and immediately reflected in the layout.
• The AWR Design Environment User Guide provides an overview of the AWR Design Environment platform including
chapters on the user interface; using schematics/system diagrams, data files, netlists, graphs, measurements, and output
files; using variables and equations in projects, and more. In addition, an appendix providing guidelines for starting a
new design is included.
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• The AWR Design Environment Dialog Box Reference provides a comprehensive reference of many AWR Design
Environment platform dialog boxes with dialog box graphics, overviews, option details, and information on how to
navigate to each dialog box.
• The AWR Design Environment Simulation and Analysis Guide discusses simulation basics such as swept parameter
analysis, tuning/optimizing/yield, and simulation filters; and provides simulation details for DC, linear, AC, harmonic
balance, transient, and EM simulation/extraction theory and methods.
• The AWR Microwave Office Element Catalog provides complete reference information on the electrical element
model database that you use to build schematics.
• The AWR Visual System Simulator System Block Catalog provides complete reference information on all of the
system blocks that you use to build systems.
• The AWR Microwave Office Measurement Catalog provides complete reference information on the "measurements"
(computed data such as gain, noise, power, or voltage) that you can choose as output for your simulations.
• The AWR Visual System Simulator Measurement Catalog provides complete reference information on the measurements
you can choose as output for your simulations.
• The AWR Visual System Simulator Modeling Guide contains information on simulation basics, RF modeling
capabilities, and noise modeling.
• The AWR API Scripting Guide explains the basic concepts of AWR Design Environment platform scripting and
provides coding examples. It also provides information on the most useful objects, properties, and methods for creating
scripts in the AWR Script Development Environment (AWR SDE). In addition, this guide contains the AWR Design
Environment Component API list.
• The AWR Design Environment Quick Reference document lists keyboard shortcuts, mouse operations, and tips and
tricks to optimize your use of the AWR Design Environment platform. This document is available within the program
by choosing Help > Quick Reference.

1.1.2. Typographical Conventions
This guide uses the following typographical conventions to help you follow instructions quickly and easily.
Item

Convention

Anything that you select (or click on) in the AWR Design Shown in a bold alternate font. Nested menu selections are
Environment program, such as menus, nested submenus, shown with a ">" to indicate that you select the first menu
menu options, dialog box options, buttons, and tab names item and then select the submenu item:
Choose File > New Project.
Text that you enter using the keyboard

Shown in a bold within quotation marks:
Enter "my_project" in Project Name.

Keys or key combinations that you press

Shown in a bold alternate font with initial capitals. Key
combinations using a "+" indicate that you press and hold
the first key while pressing the second key:
Press Alt+F1.

File names and directory paths

Shown in italics:
See the DEFAULTS.LPF file.
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Item

Convention

Contents of a file, fields within a file, command names,
Shown in a mono-spaced font:
command switches/arguments, or output from a command
Define this parameter in the $DEFAULT_VALUES field.
at the command prompt

1.2. Getting Online Help
The AWR Design Environment platform online Help provides information on the windows, menus, and dialog boxes
that compose the design environment, as well as on the concepts involved.
To access online Help, choose Help from the menu bar, or press F1. The Help menu includes the following options:
Menu Choice

Description

Contents and Index

Open the online Help file to view AWR Design Environment platform Help
topics organized by book/subject, or to search the Help contents by index or
character string.

Help on Selected Item

Access Help on the currently selected item.

Getting Started

View the "Getting Started Guide" that includes introductory material for all
products.

What's New

View the "What's New" document for information about new or enhanced
features, elements, and measurements in the latest release.

Quick Reference

View the AWR Design Environment Quick Reference document to learn keyboard
shortcuts, mouse operations, and tips and tricks to optimize your use of the AWR
Design Environment platform.

Home Page

Open the Cadence AWR web page in your internet browser to the AWR®
software products web page.

AWR e-Learning

Open the e-Learning portal login page in your internet browser to access AWR
software training videos.

Knowledge Base

Open the AWR Knowledge Base in your internet browser to access to a variety
of AWR software documentation and other resources.

Get Technical Support

Access the Cadence Learning and Support portal to search for answers to software
or licensing issues or file a Support case.

Check for Update

Check for Cadence AWR software updates using an Autoupdate utility.

Show Files/Directories

Display/open a list of the files and directories the program uses.

Open Example

Display the Open Example Project dialog box to locate a specific project in the
/Examples subdirectory by filtering by keywords or project name.

Show License Agreement

Display the AWR Design Environment platform End User License Agreement.

About

Display AWR software copyright, release, license, and registration information.

In addition, the following context-sensitive Help is available:
• Context-sensitive Help buttons in each dialog box. For example, to view Help for a specific measurement, select the
measurement in the Add/Modify Measurement dialog box, and click the Meas. Help button.
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• Context-sensitive Help for each element or system block in the Element Browser, accessed by right-clicking an element
and choosing Element Help. You can also access element Help by choosing Help > Element Help after creating a schematic
or system diagram, or by clicking Element Help in the Element Options dialog box.
• Context-sensitive Help for using the AWR Script Development Environment, accessed by selecting a keyword (for
example; object, object model, or Visual Basic syntax), and pressing F1.

1–4 AWR Design Environment

Chapter 2. Layout Overview
The Cadence® Microwave Office® software layout module uses an object-oriented design database to manage the
association between schematics and layout. Each electrical component in a schematic is assigned a layout representation.
The layout representation is used to create the physical Layout View of each electrical component in the schematic. Since
the electrical component and the layout representation are treated as a single object, any changes to the electrical object
are immediately reflected in the layout object and vice-versa. This close association between the electrical component
and the layout representation virtually eliminates the time consuming and error prone back-annotation that is typically
required to synchronize schematics and layouts in other systems.
You can select the layout representations that are assigned to each electrical component. There are several different types
of layout objects that you can assign to electrical components.

2.1. The Layout as Another View of the Schematic Database
The Schematic View and the Layout View are two views of a single intelligent database that manages the connectivity
between the circuit components. The single database approach eliminates the need for complex design synchronization
and back annotation. Any change to the circuit component in either the Schematic View or the Layout View is immediately
updated in the other view. Each circuit component has a layout representation that is used to draw the component in the
Layout View. Circuit components with their layout representation set to "none" do not draw anything in the Layout View.
Any circuit component can have its layout representation changed to use a different layout cell, so components with no
("none") default layout cells can be assigned artwork cells, or components with parameterized cells can be set to have
no layout representation.
To view the circuit component for a specific layout or artwork cell, select the cell in the layout window, right-click and
choose Select in Schematic. The schematic window displays with the associated circuit component highlighted.
Drawing shapes (created using the Microwave Office drawing tools) that are not associated with any circuit component
can also be added to the Layout View. These layout objects become part of the schematic database but do not have an
associated schematic element.
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Figure 2.1. Schematic and Layout Views
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For details about working between the Schematic View and the Layout View, see “Schematic and Schematic Layout
Interaction ”.

2.2. Layout Objects (Cells)
A layout usually requires a library of layout cells that is specialized for a particular process. A MMIC foundry library is
a good example. A MMIC foundry library uses the following different types of layout cells:

2.2.1. Built-in Parameterized Cells
Parameterized cells are layout representations that use the parameter values of the electrical components to render the
layout representation. A good example is a microstrip line, which uses the width (W) and length (L) parameters to draw
a rectangle of width W and length L. Microwave Office software has parameterized cells built in for most of the standard
microstrip, stripline, and coplanar waveguide components. Parameterized cells can be easily configured for a particular
process in the Layout Process File (LPF). This file describes the different types of lines and the drawing layers used to
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construct them. Parameterized cells provide the layout cells for the majority of the components needed in a foundry
library.

2.2.2. Artwork Cells
Artwork cells are standard GDSII or DXF cells that have connection points added to them for use as layout cells. Artwork
cells are used for non-parameterized geometry such as vias, FETs and bias pads. The creation of artwork cells is simple;
the cells are read into or created in the Artwork Cell Editor, and then connection faces are drawn onto the cells and the
cells are saved as a library.

2.2.3. User-Defined Cells
If a more sophisticated parameterized layout cell is required, then a fully parametric layout cell can be created using
standard C++ which is compiled into a DLL that can be easily distributed and shared amongst users. The Cell Wizard,
which is part of a layout customization kit, can help generate the C++ source code. You will need to enter the actual
drawing code by using pre-defined drawing functions.

2.2.4. No Layout (Ports, for Example)
For some electrical components, you may not want a layout representation associated with the component (such as a
parasitic capacitance). When two electrical elements with layout representations are connected together with an electrical
element that does not have a layout representation, the two layout objects appear to be disconnected in the Layout View.
Since most of the foundry library can be created using only the built-in configurable cells and the artwork cells, only a
few parameterized cells typically need to be created for a foundry process. The process for creating these parameterized
cells is described later.

2.3. Layout Fundamentals
A layout of a circuit is automatically created when you open a Layout View from a Schematic View. The Schematic
View is the window that displays the schematic elements. The Layout View is the window that displays the layout objects
of the schematic elements. The creation of a layout starts from the schematic.
The process of creating a layout is illustrated by example. The first step in creating a layout is to create a new schematic
in the project. You can add a new schematic to the project by right-clicking Circuit Schematics in the Project Browser
and choosing New Schematic. When a new schematic is added, a schematic node is added under Circuit Schematics in the
Project Browser, and a Schematic View automatically opens. All editing of the schematic is done in the Schematic View
(the window the schematic is displayed in). The schematic that displays under Circuit Schematics in the Project Browser
represents the schematic database (it contains the objects that are displayed in the Schematic View). Schematic elements
can then be added to the schematic.
To access schematic elements, click the Elements tab on the main window to display the Elements Browser. You can
add schematic elements to the schematic by dragging the elements from the Elements Browser into the Schematic View.
You can also add elements using the Add Element command which allows you to select elements from a list dialog box
that supports filtering by element name, description, or library path. In a Schematic View, choose Draw > More Elements
to display the Add Element dialog box. The Schematic Design toolbar also includes an Element button. The following
figure shows a schematic with four schematic elements. The schematic database contains the schematic element objects
(the objects are shown drawn in gray boxes), while the Schematic View is used to view and edit the contents of the
schematic database. The schematic database also defines the connectivity between the schematic elements within the
database.
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Figure 2.2. Connectivity Between Schematic Elements
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The layout for the schematic shown in Figure 2.2, “Connectivity Between Schematic Elements” is created by first opening
a Schematic View, and then opening a Layout View of the schematic from the Schematic View (if a Schematic View is
already open, activate the Schematic View by clicking on its window). The Layout View is created by choosing View >
View Layout while in a schematic window. The layout can also be created by clicking the View Layout button on the
toolbar.

The following figure illustrates the initial layout created for the example shown in Figure 2.2, “Connectivity Between
Schematic Elements”. When the Layout View is opened, layout objects are automatically created for all schematic
elements that have a default layout cell. As shown in the following figure, the two microstrip lines (TL1 and TL2)
automatically have layout objects created. The default layout cells for the microstrip lines are parameterized layout cells
that use the width and length parameters of the schematic element to define the width and length of the layout
representation. The layout objects are directly linked to the corresponding schematic elements in the schematic database.
The links are shown with heavy arrows in the following figure. The capacitor element does not have a default layout
cell, so no layout objects are automatically created for the two capacitors. The only layout objects that are visible in the
Layout View are for the two microstrip lines.
The connectivity defined in the schematic is used to define the connectivity of the layout objects in the Layout View.
When the connection points (called connection faces) for the layout objects are not connected directly together, a
connection line is drawn, as shown in the following figure, to indicate the connection between the two microstrip lines.
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Choose Options > Layout Options and in the Layout Options dialog box on the Layout tab, set Snap together to Auto Snap
on parameter changes. This allows the layout objects to automatically reposition so their connection faces connect together
by choosing Edit > Snap Objects > Snap Together or by clicking the Snap Together button on the toolbar. You can also
simply select the layout elements and then click the Snap Together button.

Figure 2.3. Connected Schematic Elements
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The following figure shows the results of selecting Snap Together on the layout in Figure 2.3, “Connected Schematic
Elements”.
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Figure 2.4. Schematic with Polygon Added
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Layout shapes that are not linked to schematic elements can also be added directly to the Layout View. For example, to
draw a polygon in the Layout View, choose Draw > Polygon. The polygon is drawn by clicking in the Layout View for
each point. Double-clicking, or clicking on top of the first point already drawn closes the polygon. The following figure
shows a schematic that has a drawing shape (a polygon) added to the Layout View. The drawing shape is stored in the
schematic database with the rest of the layout objects, but it does not have any links to any of the schematic element
objects stored within the schematic database. The ability to intermix both linked and non-linked drawing entities provides
a great deal of flexibility when creating a layout. You can manually place these layout cells, or you can use the placement
feature to place the cells in a specified x-y direction relative to one another by selecting the cells and choosing Edit >
Place All to display the Place All dialog box.
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Figure 2.5. Layout View with Linked and Non-Linked Drawing Objects
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There are two types of layout cells that can be linked to a schematic element. The first type shown in Figure 2.3, “Connected
Schematic Elements” is a parameterized layout cell that uses the element parameters to automatically generate the layout
shapes associated with the layout cell. The other type is an artwork cell. Artwork cells have a fixed geometrical
representation that is not parameterized. The artwork cells are stored in GDSII or DXF libraries. Standard file formats
are used for artwork cells to provide greater flexibility when creating and maintaining libraries of artwork cells. Figure 2.6,
“Artwork Cell Editor and Libraries ” illustrates how the artwork cell libraries are related to the rest of the layout system.
It shows a GDSII library that contains two artwork cells (stored as GDSII instances). The cell libraries and artwork cells
are managed through the Layout Manager (click the Layout tab on the main window). The Layout Manager displays all
the artwork cell libraries that are loaded into the project. You can edit an artwork cell by double-clicking on it in the
Layout Manager to open it in the Artwork Cell Editor window as shown in Figure 2.6, “Artwork Cell Editor and Libraries
”. The artwork cell is used to define both the geometry and the connection faces.
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Layout faces are added to the artwork cell from within the Artwork Cell Editor window by choosing Draw > Cell Port and
then dragging and dropping a line across the desired cell face. You can also access the Cell Port tool in the Draw Tools
toolbar shown above.
Figure 2.6. Artwork Cell Editor and Libraries
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After an artwork cell is either created or loaded from a file within the Layout Manager window, you can link it to a
schematic element. The artwork cell is linked to the schematic element by right-clicking the schematic element in the
Schematic View, and then choosing Properties to display the Element Options dialog box. This dialog box has a Layout
tab that lists the available parameterized and artwork cells with the same number of connection faces as the value specified
in Number of nodes, with which you can associate the schematic element. Layout cells do not need to have the same
number of nodes as the electrical element.
The following figure shows the association between the Layout View and the Schematic View.
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Figure 2.7. Element Linking to Layout Cell or Artwork Cell Objects
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Chapter 3. Layout Editing
3.1. Schematic and Schematic Layout Interaction
When building a schematic, the layout for the schematic is also started. This section presents various ways of working
between the Schematic View and the Layout View of a design.

3.1.1. Element Symbol Color
When building a schematic, the default element symbol color is blue (or the color specified for Element on the Environment
Options dialog box Colors tab). This color indicates that a layout for the element does not yet exist.

MLIN
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After you open a layout window for the schematic, the layout for the element is initialized and placed in an optimal
location. The element symbol color changes to purple by default (or the color specified for Ele with Lay on the Environment
Options dialog box Colors tab) unless you assign the symbol a custom color, in which case it retains that color.
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See “Environment Options Dialog Box: Colors Tab ” for more information about changing these colors.

3.1.2. Initial Layout Shape Placement
When you first view a schematic layout, the layout attempts to arrange the shapes so that they are connected (no rat
lines). As you add new elements (not copy and paste of existing elements), the layout attempts to connect the shapes.
The following figure shows a single element on a schematic, and its layout.
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If you add an MLIN to the schematic and connect it directly to the adjacent MLIN, the schematic and layout display as
follows, with one MLIN element connected to the other.
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If you add an MLIN as above without connecting the nodes, the schematic and layout display as follows.
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If you move the element after placing it or draw a wire to connect the nodes, the layout does not attempt to arrange the
elements to remove rat lines, as shown in the following figure.

3–4 AWR Design Environment

Schematic and Schematic Layout Interaction

This occurs because the layout object was already placed, and the Cadence® AWR Design Environment® platform
software does not automatically move items or snap them together.
After initial element placement, there are several options for changing shape location without manually moving a shape
in layout, including using snapping and placement commands.

3.1.3. Snapping Layout Cells
A snapping function attempts to move shapes so the shapes are all connected. In some schematics it is not possible to
connect every shape in the layout, so the layout contains rat lines.
The Snap Together button (command) is available on the Schematic Layout toolbar

or by choosing Edit > Snap Objects > Snap Together. The Layout Options dialog box Layout tab Snap Together option
allows you to set the snapping mode. See “Layout Options Dialog Box: Layout Tab ” for more information on this dialog
box, including:
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•

Auto snap on parameter changes:

All the layout objects in the active window snap together when using the snap
command or when a parameter is changed for that schematic. This command is always active.

•

Manual snap for all objects:

•

Manual snap for selected objects only:

All the layout objects in the active window snap together when using the snap command.
This command is always active.
Only the items selected in the layout attempt to move when using the snap
command. This command is only active upon selection of a layout object.

The snap command only works on layout objects in the current level of hierarchy. You can choose Edit > Snap Objects
> Snap All Hierarchy to snap the layouts for the current level of hierarchy and lower levels.
Some models can change their length during the snapping process. You can choose Edit > Snap to fit or click the Snap to
Fit button (command) on the Schematic Layout toolbar to make the shapes attempt to change the length of the element.

The following example of a simple layout where the left line is an MTRACE2 element and the right line is an MLIN
element shows use of this command. The MTRACE2 can add bends in the layout while the MLIN cannot.
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If you select the MTRACE2 element and click the Snap to Fit button on the toolbar, the layout does not move the left-most
location of the cell, but the shape is adjusted to connect the layout.

If you select the MLIN element and click the Snap to Fit button on the toolbar, the layout displays as shown in the
following figure. This model cannot add bends so it does its best to connect the shape by adding length and moving the
location.
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3.1.4. Freezing and Anchoring Shapes
Freeze and anchor options are also available to assist in the snapping process. To access these options, select a shape in
layout, right-click and choose Shape Properties to display the Cell Options dialog box. On the Layout tab, select the Freeze
check box to prevent a shape from moving during the snapping process. In the layout, the shape displays with a blue
circle on it to indicate that it is frozen.
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Select the Use for anchor check box to specify that the snapping process starts with that layout object, which means it
should not move. In the layout, the shape displays with a red circle on it to indicate that it is an anchor and will remain
in a fixed location.
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If more than one connected shape is anchored, one of the anchors is used and the others are ignored.

3.1.5. Layout Placement Commands
The following commands assist with placing layout objects, including:
•

Edit > Place in Layout: Select items in the schematic and choose this command to open the layout window. The selected

shapes are in placement mode. Move the cursor around and then click to place the layout objects at the selected location.
•

Layout > Place All:

From a Layout View, this command opens the Place All dialog box.
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After specifying the spacing and clicking OK, all the layout objects are arranged based on their schematic location, as
well as the spacing specified. A layout options control in the layout objects also matches the schematic rotation. See
“Layout Options Dialog Box: Placement Tab ” for more information.
•

Layout > Regenerate layout:

From a Layout View, this command reverts any layout edits and displays the layout as if
it has not been created. A warning message displays to remind you that you cannot undo this operation and you can
lose your layout edits.

This is not a common command and should only be used when the layout is not repairable (for example, you cannot
find items).

3.1.6. Cross-selecting in Views
When working in one view (schematic or layout), you can easily identify and select the same object in the opposite view.
When you select an item in the schematic, it is highlighted in the layout as shown in the following figure.
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Similarly, when you select an item in the layout, it is highlighted in the schematic, as shown in the following figure.
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You can also select the object in the opposite view. Select one or more objects in the current view, right-click and choose
Select in Layout if in the schematic or Select in Schematic if in the layout. The opposite view opens in a new window if
not already opened, and those objects are selected in that view. You can right-click the selected objects to access their
properties.

3.2. Layout Manager
The Layout tab located on the main window opens the Layout Manager.
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The Layout Manager has the following components:
•

Layer Setup:

Right-click this node to import process definition files (*.lpf). You can also import LPFs by choosing
The *.lpf files display as subnodes.

Project > Process Library > Import LPF.

Double-click a file to display the drawing layer Options dialog box which controls all functions associated with drawing
layers in the Layout View. Right-click a file to display additional commands available for that file.
•

Layout Options: Double-click this node to open the Layout Options dialog box with options for layout, paths, dimension

lines, rulers, the layout font, and the GDS Cell Stretcher.
•

Cell Libraries:

Right-click this node for options to create or import artwork cell libraries. You can import artwork cell
libraries in GDSII or DXF format or create new cells in a drawing editor activated from this node.
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•

Layout Cells:

Generates a list of all parameterized cells loaded in a project. You can add these cells to any layout
(schematic, artwork cell, or EM) and the parameters of the cells are edited on the Cell Options dialog box Parameters
tab.

•

Drawing Layer

•

Line Types pane: Activates a line type for drawing or editing line type-based shapes. Toggle between drawing a drawing

pane: Shows or hides layers, and activates layers for drawing or editing. Toggle between drawing a
drawing layer-based shape or a line type-based shape.
layer-based shape or a line type-based shape.

The Layout Manager is used for the following functions:
• In the Drawing Layer pane, displays the set of drawing layers (or model layers if an Artwork Cell Editor is active) that
are being used in the Layout View Editor. You can select the active drawing layer and hide or view drawing layers.
See “Layout Editing” for information about the differences between the Artwork Cell Editor and the Layout View
Editor.
• Managing the libraries of artwork cells you can use in a layout.
• Configuring the layer properties (color, 3D heights, etc) for layers in each .lpf files.
• When an artwork cell library name node is selected in the top pane, displays the artwork cells in that library in a Cell
Library pane in place of the Drawing Layer pane, and you can drag-and-drop cells into any open layout window to allow
any layout cell to be used or combined to make new cells.

• When the Layout Cells node is selected in the top pane, displays the parameterized cells loaded in the project in a Layout
Cells pane in place of the Drawing Layer pane. You can drag-and-drop parameterized cells into any schematic layout
window to use the parameterized cell standalone in layout without a corresponding schematic element.
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• In the Line Types pane, displays the line types defined in the LPF. You can select a line type to draw line type-based
shapes instead of drawing layer-based shapes in the layout. Line type shapes draw with all the layers and layer offsets
set in the Line Type definition in the LPF (see “Line Type Definitions” for information).
• Double-clicking a layout cell in the upper pane opens the layout cell in the Layout View Editor. Right-clicking the
nodes in the upper pane displays menus for adding new libraries and cells. You can also merge, delete, rename, and
perform other operations on cells and libraries using the right-click context menus.

3.2.1. Drawing Layer Pane
The Drawing Layer pane has many controls to help work with layout.
The title bar displays the .lpf file used for the active window in the project. This is useful when using multi-technology
projects (multiple .lpf files in a project) or when switching from schematic layout to EM layout.
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The Layout Manager toolbar includes various buttons to manage the pane and access additional controls. For more
information about a button, hover the mouse cursor over it for a tooltip. See “Using Property Grids” for details on common
toolbar buttons. The following buttons are specific to the Layout Manager.
Hiding Non-active Layers
The Hide non-active layers button changes the visibility so only the active layer is visible.

The following figure shows the Hide non-active layers option Off, with all checked layers visible.

The following figure shows the Hide non-active layers option On, so only the selected (active) layer is visible.

The following figure shows the selection of a new (active) layer that is now the only layer visible.

AWR Microwave Office Layout Guide 3–17

Layout Manager

Selecting a Configuration
The Select configuration button allows you to change configurations or save a new configuration.

Configurations are different default settings for the properties for each layer such as fill pattern, visibility, or cloaking.
This control allows you to select an existing configuration or to save the current settings as a new configuration. For
additional controls to manage the configurations you can double-click the .lpf name in the Layout Manager or click the
Edit Drawing Layers button to the right of this button.
Editing Drawing Layers
This button displays the drawing layer Options dialog box with options for the active .lpf file.

3.2.2. Artwork Cell Libraries
The Layout Manager displays all of the layout artwork cell libraries that are loaded into the project. Each artwork cell
library is stored as either GDSII (the default) or DXF. When GDSII format is used, the library can contain any number
of layout cells that can also be hierarchical. DXF format also supports hierarchical cells.
GDSII cell libraries in the Layout Manager are connected to a file on the computer that allows linking to libraries and
updating cell libraries. You can view this link as shown in the following figure by pointing to the library name in the
Layout Manager.
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Moving a project with a GDSII cell library to a different directory can break the link, as indicated by a red X on the cell
library icon as shown in the following figure.

When an artwork cell within the library is used in a project layout, a copy of the artwork cell is stored in the project.
Until this occurs, the contents of the GDSII file stored on the computer are used by the project to update the cell library.
To display the Cell Library Properties dialog box, select the library name in the Layout Manager, right-click and choose
Cell Library Properties.
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See “Cell Library Properties Dialog Box ” for a picture and details on this dialog box.
After an artwork cell is used in a schematic layout, the stored copy of the artwork does not automatically update when
the *.gds cell library file changes unless you select the Always read newest or Replace all cells (even modified cells) check
box in the Cell Library Properties dialog box. Replace all cells (even modified cells) ignores all cells stored in the project
and reads directly from the *.gds file. Always read newest checks the date of the cell file stored in the project, compares
it with the same cell file in the *.gds file on the hard disk, and uses the newest version.

3.2.3. Navigating the Libraries in the Layout Manager
The Layout Manager displays a list of all libraries loaded into the project. The library icons indicate the state of the
libraries. The following figure shows the different icons.
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Each artwork cell in a layout library displays in the Layout Manager with an icon that indicates the state of the cell. The
following figure shows the various icons and a description of the state each represents. Artwork cells that are used in the
current layout display with a red and blue rectangle; those that are not used display with gray rectangles.

3.3. Layout Editing
There are two different layout editors in Cadence Microwave Office® software:
• Schematic Layout/EM Layout Editor: Edits the schematic layout and EM layout. This editor opens when you create
a Layout View from a schematic or create an EM structure. All the layout cell properties apply to layout objects when
the editor is opened for schematic layout. The slight difference in schematic and EM layout is that in the EM Layout
Editor the drawing layers correspond to the physically different z-positions in the dielectric stack. The extent of the
physical enclosure is shown for the EM structure.
• Artwork Cell Editor: Creates custom artwork cells or edits cells imported from GDSII or DXF files. This editor
opens when you double-click a cell in the Layout Manager.
Although most of the functionality and drawing tools are the same for both of the editors, the following are some
differences:
• The Artwork Cell Editor draws shapes on model layers, while the Layout View Editor draws shapes on draw layers.
When the Layout Manager is active, the layers that are being used in the Layout View Editor or the Artwork Cell
Editor are visible in the lower pane of the Layout Manager window. If a Layout View Editor is active, the displayed
layers are drawing layers. If an Artwork Cell Editor is active, the displayed layers are model layers. See “Drawing
Layers and Model Layer Mapping” for a complete description of model layers and drawing layers.
• The Artwork Cell Editor has an extra drawing tool for drawing connection faces onto the artwork cells.
• You can only use the Artwork Cell Editor to create and edit static shape objects (polygons, ellipses, text objects, faces,
etc.). The Layout View Editor can include static shape objects and also layout cell objects that are linked to schematic
elements (such as parameterized layout cells).
• The geometry created within the Artwork Cell Editor is saved in standard geometry formats (either GDSII or DXF).
This can lead to some subtle differences between the two editors. For example, in GDSII, there are no ellipse objects,
so if an ellipse is created in the Artwork Cell Editor and saved, it is converted to a polygon when the file is re-opened.
• Groups can be used to help construct the geometry in the Artwork Cell Editor, but the grouping is lost when the artwork
cell is saved (all the correct geometry is saved though). Groups are not saved in the artwork cell because there are no
group objects in GDSII.
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3.3.1. Schematic Layout/EM Layout Editor
The Schematic Layout Editor is the primary layout editor in the AWR Design Environment platform, opened by activating
a schematic window and clicking the View Layout button on the toolbar or choosing View > View Layout.
The EM Layout Editor is opened when you create an EM structure or double-click an existing EM structure in the Project
Browser. See “Creating EM Structures without Extraction” for information about creating, importing, and exporting
shapes in EM structures.

3.3.2. Artwork Cell Editor
The Artwork Cell Editor supports the main Layout View Editor by providing a method to import or create custom cell
libraries. You can create GDSII or DXF cells or import GDSII (.gds) and DXF (.dxf) library file formats into Microwave
Office software through the Artwork Cell Editor. There are three ways to bring an artwork cell object into a Layout View
Editor window:
• Drag and Drop: You can drag cell objects in an artwork cell library into a Layout View Editor or Artwork Cell Editor
window by selecting the name of the library in the Layout Manager window and dragging the object from the lower
pane of the Layout Manager window. If you drop it into an Artwork Cell Editor, the resulting artwork cell is hierarchical
(when constructed this way). Each artwork cell you drag into the artwork cell being edited is placed as a reference to
the dragged-in instance. If the dragged-in instance is not part of the same library, the resulting library will have a
dependency on another library. Also, when you save the library through the Layout Manager, any cells referenced
from other libraries are not written as part of the library.
• Copy and Paste: You can copy and paste objects in an artwork cell library into a Layout View Editor window by
choosing Edit > Copy and Edit > Paste.
• Associate Artwork Cell with Schematic Element: From a schematic window, select an element or subcircuit, right-click,
and choose Properties. In the Element Options dialog box Layout tab, the names of all cell objects with the specified
number of nodes displays. Select the desired cell object and click OK.
There are two types of artwork cell objects that you can create in the Artwork Cell Editor:
• Artwork Cell Object: An artwork cell object consists of one or more polygons. You can create artwork cell objects in
the Artwork Cell Editor or you can import them from a GDSII or DXF file. You can use the Layout menu or Schematic
Draw Tools toolbar to access the drawing functions in the Artwork Cell Editor.
• Artwork Cell Object with Ports: You can create artwork cells with ports from any artwork cell by adding ports to the
polygons to define the connection points. The connection points correspond to the schematic element or subcircuit
nodes.

3.4. Schematic/EM Layout Draw Tools
There are many drawing tools in the Draw menu that you can use in the Schematic Layout and EM Layout Editor.
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You can also use the drawing tools by clicking the corresponding toolbar buttons. To display the Draw Tools toolbar,
right-click the toolbar and choose Draw Tools.
You can customize toolbars by specifying which tool buttons display on them, either individually or as part of a split
button. Choose Tools > Customize to open the Customize dialog box, then click the Toolbars tab to specify buttons for
each toolbar type.

3.4.1. Drawing Tools
The following is a brief description of some of the most common drawing tools. A more detailed explanation of some
of these drawing tools is provided in the following sections.
Circle
To draw a circle, choose Draw > Circle. Click and drag to draw the circle, and then release the mouse button.
You can also change the size of a circle after it is drawn. Select the circle in the layout window, right-click and choose
Shape Properties to open a Properties dialog box with a Circle tab.
Ellipse (Ctrl+E)
To draw an ellipse, choose Draw > Ellipse. Click and drag to draw the ellipse, and then release the mouse button.
You can also change the size of an ellipse after it is drawn. Select the ellipse in the layout window, right-click and choose
Shape Properties to open a Properties dialog box with an Ellipse tab.
Path (Ctrl+L)
To draw a path, choose Draw > Path. Click to place the points and double-click to complete the path. To change the default
path width, bend type, or end type choose Options > Layout Options or double-click Layout Options in the Layout Manager.
In the Layout Options dialog box Paths tab, you can specify path properties.
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You can also change the path width, end type and bend type after the path is drawn. Select the path in the layout window,
right-click and choose Shape Properties to open a Properties dialog box with a Path tab.
Polygon (Ctrl+P)
To draw a polygon, choose Draw > Polygon. Click to place each point, and right-click to erase a point. Double-click to
close the polygon. For more information on polygon editing, see “Polygon Editing”.
Rectangle (Ctrl+B)
To draw a rectangle, choose Draw > Rectangle. Click and drag to draw the rectangle, then release the mouse button.
You can also change the size of a rectangle after it is drawn. Select the rectangle in the layout window, right-click and
choose Shape Properties to open a Properties dialog box with a Rectangle tab.
Text (Ctrl+T)
You can add text to the layout by choosing Draw > Text, and then clicking in the location where the text is to be added.
An edit box displays for text entry. To finish the text drawing command, press Enter or click outside of the edit box. The
initial properties of the added text are based on the default font settings. To change the default settings, choose Options
> Layout Options and click the Layout Font tab to make your changes.
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You can edit existing text properties by selecting the text, right-clicking, and choosing Shape Properties. A Properties
dialog box displays with a Font tab that contains the font properties to set.
You can set the following additional properties on the Properties dialog box Layout tab.
•

Draw Layers:

The layer that the text is to be drawn on. If the text is being added to the Artwork Cell Editor you must
specify the model layer.

•

Orientation:

•

Freeze:

The angle that the text is drawn with respect to the vertical baseline, along with an option to flip the text.

The text object can be frozen to prevent the object from being accidentally moved.
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The layout text is drawn as polygons on the specified drawing layer (or model layer in the Artwork Cell Editor) if the
Draw as Polygons check box is selected. The polygons are automatically generated from the TrueType font definition. If
there is not a suitable font available, you can use any commercial font creation software to create a font that you can use
within the Microwave Office layout. If the text is in the Artwork Cell Editor, it is converted to polygons when the artwork
cell is saved in the artwork cell library.
In the EM Layout editor, if a layout text is drawn using an EM mapped layer, the Draw as polygons check box must be
cleared, otherwise the text is included in the simulation. Right-click the layout text and choose Shape Properties, click
the Font tab and clear the Draw as polygons check box. Another option is to draw the layout text with a Drawing Layer
that does not have an EM Mapping configured, although this text is not displayed in a 3D view.
As shown in the following example text, the text polygons are drawn with cuts to avoid donuts in the polygons.

3D Clip Area
The 3D clip area is used to create a rectangular area in the layout that can be used to clip the 3D drawing of the layout.
This is useful for viewing sections of a layout in 3D, and can be drawn by choosing Draw > 3D Clip Area. Only one clip
area can be drawn in a Layout View.
Drill Hole
To draw a drill hole, choose Draw > Drill Hole. Place the cross cursor at any point within the drawing window and click.
The drill hole placed is the default size specified in the *.lpf process file. To change the drill size, select the drill hole,
right-click, and choose Shape Properties. A Properties dialog box with a Drill Hole tab displays with an option for selecting
various drill tools that are specified in the Options - Drill Hole Layers dialog box. Select a drill tool to automatically
change to that drill size.
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To add a new drill tool, choose Options > Drawing Layers to display the drawing layer Options dialog box. Click Drill Hole
Layers and type in the name, diameter, and tool number of the new drill tool.
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3.4.2. Layout Shapes Editing
The following options are used by many of the drawing tools and commands.
Grid Snap (Ctrl+G)
To toggle on/off the grid snap you can choose Draw > Grid Snap. When the grid snap is on, the drawing tools snap to the
grid. Editing operations (such as moving a shape) also use the grid snap. For example, if the grid snap is set to 5 um,
when moving an object it can only be moved in multiples of 5 um. You can dynamically change the snap grid by fixed
multiples by selecting the snap multiple from the Grid Spacing button on the toolbar. For example, if the grid snap is 5
um and the Grid Spacing button on the toolbar specifies 2x, the grid snap is 10 um for the layout.
Orthogonal (Ctrl+O)
The orthogonal option can be toggled on or off by choosing Draw > Orthogonal. This option is primarily used with polygon
editing. When the Orthogonal option is on, it restricts the stretching of edges and vertices to an orthogonal direction.
Shape Selection
You select an object in the layout by clicking on it. Selected objects display with selection highlighting. There are three
system layers for selection highlighting. The layer 'FirstSelected' is used to highlight the first selected object, which is
used as the reference for commands like alignment and sizing. The layer 'Selection' is used to highlight the second and
subsequent objects in a selection set. Finally, there's a system layer named 'Subselection' that is used to highlight selected
sub-objects like segments on an iNet. When performing a polygon selection on overlapping layers, the default selection
picks the smallest polygon. This is useful for editing complex drawings such as FET cells. You can Ctrl+Shift-click on
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overlapping objects to cycle through the objects under the click point. There are additional settings to control selection
behavior available in the Layout Editor Mode Settings dialog box.
Multiple Selection
You can select multiple objects in any of the layout editors using any of the following techniques:
•

Shift-click

•

Alt-click

on each object one at a time to select objects. Shift-click on an object again to deselect it.

on an area of the screen and then drag a rectangular selection area over the objects you want to select. All
objects that are completely within the selection area are selected. Objects that are only partially within the selection
area are not selected.

• Press the Shift key while dragging the selection area to select any object that touches (is only partially within) the
selection area.
• Press Ctrl + Shift for a selection method similar to the normal area selection, except that the first click can be on top of
an existing object. This is useful for area selection in dense layouts where there is no empty space to start the area
selection. If the first object clicked on is already selected, it remains selected and all objects within the selection area
are also selected.
Multiple Selection Editing
You can simultaneously change the properties of multiple layout objects. Select a group of objects in the Layout View
using any of the multiple selection methods. Right-click and choose Shape Properties, and change the properties. All
applicable changes are made to each of the selected objects.
Move with Reference
You can move a shape or shapes with reference:
1. Select the shape(s) you want to move, then choose Edit > Move or press Ctrl+Shift+M.
2. Click the location to establish the reference.
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3. Move the mouse to move the shape(s) with the reference, and click to place it.
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Copy with Reference
You can copy a shape or shapes with reference:
1. Select the shape(s) you want to copy, then choose Edit > Copy with Reference or press Ctrl+Shift+C.
2. Click the location to establish the reference
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3. Move the mouse to copy the shape(s) with the reference, and click to place it.
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Shape Edge Selection
AWR Design Environment platform layout supports sub-selecting multiple edges of a shape, or multiple edges of a shape
within a multi-layer shape. This allows you to select specific edges on two shapes and align the two edges with specified
spacing between them. In some cases, it may be useful to select more than one edge to perform a custom operation on
the selected shapes. Multi-edge selection allows you to select and highlight multiple edges of a shape or multiple edges
of a shape within a multi-layer shape.
To select an edge, Alt-click on it and hold down the Alt key while moving the cursor to the edge of one of the selected
shapes. When the cursor changes from a multi-directional move arrow to a standard cursor arrow you are over the edge
and can click. Hold down the Alt key again while moving the cursor to the upper edge of the rectangle. When the cursor
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displays as a standard arrow over the shape edge, click to select the upper rectangle edge. When the edge is selected it
is highlighted.

Multi-edge selection extends edge selection to allow you to select multiple edges on the same shape. Operations such as
the Align command work on shapes with multiple selected edges, however since you can only align one edge on each
shape with the other shape, only the first edge selected is used. Multi-edge selection is most beneficial for custom solutions
where you want to select multiple edges of a shape and then run a script that uses these selections to create additional
structures relative to the selected edges.

Command Repeat Mode
You can use command repeat mode to keep any edit mode active until you cancel it. For example, click the Command
Repeat Mode button on the toolbar
,
choose Draw > Rectangle, and draw a rectangle. Note that the Draw Rectangle command remains active, allowing you to
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continue to draw shapes without repeating the menu command. To exit command repeat mode press the Esc key.
Alternatively, choose Edit > Auto Repeat to toggle this command on and off.
Gravity Points
Gravity points provide a quick and easy method for creating, positioning and aligning shapes within the layout. Gravity
points are activated by pressing the Ctrl key while moving the cursor over objects in the layout. If no drawing operation
is in progress, pressing the Ctrl key while moving the cursor causes the cursor to snap to vertices, edges, intersections,
midpoints or control points of selected objects. The different types of gravity points have different strengths. Stronger
gravity points are preferred over weaker gravity points. For example, while pressing the Ctrl key, the cursor snaps to the
edges of a selected polygon, but if the cursor is moved towards a corner, the cursor snaps to the corner even though it is
already snapped to an edge. The following figure shows the typical control points for a few different shapes. Note that
the intersections of the shape edges are also control points.

Gravity points can be used in many different situations. Pressing the Ctrl key when no drawing operation is in progress
is useful for setting the base point for an operation. For example, when moving a shape, if you first snap the cursor to a
corner of the shape, it is very easy to move the shape such that the corner aligns with a corner, midpoint, edge, or
intersection of another shape. Setting the initial base position using the Ctrl key only works with selected shapes, while
all the other uses of the gravity points operate on any shape (selected or deselected).
The following are useful applications for gravity points:
• Moving Objects: When moving a shape in the layout, press the Ctrl key and move the cursor to a gravity point on a
selected shape and then click and drag the shape. The cursor is now locked to the exact gravity point on the selected
shape. If you press the Ctrl key during the drag operation, the cursor snaps to any gravity point on any other object
(selected or deselected). If you move the cursor to a gravity point on another object and release the mouse (ending the
drag operation), the gravity points on the moved object and the other object are at the same point. For example, if the
gravity point on the moved object is the corner of the rectangle, and the gravity point on the other object is also the
corner (and it is a rectangle) then the corners of the two rectangles are aligned.
• Aligning Edges: You can make the edges of shapes coincident by moving the shapes and using the edges for the gravity
points.
• Centering Ellipses: You can center a circle or ellipse on another gravity point.
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• Drawing Polygons: You can use gravity points while drawing a polygon. To use gravity points, press the Ctrl key
while clicking on gravity points to add the new points to the polygon. This allows you to quickly draw polygons that
are coincident with the corners, edges, midpoints or intersections of any existing shapes.
• Drawing Rectangles: You can use gravity points to define the two opposing corners of a rectangle during a drawing
operation.
• Drawing Paths: When using gravity points with the Path drawing tool, you can make the path center line points snap
to gravity points if you press the Ctrl key while drawing the path.
• Rotating Objects: To rotate a shape about an exact point (for example, to rotate it about one of its corners), select the
shape, right-click it and choose Rotate. If you press the Ctrl key while the cursor is moved, the cursor snaps to any
gravity point on itself or any other shape. Once the cursor has snapped to a gravity point, click and drag the rotation
line to rotate the object about the gravity point.
• Flipping Objects: To flip a shape about an exact point or edge (for example, to flip a shape so that one of its edges in
the same position), select the shape, right-click it and choose Flip. If you press the Ctrl key while moving the cursor,
the cursor snaps to any gravity point on itself or any other shape. Once the cursor has snapped to a gravity point, click
and drag the flip line to flip the object about the flip line.
• Measuring: The measurement tool always uses gravity points (you do not need to press the Ctrl key), making it easier
to make precise measurements on different shapes in the layout.
• Adding Cell Ports: When adding cell ports to artwork cells in the Artwork Cell Editor, you must ensure that the cell
port is coincident with the edges of the connecting shapes in the artwork cell, otherwise there may be small gaps in
the final layout. The gravity points can be used to define the two end points of the cell port during the port drawing
operation.
Rotation and Flipping
To arbitrarily rotate objects in layout, select the objects, right-click, choose Rotate, and move the mouse in the desired
direction. The rotation uses the Rotation Snap angle set in the Layout Options dialog box Layout tab. An alternate method
for rotating is to select the object, right-click, choose Shape Properties, and then specify an Angle in the Orientation area
of the Cell Options dialog box. The layout system allows arbitrary angle rotation down to 0.1 deg increments.
To flip an object in the layout, select the object, right-click, choose Flip, and then click and drag. The line defined by the
endpoints of the click and drag operation defines the line that the layout object is flipped about.
Gravity points or coordinate entry can also be used during rotation and flipping for more precise control of the positioning.
Restricted Object Selection
Restricted object selection is added in schematic Layout Views to prevent objects from being selected. To use this feature,
right-click in the layout window, choose Restrict Selection and then select the item types to restrict. Selecting a layout
item type prohibits it from being selected in the layout. If you find you cannot select certain items in a layout, you should
verify that they have not been restricted for selection. See “Restrict Selection (Layouts) Dialog Box ” for more information.

3.4.3. Polygon Editing
Adding Polygons
You can draw polygons in the layout by using the mouse or by coordinate entry. To draw a polygon, choose Draw >
Polygon. You enter the first point by clicking and releasing the mouse at the desired position. For the next point in the
polygon, you can add the point graphically by clicking (gravity points can be used to graphically enter exact coordinates).
If you press the Shift key while adding new points, you can add segments at other than vertical, horizontal, or 45-degree
angles. You can remove previously placed points by right-clicking during the drawing operation. You can enter the last
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point by double-clicking (that point is added to the polygon and the polygon is closed) or by clicking on the first point
to close the polygon.
To draw a polygon using coordinates entry, see “Coordinate Entry”.
Editing Points and Edges
You can move a shape point or edge, or use the Edit Points command to modify its vertices.
To move a point or edge of a polygon, double-click the polygon to activate edit mode (in edit mode, the polygon displays
selection squares on each vertex and selection diamonds at each midpoint). To move an edge, click and drag one of the
selection diamonds at one of the midpoints. To move a point, click and drag one of the selection squares on a vertex.
Rectangles, paths, and ellipses can be modified in a similar way.
To move points or edges of a polygon using coordinates entry, see “Coordinate Entry”.
The Edit Points command in the Layout Editor allows you to add, remove and edit the vertices of shapes, or add/remove
fillets and chamfers. You can add new points to an existing polygon and then move them to change the polygon shape,
or you can delete points to remove vertices from the polygon. In point edit mode, you can select and move single or
multiple vertices of the shape to introduce new sides to an existing polygon and new segments to an existing path.
To use the Edit Points command, select the shape you want to edit, then choose Draw > Modify Shapes > Edit Points, or
right-click the shape and choose Edit Points. The shape displays in edit mode.
Clicking on the shape or its vertices, or clicking and dragging to select an area maintains edit mode. In edit mode you
can:
• Stretch vertices by clicking on a vertex and dragging while holding down the mouse button
• Select highlighted vertices by clicking on them singly or by Shift-clicking to select multiples. Selected vertices display
a selection square as shown in the following figure.

• Select multiple vertices by clicking and dragging a selection box to enclose them, as shown in the following figure.
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• Delete selected vertices by pressing the Delete key or Backspace key
• Add vertices by clicking on an edge between existing vertices
• Add a fillet or chamfer by selecting one or more vertices, then right-clicking and choosing Add Fillet/Chamfer
• Remove a fillet or chamfer by selecting two or more vertices which make up the fillet or chamfer, then right-clicking
and choosing Removing Fillet Chamfer
To end edit mode and keep your changes, click in an open space to end the command, or press the Esc key to cancel the
command and revert any changes.
For the Edit Points command, an edge is defined as the line connecting two existing vertices, as shown in the following
figure.
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Deleting Shape Vertices

You can remove a selected vertex from the shape by pressing the Delete key. When deleting vertices, if the number of
remaining vertices is not sufficient to create a viable shape, the shape is removed. Polygons must have at least three
points, and paths must have at least two points.
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Stretching Shape Vertices

You can select and move multiple vertices to stretch the shape. To stretch the selected vertices, click on one of them and
drag it while holding down the mouse button, then release the mouse to end the stretch operation. The following figure
shows the top two vertices selected and dragged upward to increase the height of the polygon.

You can stretch a single vertex without first selecting it, similar to point editing (outside of Edit Points command mode)
by simply clicking a vertex and dragging it to stretch the shape, as shown in the following figure.

Adding Shape Vertices

You can add vertex points to a shape by clicking on a shape edge between two existing vertices. For a polygon, the
vertices are along the outer edge of the shape. For path objects, the edges are along the centerline of the path. When the
cursor is close to an edge at a location and away from existing vertices where a point can be added, it changes from an
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arrow to a plus sign “+”. You can click in this location to add a point. For example, clicking the middle of the top of the
polygon near the edge adds a point in the center of the top, as shown in the following figure.

After adding a vertex you may want to stretch the polygon around the newly added vertex. Since editing involving single
vertex stretching attempts to maintain the angles into and out of each vertex, selecting the new center vertex and dragging
up moves the two adjacent vertices as well.

Often the reason for inserting a vertex is to create a split in the polygon to introduce a new edge at the location of the
inserted point. You can do so by stretching either the point before or after the newly inserted vertex. For example,
stretching the upper left vertex introduces a new edge at the location of the newly added point, as shown in the following
figure.
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This often has the desired effect of splitting the edge at the location of the new point and introducing a new side. You
can again stretch the point after the newly inserted point to insert a new side in the polygon.

You can also insert points into path objects along the centerline. The following figure shows insertion of a point in the
middle section of a path.
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After inserting a point you can use the same process of stretching the point before or after the inserted point to introduce
a new path segment, as shown in the following figure.

As with polygons, when modifying paths you can also click and drag the point before the newly inserted point to create
a new path segment.

It is often useful to create a trombone-like segment in a section of straight path to allow adjustment of the length by
adjusting the length of the U-shaped segment in the trombone. The Edit Points command can introduce a trombone
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segment into a straight segment of path by inserting two points and then stretching one of the two newly inserted points.
For example, you can first introduce two new points into a straight segment as shown in the following figure.

Next you drag down the two outside points, which introduces new segments at the inserted point locations. You use the
outside points because stretching the collinear points in the middle brings the path segment with them.

An alternative is to use a combination of the Edit Points command to insert the points and a standard Stretch Area
command to create the trombone section. After the points are inserted you can create the trombone by using a mid-point
selection handle in the middle of the middle segment. After introducing two new points as shown in the previous figure,
you click in an open space to exit Edit Points mode. Next you double-click the path to enter normal path editing mode
and stretch the middle handle, as shown in the following figure.

This method has the advantage of not needing to move the path end-points. If the path is connected at the ends, this is
the best method for adding a trombone without changing the connection points.
Filleting or Chamfering Vertices

You can modify corners by selecting one or more vertices, then right-clicking and choosing Add Fillet/Chamfer.
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In the Modify Selected Vertices dialog box, you can specify how to modify the selected vertices, the radius of inside and
outside corners, and what to do when not enough room is available for the specified radius. When you select Fillets with
Points the Layout Options dialog box Layout tab Number of points/circle setting is used:

You can also create fillets with Arc segments

or create chamfers.
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In addition you can specify what to do with vertices when not enough room is available to create the desired fillet. In
When vertices too close choose Skip Vertex to not fillet the vertex. In the following figure, the edge between the selected
vertices needs to be 120um to support two of the desired 60um fillets, so no fillet is added.

Choosing Reduce Radius reduces the fillets to 40um to fit the available 80um width:
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Removing Fillets or Chamfers

You can remove filleted or chamfered corners by selecting two or more vertices, then right-clicking and choosing Remove
Fillet/Chamfer .

Adding/Editing Cutouts and Arcs
Polygons in the AWR Design Environment platform support cutouts without the need for cutlines or arc segments (arcs
described by a center point and radius rather than vertices at certain degree intervals). This allows for simplified layout
creation and editing of more complex shapes. Polygons with cutouts or arc segments are referred to as generalized
polygons and polygons without cutouts or arc segments are referred to as simple polygons.
The following sections show the basics for adding cutouts to shapes, editing those cutouts, and editing the segments of
a polygon to turn them into an arc. There are more advanced use cases for these constructs as well. For example, generalized
polygons can have cutouts as well as arc segments, and even cutouts can have their own arc segments. Used independently
or together these two layout constructs can simplify creating complex board layouts.
Adding Cutouts

You add cutouts to existing polygon shapes in layout. To add a cutout to an existing polygon, select the polygon and
choose Draw > Add Cutout and Rectangle, Polygon, Circle, or Ellipse, then draw the cutout on the polygon in the same way
the shape type is drawn when creating a new object in layout.
Editing Cutouts

To reposition a cutout, double-click the parent polygon to enter edit mode. Each cutout has a drag handle in the middle
for repositioning. Simply click and drag the drag handle to reposition the cutout.
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To reposition multiple cutouts at the same time, double-click the parent polygon to enter edit mode, then press the Shift
key while selecting the cutouts you want to reposition. Click and drag the center drag handle of a cutout to move all the
selected cutouts the same distance.

You can also edit the size or shape of a cutout. To edit a cutout, double-click the parent polygon to enter edit mode. With
the drag handles displayed, press the Shift key and click in the cutout region. Drag handles for the cutout display to allow
you to edit the size or shape of the cutout.
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You can remove a cutout from a polygon by double-clicking the parent polygon to enter edit mode. With the drag handles
displayed, press the Shift key and then select the cutout(s) to delete. Next press the Delete key or choose Edit > Delete.
Adding Cutlines

In some cases you may need to revert a generalized polygon with cutouts back to a simple polygon with cutlines. To do
so, select the polygon and then right-click the shape and choose Add Cutlines or choose Draw > Modify Shapes > Add
Cutlines. When you execute this command, a cutline is added for each cutout present in the polygon converting the
generalized polygon back to a simple polygon (if no arc segments are present). The following figure shows an example
of an added cutline.

Editing Arc Segments

Generalized polygons also support the notion of an arc segment, which is a side segment that can be bent into an arc
between the two segment end points. This can be convenient for creating rounded portions of a polygon object without
having to enter all the arc points individually. Any polygon in the AWR Design Environment platform Layout Editor
can have arc segments added to the polygon by editing the polygon sides.
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To edit arc segments, select the polygon for which you want to edit the segments, then choose Draw > Modify Shapes >
Edit Arc Segments.
When the command executes, edit handles display in the middle of each of the polygon side segments. Dragging these
handles perpendicular to the segment side causes the segment to bend into an arc. The farther you drag the handle, the
greater the curvature in the arc.

The following figure shows the addition of solder pads to the end of the trace.

Array Copy
The Array Copy command is used to create multiple copies of single or multi-layered shapes and artwork cells by giving
the number of rows and columns and separation for each dimension. To access this command choose Draw > Modify
Shapes > Array Copy.
Area Stretching (Stretch Area)
You can use the Stretch Area command to stretch parts of one or more selected shapes. To start the operation, choose
Draw > Modify Shapes > Stretch Area. When the command is active, clicking and dragging the mouse over an area selects
the points on selected shapes that are inside the area. The selected points are indicated by being drawn in the selection
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color (usually a dark color). You can click and drag over an area repeatedly to add more points. You can also select
points by clicking directly on the shape vertices. As points are selected, previously selected points remain selected. If
you press the Shift key while dragging over an area, the points within the area are deselected. Similarly, if you press the
Shift key and click on a shape vertex that is already selected, that point is deselected. Once all the desired points have
been selected, click (and hold down) the mouse on one of the selected points by moving the square in the upper left hand
corner of the cursor over a vertex. When the cursor square turns into four arrowheads, click and drag the vertex to move
all the selected points. If you drag and release the mouse, all of the selected points are shifted by the amount the mouse
moved.
To stretch by entering coordinates, see “Coordinate Entry”.
Slicing Polygons (Slice Shape)
You can slice multilayer (layout shapes) polygons. Polygon slicing is useful for isolating the portion of a cell you want
to reuse, or for breaking up a polygon that exceeds a maximum number of vertices.
To access Polygon Slicing, in Layout View, select the desired shapes. Click the Slice Shape button on the Draw Tools
toolbar or choose Draw > Modify Shapes > Slice Shape. Click to start a line segment through the shape where you want to
split it, and then click to set the line segment. The slice operation uses the segment to define an infinite line, and any
selected shape that intersects the infinite line is sliced.
To slice layout shapes using coordinate entry, see “Coordinate Entry”.
Creating Notches (Notch Shape)
You can add an intruding or protruding notch to a polygon shape using the Notch tool.
To access Notching, in Layout View, select the desired shape. Click the Notch Shape button on the Draw Tools toolbar
or choose Draw > Modify Shapes > Notch Shape. Click and drag the mouse over the shape to create an intruding notch of
the desired size, or click and drag the mouse outward from the edge of the shape to create a protruding notch of the
desired size, then release the mouse button to complete the notch.
To add a notch using coordinate entry, see “Coordinate Entry”.
Merge Shapes
The Merge Shapes command is used to combine positive, negative, and normal layers without requiring an export to
apply these shape modifications. To merge shapes, choose Draw > Modify Shapes > Merge Shapes. If you are not familiar
with these layer concepts, see “Negative Layers ” for details. Note that this operation cannot change shapes assigned to
schematic items. You may want to copy and paste an entire layout into a new schematic layout to remove all layout
association from schematic elements. This command works only on selected layers, so a common use is to select all
shapes on the positive and negative layers only to perform the subtraction of the cut-out layers.
Fracturing Polygons (Fracture Shapes)
The Fracture Shapes command is used to break up complex polygons with a large number of vertices into multiple
polygons with limited vertices. You specify the maximum number of vertices for the resulting polygons when you run
the command. To use this command, first select the polygon, and then choose Draw > Modify Shapes > Fracture Shapes.
Shape Mirroring (Mirror)
You can create mirrored images of shapes in a layout (or elements in a schematic).
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To access Mirroring, in Layout View, select the desired shape and choose Edit > Mirror. The cursor changes to reflect the
mirroring operation. Click in the layout to position the new shape. The following example shows the results of a mirroring
operation:

Shape Modification Operations
The shape modifier commands modify a polygon or groups of polygons. The commands are dependent on the order in
which you select the polygons. You can use Ctrl + click, Shift + click, and drag-and-click mouse commands to select
multiple polygons. See “Multiple Selection” for more information about multiple selection.
There are additional settings on the Layout Options dialog box Boolean tab to control shape modifier operations. You
can specify whether modified polygons contain cutlines, and whether resized acute corners are rounded. See “Layout
Options Dialog Box: Boolean Tab” for details.
To execute the shape modification commands choose Draw > Modify Shapes and then choose the appropriate option, or
you can click the corresponding toolbar button. The following operations are available (for commands that require the
selection of two or more shapes, this assumes that the "A" shape is selected before the "B" shape). These operations only
function for shapes on the same layer. For example, if you select shape 1 on layer A and shape 2 on layer B, merging of
the shapes cannot occur.
• Union: Select two different overlapping or touching polygons and this command merges the areas into a single polygon,
as shown in the following figure.

• Intersection: Select two different overlapping polygons and this command eliminates all areas that do not intersect.
The result is a single polygon, as shown in the following figure.

• Subtraction: Select two different overlapping polygons and this command subtracts the overlapping area from the
first polygon selected. The second polygon selected disappears completely, as shown in the following figure.
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• Resize: Select a polygon and this command allows you to resize it by adding an offset to the (x, y) dimension of each
vertex, as shown in the following figure. Positive numbers make it larger; negative numbers make it smaller.

• Resize Copy: Select a polygon and this command allows you to create a resized copy of the polygon by adding an
offset to the (x, y) dimension of each vertex. The copy displays directly on top of the original of each vertex, as shown
in the following figure.

• Exclusive Or (Xor): Select two different overlapping polygons and this command deletes the areas that overlap, as
shown in the following figure.

• Make Ring: This command turns a solid polygon into a ring with a width that you specify, as shown in the following
figure.

• Smooth: This command removes collinear vertices in polygons. It does not apply to shapes drawn in the Layout
Editor, which do not contain excess collinear points. It is intended for use with imported layouts that may contain
shapes with excess collinear vertices.
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3.4.4. Coordinate Entry
You can use coordinate entry for most of the drawing entry and editing you do using the mouse. The layout system uses
a uniform approach for coordinate entry. To perform an operation with coordinate entry, press the Tab key or Space bar
during any operation that requires a mouse movement. The following dialog box displays to allow you to enter (x, y)
coordinates as absolute or relative coordinates. You can also enter (mag, angle) by selecting the Polar check box.

If you select Snap, the cursor moves to the closest grid location to start drawing. Coordinate entry can be intermixed
with normal mouse editing. For example, when drawing a polygon, you can add some of the points with the mouse and
other points using coordinate entry.
The following are some of the more useful applications of coordinate entry:
• Drawing Polygons: You can use coordinate entry to type in the exact coordinates of a polygon as you draw the
polygon. To use coordinate entry, choose Draw > Polygon. You can enter the first point by either clicking and releasing
the mouse at the desired position, or you can press the Tab key or Space bar to directly enter the coordinates of the
first point. Do not select Rel in the Enter Coordinates dialog box for the first point since a relative position does not
apply for the first point entered. After entering the coordinates in the dialog box, click OK (or press Enter). For the
next point in the polygon, again you can add the point graphically by clicking (you can use gravity points to graphically
enter exact coordinates) or by pressing the Tab key or Space bar to display the Enter Coordinates dialog box. You can
then enter the coordinates as relative coordinates (the default; relative to the previous point) or as absolute coordinates.
This procedure is continued for all points in the polygon. You can enter the last point (close the polygon) using the
techniques discussed in “Adding Polygons” or if using coordinate entry, by entering a relative value of (0,0). The
default relative value in the Enter Coordinates dialog box is (0,0), so you can close the polygon by pressing the Tab
key or Space bar to display this dialog box, then press Enter. If you enter the coordinates such that the last point
coincides with the first point, the polygon is closed also. The coordinate entry mode is designed to make it possible
to enter the entire polygon without needing to use the mouse. To enter the polygon without using the mouse, press
Ctrl+P to start the polygon tool, press the Tab key or Space bar, then type in the absolute x coordinate, press the Tab
key or Space bar, then type in the absolute y coordinate, press Enter to accept the point, press the Tab key or Space bar
to start the next point, and so on, then press the Tab key or Space bar followed by Enter to close the polygon.
• Drawing Rectangles: You can also use coordinate entry to specify either or both of the opposing points that define
the rectangle. The first point is entered in absolute coordinates (or with the mouse) and the second point is entered in
either relative or absolute coordinates (or with the mouse). As with the polygon entry, you can use gravity points to
define either point with the mouse. Start the command by choosing Draw > Rectangle.
• Drawing Ellipses: You draw ellipses by specifying the rectangular bounding box of the ellipse, so coordinate entry
is the same as that of the rectangle. You start this command by choosing Draw > Ellipse.
• Drawing Paths: Adding a path using coordinate entry is almost the same as adding a polygon using coordinate entry.
Start the command by choosing Draw > Path. The center line of the path is drawn like a polygon. The main difference
is that the polygon defining the center line is not closed when the command is finished. You can complete the path
drawing command by entering a relative (0,0) point for the last point when using coordinate entry.
• Placing Drill Holes: You can use coordinate entry to place a drill hole object. To place the object, choose Draw > Drill
Hole, then press the Tab key or Space bar to display the Enter Coordinates dialog box. The absolute coordinates you
enter are the position of the center of the drill hole object.
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• Moving Objects: Coordinate entry provides a couple of options for moving objects in the layout. To move an object,
click (and hold down) on the object with the mouse. Instead of moving the object by dragging the mouse, press the
Tab key or Space bar. The coordinate entry dialog box opens to allow you to enter relative or absolute coordinates. If
you use relative coordinates, the object is shifted by the specified amount. If you use absolute coordinates, the object
is placed at the specified point. The base point of the object is the click point when using absolute coordinates. If you
enter absolute coordinates, you should usually have the base position snapped to one of the gravity points on the object.
For example, to move a rectangle so that it has a corner at (100,100), select the rectangle, press the Ctrl key and snap
the cursor to the desired corner, then click. While pressing the mouse button, release the Ctrl key, then press the Tab
key or Space bar to display the Enter Coordinates dialog box. Clear the Rel check box and enter (100,100) as the
coordinates, then press Enter. The specified corner of the rectangle is now at (100,100).
• Stretching Shape Edges: You can easily move an edge (or point) of a polygon or other shape by a specified amount
using coordinate entry. To move an edge of a polygon, double-click the polygon to activate edit mode (selection
squares display on each vertex and selection diamonds display at each midpoint), then click on one of the selection
diamonds and hold down the mouse button. Next, press the Tab key or Space bar to display the Enter Coordinates
dialog box. If you enter the coordinates as relative, the edge moves by the specified amount. If you enter absolute
coordinates, the edge is moved to fall on the specified point. You can stretch the corners of the polygons in the same
way. You can also similarly modify rectangles, paths, and ellipses.
• Stretching Areas: You can use the Stretch Area command to stretch parts of one or more selected shapes. You can
use coordinate entry to specify the distance that the area is stretched. To use coordinate entry, press the Tab key or
Space bar while holding down the mouse button on one of the selected points during the area stretch. The Enter
Coordinates dialog box displays to allow you to specify the shift in relative or absolute coordinates. For more information
on stretching areas, see “Area Stretching (Stretch Area)”.
• Adding Notches: You can use the Notch command to add intruding or protruding notches to a shape. You can use
coordinate entry to specify the coordinates of the added notch. To use coordinate entry, select the shape, then click
the Notch Shape button on the toolbar and press the Tab key or Space bar to open the Enter Coordinates dialog box.
Click OK to display a crosshair cursor with a dx/dy coordinates display. Position the cursor at the desired coordinates
and click to draw the notch. For more information on notches, see “Creating Notches (Notch Shape)”.
• Splitting Polygons: You can use the Slice Shape command to split polygons. You can use coordinate entry to specify
the coordinates of the line that splits the shape. To use coordinate entry, select the shape, then click the Slice Shape
button on the toolbar and press the Tab key or Space bar to open the Enter Coordinates dialog box. Specify the x and
y coordinates for the starting point of the line you draw to slice the shape. Drag the cursor to the coordinates at which
you want to end the line and click OK to create the split. You can separate the shape halves by selecting them and
dragging them apart. For more information on splitting polygons, see “Slicing Polygons (Slice Shape)”.
• Copied Object Placement: You can use coordinate entry to precisely place objects when you copy and paste them
into the layout. For example, to make a copy of a rectangle 100 units to the right of the original rectangle, select the
rectangle, then copy and paste it. When you paste the rectangle it moves with the cursor. To place it exactly, press the
Tab key or Space bar to open the Enter Coordinates dialog box. Next, enter a relative coordinate of (100,0) and press
Enter. The copied rectangle is offset from the original by exactly 100 units in the x direction. If you do not select Rel
in the Enter Coordinates dialog box, the copy is placed at the absolute coordinate you entered. The reference point for
absolute placement is always the center of the shape.
• TRACE Element Routing: You can reroute TRACE layout objects (for example, MTRACE) by drawing the center
line of the TRACE in the same way that a path is entered. To indicate the end of an MTRACE or MCTRACE routing
command, enter a relative coordinate of (0,0) to end the command. Press the Tab key followed directly by the Enter
key to end the command when entering relative coordinates, because the default relative coordinates are always (0,0).
For more information on routing the TRACE element, see “TRACE Elements”.
• Rotating about Points: You can use coordinate entry to specify the point about which an object is to rotate. To rotate
a shape about an exact point, select the shape, right-click the selected object and choose Rotate. If you press the Tab
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key or Space bar the Enter Coordinates dialog box displays and you can enter the point to rotate about in absolute
coordinates. The rest of the rotation command proceeds as normal.
• Flipping about Points: You can use coordinate entry to specify the line about which an object is to flip. To flip a
shape about an exact line, select the shape, right-click the selected object and choose Flip. If you press the Tab key or
Space bar, the Enter Coordinates dialog box displays and you can enter the first point of the flip line in absolute
coordinates. The rest of the flip command proceeds as normal.

3.4.5. Measuring Tools
The following measuring tools are available in a Layout View.
Standard Ruler
The Ruler measures the distance between two points, and is visible only during the measuring operation.
To access the ruler press Ctrl + D or choose Draw > Measure. To measure the distance between two points, click on the
starting point for the measurement, then drag the mouse to the point to which you want to measure. The ruler automatically
snaps to grid points in the layout as you move the mouse, to make measuring exact distances easier. If there is a shape
vertex, midpoint, edge, intersection or other grid point near the cursor, the cursor automatically snaps to the exact point.
If both the first point and the second point are snapped to grid points, the displayed distance is the exact distance between
the two points. The cursor displays dx, dy and the total distance. To force the measurement to an exact vertical, horizontal
or 45-degree angle, press Shift while measuring. When you release the mouse button the measurement no longer displays.
Layout Ruler
The Layout Ruler also precisely measures the distance between two points by displaying a ruler with specified increments
and unit of measure. Unlike the standard ruler activated by choosing Draw > Measure, the Layout Ruler remains visible
after you measure.
To access the Layout Ruler, choose Draw > Layout Ruler. Using the ruler crosshair to set the measurement origin, click
and drag the ruler beside the element you want to measure. Release the mouse to set the length of the measurement and
click again to end the measurement. Hold down the Ctrl key to snap to shape vertices. The following figure illustrates a
measurement using the Layout ruler.

To set default ruler properties, choose Options > Layout Options and click the Ruler tab on the Layout Options dialog box.
You can specify properties such as the ruler increments, the gap from the measured object, the ruler tick mark height,
and measurement precision in number of decimal places. See “Layout Options Dialog Box: Ruler Tab ” for dialog box
details.
To modify individual ruler properties, right-click the applied ruler and choose Shape Properties.
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Dimension Line
The Dimension Line feature measures and displays the distance between two points.
To access the Dimension Line, choose Draw > Dimension Line. Using the ruler crosshair to set the measurement origin,
click and drag the line between the points you want to measure. Release the mouse to set the desired length, then move
the mouse to move the dimensioning line away from any objects. Click again to place the line and end the measurement.
Hold down the Ctrl key to snap to shape vertices. The following figure illustrates a measurement using a dimension line.

To set default dimension line properties, choose Options > Layout Options and click the Dimension Lines tab on the Layout
Options dialog box. You can specify properties such as the line's arrow location (inside or outside), text direction in
relation to the line, the arrow size, the gap between the line and measured objects, the measurement precision in number
of decimal places, and the measurement accuracy tolerance. See “Layout Options Dialog Box: Dimension Lines Tab ”
for dialog box details.
To modify individual dimension line properties, right-click the applied line and choose Shape Properties.

3.4.6. Zooming and Panning
The following are techniques for zooming in and out of, and panning in a Layout View.
View All
Press the Home key or choose View > View All to display the entire layout in the window.
View Area
Choose View > View Area to start the view area command. When the cursor changes to a magnifying glass, click and drag
the cursor over the desired area and then release the mouse button to zoom in on that area.
Zoom Previous
Press the End key or choose View > Zoom Previous to return the view area to its previous state before the last View All,
View Area, Zoom In, Zoom Out or Zoom Previous command was executed.
Zoom In
Press the "+" key, choose View > Zoom In, or hold Ctrl while scrolling the mouse wheel to zoom in on the current view.
If you press and hold the mouse button at a point in the layout, the zoomed area is centered on that point. Otherwise, the
zoomed in area is centered around the center of the view. You can also use Zoom In, Zoom Out, and panning while
executing other editing operations. For example, when moving a shape in layout by dragging it, you can press the "-"
key (or Ctrl + the mouse wheel) while dragging to zoom out and display more of the layout. You can move the shape to
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another point in the layout by continuing the drag operation. If you press the "+" key while dragging a shape, the view
area zooms in on the shape that you are moving. This is useful for moving shapes in large layouts when the placement
of the shapes requires the Layout View to be zoomed. You can maintain the same zoom level while panning.
Zoom Out
Press the "-" key, choose View > Zoom Out, or press Ctrl while scrolling with the mouse wheel to zoom out of the view.
Panning
Press the up, down, left, or right arrows on the keyboard to pan the view in the specified direction. You can also scroll
the mouse wheel with no keys selected to pan up and down. To pan right and left, press Shift while scrolling the mouse
wheel. Alternatively, hold down the middle mouse button (or wheel) and when the cursor changes to a hand, drag to
reposition the view in the window.

3.4.7. Grouping
The Group command locks together the relative positions of multiple layout objects. The Ungroup command separates
grouped objects. To access these commands click the Group or Ungroup buttons on the Draw Tools toolbar. Groups can
be used to help construct the geometry in the Artwork Cell Editor, but the grouping is lost when the artwork cell is saved
(all the correct geometry is saved however). Groups are not saved in the artwork cell because there are no group objects
in GDSII.

3.4.8. Alignment Tools
To access polygon alignment functions, select two or more polygons to align and choose Draw > Align Shapes or display
the Alignment Tools toolbar by right-clicking the toolbar and choosing Align.
The alignment tools align the selected shapes as follows:
• Align Top: Aligns all shapes to the top edge of the first shape selected.
• Align Bottom: Aligns all shapes to the bottom edge of the first shape selected.
• Align Middle: Aligns all shapes vertically with the mid-point of the first shape selected.
• Space Evenly Down: Aligns all shapes using the vertical spacing you specify in the Spacing dialog box that displays.
The first shape selected is the "virtual anchor".
• Align Left: Aligns all shapes to the left edge of the first shape selected.
• Align Right: Aligns all shapes to the right edge of the first shape selected.
• Align Center: Aligns all shapes horizontally with the mid-point of the first shape selected.
• Space Evenly Across: Aligns all shapes using the horizontal spacing you specify in the Spacing dialog box that
displays. The first shape selected is the "virtual anchor".
• Make Same Width: Makes all shapes the same width as that of the first shape selected.
• Make Same Height: Makes all shapes the same height as that of the first shape selected.
• Make Same Both: Makes all shapes the same width and height as that of the first shape selected.
• Space and Size as Array: Displays the Align Shapes to Array dialog box and aligns and resizes shapes in an array.
Note that a frozen polygon does not move. You can unfreeze a shape by right-clicking it and choosing Shape Properties,
then on the Layout tab, clear the Freeze check box.
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3.5. Intelligent Cells (iCells)
iCells make the use of many elements much simpler and less error-prone. With iCells, the parameter values from one
element can be associated with the parameter values of another element. For example, Microwave Office software does
not require parameters for both interconnecting transmission lines and discontinuity models. iCells dynamically adapt,
based on their electrical connections, effectively inheriting their properties from the connections and thus eliminating
synchronization errors and increasing designer productivity.

3.5.1. Standard iCells
There are many iCells that are already set up within Microwave Office software. The standard iCell elements have names
that end with a "$". The rest of the name is the same as the non-iCell version of the element. For example, the MTEEX
iCell is MTEEX$. The schematic in the following figure shows an iCell version of the MTEEX element that is connected
to three MLIN elements. The MTEEX$ element does not require any parameters for any of the widths of the MTEEX.
All the required width values are automatically obtained from the elements that are connected to the MTEEX$ iCell.
MLIN
ID=TL3
W=30 um
L=140 um

MLIN
ID=TL1
W=70 um
L=140 um

MTEEX$
ID=MT1
1

2
3

MLIN
ID=TL2
W=15 um
L=140 um

The following layout is the Layout View of the previous schematic. Note that the three widths required to draw the center
MTEEX element are correctly assuming the values of the connected lines.
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Standard iCells require that the elements they connect to have the parameter the iCells are looking for. For example, the
MTEEX$ element must have elements connected at each node that have W parameters. If one of the connected elements
does not have a W parameter, the iCell reports an error. You can edit the iCells to allow them to connect to different
parameter names if needed. For example, you can change MTEEX$ so that its W1 parameter connects to a connected
element's W1 parameter instead of the default W parameter. To do so, double-click the iCell element in the schematic
window or right-click the selected element and choose Edit Element. You can view and edit the W1, W2, and W3 parameters
of the MTEEX$ in the Element Options dialog box (you can also make them visible on the schematic by deselecting
Hide for the parameter on the Display tab). If the W1 parameter is selected in the Parameters list, you can see that it has
a value of W@1. This syntax indicates that W1 should be assigned to the value of the W parameter from the element
connected to node 1 of the MTEEX$ element. If you change this to W1@1, the MTEEX$ tries to connect to a W1
parameter from the element connected to its node 1.

3.5.2. User-Defined iCells
Any element can be made to act as an iCell by using the correct iCell syntax for the element's parameter values. For
example, if you place a MTEEX element on the schematic and its W1, W2, and W3 parameter values are set as follows,
W1 = W@1 W2 = W@2 W3 = W@3
the MTEEX instance is the same as a MTEEX$ element (except the W1, W2, and W3 parameters are visible on the
schematic).
The iCells are created by assigning parameter values X using the syntax X=P@N. This syntax indicates that X should
be assigned to the value of the parameter P from the element connected to node N of the iCell element.
NOTE: When creating user-defined iCells, it is possible to connect elements together that form a circular reference.
This causes errors in the circuit and should be avoided.
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3.5.3. Generalized iCells
Generalized iCells are an extension of normal iCells. Normal iCells allow you to assign parameter values to the parameter
values of elements connected to the iCell. Generalized iCells allow you to assign parameters to the parameter values of
any other element in the schematic. The generalized iCells are created by assigning parameter values X using the syntax
X=P@ELEMENT.NAME. This syntax indicates that parameter X should be assigned to the value of the parameter P
from the element of type ELEMENT with an ID parameter equal to NAME. For example, W1=W@MLIN.TL1 indicates
that the parameter W1 should be assigned to the value of the W parameter of a MLIN element with an ID parameter
named TL1.

3.6. TRACE Elements
There are several different TRACE elements. The MTRACE is a microstrip line that can have zero or more bends. The
MCTRACE is a variation of the MTRACE that uses curves instead of bends. The SCTRACE is the same as MCTRACE,
except it is used for stripline.

3.6.1. TRACE Editing
In general, you perform graphical editing of the TRACE layout cells using mouse commands. Double-clicking the layout
object activates edit mode and displays the black diamonds that you use to edit the bends and lines.

On one straight segment there are three diamonds. The outside diamonds control the length of the segment while the
middle diamond controls bend manipulation. The diamonds are manipulated by placing the mouse over the diamond to
activate an arrow cursor.

To move the diamond, click and drag the arrow cursor to another position and then release the mouse button.
Adding a Bend
To add a bend, select the MTRACE element in the Layout View. To move the middle diamond, click and drag the arrow
cursor to another position and then release the mouse button. Before the mouse button is released, an outline of the new
MTRACE displays, as shown in the following figure.
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The following figure shows the completed bend.

Moving Bend Position with Overall Length Constant
There are three options when moving a bend to a new position. The first two options refer to moving a bend on one of
the end segments. The third option refers to moving a middle segment between two bends.
Option 1: When moving an end segment, the two segments attached to the bend being moved take up the slack in length
while the other segment remains constant. To move the middle diamond of an end segment, click and drag the arrow
cursor to another position and then release the mouse button. An outline of the new bend position displays as shown in
the following figure.

AWR Microwave Office Layout Guide 3–63

TRACE Elements

The following figure shows the new bend position with overall length constant.

Option 2: To move the middle diamond of an end segment, press Ctrl + Shift while clicking and dragging the arrow cursor
to another position, then release the mouse button. This option is the opposite of option 1. The slack in the length is taken
up by the segments that are not being moved. Observe that the end segment that is moving is constant in length while
the other two segments change, as shown in the following figure.
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The following figures shows the new bend position for option 2.

Option 3: When moving a middle segment between two bends, the middle segment remains constant while the end
segments vary in length, as shown in the following figure. Use the same commands as in option 1 to move a middle
segment.
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Moving the Bend Position and Changing the Overall Length
To move a bend position while changing the overall length, you move the end segments of the TRACE when there are
two bends or less in the layout. When changing the length of a TRACE and moving a bend position, the segment being
moved remains at a constant length while the segment attached to the bend varies in length. To move a bend and change
the length, hold down the Shift key. To move the middle diamond of the end segment, click and drag the arrow cursor
to another position and then release the mouse button. The length of the middle segment changes, while the end segment
remains a constant length, as shown in the following figure.
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The following figure shows the new change in length and bend position.

When there are more than two bends in the TRACE you can change the bend position and the length in a "trombone"
action by holding down the Shift key. To move the diamond, click and drag an interior segment of the TRACE to another
position and then release the mouse button. Notice that the middle section's length remains constant while the other two
segments vary in length, as shown in the following figure.
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Adding a Bend After Initial Bend
To add a bend after the initial bend is added, hold down the Ctrl key, and click and drag the middle diamond between
the two bends to another position and then release the mouse button. The following figure shows the outline of the new
bend.

The following figure shows the final TRACE with the new bend.
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Rotating a Segment
To rotate the end segment of a TRACE, press the Ctrl key and click and drag the end of an MTRACE that has at least
one bend in it to another position, and then release the mouse button.

NOTE: When grid snap is on, the angle of rotation is only placed on a snap angle increment specified in the Layout
Options dialog box (choose Options > Layout Options and click the Layout tab).
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3.6.2. TRACE Routing
You can route the TRACE layout cell using the TRACE routing command. The TRACE is routed from the start end
which is indicated by an arrow.

The TRACE routing command routes the TRACE from a center line path that is drawn with the mouse (or using coordinate
entry). You start TRACE routing by double-clicking the TRACE to put it into edit mode, where its grab diamonds are
visible. To start TRACE routing you double-click one of the diamonds on either end of the TRACE.
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After you start the TRACE routing command, you can draw a center line path as shown in the following figure. If you
press the Tab key or Space bar while drawing, a Coordinate Entry dialog box displays to allow coordinate entry of the
center line points. You can also use gravity points when drawing the center line. You draw the center line by clicking at
each of the desired vertex points. To complete the center line drawing, double-click for the last point or click on the same
point twice.
Hold the Shift key during trace routing to route with no orthogonal restraints on the route.

After the center line path drawing is completed, the MTRACE element routes itself to the center line path. The routing
is not always exactly on the center line because there are other constraints that may need to be satisfied. For example,
when routing the MTRACE, there is a minimum allowable length for each segment.
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Maintaining the Line Length
During TRACE routing, the length of the TRACE is based on the length of the drawn center line. If you want to route
an MTRACE while maintaining its length, press the Shift key when double-clicking to end the route. This action causes
the MTRACE to be scaled such that the general shape of the MTRACE is the same as the drawn center line, but the
length is the same as the length of the original line.
NOTE: Avoid pressing the Shift key during intermediate routing points; it makes it difficult to drag orthogonal routes.

3.6.3. Snap to Fit
There are several elements that have layout cells that can automatically resize themselves to Snap to Fit between two
points. The TRACE elements and iNet all support this feature, as do many of the transmission line cells (for example,
the MLIN cell). The use of Snap to Fit is shown in the following figure.

The following figure shows the result of applying Snap to Fit on the center MTRACE cell in the previous figure.

3–72 AWR Design Environment

TRACE Elements

When it is not possible for the layout cell to resize itself to fit exactly, it resizes as closely as it can. For example, an
MLIN cell can only stretch in one dimension, so if Snap to Fit is applied to an MLIN, the MLIN may still be disconnected
in the direction perpendicular to the MLIN.

3.6.4. Symmetric Circuits
You can use generalized Intelligent Cells (iCells) to simplify the creation of layouts that have symmetric components.
The generalized iCell syntax allows an element parameter to be assigned the same value as a parameter on any other
element in the schematic. For example, you can assign the W parameter on an MLIN (instance TL1) to have the same
W parameter as another MLIN (instance TL2) using the syntax W=W@MLIN.TL2 for the W parameter of TL1. The
instance name TL1, is the value of the ID parameter for the schematic element.
MLIN
ID=TL3
W=70 um
L=355 um

MTRACE
ID=X1
W=70 um
L=1748 um
BType=2
M=0.6
MLIN
ID=TL1
W=60 um
L=522 um

1
3
2

MTRACE
ID=X2
W=70 um
L=L@MTRACE.X1 um
BType=2
M=0.6
DB=DB@MTRACE.X1 um
RB=RB@MTRACE.X1

MTEE
ID=TL2
W1=70 um
W2=70 um
W3=70 um

MLIN
ID=TL4
W=70 um
L=355 um

For the schematic shown in the previous figure, the MTRACE element with ID=X2 uses the generalized iCell syntax to
assign most of its parameter values to the same values as the corresponding parameters in the MTRACE instance with
ID=X1. Normally, the DB and RB parameters for the MTRACE element are hidden (they can be made visible or edited
in the Element Options dialog box). The DB parameter specifies a vector of segment lengths, and the RB parameter
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specifies the angle of each bend. If the RB and DB parameters are assigned as equal to the RB and DB parameters of
another MTRACE, the resulting TRACE will have the same bends. It is important to also set the length of the MTRACE
to the same as the other MTRACE so that the line is drawn symmetrically. You can also assign the other parameters of
the MTRACE (such as width) to the other MTRACE parameters, but this is not required. The following figure shows
the resulting layout for the previous circuit. If the upper TRACE is re-routed, or edited, then the lower TRACE
automatically re-routes itself to match. In the following figure, the MTRACE that uses the generalized iCell syntax is
also flipped so that the circuit is completely symmetric.

3.7. Electrical Net (iNet) Elements
Electrical Nets (iNets) are advanced schematic and layout objects in the AWR Design Environment platform that are
only available with the most advanced feature set. If you are unsure if your current license includes iNets, please contact
your regional sales representative.
Like all models in the AWR Design Environment platform, iNets have both a schematic and layout representation. In
the schematic, an iNet is a single node that connects two or more element nodes together. This node is created by wires
or by named connectors (the NCONN element), or by directly connecting the element nodes. In the layout, an iNet is a
collection of routes and shapes drawn to physically complete the connections specified in the schematic. When incomplete,
these connections display as rat lines in the layout. Routing is the process of drawing the routes that complete the
connections and eliminate the rat lines.
Once an iNet is routed, you can use it in simulation through the AWR extraction process. This means the iNet geometry
is used as the input to one of many physical simulators that can determine the characteristics of the iNet based on its
geometry and physical stackup. For silicon designs, this is typically an RLCK parasitic extractor. For microwave designs
(MMIC or PCB), this is typically the ACE extractor or EM simulators (EMSight, Cadence AXIEM® 3D planar EM
analysis simulator, Cadence Analyst™ 3D FEM EM analysis software, or EM simulators from vendors who use the EM
Socket). See “EM: Creating EM Structures with Extraction” for more information.
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iNets must be properly configured for each process. This section discusses how to properly use iNets after the technology
is configured. For silicon and MMIC design, the PDKs are configured for iNets. For PCB, you should contact your
regional sales representative to get support configuring your PCB process for iNets.

3.7.1. Defining iNets
The following sections define iNets in a schematic and in a layout.
Defining iNets in a Schematic
Each iNet is one electrical node connecting two or more model connections.
Defining iNets in a Layout
iNet - A collection of routes and/or shapes that complete the physical connection of cell faces in layout.
Route - A collection of segments (and vias, if needed) that connect two points in a layout. Double-click a ratline in the
layout to start adding a route.
Segment - One rectangle, the simplest part of an iNet.
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An iNet can have different combinations of routes to make it complete.
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You can also associate an existing arbitrary shape (dumb shape) with an iNet.
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You can use dumb shapes to complete the connections of an iNet.

Finally, you can use a combination of routes and shapes to complete an iNet.
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Note that iNet shapes can only be extracted and simulated by EM simulators such as AXIEM, because an arbitrary shape
cannot always be mapped to an available distributed element model. For maximum simulation flexibility, use iNet routes
wherever possible, and use shapes only when necessary.

3.7.2. Preparing to Route
The following sections discuss routing configuration.
Default Vias and Discontinuities
If connected segments in an iNet are on different layers, their connection includes vias. Depending on your technology,
you may need to configure default via and discontinuity settings for your iNets. Choose Options > Layout Options to
display the Layout Options dialog box, then click the iNet tab. See “Layout Options Dialog Box: iNet Tab ” for more
information.
Minimal 2 iNet Route Via Mode

via mode provides support for constructing complex multi-layer self-overlapping iNet route structures. This
option provides a mode where the via insertion location is more predictable than the standard Minimal via mode when
working on these types of structures.
Minimal 2

In the Minimal 2 vias mode a via is only inserted under two conditions:
1. If two consecutive line segments along the iNet route change layers a via is inserted at the junction between the two
line segments.
2. If an end of the iNet Route terminates over an area pin on a different layer a via is inserted to connect the end to the
pin.
This is more restrictive, so more predictable than the standard Minimal via mode. It only inserts vias in the junctions of
a single iNet route or between a route and end points and overlapped area pins. It does not insert vias when the route
overlaps itself or if two independent routes overlap each other.
The following figure shows an example of how the new Minimal 2 via mode works for a multi-level self-overlapping
route.
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This figure shows that the Minimal 2 via mode only inserts vias at the junctions where the line changes layers. In this
layout many corners overlap but the vias are only placed where the line transitions from one layer to another. At the
lower end there is an area pin which overlaps the route end point so a via is inserted to connect that area pin to the route.
Minimal 2 via mode provides support for predictable via insertion when constructing complex multi-level self-overlapping

iNet route structures.
Default Widths and Line Types

Choose Layout > Show Routing Properties or click the Show Routing Properties button on the toolbar to open the iNet
Routing dialog box and set the initial iNet properties when routing.

Use HV routing:

When this check box is cleared, horizontal and vertical routing use the same defaults. When you select
this check box, you can specify different options for horizontal and vertical routing.
When you are routing a net, you cannot change the settings in this dialog box; you can only change iNet widths during
routing if you press the Tab key or Space bar.
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Default width:
Line type:

Specify an iNet width (in the project unit for length). Previous widths are remembered.

Select a line type available in your process.

3.7.3. Starting Routes
Double-click a rat line in the layout or select a rat line or completed route, right-click and choose Select Draw Route. The
following figure shows a layout with two iNets, with the left iNet in routing mode.

The cursor changes to a routing symbol that also includes dx, dy and Line displays. dx and dy display the amount moved
in either direction for the current segment, and Line displays the line type used for the current segment.
All faces or area pins to be connected by the iNet are highlighted in blue.
All rats lines from different iNets are gray to help identify only the iNet being routed.

3.7.4. Entering Routes
Once you start a route, click to set the start/end points of each segment.

Press Ctrl + Shift and use the mouse wheel to change the line type for the current segment. The Line name changes on
the cursor display.
Right-click to undo the last iNet segment.
While in routing mode, press the Tab key or Space bar to set iNet segment locations with coordinate entry. You can enter
coordinates relative to the previous point or absolute x,y coordinates.
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Also while in routing mode, press Shift + V to cycle through valid via types between the layers being connected. The last
via added becomes the current (default) via.
Double-click or press Enter to finish the current route.
Minimum Spacing Routing Guides
The Minimum Spacing Routing Guides provide assistance for entering iNet routes, which allows you to place the route
lines as close as possible to other structures in the design without violating the design rules. The guides use the separation
entries from the DRC file to create guides which help when tracing out routes consistent with the rules in the DRC file.
The Minimum Spacing Routing Guides show a guiding line to guide the route trace centerline at a distance that results
in the route trace being as close as possible to the other structures, while still satisfying the DRC minimum spacing
separation rules. An option to reject points within the minimum spacing range of a structure prevents placing routing
points inside the minimum spacing guides. The guides provide gravity assistance to guide the entry, but do not rigidly
constrain entry to the guide. The route entry can move off the guide at any point if needed to continue a route. The route
gravity specifies how strongly the mouse is attracted to the guide and how far away from the guide it needs to be moved
before gravity is released.
Design Rule Specifications

To provide these guides, the process library needs to include a set of DRC rules for the process with separation
specifications for all important layer spacings. For the route spacing guides the important rules are the “SEPARATION”
entries which specify the minimum separation spacing required between specific design layers, as shown in the following
example:
SEPARATION "Metal 2" "Metal 2" 3000
SEPARATION "Metal 1" "Metal 1" 3000
SEPARATION "Metal 1" "Metal 2" 3000

For example, the following rule
SEPARATION "Metal 2" "Metal 2" 3000

specifies that two structures on the layer “Metal 2” must have at least 3 µm minimum separation between them. These
values from the DRC rules are used in the calculation of where to place the guide so that the resulting trace has this
minimum spacing between the layers in the route line and other structures in the design.
Activating the Separation Rules

After loading into the project the DRC rule files with minimum spacing rules, choose Layout > Layout Mode Properties.
Under Routing options select the following options.
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•

Minimum spacing guides

enables the use of minimum spacing guides when drawing routes.

•

Reject clicks inside min spacing rejects single mouse clicks inside the regions around shapes that are inside the minimum
spacing guides. You can override this behavior by holding down the Alt key to allow a route connection to a desired

shape.
•

Constrain to outside min spacing attempts to restrict routing to outside of the minimum spacing guides. While routing,

if the current segment approaches a shape, the progress is constrained when the route reaches the minimum spacing
guide. You can override this behavior by holding down the Alt key to allow a route connection to a desired shape.
• To override this behavior you can hold down the Alt-key to allow a route connection to a desired shape.
•

Disable self avoidance guides disables guides normally placed around segments of the current route as they are entered.

The Alignment gravity setting also pertains to the routing guides. It affects how strongly the cursor is pulled to stay in
alignment with the guides during routing. The stronger the gravity, the farther away from the guide you must move the
cursor in order to pull it off alignment with the guides.
The following example shows some wired elements in a schematic.

Their layout view shows two elements are already connected using iNet routes.
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After the separation rules in "Design Rule Specifications" are included in the DRC file and activated, the Minimum
Spacing Route Guide displays with a dotted red line when starting the iNet routing on the remaining rat line.

Route the second line as close to the initial line as possible without violating the DRC rules regarding the separation
between the line layers. When you start on Metal 1 and move toward the left, as you approach the existing route a dotted
red line displays to the right of it as shown in the following figure. If you try to click inside the red dotted line and the
existing route to place the route, route placement is not permitted.
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Continuing to route displays the route guide as shown in the following figure. A closer look at the spacing between the
traces resulting from the minimum spacing guides indicates that the separation between the Metal 2 - Metal 2 and Metal
1- Metal 2 is as defined in the SEPARATION rules in the previous section.
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Horizontal/Vertical Routing with Minimum Spacing Guides

For H/V routing, guides are placed at the maximum of the spacing values for the two line types used. This is to try to
ensure that neither line type is placed at a position that is too close to an existing structure, resulting in DRC violations.
For example if the separation rules are as follows,
SEPARATION "Metal 2" "Metal 2" 5000
SEPARATION "Metal 1" "Metal 1" 3000

and the H/V routing is set to use Metal 1 for horizontal and Metal 2 for vertical.
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If routed along Metal 2 shapes, the guides display and guide both the horizontal lines and the vertical lines at a distance
of 5um from the structure.

iNet Status
When all pins of the models connected to an iNet are connected with routes, the iNet is complete. For simple iNets, you
can see visually if the iNet is complete or not.
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With an iNet selected, you can view the Status bar along the bottom of the AWR Design Environment platform main
window to see whether or not an iNet is complete.

Connecting to Non-orthogonal Faces and Area Pin Sides
When starting an iNet route segment from the side of a non-orthogonal area pin or from a non-orthogonal face, the Layout
Editor provides alignment lines and alignment gravity to help guide the iNet route segment direction to maintain a
perpendicular connection to the area pin side or cell face so that the resulting connection is flush. This alignment help
is also useful when attempting to finish a route by connecting the last segment of an iNet route to a non-orthogonal area
pin side or cell face.
For example, in the following figure, there are two pins which have non-orthogonal faces that need to be connected
together to complete the circuit and replace the flight line.

To replace the flight line with an iNet route, double-click on the flight line, then starting from the connection point on
one of the pins, click and drag to begin a new iNet route segment. As the segment is drawn away from the non-orthogonal
pin face, alignment gravity guides its direction to maintain a perpendicular end connection with the pin face. A dotted
line drawn down the middle of the route segment shows the perpendicular direction out from the pin face. The following
figure shows this directional support and centerline while drawing the line outward from the pin.
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Since the pins are not directly aligned for connection with a single segment, you need to create a horizontal segment that
is just long enough to assure alignment with a third (diagonal) segment which is perpendicular to the second pin's
non-orthogonal face. It can be difficult to determine how long the horizontal segment should be so that the final diagonal
segment is perpendicular to the pin face and results in a flush connection.
A guide line and alignment gravity display when the horizontal segment is at the correct length to create the final segment
and make it align perpendicular with the pin face. The following figure shows the point at which the alignment gravity
provides a slight resistance and the alignment line is drawn along the flight line, indicating that starting the final segment
at this point aligns correctly.
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Click and begin the final segment leading into the second pin. As the cursor gets close to the pin, alignment gravity
attempts to guide the connection of the iNet route end segment to the pin face connection point providing a clean flush
connection. The following figure shows the final position where the alignment gravity assisted in connecting to the pin
face.
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Double-click to end the route, and both the start and end connections should provide flush connections to the pin faces.
The following figure shows a magnified look at the resulting segment connection.
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The alignment guides and gravity help create clean flush start and end connections to pins with non-orthogonal faces of
any angle, helping to provide clean connections to these hard-to-align faces.
Coordinate Entry
When entering iNet route objects through coordinate entry, the Enter Segment Coordinates and Properties dialog box
allows you to specify coordinates, line type, and line width. When starting entry of a route using coordinate entry, the
initial width and line type are the defaults specified in the iNet Routing dialog box (with a layout window active, choose
Layout > Show Routing Properties), as shown in the following figure.

To use coordinate entry when starting a new route, double-click on a flight line and then press the Tab key to display the
Enter Segment Coordinates and Properties dialog box. The first time you display this dialog box, its values match those
of the iNet Routing dialog box.

Once you change these values, the new line type and width become the default value for the next route entry.

3.7.5. Editing Routes
After you enter iNet routes, there are several editing techniques for editing the end points of each route's segments and
editing the line types and vias for each route.
End Points
Double-click any route to enter editing mode. In editing mode, diamonds display along the middle of the route.
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Click and drag the edit diamond in the middle of a segment to move that segment. The length of any segments on either
side is adjusted.
Click and drag the edit diamond on the end of a segment to move the end point of the two connecting segments. The
length of segments on either side are adjusted.
Click and drag the end point of any route to move the end point. The length of the attached segment and one segment
behind are adjusted.
During any segment movement the cursor displays the distance the segment(s) has moved in the x and y directions.
You can also use the Tab key or Space bar to move segments specific amounts.
Line Types
After you finish a route, you can change the line type used for each segment, for multiple segments, or for all segments
of the route.
Select a route, right-click, and then choose Route Segment Properties to display the Segment Properties dialog box.

In this dialog box you can change the Line Type and Width for all selected segments.
You can select individual segments of a route. Shift+right-click a segment to draw a line through the center of the segment.
Using the same technique, you can select more segments or click again on selected segments to deselect them.
Vias
You can add vias while in routing mode. Pressing Shift + V during routing allows you to cycle through valid via types
between the layers being connected. The last via added is shown as the current (default) via.
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After you finish a route, you can change the via properties that connect segments on different layers.
Double-click over the via area to display the edit diamonds for the via region only.

Click and drag the edit diamonds to resize the via area graphically.
Right-click over the via and choose Route Via Properties to display the Via Properties dialog box and edit the via properties.

Select multiple vias for editing by Shift+right-clicking the vias.
Note that for different iNet configurations, via editing changes. Some processes have fixed via sizes, so dragging the
edit diamonds does not apply. Instead you change the Via Type in the Via Properties dialog box.
To offset vias, select the via(s) to offset, right-click and choose Route Via Properties. In the Via Properties dialog box,
clear the Auto Size check box and enter the desired offset. Note that the LPF must have the
DRAW_VIA_ON_SEGMENT_END property unset.
Alternatively, you can offset vias directly in the layout by double-clicking on a via and dragging it by its center drag
handle, as shown in the following figure.
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Shape Properties
To specify all iNet route properties, select an iNet, right-click, and choose Shape Properties to display the Properties
dialog box. See “Properties Dialog Box: Layout Tab ” for information on layout options.
The Route tab controls the discontinuity types for the route. Typically, silicon designs use square discontinuities and
microwave designs use any of the types available. See “Properties Dialog Box: Route Tab ” for information on route
options.
The Segments tab controls the properties for each segment of the route. When you select a segment in this dialog box it
is also highlighted on the route with a line through the center of the segment. See “Properties Dialog Box: Segments Tab
” for information on segment options.
The Vias tab controls the properties for each via of the route. When you select a via in this dialog box, it is also highlighted
on the route with an "X" through the center of the via. See “Properties Dialog Box: Vias Tab ” for information on via
options.
Bend Styles
iNets can have square, mitered, curved, chamfered or rounded bends.
The following figure shows a section of iNet route with four default square style bends.
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Rounded bends provide an alternative to square bends, decreasing radiation at the corner points, similar to mitered
corners. Rounded corners are also preferable in some processes such as Printed Circuit Boards (PCBs). Implementation
of a rounded bend is similar to a square bend, but with the outer edge corners rounded off with a radius that is half the
line width.
To use rounded bends, select the route, then right-click and choose Shape Properties to display the Properties dialog box.
On the Properties dialog box Route tab, select Rounded as the Bend style, as shown in the following figure.
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Chamfered bends are useful for maintaining a fixed diagonal segment length while adjusting the route segments. Chamfered
provides an intermediate step between a square bend and a rounded bend, providing one diagonal segment that cuts off
the corner, as compared with the square bend. You can control the length of the diagonal segment by setting the chamfer
amount, similar to the way the amount of curvature for a rounded bend is controlled by adjusting the radius.
On the Properties dialog box Route tab, select Chamfered as the Bend style, as shown in the following figure.
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The amount of chamfer in a bend is relative to the route width or specified by an absolute size. When the lengths of the
incoming and outgoing segments to a bend become too small to fit the full-size chamfer segment, the length of the
chamfer segment is automatically reduced to fit a shorter segment by default. To prevent automatic resizing, select the
Curves use fixed radius check box in the Properties dialog box. If selected, incoming or outgoing segments that become
too short cause the bend to revert to a rounded style.
The following figure shows the route segment with chamfered bends, with the amount of chamfer relative to the width
and Amount set to 1, so the chamfer length is equal to the width.
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Reroute Mode
After a route is complete, you can continue editing the segments of the route. Select the route, right-click, and choose
Extend Route. You can enter new segments to the route or right-click to remove the last segment.
The location in which you right-click to enter this mode is important. The end of the route you are closest to is the end
of the route you will edit.
Snap to Fit
iNets can slightly auto-correct to complete a route, such as when a model to which the iNet is connected moves or is
resized. While iNets function with the Snap to fit command it is important to note that they do not work with the snap
command.
Select the iNet and choose Edit > Snap to fit or click the Snap to fit button on the toolbar to complete a route.

Snap to Fit should not be confused with routing capability. Snap to Fit only attempts to adjust the two segments of the
route back from the end of the route that has a rats line. If you want more extensive iNet changes you should use Reroute
mode.
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Reshaping Routes
You may need to change an existing route to accommodate new design elements, specifically to reshape the route around
obstacles. The Route Reshape feature allows you to make the necessary modifications without deleting and redrawing
the entire route. Instead, by picking a point along the route and entering a new sequence of segments that connect back
to the route, you can cut out and replace a section of the route.
The following figure shows an example of an iNet route line running over the top of a FET device in a design. It is best
to reshape the existing route around the device, rather than deleting and replacing the entire route.

To reshape the existing route, select the iNet route, right-click and choose Reshape Route.
Select a point on the route centerline where you want to begin the reroute. In the following figure, a point above the FET
is selected, along the existing iNet route centerline. After the first click, the reshaped section is started to the right by
dragging the mouse away from the centerline.

3–100 AWR Design Environment

Electrical Net (iNet) Elements

Click to add new segments to the reshape portion, the same as creating a new route. To finish the reshape segment,
double-click the original route where the reshape section should connect back to it. The following figure shows the
reconnection back to the original iNet Route, after drawing the reshaped section.
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After you double-click, the region of the original iNet route between the start of the reshape and the end is removed, and
the reshaped section replaces it, as shown in the following figure.

Similarly, you can replace multiple route segments. The following example shows a three-segment route that passes over
the top of a FET.
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To reshape this route, select the iNet route, right-click and choose Reshape Route, then click on the centerline of an
existing route segment. Draw the reshape section and double-click on the centerline of another existing segment to end
the reshape section. The following figure shows the process of drawing the reshaped route around the FET.

When you complete the reshaped section by double-clicking on the existing segment centerline, the segments between
the start and finish points are removed and replaced by the reshaped section, as shown in the following figure.
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Snap Cell Connections
Often when developing a design, you need to shift a cell a small amount to accommodate additional design elements. If
the cell also has iNet route connections to its faces, shifting the cell results in flight lines from the location off the cell
with the previous iNet connections to the new location of the cell. The following figure shows an example of a FET cell
shifting to connect with a couple of connections, where doing so opened up two other connections.

The Snap Cell Connections command can adjust iNet routes with remaining flight lines to close the connections and
connect to the cell faces. To use this command, select the cell, right-click and choose Snap Cell Connections as shown
here.
This command attempts to adjust the iNet routes which have flight lines close the connection and attach the lines to the
middle of the cell faces. The following figure shows the result of running the command for this example.
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3.7.6. Selecting iNets in Layout
You can select more than one route or shape of an iNet by Shift-clicking to add or remove them from the current selection
set. This technique is difficult for complex iNets, however.
To select all routes and shapes associated with an iNet, select the corresponding wire in the schematic, then right-click
and choose Select in Layout.
Alternatively, you can select a route in the layout, right-click and choose Select net routes to add all routes (not shapes)
to the current selection.

3.7.7. Deleting an iNet
You can delete routes and shapes of an iNet by selecting them and pressing the Delete key or choosing Edit > Delete.
Since an iNet is an object in both schematics and layouts, you can also delete an iNet from the schematic by deleting the
wire connecting model nodes or by renaming or removing named connectors. If you delete a schematic iNet the layout
iNet remains in layout in a disassociated state.
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You can identify an iNet in a disassociated state in several ways. The Status bar with the iNet selected shows a disassociated
status. The iNet also draws on the Error Highlight drawing layer, so the routes of the iNet differ visually. The rat lines
for the iNet no longer draw to the routes or shapes.

3.7.8. Associating and Disassociating iNets
In this section, the term "route" applies to both routes and shapes of an iNet. You can correct a disassociated iNet by
associating the route in layout with the correct iNet by first selecting the rat line for the proper iNet, then pressing the
Shift key, selecting the disassociated routes, right-clicking, and choosing Associate Net Routes. The following figure
shows the route associated back to the iNet.

To disassociate associated iNet routes, select the routes, right-click, and choose Disassociate Net Routes.
You can automatically associate and disassociate all iNets in a layout based on connectivity by choosing Layout > Connect
Net Shapes. Any routes in contact with the pins on which the "x" of the rat lines display are associated with the
corresponding iNet(s). Additionally, any other routes that contact such an associated route are also associated with the
same iNet. Finally, this command disassociates any routes that do not connect to an iNet through contiguous metal.
Connect Net Shapes uses connectivity rules to determine connections between different layers. See “Connectivity Rules”
for details.
The following figure shows examples of Connect Net Shapes working. Disassociated routes and shapes, which directly
or indirectly connect to one or more ends of an iNet, become associated with that iNet.
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The following figure shows an example of Connect Net Shapes disassociating a route and a shape from an iNet because
they are not connected to it. The second example shows a route being disassociated from one iNet and associated with
another, again based on connectivity.
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3.7.9. iNet Cleanup
The Net Cleanup command provides editing features for iNet route objects in addition to the normal routing editing
commands. This command supports the following optional operations that you can perform on a selected set of iNet
route objects:
• Merge end-connected routes
• Insert route crossovers
Invoking the Command
To enable the Layout menu a layout window must be active, and to enable the Net Cleanup command you must select at
least one route object in the layout window. Choose Layout > Net Cleanup to display the Net Cleanup dialog box with
options for merging end connected routes and inserting crossovers, as shown in the following figure.

Merging End-Connected Routes
This option does not require any additions to the Layer Process Definition (LPF). In the design, it is possible for several
routes to be associated with a line of single connection, and a single route might be separated into two Route objects
using the Slice command. The Merge end-connected routes option can clean this up.
The following figure shows how to merge end-connected routes. Here the route is sliced and needs be merged together.

If you select the two routes and choose the Merge end-connected routes option, the two routes are joined to form one
route, as shown in the following figure.
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Inserting Crossovers
You can also insert crossovers to perform Net Cleanup. The Insert crossovers option attempts to automate the process
of inserting a new crossover segment on a different layer, and keeping the route as one object, making it easier to edit
and manipulate.
For the Net Cleanup command to handle the intersection of two line types, some process rules must be defined in the
LPF. These rules tell the command when it encounters an intersection of specific line types, what layers each line type
should be transitioned to, to form the crossover. The rules can also describe how far back from the other lines the
intersection must be to be valid for the process. The following is a typical rule:
$CROSSOVER_RULES_BEGIN
! LT1:LT2
LTUnder
LTOver
M1:M1
M1
M2
$CROSSOVER_RULES_END

OffUnder
5e-6

OffOver
5e-6

Flags
1

This rule indicates that when you see an intersection between line type M1 and line type M1, the first line type should
stay on M1 and the second line type should be transitioned to M2 at the intersection. In both cases the pullback should
be 5 um from the lines at the intersection. Note that the flags are set to 1. This indicates that an extra half of a line width
should be included in the pullback to make room for things like the addition of an inline via. If the flag is set to 0, only
the fixed pullback is used for the lines at the intersection.
The following example uses the rules supplied for the example AWR MMIC process.
!--- Used for automatic crossover insertion ---$CROSSOVER_RULES_BEGIN
! -> LT1:LT2
LTUnder
OffOver
flags
"Thick Metal Line:Thick Metal Line"
"Thick Metal Line"
5e-06
1
"Cap Bottom Line:Cap Bottom Line"
"Thick Metal Line"
5e-06
1
"Plated Metal Line:Plated Metal Line"
"Thick Metal Line"
5e-06
1

LTOver

OffUnder

"Cap Bottom Line"

5e-06

"Cap Bottom Line"

5e-06

"Cap Bottom Line"

5e-06
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"Thick Metal Line:Plated Metal Line"
5e-06
1
"Cap Bottom Line:Plated Metal Line"
5e-06
1
$CROSSOVER_RULES_END

"Thick Metal Line"

"Cap Bottom Line"

5e-06

"Cap Bottom Line"

"Thick Metal Line"

5e-06

You only need to specify crossover rules when layers are in conflict. For the MMIC process, an intersection between
Thick Metal Line and Cap Bottom Line is fine because these line types are on different layers. Note however that an
intersection between a Plated Metal Line and either a Cap Bottom Line or Thick Metal Line requires crossover rules
since the Plated Metal Line includes the layers used by the Cap Bottom Line and the Thick Metal Line.
The following example shows how the rule is implemented, starting with a figure of the lines with their routes before
the net cleanup is performed.

Assuming there is sufficient space to insert the crossover segments and perform the pullbacks, you can insert the crossover
segment shown in the following figure.
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A feature of the command when working with just two lines is the ability to control by selection order, which line is
selected as the over and under line. Changing the selection order for the lines allows you to control which line gets the
crossover inserted. In this case, the vertical line is selected first and then the horizontal line. If this were reversed, the
crossover is inserted in the horizontal line as shown in the following figure.
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You can insert multiple crossovers if the line crosses a number of other lines, as shown in the following figure.
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If there is sufficient space to insert crossover segments and perform pullbacks, then you can insert multiple crossover
segments as shown in the following figure:

If the lines are too close, you can manually extend one to have two separate crossovers inserted.
Frequently with crossovers, one of the lines needs to be moved to retain connections or to make room for additional
circuitry. If the move is not too significant, you can run the Net Cleanup command again on some routes to try to update
the crossover location.
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After shifting the lines, the crossover bridge is in the wrong location. If you select the two routes again and run the Net
Cleanup command using the Insert crossovers option, the location of the crossover is updated to be at the intersection
between the lines, as shown in the following figure:
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Inserting Crossovers Incrementally
Incrementally adding crossovers provides a mechanism for suppressing the automatic update of existing crossovers when
adding additional crossovers. Crossover updating is a useful feature, however sometimes it is better not to have any of
the existing crossovers updated when attempting to insert additional crossovers. For example, the following figure shows
a scenario where you are attempting to insert multiple crossovers between some lines and you want a specific orientation
for each crossover.

For example, if you want to insert a crossover in the vertical line at the top intersection and a horizontal crossover in the
lower intersection, because these are different orientations, you cannot select all the lines and precisely control the
orientations at the intersections. You need to insert the crossovers by selecting the lines in pairs and running the Net
Cleanup command for each intersection. To perform the insertion at the top intersection, you select the vertical line first
and then the horizontal line, as shown in the following figure:
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Next you run the Net Cleanup command, selecting Insert crossovers. This applies the crossover rules so that the crossover
segment is inserted into the vertical line at the top intersection, as shown in the following figure.
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In the next step you need to select the two lines that form the lower intersection, and because you want the crossover
inserted horizontally, you select the horizontal line first. This may be a problem because the Net Cleanup command only
considers intersections in the lines that are selected to be candidates for crossovers; the update behavior may remove the
top crossover. For this step, you suppress the update behavior by telling the Net Cleanup command to add the crossover
incrementally. Existing crossovers are not disturbed, and only the selected lines are considered for adding new crossovers.
Here you select the lower horizontal line first, the vertical line second, and when running the Net Cleanup command, you
also select the Add Crossovers Incrementally check box, as shown in the following figure:

When you run the Net Cleanup command, the crossover at the top is not disturbed and a new horizontal crossover is added
to the bottom intersection, as shown in the following figure:
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Here the lower crossover is inserted with a horizontal orientation, and the top one with a vertical orientation. This was
accomplished by selecting the lines in pairs in a specific order, and when inserting the second one, by selecting the Add
Crossovers Incrementally check box to suppress the update behavior on the vertical line.

3.7.10. Copying iNets
You can copy and paste routes. Select the routes to copy, choose Edit > Copy (or press Ctrl+C), or choose Edit > Paste (or
press Ctrl+V) and then click where you want to paste the route.
When you paste a route, it belongs to the same iNet as the route from which you copied.
To associate the copied route with a different iNet, you can use either method previously described in “Associating and
Disassociating iNets”:
1. Position each copied route so it overlaps a connection of the new iNet with which you want to associate it, and choose
Layout > Connect Net Shapes to associate all of them.
2. Select a route or rat line from the different iNet, Shift-select the copied route, and then right-click and choose Associate
Net Route.

3.7.11. Simulating with iNets
iNets are included with electrical simulation through the extraction process in the AWR Design Environment platform.
See “EM: Creating EM Structures with Extraction” for details on the extraction process.
The portion of the extraction process specific to iNets is their enablement for extraction. In a schematic, select the wire
for an iNet, right-click and choose Edit Net Properties. In a layout, select any route of the iNet, right-click and choose
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Element Properties. Both of these commands open the Element Options dialog box. Click the Model Options tab and note
the EM Extraction Options section. See “Element Options Dialog Box: (Distributed Line) Model Options Tab” for more

information.
In this dialog box you can enable or disable iNets for extraction and also specify the extraction group to which they
belong.

3.7.12. Additional iNet Commands and Options
The following sections describe additional iNet commands and options.
Net Highlight
Net highlight is a means to easily identify (in both the schematic and layout) all of the objects that exist for a single iNet,
by using different colors to draw schematic wires and iNet routes.
In a schematic, select the wire for an iNet, right-click and choose Highlight On. In a layout, select any route of the iNet,
right-click and choose Highlight On to open a Color dialog box and choose a highlight color.
The following figure shows the iNets in schematic and layout with the highlight color specified as orange.

Turn off the net highlight using the same mouse clicks on a schematic or layout, and choose Highlight Off.
Selecting All iNets
To select all iNets at one level of hierarchy:
1. View the entire layout by right-clicking and choosing View All.
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2. Right-click and choose Restrict Selection.
3. Click the Check All button.
4. Clear the iNets check box.
5. Press Ctrl+A to select the entire layout.
Note that you need to view the entire layout because one of the selection filters is for "Object bounds exceeds view". If
you want to zoom in and then select all, you should deselect this filter and then select all.
Repeat Command
When routing a complex net, the repeat command allows you to continue adding routes to an iNet after you finish a
route. For example, if you route the iNet shown by the rat lines in the following figure,

the finished routing displays as follows:

Without the repeat command, you could add one horizontal route over the squares, then add five vertical routes hooking
up to the horizontal route. For each vertical route, you would need to double-click the rat line to start the route. To route
this example without the repeat command would take 29 mouse clicks.
With the repeat command, once you finish the horizontal route you can immediately start entering the vertical routes.
To route this example using the repeat command takes only 20 mouse clicks.
The repeat command is not available by default, so you must configure it as a hotkey, toolbar item, or menu item. To
configure this command as a toolbar or menu item, see “Customizing Toolbars and Menus”. To configure this command
as a hotkey, choose Tools > Hotkeys to display the Customize dialog box. In Categories, select Miscellaneous and in

3–120 AWR Design Environment

Electrical Net (iNet) Elements
choose CommandRepeatMode. In Press the new hotkeys, press the key or key-combo you want to use as the
hotkey. The following example uses the R key for this command and applies the hotkey to the SchematicLayout group
after you click Assign.
Commands

When you create iNet routes you can invoke this repeat command using the hotkey you set up. To exit repeat mode press
the Esc key.
Colinear Points
iNets can easily connect to many layout pins with one segment. Colinear points refers to three or more points that are
along a single line. For example, you can route the following layout objects with a single segment route.
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Hierarchy
When using iNets in hierarchy, you must define your connection points in the schematic layout you are building. The
best way to do this is to assign the RECT_PIN layout cell to your PORT or PORT_NAME elements, then you can route
iNets to the port. The RECT_PIN layout cell can draw on any of the line types in your process. In the layout, you can
edit the size of this layout cell by selecting the RECT_PIN, right-clicking, and choosing Shape Properties. Click the
Parameters tab of the dialog box that displays.
Verifying Connectivity
Connectivity errors can occur for various reasons, including different iNets being routed across one another on the same
layer, erroneously positioned polygon vertices that short iNets, completed nets or elements accidentally moved to cause
open circuits. See “Connectivity Checking ” for information on how to check for connectivity errors.
Current Density
Since iNets are both schematic and layout objects, the program can easily display the current and/or current density for
each iNet. From your top level design, right-click the schematic name in the Project Browser and choose Add Annotation.
In Measurement Type, choose Annotate and in Measurement, choose INET_I or INET_J. See AWR Microwave Office
Measurement Catalog for setting details. The following figure shows a resistor between two iNets with the current density
annotation turned on. Each iNet segment is 0.5 um wide.

The different colors of the annotation denote if an iNet is below (blue), near (purple), over (red) or extremely over
(yellow) the current density limit set by the annotation. The annotation can also show the width of the iNet needed to
pass the current density limit.
RC Equivalent
If the process you are using is properly configured, you can also display the total resistance and capacitance of each iNet.
In the Project Browser, right-click the name of the schematic that contains iNets and choose Add Annotation to display
the Add Annotation to the Schematic dialog box. In Measurement Type, choose Annotate and in Measurement choose
INET_RC. See “Add/Edit Schematic/System Diagram/EM Structure Annotation Dialog Box ”for more information about
the options in this dialog box. The following figure shows an iNet with this annotation turned on.
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These values are determined through calculations based on the stackup of the process, not from simulation results.

3.8. Routes
The “Electrical Net (iNet) Elements” section covered the details of creating and working with intelligent nets. There is
a corresponding layout object called a route. It is similar in how you add and edit the route, but different in that it is not
associated with a net from the schematic. Routes are layout objects only, and therefore have no electrical model when
added to a schematic layout. You can set up routes with extraction so they can be EM simulated. Additionally, routes
can be added directly in EM layout.

3.8.1. Adding Routes
You can add a route to a schematic or EM layout by choosing Draw > Draw Route. The commands you use are the same
as those used to draw iNets. Click to add a point of the route. Press Shift + Ctrl and scroll the mouse wheel to change the
line type of the current route segment. Right-click to undo the last segment added. Double-click to end adding the route.

3.8.2. Adding Vias
Routes do not add vias between line types automatically, as shown in the following example. This layout is drawn as a
simple route.
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The 3D layout view shows clearly that there is no via between the different segments of the route.
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To add the via, select the route, right-click and choose Add Via. An outline follows the cursor along the route segments.
Cadence recommends adding vias only at the intersections where the line types change. Otherwise, the via can be difficult
to select, because both the start and stop linetypes would be the same.
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Click to place the via in the desired location. After adding the via to the intersection of the two segments, the 3D layout
shows that the segments are connected.
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After adding the via, double-click it to display drag handles that you can use to change its size.
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Additionally, right-click on the via and choose Route Via Properties to display the Via Properties dialog box where you
can specify the size of the via as well as control the line types on each end of the via.

3.8.3. Preparing To Route
The default discontinuities and line widths are identical to using iNet routing. See “Preparing to Route” for details.
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3.9. Placement Mirroring
Placement Mirroring allows mirroring of elements in both schematic and layout. When mirroring elements in a schematic,
select the elements you want to mirror by choosing Edit > Mirror, then click inside the schematic window.
Mirroring of layout elements and iNets requires a vertical or horizontal symmetry line. For mirror placement in layout,
all the layout elements and iNets must have identifiable pairs, and for each pair the corresponding schematic elements'
ID must follow the naming convention. The required element ID naming convention for each pair is deviceName a,
deviceName b. For example, in the following figure, one nmos is assigned ID=M1a and the other nmos is assigned
ID=M1b. Similarly, one pmos is assigned ID=M2a and the other pmos is assigned ID=M2b. The ID must be unique to
each pair and cannot be used more than once.
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After the pair is identified, draw a symmetry line in the layout window by choosing Draw > Symmetry Line.
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Select the mirror devices, iNets, and symmetry line, and choose Edit > Mirror Placement. The mirror pair along with the
iNet is placed as shown in the following figure.
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3.10. Shape/Layer Modifiers
Shape modifiers are layout objects that can manipulate shapes by various methods such as edge length, spacing, and
Boolean operations. A shape modifier applies to one or more shapes in a layout. A layer modifier applies to all shapes
on the selected layers. Typical applications for these modifiers include:
• Parameterizing an EM layout so the geometry can be swept to create a parameterized EM model (reference section)
or parameterized EM layout such that when used in a subcircuit, it gets EM simulation for geometries requested
(reference section). In this mode, these modifiers are used in EM layout. See “Parameterizing EM Structures” for
details on parameterizing EM structures.
• Changing all shapes on specific layers that can be used with extraction and yield analysis to study effects of layers
shifting or resizing during the manufacturing processes. In this mode, these modifiers are used in schematic layout.
See “Extraction and Shape/Layer Modifiers” for more information
• Aligning or spacing shapes in a schematic layout when using layout items not associated with schematic models, which
cannot snap together like layouts with schematic models.
• Layer modifiers do not affect the layout of 3D parts such as bondwires.
NOTE: While shape modifiers act immediately on the layout they are operating on, to see the effects of layer modifiers
you need to place the document in hierarchy and view it from the top level. If it is an EM layout, the geometry preview
also shows the effects of the layer modifiers.
The available shape modifiers include:
• Edge
• Point Stretch
• Width
• Radius
• Ellipse Size
• Array Modifier
• Spacing Modifier
• Polar Spacing Modifier
• Stretch Area Modifier
• Control Point Modifier
The available layer modifiers include:
• Layer Offset
• Layer Resize
• Layer Boolean
• Layer Corner
• Shape Pre-processing
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3.10.1. Adding Modifiers
From an EM layout or a schematic layout, choose Draw > Parameterized Modifiers > <type>. The enabled modifiers depend
on the type(s) of layout object(s) currently selected. Shape modifiers are not available in the Artwork Cell Editor. The
following sections provide detailed information about each modifier.
The layout for the shape/layer modifiers uses the Dimension line layer for the shape and the text.
The default modifier size and font size are determined by the Height specified on the Layout Options dialog box Layout
Font tab (choose Options > Layout Options). See “Layout Options Dialog Box: Layout Font Tab ” for details.
Edge Modifier
To add an Edge modifier:
1. Select one or more shapes in your layout and choose Draw > Parameterized Modifiers > Edge Length.
2. Move the cursor over the edge of any selected shape. The modifier displays on the edge closest to the cursor position.
You can only add this modifier to shapes not associated with a schematic element. For example, if you have an MLIN
in a schematic, you cannot add this modifier to the layout for this element.
3. Click to add the modifier to that edge.
4. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

The edge of the modifier that draws a square is the end that remains fixed if the edge length changes.
5. Right-click the modifier (not the modifier text) and choose Shape Properties to display the Properties dialog box (see
“Properties Dialog Box: Edge Modifier ” for details).
6. Change the FE (Fixed End) parameter to "Left", "Right", or "Center".
Point Stretch Modifier
To add a Point Stretch modifier:
1. Select one or more shapes in your layout and choose Draw > Parameterized Modifiers > Point Stretch .
2. Move the cursor over the edge of any selected shape. The modifier displays on the edge closest to the cursor position.
You can only add this modifier to shapes not associated with a schematic element. For example, if you have an MLIN
in a schematic, you cannot add this modifier to the layout for this element.
3. Click to add the modifier to that edge.
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4. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

The edge of the modifier that draws a square is the end that remains fixed if the spacing changes.
5. Right-click the modifier (not the modifier text) and choose Shape Properties to display the Properties dialog box (see
“Properties Dialog Box: Point Stretch Modifier ” for details).
6. Change the FE (Fixed End) parameter to "Left", "Right", or "Center".
Width Modifier
To add a Width modifier:
1. Select one or more paths or iNets in your layout and choose Draw > Parameterized Modifiers > Path Width .
2. Move the cursor over any of the selected paths or iNets. The modifier displays at the location closest to the cursor
position.
3. Click to add the modifier to that location of the path.
4. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

When adding a path modifier to an iNet, you can control the width of each individual segment.
5. Right-click the modifier (not the modifier text) and choose Shape Properties to display the Properties dialog box (see
“Properties Dialog Box: Width Modifier ” for details).
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6. Change the WT (Width Type) parameter to "Segment". If each modifier on an iNet is set to "Segment", then you can
specify different widths. If any path modifiers are set to "Path", then all modifiers use the width of that modifier. The
following figure shows a multi-segment iNet with different widths.

Radius Modifier
To add a Radius modifier:
1. Select one or more perfect circles in your layout and choose Draw > Parameterized Modifiers > Circle Radius .
2. Move the cursor over any of the selected circles. The modifier displays at the location closest to the cursor position.
3. Click to add the modifier to that circle.
4. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

See “Properties Dialog Box: Radius Modifier ” for details on the settings for this shape modifier.
Ellipse Size Modifier
To add an Ellipse Size modifier:
1. Select one or more ellipses in your layout and choose Draw > Parameterized Modifiers > Ellipse Size.
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2. Move the cursor over any of the selected ellipses. The modifier displays at the location closest to the cursor position.
3. Click to add the modifier to that ellipse.
4. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

See “Properties Dialog Box: Ellipse Size Modifier ” for details on the settings for this shape modifier.
Array Modifier
To add an Array modifier:
1. Select one or more shapes in your layout and choose Draw > Parameterized Modifiers > Array Modifier.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes, and the text displays above the modifier.

See “Properties Dialog Box: Array Modifier ” for details on the settings for this shape modifier.
Spacing Modifier
To add a Spacing modifier:
1. Select two or more shapes in your layout and choose Draw > Parameterized Modifiers > Spacing Modifier.
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2. Move the cursor over any of the selected shapes. The modifier displays at the location closest to the cursor position.
3. Click to add the first point of the spacing modifier.
4. Move the cursor over another of the selected shapes. The modifier displays at the location closest to the cursor position.
By default the modifier draws in orthogonal mode and the furthest distance (x or y). Press the Ctrl key to toggle from
horizontal to vertical or vertical to horizontal, and the Shift key to allow any angle.
5. Click to add the second point of the spacing modifier.
6. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

The edge of the modifier that draws a square is the end that remains fixed if the spacing changes.
7. Right-click the modifier (not the modifier text) and choose Shape Properties to display the Properties dialog box (see
“Properties Dialog Box: Spacing Modifier ” for details).
8. Change the FE (Fixed End) parameter to "Left", "Right", or "Center".
Polar Spacing Modifier
To add a Polar Spacing modifier:
1. Select two or more shapes in your layout and choose Draw > Parameterized Modifiers > Polar Spacing Modifier.
2. Move the cursor over any of the selected shapes. The modifier displays at the location closest to the cursor position.
3. Click to add the first point of the spacing modifier.
4. Move the cursor over another of the selected shapes. The modifier displays at the location closest to the cursor position.
5. Click to add the second point of the spacing modifier.
6. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.
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The edge of the modifier that draws an angle indicator is the end that remains fixed if the spacing or angle parameter
change.
7. Right-click the modifier (not the modifier text) and choose Shape Properties to display the Properties dialog box (see
“Properties Dialog Box: Polar Spacing Modifier ” for details).
Stretch Area Modifier
To add a Stretch Area modifier:
1. Choose Draw > Parameterized Modifiers > Stretch Area.
2. Click on the layout to draw a polygon, one click per point. Double-click to finish drawing the polygon.
3. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

See “Properties Dialog Box: Stretch Area Modifier ” for details on the settings for this shape modifier.
Control Point Modifier
To add a Control Point modifier:
1. Choose Draw > Parameterized Modifiers > Control Point .
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2. Click on the layout to draw a polygon, one click per point. Double-click to finish drawing the polygon.
3. Move the cursor to the initial location of the text and click again to finish adding the modifier, as shown in the following
figure.

See “Properties Dialog Box: Control Point Modifier ” for details on the settings for this shape modifier.
Layer Offset Modifier
To add a Layer Offset modifier:
1. Choose Draw > Parameterized Modifiers > Layer Offset.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes, and the text displays above the modifier.

See “Properties Dialog Box: Layer Offset Modifier ” for details on the settings for this shape modifier.
Layer Resize Modifier
To add a Layer Resize modifier:
1. Choose Draw > Parameterized Modifiers > Layer Resize.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes and the text displays above the modifier.
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See “Properties Dialog Box: Layer Resize Modifier ” for details on the settings for this shape modifier.
Layer Boolean Modifier
To add a Layer Boolean modifier:
1. Choose Draw > Parameterized Modifiers > Layer Boolean.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes and the text displays above the modifier.

See “Properties Dialog Box: Layer Boolean Modifier ” for details on the settings for this shape modifier.
Layer Corner Modifier
To add a Layer Corner modifier:
1. Choose Draw > Parameterized Modifiers > Layer Corner.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes and the text displays above the modifier.
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See “Properties Dialog Box: Layer Corner Modifier ” for details on the settings for this shape modifier.
Shape Preprocessor (SPP) Modifier
To add an SPP modifier:
1. Choose Draw > Parameterized Modifiers > Shape Preprocessor.
2. Click to add the modifier to any location in the layout, as shown in the following figure. This modifier does not snap
to any shapes and the text displays above the modifier.

See “Properties Dialog Box: Shape Preprocessor (SPP) Modifier ” for details on the settings for this shape modifier.

3.10.2. Layout Modifier Order
The order in which layout modifiers operate can change how a structure's parameterization is performed. Each modifier
type has a given priority as well as an order. In general, the order is determined by the order in which you add the
modifiers, and the priority of the modifier. You can modify the order of operation in the Modifier Properties dialog box
by choosing Layout > Modifier Properties. See “Modifier Properties Dialog Box: Shape Modifiers tab ” for dialog box
details. You should only re-order modifiers within a given priority. Moving a lower priority modifier above a higher
priority modifier may lead to an incorrect layout and prompt a warning message to display.
Layout modifiers are categorized by three priorities, listed as follows from high to low priority.
• Priority 1: Simple shape modifiers (Edge, Width, Circle Radius, Ellipse Size, Array, Spacing)
• Priority 2: Shape Modification modifiers (Stretch Area)
• Priority 3: Global Layer Modifiers (Layer Offset, Layer Resize, Layer Boolean)
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You should always order Priority 1 modifiers before priority 2 modifiers. Priority 3 modifiers are always applied last
because priority 2 and priority 3 modifiers flatten shapes. Once a shape is flattened, priority 1 modifiers may not have a
shape on which to operate. For example, if the Stretch Area modifier is applied to a path before a Width modifier, the
path is flattened into a polygon, so it no longer exists for the Width modifier to operate on.

3.10.3. Editing Modifiers
You can edit individual modifiers just as you do model parameters. You can set up each parameter for optimization and
yield analysis, and set values to variables. For individual modifier details, see “Adding Modifiers”.
To enable or disable a single modifier, right-click the modifier and choose Toggle Enable. To change the enable state of
several modifiers at once you can select or clear the Enabled column check box for each in the Modifier Properties dialog
box (choose Layout > Modifier Properties). See “Modifier Properties Dialog Box: Shape Modifiers tab ” for dialog box
details.
Click and drag a modifier to move it in a schematic. Moving modifiers that are attached to shapes may not be desirable.
You can right-click an edge modifier and choose Snap to Shapes to move the modifier back to its associated shape.

3.10.4. Debugging Modifiers
You can identify which shapes belong to a modifier in a layout. Attributes of the shapes that are directly connected to
the modifier (such as a shape, a vertex, or an edge) display in light blue, and any additional associated shapes are outlined
in a dotted green shape. The following figure shows a simple Spacing modifier with the modifier selected.

The text and arrows of the modifier are yellow because they are selected. The vertices of the two shapes that are being
spaced display with a light blue square, and the remaining shapes being spaced are outlined in a dotted green shape.
When building up a parameterized layout, you will want to view the results of the modifiers. All of the shape modifiers
directly change the layout except the Stretch Area modifier. None of the layer modifiers directly change the layout. For
the shape modifiers and the Stretch Area modifiers, you need to use another technique to see the effects of the modifiers.
If you are working in an EM layout, right-click the EM document and choose Preview Geometry to see the modified
geometry. If you are working in a schematic layout, you should use the schematic you are working on as a subcircuit in
another schematic, then view the layout for the schematic that is using the parameterized layout through hierarchy.
When a parameterized subcircuit schematic or EM document utilizes many modifiers, it can be difficult to understand
the interactions between the modifiers. To see the effects of each modifier one by one, select the subcircuit instance in
the Layout editor, right-click and choose Debug Modified Cell Instance to display the Debug Cell Instance dialog box. See
“Debug Cell Instance Dialog Box” for details on using the interactive debugger.
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3.11. Via Fill and Via Fence
The Via Fill feature provides support for via stitching in a layout design. Via stitching is used to tie together layers in
specific areas with a large number of vias arranged in a grid to provide a strong vertical connection between layers. The
Via Fencing feature allows the creation of lines of vias to separate different regions and provide isolation between parts
of the design.

3.11.1. Setting Up the Via Fill/Fence Operation
To use the Via Fill and Via Fencing features you must include a cell library that defines the via cells to use in the Fill or
Fence operation. For information on importing a cell library, see “Loading Artwork Cell Libraries”. For information on
creating a cell library, see “Creating Artwork Cell Libraries”.

3.11.2. Via Fill
After you import the via cells you can begin using the Via Fill operation to add vias to shapes in layout designs. Open a
design that contains the regions you want to fill. To perform the operation you must first define the region to fill by
creating a polygon that covers the region. For many designs this region may already exist. To fill a region in the layout,
select the polygon(s) to fill with vias and choose Draw > Add Shapes > Via Fill to display the Via Fill dialog box used for
defining the fill.
Running the Via Fill Operation
Select the shapes to fill and then choose Draw > Add Shapes > Via Fill to open the Via Fill dialog box. For more information
on Via Fill options, see “Via Fill Dialog Box ”.
After specifying spacing, offset, and clearance values, click OK to fill the regions with the selected via cell.
If the resulting fill pattern is not what you want, you can Undo (press Ctrl + Z) the operation and remove the inserted vias.
Next, reselect the polygon and restart the Via Fill command by choosing Draw > Add Shapes > Via Fill. The Via Fill dialog
box remembers all the settings, allowing you to adjust the values for a more favorable outcome.
Via Fill Presets
You can use process defaults or presets for the Via Fill command. By adding entries to the Layer Process File (LPF),
you can establish default settings for Via Fill operations so that the spacing values are auto-filled with values that are
correct for a particular process. If the process file has these entries, you can enter standard Via Fill settings in the Via
Fill dialog box by selecting one entry in the Process Defaults drop-down list.
For Via Fill, the entries in the LPF are defined as follows:
!--- Via Fill Entries Process Presets ---$VIA_FILL_ENTRIES_BEGIN
<Entry Name> <Lib Name> <Cell Name> <Spacing Type> <Spacing X> <Spacing Y> <Offset X>
<Offset Y> <Clearance> <Stagger>
$VIA_FILL_ENTRIES_END

An example entry would be as follows:
!--- Via Fill Entries Process Presets ---$VIA_FILL_ENTRIES_BEGIN
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"Via1" "ViaLib"
0

"ViaCell"

0

15e-6

"Via2"

"ViaCell2"

0

10e-6 10e-6

"ViaLib2"
0

15e-6

0.0

0.0

0.0

5e-6

0.0

15e-6

$VIA_FILL_ENTRIES_END

After the LPF with the Via Fill entries is imported into the project, the settings are available for use in the Via Fill dialog
box.

3.11.3. Via Fence
After you import the via cells you can begin using the Via Fence operation to add vias to shapes in layout designs. Open
a design that contains the regions you want to fill. To perform the operation you must first define the region to fill by
creating a polygon that covers the region. For many designs this region may already exist. To fence a region in the layout,
select the polygon(s) to fill with vias and choose Draw > Add Shapes > Via Fence to display the Via Fence dialog box used
for defining the fence.
Running the Via Fence Operation
Select the shapes to fence and then choose Draw> Add Shapes > Via Fence to open the Via Fence dialog box. For more
information on Via Fence options, see “Via Fence Dialog Box ”.
After the Via Fence settings are correct, click OK to fence the shape with the selected via cell.
If the resulting fence pattern is not what you want, you can Undo (press Ctrl + Z) the operation and remove the inserted
vias. Next, reselect the polygon and restart the Via Fence command by choosing Draw > Add Shapes > Via Fence. The Via
Fence dialog box remembers all the settings, allowing you to adjust the values for a more favorable outcome.
Via Fence Presets
Like Via Fill, Via Fence can use process defaults or presets specified in the LPF. By adding entries to the LPF, you can
establish default settings for Via Fence operations so that the fence option values are auto-filled with values that are
correct for a particular process. If the process file has these entries, you can enter standard Via Fence settings into the
Via Fence dialog box by selecting one entry in the top Process Defaults drop-down list.
For Via Fence, the entries in the LPF are defined as follows:
!--- Via Fence Entries Process Presets ---$VIA_FENCE_ENTRIES_BEGIN
<Entry Name> <Lib Name> <Cell Name> Spacing Type> <Spacing> <Offset X> <Offset Y>
<Merge Perimeters> <Perimeter Oversize> <Open Ends>
$VIA_FENCE_ENTRIES_END

An example entry would be as follows:
!--- Via Fence Entries Process Presets ---$VIA_FENCE_ENTRIES_BEGIN
"Via1" "ViaLib"
0.0
1

"ViaCell"

0

15e-6

0.0

0.0

0
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"Via2"
0.0

"ViaLib2"
1

"ViaCell2"

0

10e-6

0.0

0.0

0

$VIA_FENCE_ENTRIES_END

After the LPF with the Via Fence entries is imported into the project, the settings are available for use in the Via Fence
dialog box.

3.12. Artwork Cells
Artwork cells are layout cells that read in as standard CAD drawing cells or are created from scratch using the Artwork
Cell Editor. Microwave Office software can read in GDSII-based or DXF-based drawing cells. The GDSII- and DXF-based
layout cells are stored as native GDSII or DXF, so any layout cells created in the Microwave Office program can be read
and edited in any layout software that supports GDSII or DXF.

An artwork cell needs to have connection points defined that correspond to the nodes of the electrical component. These
connection points are called "faces" in Microwave Office software. The orientation of the face is used to determine to
which side of the face adjacent layout cells snap.
To draw an artwork cell with new layers you must first add the drawing layers and the model layer mapping (see “Drawing
Layers and Model Layer Mapping”). To use the layers in GDSII artwork cells, make sure you use proper GDSII layer
convention (see“Drawing Layers and Model Layer Mapping”).

3.12.1. Editing Artwork Cells

You can edit artwork cells by double-clicking the artwork cell in the upper pane of the Layout Manager. The artwork
cell opens in the Artwork Cell Editor. You can use the Cell Port tool to add a face to the cell by choosing Draw > Cell Port
or by clicking the Cell Port button on the Draw Tools toolbar. You can snap a cell port to a polygon edge by pressing the
Ctrl key while placing the port. You can create artwork cells with multiple faces for each connection point by assigning
the same port number to two or more faces in the Artwork Cell Editor. To change the port numbers, select the cell port
in the editor, right-click, and choose Shape Properties. The Properties dialog box displays with a Cell Port tab and allows
you to enter the Port Number and port Connection Type.
You must ensure that there is at least one port for each consecutive number starting from 1. For example, it is not valid
to have a port 1 and a port 3 without having a port 2. For more information, see “Face and Snap to”.
If you make any edits to the artwork cell, you must save the cell into the library before any of the references to the layout
cell are updated in the project. Unsaved edits are lost when you close the project. Choose Layout > Update Cell Edits to
save modified artwork cells.

3–144 AWR Design Environment

Artwork Cells
Creating an Area Pin
Cell ports allow connections only along a linear face and over a specified area. To create an area pin, select a structure
in the Artwork Cell Editor and choose Draw > Create Pin. The entire area of the shape selected becomes the area pin. You
can also choose Draw > Cell Pin to free-hand draw the area for a pin. The pin has a default side for connections shown by
the arrow of the pin. To move the location of the default side of the area pin, double-click the area pin and click on the
drag handle on the tip of the default side arrow to drag it to the desired default side.

3.12.2. Stretching Artwork Cells

The Cell Stretcher allows you to create parameterized cells graphically by stretching cells instead of creating them by
programming in C++.
To access Cell Stretcher properties, double-click a cell in the GDS library to display it, then click the Cell Stretcher button
on the Draw Tools toolbar or choose Draw > Cell Stretcher. Draw a horizontal or vertical break line at the point you want
to stretch the cell, then click to set the line. Select the line and then right-click to display the Properties dialog box.
In the Layout Options dialog box on the Gds Cell Stretcher tab, you can specify the Multiplier, the Parameter in the element
to which the manipulated cell connects, and the Offset value to create an equation that solves for the distance the Delta
point moves in the specified Direction. You can also specify the Minimum and Maximum distances a point may move and
the Arrow height of the displayed arrow. The parameter property is the name of the element's electrical parameter used
in the stretching equation. For example, the parameter for a resistor is R, a capacitor C, or the electrical length of an ideal
transmission line EL.
Consider a resistor whose length is varied to adjust the resistance. The general relation for the resistance of a thin-film
resistor is

(3.1)

R=RsL/W

where Rs is the resistance in ohms per square, L is the length, and W is the width. For a stretched resistor, this is simply

(3.2)

R=Rs(ΔL+L0)/W

where L0 is the unstretched length and ΔL is the extension. You need ΔL, however, as a function of resistance, R; this
is easily determined from the above equation:

(3.3)

ΔL=(W/Rs)R-L0

The Multiplier value is W/Rs and the Offset value is L0. If both sides are stretched (Both is the Direction), this value of ΔL
is applied to both halves of the stretched cell. Thus, the values entered for the multiplier and offset should be halved.
Note that quantities in the above equations must use MKS units, in this case meters and ohms. If a capacitor is stretched,
the units are meters and Farads. Also, the cell must be associated with a specific circuit element in either a circuit or a
library for the Cell Stretcher to work.

3.12.3. Saving Artwork Cells
Saving the project or closing the artwork cell window prompts you to save the artwork cell.
When saving GDSII cell library edits, the GDSII file is saved directly using the GDSII layers used in the artwork cell
library.
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When saving DXF cell library edits, the DXF file is saved through the first DXF export mapping table defined in the
software. See “Exporting the Layout ” for more information. If you do not have a DXF export mapping table defined,
an "Unable to find export mapping" error message displays.
To correct this, add a DXF export mapping table, ensure all of the layers are selected for Write Layer, and then save the
cell edits again.
Generally, you only need to add a DXF export mapping table. There are special cases where you may be using special
model layer names (see “Drawing Layers and Model Layer Mapping” for more information). In this case, when you add
a DXF export mapping table, you must set up the Drawing Layers used to display the layers in the DXF artwork cell to
export to the right model layer names (the same model layers used in the artwork cell), or the cell updates do not work
correctly.

3.12.4. Flattening Parameterized Layout Cells
The Cell Flattening feature allows you to flatten a parameterized layout cell to access and change it at the polygon level.
You can use this feature to change a single instance of a library cell or make minor changes to an existing cell without
recreating it entirely.
To flatten a cell, in the Layout View, select a cell and choose Draw > Modify Shapes > Flatten Shape. Select the shape you
want to alter and then change its properties, position, or dimensions.

3.12.5. Creating Artwork Cell Libraries
You can create artwork cell libraries in a project by selecting the Cell Libraries node in the upper pane of the Layout
Manager, right-clicking, and choosing New Cell Library and the desired library type in the New Cell Library dialog box.
After you create a library you can create a new artwork cell by right-clicking the library in the Layout Manager and
choosing New Layout Cell. The artwork cell name must be unique across all of the libraries open in the project.
You can also create a new layout cell by copying an existing artwork cell. Right-click the artwork cell and choose Copy
Layout Cell to display the Copy Cell dialog box. If the cell is hierarchical you can choose Copy Hierarchy or Flatten new
cell. Specify the Library name to which you want to copy the cell.

3.12.6. Saving Artwork Cell Libraries
You can save an artwork cell library as a GDSII file by right-clicking the library in the upper pane of the Layout Manager
and choosing Export Cell Library. If there are any cell references in the library that reference cells from other libraries,
these cells are not written out from the library.
GDSII libraries are saved directly to the GDSII model layer names used in the artwork cell library.
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There are a couple of different ways to save a DXF library. If there is a DXF export mapping table defined, the layers
are exported to the DXF layer name in the mapping table whether the Write Layer field is selected or not. If more than
one DXF table is defined, the software uses only the first one. If there is no DXF export mapping table defined, the layers
are written to the drawing layers used to display the layers in the artwork cell.

3.12.7. Loading Artwork Cell Libraries
You can import artwork cell libraries from a GDSII file or DXF file (DXF libraries can only contain one layout cell per
library) by selecting the Cell Libraries node in the upper pane of the Layout Manager window, right-clicking, and choosing
Import Cell Library. You can also link to the libraries by choosing Link To Cell Library. When the library is linked, any
changes made to cells are saved in the original location of the library. For imported libraries, the changes made to cells
are saved in the project only, unless the library is exported. After you load a library, you can add new artwork cells to it
by right-clicking the library in the Layout Manager and choosing New Layout Cell.
Typically, layout cells for parameterized electrical elements are created from the element's electrical parameters (a
microstrip's length and width determine the layout of the element). It is possible to set the layout for a non-parameterized
element (for example, a capacitor) to have a layout representation of a parameterized cell (for example, a microstrip
layout representation). In this case, there is missing information in the electrical element's parameters to create the layout
cell (the capacitor only has a capacitance value as its electrical parameter, therefore the layout cell does not have the
length and width parameters needed to draw the layout). When this occurs, the length and width of the layout cell become
a property of the layout cell. You can view and edit the value of the layout cell parameters on the Parameters tab of the
Cell Properties dialog box by selecting the layout cell in the Layout View and choosing Layout > Edit Shape Properties,
or right-clicking the layout cell and choosing Shape Properties.
When importing a GDSII or DXF library, the following message may display. This warning commonly displays when
placing a part from a vendor library into a schematic.
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It indicates that the project does not have corresponding drawing layer names for the layer names in the file, so the
program automatically creates these drawing layers. Click OK to accept this auto-generation.

3.12.8. Assigning Artwork Cells to Layout of Schematic Elements
Artwork cells are created to give a user-specified layout to any element. After an artwork cell is created and its cell ports
are attached, you can assign it to an electrical element. You can change the layout for any element by right-clicking the
element in the schematic window and choosing Properties. Click the Layout tab on the Element Options dialog box and
select the library name in Library Name. A list of all available layout cells with the same number of ports as the specified
Number of nodes displays. Clicking on one of the available cells shows a preview of the layout. A compatible cell with
an "*" at the end of its name specifies a layout cell built into Microwave Office software.
After disassociating a layout cell with an element in a schematic's layout (right-click the cell in the layout and choose
Disassociate Cell) you can re-associate the cell with the same or another element in the schematic by right-clicking the
cell in the layout and choosing Associate Cell. The “Associate Cell Dialog Box ” displays with a list of the elements in
the schematic that are not associated and that have the correct number of ports to be associated with the cell. After
selecting the desired element, click OK. The color of the element in the schematic changes from blue to purple to indicate
that it has an associated layout cell.

3.13. Layout Cell Properties
Circuit components that are connected in the schematic are connected in the Layout View. The schematic connectivity
controls the connectivity in the layout. All new circuit components or connections must be added in the Schematic View.
Circuit components that do not have layout cells result in disconnected layout objects as shown in the following figure.
When you move layout objects, the connections to other layout objects are shown as connection lines between the objects.
To "snap" the shapes together (eliminate the connection lines by moving the shapes) choose Edit > Snap Objects > Snap
Together or click the Snap Together button on the toolbar. Snap Together snaps together all selected objects and objects
that are connected to them.
The Microwave Office layout tool provides options to specify what each layout cell looks like and how cells connect
together. These options are stored in the properties of each layout cell. The properties are edited by selecting the layout
cell in the layout window and choosing Layout > Edit Shape Properties or by right-clicking on the layout cell and choosing
Shape Properties to display the “Cell Options Dialog Box: Layout Tab ”.
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3.13.1. Cell Options
The Cell Options dialog box Layout tab allows you to configure how parameterized cells are drawn, the orientation of
every layout cell, and how layout cells interact spatially with other layout cells. You can also create user-defined
parameterized cells which support configuration from the LPF files. The following sections provide details about the
options available in the “Cell Options Dialog Box: Layout Tab ”.
Line Type
When layout cells have configurable layers, you can specify the line type. Each of the line types created in the LPF file
are available options. Selecting the line type for the layout cell causes the cell to use that line type when drawing the
cell.
• Configurable layers: The configurable cells support multi-layer processes (such as when a transmission line is created
from two layers of metal with an etch layer between the metal layers).
• Multi-layer layout cell definition: The following example is for a multi-layer transmission line. The W and L dimensions
represent the width and length of the transmission line that is used to model the electrical behavior of the component.
Any shapes that are drawn larger or smaller than the L x W transmission line are for layout only and do not affect the
electrical simulation.
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• Multiple line type definition: The LPF file allows the definition of multiple line types. A line type describes the layers
used for a single transmission line. For example, a plated metal line that requires two metal layers and an etch layer
can be configured as a line type in the LPF file. The following shows an LPF entry for four different line types:
$LINE_TYPE_BEGIN "Plated Line"
!Name is to identify the line
!Layer
Layer_offset minWidth
"Metal1"
0
2e-6
"Via2"
-0.5e-6
3e-6
"Metal2"
0.5e-6
2e-6
$LINE_TYPE_END

flags
0 0
0 0
0 0

$LINE_TYPE_BEGIN "Metal0 Line"
"Metal0"
0
2e-6
$LINE_TYPE_END

0

0

$LINE_TYPE_BEGIN "Metal1 Line"
"Metal1"
0
2e-6
$LINE_TYPE_END

0

0

$LINE_TYPE_BEGIN "Metal2 Line"
"Metal2"
0
2e-6
$LINE_TYPE_END

0

0

"Layer" is the name of the model layer. "Layer_offset" is the offset used for drawing the layer as shown previously. The
"minWidth" value is used for checking design rule violations. The flags can be used to pass specialized information to
the layout cells.
The previous LPF file defines four different types of lines (Plated, Metal0, Metal1 and Metal 2). A configurable cell
(such as a microstrip line cell) can select which line type is used to draw the cell in the layout. If the "Plated Line" type
is selected, then the microstrip line is drawn using three layers (Metal1, Via2 and Metal2) where Via2 is drawn inset by
0.5um and Metal2 is drawn outset by 0.5um. If the "Metal0 Line" type is selected, the line draws on a single layer
(Metal0). The following figure shows a plated line.

The multi-layer layout cells are designed to interlock so that the shapes on each layer join correctly. The following figure
shows a layout cell for a microstrip tee. The tee on the top is pulled apart to show how the interlocked cells are drawn.

Line Type Definitions

Line type definitions are automatically linked with an identically named substrate definition element (for example,
MSUB). When the line type of an element is changed, its MSUB in the schematic automatically updates to the linked
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MSUB. When an element's MSUB parameter changes, if the name of the MSUB element is identical to the line type
name defined in the LPF, the element layout is automatically updated to the linked line type. Since MSUB names cannot
include spaces, you cannot link to a substrate a line type that has spaces in its name. To use existing line types with spaces
in their names, you must export the LPF, edit it to change the line type names (remove or replace the spaces and match
the substrate names), and import it again. NOTE: Do not change the order of the line types when modifying the LPF of
an existing project. Older projects do not change automatically. When you open a project older than v12, elements retain
their MSUB and line type, even if they are mismatched, and matching versions are available. The change occurs when
an element's substrate or line type is changed.
Layer Mapping
Layer mapping lists all of the mapping tables available for the layout cell to use. The available layer mappings are read
from the LPF file or added from the drawing layer Options dialog box (choose Options > Drawing Layers). For more
information on layer mapping, see “Drawing Layers and Model Layer Mapping”.
Flip Cell
You can flip cells about the horizontal axis by selecting the Flipped check box.
Orientation Angle
You can set the rotation of a cell by specifying the Angle in degrees. You can also change the orientation angle by rotating
the cell with the mouse, however when doing so only angles allowed by the current rotation snap are allowed. When
entering the rotation angle manually, the rotation snap is overridden.
Freeze Position
You can freeze the cell position to prevent it from being moved with the mouse or by coordinate entry. Frozen cells, like
anchored cells, do not move when the layout is snapped together, but are editable when you double-click them. Frozen
cells exhibit a weaker form of snapping than other cells, which leads to somewhat different behaviors than anchored
cells. With anchored cells, adjacent layout cells attempt to re-adjust so that they snap to the anchored cell. With frozen
cells, the adjacent cells do not always try to snap to the frozen cell when the layout is snapped together. To make another
layout cell snap to a frozen cell, try selecting the frozen cell and then snap the layout together. There can be multiple
frozen cells within a layout.
Use For Anchor
You can "anchor" one cell within a layout. The anchored cell stays in a fixed location, and all other cells adjust themselves
accordingly when circuit parameters are changed and objects are resized. You can anchor multiple objects per schematic.
Each anchored object stays in a fixed position when the layout is snapped together. Unlike the Freeze operation, you can
move anchored cells with the mouse (or with coordinate entry). Selecting both the Use for anchor and Freeze check boxes
causes the cell to be used as an unmovable anchored cell. Only the anchored layout objects at the top level of a hierarchy
are used to anchor the layout cells.
Stretch to Fit
You can use this option with LINE elements (for example, MLIN and SLIN), the TRACE elements (for example MTRACE
or MCTRACE), and iNets to automatically stretch the elements to fit between two other cells when the layout is snapped
together.

AWR Microwave Office Layout Guide 3–151

Layout Cell Properties

3.13.2. Face Properties
The connections between the layout cells in the Layout View are defined by faces. A layout cell face is a line segment
that defines how other cells should connect to the cell when they are snapped together.
The Cell Options dialog box Faces tab allows you to configure how faces of layout cells snap together (including
multi-layer layout cells), assign layout face connectivity for cells that have multiple layout faces, and specify offsets
when faces connect together. This section provides details about the options available in the “Cell Options Dialog Box:
Faces Tab ”.
The following figure shows the faces for two simple transmission lines. When the two layout shapes are snapped together,
the centers of the two faces coincide.

The layout cell faces have properties you can set to specify how the faces connect to each other. The default is for all
faces to connect "center to center". Other options include top- or bottom-justified connections. The following figure
shows two transmission lines snapped together with the face properties set to "top" justification.

The "variable" justification setting allows elements to connect anywhere along the face (rather than the center, top,
bottom, or specified offset from center). If any part of this face overlaps the adjacent face, the elements are considered
connected. You can specify all face settings as "variable" by default by selecting Variable alignment as the Default Face
Justification on the Layout tab of the Environment Options dialog box. Note that this setting only applies to elements
placed in a schematic after this setting is made.
Face and Snap to
For most layout cells, there is a connection face for each node of the electrical component with which the cell is associated.
Layout cells can also be created with multiple physical connection points (faces) for a single electrical node by adding
additional faces using the same node number for more than one face. For multiple faces with the same node number, the
first face added is the default connection point. The following schematic illustrates multiple faces using a single node.
Transmission line TL1 and transmission line TL2 are both connected to the FET node 3.
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As shown in the following figure, an artwork cell is used for the layout cell of the FET in this schematic. The layout cell
for the FET has four faces that correspond to three nodes. You can modify the layout face node numbers by selecting an
element connected to that node, right-clicking, and choosing Shape Properties. The Properties dialog box displays with
a Cell Port tab and allows you to enter the Port Number and port Connection Type. The node numbers are shown on the
face objects in the following figure.
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The Layout View for the FET schematic is shown in the following figure. The transmission lines connected to the FET
are pulled away from the FET to make the connections easier to see. When there is more than one face for a node, the
face is identified in the Cell Property dialog box using a letter after the number. For the FET example, there is a face 3a
and a face 3b. The transmission line TL1 is connected to face 3a and transmission line TL2 is connected to 3b.
When there are three items connected to a single node as shown (and there are two layout faces for one of the nodes)
then there are several different possible connections that can be made between the connected layout cells. In the example
shown, either transmission line could be connected to either face, or the two transmission lines could have their faces
connected to each other. Since it is generally impossible to detect what the correct connection should be, you must specify
the desired connection using the Snap to operation on the Faces tab of the Cell Options dialog box (unless the default
gives the desired connection). Snap to is used to specify which face snaps to which other face. You first select in Face
the face for which you want to set properties. The selected face displays in blue in the layout window. After selecting
the desired face, you select a Snap to face. The Snap to face displays in red in the layout window. You should do this for
both faces with the same node number. In the following example the face on TL1 is snapped to 3a and 3b is snapped to
TL2.

An alternate method of element connection is to just move the elements around in layout and allow the software to find
the closest face connection. To disable this ability you can clear the Default connection to closest face check box in the
Layout Options dialog box. Instead of completing all of the face assignments as previously described, you could move
TL1 and TL2 to opposite sides of the device artwork to allow the connection points to be automatically determined.
Cells that have multiple faces with the same node number are also used to provide alternate connection points for a layout
cell. An example for a thin film capacitor is shown in the following figure. Node 1 has faces 1a and 1b that can be used
as connection points.
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Snap To Adjacent
This feature enables the snapping feature for the connected faces. When the layout is snapped together, the two faces
line up with no space between them. If the faces are separated and this feature is active, a connection line (typically red)
displays between them. When the layout is snapped together the faces line up and the connection line disappears. If this
feature is not active, the line between the faces is gray. When the layout is snapped together the faces do not snap together
and the gray line remains.
Multi-layer Drawing
• There are several options used to configure how the multi-layer cells draw at the connection faces. The following
figure illustrates the options where the left ends of the lines are drawn using "Inside", "Outside", and "Flush".

• Air bridge: This feature specifies that a line face attaches to an air bridge. Many times in MMIC designs, line ends
attach to air bridge elements. When this occurs, the various layers to build the line need to be stretched and spaced for
attachment. Air bridges are user-defined parameterized cells that must be defined for a particular MMIC process to
work. The name of the air bridge that is created is entered into the LPF file so it is available for use in the project.
• Default: This feature ensures continuity of all the layers in a multi-layer drawing. The default specifies how the
multi-layer face properties are drawn. The line elements are drawn as specified in the LPF file. The discontinuities
are drawn so that all of the layers are connected. The "T" element has the layers inside the outermost layer extended
so they touch the same layers in the line elements.
• Bridge type: The LPF file allows specification of as many bridges as needed. All of the bridge types in the LPF file
are available. You can specify which air bridge definition you want to use when specifying Airbridge as the multi-layer
drawing type.
Face Justification
For more control over the relative positions of the faces, you can define a variable offset that allows a delta X, delta Y,
and a rotation angle to be set for the faces. The variable offset has the effect of shifting the face to an offset position.
When the layout shapes are snapped together, the connected layout shapes snap to the offset face as shown in the following
figure.

3.13.3. Local Cell Parameters
Usually the parameters needed to draw a layout cell are provided by the schematic component with which the layout cell
is associated. You can add additional "local" parameters to the layout cell definition to allow the layout cell instance to
store information that can be used to draw the layout cell. This is typically used when there are dimensional parameters
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needed to draw the layout cell that are not part of the electrical model. You can set the values of the local parameters on
the Parameters tab of the Cell Properties dialog box.
Local parameters are also automatically created when a layout cell is connected to a schematic element that does not
have the parameters that the layout cell needs. This allows you to use any layout cell with any electrical element (regardless
of the number of nodes). For example, you can assign a layout cell for a spiral inductor to a subcircuit that uses measured
S-parameters. The physical dimensions of the spiral are then entered as local parameters to allow the spiral to draw
correctly.

3.14. Dynamic Voiding
Dynamic voiding is a layout mode that automatically adds clearance between layout shapes and signal traces, such as
signal traces embedded in ground or power planes. You can also apply clearance between layout shapes such as a power
and ground plane. Additional features include rounding of layout shape corners and the removal of small features that
could potentially cause DRC violations or manufacturing issues.
Dynamic voiding applies only to schematic layouts, not to EM documents or artwork cells. However, you can apply it
in a schematic layout and then extract to an EM document.
Dynamic voiding can be enabled or disabled in a Layout view by choosing Draw > Enable Voiding or by clicking the
Enable Voiding button on the Draw Tools toolbar:.

With dynamic voiding disabled, clearance cutouts are not applied. When dynamic voiding is enabled, clearance is applied
to the layout shape surrounding the signal trace, and the outside corners of the layout shape are rounded.

Dynamic Voiding Disabled

Dynamic Voiding Enabled

3.14.1. Dynamic Voiding Setup
As shown in the following figure, signal shapes are the routed traces of the design. These can be either layout representation
of elements from a schematic, iNet routes, or layout shapes that are associated with a schematic net. Dynamic shapes
are drawn as shapes such as rectangles or polygons, and they represent layout items such as ground planes and power
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planes. The following example shows signal shapes including the MLIN microstrip elements at the ends as well as an
iNet route between the two elements.
Dynamic Shape

Signal Shape

Signal and dynamic shapes use the positive and negative layer naming convention. Dynamic shapes are drawn on the
positive layer and signal shapes are drawn on the normal layer. You can apply additional cutouts by drawing a layout
shape on the negative layer as shown.

Normal Layer

Positive Layer

Negative Layer used for
Dynamic Shape cutout

If a line type is defined so that it includes a negative layer with offset defined, the clearance is set by either the negative
layer offset value or the dynamic voiding rules, whichever is larger. See “Negative Layers ” for details on positive and
negative layers.
Signal shapes that are associated with schematic elements or iNet routes require a defined line type. For more information
on line types, see “Line Type ”. To configure line types, the “Create New Process Wizard” is available.
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Layout shapes can be associated with net routes by selecting the layout shape and the net rat line or an iNet route, right
clicking, and choosing Associate Net Routes. These shapes must be drawn on the normal layer. Associating net routes
can also be performed automatically, see “Automatic Net Connectivity Extraction”.

3.14.2. Utilizing Constraint Rules
Constraint rules are defined in the layout process file (LPF). See “Options - Voiding Constraint Sets Dialog Box ” for
details on configuring the constraint rules.
Two main groups define the dynamic voiding constraint rules: Spacing and Same Net Spacing. Spacing rules apply to
signal shapes and dynamic shapes that have different net names. Same Net Spacing rules apply to signal shapes and
dynamic shapes that use the same net name. The following figure shows the Same Net Spacing rules set to 10 mils, and
the Spacing rules set to 5 mils.

In the following Layout View, the upper dynamic shape has the same net name as the route, yielding a clearance of 10
mils in accordance with the Same Net Spacing rules. The lower dynamic shape has a different net name than the route,
so its clearance conforms to the Spacing rule of 5 mils.
Dynamic Shape
Net A

10 mils
Signal Shape

Net A
5 mils
Dynamic Shape
Net B

The LPF Voiding Options control the rounding of dynamic shape corners and the removal of small dynamic shape features.
See “Options - Voiding Options Dialog Box ” for details on setting these parameters. The Smoothing mode on the Circuit
Options dialog box Nets/Voiding tab is related to the Voiding Options settings. With Smoothing mode set to Disabled, the
dynamic shape corner rounding and small feature removal are not applied as shown:
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Smoothing mode: Disabled

With Smoothing mode set to Standard, all outside corners are rounded and small features are removed as shown:
Smoothing mode: Standard

When Smoothing mode is set to Allegro compatibility (the default), small features are removed and corners around the
perimeter of the dynamic shape are not rounded. Interior corners are not rounded if the adjacent signal shape is a square
corner. In the following figure, the two interior corners are rounded due to the clearance spacing rules that void the
dynamic shape between the signal route and the rectangular signal shapes. The other interior corners are not rounded
because the dynamic shape fully surrounds the adjacent signal shapes.
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Smoothing mode: Allegro compatibility

You can assign priority to overlapping dynamic shapes so that the clearance operation is only applied to the lower priority
shape. For example, in the following figure, dynamic shapes A and B overlap when dynamic voiding is disabled. Dynamic
shape A is assigned a higher priority than dynamic shape B. When dynamic voiding is enabled, dynamic shape A is left
intact, while dynamic shape B has the clearance applied.

A

A

B
Dynamic Voiding disabled

B
Dynamic Voiding enabled

When dynamic shapes have the same priority value, the shapes overlap without clearances being applied.
To assign a priority, right-click the layout shape and choose Shape Properties. On the Properties dialog box Net Properties
tab, set the Dynamic shape priority. See “Properties Dialog Box: Net Properties Tab ” for details.

3.14.3. Dynamic Voiding Across Hierarchy
For hierarchical schematics, the Show top level dynamic only option on the Options dialog box Nets/Voiding tab controls
whether dynamic shapes in lower levels of the hierarchy are included in the top level.
The following figure shows two layouts in a hierarchy with Show top level dynamic only enabled (default selection). The
dynamic shape in child schematic Level_2 layout is not included in the parent schematic TopLevel layout. This allows
dynamic shapes to be defined only at the top level in the hierarchy.
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Show top level dynamic only enabled

Dynamic Shape
in a subcircuit

The following figures shows the same structure with Show top level dynamic only disabled. In this configuration, the
dynamic shape in schematic layout Level_2 is included in the TopLevel schematic layout.

Show top level dynamic only disabled

Dynamic Shape
in a subcircuit

3.14.4. Assigning Net Names and Constraint Rules
Net names are associated with both signal shapes and dynamic shapes. Layout shapes without a net name are not included
in dynamic voiding. These shapes are still included in the layout; however, clearance extraction, corner rounding, and
small feature removal are not applied when dynamic voiding is enabled.
To assign a net name to a dynamic shape, right-click the layout shape and choose Shape Properties. On the Properties
dialog box Net Properties tab, specify the Net Name. See “Properties Dialog Box: Net Properties Tab ” for details.
After signal shapes and dynamic shapes are added to the schematic layout, you can modify the net names and apply the
constraint rules to a particular net using the Net and Constraint View window. See “Net and Constraint View Window
” for details.
Net Name Restrictions:
1. The following characters are not allowed in a net name: ) ( , = \ " ' ` / { } ! *
2. Net names cannot be longer than 31 characters.
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3. Net names are not case sensitive and must be unique. For example you cannot use NetA and NETA for two different
net names.

3.14.5. Net Connectivity
A net is defined by two or more schematic element pins that are connected together. Net connection can be made by
connecting schematic elements together with a wire, by joining the schematic elements together, or by using a Named
Connector between schematic element pins as shown in the following figure.
MLIN
ID=TL1
W=20 mil
L=100mil
MSUB=Copper01

MLIN
ID=TL2
W=20 mil
L=100mil
MSUB=Copper01

MLIN
ID=TL4
W=20 mil
L=100mil
MSUB=Copper01

Net Conn A

MLIN
ID=TL5
W=20 mil
L=100mil
MSUB=Copper01

Net Conn A

MLIN
ID=TL3
W=20 mil
L=100mil
MSUB=Copper01

MLIN
ID=TL6
W=20 mil
L=100mil
MSUB=Copper01

Unique net names are automatically assigned to each net as shown in the following figure. Once assigned, you can
reassign the net name in the “Properties Dialog Box: Net Properties Tab ” for iNet routes, or in the “Net and Constraint
View Window ” for all signal shapes.
MLIN
ID=TL1
W=20 mil
L=100 mil
MSUB=Copper01

EN1

MLIN
ID=TL2
W=20 mil
L=100 mil
MSUB=Copper01

EN2

MLIN
ID=TL3
W=20 mil
L=100 mil
MSUB=Copper01

The one exception to unique name assignment pertains to supernets. A supernet is a collection of separate nets that are
assigned the same net name. The one supernet structure supported is separate nets connected through schematic vias as
shown in the following figure.
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MLIN
ID=TL6
W=20 mil
L=100 mil
MSUB=Copper01

EN1

EN1

VIA
ID=V1
D=20 mil
H=5 mil
T=0.7 mil
RHO=1

EN1

EN1

VIA
ID=V2
D=20 mil
H=5 mil
T=0.7 mil
RHO=1

EN1

MLIN
ID=TL1
W=20 mil
L=100 mil
MSUB=Copper01

When nets are connected through vias, all the nets as well as the vias in the collection are automatically assigned the
same net name. If the net name is changed on any one item in the supernet structure, then all net names in the supernet
structure also change. The schematic vias that are supported with supernet structures are: VIA, VIAM, VIAM2 and TVia.
To assist with net management, choose View > Net and Constraint View to access the “Net and Constraint View Window
”. This dialog box allows you to browse and filter net objects and assign net names and constraint sets to signal shapes
and dynamic shapes. You can also toggle on/off highlighting of shapes and instances associated with selected nets.

3.14.6. Automatic Net Connectivity Extraction
To manually associate layout shapes with a net, select the layout shape and the net rat line, right-click and choose Associate
Net Routes. Automatic net extraction allows layout shapes that overlay signal shapes to inherit the net name of the signal
shape without performing the Associate Net Routes procedure. Automatic net extraction behavior is set globally on the
“Circuit Options Dialog Box: Nets/Voiding Tab”, accessed by choosing Options > Default Circuit Options. These settings
can also be set per schematic on the schematic Options dialog box Nets/Voiding tab. The selections for Connectivity mode
are:
• Disable
• Extract before voiding
• Auto extract
Each of the Connectivity mode setting affects layout shapes that are drawn on the normal layer and overlap with signal
shapes such as iNet routes or schematic instances.
With Connectivity mode set to Disable, the layout shape does not get connected to the net and is not assigned a net name.
In the following example, the rat line drawn across the layout shape indicates that this shape is not connected to the net.
In addition, the layout shape is not highlighted when the net is selected in the Net and Constraint View window.

AWR Microwave Office Layout Guide 3–163

Dynamic Voiding

Layout Shape

net

rat line
Layout Shape is disconnected from the net

When Connectivity mode is set to Auto Extract, layout shapes that overlay with signal shapes are automatically connected
to the net. In the following example, the rat line ends at the layout shape edge, indicating that the layout shape is now
part of the net. In addition, the layout shape is now highlighted when the net is selected in the Net and Constraint View
window.
Layout Shape
net

Layout Shape is connected to the net

When Shapes sticky to nets is selected, if the layout shape is moved such that is does not overlap with any other signal
shape on the net, the layout shape retains the original net name, as shown in the following example. The rat lines connecting
to the layout shape indicate that it is still connected to the net.

net

Layout Shape

Layout Shape is still connected to the net after movement
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If the layout shape is moved such that it overlaps with a signal shape on another net, that layout shape inherits the new
net name and becomes part of the new net if Connectivity mode is set to Auto Extract.
When the Constraint mode is set to Extract before voiding, the automatic net extraction behavior depends on whether or
not dynamic voiding is enabled. In this mode, if voiding is disabled the behavior is the same as Constraint mode set to
Disable. Under these conditions (voiding disabled and Constraint mode set to Extract before voiding), layout shapes that
overlap signal shapes do not automatically become part of the net. In this mode, if voiding is enabled, the behavior is
the same as Constraint mode set to Auto Extract. Under these conditions (voiding enabled and Constraint mode set to
Extract before voiding), layout shapes that overlap signal shapes automatically become part of the net.
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Chapter 4. Layout Configuration
4.1. Setting Layout Options
Before beginning layout work, you should read this entire chapter to potentially save time and troubles at the end of your
design cycle.

4.1.1. Orthogonal vs Non-Orthogonal Design Styles
Before you design, you should decide whether to use an orthogonal or non-orthogonal design style. With an orthogonal
design style, all of the connection locations (called faces) between different layout items can only be rotated 0-, 90-,
180-, or 270-degrees. For example, the following figure shows a simple design that is orthogonal.

Notice that the shapes can be at any angle, but the faces (the locations highlighted in red) must be at an orthogonal angles.
The following figure shows a simple non-orthogonal design.

Notice that the face highlighted in red is at a non-orthogonal angle.
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This is important because when there are non-orthogonal rotations, it is impossible to represent each vertex of the shapes
exactly as 1nm values (the minimum resolution in the drawing system). For example, this 100um rectangle is rotated by
31-degrees.

The upper right vertices have decimal places that must be rounded at some point, and if all of the rounding is not the
same, it is possible to have gaps in the layout.

4.1.2. Grid Options
Most of the options for the Layout View Editor and the Artwork Cell Editor are set by choosing Options > Layout Options
(or double-clicking Layout Options in the top window of the Layout Manager). See “Layout Options Dialog Box: Layout
Tab ” for details on this dialog box.
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Before beginning a project with layout, it is important to set up the resolution of the drawing database. After selecting
the Grid to modify, click the Edit Grid button to access the options for Database Size and Grid Spacing.
Database Size sets the precision of the coordinates of the shapes within the layout system. The smallest resolution of the
layout system is one nanometer (1e-9 meters). The specified database unit size must be a multiple of a nanometer. If you
use English units (mils), the smallest database resolution that you can specify is 0.005 mils (equal to 127 nm), so the
database resolution must be an integer multiple of 0.005 mils. If you use units smaller than 0.005 mils there are significant
rounding errors in the generated shapes.
Cadence® recommends that for processes that do not have a vertex grid requirement, set the database unit size to the
smallest possible, 1e-9 meters (or equivalent in your project units if using um or mm) or 0.005 mils. Typically PCB and
other "larger scale" manufacturing technologies do not have vertex grid requirements. Many IC fabrication processes do
have vertex grid requirements. Note that PDKs configured for the Cadence AWR Design Environment® software should
come with the database unit size set to the proper vertex grid requirement required by the fabrication process. However,
Cadence recommends that you always double check this value with your design manufacturer.
Grid Spacing specifies the drawing grid snap. The drawing grid snap simplifies the placement and construction of shapes
within the layout system. In addition to being able to specify the grid spacing from the Layout Options dialog box, the
toolbar for the Layout View Editor and the Artwork Cell Editor includes a tool for setting the grid snap multiplier as
shown in the following figure. The multiple ranges from 0.5x to 10x. For example, if the grid spacing is set to 1 um and
a multiple of 4x is chosen, the grid snap points are spaced 4 um apart.
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specifies the number of discrete angles allowed during the rotation of a shape in the layout system.
The allowable values range from 0.1-degrees to 90-degrees. It is also used for some of the drawing cells. For example,
the MTRACE element can have angled sections, but the angles of these sections must conform to the rotation snap.
Rotation snap angle

4.1.3. Layout Cell Snap Options
The Snap together option determines when the AWR Design Environment platform software snaps layouts together. Auto
Snap on Parameter Changes automatically snaps whenever any element parameter is changed for that level of hierarchy
only. Choose Edit > Snap Objects > Snap All Hierarchy to snap the entire hierarchy. This option is useful for simple layouts.
For more complex layouts, especially with closed loops, this setting can cause layouts to snap more often than you want.
Manual snap for selected objects only only attempts to snap together selected items when you choose Edit > Snap Objects
> Snap Together or click the Snap Together button on the toolbar. The first item you select is the item that does not move
unless one of the other items is anchored. For hierarchy, if you select items including subcircuits, and choose Edit > Snap
Objects > Snap All Hierarchy, all the items including hierarchy are snapped together.
Manual snap for all objects is

identical to Manual snap for selected objects only except you do not have to select items and

all items are snapped.
NOTE: You can set default snap options at the environment options level (see “Environment Options Dialog Box: Layout
Tab ”) to apply the setting to all of your projects, or at the project level (see “Layout Options Dialog Box: Layout Tab
”) to apply the settings only to the current project.
Face inset options are selected from the Auto face inset list in the Layout Cell Snap Options area of the Layout Options
dialog box Layout tab. The following options are available:
•

Do not inset faces:

Turns off the automatic face insetting so no artificial overlap is created for any of the layout cells.

•

Inset non-orthog. X.X db units:

•

Inset all X.X db units:

This is the default option (with X.X = 0.5). This option insets any faces that are not
orthogonal. The default insets an angled face by 0.5 database units to ensure that any connecting shapes are still
connected after the shape is created on the database grid.
Insets all faces (including orthogonal faces) by a multiple of the database unit. This is the
recommended setting for non-orthogonal designs.

For non-orthogonal designs, these settings help avoid gaps in layout. Although the DRC (if it is set up to do so) can catch
cell connection gaps like those described in “Diagnosing Layout Problems ”, it is often desirable to have a mechanism
to avoid these potential gaps. The mechanism that is provided allows you to select an option that causes the connection
faces to be inset automatically so there is some built-in overlap at the connection points.
Cadence recommends always using Keep origin on grid. This is the default for new projects and it cannot be turned off
once it is turned on. This option exists to allow customers with pre-v9.0 designs to make this change and see what the
affect is on their layout. Layouts change when you select this setting, so you should save a backup.
You should select Allow pCell's origin to float for non-orthogonal designs to allow rotated pCells to properly snap together.

4.1.4. Preventing Layout Problems
The following sections describe potential layout problems and their solutions.
Subcircuits and Artwork Cells Must be Orthogonal
Subcircuits and any layout item using an artwork cell as the layout should never be rotated non-orthogonally, or you can
end up with gaps in the layout and/or items that cannot be snapped together. Only pCells can be non-orthogonal. For
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example, in the following figure the layout uses one pCell (layout for a MLIN element) and one artwork cell and they
are rotated by 45-degrees with a very large database grid size (1um) to demonstrate what can occur.

pCell Rounding
pCells always round to 2x the database grid size so the centers of each face can still be drawn on the database grid. For
example, with a 1um grid and a 5um wide line, the center is 2.5um which cannot be drawn on the grid, as shown in the
following figure.

The database grid size is 1um, the left shape is 6um wide and the right shape is 5um wide. The 5um wide line was rounded
down to 4um. This example uses an unrealistically large database grid size to demonstrate this issue.
Path Vertices on Grid
Paths are drawing objects with user-specified centerline, width, and corner miter type. Alternatively, many of the pCells
in the AWR Design Environment platform draw as paths, such as TRACE elements and inductors. These can lead to
situations where the vertices stored are on grid, but the outline of the shape is not. If your vertices must be on grid, you
can force paths to draw and export this way. Choose Options > Layout Options and click the Paths tab. In Draw as polygons,
you can set the path to always draw as polygons or only when vertices are off grid. The advantage is that you are guaranteed
to have shapes on grid. The disadvantage is that the shape is no longer a path when it is exported from the AWR Design
Environment software, which might make editing the exported artwork file more difficult. For example, a 40um MTRACE2
element has been routed at non-orthogonal angles with a 1um database grid size. The following figure magnifies one of
the vertices of this path.
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Notice the vertex circled in red is not on the grid drawn on the layout. With Draw as polygons set to Always or When
vertices are off-grid, this layout displays like the following figure.

Now the highlighted vertex is exactly on grid.
Different Length Faces
Rotated items with faces that have different lengths cause gaps in layout. This is due to the way vertices get rounded.
For example, the following figure magnifies a 40um line connected to a 10um line with a 1um database grid size.

Note the rather large gap between the shapes, but no rat line. There are several solutions to this problem. The first is to
use a cell between them that has the same face lengths. For example, for two MLIN elements with these dimensions, an
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MSTEP should be used between the two lines. This produces a more accurate simulation result and better layout. With
the MSTEP included the layout displays as follows.

The other option is to inset non-orthogonal faces, as discussed in the following sections. If you do this, the layout displays
as follows.

Artwork Cells with Odd Multiples of the Grid
Artwork cells that draw faces that are odd multiples of the database unit size can have problems snapping together since
the center of the face is off grid. For example, see the following layout where a pCell is connected to an artwork cell
with a 5um face length and a 1um database resolution.
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The software cannot snap these cells together with default settings; the red circle highlights the ratline. The solution is
to either change the size of the face drawing or change the database resolution size to half of the current setting or lower.

You can also use the Allow pCell's origin to float option.
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Snapping vs Dragging
In a layout, there is a difference between manually dragging shapes and snapping them together. This is more common
with non-orthogonal designs or when faces on artwork cells are an odd multiple of the database resolution size. Moving
shapes only moves them to align the edges of the shapes, but not the center of the faces. Snapping aligns the center of
the faces.

4.1.5. Diagnosing Layout Problems
Since a layout must be drawn to a finite integer grid, there are often round-off related issues related to how the cells snap
together. These round-off related problems are usually associated with non-orthogonal geometry. For example, in the
following figure, if the grid dots represent the database unit size, it is not possible to rotate the rectangle without distorting
the shape. The true rotated shape is shown with a solid line, and the distorted snapped shape is drawn with a dashed line.

There are other problems with angled geometry regarding how the layout cell objects connect together at their faces. In
the following figure, there are two rotated rectangles that should be connected together. The solid line shows where the
rectangles should draw, and the dashed line shows where the rectangles must draw when they are snapped to the grid.
The grid snap operation snaps each off-grid point to the nearest grid point. As shown in the following figure, the snapped
versions of the shape are no longer connected at all and there is a small gap between the two rectangles.

There are options you can set in the Drawing options section of the Layout Editor Mode Settings dialog box related to
the layout cell faces to help diagnose specific problems. See “Layout Editor Mode Settings Dialog Box ” for a description
of this dialog box. Draw origin markers draws an "+" symbol at the origin of each layout object, and Draw cell faces draws
a line along the length of each cell face and a smaller perpendicular line at the face center.

AWR Microwave Office Layout Guide 4–9

Setting Layout Options

For example, cells that are not connected properly when dragged instead of snapped are easily diagnosed by viewing
these items. The following figure demonstrates this; the red circle shows the rat line in the layout.

If you look closely, you can see that the face center markers are not aligned. When this problem is fixed, however, you
can see that the face centers are at the same location.
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In complex designs, it may be difficult to find locations where the layout does not snap together. The integrated Design
Rule Checker (DRC) tool in the AWR Design Environment platform software is helpful in locating ratlines. See “Design
Rule Checking (DRC) ” for details on the AWR DRC tool. Specifically, the rat line check helps you find any rat lines
in your design. You must have a feature that has DRC enabled to use this tool. To perform this specific check:
1. Make your top level layout the active window and choose Verify > Design Rule Check.
2. In the displayed dialog box, click the Uncheck All button.
3. Click the Run Rat Line Check button.
4. Click the Run DRC button.
5. The Design rule violations window displays to show any rat lines left in the design.

4.2. Configuring Layout Mode Properties
You can set various layout modes, each with different layout option configurations to control the properties such as
display of layers, instances, text, iNets and hierarchical viewing; and for layout works such as placement, routing, and
custom work. You can easily switch between layout modes by clicking on the layout mode name.
For example, while routing iNets you may be required to dim the colors for artwork cells and subcircuits, restrict the
selection of all the items except for flylines, show only the outlines of layout shapes, and display only a few levels of
hierarchy; but for placement, you may need to display the entire hierarchy, restrict the selection of flylines, show the
entire detail of layout, and not dim the colors. You can easily configure this using Layout Mode Properties.
To define a mode, choose Layout > Layout Mode Manager with a layout window active.
In the Layout Mode Properties dialog box, click Add to create a new Normal, View Only, or Routing Layout mode.

Enter the Mode name in the Layout Editor Mode Settings dialog box and set the desired properties.
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You can access all of the modes and their properties by choosing Layout > Layout Mode Properties. All of the defined
modes are displayed in separate tabs. While working in layout, you can execute each mode's properties by choosing the
mode name from the drop-down list in the toolbar.

See “Layout Editor Mode Settings Dialog Box ” for a description of each option.
NOTE: You need to set the layout mode properties carefully and select the proper mode, otherwise working in the layout
window can be confusing.

4.3. Drawing Layers and Model Layer Mapping
The layout tool in Cadence Microwave Office® software has a powerful system for handling multiple-layer layouts that
are commonly used for the physical design of RF and microwave circuits. The model layers are then mapped to drawing
layers. You can define the drawing layers and how the drawing layers are mapped to each model layer. Note that each
model layer must have one drawing layer in the mapping, but any number of model layers can be mapped to the same
drawing layer. Two separate, unique layer lists are managed in the program. This allows the layout system to be very
flexible for bringing together layout objects (for example, parameterized artwork and GDSII artwork cells) from many
different sources. Drawing layers are used for display and for exporting purposes of layouts. Model layers are used to
store information for parameterized cells and artwork cells. You can also specify many different layer mapping schemes.
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When editing an artwork cell, the layer of the cell is shown on the model layers. When a layout is created from the
schematic, the layer is shown on the drawing layers.
Drawing layers are defined in the General section of the Drawing Layer Options dialog box accessible by choosing
Options > Drawing Layers. The Drawing Layer 2d section defines all of the drawing layers that are used in schematic Layout
View and the Drawing Layer 3d section defines the 3D properties of drawing layers so you can view the layout in 3D. If
the 3D properties are not defined for a drawing layer, the layer is not displayed in a 3D view of the layout.
For example, in the following figure resistors are created on two different layers in a dielectric stack. The artwork for
the resistors is imported into Microwave Office software in a GDSII library, and the artwork is stored on model layers
that correspond to the GDSII layers in the GDSII library. To simplify, if the resistor is on a single layer and is originally
on layer 9 with object type 0 in the GDSII file, the resistor artwork is stored on the model layer "9_0." The model naming
convention is discussed in “Model Layer Conventions”. The designer is using a process that has two levels for circuit
components and has set up two drawing layers, "resistor_level_1" and "resistor_level_2" to draw the resistor on the
different layers. Two mapping tables are also set up, one called "level1" with model layer "9_0" mapped to drawing layer
"resistor_level_1", and a second called "level2" with model layer "9_0" mapped to drawing layer "resistor_level_2", as
shown in the following figures. The designer can now create a schematic with two resistors, one for layer 1 and one for
layer 2.
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You must modify the layout property for each resistor to be the artwork cell that was imported in the GDSII library. This
is discussed in “Assigning Artwork Cells to Layout of Schematic Elements”. Next you create the layout from the library
from the Schematic View and assign the proper layer mapping to the two types of resistors. To do so, select the resistor
object in the layout and open the Cell Options dialog box, then select the cell options and change the Layer Mapping to
"level1" for the resistor to be drawn on Level 1 and "level2" for the resistor to be drawn on Level 2. Finally, the resistors
display in the Layout View on two different drawing layers even though they were brought into the project as a single
artwork cell.
Model layers and drawing layers are specified by a name given to the layer (a text string). Commonly, model layers map
to drawing layers of the same name (unity mapping) for simplicity. The ability to map model layers to arbitrary drawing
layers is useful in some situations.
The layout cells used in the layout can be artwork cells that are stored as instances within a GDSII library. If layout cells
from multiple GDSII libraries are used in a project, and the layers defined in the two libraries are not consistent, then
the layer mapping provides a clean mechanism for mapping the layers from the different libraries (the layer definitions
in the GDSII file are treated as model layers by the artwork cells) to a consistent set of drawing layers.
GDSII-based layout cells draw to model layers that are based on the GDSII layer number and the GDSII object type.
For example, a shape drawn on GDSII layer 6 with an object type of 0 would draw on model layer "6_0" (the object type
is usually 0 for most GDSII libraries). The layer mapping allows the less descriptive model layer (for example, "6_0")
to be drawn using a more descriptive drawing layer name (for example, "Metal1").
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You can program parameterized layout cells to use "hard coded" layer names. For instance, you can code a parameterized
layout cell that draws a transmission line to draw the shape for the transmission line on a model layer named "Metal1".
A parameterized layout cell coded by someone else for a discontinuity element could draw on a model layer named
"Trace1". If both layout cells are needed within a single project (and they need to draw on the same drawing layer named
"Metal1"), the mapping can be set up so that model layer "Metal1" is mapped to drawing layer "Metal1" (unity mapping)
and model layer "Trace1" is also mapped to drawing layer "Metal1." When the Layout View of a schematic using both
types of parameterized cells is opened, both cells are drawn on the same drawing layers.
For complex, multi-layered boards (such as an LTCC module) you may want to have a given layout cell draw onto
different drawing layers. For example, a layout cell for a buried resistor may be the same for resistors that are sandwiched
between different layers of the physical board. By creating additional mapping tables, the buried resistor can always
draw on the same model layers while being mapped to the actual drawing layer that is appropriate for the resistor given
its location in the physical layer stack, as shown in the following figure.

4.3.1. Layer Mapping of Layout Cells
Mapping of the model layers to the drawing layers for a layout cell is shown in the following figure.
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4.3.2. Model Layer Conventions
The naming of the model layers used by the layout cells depends on the type of layout cell. There are three different
types of layout cells that have different mechanisms for naming the model layers.
For parameterized cells that are implemented by coding in the parameterized drawing of the layout cell, there are two
methods for naming the model layer. Each method has advantages and disadvantages and it may be appropriate to use
both methods in a given layout cell definition.
The simplest method for naming the model layers within the layout cell is to "hard code" the model layer name into the
cell definition. For example, an MS Line can be coded to always draw to the "Thick Metal" model layer. This method
works best when a naming convention is established so that different layout cells that need to draw on the same drawing
layers use the same set of model layers. This is not strictly required because it is always possible to map incompatible
model layers to any set of drawing layers. In general, it is not convenient to have to set different mappings for a large
number of different layout cells, so having a naming convention simplifies the use of the layout cells.
The second method for naming the model layers within a parameterized cell definition is to use model layer names that
are configured using the Process Definition File (LPF file). This method is more flexible, and it is also the method used
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by most of the built-in cells that are included with Microwave Office software. The LPF file defines line types, which
include the names of the model layers used to draw the line types. Layout cells that use configured layers can easily be
transferred from one process to another by reading in a different LPF file that is configured for the process. In addition
to providing model layer names, the line type definitions in the LPF file allow multi-layer line types to be defined. See
“Line Type ” for more information. Note that the layer names defined in the LPF file are model layer names and not
drawing layer names, although it is common to use the same names for both with a unity mapping from the model layers
to the drawing layers.
Another method for naming model layers applies to the GDSII-based artwork cells. These cells use model names derived
from the GDSII layer number and object type. For example, a GDSII shape that draws on layer 4 with an object type of
0 draws to model layer "4_0". See “GDSII Layer Mapping” for a more detailed description of GDSII model naming
conventions.

4.3.3. Creating the Layer Mapping
You can create or edit one or more layer mapping tables for a project from within the drawing layer Options dialog box,
or you can initialize them from an *.LPF file. The following figure shows the Options - Model Layer Mappings dialog
box.
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You can create a new mapping table by right-clicking Model Layer Mappings and choosing New Model Layer Mapping.
When you create a new mapping you must provide a name to identify the mapping. You can also copy or delete mapping
tables from the drawing layer Options dialog box. Click New Layer to add a new model layer to the mapping table. To
edit the model layer, simply click and edit. Click Delete to delete model layers from the table. Click the drawing layer to
the right of a model layer to view a drop-down list of drawing layers to which you can map a model layer.
Note that the model layers in a project are common to all model layer mappings. When you create a new mapping, all
the existing model layers are automatically included. If, while editing one mapping, you create a new model layer or
delete an existing model layer, that change is made in all model layer mappings. You can create different drawing layer
assignments in each mapping, however, and that change is not synchronized to the other mappings. This is how you
create separate mappings from the same model layer names to different drawing layers. This is useful, for example, when
you import cell libraries from different sources whose layer naming or numbering conventions conflict with one another.
GDSII Layer Mapping
You can use GDSII cells for defining layout cells, or you can add them to the layout as drawing shapes that are not
associated with any circuit components in the schematic. The GDSII instances that are used for layout cells (or used as
non-associated shapes) can contain unlimited levels of hierarchy within the cells. For example, a GDSII cell of a FET
may contain sub-cells for the gate fingers. When a hierarchical cell is used, all cells within the hierarchy need to be
loaded into the project.
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GDSII Layer Conventions

The polygons within a GDSII file are on layers defined by a drawing layer number and an object type. The layer number
and the object type combine to define a unique layer number. The actual layer number is formed by using the GDSII
layer number for the low order byte and the object type for the high order byte. In the original GDSII specification, only
64 layers were allowed. The data size used to store the layer number within the GDSII file allows for up to 256 layers.
Most modern software that supports GDSII allows the full range of 256 layers to be used. When combined with 256
possible object types, the total number of possible unique layers is 65,536. The object type is usually zero for most GDSII
libraries, so typical GDSII files usually have less than 256 unique layers.
Microwave Office software works with named layers (as opposed to the numbered layers used by GDSII). When a GDSII
file is read into Microwave Office software, the numbered layers are automatically assigned to named model layers. The
model layer names are of the form "LayerNumber_ObjectType". For example, a shape on layer 8 with an object type of
0 is associated with a model layer named "8_0". The generated GDSII model layers are typically mapped to more
descriptive drawing layer names.
GDSII Layout Cells

GDSII cells used as layout cells need to have "faces" added to them to define how they should connect to other layout
cells. You can easily add a "face" to any GDSII cell by drawing the face onto the cell in the GDSII Cell Editor. You can
save GDSII cells that have faces added as native GDSII files. The faces that are drawn onto the cell are drawn as GDSII
path objects with a layer number of 99 and an object type equal to the node number to which the face corresponds. Since
all the information about the faces are stored as standard GDSII constructs, the GDSII layout cells can be read into and
modified by any tool that handles GDSII. The use of standard GDSII constructs also makes it possible to create
GDSII-based layout cells (with faces) in other tools that allow specification of the layer numbers and object types.
Importing GDSII Libraries

When importing a GDSII library from the Layout Manager, it is very important that there are layer mappings from the
GDSII layers to the drawing layers. This requires that there be a model layer for each GDSII layer. For example, if there
are only two layers in the GDSII file (layer 2 and layer 8), then there needs to be two model layers in the mapping table
for layers 2_0 and 8_0 (see the previous discussion on GDSII layer naming conventions). You should then map the 2_0
and 8_0 model layers to the desired drawing layers.
Often, you do not know what GDSII layers are in a GDSII artwork library before they are imported. This is especially
true when using XML libraries for vendor parts, since the vendors usually create the artwork representations that the
software automatically imports. If there is no GDSII model layer defined for the GDSII layer being imported, the program
automatically generates the new model layer. At this point, the program does not know what drawing layer to use for
the new model layer, so it automatically creates a new drawing layer with the same name as the drawing layer and uses
unity mapping (the same drawing and model layer name).
It is good practice in layout to have a list of drawing layers defined for the process you are using. If you see any new
layers added to the drawing layer list (the most obvious are GDSII formatted layers, for example, "6_0"), you should
map these model layers to one of your pre-defined drawing layers. This may require more than one mapping table to get
it correct. Once this model layer is mapped, you should delete the unwanted drawing layers from the drawing layer list.

4.4. The Layout Process File (LPF)
The Layout Process File (LPF file) allows you to configure a project for a particular manufacturing process.
With LPF Units, AWR Design Environment software supports per-process technology native units. This feature allows
different designs (using different process technologies) within the same project to specify values in units most appropriate
for that design process. You specify the units for each process as part of the layer process file (LPF). For example, a chip
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design might use units of microns for length, while the board in which the chip is mounted uses units specified in mils
for lengths.
You can import an LPF file into a project at any time to facilitate moving designs from one process to another. To import
an LPF file, choose Project > Process Library > Import LPF or right-click Layer Setup in the top pane of the Layout Manager
and choose Import Process Definition. You can also export an LPF file from an existing project by choosing Project >
Process Library > Export LPF or by right-clicking the process definition object in the top pane of the Layout Manger and
choosing Export. Commands available on the context menu include:
•

Edit

– opens the process definition in the drawing layer Options dialog box for editing. You can also double-click the
process definition object node to display this dialog box.

•

Edit as Text

•

Rename

•

Delete

– deletes the process definition.

•

Export

– exports the process definition to a user-specified file in text format.

•

Convert to Linked

•

Sync LPF with Stackup – displays the Update LPF from Stackup dialog box to allow you to select a STACKUP element

– allows you to edit the process definition in a text view. Changes take effect when you close the view, or
immediately if you click the Parse button on the toolbar that is active while the text edit view is open.
- renames the process definition.

- changes the process definition from a project-embedded to a linked file.

located in a Global Definitions document and transfer the color, hatch pattern, thickness, and Z position of the EM
layers into the drawing layers of the process definition.

The LPF file named default.lpf in the program directory is used as the default configuration for new projects. The contents
of the default.lpf file are determined by the default unit of measure you select during installation. The contents of the
MMIC.lpf file are copied to this file if you choose microns, the contents of the MIC_metric.lpf file are copied if you
choose millimeters, and the contents of the MIC_english.lpf file are copied if you choose mils. To use a different LPF
file for the default, you should rename that LPF file to default.lpf and place it in the program directory. Alternatively,
you can use an LPF file that already exists in the project by selecting it on the Layout Options dialog box Layout tab as
the Grid to modify to make it the new default LPF. You can also right-click the non-default LPF in the Project Browser
and choose Make Default Process Definition.
The default LPF file is not used to configure saved projects that are read back into Microwave Office software. Saved
projects maintain the settings specified during their creation, and they also save any changes made after project creation.
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You can "update" the settings in a project by importing a newer LPF file back into the project. This file resets all settings
and overwrites any previous setting changes (such as a change to a layer mapping table).
Once the process definitions are imported via layer process files (LPFs), you can begin creating designs which use these
process technologies, and specifying values for structures in their native process units.
The entries in the LPF file are bracketed using the following notation:
$XXX_BEGIN
!Specific information
$XXX_END

The XXX portion is replaced with a more descriptive indication of what the information is used for. Comments can also
be included in the LPF file by preceding the comment with a "!" character. There are many different components to the
LPF file:
$PROCESS_SETUP_BEGIN
:
$PROCESS_SETUP_END

PROCESS_SETUP_BEGIN and PROCESS_SETUP_END bracket the information in the LPF file that sets up information
on multi-layer drawing cells, default values, units, and others. This section is one of two main sections within the LPF
file. The other section is bracketed by the following:
$LAYER_SETUP_BEGIN
:
$LAYER_SETUP_END

LAYER_SETUP_BEGIN and LAYER_SETUP_END bracket the information in the LPF file that sets up the information
displayed in the drawing layer Options dialog box. The layer information includes all information on drawing layer
properties and all the layer mapping and file mapping tables.
$EM_MAPPING_BEGIN
:
$EM_MAPPING_END

EM_SETUP_BEGIN and EM_SETUP_END bracket the information in the LPF file that sets up the default properties
of the new EM structures and the properties of the conductor types available.
NOTES:
• All names for layers, structures, line types, bridge types, map tables, and conductors are restricted to 32 characters
maximum.
• You can configure many of the items specified in the LPF within a dialog box in the AWR Design Environment
platform software. For those sections, the proper dialog box is referenced in the following sections.
For information about the Process Definition Wizard, see “Create New Process Wizard”.

4.4.1. The $PROCESS_SETUP_BEGIN/END Section
There are several sub-sections that you can include in this section:
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Default Units
Default units are set on a per-LPF basis by choosing Options > Drawing Layers, then selecting the desired LPF from the
Select LPF file dialog box. Click OK to display the LPF Options dialog box, then under the General folder in the left
pane, click Units and specify the desired units.
The following shows a sample section for setting the default units with all of the possible unit types listed (length,
frequency, capacitance, inductance, resistance, conductance, temperature, angle, time, voltage, current, and power).
$DEFAULT_UNITS_BEGIN
LEN mil
FREQ G
CAP p
IND n
RES k
COND m
TEMP DegC
ANG Deg
TIME n
VOLT m
CUR m
PWR m
$DEFAULT_UNITS_END

The possible unit values are:
f
p
n
u
m
c
k
M
G
T
mil
inch
feet

femto
pico
nano
micro
mili
centi
kilo
mega
giga
tera
mil (for length only)
inch (for length only)
feet (for length only)

Default Values
Default values are set on a per-LPF basis by choosing Options > Drawing Layers, then selecting the desired LPF from the
Select LPF file dialog box. Click OK to display the LPF Options dialog box, then under the General folder in the left
pane, click Default Values and specify the desired values.
The following is a sample section for setting the default values for new circuit elements that are added to the project,
with all of the possible unit types listed. The unit modifiers that can be applied to the entry in the LPF file are the same
as the unit modifiers used for the default units previously described.
$DEFAULT_VALUES_BEGIN
W
40
u
L
100 u
H
50
u
T
2
u
Er
12.9
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Rho
1
C
1
p
Li
1
n
Rad
50
u
M
0.6
$DEFAULT_VALUES_END

Drawing Resolution Settings
Database size and grid spacing settings are set on a per-LPF basis by choosing Options > Drawing Layers, then selecting
the desired LPF from the Select LPF file dialog box. Click OK to display the LPF Options dialog box, then under the
General folder in the left pane, click Grids and specify the desired values.
The following section is used to specify the database resolution and the grid spacing used for the visual grid. The layout
system stores shapes in integer nanometers, so the smallest possible drawing resolution is 1 nanometer. If the drawing
is in English units, then the drawing resolution needs to be representable by an even number of nanometers. For layouts
specified using mils, this implies that the smallest possible drawing resolution is 0.005 mils (127 nanometers).
$DBASE_UNIT_BEGIN
DRAW_RESOLUTION
GRID_SPACING
$DBASE_UNIT_END

.01 u
1 u

Line Type Definitions
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
A line type describes the layers used for a single transmission line. For example, a plated metal line that requires two
metal layers and an etch layer can be configured as a line type in the LPF file. The following shows an LPF entry for a
single line type (there is an entry like this for each line type).
$LINE_TYPE_BEGIN "PlatedLine"
!Name is to identify the line, 32 characters maximum
!Layer
Layer_offset
minWidth
flags
"Metal1"
0
2e-60
0
"Via2"
-0.5e-6
3e-60
0
"Metal2"
0.5e-6
2e-60
0
$LINE_TYPE_END

Layer is the name of the model layer. Layer_offset is the offset used for drawing the layer as shown previously.
The minWidth number is used for checking design rule violations. Flags can be used to pass specialized information
to the layout cells.
Process Development Kit Line Types List

The Process Development Kit Line Type List block provides a listing of the line names from the LPF file the PDK uses,
in the order in which the PDK expects the line types to appear.
A block of this type is required to maintain correct Via and Bridge connections in layouts if line types are added, deleted,
or re-ordered without updating the PDK kit. You can change line types if there is a PDK line types block describing
which line types the PDK uses, and their order.
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This block is normally added by PDK Kit developers to indicate the line types and their order of use by the kit at the
time of development. The block should only be updated by PDK developers when they update the kit to use a different
set or order of line types. This block should not be changed unless the PDK kit is changed accordingly.
The block itself is a simple list of the names of each line type the kit uses, between a block begin and end statement as
follows.
$PDK_LINE_TYPES_BEGIN
! Line Types in order expected by PDK, modify only if PDK is updated.
"Thick Metal Line"
"Plated Metal Line"
"Cap Bottom Line"
$PDK_LINE_TYPES_END

Each entry in the table is a name that corresponds to the name of a line type after a $LINE_TYPE_BEGIN "Line Type
Name" entry in the LPF file when the LPF file is initially created. This list corresponds to a line type set as follows:
$LINE_TYPE_BEGIN "Thick Metal Line"
! -> Layer offset minWidth flags
"Thick Metal" 0 5e-06 0
$LINE_TYPE_END
$LINE_TYPE_BEGIN "Plated Metal Line"
! -> Layer offset minWidth flags
"Cap Bottom" 0 5e-06 0
"Thick Metal" -3e-06 5e-06 0
"Nitride Etch" -5e-06 4e-06 0
$LINE_TYPE_END
$LINE_TYPE_BEGIN "Cap Bottom Line"
! -> Layer offset minWidth flags
"Cap Bottom" 0 5e-06 0
$LINE_TYPE_END

If you want to make "Cap Bottom Line" the first line type, you could modify the line types as follows:
$LINE_TYPE_BEGIN "Cap Bottom Line"
! -> Layer offset minWidth flags
"Cap Bottom" 0 5e-06 0
$LINE_TYPE_END
$LINE_TYPE_BEGIN "Thick Metal Line"
! -> Layer offset minWidth flags
"Thick Metal" 0 5e-06 0
$LINE_TYPE_END
$LINE_TYPE_BEGIN "Plated Metal Line"
! -> Layer offset minWidth flags
"Cap Bottom" 0 5e-06 0
"Thick Metal" -3e-06 5e-06 0
"Nitride Etch" -5e-06 4e-06 0
$LINE_TYPE_END

You would not change the PDK line type list because it needs to reflect the order when the PDK was developed:
$PDK_LINE_TYPES_BEGIN
! Line Types in order expected by PDK, modify only if PDK is updated.
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"Thick Metal Line"
"Plated Metal Line"
"Cap Bottom Line"
$PDK_LINE_TYPES_END

In this example the list remains the same as the original, so the PDK knows the original order for the line types when
the kit was developed.
With the PDK line types block defined in the LPF you can add, delete, or reorder line type entries and still get correct
connections in the existing layout design documents.
Structure Type Definitions
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
A structure type describes the layers used for a structure that can be defined in a parameterized layout cell. This allows
the same type of information that is used to draw line types to be passed to user-defined layout cells to allow the creation
of user-defined configurable cells. The name given by the structure can be used to access the information in the structure
from the layout cell drawing code, and it cannot exceed 32 characters in length.
$STRUCT_TYPE_BEGIN "Resistor"
!layer
offset
"Res"
-2e-6
"Thick Metal"
0
$STRUCT_TYPE_END

min width
4e-6
5e-6

flags
1
0

Only a small number of elements use cells that reference structures, including:
• “Single Line on General Multilayer Substrate (EM Quasi-Static): GM1LIN”
• “Multiple Coupled Lines on General Multilayer Substrate (Dynamic Model) (EM Quasi-Static): GMCLIN”
• “Cylindrical One Port Via with Microstrip Pad (Closed Form): MVIA1P ”
• “Single Line on Stratified Homogeneous Substrate (EM Quasi-Static): PC1LIN”
• “Multiple Coupled Lines on Stratified Homogeneous Substrate (n=2 to 10) (EM Quasi-Static): PCnCLIN”
• “Cylindrical One Port Via with Stripline Pad (Closed Form): SVIA1P ”
• “Polygon Thin Film Capacitor for MMIC (Closed Form): TFCMP”
• “Cylindrical Via (Closed Form): VIA”
• “Cylindrical One Port Via (Closed Form): VIA1P”
Capacitor Definitions
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
The capacitor definition describes the layers used for the built-in thin film capacitor layout cells. The first layer in the
definition needs to be the bottom plate of the capacitor.
$CAP_DEFINE_BEGIN
!layer
"Metal2"
"Metal Top"
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0

min width
5e-6
4e-6

flags
0
0
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"Thick Metal"
$CAP_DEFINE_END

-2e-6

4e-6

0

PAD Definitions
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
The PAD definition constructs PADS for specific processes (RPCB, MMIC, RPIC) based upon the layering scheme.
$PAD_DEFINE_BEGIN
!Layer
"Source Drain"
"Cap bottom"
"Thick Metal"
"Nitride Etch"
$PAD_DEFINE_END

offset
0
-2e-06
-5e-06
-7e-06

minWidth
e-06
5e-06
5e-06
4e-06

flags
0
0
0
0

Via Definitions
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
The via definition describes the layers used for the built-in via layout cell. The following figure shows an example of a
via layout cell. The via cell is sized from the element parameter named "D" (the diameter).

The following LPF file entry was used to generate the layout shown in the previous figure. There are three defined layers
in the entry. Each of these layers causes a shape to be drawn on the specified layer for the via. The offset value for each
layer defines the size of the shape. For example, if a circle is drawn, the radius of the circle is D/2+offset. A negative
offset then makes a smaller circle. The flags value determines the type of shape that is drawn. A drawn shape can be a
square (with or without mitered corners) or a circle. The flags are also used to specify where on the via the connection
face should be located. By default, the connection face is located at the center of the via (there are also alternative faces
that allow connection to the via from any of the four different orthogonal directions). There are four possible values for
Flags. If the value is 1 or 3 (1st bit set), then the drawn shape is a circle; if it is 0 or 2 (1st bit clear), it is a square. A
value of 2 or 3 (second bit set) causes the outer perimeter of the drawn shape to be used as the reference plane for drawing
the connection face. Only one (at most) of the defined layers should have a flag value of 2 or 3. If none of the defined
layers has a value of 2 or 3, then the connection face is drawn at the center of the via. The miter parameter is only used
when a square is drawn. A non-zero value for the miter causes the corners of the square to be mitered as shown previously.
$VIA_DEFINE_BEGIN
!Layer
"First Metal"
"Source Metal"

offset
0
-2e-06

miter
0
5e-06

flags
0
0
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"Via Etch"
$VIA_DEFINE_END

-7e-06

0

1

You can use process defaults or presets for the Via Fill command in the Via Fill dialog box by including the following
LPF file entry:
!--- Via Fill Entries Process Presets ---$VIA_FILL_ENTRIES_BEGIN
<Entry Name> <Lib Name> <Cell Name> <Spacing Type> <Spacing X> <Spacing Y> <Offset X>
<Offset Y> <Clearance> <Stagger>
$VIA_FILL_ENTRIES_END

You can use process defaults or presets for the Via Fence command in the Via Fence dialog box by including the following
LPF file entry:
!--- Via Fence Entries Process Presets ---$VIA_FENCE_ENTRIES_BEGIN
<Entry Name> <Lib Name> <Cell Name> Spacing Type> <Spacing> <Offset X> <Offset Y>
<Merge Perimeters> <Perimeter Oversize> <Open Ends>
$VIA_FENCE_ENTRIES_END

pCell Multi-layer Line Drawing
When using LPF’s with multi-layer LineTypes, some pCells (particularly those with curves or arcs such as MCURVE,
MRSTUB, or MRINDSBR) are likely to have DRC errors. These errors most often occur when one layer should be
drawn with a minimum inset to another layer. Because the points along the curve are snapped to the layout grid, some
of them are slightly less than the required inset distance.
For example, a LineType has three drawing layers, METAL1 and METAL2 drawn with 0 offset, and VIA2, which is
required to be inset by 1um. Because of grid rounding, VIA2 gets too close to METAL1 and METAL2 in some places,
as shown in the following figure.
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The result is a DRC error such as: 'Minimum extension' violation from VIA2 to METAL1 {EXTENSION "VIA2"
"METAL1" 1000 } (< 1um).
pCells with curves check the LPF for process variables in a “name value” format that tells them to draw the inset layers
(VIA2 in this case) with extra inset to prevent this DRC error. You should include the variables in the
$PROPERTY_VALUES_BEGIN/_END section of the LPF:
$PROPERTY_VALUES_BEGIN
EXTRA_OFFSET_ON_CURVES 1
XTRA_CURVE_OFFS_LT0_LN1 -.2e-6
$PROPERTY_VALUES_END

Setting the 'EXTRA_OFFSET_ON_CURVES' variable to 1 indicates that the pCell should check each layer to see if an
additional inset is supplied. You can specify additional offset amounts for specific layers in each LineType with a variable
of the form:
XTRA_CURVE_OFFS_LT<x>_LN<y> <offsetAmount>
where <x> is the LineType index (starting from 0), <y> is the drawing layer index in the LineType (starting from 0),
and <offsetAmount> is the additional offset distance. In the previous example, the second variable,
'XTRA_CURVE_OFFS_LT0_LN1 -.2e-6', indicates that the 2nd drawing layer (index 1) of the first LineType (index
0) should be inset by an additional 0.2um on curved pCells. If this layer normally has a -1um inset in LineType 0, then
on curved pCells it has an inset of -1.2um.
Airbridge Drawing Object Selection
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
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The following selects which airbridge drawing object is used to draw the airbridges specified by the layout cells. The
name specified must match the name assigned to the airbridge drawing object in its implementation, and it cannot exceed
32 characters in length.
$BRIDGE_DRAW_BEGIN MyLayoutType $BRIDGE_DRAW_END

DRC Rules File
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
The rules file that the DRC uses can be configured from the LPF file as follows. You can also import DRC files directly
into the DRC editor using any valid file path to specify the rules file. The $MWO identifier is automatically replaced
with the Microwave Office installation directory.
$DRC_RULES_FILE_BEGIN
"$MWO\drc_rules.txt" $DRC_RULES_FILE_END

Connectivity Rules
These settings must be specified in the LPF file using a text editor. Export your LPF, edit the LPF and then import the
file back into your project.
The connectivity rules define how layers are physically connected. There are several types of rules to properly define
connectivity for all processes. The following section provides an example of these rules. For details on all of the rules
available, see “Connectivity Rules” for details.
$CONNECT_RULES_BEGIN
Connect "Gate Metal" To "Metal 1"
Connect "Source Drain Metal" To "Metal 1"
Connect "Ground Via" To "Metal 1"
Connect "Metal 1" To "Metal 2" By "Dielectric Via"
$CONNECT_RULES_END

Default Layout Font
You can set these values directly in the program by choosing Options > Layout Options and clicking the Layout Font tab.
See “Layout Options Dialog Box: Layout Font Tab ” for details.
You can specify in the LPF the default font used for layout text as follows. The first item in the specification is the font
name, which can be any installed Windows True Type font. The second item is the height of the font in integer nanometers.
The third number is 1 if the font is a bold font and 0 otherwise. The fourth number is 1 if the font is italic and 0 otherwise.
$DEFAULT_FONT_BEGIN "Arial"
100000 0 0 $DEFAULT_FONT_END

4.4.2. The $LAYER_SETUP_BEGIN/END Section
There are several subsections that can be included in this section. The properties in this part of the LPF are most easily
configured by setting the desired options in the drawing layer Options dialog box and then exporting an LPF file from
the project. Layer names cannot exceed 32 characters in length.
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Drawing Layers Properties
You can set these values directly in the program by clicking the Layout tab in the Project Browser. Double-click the LPF
you want to edit under the Layer Setup node to display the drawing layer Options dialog box. Select the Drawing Layer
2d and Drawing Layer 3d nodes under the General folder. See “Options - Drawing Layer 2D Properties Dialog Box ” for
details.
The following is an example for the drawing layer properties:
$DRAW_LAYERS_BEGIN
"Error"

255

0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

"Air Bridge"

32896 65535 0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

"Thick Metal"

8388

60884 0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

"Via"

128

33023 0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

"SubCircuitAnnotation" 4

48

0

16 1

1

0

350

0

""

0

0 1

"Obsolete" 0

"Annotation"

128

33023 0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

"RatsNest"

128

33023 0

16 1

1

0

35000 0

""

0

0 1

"Obsolete" 0

255

$DRAW_LAYERS_END
Layer Mapping Properties
You can set these values directly in the program by clicking the Layout tab in the Project Browser. Double-click the LPF
you want to edit under the Layer Setup node to display the drawing layer Options dialog box. Under the Model Layer
Mappings folder select the mapping table you want to edit, or right-click the folder to add a new mapping table. See
“Options - Model Layer Mappings Dialog Box ” for details.
An example for the model layer mapping follows. For each of the mapping pairs, the model layer is first and the drawing
layer is second. The entries in the form "11_0" are used to map the GDSII model layers to drawing layers. In the following
example, there are two mapping tables (Mapping 1 and Mapping 2). The $MAP_NAME keyword indicates the name of
the map, which also indicates the beginning of a new table. This name cannot exceed 32 characters in length. The
following two mapping tables are the same except the mapping of the Air Bridge and Thick Metal is reversed in the
second table.
$MODEL_LAYER_BEGIN
$MAP_NAME

"Mapping 1"

"Error"

"Error"

"Air Bridge"

"Air Bridge"

"Thick Metal"

"Thick Metal"

"Via"

"Via"

"SubCircuitAnnotation"

"SubCircuitAnnotation"

"Annotation"

"Annotation"

"RatsNest"

"RatsNest"

"11_0"

"Air Bridge"

"12_0"

"Error"

"13_0"

"Via"
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$MAP_NAME

"Mapping 2"

"Error"

"Error"

"Air Bridge"

"Thick Metal"

"Thick Metal"

"Air Bridge"

"Via"

"Via"

"SubCircuitAnnotation"

"SubCircuitAnnotation"

"Annotation"

"Annotation"

"RatsNest"

"RatsNest"

"11_0"

"Air Bridge"

"12_0"

"Error"

"13_0"

"Via"

"Error"

"Error"

"Air Bridge"

"Air Bridge"

$MODEL_LAYER_END
EM Layer Mapping Properties
You can set these values directly in the program by clicking the Layout tab in the Project Browser. Double-click the LPF
you want to edit under the Layer Setup node to display the drawing layer Options dialog box. Under the EM Layer Mappings
folder select the mapping table to edit, or right-click the folder to add a new mapping table. See “Options - EM Layer
Mappings Dialog Box ” for details.
The following is an example of EMSight layer mapping. For each of the mapping entries, the drawing layer is first and
the EMSight layer is second. The third entry indicates if the layer is a shape or a via, and the fourth entry is used to name
a material. The $EM_MAP keyword indicates the name of the map and also the beginning of a new table.
$EM_MAPPING_BEGIN
$EM_MAP "Default"
!draw_layer em_layer is_via material
"Thick Metal" 1
0
""
$EM_MAPPING_END

User Defined Drawing Layer Fill Patterns
The AWR Design Environment software includes many different predefined fill (or stipple or hatch) patterns you can
use when setting up how the drawing layers display. You can also define your own custom fill patterns. A stipple pattern
is defined as a string of '1' or '0 in 8x8, 16x16, and 32x32 forms. It must begin with the keyword
$LAYER_FILL_PATTERN_BEGIN and end with $LAYER_FILL_PATTERN_END. Between the keywords, you can
define one or many stipple patterns. Each stipple pattern consists of a display name followed by a series of '1's and '0's
between '(' and ')' separated with white space(s). The display name is used in the internal data structures and does not
need to be used elsewhere. The last two closing right parentheses of the fill pattern definition must be separated with a
space: ‘) )'.
The following example shows some user defined patterns with the proper syntax for each block.
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$LAYER_FILL_PATTERN_BEGIN
( display forward_slash (
( 0 1 0 1 0 1 0 1 )
( 1 0 1 0 1 0 1 0 )
( 0 1 0 1 0 1 0 1 )
( 1 0 1 0 1 0 1 0 )
( 0 1 0 1 0 1 0 1 )
( 1 0 1 0 1 0 1 0 )
( 0 1 0 1 0 1 0 1 )
( 1 0 1 0 1 0 1 0 )
) )
( display back_slash (
( 0 1 0 0 0 1 0 0 0 1
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 1 0 0 0 1 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 1 0 0 0 1 0 0 0 1
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 1 0 0 0 1 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 1 0 0 0 1 0 0 0 1
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 1 0 0 0 1 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 1 0 0 0 1 0 0 0 1
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 1 0 0 0 1 0 0
( 0 0 0 0 0 0 0 0 0 0
) )
( display big_plus (
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 1
( 0 0 0 0 0 0 0 0 0 1
( 0 0 0 0 0 0 0 0 0 1
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0
( 0 0 0 0 0 0 0 0 0 0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
1
0
0
0
1
0
0
0
1
0
0
0
1
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

1
0
0
0
1
0
0
0
1
0
0
0
1
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
1
0
0
0
1
0
0
0
1
0
0
0
1
0

)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
1
1
1
1
1
1
1
1
1
1
1
1
1
0
0
0
0

0
0
0
0
0
0
0
0
0
1
1
1
1
1
1
1
1
1
1
1
1
1
0
0
0
0

0
0
0
0
0
0
0
0
0
1
1
1
1
1
1
1
1
1
1
1
1
1
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
1
1
1
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
)
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(
(
(
(
(
(

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

0
0
0
0
0
0

)
)
)
)
)
)

) )
$LAYER_FILL_PATTERN_END

After you define the stipple patterns and load the LPF into a project, when setting up drawing layers, see “Options Drawing Layer 2D Properties Dialog Box ”. Your defined stipple pattern is included as an option for a layer.

4.4.3. The $EM_SETUP_BEGIN/END Section
There are several subsections that can be included in this section. The properties in this part of the LPF allow you to
specify the default properties of the new EM structures and the properties of the conductor types available.
Default EM Enclosure Size
This subsection of EM Setup allows you to specify the x and y dimensions of a newly created EM structure. In addition,
it allows the number of cells to be specified in the x and y dimensions. Note that x and y dimensions are specified in
meters. The following example of this section sets the size of newly created EM structures to 800 x 800 um with 80 cells
in the x and y dimensions.
$DEFAULT_EM_ENCLOSURE_BEGIN
!-----XDIM-----YDIM-----NX-----NY----800e-6

800e-6

80

80

$DEFAULT_EM_ENCLOSURE_END

Default EM Layers
The following section is an obsolete way of configuring defaults for EM structures. The better approach is to add
STACKUP blocks to your Global Definitions and configure your defaults on these blocks. When you create a new EM
structure you can either initialize from the LPF or a STACKUP that is global. The STACKUP is better since you can
have more than one default configured and the EM mapping (mainly used for extraction) is configurable.
This subsection of EM Setup allows you to define the stackup of dielectric layers for newly created EM structures. This
includes the layer number, thickness, dielectric constant, conductivity, scale and hatch patterns to use for conductors
placed on that layer. Note that thickness should be specified in meters, and the conductivity in S/m. The hatch pattern is
specified by a number between zero and five. The following is an example of this section:
$DEFAULT_EM_LAYERS_BEGIN
!----T----Er--Tand---Sigma---Scale---CondHatch---ViaHatch--500e-6

1.0

0.0

0.0

1.0

0

1

0.2e-6

6.5

0.005

0.0

5.0

4

5

100e-6

12.9 0.0001 0.0

1.0

2

3

$DEFAULT_EM_LAYERS_END
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EM Conductors
The following section is an obsolete way of configuring defaults for EM structures. The better approach is to add
STACKUP blocks to your Global Definitions and configure your defaults on these blocks. When you create a new EM
structure you can either initialize from the LPF or a STACKUP that is global. The STACKUP is better since you can
have more than one default configured and the EM mapping (mainly used for extraction) is configurable.
This section of EM Setup allows you to automatically specify the materials available for use as conductors. You can
specify the materials using physical parameters or electrical parameters. An electrical specification includes the conductor
name, surface resistance and DC, high frequency surface resistance parameter, and the excess surface reactance. All of
these quantities are specified in ohms per square. A physical specification of a conductor includes the name, thickness
in meters and the conductivity in S/m. In addition, the color of each conductor is specified using a red/green/blue notation.
Each of these integer parameters should be in the 0 to 255 range and the names cannot exceed 32 characters in length.
The following is an example of this section:
$EM_CONDUCTORS_BEGIN
$ELECTRICAL_SPEC_BEGIN
!--Name--------rDC---rHF--+jX---Red---Green---Blue
"Tantalum"

50.0

0.0

0.0

230

20

50

$ELECTRICAL_SPEC_END
$PHYSICAL_SPEC_BEGIN
!--Name---------T------Sigma----Red----Green---Blue-"Cap Bottom"

1e-6

4.1e7

128

128

64

"Plated Metal" 4e-6

4.1e7

230

155

40

"Thick Metal"

4.1e7

45

160

120

3e-6

$PHYSICAL_SPEC_END
$EM_CONDUCTORS_END
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Chapter 5. Layout Verification and Export
5.1. Design Rule Checking (DRC)
Design Rule Checking (DRC) checks for various design rules within the active layout (the active Layout View window).
In hierarchical designs, all levels of the hierarchy are checked when the DRC is run from the top level. The DRC can
also be run on only the lower levels of the hierarchy by making the Layout View for the lower level the active window.
You can also run third-party DRC engines such as Calibre®, Assura®, and ICED from within the Cadence® AWR
Design Environment® platform software, and the errors display in the AWR Design Environment Status Window.
When you run DRC on a layout you can perform several types of checks:
• Cell-based checking, which allows rules to be programmed into parameterized layout cells.
• Rat lines checking, which checks for any rat lines (layout connection lines) in the layout, indicating a layout not
properly put together.
• Polygon-based checking, which applies a set of rules to the polygons that are generated from a flat version of the
layout ("flat" means that all the polygons from all levels of the hierarchy are flattened to a single level of hierarchy).
These check types are described in the following sections.
The DRC Rules dialog box allows you to load saved rule files, edit rule files, run all checked rules or only those rules
you select, uncheck all rules, run DRC on an entire layout, run an area DRC check, and run third-party DRC engines.
To open the DRC Rules dialog box, in the Layout View, choose Verify > Design Rule Check.
DRC Errors navigation options are also available in the DRC toolbar.

5.1.1. Running Design Rule Check
An example DRC Rules dialog box is shown in the following figure.
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Cell-Based Checking
Cell-based checking is used with parameterized layout cells. The cell drawing API allows rules to be programmed into
the parameterized layout cells. These rules can use values that are either hard-coded into the cell or read from the *.LPF
file (Layout Process File).
The cell-based checks are implemented by overriding a checking function in the parameterized layout cell implementation.
These rules can be used to validate that the parameters the cell reads from the schematic elements are acceptable for
generating a DRC correct layout cell. For information on implementing cell-based checking, see the Layout Cell Software
Development Kit (Layout Cell SDK) documentation. For more information about this kit, or to obtain a kit, contact your
Cadence sales representative.
The Run Cell Base DRC rule (a built-in rule that allows you to run the Cell base DRC) applies to cell-based checking
only.
When executing the DRC for a layout, any cell-based violations are listed in the DRC violation window. Double-click
the violation to zoom in on the shape. See “Working with DRC Errors ” for more information about rule violation
reporting.
Rat Lines Checking
The Run Rat Lines check rule (a built-in rule that warns you if the layout cell has layout connection lines, indicating
improper snapping of objects) applies to rat line checking only.
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When executing the DRC for a layout, any rat line violations are listed in the DRC violation window, as shown in the
following figure. Double-click the violation to zoom in on the shape. See “Working with DRC Errors ” for more information
about rule violation reporting.

Polygon-Based Checking
General polygon-based DRC applies a set of rules to the polygons generated by the layout. The rules are defined in a
rules file that you can create or that is supplied with a foundry library. The DRC automatically flattens the hierarchy and
"unions" all shapes together on each layer that is checked, before the checks are performed. The polygon-based DRC is
a simplified rule checker that is specialized to work on arbitrary geometry, such as that found in microwave and RF
circuits. For example, special handling of curved shapes is included to prevent false errors on curved lines.
Polygon-Based Rules File
The DRC rules are easy to implement using a simple text editor. All dimensions in the rules file need to be in integer
nanometers. For example, 2um is entered as 2000.
You can specify the location of the drc_rules.txt file in the .lpf file. The following is the syntax of the line:
!--- File used for polygon DRC rules -----$DRC_RULES_FILE_BEGIN
"$MWO\drc_rules.txt" $DRC_RULES_FILE_END

To use a different rules file, replace $MWO\drc_rules.txt with the path and file name containing the DRC rules that you
want to use in the project. $MWO is the Cadence Microwave Office® software root directory.
The syntax of the rules file is very simple. Each rule has a keyword, which is followed by one or two layer names
(depending on the rule) in quotes and a minimum distance. The distance is always specified in integer nanometers.
The following are the rules that are currently supported in the polygon-based DRC:
• Error tolerance

AWR Microwave Office Layout Guide 5–3

Design Rule Checking (DRC)
Sets the error tolerance for DRC checking as a fraction of the Layout Options Database unit size, or of the
DATABASE_UNIT rule (see below). Can appear anywhere in the rules file, but should only appear once.
ERROR_TOLERANCE 0.5 is a 0.5 layout dbu tolerance.
ERROR_TOLERANCE <fraction_of_dbu>
• Database unit for error tolerance
Sets the database unit size to use with the ERROR_TOLERANCE value. If this rule is not specified, the document
database unit size from the Layout Options dialog box Database Size option is used instead. (On the Layout Options
dialog box Layout tab, click the Edit Grid button to display the Options dialog box for the current .lpf file and view/specify
the Database Size Spacing.) Specifying this rule enables consistent results from polygon DRC checking regardless of
what the document DBU is set to. This rule only effects the final tolerance distance in combination with the
ERROR_TOLERANCE rule; it does not cause shapes to snap to the specified DBU. It can be included anywhere in
the rules file, but should only appear once. DATABASE_UNIT 10 is a 10nm dbu.
DATABASE_UNIT <dbu [nm]>
• Merge related distance errors
Merges distance errors of the same rule type and from the same polygons. Merging can greatly reduce the error count
on layouts with curved geometries. This rule affects error markers from MINWIDTH, NOTCH, EXTENSION, JOG,
OVERLAP, and SEPARATION rules.
MERGE_DISTANCE_ERRORS <0 or 1>

• Minimum width
Detects the minimum width of lines and other shapes. Any polygon with opposing edges less than the minimum width
causes a violation. For this rule, only one layer is specified.
MINWIDTH <layer_name> <width [nm]>

• Separation
Checks for the minimum separation between two shapes on either the same layer or different layers. You can also use
this rule to detect small gaps in metal layers that are too small to be seen by visual examination. This rule requires
specification of two layers (the two layers can be the same layer if desired).
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SEPARATION <layer_name><layer_name>< distance [nm]>

• Overlap
Checks for the minimum overlap of one layer over another layer. This rule is often used to ensure that different layers
overlap enough to make a manufacturable connection. This rule requires specification of two different layers. The rule
does not depend on the order of the layers in the rule specification. For example, a rule like OVERLAP "A" "B" 1000
is redundant with the rule OVERLAP "B" "A" 1000.
OVERLAP <layer_name1> <layer_name2> <distance [nm]>.

• Extension
Checks for a minimum extension of shapes on one layer over shapes on another layer. The following figure shows
the distance being checked. This rule is often used to ensure that process layers are inset by a sufficient amount (for
example, when plating a line). This rule requires specification of two different layers. The order of the layers in the
rule is considered. This means that a rule of the form EXTENSION "A" "B" 1000 does not check the same thing as
EXTENSION "B" "A" 1000.
EXTENSION <layer_name1><layer_name2> <distance [nm]>.

• Notch
Checks for a minimum width of an intruding or protruding notch within a shape as shown in the following diagram.
This rule requires specification of only one layer.
NOTCH <layer_name> <distance [nm]>.
Notch

Notch

• Jog
Checks for a minimum width of a "jog" (a concave angle of greater than 80-degrees) within a shape as shown in the
following diagram. This rule requires specification of only one layer.
JOG <layer_name> <distance [nm]>
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• Minimum Polygon Area
Ensures that a polygon is not less than the minimum polygon area. This rule requires specification of only one layer.
MINAREA <layer_name> <area [m2]>
• Polygon Holes
Ensures that a polygon contains a hole. This rule requires specification of only one layer.
MUST_HAVE_HOLE<layer_name>
Ensures that a polygon does not contain a hole. This rule requires specification of only one layer.
NO_HOLE <layer_name>
• Polygon on Grid
Ensures that a polygon is on the grid. This rule requires specification of only one layer.
ON_GRID <layer_name> <grid_size [nm]>
• Minimum Angle
Checks for less than the minimum angle. This rule requires specification of only one layer.
MIN_ANGLE <layer_name> <angle [degree]>
• Maximum Vertices
Checks for more than the maximum number of vertices. This rule requires specification of only one layer.
MAX_VERTICES <layer_name> <number of vertices>
• Maximum Side Length
Ensures that a polygon side does not exceed the maximum length.
MAX_SIDE_LENGTH <layer_name> <size [nm]>
• Resize Polygons
Resizes polygons in an existing layer with a specified offset, then places them in a new layer. This rule requires
specification of two different layers.
RESIZE <new_layer_name> <layer1> <offset [nm]>
• Boolean Operations
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Perform Boolean operations on two layers to create a new layer:
BOOLEAN_OPS <new layer name> <layer_1> <operation: AND, OR, XOR, and SUBTRACT> <layer_2>
Example: BOOLEAN_OPS "Resulting Layer" "Second Metal" SUBTRACT "First Metal"
NOTE: When resizing polygons and performing Boolean operations, the new layer specified can have any name. This
new "derived" layer can then be used for other DRC checks, however the new layer is not visible in the layout.
• Specify a DRC Group
A DRC group is used to bundle DRC rules together. This allows you in the DRC Rules dialog box to toggle on/off an
entire group of rules, rather than each rule separately.
DRC_GROUP_BEGIN <group_name>
<DRC rule>
<DRC rule> ...
DRC_GROUP_END
• Specify a Constraint Region
The constraint block allows the rules listed in the block to be checked in certain regions of the layout. The region of
the layout to check is specified by the <layer_name>, and <INSIDE or OUTSIDE> specifies whether to check inside
the <layer_name> or outside the <layer_name>. Groups can be used within the constraint block.
In addition the following clauses are accepted as conditional keywords:
=
!=
<
<=
>
>=
CONSTRAINT_BEGIN <layer_name> <INSIDE or OUTSIDE>
<DRC rule>
<DRC rule> ...
CONSTRAINT_END
For example:
CONSTRAINT_BEGIN "TFR" <= 3000 ! If minimum width <= 3um
MAX_SIDE_LENGTH "TFR" 200000 ! Then max length must be < 200um
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CONSTRAINT_END
Area DRC Check
You can also execute DRC only in a specified area of layout. To specify the area for DRC, choose Verify > DRC Check
Area. With the Area Selection cursor, click and drag inside the layout window to draw a rectangle that defines the area
for DRC, as shown in the following figure. Choose Verify > Design Rule Check, and in the DRC Rules dialog box choose
DRC check area, then click the Run DRC button. When an area DRC check is run, all of the DRC rules that do not apply
to the specified area are ignored even if those rules are selected in the DRC Rules dialog box.

5.1.2. Working with DRC Errors
Design rule violations are reported in a DRC Errors window as shown in the following figure. After the DRC is run, you
can open or close the DRC window by choosing Verify > DRC Errors Window.
Identifying DRC Errors
Double-click the rule violation in the DRC Errors window to automatically zoom in to the errors in the layout window.
The violation(s) for that rule alternately flashes in red and green.

Right-click an error and choose Error Marker Options to display the Error Marker Options dialog box for configuring error
marker display. See “Error Marker Options Dialog Box ” for information on this dialog and its options.
The following figure is an example of a polygon-based design rule violation in the layout. The circle represents the
minimum distance needed to satisfy the rule, and the arrow shows the actual violation. In this example, the horizontal
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left arrow line causes a minimum width of a jog violation. If the cursor is moved over the violation in the layout window,
a tool tip window displays a description of the violation.

Customized DRC Error Messages

Customized error messages are displayed using the following syntax: 'ERRORTEXT_BEGIN - ERRORTEXT_END'
ERRORTEXT_BEGIN "Nitride Etch needs to be covered by Thick Metal" BOOLEAN_OPS "temp" "Nitride Etch"
SUBTRACT "Thick Metal" MAX_VERTICES "temp" 0 ERRORTEXT_END
When this rule is violated, the custom error message displays in the Design Rule Violation window.
Checked Errors and False Errors

You can categorize an entire rule violation or an individual occurrence of a violation as Checked Errors or False Errors.
Right-click the violation in the DRC Errors window and specify Checked Error or False Error. If working in a layout
window you can choose Verify > False Error or Checked Error or use the toolbar buttons.
The violations are moved to a selected category (Checked Errors or False Errors), removed from the original violations
section, and are no longer highlighted in the layout. To remove an individual error from the Checked Errors or False
Errors category, right-click the error in the DRC Errors window and choose Remove False Error or Remove Checked Error.
To remove all errors choose Remove All False Errors or Remove All Checked Errors. After removal the errors display again
in their original violation category.
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Save DRC Errors
You can save DRC run results in a file by choosing Verify > Save DRC Errors. In the dialog box that displays, type a name
for the file and save it.
Load DRC Errors
You can load saved DRC run results back into the layout by choosing Verify > Load DRC Errors, browsing to the file
location, and clicking Open to load the saved results file.
Copy DRC Errors
You can copy DRC errors to a text file or copy and paste the errors into other applications. In the DRC Errors window,
right-click an error and choose Copy.

To copy all of the errors for a specific rule violation, in the DRC Errors window right-click the rule violation and choose
Copy All as shown in the following figure. The Copy All operation copies both errors under the highlighted rule violation.
Paste the information using Ctrl + V or by choosing Edit > Paste.
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View All Errors

To view all of the errors in the layout window choose Verify > View All Errors or use the toolbar button.
View Rule Error

When zoomed in to an error, to view all of the rule violations choose Verify > View Rule Errors or use the toolbar button.
Next Rule Error

To view the next rule violation choose Verify > Next Rule Errors.
Previous Rule Error

To view previous rule violations choose Verify > Prev Rule Errors.
Next Error

To view the next error for a rule choose Verify > Next Error.
Previous Error

To view the previous error for a rule choose Verify > Prev Error.

5.1.3. GDSII Compare
You can compare the shapes between two GDSII files if the top level cells you want to compare have the same name.
To perform a GDSII compare, import a GDSII file into the AWR Design Environment software, then make active the
layout window for the cell you want to GDSII compare. Choose Verify > GDSII Compare and browse to open another
GDSII library. An XOR operation is performed between the shapes in the two layout cells and the differences are
highlighted in the layout cell window as shown in the following figure. You can also perform a GDSII compare from a
schematic layout if the schematic name is the same as the top level cell in another GDSII file.

AWR Microwave Office Layout Guide 5–11

LVS (Layout vs Schematic)

5.2. LVS (Layout vs Schematic)
As with design rule checking (DRC), you can run a layout versus schematic (LVS) check from within the AWR Design
Environment platform software using the LVS interface. In the Add Output File dialog box you can choose the type of
netlist syntax for netlist generation by choosing File > LVS as the Measurement Type, and then selecting the appropriate
netlist syntax under Measurement.
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Currently, the full integration of Calibre and ICED LVS are available. LVS is run from within the AWR Design
Environment software, and errors are viewable in the AWR LVS viewer. You can save LVS errors to a file and import
them into the program. The LVS viewer allows schematic and layout cross-probing, and you can categorize and navigate
the errors as described in “Working with DRC Errors ”.

The Verify menu contains options for the LVS Errors Window and other items.

5.2.1. Preparing an RF Schematic for LVS
The AWR Design Environment platform software automatically converts RF schematics into DC equivalent netlists for
LVS. The netlister is intelligent and automatically shorts any distributed elements such as MLIN or SLIN. However, for
proper creation of the netlist, there are certain items in a schematic that may require manual setup. This can include
elements that are represented in the schematic but not in the layout and should be excluded from the LVS netlist, like
meters and extra parasitics. Alternatively, elements that are represented in both the schematic and the layout but are not
recognizable as a design kit part (for example, S-parameters and user models) need to be set up so they are included in
the LVS netlist.
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SUBCKT
ID=S1
NET="my_ind"
PORT
P=1
Z=50 Ohm

1

Resistor

I_METER
ID=AMP1

MIM Cap

Parasitic Ind

2

1

1

PORT
P=2
Z=50 Ohm

Parasitic Cap

Pad

Pad

Meters are considered obsolete in the AWR Design Environment platform software and can be fully replaced by the
M_PROBE element, which is non-insertable and thus does not create a connectivity problem in the LVS netlist.
I_METER
ID=AMP1

Resistor

MIM Cap

M_PROBE
ID=VP1
Resistor

MIM Cap

For all other elements and netlist issues you can implement Switch Views (for more information see “Switch View
Concepts ”). Switch Views are alternative electrical models for a given instance. When properly configured, they allow
the LVS netlister to see the “correct” view of an element, while the simulator continues to see the model on the schematic.
For example, the “LVS view” of a parasitic shunt element is probably an open circuit, so that it disappears from the
netlist.

Similarly, the “LVS view” of a parasitic series element is a short circuit so that the element disappears from the netlist,
but the connectivity between adjacent elements is maintained.
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Lastly, the “LVS view” of some S-parameters or a user model (for example, a custom CAP, IND, or RES model) is the
actual PDK part that model represents.

A ready-to-run LVS schematic that includes S-parameters, series parasitic models, shunt parasitic models, and
current/voltage probes is shown in the following figure.
M_PROBE
ID=VP1

SUBCKT
ID=S1
NET="my_ind"
PORT
P=1
Z=50 Ohm

1

Resistor

MIM Cap

SUBCKT
ID=S3
NET="Parasitic Ind"

2

1

1

PORT
P=2
Z=50 Ohm

SUBCKT
ID=S2
NET="Parasitic Cap"
Pad

Pad

NOTE: All Switch Views used for LVS should have the same name.

5.3. Connectivity Checking
The Connectivity Checker detects shorts or opens in circuits by determining the connectivity in a layout using “Connectivity
Rules” and layout shapes. This connectivity is compared with the schematic connectivity to show where there are errors.
Any errors are listed in the Errors Window and are easy to navigate.
The Connectivity Highlight function highlights in one color the shapes that are connected in layout using the “Connectivity
Rules”. It does not check for open or short errors.
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NOTE: This feature is not an LVS replacement. The Connectivity Checker only analyzes DC connectivity, not the RF.
You should use this feature together with rat lines checking in “Design Rule Checking (DRC) ” to make your design as
clean as possible before signing off with an LVS tool. You can use the Connectivity Highlight function in either a
schematic layout or an artwork cell, but the Connectivity Checker can only be run for schematic layout. Connectivity
errors such as short and open, and layout setup errors such as port connections and port layers are listed in the LVS Errors
and Warnings window.

5.3.1. Running the Connectivity Checker
To run the Connectivity Checker, choose Verify > Run Connectivity Check to display an error and warnings window similar
to the DRC errors window. This window displays LVS errors such as open or short as well as layout cell errors.

You can double-click an LVS error to highlight the corresponding element in both the layout and schematic windows.
Double-click the Layout Cell Errors to zoom in to the cell port locations. Right-click an error and choose Show Help to
display more information and error solutions.

See “Port_Number: Face(s) Not on a Drawing Layer”, “Port_Number: Detached Face(s) on Drawing Layer Without
Connectivity Rules”, and “Port_Number: Detached Face(s) on Drawing Layer Drawing_Layer_Name ” for details.
Defining a Short
The Connectivity Checker recognizes the following shorts:
• Shorts between two nets: When two disconnected elements are shorted together, an error is issued.
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• Intranet shorts (shorts on the same net): When elements that are not directly connected in the network are shorted in
layout, an error is issued.

• Connected elements in a net: When two elements are directly connected, if an additional shape (that is not a layout of
a schematic element or part of another iNet) shorts them in the layout it is NOT considered an error. In the following
figure, the two MLINs, TL1 and TL2, are directly connected in the schematic, so even though another polygon is
shorting the two MLINs, an error is not issued. Also notice that their faces are not connected in layout, resulting in a
ratline. In this case, the layouts do overlap, so even if you remove the extra polygon shorting the two MLINS, an
OPEN error is not issued. A rat lines check, however, alerts you to this situation.
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• Exceptions: When layout faces are connected, the associated elements are considered connected in the network even
if they are not directly connected in the schematic. This exception applies to all types of layout objects with faces,
such as pCells and GDS cells. For example, in the following figure TL1-TL3 and TL3-TL2 are "shorts" in the layout
since the MLINs are not connected directly in the schematic; they are connected through an MTEE. The Connectivity
Checker, however, only detects the short between TL2 and TL3 because in the network, TL1 and TL3 are considered
directly connected because their faces are connected in the layout. Any additional connections between TL1 and TL3
are not considered an error.

Artwork Cells, pCells, and EM Subcircuits
The Connectivity Checker does not check the layout of an artwork cell, pCell, or EM subcircuit against the
element/schematic that it represents. It assumes that the layout correctly represents the electrical connectivity, so any
error made inside the cells or EM structure is ignored by the checker. For example, the resistor in the following schematic
is assigned an artwork layout. The GDS layout, however, contains an error in that the two cell ports of the artwork cell
are not connected due to the gap. Here, the layout does not represent the schematic in terms of electrical connectivity.
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The Connectivity Checker does not generate any errors because it is assumed that the GDS layout with the gap in it is
correct, and that the element (the resistor in this case) is an OPEN.

If the gap is shorted in the schematic layout, however, an error is generated.

1. Floating Metal: A Floating Metal error occurs when there is a piece of metal without any cell port, and the metal is
shorted to another layout cell. The following figure shows that the "Res" artwork cell has a piece of metal that is not
attached to any cell port. This metal is then shorted to MLIN in the layout.

Ground Connections
The Connectivity Checker operates as follows with various ground connections.
• Ideal Ground Element (GND) Connection: The Ideal Ground Element (GND) represents a short in network connectivity.
Any elements connected to an Ideal Ground is considered directly connected, and any additional shapes connecting
those elements does not trigger an error, as shown in the following figure.
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• Open Ground: The checker does not check for OPEN ground connections. If a layer that connects the layout elements
to the ground plane is missing, the checker does not see this. The two MLINs in the following figure are shorted to
GND in the schematic. In the layout, however, they are not connected to a specified ground layer or to each other.
The checker does not see the error.

• Ground Via Cells: The checker also does not recognize GND Vias as true ground. Two ground vias in the following
figure are shorted together in layout, triggering errors.
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Unsupported Connectivity Checker Items
The Connectivity Checker does not support the following items:
• Positive and negative layers: shorts and opens in positive and negative layers.
• Shape modifiers: Errors caused due to shape modifiers (see “Shape/Layer Modifiers” for more information) in schematic
layouts are not recognized. However, if shape modifiers used in an EM document cause errors in the schematic layout,
those errors are recognized.
• Bond wire: Errors caused due to bond wires.

5.3.2. Connectivity Highlighting
The Connectivity Highlight function allows you to view a layout with colors that show electrically connected shapes in
the same color in both 2D and 3D layout views. For a given level of hierarchy, the entire layout is checked for connectivity.
The following figures show a simple section of a MMIC chip for 2D and 3D layouts.
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The following figures show the 2D and 3D layouts for the same circuit with the connectivity highlight turned on.

The Connectivity Highlight function operates in two modes. One mode displays the entire connectivity of the current
layout, and the other mode allows you to click on specific areas of the layout to display the connectivity at those locations.
Highlight Connectivity All
With a schematic layout or artwork cell layout open, choose Verify > Highlight Connectivity All.
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Because there are a limited number of colors that can be easily differentiated, it may appear that different nets of similar
colors are shorted. If you run the Connectivity Highlight function a second time, however, random colors are used for
different nets and you can easily determine if a net is shorted or was just using a similar color. For example, when the
previous layout has connectivity turned on it might display as shown in the following figure.

You can turn off connectivity highlighting by choosing Verify > Highlight Connectivity Off.
Highlight Connectivity Probe
With a schematic layout or artwork cell layout open, choose Verify > Highlight Connectivity Probe to activate "probe mode".
The cursor changes to a pointer with a circle, as shown in the following figure.

You can click over any section of the layout to highlight the connectivity for that location through all levels of hierarchy.
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Clicking the same connected shape again toggles the connectivity off for that shape, while clicking separate locations
highlights (toggles on) the connectivity for those shapes.

You can change the color of any highlighted area by right-clicking the highlighted area and choosing Set Highlight Color.
A Color dialog box displays to allow you to change the color.

In this example, the highlighted area is changed from yellow to magenta.
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Since the probe mode toggles the connectivity, you can turn on all connectivity and then use the probe to toggle off
certain areas.
In probe mode, if you click over an area that has different connectivity below the point you select, all of the connected
shapes below that point are highlighted. In the following example, clicking over the parallel plate capacitor highlights
the areas for both the top and bottom plate of the capacitor.

To exit probe mode, press the Esc key or click another window to make it active.
Highlight Connectivity Rules
The Connectivity Highlight Rules dialog box (choose Verify > Highlight Connectivity Rules) allows you to control which
rules run during a connectivity analysis. This is helpful if you want to run only certain rules (for example, to remove
resistors from connectivity) and when you are developing rule sets for your process. You can also edit, add, and remove
rules directly from this dialog box and be alerted to rules that have potential syntax problems. See “Connectivity Highlight
Rules Dialog Box ” for dialog box details.
Layer Visibility
In both 2D and 3D layouts, the Connectivity Highlight function allows you to turn on and off the visibility of specific
layers, so you can choose to view shapes only on the visible layers.
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Using Hotkeys
These highlight commands do not have default hotkeys assigned. You can simplify their use by assigning hotkeys for
each Connectivity Highlight mode. Choose Tools > Hotkeys to display the Customize dialog box and navigate to the
commands as shown in the following figure.

See “Assigning and Configuring Hotkeys” for details on adding hotkeys.
Using Positive and Negative Layers
The Connectivity Highlight function does not by default perform Boolean operations for the positive, negative, and
normal layer structure. If you need more information about layers, see “Negative Layers ”. You can manually perform
the layer operations with the following steps:
1. Select the entire layout by pressing Ctrl + A to select all, then Ctrl + C to copy all.
2. Make a new schematic in the same project and view the layout.
3. Paste the layout into the new schematic layout by choosing Edit > Paste Special > Paste Flatten to paste all.
4. Ensure everything is still selected, then choose Draw > Modify Shapes > Merge Shapes to perform the Boolean operations
of the positive, negative and normal layers.
5. Use the Connectivity Highlight function on this layout.
The following is an example CPW layout.
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With connectivity rules set up, only the signal conductors display, although this is not the correct connectivity.

The following figure shows the connectivity with the ground shapes using the previous steps outlined.

Multiple Technology Designs
The connectivity tracer functions in multiple technology projects. You must write special connectivity rules for each
individual technology to specify which layers define external connections. These special rules are discussed in
“Connectivity Rules”. The following figure shows a MMIC chip wire bonded onto a module.
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The connectivity shows the proper connection between the MMIC and the module in both the 2D and 3D views.

Currently the bond wires do not display in the 3D view.

5.3.3. Connectivity Rules
Connectivity Rules are stored in the LPF. For more information on working with LPF files, see “The Layout Process
File (LPF)”. You can add or edit rules in the Connectivity Highlight Rules window. To access this window, choose Verify
> Highlight Connectivity Rules from an active layout window.
For each rule, layer names are case sensitive and must be enclosed in quotes. The following examples use simple layer
names that you should replace with the proper drawing layers for the process.
• Connect "a"
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The simplest rule. Shapes on layer "a" are connected where they touch or overlap. Shapes on a layer do not highlight
unless there is one rule using that layer. You can use this rule if no other rule using that drawing layer exists. The
following figure shows a simple layout

that produces the following connectivity with this rule.

• Connect_All "a"
Shapes on layer "a" are connected whether they touch or overlap. A common scenario for this rule is for vias to a
ground on the top or bottom of a design where the ground shape is not drawn. The following figure shows a simple
layout

that produces the following connectivity with this rule.

• Connect "a" To "b"
Shapes on layer "a" are connected to shapes on layer "b" anywhere the shapes touch or overlap. The following figure
shows a simple layout
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that produces the following connectivity with this rule.

• Connect Overlap "a" To "b"
Shapes on layer "a" are connected to shapes on layer "b" anywhere the shapes only overlap. Notice the difference in
connectivity from the previous rule. The following figure shows a simple layout

that produces the following connectivity with this rule.
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• Connect "a" To "b" By "c"
Shapes on layer "a" are connected to shapes on layer "b" anywhere they touch or overlap and shape "c" is present. The
layer of "c" is also used in the connectivity check. The following figure shows a simple layout

that produces the following connectivity with this rule.

• Connect Touch "a" To "b" By "c"
Shapes on layer "a" are connected to shapes on layer "b" anywhere they touch or overlap with shape "c". The layer of
"c" is also used in the connectivity check. Notice the difference in connectivity from the previous rule. The following
figure shows a simple layout
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that produces the following connectivity with this rule.

• Connect "a" To "b" By Not "c"
Shapes on layer "a" are connected to shapes on layer "b" anywhere they touch and shape "c" is not present. The layer
of "c" is not used in the connectivity check. The following figure shows a simple layout
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that produces the following connectivity with this rule.

• Connect Overlap "a" To "b" By Not "c"
Shapes on layer "a" are connected to shapes on layer "b" anywhere they overlap and shape "c" is not present. The layer
of "c" is not used in the connectivity check. Notice the difference in connectivity from the previous rule. The following
figure shows a simple layout
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that produces the following connectivity with this rule.

• External_Connect "a" name
Shapes on layer "a" are assigned to an external connection layer named name, where name can be anything and is not
a current drawing layer. Notice that "a" is a layer name so it is enclosed in quotation marks, whereas name is not a
layer so it is not enclosed in quotes. If you have a second LPF file, and you have a layer "b", and want "b" to connect
to layer "a" of the first LPF file, you must include the following entry in your second LPF file:
External_Connect "b" name

5.3.4. Connectivity Rules Syntax Errors
The following sections show connectivity rules error scenarios.
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No Rules Defined
When you run the Connectivity Checker with no connectivity rules defined, a message box displays to indicate that there
are no rules defined.

Syntax Error in Rule Keywords
When you load a new LPF with connectivity rules any rule errors display in the Status Window. When the error is a
syntax error in the rule keywords, the error message lists the offending rule and shows where in the rule a problem was
first found.

In this case, no new rules in the LPF are imported. You should fix the rule error and import the rules again.
Drawing Layer Not Defined
When the error references a drawing layer that does not exists, the error message shows which layer is not correct. You
can either add or edit a drawing layer to use the missing name, or fix the layer name referenced in the rules file.

In this case, the new rules in the LPF are imported because you can fix the error by changing a drawing layer name.

5.4. Exporting the Layout
General layout export options are specified in the “Layout Options Dialog Box: Export/LPF Tab ”.
You can export a schematic layout (any layout generated from a schematic) as a GDSII file (hierarchical or flat), a DXF
file, a Gerber file, or a PADS geometry file. Exporting a layout generates a log file with statistics on the exported layout.
You can access this file via the Status Window. It is important to realize that this type of exporting of layout is different
from updating and saving artwork cells as discussed in “Artwork Cells”.
Before you can export a layout, there must be a file mapping available for the type of file (for example, GDSII or DXF).
You must create a different file mapping for each type of file that is output. You can create multiple file mappings so it
is possible to write some of the layers to one file, and other layers to another file (for example, when making CAD
drawings for individual mask layers). The file mapping for a GDSII layout cell is shown in the following figure.
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The file mapping is used to map drawing layers to layers in the output file. It can also be used to prevent certain layers
from being written to the file. It is important to note that the layer mapping in the drawing layer Options dialog box maps
model layers to drawing layers for the individual layout cell objects, while the file layers mapping (export mapping)
maps the drawing layers on which the layout objects are written in the output file. If a GDSII cell library is being used
and the exported layout needs to be on the same set of GDSII layers, the file mapping must be set up so that the drawing
layers that the GDSII cells are mapped to on the Layer Mapping tab are mapped to the same GDSII layer numbers in the
file (export) mapping. This GDSII layer mapping is shown in the previous figure.
You can export the layout starting at any level of the hierarchy by opening the Layout View window and choosing Layout
> Export Layout. When exporting a layout, there is an option for each file mapping table in the Save As Type list in the
Export Layout dialog box. The exported layout is for the active layout in the Layout View window.
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5.4.1. Setting Up Export File Mapping
You can set up file mapping in the LPF file or on the File Export Mappings section of the drawing layer Options dialog
box. To create a new file mapping, right-click File Export Mappings and choose New <format_name> File Export Mapping.
The check box for each layer specifies whether the layer is written or not for this file mapping.
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5.4.2. Exporting Unioned Polygons
Microwave Office software can automatically union touching polygons on the same layer when a layout file is exported.
This feature can be very useful when creating masks because many photo plotters require a closed polygon to make the
mask. Exporting unioned polygons eliminates the need to remove all intersecting lines in a particular layer. The following
figure shows the difference between a normal exported layout and one that is exported with a unioned layout that joins
together all the individual shapes that are created from the connecting layout cells.
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The option to union the shapes for each layer when exporting a layout is set by choosing Options > Layout Options (or
double-clicking Layout Options in the Layout Manager). This option is set on the Export/LPF tab of the Layout Options
dialog box by selecting the Union layout shapes check box in the Layout Export Options section.

5.4.3. Exporting Subcircuits as Instances
By default, the layout for a subcircuit is exported as an instance when exporting to a hierarchical GDSII or DXF file.
You can change this behavior by choosing Options > Layout Options to display the Layout Options dialog box, and then
clearing the Subcircuits as instances check box in the Layout Export Options section of the Export/LPF tab. When this
check box is cleared, only the layout cells that are implemented using artwork cells are written as instances. Clearing
this check box when the Union layout shapes check box is selected causes the shapes at different levels of the circuit
hierarchy to be unioned together (everything gets unioned except instances). This is useful for foundries so that FET
cells can be replaced with the foundry's FET cells, leaving the other artwork unchanged.
Artwork Instance Export Options
There are several options that control how GDSII artwork instances are exported to a file. The options are only used for
exporting hierarchical GDSII and most of the options concern how to handle multiple GDSII instances with the same
name. These options are selected from the Instance export options list on the Export/LPF tab of the Layout Options dialog
box (choose Options > Layout Options). These options are:
•

Do not change cell names: If there are multiple cells (from different libraries) that have the same cell name in a layout,

only one of the multiple instances is written to the GDSII file if this option is selected. This is a result of the restriction
that the cell instance names must be unique within the GDSII file, so by not allowing the name of the cell instance to
be changed, it is only possible to write one of the cells.
•

Append number to duplicates: This option allows multiple cell instances with the same name to be written into a single

GDSII file. This option automatically changes the name of cell instances that were previously written out by appending
a number preceded by an underscore. For example, if there is a CellA written, then another CellA is encountered that
needs to be written to the same file, the second instance of CellA is automatically renamed to CellA_1.
•

Append lib name to duplicates: This option allows multiple cell instances with the same name to be written into a single

GDSII file. This option automatically changes the name of cell instances that were previously written by appending
the name of the library from which the cell instance was located. For example, if there is a CellA from LibA written,
then another CellA from LibB is encountered that needs to be written to the same file, then the first instance is renamed
CellA_LibA and the second instance is renamed CellA_LibB.
•

Append lib name to all: This option appends the library name to all cell instances that are written. For example, a CellA

from LibA is renamed CellA_LibA even if there are no other cell instances named CellA.
Layout Cell Export Options
The following are the layout cell export options;
•

Export Flattened:

The layout cells are flattened when exported.

•

Export all as instances:

•

Export Specified as instance: Only the selected layout cells are written
Select cells to export as instances and select the cells from the list.

All the layout cells are written as instances.
as instances while others are flattened. Click
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5.4.4. Negative Layers
Microwave Office layout supports the concept of negative layers. These layers are typically used for CPW style layouts
or PCB layout with a ground flood needed. The basic concept is that lines draw their geometry, and additionally draw
some spacing to the ground plane on the same layers. When using negative layers, the following layers are used:
• Positive Layer: This layer is used in conjunction with negative layers. The idea is that negative layers subtract from
positive layers. Positive layers are created by appending a "+" character to a drawing layer name. For example,
"LayerA+" is the positive layer version of "LayerA".
• Negative Layer: This layer subtracts from positive layers. Negative layers are created by appending a "-" character to
a drawing layer name. For example, "LayerA-" is the negative layer version of "LayerA".
• Normal Layer: This drawing layer is not subtracted from by negative layers (it is not affected by Union layout shapes).
If the Merge layout shapes on +/- layers check box is selected (choose Options > Layout Options to display the Layout
Options dialog box, then click the Export/LPF tab) the subtraction and merging of positive and negative layers is
automatically performed upon layout export. The subtraction and merging is only done on export, so shapes on negative
layers draw like any other shape in the Layout View Editor. To make the shapes appear as though they are subtracting
each other, you can set up the ordering of the layers and the fill patterns so that the negative layers appear to subtract
from the positive layers as follows:
1. The positive layer needs to use the same fill pattern and color as the normal layer.
2. The negative layer needs to use the same fill pattern as the positive layer, except the chosen fill color needs to be the
same as the background.
3. You must order the layers so that the positive layer draws first. When the negative layer draws, it appears that it is
erasing the positive layer. The proper order is shown in the following figure.

NOTE: By default, when you view 3D layouts using these layers, the shapes do not look as clean as they can. With the
3D view open, choose View > Visual > Shapes Merged to merge the shapes for the 3D view. You cannot save this setting
in a project.
The following example shows how you can use negative layers to implement a cell for coplanar waveguide. The layer
shapes used to draw the ground plane are drawn on a positive layer, while the shapes used to draw the gaps use negative
layers. To simplify the implementation of the cell, the center conductors are drawn on normal layers on top of the
rectangles drawn on negative layers. The normal layers draw without alteration.
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The following figure displays the previous configuration after export with the Union layout shapes check box selected.

5.4.5. Exporting Coplanar Waveguide Layouts
When exporting a coplanar waveguide layout that uses negative layers, you should select the Union layout shapes check
box, and clear the Subcircuits as instances check box (see “Exporting Subcircuits as Instances ” for an explanation of
these options). Union layout shapes enables the shape merging and negative layer subtraction required to make the coplanar
waveguide cells export correct layouts. Subcircuits as instances needs to be deselected so that the merged and subtracted
layers span all levels of the hierarchy. For example, negative layers in lower level subcircuits need to be able to subtract
from shapes at higher levels.

5.4.6. Exporting Polygons with Cutouts
When exporting polygons with cutouts, the cutouts are processed away and the resulting polygons have cutlines. This
processing is required for formats that do not support cutouts like GDSII and DXF.

5.4.7. Reticle Creation
There are several different methods you can use to create a layout mask that contains a number of other circuit layouts
(a reticle). The preferred method of building a reticle is described in this section. Cadence recommends that the reticle
be assembled in the Layout View Editor and not the Artwork Cell Editor because there are more options for exporting
the layout when using the Layout View Editor libraries saved from the Layout Manager window. (See “Layout Editing”
for more information about the Editors.) The libraries assembled with the Artwork Cell Editor do not include layout cells
from other libraries. To merge layout cells from multiple libraries, you must export the layout from the Layout View
Editor. An alternative method of assembling the reticle is to build it in the Artwork Cell Editor as one large artwork cell,
and then drag that artwork cell into the Layout View Editor and export the reticle from there.
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The first step in creating a reticle is to create an empty schematic and open the layout of the schematic (choose View >
View Layout).
If the circuit to be added to the reticle is in the same project, add a subcircuit instance of the circuit in the empty schematic
so that the entire layout of the circuit displays in the layout window. You can repeat this for any other circuits you need
to add from the project.
If the layout of a circuit that is to be added to the reticle is located in an external GDSII file, then import the GDSII file
as a library in the Layout Manager. See “Loading Artwork Cell Libraries” for more information on importing files. When
importing the external files, it is important that the layer mapping is set up correctly so that the imported GDSII layers
are written to the correct layers when imported. See “Drawing Layers and Model Layer Mapping” for more information
on setting up the layer mapping for importing GDSII files. After the GDSII library is correctly imported into the Layout
Manager, you can add any instance in the imported library to the reticle from the Layout Manager window. To do this,
select the imported GDSII library in the Layout Manager, and then drag and drop the desired cell into the Layout View
Editor window from the lower pane of the Layout Manager window. See “Layout Manager” for more information on
the use of the Layout Manager.
After the desired circuits and artwork cells are placed into the Layout View window you can position them to form a
reticle. The use of gravity points and/or coordinate entry can greatly simplify the positioning of circuit layouts within
the reticle. See “Gravity Points” and “Coordinate Entry” for more information.
After the reticle is assembled in the Layout View Editor you can export it as described in “Exporting the Layout ”.

5–42 AWR Design Environment

Index
A
Airbridge drawing object, 4–29
Alignment tools, 3–59
Anchor, 3–8
Anchoring layout cell, 3–8
Area pins, 3–145
Array
copying, 3–51
Artwork
cell libraries, 3–18, 3–146
Artwork Cell Editor, 3–21, 3–22
Artwork cells, 2–3, 3–144
assigning to layout, 3–148
creating libraries, 3–146
editing, 3–144
libraries, 3–146
loading libraries, 3–147
re-associating, 3–148
saving, 3–145
stretching, 3–145

B
Bend; adding, 3–62

C
Cell
artwork, 2–3, 3–144
connections, 3–148
definition; multi-layer, 3–149
faces, 3–152, 3–155
flattening, 3–146
multi-layer, 3–155
properties, 3–148
user-defined, 2–3
Cell Options dialog box, 3–149
Cell Stretcher, 3–145
Circuit
symmetric, 3–73
Command
repeat mode, 3–35
Connectivity
highlight, 5–21
rules definition, 4–30
Connectivity Checker, 5–15, 5–16
ground connection, 5–19
short, 5–16
unsupported items, 5–21
Coordinate entry drawing, 3–55

Coplanar waveguide
exporting, 5–41
Copying
arrays, 3–51

D
Database, 2–1
unit size, 4–2
Design rule checking, 5–1
cell based checking, 5–2
GDSII compare, 5–11
polygon based checking, 5–3
database unit, 5–4
display rule violations, 5–8
error tolerance, 5–3
extension rule, 5–5
jog rule, 5–5
maximum side length rule, 5–6
maximum vertices rule, 5–6
merge errors, 5–4
minimum angle rule, 5–6
minimum polygon area, 5–6
minimum width rule, 5–4
notch rule, 5–5
overlap rule, 5–5
polygon holes rule, 5–6
polygon on grid rule, 5–6
resize polygons rule, 5–6
rules file, 5–3
separation rule, 5–4
Dimension line, 3–58
Documentation; AWR, 1–1
Draw tools, 3–22
Draw Tools toolbar, 3–22
DRC (design rule checking), 5–1
DRC rules file, 4–30

E
Electrical (iNet) elements, 3–74
EM Layout Editor, 3–21
Exporting
GDSII artwork instances, 5–39
layouts, 5–35, 5–41, 5–41

F
Face options, 3–152, 3–154
File mapping, 5–37
Flattening cells, 3–146
Floating metal, 5–18
Freeze, 3–8

AWR Microwave Office Layout Guide Index–1

Index
Freezing layout cells, 3–8

G
GDSII
importing libraries, 4–20
layer conventions, 4–20
layer mapping, 4–19
layout cells, 4–20
Gravity points, 3–36
Grid
drawing, 4–2
options, 4–2
snap, 3–29
spacing, 4–3
Grouping objects, 3–59

H
Help
context sensitive, 1–3
online, 1–3

I
iCells, 3–60
generalized, 3–62
standard, 3–60
user defined, 3–61
iNet elements, 3–74
Intelligent cells, 3–60

L
Layer
mapping, 3–151, 4–12, 4–18
negative, 5–40
setup, 4–18
Layout
alignment tools, 3–59
artwork cell libraries
creating, 3–146
loading, 3–147
artwork cells, 3–22, 3–144
cell, 2–2
connections, 3–148
faces, 3–152
flattening, 3–146
line type, 3–149
local parameters, 3–155
options, 3–155
parameterized, 3–146
properties, 3–148
snap options, 4–4

Index–2 AWR Design Environment

configuration, 4–1
connectivity checking, 5–15
connectivity highlight, 5–21
coordinate entry, 3–55
creating layer mapping, 4–18
design rule checking, 5–1
draw tools, 3–22
3D clip area, 3–27
add text, 3–25
circle, 3–24
drill hole, 3–27
ellipse, 3–24
path, 3–24
polygon, 3–25
rectangle, 3–25
drawing grid, 4–2
edit modes, 3–29
changing multiple object properties, 3–30
Command Repeat Mode, 3–35
Copy with Reference, 3–32
gravity points, 3–36
grid snap, 3–29
multiple selection, 3–30
orthogonal, 3–29
Reference Copy, 3–32
Reference Move, 3–30
rotation and flipping, 3–37
shape selection, 3–29
editing, 3–1, 3–21, 3–22
artwork cells, 3–22
editors, 3–21
export, 5–1
exporting, 5–35
coplanar waveguide, 5–41
cutouts, 5–41
instance options, 5–39
polygons, 5–38
subcircuits, 5–39
file mapping, 5–37
fundamentals, 2–3
GDSII
importing libraries, 4–20
layer conventions, 4–20
layer mapping, 4–19
layout cells, 4–20
grouping, 3–59
iCells, 3–60
generalized, 3–62
standard, 3–60
user defined, 3–61
intelligent cells, 3–60

Index
layer mapping, 4–12
Layout Manager, 3–13
layout process file, 4–20
libraries, 2–2
mapping model layers, 4–16
mask creation, 5–41
model layer conventions, 4–17
multi-layer cell definition, 3–149
object placement, 3–10
options, 4–1
overview, 2–1
panning in Layout View, 3–58
placement mirroring, 3–129
polygon editing, 3–37
area stretching, 3–51
points and edges, 3–38
reticle creation, 5–41
ruler, 3–57
schematic database view, 2–1
shape edge selection, 3–34
shape mirroring, 3–52
shape modification, 3–53
shape modifiers, 3–131, 3–131
shape placement, 3–1
snap to fit, 3–72
snapping cells, 3–5
symmetric circuits, 3–73
TRACE elements, 3–62
adding a bend, 3–62
adding additional bends, 3–68
moving bends, 3–63, 3–66
rotating segments, 3–69
TRACE routing, 3–70
verification, 5–1
vs schematic, 3–11
vs. schematic, 5–12
zooming in Layout View, 3–58
Layout Manager, 3–13
libraries, 3–20
Layout Options dialog box
Layout Tab, 4–1
Layout process file, 4–20
airbridge drawing object selection, 4–29
capacitor definitions, 4–26
connectivity rules definition, 4–30
default layout font, 4–30
default units, 4–23
default values, 4–23
dielectric layers definition, 4–34
drawing layers properties, 4–31
drawing resolution settings, 4–24

DRC rules file, 4–30
EM enclosure size, 4–34
EM layer mapping properties, 4–32
layer mapping properties, 4–31
line type definitions, 4–24
PAD definitions, 4–27
pCell line drawing, 4–28
structure type definitions, 4–26
User defined fill patterns, 4–32
via definitions, 4–27
Layout View, 2–1, 3–1
Layout View Editor, 3–21, 3–22
options, 4–1
Libraries
artwork, 3–18
layout, 2–2
Line type editing
PDK line type, 4–24
Line type; layout cell, 3–149
Local
cell parameters, 3–155
LPF file, 4–20
LVS, 5–12

M
Mapping model layers, 4–16
MCTRACE, 3–56, 3–62, 3–151
Measuring
tools, 3–57
Merge
Shapes, 3–52
Minimum spacing routing guides, 3–82
Mirroring shapes, 3–52
Model layer naming, 4–17
Modifiers
shape and layout, 3–131
MTRACE, 3–56, 3–62
Multiple object selection, 3–30

N
Negative
layers, 5–40
Notches; creating, 3–52

O
Object selection
multiple, 3–30
restricted, 3–37
Online Help, 1–3
Orthogonal editing, 3–29

AWR Microwave Office Layout Guide Index–3

Index

P

V

Panning options, 3–58
Parameterized
layout cells, 3–146
Placement mirroring, 3–129
Polygons
adding, 3–37
editing points and edges, 3–38
exporting merged, 5–38
moving points or edges, 3–38
notches, 3–52
shape modification, 3–53
slicing, 3–52
stretching, 3–51

Variables
face setting, 3–152
Via fence, 3–142
Via fill, 3–142
Viewing
options, 3–58

R
Restricted object selection, 3–37
Reticles, 5–41
Routing nets
Minimum spacing routing guides, 3–82
Rulers, 3–57

S
Saving
artwork cells, 3–145
Schematic View, 2–1, 3–1
Shape
mirroring, 3–52
Shape edge selection, 3–34
Snap to fit, 3–72, 3–99, 3–104
Snapping layout cells, 3–5, 4–4
Standard ruler, 3–57
Symbol color, 3–1
Symmetric circuits, 3–73

T
Toolbars; customizing, 3–22
Tools
drawing, 3–22
measuring, 3–57
TRACE, 3–56
routing, 3–70
TRACE element, 3–62, 3–151
editing, 3–62
MCTRACE, 3–62
Typographical conventions, 1–2

U
Unioned polygons; exporting, 5–38

Index–4 AWR Design Environment

Z
Zooming in Layout View, 3–58

