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Chapter 1. Introduction
The following AWR Design Environment Getting Started Guides are available:
• The Microwave Office Getting Started Guide provides step-by-step examples that show you how to use Microwave
Office software to create circuit designs.
• The AWR Analyst Getting Started Guide provides step-by-step examples that show you how to use Analyst software
to create and simulate 3D EM structures from the Microwave Office program.
• Microwave Office MMIC Getting Started Guide provides step-by-step examples that show you Monolithic Microwave
Integrated Circuit (MMIC) features and designs.
• AWR Visual System Simulator Getting Started Guide provides step-by-step examples that show you how to use VSS
software to create system simulations and to incorporate Microwave Office software circuit designs.
To set up the AWR Design Environment software for PCB style design, choose Tools > Create New Process to display
the Create New Process dialog box, then click the Help button for details on using this tool.

Introducing the AWR Design Environment Platform
This platform comprises two powerful tools that can be used together to create an integrated system or RF design
environment: VSS and Microwave Office software. These powerful tools are fully integrated in the AWR Design
Environment platform and allow you to incorporate circuit designs into system designs without leaving the design
environment.
VSS software enables you to design and analyze end-to-end communication systems. You can design systems composed
of modulated signals, encoding schemes, channel blocks and system level performance measurements. You can perform
simulations using the VSS software predefined transmitters and receivers, or you can build customized transmitters and
receivers from basic blocks. Based on your analysis needs, you can display BER curves, ACPR measurements,
constellations, and power spectrums, to name a few. VSS software provides a real-time tuner that allows you to tune the
designs and then see your changes immediately in the data display.
Microwave Office software enables you to design circuits composed of schematics and electromagnetic (EM) structures
from an extensive electrical model database, and then generate layout representations of these designs. You can perform
simulations using any of the Cadence AWR simulation engines, such as a linear simulator; the Cadence APLAC® HB
simulator for nonlinear frequency-domain simulation and analysis; the AXIEM 3D-planar EM simulator; the Analyst
3D-FEM simulator; or transient circuit simulators (the APLAC transient simulator or an optional Spectre simulator), and
display the output in a wide variety of graphical forms based on your analysis needs. You can then tune or optimize the
designs and your changes are automatically and immediately reflected in the layout. Statistical analysis allows you to
analyze responses based on statistically varying design components.
The tool set spans the entire IC design flow, from system-level to circuit-level design and verification, including design
entry and schematic capture, time- and frequency-domain simulation and analysis, physical layout with automated
device-level place and route and integrated design rule checker (DRC), and a comprehensive set of waveform display
and analysis capabilities supporting complex RF measurements.
OBJECT ORIENTED TECHNOLOGY
At the core of the AWR Design Environment platform capability is advanced object-oriented technology. This technology
results in software that is compact, fast, reliable, and easily enhanced with new technology as it becomes available.
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About This Guide

About This Guide
Through working examples, this Getting Started Guide is designed to familiarize you with Microwave Office, VSS, and
Analyst software; and MMIC capabilities.

Prerequisites
You should be familiar with Microsoft® Windows® and have a working knowledge of basic circuit and/or system design
and analysis.
This document is available as a download from the Cadence AWR Knowledge Base.
If you are viewing this guide as online Help and intend to work through the examples, you can download and print out
the PDF version for ease of use.

Contents of this Guide
Chapter 2 provides an overview of the AWR Design Environment platform including the basic menus, windows,
components and commands.
In the Microwave Office Getting Started Guide the subsequent chapters take you through hands-on examples that show
you how to use Microwave Office software to create circuit designs including layout and AXIEM 3D planar EM layout
and simulation.
In the Analyst Getting Started Guide the subsequent chapters take you through hands-on examples that show use of the
Analyst 3D Electromagnetic simulator for 3D EM simulation within Microwave Office software. Use of 3D parametric
layout cells and a 3D Layout Editor is included.
In the Microwave Office MMIC Getting Started Guide the subsequent chapters take you through hands-on examples that
allow you to work with Monolithic Microwave Integrated Circuit (MMIC) features and designs.
In the AWR Visual System Simulator Getting Started Guide the subsequent chapters take you through hands-on examples
that show you how to use VSS software to create system simulations and to incorporate Microwave Office software
circuit designs.

Conventions Used in This Guide
This guide uses the following typographical conventions:
Item

Convention

Anything that you select (or click on) in the AWR Design Shown in a bold alternate font. Nested menu selections are
Environment program, such as menus, nested submenus, shown with a ">" to indicate that you select the first menu
menu options, dialog box options, buttons, and tab names item and then select the submenu item:
Choose File > New Project.
Text that you enter using the keyboard

Shown in a bold within quotation marks:
Enter "my_project" in Project Name.

Keys or key combinations that you press

1–2 AWR Design Environment

Shown in a bold alternate font with initial capitals. Key
combinations using a "+" indicate that you press and hold
the first key while pressing the second key:

Getting Additional Information
Item

Convention
Press Alt+F1.

File names and directory paths

Shown in italics:
See the DEFAULTS.LPF file.

Getting Additional Information
There are multiple resources available for additional information and technical support for Cadence products.

Cadence AWR Knowledge Base
The Cadence AWR Knowledge Base includes these and other resources:
• Application Notes - Technical papers on various topics written by Cadence or our partners.
• Examples - Pages explaining project examples in the installed software or available for download.
• Licensing - A step-by-step guide to resolving most licensing problems.
• Questions - Frequently Asked Questions (FAQs) and answers for common customer issues.
• Scripts - Scripted utilities to help solve specific problems.
• Documentation - Downloadable copies of the latest released documentation.
• Videos - Short technical videos on how to accomplish specific tasks.

Documentation
Documentation for the AWR Design Environment platform includes:
• What's New in AWR Design Environment v22.1? presents the new or enhanced features, elements, system blocks, and
measurements for the current release. This document is available in the Help by clicking the Windows Start button
and choosing AWRDE 22.1 > AWR Design Environment Help and then expanding the Cadence AWR Design Environment
node on the Contents tab, or by choosing Help > What's New while in the program.
• The AWR Design Environment Installation Guide describes how to install the AWR Design Environment platform
and configure it for locked or floating licensing options. It also provides licensing configuration troubleshooting tips.
This document is downloadable from the Cadence AWR Knowledge Base.
• The AWR Design Environment User Guide provides an overview of the AWR Design Environment platform including
chapters on the user interface; using schematics/system diagrams, data files, netlists, graphs, measurements, and output
files; using variables and equations in projects, and more. In addition, an appendix providing guidelines for starting a
new design is included.
• The AWR Design Environment Simulation and Analysis Guide discusses simulation basics such as swept parameter
analysis, tuning/optimizing/yield, and simulation filters; and provides simulation details for DC, linear, AC, harmonic
balance, transient, and EM simulation/extraction theory and methods.
• The AWR Design Environment Dialog Box Reference provides a reference of many program dialog boxes with dialog
box graphics, overviews, option details, and information on how to access each dialog box.
• The AWR API Scripting Guide explains the basic concepts of AWR Design Environment scripting and includes coding
examples. It also provides information on the most useful objects, properties, and methods for creating scripts in the
AWR Script Development Environment (AWR SDE). In addition, this guide contains the AWR Design Environment
Component API list.
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• The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your use
of the AWR Design Environment platform. This document is available within the program by choosing Help > Quick
Reference. This is an excellent document to print and keep handy at your desk.
• Context sensitive Help is available for most operations or phases of design creation. To view an associated Help topic,
press the F1 key during design creation.
Documentation for Microwave Office software includes:
• The AWR Microwave Office Layout Guide, which contains information on creating and viewing layouts for schematics
and EM structures, including use of the Layout Manager, Layout Process File, artwork cell creation/editing/properties,
Design Rule Checking, and other topics.
• The AWR Microwave Office Element Catalog, which provides complete reference information on all of the electrical
elements that you use to build schematics.
• The AWR Microwave Office Measurement Catalog, which provides complete reference information on the
"measurements" (for example, computed data such as gain, noise, power, or voltage) that you can choose as output
for your simulations.
Documentation for VSS software includes:
• The AWR Visual System Simulator System Block Catalog, which provides complete reference information on all of
the system blocks that you use to build systems.
• The AWR Visual System Simulator Measurement Catalog, which provides complete reference information on the
measurements you can choose as output for your simulations.
• The AWR Visual System Simulator Modeling Guide, which contains information on simulation basics, RF modeling
capabilities, and noise modeling.
Documentation for the 3D Editor and Cadence Analyst™-MP multi-physics simulator (stand-alone product for
multi-physics types of EM problems) includes:
• The What's New in Analyst-MP v22.1 (Analyst_Whats_New.pdf), which presents the new or enhanced features for
both the 3D Layout Editor and Analyst-MP simulator software.
• The Analyst-MP Getting Started Guide (Analyst_Getting_Started.pdf), which provides step-by-step examples that
show you how to use Analyst-MP simulator software.
• The Analyst User Guide (Analyst_User_Guide.pdf), which provides an overview of the 3D Editor and Analyst-MP
simulator software; including chapters on the user interface, structures, simulations, post-processing, variables, data
files, and scripting.

Online Help
All AWR Design Environment documentation is available as on-line Help.
To access online Help, choose Help from the menu bar or press F1 anywhere in the program. Context sensitive help is
available for elements and system blocks in the Elements Browser and within schematics or system diagrams, and for
measurements from the Add/Modify Measurement dialog box.

Online Support
The Cadence Learning and Support System is available from the Cadence Support website. You can navigate to this site
from the AWR Design Environment platform by choosing Help > Get Technical Support.
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Chapter 2. AWR Design Environment Platform
The basic design flow in the Cadence® AWR Design Environment® platform is shown in the following flow chart.
Create Project
File > New Project or File > New with Library

Set Units, Environment Options
Options > Project Options
Create Schematics/Diagrams
Project > Add Schem./Sys. Diagram
View > View Schematic

(Microwave Office) Create Layout
View > View Layout

Set Frequency, Simulation Options
(Microwave Office) Options > Def. Circuit Options
(VSS) Options > Def. System Options

Create Graphs/Measurements
Project > Add Graph
Project > Add Measurement

Simulate Circuit
(Microwave Office) Simulate > Analyze
(VSS) Simulate > Run Sys. Sim.
(Microwave Office) Optimizing
Simulate > Optimize

Tuning
Simulate > Tune

Set Optimization Goals

Manually Vary Parameters

Project > Add Opt Goal

Simulate > Tune Tool

Automatically:

Automatically:

*Updates Schem./Sys. Diagrams

*Updates Schem./Sys. Diagrams

*(Microwave Office) Updates Layout

*(Microwave Office) Updates Layout

*Simulates

*Simulates

*Updates Results/Graphs

*Updates Results/Graphs

This chapter describes the windows, menus and basic operations for performing the following tasks in the AWR Design
Environment platform:
• Creating projects to organize and save your designs
• Creating system diagrams, circuit schematics, and EM structures
• Placing circuit elements into schematics
• Placing system blocks into system diagrams
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• Incorporating subcircuits into system diagrams and schematics
• Creating layouts
• Creating and displaying output graphs
• Running simulations for schematics and system diagrams
• Tuning simulations
NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Starting AWR Software Programs
To start the AWR Design Environment platform:
1. Click the Windows Start button.
2. Choose All Programs > AWRDE 22.1 > AWR Design Environment 22.1.
The following main window displays.

2–2 AWR Design Environment

AWR Design Environment Platform Components

Title bar
Menu bar
Toolbar
Project Browser

System diagrams
Circuit schematics
Workspace

Tabs
Status Window
Status bar
If the AWR Design Environment platform was not configured during installation to display in your Start menu, start the
application by double-clicking the This PC icon on your desktop, opening the drive and folder where you installed the
program, and double-clicking on MWOffice.exe, the AWR Design Environment platform application.

AWR Design Environment Platform Components
The AWR Design Environment platform contains the windows, components, menu selections and tools you need to
create linear and nonlinear schematics, set up EM structures, generate circuit layouts, create system diagrams, perform
simulations, and display graphs. Most of the basic procedures apply to Cadence Microwave Office® software, Cadence
Visual System Simulator™ and (VSS) communications and radar systems design software. The major components of
the AWR Design Environment platform are:
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Component

Description

Title bar

The title bar displays the name of the open project and any Process Design Kit (PDK) used with
the project.

Menu bar

The menu bar comprises the set of menus located along the top of the window for performing
a variety of Microwave Office and VSS tasks.

Toolbar

The toolbar is the row of buttons located just below the menu bar that provides shortcuts to
frequently used commands such as creating new schematics, performing simulations, or tuning
parameter values or variables. The buttons available depend on the functions in use and the
active window within the design environment (as well as any customization of toolbar button
groups). Position the cursor over a button to view the button name/function.

Workspace

The workspace is the area in which you design schematics and diagrams, draw EM structures,
view and edit layouts, and view graphs. You can use the scrollbars to move around the workspace.
You can also use the zoom in and zoom out options from the View menu.

Project Browser
(Project tab)

Located by default in the left column of the window, this is the complete collection of data and
components that define the currently active project. Items are organized into a tree-like structure
of nodes and include schematics, system diagrams and EM structures, simulation frequency
settings, output graphs, user folders and more. The Project Browser is active when the AWR
Design Environment platform first opens, or when you click the Project tab. Right-click a node
in the Project Browser to access menus of relevant commands.

Elements Browser
(Elements tab)

The Elements Browser contains a comprehensive inventory of circuit elements for building your
schematics, and system blocks for building system diagrams for simulations. The Elements
Browser displays by default in the left column in place of the Project Browser when you click
the Elements tab.

Layout Manager
(Layout tab)

The Layout Manager contains options for viewing and drawing layout representations, creating
new layout cells, and working with artwork cell libraries. The Layout Manager displays by
default in the left column in place of the Project Browser when you click the Layout tab.

Status Window (Status The Status Window displays error, warning, and informational messages about the current
Window tab)
operation or simulation. The Status Window displays by default at the bottom of the workspace
when you click the Status Window tab.
Status bar

The bar along the very bottom of the design environment window that displays information
dependent on what is highlighted. For example, when an element in a schematic is selected, the
element name and ID displays. When a polygon is selected, layer and size information displays,
and when a trace on a graph is selected, the value of a swept parameter displays.

You can invoke many of the functions and commands from the menus and on the toolbar, and in some cases by
right-clicking a node in the Project Browser. This guide may not describe all of the ways to invoke a specific task.

Basic Operations
This section highlights the windows, menu choices, and commands available for creating simulation designs and projects
in the AWR Design Environment platform. Detailed use information is provided in the chapters that follow.

Working with Projects
The first step in building and simulating a design is to create a project. You use a project to organize and manage your
designs and everything associated with them in a tree-like structure.
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Project Contents
Because Microwave Office software and VSS software are fully integrated in the AWR Design Environment platform,
you can start a project based on a system design using VSS software, or on a circuit design using Microwave Office
software. The project may ultimately combine all elements. You can view all of the components and elements in the
project in the Project Browser. Modifications are automatically reflected in the relevant elements.
A project can include any set of designs and one or more linear schematics, nonlinear schematics, EM structures, or
system level blocks. A project can include anything associated with the designs, such as global parameter values, imported
files, layout views, and output graphs.
Creating, Opening, and Saving Projects
When you first start the AWR Design Environment platform, a default empty project titled "Untitled Project" is loaded.
Only one project can be active at a time. The name of the active project displays in the main window title bar.
After you create (name) a project, you can create your designs. You can perform simulations to analyze the designs and
see the results on a variety of graphical forms. Then, you can tune or optimize parameter values and variables as needed
to achieve the desired response. You can generate layout representations of the designs, and output the layout to a DXF,
GDSII, or Gerber file. See Appendix B, New Design Considerations in AWR Design Environment User Guide in the
AWR Design Environment User Guide for advanced guidelines on starting a new design. You can also transfer technology
and design information with Virtuoso and DE-HDL/Allegro platforms through a Cadence Unified Library. See Appendix E,
AWR Design Environment Interoperability with Virtuoso and Allegro in AWR Design Environment User Guide in the
AWR Design Environment User Guide for details.
To create a project choose File > New Project. Name the new project and the directory you want to write it to by choosing
File > Save Project As. The project name displays in the title bar.
To open an existing project, choose File > Open Project. To save the current project, choose File > Save Project. When you
save a project, everything associated with it is automatically saved. Cadence AWR® projects are saved as *.emp files.
Opening Example Projects
Cadence provides a number of project examples (*.emp files) in the installation directory to demonstrate key concepts,
program functions and features, and show use of specific elements.
To search for and open example projects referenced in this guide:
1. Choose File > Open Example.
The Open Example Project dialog box displays with columns for the project name and keywords associated with each
example project.
2. Filter the list using "getting_started" as a keyword by Ctrl-clicking the Keywords column header and typing
"getting_started" in the text box at the bottom of the dialog box.
As shown in the following figure, the example list is filtered to display only those projects that have the "getting_started"
keyword associated with them.
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NOTE: You can filter examples by keyword or by file name. An inverted triangle in the column header indicates the
column on which your search is filtered. Press the Ctrl key while clicking a column header to change which column is
used to filter.
Importing Test Benches
Cadence provides several test bench examples that can serve as design guides for various applications such as mixers,
amplifiers, and oscillators. These test benches are set up for import into your working project.
To import a test bench into your project:
1. Choose File > Import Project.
2. Browse to C:\Program Files\AWR\AWRDE\22.1\Examples\ or C:\Program Files (x86)\AWR\AWRDE\22.1\Examples\
and import the desired test bench. The test bench project file names are prefaced with "TESTBENCH" as shown in
the following figure.

2–6 AWR Design Environment
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Working with Schematics and Netlists in Microwave Office
A schematic is a graphical representation of a circuit, while a netlist is a text-based description.
To create a schematic, right-click Circuit Schematics in the Project Browser, choose New Schematic, and then specify a
schematic name.
To create a netlist, right-click Netlists in the Project Browser, choose New Netlist, and then specify a netlist name and
type.
After you name the schematic or netlist, a window for it opens in the workspace and the Project Browser displays the
new item as a subnode under Circuit Schematics or Netlists. In addition, the menu bar and toolbar display new command
choices and buttons particular to building and simulating schematics or netlists.
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Adding Data to Netlists
When you create a netlist, an empty netlist window opens into which you type a text-based description of a schematic.
Netlist data is arranged in blocks in a particular order, where each block defines a different attribute of an element such
as units, equations, or element connections. For more information about creating netlists, see “Creating a Netlist” in AWR
Design Environment User Guide.

Working with System Diagrams in VSS
To create a system diagram, right-click System Diagrams in the Project Browser and choose New System Diagram, and
then specify a system diagram name.
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After you name the system diagram, a window for it opens in the workspace and the Project Browser displays the new
item as a subnode under System Diagrams. In addition, the menu bar and toolbar display new command choices and
buttons particular to building and simulating systems.

Connecting Element and System Block Nodes
You can connect elements or system blocks directly by positioning them so their nodes touch. Small green boxes display
to indicate the connection. You can also connect elements with wires.
• To connect element or system block nodes with a wire, position the cursor over a node. The cursor displays as a wire
coil symbol. Click at this position to mark the beginning of the wire and drag the mouse to a location where a bend is
needed. Click again to mark the bend point. You can make multiple bends.
• Right-click to undo the last wire segment added.
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• To start a wire from another wire, select the wire, right-click and choose Add wire, then click to mark the beginning
of the wire.
• To terminate a wire, click on another element node or on top of another wire.
• To cancel a wire, press the Esc key.
• When placing or positioning an element, alignment guidelines automatically display when the element nodes align
with another element. To automatically add a wire between the nodes, press the Shift key when placing the element.

Using the Elements Browser
The Elements Browser gives you access to a comprehensive database of hierarchical groups of circuit elements for
schematics and system blocks for system diagrams. The Libraries folder in the Elements Browser provides a wide range
of electrical models and S-parameter files from manufacturers.
Circuit elements include models, sources, ports, probes, measurement devices, data libraries, and model libraries that
can be placed in a circuit schematic for linear and non-linear simulations.
System blocks include channels, math tools, meters, subcircuits, and other models for system simulations.
• To view elements or system blocks, click the Elements tab. The Elements Browser replaces the Project Browser
window.
• To expand and collapse the model categories, click the + or - symbol to the left of the category name to view or hide
its subcategories. When you click on a category/subcategory, the available models display in the lower window pane.
If there are more models than the window can show, a vertical scroll bar displays to allow you to scroll down to see
all of the models.
• To place a model into a schematic or system diagram, simply click and drag it into the window, release the mouse
button, right-click to rotate it if needed, position it, and click to place it.
• To edit model parameters, double-click the element graphic in the schematic or system diagram window. An Element
Options dialog box displays for you to specify new parameter values. You can also edit individual parameter values
by double-clicking the value in the schematic or system diagram and entering a new value in the text box that displays.
Press the Tab key to move to the next parameter when editing.

2–10 AWR Design Environment

Basic Operations

Expand, then click
desired subcategory

Buttons for adding
ground and ports

Drag the desired
model into schematic
or system diagram
window

Elements tab diplays the
Elements Browser

NOTE: Choose Draw > More Elements to display the Add Circuit Element or Add System Block dialog box to search for
elements. Press the Ctrl key while clicking a column header to change which column is used to filter.
Adding Subcircuits to Schematics
Subcircuits allow you to construct hierarchical circuits by including a subcircuit block in a schematic (insert a schematic
inside of another schematic). The circuit block can be a schematic, a netlist, an EM structure, or a data file.
• To add a subcircuit to a schematic, click Subcircuits in the Elements Browser. The available subcircuits display in the
lower window pane. These include all of the schematics, netlists, and EM structures associated with the project, as
well as any imported data files defined for the project.
• To use a data file as a subcircuit, you must first create or add it to the project. To create a new data file, choose Project
> Add Data File > New Data File. To import an existing data file, choose Project > Add Data File > Import Data File. Any
new or imported data files automatically display in the list of available subcircuits in the Elements Browser.
• To place the desired subcircuit, simply click it and drag it into the schematic window, release the mouse button, position
it, and click to place it.
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• To edit subcircuit parameters, select the subcircuit in the schematic window, right-click, and choose Edit Subcircuit.
Either a schematic, netlist, EM structure, or data file opens in the workspace. You can edit it in the same way that you
would edit the individual circuit block types.
Adding Subcircuits to System Diagrams
Subcircuits allow you to construct hierarchical systems and to import results of circuit simulation directly into the system
block diagram.
• To create a subcircuit to a system diagram, choose Project > Add System Diagram > New System Diagram or Import
System Diagram and then click Subcircuits under System Blocks in the Element Browser. The available subcircuits
display in the lower window pane.
• To place the desired subcircuit, simply click and drag it into the system diagram window, release the mouse button,
position it, and click to place it.
• To edit subcircuit parameters, select the subcircuit in the system diagram window, right-click, and choose Edit Subcircuit.
• To add a system diagram as a subcircuit to another system diagram, you must first add ports to the system that is
designated as a subcircuit.
Adding Ports to Schematics and System Diagrams
To add ports to a schematic or system diagram, expand the Ports category in the Elements Browser. Under Circuit Elements
or System Blocks, click Ports or one of its subgroups, for example, Harmonic Balance. The available models display in
the lower window pane.
Drag the port into the schematic or system diagram window, right-click to rotate it if needed, position it, and click to
place it.
For a shortcut when placing ports and ground, click the Ground or Port buttons on the toolbar, position the ground or
port, and click to place it.
To edit port parameters, double-click the port in the schematic or system diagram window to display an Element Options
dialog box.
NOTE: You can change the port type after placing it by double-clicking the port and selecting a Port type on the Port
tab of the dialog box.

Creating EM Structures
EM structures are arbitrary multi-layered electrical structures such as spiral inductors with air bridges.
To create an EM structure, right-click the EM Structures node in the Project Browser, and choose New EM Structure.
After you specify an EM structure name and select a simulator, an EM structure window opens in the workspace and
the Project Browser displays the new EM structure under EM Structures. In addition, the menu and toolbar display new
choices particular to drawing and simulating EM structures.
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NOTE: The EM structure examples presented in this guide use Cadence AXIEM® 3D planar EM analysis.
Adding EM Structure Drawings
Before you draw an EM structure, you must define an enclosure. The enclosure specifies things such as boundary
conditions and dielectric materials for each layer of the structure.
To define an enclosure, double-click Enclosure under your new EM structure in the Project Browser to display a dialog
box in which you can specify the required information.
After you define the enclosure, you can draw components such as rectangular conductors, vias, and edge ports in the
Layout Manager.
You can view EM structures in 2D (double-click the EM structure node in the Project Browser) and 3D (right-click the
EM structure node in the Project Browser and choose View 3D EM Layout), and you can view currents and electrical fields
using the Animate buttons on the EM 3D Layout toolbar.
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Creating a Layout with Microwave Office
A layout is a view of the physical representation of a circuit, in which each component of the schematic is represented
by a layout cell. In the object-oriented AWR Design Environment platform software, layouts are tightly integrated with
the schematics and EM structures that they represent, and are simply another view of the same circuits. Any modifications
to a schematic or EM structure are automatically and instantly reflected in their corresponding layouts.
To create a layout representation of a schematic, click the schematic window to make it active, then choose View > Layout.
A layout window tab opens with an automatically-generated layout view of the schematic.
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With a schematic window active, you can also click the View Layout button on the toolbar to view the layout of a schematic.

The resulting layout contains layout cells representing electrical components floating in the layout window. Choose Edit
> Select All then choose Edit > Snap Objects > Snap Together to snap the faces of the layout cells together. The following
figure shows the layout view from the previous figure after a snap together operation.

When you choose View > View Layout, corresponding schematic components with default layout cells are automatically
generated for common electrical components such as microstrip, coplanar waveguide, and stripline elements. After the
layout is generated, the schematic window displays in blue the components that do not map to default layout cells, and
displays in magenta the components that do have default layout cells. You must use the Layout Manager to create or
import layout cells for components without them. For more information see “Using the Layout Manager”.
You can draw in the schematic layout window using the Draw tools to build substrate outlines, draw DC pads for biasing,
or to add other details to the layout. In this mode, the layout is not part of a schematic element and therefore does not
move as part of the snapping process.
Modifying Layout Attributes and Drawing Properties
To modify layout attributes and drawing properties, and to create new layout cells for elements without default cells,
click the Layout tab to open the Layout Manager.
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Using the Layout Manager
The Layer Setup node in the Layout Manager defines layout attributes such as drawing properties (for example, line color
or layer pattern), 3D properties such as thickness, and layer mappings. To modify layer attributes, double-click the node
(named "default.lpf" in the previous figure) below the Layer Setup node. You can also import a layer process file (LPF)
to define these attributes by right-clicking Layer Setup and choosing Import Process Definition.
The Cell Libraries node in the Layout Manager allows you to create artwork cells for elements that do not have default
layout cells. The powerful Cell Editor includes such features as Boolean operations for subtracting and uniting shapes,
coordinate entry, array copy, arbitrary rotation, grouping, and alignment tools. You can also import artwork cell libraries
such as GDSII or DXF into the AWR Design Environment platform by right-clicking the Cell Libraries node and choosing
Import Cell Library.
After creating or importing cell libraries, you can browse through the libraries and select the desired layout cells to
include in your layout. Click the + and - symbols to expand and contract the cell libraries, and click the desired library.
The available layout cells display in the lower window pane.
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After you define a cell library, you can assign cells to schematic elements. You can also use a cell directly in a schematic
layout by clicking and dragging the cell into an open schematic layout window, releasing the mouse button, positioning
it, and clicking to place it.
To export a schematic layout to GDSII, DXF, or Gerber formats, click the layout window to make it active, and choose
Layout > Export Layout. To export a layout cell from the cell libraries, select the cell node in the Layout Manager, right-click
and choose Export Layout Cell.

Creating Output Graphs and Measurements
You can view the results of your circuit and system simulations in various graphical forms. Before you perform a
simulation, you can create a graph, specifying the data or measurements (for example, gain, noise or scattering coefficients)
that you want to plot.
To create a graph, right-click Graphs in the Project Browser and choose New Graph to display a dialog box in which to
specify a graph name and graph type. An empty graph displays in the workspace and the graph name displays under
Graphs in the Project Browser. The following graph types are available:
Graph Type

Description

Rectangular

Displays the measurement on an x-y axis, usually over frequency.
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Graph Type

Description

Rectangular - Real/Imag

Displays real versus imaginary components of complex data on a
rectangular graph.

Smith Chart

Displays passive impedance or admittances in a reflection coefficient
chart of unit radius.

Polar

Displays the magnitude and angle of the measurement.

Histogram

Displays the measurement as a histogram.

Antenna Plot

Displays the sweep dimension of the measurement as the angle and
the data dimension of the measurement as the magnitude.

Tabular

Displays the measurement in columns of numbers, usually against
frequency.

Constellation

Displays the in-phase (real) versus the quadrature (imaginary)
component of a complex signal.

3D Plot

Displays the measurement in a 3D graph.

To specify the data that you want to plot, right-click the new graph name in the Project Browser and choose Add
Measurement. An Add Measurement dialog box similar to the following displays to allow you to choose from a
comprehensive list of measurements.

Setting Simulation Frequency and Performing Simulations
To set the Microwave Office simulation frequency, double-click the Project Options node in the Project Browser, or
choose Options > Project Options and then specify frequency values on the Frequencies tab in the Project Options dialog
box. By default, all the schematics use this frequency for simulation. You can overwrite this frequency with an individual
schematic frequency by right-clicking the schematic name under Circuit Schematics in the Project Browser and choosing
Options. Click the Frequencies tab, clear the Use project defaults check box and then specify frequency values.
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To set VSS system simulation frequency, double-click the System Diagrams node in the Project Browser or choose Options
> Default System Options, and then specify frequency values on the Basic tab in the System Simulator Options dialog box.

To run a simulation on the active project, choose Simulate > Analyze. The simulation runs automatically on the entire
project, using the appropriate simulator (for example, linear simulator, harmonic balance nonlinear simulator, or 3D-planar
EM simulator) for the different documents of the project.
When the simulation is complete, you can view the measurement output on the graphs and easily tune and/or optimize
as needed.
You can perform limited simulations by right-clicking the Graphs node or its subnodes to simulate only the graphs that
are open, only a specific graph, or simulate for just one measurement on a graph.
Tuning and Optimizing Simulations
The real-time tuner lets you see the effect on the simulation as you tune. The optimizer lets you see circuit parameter
values and variables change in real-time as it works to meet the optimization goals that you specified. These features are
shown in detail in the linear simulator chapter.
You can also click the Tune Tool button on the toolbar. Select the parameters you want to tune and then click the Tune
button to tune the values. As you tune or optimize, the schematics and associated layouts are automatically updated!
When you re-run the simulation, only the modified portions of the project are recalculated.

Using Command Shortcuts
The use of keyboard command shortcuts (or hotkeys) can greatly increase efficiency within the AWR Design Environment
platform. Default menu command shortcuts are available for many common actions such as simulation, optimization,
and navigating between the Project Browser, Elements Browser and Layout Manager. Default shortcuts display on menus
or by choosing Tools > Hotkeys to display the Customize dialog box where you can also create custom hotkeys.

Getting Started Guide 2–19

Using Scripts and Wizards

Using Scripts and Wizards
Scripts and wizards allow you to automate and extend AWR Design Environment platform functions through customization.
These features are implemented via the Microwave Office API, a COM automation-compliant server that can be
programmed in any non-proprietary language such as C, Visual Basic™, or Java.
Scripts are Visual Basic programs that you can write to do things such as automate schematic-building tasks within the
AWR Design Environment platform software. To access scripts, choose Tools > Scripting Editor or any of the options on
the Scripts menu.
Wizards are Dynamic Link Library (DLL) files that you can author to create add-on tools for the AWR Design Environment
platform; for example, a filter synthesis tool or load pull tool. Wizards display under the Wizards node in the Project
Browser.

Using Online Help
Online Help provides information on the windows, menu choices, and dialog boxes in the AWR Design Environment
platform, as well as for design concepts.
To access online Help, choose Help from the main menu bar or press the F1 key anytime during design creation. The
Help topic that displays is context sensitive-- it depends on the active window and/or type of object selected. The following
are examples:
• Active window = graph, Help topic = "Working with Graphs".
• Active window = schematic (with nothing selected), Help topic = "Schematics and System Diagrams in the Project
Browser".
• Active window = schematic (with an element selected), Help topic = the Help page for that element.
• Active window = schematic (with an equation selected), Help topic = "Equation Syntax".
• Active window = schematic layout (with nothing selected), Help topic = "Layout Editing".
Context sensitive Help is also available by:
• clicking the Help button in most dialog boxes
• right-clicking a model or system block in the Elements Browser and choosing Element Help, or selecting an element
in a schematic or a system block in a system diagram and pressing F1, or clicking the Element Help button in the Element
Options dialog box.
• clicking the Meas Help button in the Add/Modify Measurement dialog box
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Chapter 3. Microwave Office: Importing Data Files
This chapter includes an example that demonstrates how to import a Touchstone format data file and use it in simulations.
The basic procedures in this example include:
• Importing an S-parameter file
• Making measurements directly on a data file
• Adding a data file to a schematic
• Assigning a symbol to the data file
• Setting up a circuit for analysis
NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the Cadence AWR Design Environment® platform. Choose Help > Quick Reference to access this document.

Importing an S-parameter Data File
In this example you import a Touchstone data file. You can also import other file formats using this procedure.

Creating a New Project
The example you create in this chapter is available in its complete form as datafile.emp. To access this file from a list
of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box, then
Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box. You
can use this example file as a reference.
To create a project:
1. Choose File > New Project.
2. Choose File > Save Project As. The Save As dialog box displays.
3. Navigate to the directory in which you want to save the project, type "datafile" as the project name, and then click
Save.

Importing Data Files
To import a data file:
1. Right-click Data Files in the Project Browser and choose Import Data File.
2. In the dialog box that displays, browse to the C:\Program Files\AWR\AWRDE\22.1\Examples\ or C:\Program Files
(x86)\AWR\AWRDE\22.1\Examples\ directory. Select Touchstone Files as the file type, select the N73068a.s2p file,
and then click Open. The data file is added under the Data Files node in the Project Browser as shown in the following
figure.
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Plotting a Data File Directly
1. Choose Project > Add Graph or click the Add New Graph button on the toolbar. The New Graph dialog box displays.
2. Type "S21 Data File" as the graph name, select Rectangular as the graph type, and click Create.
3. Right-click the "S21 Data File" graph in the Project Browser, and choose Add Measurement. The Add Measurement
dialog box displays. You can also click the Add New Measurement button on the toolbar or right-click inside the graph
window and choose Add New Measurement. Add the measurement as shown in the following figure.
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4. Choose Simulate > Analyze. The simulation response as shown in the following figure displays.
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5. Right-click the "S21 Data File" graph in the Project Browser, and choose Duplicate as > Smith. A new Smith Chart
named "S21 Data File 1" displays in the Project Browser.
6. Right-click "S21 Data File 1" in the Project Browser and choose Rename. In the Rename Graph dialog box enter "S11
Smith" as the new graph name and then click OK.
7. Double-click the measurement under the "S11 Smith" Chart in the Project Browser to display the Modify Measurement
dialog box. Change To Port Index to "1" and click OK.
8. Choose Simulate > Analyze. The simulation response as shown in the following figure displays.
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9. Choose Window > Tile Vertical to tile the workspace windows.
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Adding a Data File to the Schematic
Creating a Schematic
To create a schematic:
1. Choose Project > Add Schematic > New Schematic. The New Schematic dialog box displays.
2. Type "Amp" as the schematic name and then click Create.

Placing a Data File in a Schematic
To place a data file in a schematic:
1. Choose Draw > Add Subcircuit. The Add Subcircuit Element dialog box displays. Select the data file listed, select
Explicit ground node, and then click OK.

Note that if you don't select Explicit ground node the data file shows two pins. You can expose the ground node by
right-clicking the subcircuit in the schematic and choosing Properties > Ground.
2. Click inside the schematic window to place the data file as a subcircuit. Note the port names "G" and "D" instead of
"1" and "2". The names are defined in the data file header. Double-click the "N76038a" data file in the Project Browser
to view or edit it.
SUBCKT
ID=S1
NET="N76038a"
G

D
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3. Choose Draw > Add Port or click the Port button on the toolbar.
4. Add a port on the G pin side of the SUBCKT, as shown in the following figure. A dashed wire line displays from the
port pin to the G pin when the port aligns to the pin.

5.

Shift-click

to place the port. The port is automatically wired to the G pin as shown.

6. Add another port on the other side of the SUBCKT block as shown in the following figure. Before placing the port,
right-click twice to rotate the port 180-degrees, then click to place the PORT element.
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7. Place the cursor over the pin of the PORT element. The cursor displays as a wire coil symbol as shown in the following
figure.

8. Click, then drag the wire to pin D of the SUBCKT and click to place it. Complete the wiring of the circuit as shown
in the following figure.
9. Choose Draw > Add Ground or click the Ground button on the toolbar. Add a ground as shown in the following figure.
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Specifying the Simulation Frequency
To specify the simulation frequency:
1. Choose Options > Project Options or double-click the Project Options node in the Project Browser.
2. Click the Frequencies tab.
3. Type "2" in Start, "10" in Stop, and "0.1" in Step, and then click Apply. The frequency range and steps you specified
display in Current Range.
4. Click OK.
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Simulating a Schematic with a Data File
1. Right-click the "S21 Data File" graph in the Project Browser and choose Add Measurement, or click the Add New
Measurement button on the toolbar. The Add Measurement dialog box displays. Add the measurement as shown in
the following figure.

2. Choose Simulate > Analyze. The simulation response as shown in the following figure displays. Notice that the simulation
result from the schematic looks coarse and doesn't match that of the direct data file measurement.
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3. Choose Options > Project Options.
4. Click the Interpolation/Passivity tab and select Polar as the Coordinate System, then click OK.

5. Choose Simulate > Analyze. The simulation response shown in the following figure displays. Notice the change in
trace from the schematic simulation.
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Renormalizing the Data File to a Different Impedance
To renormalize the data to different impedance:
1. In the AMP schematic, double-click the PORT1 Z parameter value to activate edit mode, as shown in the following
figure.

2. Type "25" as the Z parameter value for PORT1 and PORT2.
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3. Choose Simulate > Analyze and view the results in the graph.
4. Save and close the project.
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Chapter 4. Microwave Office: Using the Linear Simulator
Linear simulators use nodal analysis to simulate the characteristics of a circuit. Linear simulations are used for circuits
such as low noise amplifiers, filters, and couplers whose elements can be characterized by an admittance matrix. Linear
simulators typically generate measurements such as gain, stability, noise figure, reflection coefficient, noise circles, and
gain circles.

Linear Simulations in Microwave Office
The Cadence® Microwave Office® software linear simulator architecture uses object-oriented techniques to enable fast
and efficient simulations of linear circuits. One of its trademark features is a real-time tuner, allowing you to see resulting
simulations from modifying circuit or component parameters in real-time, in addition to performing optimization and
yield analysis.
The following example illustrates some of the key features of the Microwave Office linear simulator.

Creating a Lumped Element Filter
This example demonstrates how to use Microwave Office software to simulate a basic lumped element filter using the
linear simulator. It includes the following steps:
• Creating a schematic
• Adding graphs and measurements
• Adding auto-search graph markers
• Analyzing the circuit
• Tuning the circuit
• Creating variables
• Optimizing the circuit
NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the Cadence AWR Design Environment® platform. Choose Help > Quick Reference to access this document.

Creating a New Project
The example you create in this chapter is available in its complete form as linear_example.emp. To access this file from
a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box,
then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box.
You can use this example file as a reference.
To create a project:
1. Choose File > New Project.
2. Choose File > Save Project As. The Save As dialog box displays.
3. Navigate to the directory in which you want to save the project, type "linear_example" as the project name, and then
click Save.
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Setting Default Project Units
Before creating a schematic you should set the default project units. The method for setting units depends on the license
features you use.
Setting Default Project Units With Layout
To set default project units with the Layout license feature:
1. Choose Options > Drawing Layers. The LPF Options dialog box displays.
2. Under the General folder in the left pane, click Units. Verify that your settings match those in the following figure.
You can choose units by clicking in the Multiplier column.

3. Click OK. (If a warning message displays, click OK).
Setting Default Project Units Without Layout
To set default project units without the Layout license feature:
1. Choose Options > Project Options. The Project Options dialog box displays.
2. Click the Global Units tab and verify that your settings match those in the following figure. You can choose units by
clicking the arrows to the right of the display boxes.
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3. Click OK. (If a warning message displays, click OK).

Creating a Schematic
To create a schematic:
1. Choose Project > Add Schematic > New Schematic. The New Schematic dialog box displays.
2. Type "lpf", and click Create. A schematic window displays in the workspace and the schematic displays under Circuit
Schematics in the Project Browser.
Placing Elements in a Schematic
Use the scroll arrows along the right and bottom of the schematic window to view different portions of the schematic as
you work, or to view the entire schematic choose View > View All.
To place elements on a schematic:
1. Click the Elements tab to display the Element Browser. The Elements Browser replaces the Project Browser window.
2. If necessary, click the + symbol to the left of the Circuit Elements node to expand the elements tree.
3. Under Circuit Elements, expand the Lumped Element category , then click the Inductor group. Select the IND model
from the bottom window and drag it to the schematic as shown in the following figure.
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In the Elements Browser, you can change the display of the models in the lower window by right-clicking on the
window and selecting a model display option. One useful mode is the Details option.
4. Add three more IND elements, aligning and connecting each inductor as shown in the following figure.
NOTE: You can also connect elements by moving them to snap their nodes together. When they are properly connected
a small colored square (green by default) displays at the connection point and the connection wire extends if you move
either element. If you do not see the colored square, try to drag one of the elements into place again.
IND
ID=L1
L=1 nH

IND
ID=L2
L=1 nH

IND
ID=L3
L=1 nH

IND
ID=L4
L=1 nH

5. Under the Lumped Element category, click the Capacitor group , then select the CAP model and place it on the schematic
as shown in the following figure. Right-click once before placing the capacitor to rotate it as shown.
6. Add two more CAP elements, aligning and linking each capacitor as shown in the following figure.
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Connecting the Wires
To connect the bottom nodes of the three capacitor elements together:
1. Place the cursor over the bottom node of CAP C1. The cursor displays as a wire coil symbol as shown in the following
figure.
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CAP
ID=C3
C=1 pF

2. Click, then drag the wire past the bottom node of CAP C2, then onto the bottom node of CAP C3, and click to place
the wire.
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Placing Ports on a Node
To place a port on a node:
1. Choose Draw > Add Port or click the Port button on the toolbar.
2. Move the cursor onto the schematic, position the port on the first inductor node as shown in the following figure, then
click to place it.
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Z=50 Ohm
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3. Add another port to the right-most inductor, but right-click two times to rotate the port 180-degrees before you place
it.
Placing Ground on a Node
To place ground on a node:
1. Choose Draw > Add Ground.
2. Move the cursor onto the schematic, position the ground on the bottom node of CAP C1 as shown in the following
figure, and click to place it.
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Tip: When adding/moving/pasting an element in a schematic, an inference line displays when nodes between elements
align. Press the Shift key when placing an inference-aligned element to automatically add the connecting wire.
Editing Element Parameters
To edit the element parameters:
1. Double-click the IND L1 element. The Element Options dialog box displays.
2. Set the L parameter Value to "15" and click OK. The change is reflected in the schematic.
3. Repeat Steps 1 and 2 to edit the inductor and capacitor values to match those in the following figure. (To edit capacitor
values, set the C parameter value as shown.)
PORT
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NOTE: Alternatively you can double-click the parameter value directly on the schematic to edit the value in-place.
Specifying the Simulation Frequency
To specify the simulation frequency:
1. Click the Project tab.
2. Double-click Project Options. The Project Options dialog box displays.
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3. Click the Frequencies tab.
4. Change the Data Entry Units to MHz.
5. Type "100" in Start, " 1000" in Stop, and " 10" in Step, and then click Apply. The frequency range and steps you
specified display in Current Range.
6. Click OK.

Creating a Graph
To create a graph:
1. Right-click Graphs in the Project Browser and choose New Graph. You can also click the Add New Graph button on
the toolbar. The New Graph dialog box displays.
2. Type "s21 and s11" as the graph name, select Rectangular as the graph type, and click Create. The graph displays in
a window in the workspace and displays as a subgroup of Graphs in the Project Browser.
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Adding a Measurement
To add measurements to the graph:
1. Right-click the "s21 and s11" graph in the Project Browser, and choose Add Measurement. The Add Measurement
dialog box displays. You can also click the Add New Measurement button on the toolbar or right-click inside the graph
window and choose Add New Measurement.
2. Select Linear > Port Parameters as the Measurement Type and S as the Measurement. Click the arrow to the right of Data
Source Name and select lpf. Click the arrows to the right of To Port Index and From Port Index and select 1 for each.
Select Mag. as the Complex Modifier, select the dB check box under Result Type, and then click OK.
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3. Right-click the measurement legend in the graph and choose Duplicate Measurement.
4. Change the value in To Port Index to "2", and click OK to add a second measurement.
5. Click OK. The measurements lpf:DB(|S(1,1)|) and lpf:DB(|S(2,1)|) display under the "s21 and s11" graph in the Project
Browser.
NOTE: When adding more than one measurement to a graph, click Add instead of OK after each measurement. The Add
New Measurement dialog box remains open until you add the last measurement and click Close.

Analyzing the Circuit
To analyze the circuit choose Simulate > Analyze. The simulation response shown in the following figure displays on the
graph. You can also click the Analyze button on the toolbar to simulate the active project.
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Adding Auto-Search Markers
To add auto-search markers:
1. Right-click the graph and choose Add Auto-Search Marker to display the Add Auto-Search Marker dialog box.
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2. Under Search Type select Max, then click OK to close the dialog box.
3. Click anywhere on the DB(|S(2,1)|) trace to add marker "m1" at the maximum of the trace.
4. Right-click the graph and choose Add Offset Marker to display the Add Offset Marker dialog box.

5. Set m1 as the Reference Marker, type "-3" for the y offset, and then click OK. Marker m2 is added to the DB(|S(2,1)|)
trace where the y-axis value is 3 dB down from the y-axis value of marker m1.
6. Right-click on marker "m2" and choose Add Note. The cursor changes.
7. Click on the graph and drag to form a rectangle, then release the mouse button when the desired note shape is formed.

8. Type "3dB Cutoff" in the note you created.
NOTE: To match the color of the marker and the trace, right-click inside the graph window and choose Options to display
the Plot Options dialog box. Click the Markers tab and select Match text color to trace.
The following figure shows the graph with the added auto-search markers. The auto-search markers track with changes
to the trace values. Marker "m1" shifts with the trace maximum and marker "m2" shifts with the point on the trace that
is 3dB down from marker "m1".

Getting Started Guide 4–11

Analyzing the Circuit

s21 and s11
0

DB(|S(1,1)|)
lpf

m1: Maximum
240 MHz
-0.0003675dB

-10

DB(|S(2,1)|)
lpf
-20
m2: Offset (m1)
576.21 MHz
-3 dB

-30

3dB Cutoff

-40

-50
100

300

500
700
Frequency (MHz)

900

1000

Tuning the Circuit
When you place the Tune tool over a schematic element, the cursor displays as a cross icon to indicate that the parameter
is tunable.
To tune the circuit:
1. Right-click the measurement legend and choose View Source Document to activate the schematic window.
2. Click the Tune Tool button on the toolbar or choose Simulate > Tune Tool.
3. Move the cursor over the L parameter of IND L1. The cursor displays as a cross as shown in the following figure.

4. Click to activate the L parameter for tuning. The parameter displays in an alternate color.
5. Click an empty space inside the schematic or click the Tune Tool button on the toolbar to deactivate the tuner.
6. Choose View > Variable Browser to open the Variable Browser, then click the Independent tab at the bottom of the
window to only display independent variables.
7. Click the Element column header to sort by element types, then enable the remaining variables for tuning by selecting
the Tune check box for the IND L4 element and the C parameters of the CAP C1 and CAP C3 elements.
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8. Add a tag to the L parameter for inductor elements L1 and L4 by typing "L" in the Tag column for each parameter.
Also add a "C" tag for the C parameter for capacitors C1 and C3.
NOTE: To open the document that contains the element (with the view zoomed to the element), click on an element
in the Element column .

9. Click the graph window to make it active.
10. Choose Simulate > Tune. The Tuner displays. You can also click the Tune button on the menu.
11. Click a tuning bar and hold down the mouse button while sliding the bar up and down. Note the simulation change
on the graph as the variables are tuned. Also note that markers "m1" and "m2" track with simulation changes.
12. Click in the Tag column on the Tuner and type "L" to filter the choices for tuning down to the inductors. While this
is a simple example, it can be useful to tag variables that affect certain performance characteristics of the circuit such
as S11, or power added efficiency (PAE).

13. Delete the "L" in the Tuner Tag column header to see all of the variables enabled for tuning.
14. Slide the tuners to the values shown in the following figure, and observe the resulting response on the graph of the
tuned circuit. Note that the order of elements in the Tuner may differ from that shown. Click Simulate > Analyze.
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15. Click the X at the top right of the Tuner to close it.

Creating Variables
Filters are typically symmetric circuits. To optimize the circuit while maintaining symmetry, you must change some of
the parameter values to variables.
To create variables:
1. Click the schematic window to make it active.
2. Choose Draw > Add Equation or click the Equation button on the toolbar.
3. Move the cursor into the schematic to display an edit box.
4. Position the edit box near the top of the schematic window and click to place it.
5. Type "IND=15" (without the quotes) in the edit box, and then click outside of the box.
6. Repeat Steps 2 through 5 to create a second edit box, but type "CAP=8" (without the quotes).
7. Double-click the L parameter value of IND L1. An edit box displays. Type the value "IND" and then click outside
of the edit box.
8. Repeat Step 7 to change the L parameter value of IND L4 to "IND", and the C parameter values of CAP C1 and CAP
C3 to "CAP", as shown in the following figure.
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To enable the IND and CAP variables for optimization:
1. Choose View > Variable Browser. The Variable Browser dialog box displays.
2. Locate the IND and CAP variables in the Parameter column.
3. In the Optimize column, click the boxes in the IND, CAP, and CAP C2 rows.
To add constraints to the variables:
1. In the Constrained column, click the boxes in the IND, CAP, and CAP C2 rows.
2. In the Value column for each of these variables, type "25%" to set the upper and lower constraints to the variable's
current value plus or minus twenty-five percent, then click the X at the top right of the dialog box to close it. Note
that the order of elements displayed may differ from that in the following figure.

NOTE: Click the All tab at the bottom of the Variable Browser window to display all variables and equations, including
dependent variables. Undo and Redo options are available on both the Independent and All tabs, while search and
replace capabilities are only available on the All tab.
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Adding Optimization Goals
When you create an optimization goal, its value is specified in the units of the parameter or measurement used to create
the goal.
To add optimization goals:
1. In the Project Browser, right-click Optimizer Goals and choose Add Optimizer Goal. The New Optimization Goal dialog
box displays.
2. Select lpf:DB(|S(1,1)) as the Measurement. Select Meas < Goal as the Goal Type, deselect Max under Range and type "500"
as the Stop value, type "-17" as return loss Goal in dB, and then click OK.

3. Repeat Step 1, then select lpf:DB(|S(2,1)) as the Measurement, select Meas > Goal as the Goal Type, deselect
Range , type "500" as the Stop value, type "-1" as the attenuation Goal in dB, and then click OK.

Max under

4. Repeat Step 1, then select lpf:DB(|S(2,1)) as the Measurement, select Meas < Goal as the Goal Type, deselect Min under
Range, type "700" as the Start value, type "-30" as the Goal in dB, and then click OK.
NOTE To add optimization goals directly in a graph, right-click on a measurement in the legend and choose Add
Optimization Goal, then draw a line in the graph that represents the goal value, slope, and start and stop range.

Optimizing the Circuit
To view the optimization in progress, ensure that the graph window is visible before performing these steps.
1. Choose Simulate > Optimize. The Optimizer dialog box displays.
2. Under Optimization Methods select Random (Local) from the drop-down list, type "5000" in Maximum Iterations, and
then click Start. The optimization runs.
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3. When the optimization is complete, click the X box to exit the Optimizer dialog box. The optimized response in the
following schematic and graph should display. Note that your IND and CAP values may vary slightly.
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4. Save and close the project.
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Chapter 5. Microwave Office: Creating Layouts from Schematics
Layouts are views of the physical representations of a schematic. Layout is a critical part of high-frequency circuit design
and simulation, since the response of a circuit is dependent on the geometric shapes with which it is composed.

Layouts in Microwave Office
The Cadence® Microwave Office® software layout capability, architected using advanced object-oriented programming
techniques, is tightly integrated with its schematic and EM structure design capabilities. The Layout View is another
view of the schematic, so any modifications you make to a schematic are simultaneously updated in its corresponding
layout. This eliminates the need for complicated design synchronization and back annotation before you perform your
simulations.
The following example demonstrates basic layout features. Microwave Office software offers many advanced features
that allow you to generate complex layouts such as MMIC circuits and various types of multi-layer boards. For more
advanced layout topics, see the AWR Microwave Office Layout Guide.

Layout Tips and Tricks
The following keyboard shortcuts are helpful as you use Microwave Office's layout capability.
Keystrokes

Layout Function

Press the + key

Zoom in

Press the - key

Zoom out

Press the Home key

Full view

Press the Ctrl key, select a shape, move the mouse

Snap to corners, edges, and centers of circles

Select a shape, hold down the mouse button, press the Tab Move shape with coordinate entry
key or Space bar
Press Ctrl + Shift while clicking on layered shapes

Cycle through layered shapes/elements and select them
individually

NOTE: The Quick Reference document lists additional keyboard shortcuts, mouse operations, and tips and tricks to
optimize your use of the Cadence AWR Design Environment® platform. Choose Help > Quick Reference to access this
document.
AWR Design Environment platform software supports a two-click entry mode for defining a draw or view window. In
this mode, you click once to start a window, then click a second time to define the window size, rather than clicking and
dragging the mouse to define the window. To enable this mode, choose Options > Environment Options and click the
Mouse tab, then select Two click as the Entry mode.

Creating a Layout from a Schematic
This example demonstrates how to use Microwave Office software to create a layout from a schematic. It includes the
following main steps:
• Importing a Layer Process File (LPF)
• Editing Database Units and Default Grid Size
• Importing a cell library
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• Importing and placing a data file in a schematic
• Changing an element symbol
• Placing microstrip lines for layout
• Assigning an artwork cell to a schematic element
• Viewing a layout
• Anchoring a layout cell
• Creating an artwork cell
• Manipulating the MTRACE2 element in layout
• Snapping functions in layout
• Exporting a layout

Creating a New Project
The example you create in this chapter is available in its complete form as layout_example.emp. To access this file from
a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box,
then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box.
You can use this example file as a reference.
To create a project:
1. Choose File > New Project.
2. Choose File > Save Project As. The Save As dialog box displays.
3. Navigate to the directory in which you want to save the project, type "layout_example" as the project name, and then
click Save.

Importing a Layer Process File
A Layer Process File (LPF) defines the default settings for the Layout View, including drawing layers, layer mappings,
3D views, and EM layer mappings.
To import an LPF:
1. Click the Layout tab to display the Layout Manager.
2. Right-click Layer Setup in the Layout Manager, and choose Import Process Definition. The Import Process Definition
dialog box displays.
3. Locate the program directory (C:\Program Files\AWR\AWRDE\22.1 or C:\Program Files (x86)\AWR\AWRDE\22.1
is the default installation directory) and double-click it to open it. If you changed the default installation directory,
then locate that directory instead when the program directory is referenced.
4. Select the MIC_english.lpf file and click Open. Click Replace when prompted to replace the default lpf file. This step
ensures that your project uses the same project units and drawing layers as this example.
The following figure shows an example Layout Manager.
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Editing Database Units and Default Grid Size
A database unit is defined as the smallest unit of precision for a layout. It is very important that this parameter is not
changed after it is set. Changing database units can cause rounding errors that may lead to problems in the layout file.
The grid size is important because many IC designs must reside on a grid. The grid must be greater than or equal to the
database unit. Because the grid multiplier's smallest unit is .1x, you should set the grid to 10 times the database unit to
prevent having a smaller grid than database unit.
To set snap options and the database unit and grid size:
1. Choose Options > Layout Options. The Layout Options dialog box displays.
2. Click the Layout tab, and in Snap together, select Auto snap on parameter changes, then click OK.

3. Choose Options > Drawing Layers. The LPF Options dialog box displays.
4. Under the General folder in the left pane, click Grids. In the Spacing column, type "0.01" for Database Size and "0.1"
for Grid Spacing, then click OK.
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For multi-technology projects, since the database unit and grid size are set specific to an individual LPF (specified
by choosing Options > Layout Options, on the Layout Options dialog box Layout tab in the Grid Options section),
schematics have database unit and grid size settings consistent with those of their assigned LPF.

Importing a GDSII Cell Library
Cell libraries are used in Microwave Office software to provide both the physical packages and footprints for printed
circuit board or hybrid design processes, as well as the standard artwork cells used in MMIC and RFIC design processes.
Microwave Office software supports the GDSII file format as the native drawing tool format.
To import a GDSII cell library:
1. Right-click Cell Libraries in the Layout Manager and choose Import Cell Library.
2. Browse to the C:\Program Files\AWR\AWRDE\22.1\Examples\ or C:\Program Files (x86)\AWR\AWRDE\22.1\Examples
directory and double-click it to open it.
3. Select the packages.gds file and click Open. The imported cell library displays in the Layout Manager. If a warning
message displays, click OK.
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Importing a Data File
To import a data file:
1. In the Project Browser, right-click Data Files and choose Import Data File. The Browse for File dialog box displays.
2. Browse to the C:\Program Files\AWR\AWRDE\22.1\Examples\ or C:\Program Files (x86)\AWR\AWRDE\22.1\Examples
directory and double-click it to open it.
3. Select the N76038a.s2p file and then click Open.

Placing a Data File in a Schematic and Adding a Ground Node
To place a data file in a schematic and add a ground node:
1. Right-click Circuit Schematics in the Project Browser, choose New Schematic, and create a schematic named "qs
layout", then click Create.
2. Choose Draw > Add Subcircuit, or click the SUB button on the toolbar to add a subcircuit. The Add Subcircuit Element
dialog box displays as shown in the following figure.
3. Select N76038a from the list and select Explicit ground node as the Grounding type.

4. Click OK to place it in the schematic window.
SUBCKT
ID=S1
NET="N76038a"
G

D

3
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Changing the Element Symbol
You can change the subcircuit symbol to represent a FET so that you can see which nodes correspond to the gate, drain,
and source.
To change the element symbol:
1. Double-click the subcircuit element in the schematic window. The Element Options dialog box displays.
2. Click the Symbol tab.
3. Select FET@system.syf in the list box, and then click OK.

D
SUBCKT
ID=S1
NET="N76038a"

G

3

Placing Microstrip Elements for Layout
Microstrip elements have default layout cells associated with each element. The layout cells are parameterized and
dynamically sized to the values specified for each parameter.
Microwave Office software has specialized microstrip elements called iCells (intelligent cells) that do not require any
parameter values for the dimensions of the element. iCells automatically inherit the necessary parameters from the
connecting element.
To place microstrip elements:
1. In the Elements Browser, expand the Microstrip category, then click the Lines group. Select the MLIN model and place
it onto node 1 of the N7068a subcircuit in the schematic window. Change its parameters as shown in the following
figure.
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L=100 mil
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2. In the Microstrip category, click the Junctions group. Select the MTEE$ model and place it in the schematic window
connected to the MLIN element as shown in the following figure.
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3
3
NOTE: Elements with names ending in "$" inherit their attributes from the ports to which they connect. Elements
with names ending in "X" are created from a lookup table of EM-generated models. Thus, the name "MTEEX$" is a
microstrip tee junction based on an EM model lookup table that inherits its widths from the ports to which it connects.
3. In the Microstrip category, click the Lines group. Select the MTRACE2 model and place it in the schematic window
onto node 1 of the MTEE$ element.
4. Select the MLEF model in the same group and drag it into the schematic window. Right-click three times to rotate
the element, then position it onto node 3 of the MTEE$ element.
5. Double-click the MTRACE2 element in the schematic window to display the Element Options dialog box.
6. On the Parameters tab, edit the MTRACE2 parameters to match those shown in the following figure, then click OK.
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7. Repeat steps 5 and 6 for the MLEF element to match its parameters to those shown in the previous figure.
8. Click the Substrates category, then select the MSUB model and place it on the schematic window as shown in the
following figure.
9. Double-click the MSUB element in the schematic window to display the Element Options dialog box. On the Parameters
tab, edit the MSUB parameters to match those shown in the following figure, then click OK.
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NOTE: To synthesize physical parameters such as width and length for transmission line elements such as an MLIN,
right-click the element in a schematic and choose Synthesize to open the Transmission Line Calculator. The substrate
parameters in the Transmission Line Calculator automatically populate with values from the referenced MSUB.
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10. Choose Draw > Add Port, or click the Port button on the toolbar, move the cursor onto the schematic, position the port
on the left node of the MTRACE2 element as shown in the following figure, and click again to place it.
11. Add another port to node 2 of the SUBCKT element. Right-click three times to rotate the port, position it, and click
again to place it.
12. To complete the schematic, click the Ground button on the toolbar, move the cursor into the schematic, position the
ground on node 3 of the SUBCKT element, and click again to place it.
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Assigning an Artwork Cell to a Schematic Element
Artwork cells that represent a package layout can be assigned to a schematic element.
To assign an artwork cell:
1. Double-click the "N76038a" subcircuit element in the schematic window to display the Element Options dialog box.
2. Click the Layout tab.
3. Select packages as Library Name and Alpha_212_3 in the cell list at the right of the dialog box, then click OK.
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Viewing a Layout
The schematic and layout are different views of the same database. Edits made to the parameters in the schematic are
instantly updated in the layout, and edits made in the layout are instantly updated in the schematic.
To view a layout:
1. Click the schematic window to make it active.
2. Choose View > View Layout or click the View Layout button on the toolbar to view a layout representation. The layout
displays in a layout window.
NOTE: To maximize work area you can "float" a tiled layout window by right-clicking its title bar and choosing Floating.
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Snapping Layout
1. Choose Edit > Select All to select all of the layout cells.
2. Choose Edit > Snap Objects > Snap Together to snap all of the layout cells faces together at once.

Running the Connectivity Checker
To run the Connectivity Checker:
1. If your layout displays differently, click and drag the "Alpha_212_3" cell in the layout window until it is positioned
as shown in the following figure. To rotate the cell, select it and then right-click and choose Rotate. When the cursor
displays as a 90-degree arc, hold down the mouse button and move the cursor clockwise in 45-degree increments until
the cell is properly oriented.

2. Choose Verify > Highlight Connectivity Rules. In the Connectivity Highlight Rules dialog box, select the rules and
options shown in the following figure, then click OK.

Getting Started Guide 5–11

Creating a Layout from a Schematic

3. Choose Verify > Run Connectivity Check. An LVS errors window opens and lists any violations. If you select a violation,
the corresponding elements are highlighted in both the schematic and layout windows, as shown in the following
figure.
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4. Choose Verify > Clear LVS Errors.
5. Choose Edit > Select All to select all of the layout cells.
6. Choose Edit > Snap Objects > Snap Together to snap the layout cells again.
7. Choose Verify > Run Connectivity Check. Notice that there are no errors listed in the LVS errors window.

Anchoring a Layout Cell
Layout cells have various properties that determine the connectivity of each cell in the Layout View. One of the important
properties is anchoring. Anchoring a layout cell holds the cell in place so that it cannot be moved by snapping functions.
An anchored layout cell is typically used to define a reference point for the layout.
To anchor a layout cell:
1. In the layout window, select the "Alpha_212_3" artwork cell. Right-click and choose Shape Properties to display the
Cell Options dialog box. You may have all the layout shapes selected from previous operations, so make sure to
deselect all the element first.
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2. Click the Layout tab, select the Use for anchor check box, and click OK. The artwork cell now has an anchor symbol
as shown in the following figure.

Creating an Artwork Cell
Choose Options > Environment Options and on the Mouse tab, verify that Two click is selected as the Entry mode.
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To create an artwork cell:
1. Click the Layout tab to open the Layout Manager.
2. Right-click packages under Cell Libraries and choose New Layout Cell. The Create New Layout Cell dialog box displays.
3. Name the cell "chip cap" and click OK. A drawing window displays in the workspace.
4. Click the Grid Spacing button on the toolbar and set it to 10x. (Ensure that the Schematic Layout toolbar is displayed
by right-clicking on the toolbar and selecting Schematic Layout.)

5. Click chip cap under packages in the upper Layout Manager window, and then click the Copper box in the Actv column
of the Drawing Layer pane to enable Copper as the active layer, as shown in the following figure. (Do not select any
check boxes, as it changes other drawing layer properties.)
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Click this box to
enable Copper as
the active layer

6. Choose Draw > Rectangle.
7. Move the cursor into the drawing window and then press the Tab key or Space bar to display the Enter Coordinates
dialog box.
8. Type the values "0" and "10" in x and y, respectively, and click OK.

NOTE: Coordinate entry allows you to type in coordinate values; you can also click and drag to draw shapes.
9. Press the Tab key or Space bar again to display the Enter Coordinates dialog box.
10. Type the values "10" and "-10" in dx and dy, respectively, and click OK. (Rel is automatically selected.) The following
figure shows the resulting drawing. (You may need to adjust your view by choosing View > Zoom In or View > Zoom
Out.)

11. Click the Footprint box in the left column of the lower pane of the Layout Manager to enable Footprint as the active
layer.
12. Click the "chip cap" window to make it active.
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13. Choose Draw > Rectangle.
14. Move the cursor into the "chip cap" window, then press the Tab key or Space bar to display the Enter Coordinates
dialog box.
15. Type the values "10" and "10" in x and y, respectively, and click OK.
16. Press the Tab key or Space bar again to display the Enter Coordinates dialog box.
17. Type the values "20" and "-10" in dx and dy, respectively, and click OK. Click to complete the shape, as shown in the
following figure.

18. Click the copper square in the "chip cap" window, and press Ctrl + C then Ctrl + V to copy and paste it. Slide the mouse
to position the copied square along the right edge of the rectangle as shown in the following figure, and click to place
it.

Add Ports to an Artwork Cell
Ports in the Artwork Cell Editor define the faces to which other layout cells connect. The orientation of the port arrow
determines the direction of connection to the adjacent layout cell.
To add ports to an artwork cell:
1. Choose Draw > Cell Port.
2. Move the cursor into the "chip cap" window. To use gravity points for positioning and aligning shapes in the layout,
press and hold the Ctrl key while you move the cursor over the bottom left vertex of the square until a diamond symbol
displays on the vertex. Click to start a line that represents the cell port while continuing to press the Ctrl key.
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3. With the Ctrl key still pressed, move the cursor to the top vertex, until another square displays on that vertex. Click
again to end the line that represents the cell port.

4. An arrow displays to indicate the direction in which the cell port connects to other ports.

5. To successfully run the Connectivity Checker, you must correctly set the port properties of the artwork cell. Select
cell port 1, then right-click and choose Shape Properties.
6. In the Properties dialog box, click the Layout tab and in Model Layers select 1_0->Copper, then click OK.
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7. Repeat these steps to place a port on the opposite side of the drawing, starting at the top vertex and drawing down.

8. Click the X at the top right of the "chip cap" window and click Yes when prompted to save the cell edits.

Editing the Schematic and Assigning a Chip Cap Cell
To edit the schematic and assign a chip cap cell:
1. Click PORT 1 in the schematic window.
2. Press and hold the Ctrl key while you drag the port away from the MTRACE2 element, as shown in the following
figure.
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3. In the Elements Browser, expand the Lumped Element category, then click the Capacitor group. Select the CAP model,
and place it in the schematic window between PORT 1 and the MTRACE2 element.
4. Double-click the CAP C1 element in the schematic window. The Element Options dialog box displays.
5. Click the Layout tab.
6. Select packages as Library Name then select "chip cap" from the list of cells, then click OK.

7. Choose View > View Layout. The new layout displays in the workspace. Choose Edit > Select All, and then Edit > Snap
Objects > Snap Together to snap the layout together. The layout and corresponding schematic are shown in the following
figures.
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Routing the MTRACE2 Element in Layout
The MTRACE2 element is a special element that you can edit in the Layout View to route a microstrip line.
To route the MTRACE2 element:
1. Double-click the MTRACE2 element in the Layout View to activate the blue grab diamonds.
2. Move the cursor over the right-most diamond until a double arrow symbol displays as shown and double-click it to
activate the routing tool.
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3. Move the routing tool to another point in the direction of MTRACE2 as shown, and click to place. (Right-click to
delete the last point; press the Esc key to cancel the activity). If you move the routing tool in the opposite direction
of MTRACE2 then the final route will be flipped.

4. Continue to route points by moving the routing tool and clicking to place, then double-click to complete the routing.
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NOTE: MLIN is a straight element with a width you can change in the layout. You can edit the MTRACE2 elements
in the layout to create jogs and bends and chamfered corners. You can edit the MCTRACE element to create jogs and
bends with rounded corners.

Snapping Functions for Layout Cells
Snapping functions connect the faces of artwork cells in various configurations. You can set snapping options from the
Layout Options dialog box.
To specify the snapping options:
1. Choose Options > Layout Options. The Layout Options dialog box displays.
2. On the Layout tab, select Manual snap for selected objects only under Snap Together, then click OK.

To separate the layout cells so the change in snapping options is viewable:
1. Click the MLEF layout cell and drag it to a new position as shown in the following figure.
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2. Repeat step 1 with the MTRACE2 element and the chip cap cell. Position the layout cells as shown in the following
figure.

The red lines indicate that the faces of the layout cells are not snapped together.
To snap a selected set of layout cells together:
1. Hold down the Shift key and select the MLEF, MTRACE2, and MTEE$ layout cells in the layout window. The first
cell selected serves as the anchor.
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2. Choose Edit > Snap Objects > Snap Together, or click the Snap Together button on the toolbar. Note that the chip cap
layout cell and MLIN layout cell are not snapped together.

To snap all of the faces together:
1. Press Ctrl + A to select all of the layout cells.
2. Click the Snap Together button on the toolbar. The layout displays as shown in the following figure.
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The "snap to fit" function finishes the routing of an MTRACE2 layout cell to a specified adjacent layout cell. In this
example, the chip cap layout cell is moved and MTRACE2 re-routes to snap to the chip cap face.
To "snap to fit" MTRACE2 to the chip cap:
1. Position the chip cap artwork cell as shown in the following figure.

2. Select the MTRACE2 layout cell.
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3. Choose Edit > Snap to fit, or click the Snap to Fit button on the toolbar. The MTRACE2 routes to snap to the chip cap
artwork cell as shown in the following figure.

Exporting the Layout
This example exports a DXF file; the AWR Design Environment platform software can also export GDSII and Gerber
files. To export a layout:
1. Choose Options > Drawing Layers to specify the file layers to export. The Drawing Layer Options dialog box displays.
2. Click the File Export Mappings folder.
3. Click DXF in the left pane. In the File Export Mapping table, click the check mark icon to the left of the Write Layer
column header to deselect all of the drawing layers. For the Copper drawing layer, type "Copper" in the File Layer
column and select its check box in the Write Layer column, then click OK.
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4. Choose Layout > Export Layout. The Export Layout dialog box displays.
5. Select DXF (DXF Flat,*.dxf) in Save As Type.
6. Type "CopperLayer" as the Filename, and click Save to export the copper file layer to a DXF file.

7. Save and close the project.
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Chapter 6. Microwave Office: Using the Nonlinear Simulator
Harmonic balance (HB) is an efficient method for the steady-state analysis of nonlinear circuits such as power amplifiers,
mixers, multipliers and oscillators. This chapter presents an overview of HB simulations in Cadence® Microwave Office®
software. For more detailed information, see “Harmonic Balance Analysis ” in AWR Design Environment Simulation
and Analysis Guide.
The Cadence AWR Design Environment® platform includes both the original HB simulator and the Cadence APLAC®
HB simulator. Cadence highly recommends using the APLAC HB simulator, which is replacing the original HB simulator.
The APLAC simulator supports all but a few nonlinear models, so the original HB simulator is still included in the AWR
Design Environment platform. The APLAC simulator continues to improve every release, while the original HB simulator
is no longer being developed. The following exercises use the APLAC Simulator as specified in the Add/Modify
Measurement dialog box.

Harmonic Balance in Microwave Office
Microwave Office software simplifies HB simulation setup. The schematic entry, measurements, and analysis are
accomplished much as they are for a linear simulation. Unlike linear analysis, HB requires the presence of voltage,
current, or power sources. Microwave Office software includes a variety of intuitive source elements and allows you to
specify single- and multi-tone excitations. The HB simulator is automatically invoked when appropriate excitations are
present in the schematic, and corresponding measurements exist.

Single-Tone Analysis
A single-tone HB analysis simulates the circuit at a fundamental frequency, at integer multiples of the fundamental
frequency, and at DC. Single-tone harmonic balance requires the specification of a fundamental frequency (or a frequency
sweep) and the total number of harmonics.

Multi-Tone Analysis
Multi-tone simulations are used to determine the output of a circuit excited by two or more frequencies that cannot be
expressed as integer multiples of one another. Typical examples include the LO and RF signals in a mixer and closely
spaced tones used for intermodulation testing of amplifiers.

Nonlinear Measurements
Microwave Office software offers a large number of post-processing functions for viewing simulation results in both the
frequency and the time domain. Examples include large signal S-parameters, voltages and currents at arbitrary nodes,
intercept points, power spectra and power-added efficiency. Results may be swept over any number of arbitrary parameters.
The following example illustrates some of the key features of the Microwave Office nonlinear simulator.

Creating a Power Amplifier Circuit
This example demonstrates how to use Microwave Office software to simulate a power amplifier circuit using the HB
nonlinear simulator.
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The basic procedures in this example include:
• Using nonlinear models from the element library
• Creating an IV curve measurement
• Biasing the transistor and measuring voltages and currents
• Adding schematic back annotation
• Importing input/output match schematic
• Creating a hierarchical circuit using subcircuits
• Creating a power out versus frequency measurement
• Creating a dynamic load line measurement
• Adding a two-tone excitation port
NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Creating a New Project
The example you create in this chapter is available in its complete form as nonlinear_example.emp. To access this file
from a list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog
box, then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog
box. You can use this example file as a reference.
To create a project:
1. Choose File > New Project.
2. Choose File > Save Project As. The Save As dialog box displays.
3. Navigate to the directory in which you want to save the project, type "nonlinear_example" as the project name, and
then click Save.

Setting Default Project Units
Before creating a schematic you should set the default project units. The method for setting units depends on the license
features you use.
Setting Default Project Units With Layout
To set default project units with the Layout license feature:
1. Choose Options > Drawing Layers. The LPF Options dialog box displays.
2. Under the General folder in the left pane, click Units. Verify that your settings match those in the following figure.
You can choose units by clicking in the Multiplier column.
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3. Click OK. (If a warning message displays, click OK).
Setting Default Project Units Without Layout
To set default project units without the Layout license feature:
1. Choose Options > Project Options. The Project Options dialog box displays.
2. Click the Global Units tab and verify that your settings match those in the following figure. You can choose units by
clicking the arrows to the right of the display boxes.

3. Click OK. (If a warning message displays, click OK).
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Creating a Schematic
To create a schematic:
1. Choose Project > Add Schematic > New Schematic. The New Schematic dialog box displays.
2. Type "IV Curve", and click Create. A schematic window displays in the workspace.
Placing a Nonlinear Model from the Library
To place a nonlinear model:
1. Click the Elements tab to display the Element Browser.
2. Expand the Nonlinear category, then click the BJT group. Select the GBJT model and place it on the schematic.
3. Double-click GBJT in the schematic to display the Element Options dialog box. On the Parameters tab, click the Show
or hide secondary parameters button in the toolbar to display all element parameters. Note that the parameters are set
to default values. You can change the parameters as per devices used in a design. Click OK. In this example you use
a model with its parameters already changed for convenience. In the Project Browser, right-click Circuit Schematics
and choose Import Schematic. The Browse for File dialog box displays.
4. Navigate to the C:\Program Files\AWR\AWRDE\22.1\Examples or C:\Program Files (x86)\AWR\AWRDE\22.1\Examples
directory.
5. Select the nonlinear_start.sch file and click Open to import and open the schematic.

Placing an IV Curve Meter on the Nonlinear Element
To place an IV curve meter:
1. Click the "IV Curve" schematic window to make it active.
2. In the Elements Browser, expand the MeasDevice category, then click the IV group. Select the IVCURVEI model and
place it in the "IV Curve" schematic as shown in the following figure. You can select its parameter block and move
it as shown.
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3. Place the cursor over the Step node of IVCURVEI. The cursor displays as a wire coil symbol. Click, then drag the
cursor to node 1 of the GBJT transistor, and click to place the wire.
4. Repeat step 3 to connect the Swp node of IVCURVEI to node 2 of the GBJT transistor.
5. Choose Draw > Add Ground, or click the Ground button on the toolbar. Move the cursor into the schematic window
and position the ground on node 3 of the GBJT transistor, then click to place it.
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Editing the IV Curve Meter Element
To specify IVCURVEI settings:
1. In the Schematic window, double-click the IVCURVEI element. The Element Options dialog box displays.
2. Edit the parameters to the values shown in the following figure, then click OK.

Getting Started Guide 6–5

Creating a Power Amplifier Circuit
Adding an IV Curve Measurement
To create a graph and add an IV curve measurement:
1. In the Project Browser, right-click Graphs and choose New Graph. The New Graph dialog box displays.
2. Type "IV BJT" as the graph name, select Rectangular as the graph type, and click Create. The graph displays in the
workspace.
3. Right-click the "IV BJT" graph in the Project Browser, and choose Add Measurement. The Add Measurement dialog
box displays.
4. Select Nonlinear > Current in Measurement Type and IVCurve in Measurement. Select APLAC DC as the Simulator, select
IVCurve as the Data Source Name, and click OK.
5. Choose Simulate > Analyze. The simulation response in the following graph displays.
NOTE: You can disable parameter markers by right-clicking the graph and choosing Options. On the Markers tab of
the Rectangular Plot Options dialog box, clear the Param markers enabled and Param markers in legend check boxes.
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6. Click the "IV Curve" schematic window to make it active.
7. Click the GBJT element to select it and press Delete to delete it.
8. Click the "nonlinear_start" schematic window to make it active.
9. Click the GBJT element to select it and press Ctrl+C to copy it.
10. Click the "IV Curve" schematic window to make it active.
11. Press Ctrl+V to copy it to the "IV Curve" schematic. Wire the circuit as shown in the previous example.
12. Choose Simulate > Analyze. The simulation response shown in the following graph displays. Notice the change in the
IV curve graph.
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Creating a Bias Circuit
To create a DC bias circuit:
1. In the Project Browser, right-click the "nonlinear_start" schematic and choose Rename Schematic. In the Rename
Schematic dialog box rename the schematic to "DC Bias", and then click Rename. Make DC Bias the active window.
2. In the Elements Browser, expand the Lumped Element category, then click the Inductor group. Select the IND model
and place it above and to the left of the GBJT transistor as shown in the following figure.
3. Place the cursor on node 1 of the GBJT transistor. The cursor displays as a wire coil symbol. Click, then move the
cursor to the right node of IND, and click once more to place the wire.
4. Double-click the IND model and set the L parameter to "1", then click OK.
5. Under Lumped Element, click the Resistor group. Select the RES model and place it as shown in the following figure
after right-clicking once to rotate the element.
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6. Double-click the RES model and set the R parameter to "0.5", then click OK.
7. Choose Draw > Add Ground, or click the Ground button on the toolbar and position the ground on the bottom of RES
R1 as shown in the previous figure.
8. Repeat step 7, positioning the ground on node 4 of the GBJT transistor as shown in the previous figure.
9. Expand the Sources category, then click the DC group. Select the DCVS model, place it and wire it as shown on the
left in the figure.
10. Click the Ground button on the toolbar and position the ground on the negative terminal of DCVS V1 as shown in the
following figure.
11. Click IND L1 in the Schematic window. Press Ctrl+C, then Ctrl+V to copy and paste the inductor as shown in the
following figure.
12. Connect the new IND element to node 2 of the GBJT model as shown in the following figure.
13. Copy the DCVS model and place the copy on the open node of IND L2 as shown in the following figure.
14. Double-click the DCVS V2 model and set the V parameter to "6", then click OK.
15. Click the Ground button on the toolbar and position the ground on the negative node of DCVS V2 as shown in the
following figure.
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Adding Schematic Back Annotation
To add schematic back annotation to display DC voltage and current measurements:
1. Right-click the "DC Bias" schematic in the Project Browser and choose Add Annotation. The Add Schematic Annotation
dialog box displays.
2. Specify a voltage measurement using the settings in the following figure, then click Apply.
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3. Specify a current measurement using the settings in the following figure, then click OK.

4. Choose Simulate > Analyze. The voltage displays at all nodes and the current displays at each element as shown in the
following figure.
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Adding a Harmonic Balance Port
Before adding a harmonic balance port, you must add DC blocking capacitors to the transistor input and output.
To add DC blocking capacitors:
1. Click the "DC Bias" schematic window in the workspace to make it active.
2. In the Elements Browser, expand the Lumped Element category, then click the Capacitor group. Select the CAP model
and connect it to node 1 of the GBJT transistor as shown in the following figure.
3. Double-click the CAP model and set the C parameter to "100", then click OK.
4. Copy the CAP model (hereinafter referred to as CAP C1) and connect the copy (CAP C2) to node 2 of the GBJT
transistor as shown in the following figure.
You must also add an RF bypass capacitor across the emitter resistor.
To add an RF bypass capacitor:
1. Copy the CAP C1 model and place the copy (CAP C3) to the left of RES R1 after right-clicking once to rotate the
model, as shown in the following figure.
2. Connect the top node of CAP C3 to node 3 of the GBJT transistor.
3. Connect a wire between the bottom node of CAP C3 and ground.
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To add a harmonic balance port:
1. In the Elements Browser, expand the Ports category, then click the Harmonic Balance group. Select the PORT1 model
and connect it to CAP C1 as shown in the following figure.
2. Double-click PORT1 and set the Pwr parameter to "23", then click OK.
3. Choose Draw > Add Port, or click the Port button on the toolbar and add a port to the open node of CAP C2 (output
blocking) after right-clicking twice to rotate the port. This port is considered a termination port.
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Specifying Nonlinear Simulation Frequencies
You can specify simulation frequencies in several ways:
• By defining a global sweep in the project options (choose Options > Project Options then click the Frequencies tab)
• By defining a document sweep, (right-click the schematic node in the Project Browser and choose Options, then click
the Frequencies tab)
• By placing a SWPFRQ component on the schematic (located under Circuit Elements in the Simulation Control category).
You select the frequency sweep used by the simulator in the Add/Modify Measurement dialog box, as shown in “Adding
a Large Signal Reflection Coefficient Measurement”. The following steps define the frequency sweep using a document
sweep, which is the simplest means.
To specify a document frequency sweep:
1. In the Project Browser under Circuit Schematics, right-click "DC Bias" and choose Options. The Options dialog box
displays.
2. Click the Frequencies tab.
3. Clear the Use project defaults check box, select GHz as the Data Entry Units, select Replace, specify the Start, Stop and
Step values shown in the following figure, click Apply to display the values in Current Range, and then click OK.
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Adding a Large Signal Reflection Coefficient Measurement
Microwave Office software makes it easy to compute large-signal network parameters. The following exercise demonstrates
how to compute the large signal reflection coefficient and display it on a Smith Chart.
To create a Smith Chart:
1. In the Project Browser, right-click Graphs and choose New Graph. The New Graph dialog box displays.
2. Type "Input Reflection" as the graph name, select Smith Chart as the graph type, and click Create.
To add a large signal reflection measurement:
1. Right-click "Input Reflection" under Graphs and choose Add Measurement. The Add Measurement dialog box displays.
2. Select Nonlinear > Parameter as the Meas. Type and Gcomp as the Measurement and set the parameters as shown in the
following figure, then click Apply and OK.
Note the frequency sweep control that simplifies control of the simulation frequencies and allows you to select among
the available frequency sweeps. The default setting is the document sweep discussed in “Specifying Nonlinear
Simulation Frequencies”.
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3. Choose Simulate > Analyze. The following simulation response displays on the Smith Chart.
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Importing Input Match and Output Match Schematics
The input and output matching for the amplifier are imported from existing schematics.
To import the input match schematic:
1. In the Project Browser, right-click Circuit Schematics and choose Import Schematic. The Browse For File dialog box
displays.
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2. Navigate to the C:\Program Files\AWR\AWRDE\22.1\Examples or C:\Program Files (x86)\AWR\AWRDE\22.1\Examples
directory.
3. Select the input_match.sch file and click Open to import and open the schematic.
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To import the output match schematic:
1. Right-click Circuit Schematics and choose Import Schematic.
2. Select the output_match.sch file from the previously opened directory and click Open to import and open the schematic.
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Adding Subcircuits to a Schematic
Whenever a schematic is created or imported it automatically becomes a subcircuit. You can use these subcircuits within
other schematics to create circuit hierarchy.
To add the input match subcircuit to the DC Bias schematic:
1. In the Project Browser under Circuit Schematics, double-click "DC Bias" to display the DC Bias schematic.
2. Click PORT1 in the schematic window, then press and hold the Shift key while clicking on CAP C1. Both PORT1
and CAP C1 should be selected (and are now considered one unit).
3.

Ctrl-click

on the selected elements, then drag them to the left of the circuit to break their connection with the circuit,
as shown in the following figure.
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4. In the Elements Browser, click the Subcircuits category, then select the "input match" subcircuit and place it on the
schematic between CAP C1 and node 1 of the GBJT transistor as shown in the following figure.
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5. If the subcircuit nodes do not properly connect with the capacitor and transistor you may need to slightly move the
elements until the proper connections are made.
6. Repeat steps 2 and 3 with PORT2 and CAP C2 as shown in the following figure.

6–18 AWR Design Environment

Creating a Power Amplifier Circuit
IND
ID=L2
L=1 uH
DCVS
ID=V1
V=1 V

IND
ID=L1
L=1 uH

DCVS
ID=V2
V=6 V

295mA

6V
295mA

1 V3.75 mA
3.75 mA

CAP
ID=C2
C=100pF
PORT1
P=1
Z=50Ohm
Pwr=18dBm

SUBCKT
ID=S1
NET="input_
match"

CAP
ID=C1
C=100pF
1

0 mA
V
0 mA

2 C 295mA
2

1 mA
0
V

1
1B
V
3.74 mA

4

S

GBJT
ID=GP1

6V
0 mA

0 mA
V

PORT
P=2
Z=50Ohm

0 mA

3 E
0.149V

CAP
ID=C3
C=100pF

299mA

RES
ID=R1
R=0.5Ohm

0V
0 mA

299mA

7. In the Subcircuits category, select the "output match" subcircuit and connect it to the open node of CAP C2 after
right-clicking twice to invert it, as shown in the following figure.
8. Connect node 2 of the output match subcircuit to node 2 of the GBJT transistor.
9. Double-click the Pwr parameter value of the PORT1 element. An edit box displays over the value. Type "18" to
change the value from 23 to 18 dBm, then click outside the edit box to save the change.
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10. Choose Simulate > Analyze. The simulation response in the following Smith Chart displays with the circuit matched.
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Creating a Pout vs. Frequency Measurement
To create a graph and add a measurement (Pout versus frequency):
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1. In the Project Browser, right-click Graphs and choose New Graph. The New Graph dialog box displays.
2. Type "Pout" as the graph name, select Rectangular as the graph type, and click Create.
3. In the Project Browser, right-click "Pout" and choose Add Measurement. The Add Measurement dialog box displays.
4. Create a measurement using the settings in the following figure, then click OK.

5. Choose Simulate > Analyze. The simulation response in the following graph displays.
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Creating a Dynamic Load Line Measurement
A dynamic load line measurement plots the large signal performance of the circuit superimposed on the IV curve of the
device.
To create a dynamic load line measurement:
1. In the Project Browser, right-click "IV BJT" under Graphs and choose Add Measurement. The Add Measurement
dialog box displays.
2. Create a measurement using the settings in the following figure, then click OK.

To select the Voltage Measure Component and Current Measure Component, click the "..." button to the right of these
options. The Component Browser shown in the following figure displays to allow you to select the desired components.
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3. Choose Simulate > Analyze. The simulation response in the following graph displays.
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Setting up a Two-Tone Simulation
The following exercise involves a two-tone simulation that is swept over power at one frequency point. It requires a new
schematic of the same circuit with a different port configuration. To create the new schematic, you can duplicate the
existing schematic and edit the port configurations.
Copying a Schematic in the Project Browse
To duplicate the DC Bias schematic:
1. Click "DC Bias" under Circuit Schematics in the Project Browser, drag it up to the Circuit Schematics node and release
the mouse button. A duplicate schematic named "DC Bias_1" is created.
2. Right-click the "DC Bias_1" schematic and choose Rename. Rename the schematic to "Two Tone Amp" in the
Rename Schematic dialog box, and then click Rename.
Adding a Two-Tone Harmonic Balance Port
A common measurement used to characterize power amplifiers is a third-order intermodulation product versus swept
power. To make this measurement, two closely-spaced tones must be injected into the input port.
To add a two-tone harmonic balance port:
1. Click the "Two Tone Amp" schematic window in the workspace to make it active. You can press the Home key to
view the entire schematic.
2. Double-click PORT1 in the schematic window. The Element Options dialog box displays.
3. Click the Port tab.
4. Specify the port settings shown in the following figure.
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5. Click the Parameters tab and edit the parameters to the values shown in the following figure, then click OK.

Adding a Third-Order Intermodulation Measurement
To add a third-order intermodulation product measurement:
1. Create a rectangular graph named "IM3".
2. Right-click "IM3" under Graphs and create a measurement using the settings in the following figure, then click OK.

3. Repeat step 2 to plot a fundamental component output power, this time selecting "0" and "1" under Harmonic Index.
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4. Choose Simulate > Analyze. The simulation response in the following graph should display.
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Using Variable Sweeps to Measure IP3 vs Voltage
The output-referred IP3 measurement extrapolates the low-power results, so in this exercise you create another schematic
to avoid multi-dimensional (voltage and power) sweeps.
To create a schematic for the IP3 measurement:
1. Copy the "Two Tone Amp" schematic under Circuit Schematics.
2. Right-click the "Two Tone Amp_1" schematic and rename it "IP3".
To change the port excitation to a fixed power:
1. In the "IP3" schematic, double-click PORT_PS2. In the Element Options dialog box, click the Port tab and clear the
Swept power check box, then click OK. The port name changes to PORT2 P=1.
2. Double-click the Pwr1 and Pwr2 parameters of this port (PORT2 P=1) and change both to "-10".
To define a swept variable:
1. Choose Draw > Add Equation or click the Equation button on the toolbar.
2. Move the cursor into the schematic to display an edit box. Position the box near the top of the schematic window and
click to place it.
3. Type "Vcc=1" in the edit box, and then click outside of the box. A variable named "Vcc" is created.
4. Right-click the "Vcc" variable and choose Setup Sweep.
5. In the Sweep Setup dialog box, type "4", "8", and "0.5" for the Start, Stop, and Step values respectively, as shown in
the following figure.
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6. Click OK and place the SWPVAR block as shown in the following figure.
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7. Double-click the V parameter value of DCVS V2 and change it to "Vcc".
To add a graph and measurement:
1. Add a rectangular graph named "IP3".
2. Create a measurement using the settings in the following figure, then click OK.
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3. Choose Simulate > Analyze to obtain the output-referred IP3 intercept, swept over the bias voltage, as shown in the
following graph.
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Plotting IM3 vs Output Power
To plot the IP3 vs Output Power:
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1. In the Project Browser, double-click the "Two_Tone_Amp" schematic.
2. In the Elements Browser, expand the Simulation Control category. Select the X_SWP model and place it anywhere in
the schematic.
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3. Set the X_SWP block parameters as shown in the following figure.

4. In the Project Browser under the Graphs node, right-click "IM3" and choose Duplicate As > Rectangular. A duplicate
graph named "IM3_1" is created.
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5. In the Project Browser under the Graphs node, right-click "IM3_1" and choose Rename. In the Rename Graph dialog
box, rename the graph to "IM3 vs Output Power" , and then click the Rename button.
6. On the "IM3 vs Output Power" graph, right-click and choose Modify Measurement and the first measurement in the
list.

7. Modify the measurement as shown in the following figure, setting PORT_1 to Use X1 for x-axis.
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8. Repeat step 7 for the other measurement in the "IM3 vs Output Power" graph, setting PORT_1 to Use X1 for x-axis.
9. Choose Simulate > Analyze. The "IM3 vs Output Power" graph displays similar to the following figure. Compare the
x-axis values against the y-axis values in the "IM3" graph.
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IM3 vs Output Power
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10. Save and close the project.
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Chapter 7. Microwave Office: Using the AXIEM EM Simulator
Electromagnetic (EM) simulators use Maxwell's equations to compute the response of a structure from its physical
geometry. EM simulations are ideal because they can simulate highly arbitrary structures and still provide very accurate
results. In addition, EM simulators are not subject to many of the constraints of circuit models because they use fundamental
equations to compute the response. One limitation of EM simulators is that simulation time grows exponentially with
the size of the problem, thus it is important to minimize problem complexity to achieve timely results.

EM Simulation in Microwave Office
EM simulation and circuit simulation are complementary techniques for circuit design, and you can use the two approaches
in combination to solve many design problems. Cadence® Microwave Office® software supports the seamless integration
of many EM simulators via an "EM Socket" software interface. To integrate a third-party simulator with the Cadence
AWR Design Environment® platform, the simulator must support an interface complementary to the "EM Socket"
interface. Since it is not possible to document the unique features of all third-party simulators that integrate with Microwave
Office software, the example presented here centers around using Cadence® AXIEM® 3D planar EM analysis software.
Manipulation of the geometry and simulation settings in the program are very similar for all simulators. Detailed
documentation of the unique functionality supplied by other compatible solvers is available from the individual vendors.
AXIEM is a Method of Moments solver that solves for the currents on conductors that can be embedded in a stackup of
planar dielectric layers. The dielectric layers are of infinite extent in the x-y plane as shown in the following figure. The
dielectric layers are sandwiched between an infinite half-space above and infinite half-space below. The half-space below
the dielectric is typically a conductor or perfect electric conductor (PEC), but it can also be an infinite open boundary if
needed. The half space above the dielectric layers is typically an infinite open boundary which correctly models free-space
radiation, but it can also be a conducting plane.

All conductor shapes in AXIEM simulation must be flat shapes drawn in the x-y plane. Each shape can be extruded
orthogonally in the z direction to give it a finite thickness. There are no restrictions on the thickness of the conductors;
they can be infinitely thin or can have finite thickness. The thickness is allowed to protrude into one or more dielectric
layers as well. There are also no restrictions on the shapes relative to the grid. A typical model built in AXIEM software
contains conductors and vias. Conductors can be of any thickness, and their bottom surface must rest on the top surface
of a dielectric layer and can extend upward (in the positive z-direction) or downward (in the negative z-direction). Vias
however, always protrude downward from the layer on which they are drawn, and they always extend through to the
bottom surface of one or more complete dielectric layers. Since there are no restrictions on the height of conductors, you
can draw vias using thick conductors. You should use actual vias when possible, however, because there are some options
in the mesher that treat a via differently from a thick conductor that spans the same z extent.
AXIEM software uses a mesh defined on the surface of the conductors as the basis for the solution. The effects of the
dielectric layers are modeled using Green's functions, which provides a solution from a much smaller set of unknowns.
The surface currents modeled by AXIEM software include all x, y and z components. There are no restrictions on how
current flows on the surfaces of conductors created in AXIEM software. The ability to model all surface currents accurately
allows accurate analysis of conductor traces of any thickness (even lines with greater thickness than width).
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Creating a Distributed Interdigital Filter
This example demonstrates how to use Microwave Office software to simulate a distributed microstrip interdigital filter
using the EM simulator.
The basic procedures in this example include:
• Creating an EM structure
• Setting up an enclosure
• Creating a layout
• Modeling via holes
• Viewing a structure in 3D
• Defining ports and de-embedding lines
• Configuring structure mesh
• Viewing current density
• Performing Advanced Frequency Sweep (AFS)
• Adding an EM structure into a schematic and simulating
NOTE: The Quick Reference document lists keyboard shortcuts, mouse operations, and tips and tricks to optimize your
use of the AWR Design Environment platform. Choose Help > Quick Reference to access this document.

Creating a New Project
The example you create in this chapter is available in its complete form as EM_example.emp. To access this file from a
list of Getting Started example projects, choose File > Open Example to display the Open Example Project dialog box,
then Ctrl-click the Keywords column header and type "getting_started" in the text box at the bottom of the dialog box.
You can use this example file as a reference.
To create a project:
1. Choose File > New Project.
2. Choose File > Save Project As. The Save As dialog box displays.
3. Navigate to the directory in which you want to save the project, type "EM_example" as the project name, and then
click Save.

Importing a Layer Process File (LPF)
To import a Layer Process File (LPF):
1. Choose Project > Process Library > Import LPF. The Import Process Definition dialog box displays.
2. Navigate to the program directory (C:\Program Files\AWR\AWRDE\22.1 or C:\Program Files (x86)\AWR\AWRDE\22.1
is the default installation directory). If you changed the default installation, then browse to that directory instead.
3. Choose the Blank.lpf file and click Open, then click Replace when prompted to replace the existing LPF.
This step is not required for EM simulation, but ensures that your project is set up with the same project units, grid
spacing, database resolution, and drawing layers as this example. These settings should be set appropriately whenever
you start a new design. Changing the settings after starting the design may affect the design.
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Setting Default Project Units and Grid
To set default project units and grid:
1. Choose Options > Drawing Layers. The LPF Options dialog box displays.
2. Under the General folder in the left pane, click Units.
3. In the right pane click on the Multiplier column for Length and choose mm from the drop-down list.

4. Under the General folder in the left window, click Grids.
5. In the right pane type "0.01" for Database Size and "1" for Grid Spacing in the Spacing column, then click OK.
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Creating an EM Structure
To create an EM structure:
1. Choose Project > Add EM Structure > New EM Structure. The New EM Structure dialog box displays.
2. Type "Interdigital Filter" and select AWR AXIEM - Async from the list of EM simulators available on your computer,
then click Create.

3. An EM structure window displays in the workspace.
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Setting Up the Enclosure
The enclosure defines the material types, the dielectric materials for each of the layers in an EM structure, the minimum
grid units used to specify conductor materials in the structure, and sets the boundary conditions.
To set up the enclosure:
1. In the Project Browser, under EM Structures and "Interdigital Filter", double-click Enclosure. The Element Options ENCLOSURE Properties dialog box displays.
2. Click the Enclosure tab and type "0.2" as the Grid_X value and "0.2" as the Grid_Y value.
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To define the materials:
1. Click the Material Defs tab.
2. Click the Add button for Dielectric Definitions to display the Add Dielectric dialog box. In Preset, choose Alumina from
the drop-down list and set the parameters as shown in the following figure, then click OK.
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3. Click the Add button for Conductor Definitions to display the Add Conductor dialog box. In Presets, choose Gold from
the drop-down list to set the parameters as shown in the following figure, then click OK.
4. Set the Color in the top two sections as shown in the following figure, or your layout colors will differ from the example
colors.

To define the dielectric layers of the enclosure:
1. Click the Dielectric Layers tab.
2. Select 1 in the Layer column. Type "5" in the Thickness column, select Air in the Material Definition column, and type
"1" in the Draw Scale column.
3. Select 2 in the Layer column. Type "0.636" in the Thickness column, select Alumina in the Material Definition column,
and type "4" in the Draw Scale column.
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Sidewall Boundary Conditions
In AXIEM simulation, there are no sidewall boundary conditions. Third-party simulators may make other assumptions
for the sidewall boundary conditions. For details, see the vendor documentation for the solver used. The boundary
conditions for the Top Boundary and Bottom Boundary of the enclosure have defaults, although you can modify these.
Notice that the stackup figure in the Element Options - ENCLOSURE Properties dialog box changes when you select a
different boundary condition. You do not modify the default boundary conditions in this example.
To assign material types for the conductors and vias:
1. Click the Materials tab in the Element Options - ENCLOSURE Properties dialog box.
2. Click the Insert button. In the Name column replace Trace1 with "Gold Line", enter "0.001" as Thickness, select Gold
in the Material Definition column for the 1um thick gold line, and then click OK.
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Adding Conductors to the Layout
You use the Microwave Office EM Layout Editor to draw physical structures for simulation. You can also import
structures directly from the AWR Design Environment platform layout tool, or import structures from AutoCAD DXF
or GDSII. In this example you draw the physical layout of a microstrip interdigital filter using the EM Layout Editor.
To draw the physical layout:
1. Click the Layout tab to display the Layout Manager, which is comprised of expandable sections such as EM Layers
and Layout Objects. To expand or collapse a section, click the symbol on the right end of the section title bar. Expand
the EM Layers section.
2. Select 2 as the EM Layer, Gold Line as the Material, and select Conductor.
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3. Click the top of the Interdigital Filter window to make it active, then choose Draw > Rectangle to add a rectangular
conductor.
4. Move the cursor into the window and press the Tab key or Space bar. The Enter Coordinates dialog box displays for
entering the coordinates at which the rectangle is placed.
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5. Type "0" as the value of x and "7.8" as the value of y, and then click OK.
6. Press the Tab key again to display the Enter Coordinates dialog box. Ensure that the Rel (relative) check box is selected,
type "0.6" as the value of dx, and "0.6" as the value of dy, and then click OK. A rectangular conductor displays in the
EM structure window.
7. Click the View All button on the toolbar (or choose View > View All).
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To draw a second rectangular conductor:
1. Click the Rectangle button on the toolbar.
2. Move the cursor into the Interdigital Filter window and press the Tab key. The Enter Coordinates dialog box displays.
Type "4" as the value of x and "1.4" as the value of y, and then click OK.
3. Press the Tab key again to display the Enter Coordinates dialog box. Type "1.2" as the value of dx and "7.2" as the
value of dy, and then click OK. A second rectangular conductor displays in the EM structure window.
4. Click the View All button on the toolbar (or choose View > View All).
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To move the second rectangular conductor next to the first conductor:
1. Click the second rectangular conductor to select it.
2. Slide the cursor over the selected conductor until the cursor displays as a cross.
3. Click and hold down the mouse button. A dx, dy readout displays in the window, as shown in the following figure.
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4. Drag the cursor until the dx, dy readout displays dx: -3.4 and dy: 1, then release the button to place the rectangle.
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NOTE: You can click the Measure button on the toolbar to measure the dimension of conductors, offsets, or spaces
in an EM structure layout.

Adding Vias
Vias are interconnects between substrate layers. You must add a via to ground from one side of the larger conductor to
the bottom of the enclosure.
To add a via:
1. In the Layout Manager, select Via in the EM Layers section.
2. Select Gold Line as the Material and 1 as the Extent.

3. Choose Draw > Ellipse.
4. Move the cursor into the Interdigital Filter window and press the Tab key. The Enter Coordinates dialog box displays.
Type "0.8" as the value of x and "9.4" as the value of y, and then click OK.
5. Press the Tab key again to display the Enter Coordinates dialog box. Type "0.8" as the value of dx and "-0.8" as the
value of dy, and then click OK. A via displays in the Interdigital Filter window.
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Viewing the Structure in 3D
The EM simulator supports multiple 2D (structure) and 3D views.
To create a 3D view:
1. Choose View > View 3D EM Layout. A window containing the 3D view displays in the workspace.
2. Choose Window > Tile Vertical. The views display side-by-side.
NOTE: To change the view of a 3D structure, right-click in the 3D window and choose Zoom Out, View Area, or View
All.
3. To rotate a 3D structure, click anywhere in the 3D window and hold down the mouse button while you move the
mouse.
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Adding Ports
AXIEM structures can have electrical ports defined at the edge of drawn shapes.
To define an edge port:
1. Click the smaller conductor in the EM structure window.
2. Choose Draw > Add Edge Port.
3. Position the cursor to the left edge of the small conductor until the outline of a square displays, then click to place the
edge port. A box with the number 1 (indicating port 1) and a bold line displays at the left edge of the conductor.
The "A" next to the port number indicates that the port is an auto port. Auto ports automatically set the ground reference
and reference plane distance for the port.
4. Click the View All button on the toolbar (or choose View > View All). Depending on your zoom level, your port may
display differently than pictured.
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Specifying the Simulation Frequencies
To specify the simulation frequencies:
1. In the Project Browser, right-click "Interdigital Filter" under EM Structures and choose Options. The Options dialog
box displays.
2. Click the Frequencies tab.
3. Clear the Use project defaults check box to give local frequency settings precedence over global project frequency
settings.
4. Ensure that GHz displays in Data Entry Units.
NOTE: You can define the simulation frequency globally (by choosing Options > Project Options and clicking the
Frequencies tab), or locally using these steps. It is best to use the local frequency settings for EM structures, as you
typically want to sweep EM structures with fewer frequency points than with linear circuits. Data are obtained at the
project frequencies using interpolation and/or extrapolation.
5. Specify the Start, Stop and Step values as shown in the following figure, then click Apply to display the values in
Current Range.
NOTE: You should include 0 Hz and harmonic frequencies in the frequency list if using the EM structure simulation
results in a nonlinear simulation. Otherwise, simulation results are extrapolated down to DC, and up to the harmonic
frequencies. At 0 Hz, AXIEM simulation utilizes a true DC solver for a robust solution.
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6. Click the AXIEM tab and clear the Enable AFS check box under Advanced Frequency Sweep (AFS) as shown in the
following figure, and then click OK.
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Previewing the Geometry
A preview of the geometry of an EM structure shows the structure after the geometry is simplified by any geometry
simplification rules that it has, and also shows the grounding reference(s) and reference plane distance the auto port is
using.
To preview the geometry:
1. In the Project Browser, under the EM Structures node, right-click "Interdigital Filter" and choose Preview Geometry.
The 2D layout view of the structure preview displays.

2. Double-click the port to display the Properties dialog box. The Type is set to Connect to lower, and the Ref. Plane
Distance is set to "1.27" mm.
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3. Choose View > View 3D EM Layout. A 3D view window displays in the workplace.
4. The reference plane extension and explicit grounding strap are visible.

5. Close the geometry preview by clicking the Close button on the Preview Geometry dialog box.
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Viewing Structure Mesh
Meshing of a structure is very important before simulation. The style of mesh largely affects the simulation time. Loosely
meshed structures take much less time to simulate than tightly meshed structures. Because the results may not be very
different, you should start with the coarsest possible grid and gradually make it finer until the result does not change
significantly. You can view mesh by adding an annotation to the structure; it displays in the 3D View.
To view mesh:
1. In the Project Browser, right-click "Interdigital Filter" under EM Structures and choose Add Annotation. The Add
Annotation dialog box displays.
2. Select EM_MESH from the Measurement list and set the parameters as shown in the following figure, then click OK.
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3. Right-click "Interdigital Filter" in the Project Browser and choose Mesh.
4. Make the 3D view window active. Choose View > View From > Top, or click the Top button on the toolbar for the top
view, and the mesh displays as follows.

5. You can also see the reference plane extension and grounding strap in the meshed structure.

Running the EM Simulator
The EM simulator is very fast for electrically small structures. To find the resonant frequency of the first resonator of
the filter, you can run an EM simulation on the initial layout of the Interdigital Filter EM structure.
To simulate the structure:
1. In the Project Browser, under the EM Structures node, under "Interdigital Filter", double-click Information. A Data Set
Properties dialog box displays similar to the following. The maximum number of unknowns for the EM structure and
other information displays, depending on the selected solver. For more information about the data displayed for
third-party simulators, see the associated vendor documentation.
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2. Click OK to close the dialog box.
3. Choose Simulate > Analyze. A Simulation dialog box displays to indicate the simulation progress. You can monitor
progress in the Output log section of the dialog box. An "Estimated Time to Completion" message provides a good
estimate of time remaining before completion when AFS (Advanced Frequency Sweep) is not enabled. This information
is not available when using AFS, as the number of additional frequencies required for AFS convergence is unknown.
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Displaying Results on a Graph
To determine the resonant frequency, you must plot the return loss of the EM structure.
To measure the resonant frequency on a graph:
1. In the Project Browser, right-click Graphs and choose New Graph. The New Graph dialog box displays.
2. Type "Filter Response" as the graph name and select Rectangular as the graph type, then click Create. The graph
displays in the workspace.
3. Right-click the "Filter Response" graph in the Project Browser, and choose Add Measurement. The Add Measurement
dialog box displays.
4. Create a measurement using the settings in the following figure, then click OK.

5. Choose Simulate > Analyze. The simulation response in the following graph displays. The measurement indicates that
the resonant frequency is at 4 GHz.
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To determine a more precise measurement of the resonant frequency, you must change the frequency range and step size
of the simulation.

Changing Frequency Range and Step Size
To change the simulation frequency range and step size:
1. In the Project Browser, right-click "Interdigital Filter" under EM Structures and choose Options. The Options dialog
box displays.
2. Click the Frequencies tab.
3. Type "3" in Start, type "5" in Stop, and type "0.1" in Step. Select Replace and click the Apply button, then click OK.
4. Choose Simulate > Analyze to re-analyze the circuit. The simulation response in the following graph displays.
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Animating Currents
Viewing the currents of an EM structure can be useful when studying its physical characteristics. Currents are added as
annotations to the EM structure and are displayed in a 3D view. For details on imaging when using an alternate simulator,
see the associated vendor documentation.
To enable current display, right-click "Interdigital Filter" and choose Options to display the Options dialog box. Click
the General tab and select the Currents check box under Save Results in Document, then click OK.
Because you did not request currents in the previous simulation, you cannot plot EM currents from the previously
simulated data set. A new simulation is required to calculate the currents. To resimulate, right-click "Interdigital Filter"
and choose Force Re-simulation, then choose Simulate > Analyze to resimulate.
To animate the currents on the conductors:
1. In the Project Browser, right-click "Interdigital Filter" under EM Structures and choose Add Annotation. The Add EM
Structure Annotation dialog box displays.
2. Select EM_CURRENT from the Measurement list and set the parameters as shown in the following figure, then click
OK.
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3. Click the 3D window of the Interdigital Filter EM structure to make it active.
4. Click the Animate Play button on the EM 3D Layout toolbar to animate the current in the 3D view as shown in the
following figure.
5. Click the Animate Stop button on the toolbar to stop the animation. Click on the structure and move the cursor to rotate
the view.
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Completing the Filter Layout
To complete the following filter you use some advanced editing features in the EM structure window.
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To add a small conductor at the end of the input resonator:
1. Click the Layout tab and select Conductor.
2. Select 2 as the EM Layer, and Gold Line as the Material.
3. Choose Draw > Rectangle, and press the Tab key to display the Enter Coordinates dialog box.
4. Type "0.6" as the x value and "2.4" as the y value, then click OK.
5. Press the Tab key again to display the Enter Coordinates dialog box. Select Rel. Type "-0.4" as the dx value and "0.2"
as the dy value, then click OK. A rectangular conductor displays in the EM structure window.
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To draw the output resonator:
1. Choose Edit > Select All.
2. Choose Edit > Copy, and then choose Edit > Paste. An outline of the input resonator displays.
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3. Move the cursor to the right. Ctrl-right-click once to flip the selected instance.

4. Click the View All button on the toolbar (or choose View > View All).
To move the flipped instance:
1. While still selected, drag the instance until the distance between the two instances equals 5.2 mm.
NOTE: To change the view, right-click and choose Zoom Out, View Area, or View All.
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2. To measure the distance between two points, choose Draw > Measure or click the Meas Tool button on the toolbar, then
click on the first node and slide the cursor to the second point.

To create the middle resonator:
1. Click near the top left corner of the left-most resonator, hold down the mouse button, and drag the cursor down and
to the right so the dashed box encompasses the resonator, then release the mouse button. The large conductor and the
via are selected.

2. Choose Edit > Copy and then

Edit > Paste.

An outline of the copied instance displays.
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3. Move the cursor to the middle of the EM structure window to move the copied instance, then right-click twice to
rotate the instance 180-degrees.
4. With the copied instance still highlighted, move the cursor to place it directly on top of the original input resonator,
then press the Tab key.
5. Clear Rel in the Enter Coordinates dialog box and type "4.4" as the x value and "5" as the y value, then click OK. The
EM Structure displays as follows.

Advanced Frequency Sweep
AXIEM software can perform Advanced Frequency Sweep (AFS), which speeds a simulation by allowing the simulator
to determine the frequencies needed to obtain an accurate response. Note that the currents are not calculated while
performing AFS.
To perform an advanced frequency sweep:
1. In the Project Browser, right-click "Interdigital Filter" under EM Structures and choose Options.
2. Click the Frequencies tab and specify the Start, Stop, and Step values as "3", "5", and "0.01" respectively. Select
Replace and click the Apply button to display the values in Current Range.
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3. Click the AXIEM tab and select the Enable AFS check box under Advanced Frequency Sweep (AFS) as shown in the
following figure, then click OK.

4. Right-click the "Filter Response" graph in the Project Browser and choose Add Measurement. The Add Measurement
dialog box displays.
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5. Create a measurement using the settings in the following figure, then click OK.

6. Choose Simulate > Analyze. The final simulation response on the following graph displays.
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If the EM structure 3D window is open, an error displays relating to using AFS and the current annotation. In the Status
Window, click the Warnings button to view a warning with a link you can click for help, then close this window.
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Adding an EM Structure to a Schematic as a Subcircuit
You can add an EM structure to a schematic in the same way you add a schematic subcircuit. The EM structure added
as a subcircuit has the same number of ports as the structure.
1. Create a new schematic named "Schematic using EM" (choose Project > Add Schematic > New Schematic or click the
Add New Schematic button on the toolbar).
2. Click the SUB button on the toolbar or choose Draw > Add Subcircuit to add a subcircuit. A window displays with the
EM structure name highlighted.
3. Click OK. Drag the subcircuit onto the schematic and click to place it.
4. Click the Port button on the toolbar to add two ports to the subcircuit as shown in the following figure.

SUBCKT
ID=S1
NET="Interdigital Filter"
PORT
P=1
Z=50 Ohm

1

2

PORT
P=2
Z=50 Ohm

5. Right-click "Schematic using EM" under Circuit Schematics in the Project Browser and choose Options to display the
Options dialog box.
6. Click the Frequencies tab and clear the Use project defaults check box.
7. Type "3" in Start, type "5" in Stop, and type "0.01" in Step. Click the Apply button, and then click OK.
8. Add a rectangular graph named "Filter Schematic".
9. With the "Filter Schematic" graph window active, click the Add New Measurement button on the toolbar and create a
measurement using the settings in the following figure, then click the Apply button.
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10. In the Add Measurement dialog box, change To Port Index to 2 and click OK.
11. Click the Analyze button on the toolbar to simulate the schematic and compare the two graphs. The results should
match.
12. Save and close the project.
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